스크립트 관리기란?

관리자는 스크립트 관리기를 이용하여 사이트 서버에 등록된 클라이언트 전체에 공지사항, 환경설정, 파일전송, 파일삭제, 프로그램 삭제등의 일괄적인 명령을 수행할 수 있습니다.

기능상으로 방역서버 관리자 콘솔의 원격명령은 사용자가 현재 PC를 사용중이어야만 명령수행이 가능하지만 스크립트가 등록되면 등록된 기간동안에 연결한 사용자들은 적어도 한번씩 명령을 수행하게 됩니다.

관리자는 스크립트 관리기를 이용하여 서버교체나 클라이언트 환경설정, 불법 소프트웨어 제거, 공지사항등의 실행이 전체 사용자에 반영되는것을 보장받을 수 있습니다.

스크립트 관리기의 기능은 서버에 속한 모든 사용자에게 반영되므로 사용에 주의를 요합니다. 사용법을 충분히 숙지하지 못했을 경우 사용하지 마십시오.


전체보기

현재 편집중인 스크립트 기능의 내용 전체를 보여줍니다.

편집중인 스크립트와 사용중인 스크립트는 다릅니다. 편집중인 스크립트는 일반 파일이 될수도 있지만 사용중인 스크립트는 서버에 등록되어 있어 전체 사용자가 참조하고 실행하는 스크립트입니다.

편집중인 스크립트는 관리명령의 스크립트 적용으로 서버에 등록할 수 있습니다.

각 기능은 항목별로 정리되어 있으며 보기상태에서 편집은 불가능 합니다. 스크립트 기능이 사용중이 아니라면 전체보기에 보여지는 기능 리스트는 없습니다.


공지사항

전체 사용자에게 전달할 메시지가 있을 경우 사용합니다.

사용자는 메시지의 일자와 제목으로 구분하여 이미 받은 메시지이면 더이상 받지 않습니다.


환경설정

전체 클라이언트의 환경을 설정합니다.

스크립트 사용기간중 접속한 클라이언트는 환경설정에 따라 변경된 서버주소나 서버접속주기로 동작합니다.

서버정보 설정

서버주소#1 : 사용자가 연결할 서버주소를 변경합니다.

서버설명#1 : 사용자가 연결할 서버주소#1의 설명입니다.

서버주소#2 : 사용자가 연결할 서버#1이 종료시나 정상동작이 안될경우 연결할 서버를 가르킵니다.

서버설명#2 : 사용자가 연결할 서버주소#2의 설명입니다.

접속주기 : 사용자가 서버에 연결할 접속주기를 설정합니다. 기본값은 7200초(=2시간)입니다.

에이전트 기능 설정

Ping 기능 사용안함 : 사용자의 클라이언트가 서버에 접속하거나 그외 명령 사용시 Ping(네트워크 확인) 기능을 사용할 것인지 안할 것인지 결정합니다. Ping 기능 을 사용하지 않을 경우 서버가 항상 실행중이라면 좀 더 빨리 서비스 받을 수 있습니다.

실시간감시기 보이기 : 윈도우 트레이에 바이로봇 실시간감시기가 보여질것인지 감춰질 것인지 결정합니다. 실시간감시기가 감춰지더라도 기능은 수행중입니다. 윈도우 트레이에 아이콘이 너무 많을 경우 사용합니다.

사용자 등록정보 설정

회사명 : 전체 사용자의 회사명을 일괄적으로 변경할 수 있습니다.


파일변경

전체 사용자에 삭제할 파일이나 이름을 변경할 파일들이 있을경우 사용합니다. 전체 사용자 중 삭제하거나 변경할 파일이 없다면 없는 사용자에 대해서만 수행되지 않고 나머지 사용자에게는 반영됩니다.

삭제할 파일 등록

사용자의 파일 중 삭제할 파일들을 등록합니다. 디렉터리에는 사용자 PC의 디렉터리명을 입력하십시오. 파일명은 존재하는 파일명을 입력하고 추가하십시오.

이름 변경할 파일 등록

사용자의 파일 중 이름을 변경할 파일들을 등록합니다. 디렉터리에는 사용자 PC의 디렉터리명을 입력하십시오. 파일명은 존재하는 파일명을 입력하며 변경명에 변경하고자 하는 파일명을 등록하고 추가하십시오.


파일전송

전체 사용자에 전송할 파일들이 있을경우 사용합니다.

파일 등록

목적지 디렉터리에는 사용자의 PC의 특정 디렉터리를 입력합니다. 사용자의 목적지 디렉터리가 존재하지 않는다면 생성합니다. 전송할 파일명을 디렉터리 포함하여 입력하거나 오른쪽 파일선택 버튼으로 여러파일들을 선택하고 추가합니다.

디렉터리 등록

목적지 디렉터리에는 사용자의 PC의 특정 디렉터리를 입력합니다. 사용자의 목적지 디렉터리가 존재하지 않는다면 생성합니다. 전송할 디렉터리명을 입력하거나 오른쪽 디렉터리선택 버튼으로 전송할 디렉터리를 선택하고 추가합니다.


파일 실행

전체 사용자에 실행할 파일(프로그램)들이 있을경우 사용합니다. 클라이언트 디렉터리에는 실행할 파일이 위치한 디렉터리명을 입력합니다. 실행할 파일명에 파일명을 입력한 후 추가하십시오. 실행할 파일의 순서는 상하이동 버튼으로 결정할 수 있습니다.


프로그램 제거

전체 사용자에 제거할 프로그램들이 있을경우 사용합니다. 프로그램명에 제거할 프로그램명을 정확히 입력하십시오. 여기서 프로그램명이란 윈도우 프로그램 추가/삭제에 등록된 프로그램명을 말합니다. 방역서버 관리자 콘솔을 사용중이라면 관리자 콘솔의 소프트웨어 자산 정보에서 복사해 사용할 수 있습니다. 소프트웨어 자산정보창에서 제거할 프로그램명을 선택한 후 오른쪽 마우스 기능의 항목복사로 복사 하십시오. 이제 스크립트 관리기의 프로그램명에 붙여넣기를 하신 후 추가하면 됩니다.


실행순서

스크립트에 등록된 항목들의 실행 순서를 결정합니다.예를들어 프로그램을 배포하고 설치하려 한다면 파일전송 항목에 설치프로그램을 등록하여 사용자들에 배포하고 파일실행에 해당 디렉터리의 설치 실행파일명을 등록하면 설치됩니다. 이때 실행순서는 파일전송이 먼저이고 파일실행이 이후입니다.

항목 리스트

스크립트에 등록된 항목중 실행순서 리스트에 등록되지 않은 항목들을 보여줍니다. 관리자는 항목 리스트의 항목을 이동버튼으로 추가/삭제 할 수 있습니다.

항목의 실행순서 리스트

전체 사용자는 실행순서에 등록된 항목별로 수행합니다. 예를들어, 불법 프로그램 삭제시 공지사항을 먼저 실행하여 사용자가 읽어볼수 있도록 한 후 프로그램 제거 항목의 실행에 사용자가 응답할 수 있도록 유도합니다.


관리명령

스크립트의 관리상태를 볼수 있으며 스크립트 기능을 생성하거나 파일로 저장 및 읽어올수 있습니다.

스크립트 관리상태

관리자는 관리상태를 통하여 스크립트 기능이 현재 사용중인 상태인지 아닌지 알수 있습니다.

스크립트 관리

편집중인 스크립트와 사용중인 스크립트를 관리합니다. 편집기능은 편집중인 스크립트를 관리하며 스크립트기능은 사용중인 스크립트를 제거하거나 편집중인 스크립트를 적용합니다.

스크립트 작성

편집중인 스크립트가 없다면 새로이 작성할 수 있습니다. 아무것도 없는 상태에서는 기능을 추가할 수 없습니다. 처음 사용시 꼭 작성부터 하셔야 합니다.

파일에서 읽어오기

저장된 스크립트 파일을 읽어와 스크립트를 편집할 수 있습니다.

편집내용 파일로 저장

편집중인 스크립트 기능을 파일로 저장하고 다음 사용시 읽어올 수 있습니다.

스크립트 제거

현재 활성화 되어있는 스크립트 기능을 해제시 사용합니다. 편집중인 스크립트와는 다릅니다.

스크립트 적용

현재 편집중인 스크립트 기능을 적용합니다. 적용된 스크립트는 전체 사용자에게 반영됩니다.


항목적용 자동/수동

스크립트 관리기 하단의 옵션 '추가/편집된 내용은 항목적용으로 반영합니다.'를 선택하면 관리기 화면 하단의 항목적용 버튼을 클릭해야만 변경된 내용이 반영됩니다. 기본값은 미선택이고 항목이동시 자동반영됩니다.