Control de datos ADO

El Control de datos ADO es similar al control intrínseco Data y al Control de datos remotos (RDC). El Control de datos ADO permite crear rápidamente una conexión con una base de datos mediante Objetos de datos ActiveX de Microsoft (ADO).

Comentarios

Es posible crear en tiempo de diseño una conexión al establecer la propiedad ConnectionString con una cadena de conexión válida y, a continuación, la propiedad RecordSource con una instrucción apropiada para el administrador de base de datos. Puede establecer también la propiedad ConnectionString con el nombre de un archivo que defina una conexión; el archivo se genera mediante el cuadro de diálogo Vínculo de datos que aparece cuando hace clic en ConnectionString en la ventana Propiedades y, después, en Generar o en Seleccionar.

Conecte el Control de datos ADO a un control enlazado a datos como DataGrid, DataCombo o DataList; para esto, establezca la propiedad DataSource con el Control de datos ADO.

En tiempo de ejecución, establezca dinámicamente las propiedades ConnectionString y RecordSource para cambiar la base de datos. Opcionalmente, puede establecer la propiedad Recordset directamente con un conjunto de registros abierto previamente.


No se encuentra el tema

No se halló el tema correspondiente. A continuación enumeramos algunas posibles razones y sus soluciones:

  • El archivo (.chm) que contiene el tema de destino no se encuentra en la ubicación esperada.

    Solución: vuelva a ejecutar la instalación de la Biblioteca MSDN.

  • El archivo (.chm) que contiene el tema actual o el de destino no está actualizado y el vínculo ya no es válido.

    Solución: instale la última versión de la Biblioteca MSDN.

  • El CD de la Biblioteca MSDN no está en la unidad de CD-ROM.

    Solución: inserte el CD en la unidad.


Control de datos ADO (Constantes)

Constantes de Appearance

Constante | Valor | Descripción
adFlatBevel | 0 | Biselado plano
ad3Dbevel | 1 | Biselado 3D

Constantes de BOFAction

Constante | Valor | Descripción
adDoMoveFirst | 0 | Se mueve al primer registro.
adStayBOF | 1 | Se mantiene al inicio.

Constantes de CommandType

Constante | Valor | Descripción
adCmdText | 1 | Texto
adCmdTable | 2 | Tabla
adCmdStoredProc | 4 | Procedimiento almacenado
adCmdUnknown | 8 | Desconocido

Constantes de Mode

Constante | Valor | Descripción
adModeUnknown | 0 | Desconocido
adModeRead | 1 | Lectura
adModeWrite | 2 | Escritura
adModeReadWrite | 3 | Lectura y escritura
adModeShareDenyRead | 4 | Deniega la lectura.
adModeShareDenyWrite | 8 | Deniega la escritura.
adModeShareExclusive | 12 | Exclusivo
adModeShareDenyNone | 16 | No deniega ninguna acción.

Constantes de ConnectionString

Constante | Valor | Descripción
adConnectStringTypeUnknown | 0 | Desconocido
adOLEDB | 1 | Cadena de conexión OLEDB.
adOLEDBFile | 2 | Usar un archivo OLEDB.
adODBC | 3 | Usar ODBC.

Constantes de CursorLocation

Constante | Valor | Descripción
adUseServer | 2 | Usar cursores del lado del servidor.
adUseClient | 3 | Usar la biblioteca de cursores por lotes del cliente.

Constantes de CursorType

Constante | Valor | Descripción
adOpenKeyset | 1 | Cursor de tipo Keyset (conjunto de claves)
adOpenDynamic | 2 | Cursor de tipo Dynamic (dinámico)
adOpenStatic | 3 | Cursor de tipo Static (estático)

Nota Los cursores ForwardOnly (desplazamiento sólo hacia delante) no están disponibles para el control de datos ADO.

Constantes de EOFAction

Constante | Valor | Descripción
adDoMoveLast | 0 | Se mueve al último registro.
adStayEOF | 1 | Se mantiene al final de archivo.
adDoAddNew | 2 | Agrega un registro nuevo.

Constantes de EventReason

Constante | Valor | Descripción
adRsnAddNew | 1 | Se debe agregar un nuevo registro.
adRsnDelete | 2 | Se ha eliminado un registro.
adRsnUpdate | 3 | Se ha actualizado un registro.
adRsnUndoUpdate | 4 | Se deshace la actualización.
adRsnUndoAddNew | 5 | Se deshace un registro nuevo.
adRsnUndoDelete | 6 | Se deshace la eliminación.
adRsnRequery | 7 | Se repite la consulta.
adRsnResynch | 8 | Se sincroniza de nuevo.
adRsnClose | 9 | Cierre
adRsnMove | 10 | Desplazamiento

Constantes de EventStatus

Constante | Valor | Descripción
adStatusOK | 1 | Aceptar
adStatusErrorsOccurred | 2 | Se produjeron errores.
adStatusCantDeny | 3 |
adStatusCancel | 4 | Cancelar
adStatusUnwantedEvent | 5 |

Constantes de LockType

Constante | Valor | Descripción
adLockUnspecified | -1 | Tipo de bloqueo no especificado
adLockReadOnly | 1 | Bloqueo de sólo lectura
adLockPessimistic | 2 | Bloqueo pesimista
adLockOptimistic | 3 | Bloqueo optimista
adLockBatchOptimistic | 4 | Bloqueo optimista por lotes

Constantes de Orientation

Constante | Valor | Descripción
adHorizontal | 0 | Orientación horizontal
adVertical | 1 | Orientación vertical


Error (Evento, control de datos ADO)

Ocurre sólo como resultado de un error de acceso a datos que tiene lugar cuando no se está ejecutando código de Visual Basic.

Sintaxis

objeto_Error([Index As Integer,] ByVal ErrorNumber As Long, Description As String, ByVal Scode As Long, ByVal Source As String, ByVal HelpFile As String, ByVal HelpContext As Long, fCancelDisplay As Boolean)

El evento Error consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
Index | Identifica el control si pertenece a una matriz de controles.
ErrorNumber | El número de error nativo.
Descripción | Describe el error.
Scode | El código de error devuelto por el servidor.
Source | El origen del error.
HelpFile | La ruta de acceso a un archivo de Ayuda con información adicional acerca del error.
HelpContext | El número de contexto del tema de Ayuda.
fCancelDisplay | Un valor booleano que puede establecerse para cancelar la presentación del error, como se muestra en Valores.

Valores

Los valores admitidos para fCancelDisplay son:

Constante | Valor | Descripción
False | 0 | Continúa.
True | -1 | (Predeterminado) Muestra el mensaje de error.

Comentarios

El evento Error se producirá cada vez que un error no causado por Visual Basic interrumpe una operación. Los errores pertenecen a dos categorías: los errores generados por ADO y los errores generales (por ejemplo, un error de memoria insuficiente). En los casos en que ADO es el origen del error, el Control de datos ADO puede agregar información de contexto a la cadena que describe el error.


Password (Propiedad, control de datos ADO)

Establece la contraseña utilizada durante la creación de un objeto Recordset de ADO.

Sintaxis

objeto.Password [= cadena]

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
cadena | Establece la contraseña correspondiente al usuario nombrado en la propiedad UserName.

Comentarios

El valor de esta propiedad es de sólo escritura: sólo puede establecerse mediante código y no puede leerse de nuevo a partir de la propiedad Password.


Recordset (Propiedad, control de datos ADO)

Devuelve o establece una referencia al objeto Recordset de ADO subyacente.

Sintaxis

objeto.Recordset [= recordset]

La sintaxis de la propiedad Recordset consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
recordset | Un objeto Recordset.

Comentarios

Si utiliza la propiedad Recordset, puede usar los métodos, propiedades y eventos del objeto ADODB.Recordset de ADO.

Debe usar la instrucción Set con la propiedad Recordset como se muestra a continuación:

Dim rsNwind As New ADODB.Recordset
' Aquí no aparece el código que abre el objeto Recordset de ADO.
Set ADODC1.Recordset = rsNwind

Si piensa programar los eventos del objeto Recordset, declare una variable de objeto mediante la palabra clave WithEvents, como se muestra a continuación.

Option Explicit
Dim WithEvents rsNames As ADODB.Recordset

Private Sub Form_Load()
   Set rsNames = New ADODB.Recordset
   ' No aparece el código que crea el recordset.
   rsNames.MoveFirst ' Se mueve al inicio del conjunto de registros.

   Set ADODC1.Recordset = rsNames

   With Text1
      Set .DataSource = ADODC1
      .DataField = "Nombre"
   End With
End Sub

Private Sub rsNames_FieldChangeComplete(ByVal cFields As Long, _
ByVal Fields As Variant, ByVal pError As ADODB.Error, adStatus As _
ADODB.EventStatusEnum, ByVal pRecordset As ADODB.Recordset)
   Debug.Print "Nuevo nombre", pRecordset!Name
End Sub


RecordSource (Propiedad, control de datos ADO)

Devuelve o establece la instrucción o la consulta con que se obtiene un conjunto de registros.

Sintaxis

objeto.RecordSource [= valor]

La propiedad RecordSource consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
valor | Una expresión de cadena que especifica un origen de registro como se describe en Valores.

Valores

Los valores admitidos para valor son:

Valor | Descripción
Un nombre de tabla | El nombre de una tabla de base de datos.
Una consulta SQL | Una cadena SQL válida que utilice la sintaxis apropiada para el origen de datos.


UserName (Propiedad, control de datos ADO)

Devuelve o establece un valor que representa a un usuario de un objeto Recordset de ADO.

Sintaxis

objeto.UserName [= valor]

La sintaxis de la propiedad UserName consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
valor | Una expresión de cadena que contiene un nombre de usuario como se describe en Valores.

Valores

La sintaxis del nombre de usuario depende del origen de datos.

Comentarios

Cuando se proporcionan valores para UserName y Password, el control los utiliza para crear una cadena de conexión (propiedad ConnectionString).