Animation (Control)

El control Animation le permite crear botones que presenten animaciones, como archivos .avi, cuando se haga clic en ellos. El control sólo puede reproducir archivos AVI que no tengan sonido. Además, el control Animation sólo puede reproducir archivos .avi sin comprimir o archivos .avi comprimidos mediante RLE (Run-Length Encoding).

Comentarios

Si intenta cargar un archivo .avi que incluya sonido o con un formato no compatible con el control, se producirá el error 35752.

Un ejemplo de este control es la barra de progreso de copia de archivos de Windows 95, que utiliza un control Animation. Las hojas de papel "vuelan" de una carpeta a otra mientras se ejecuta la operación de copia.


DateTimePicker (Control)

Utilice el control DateTimePicker para proporcionar un campo de fecha con formato que facilite la selección de la fecha. Además, los usuarios pueden seleccionar una fecha a partir de una interfaz de calendario desplegable similar a la de un control MonthView.

Sintaxis

DTPicker

Comentarios

El control DateTimePicker tiene dos modos de funcionamiento:

  • En el modo Calendario desplegable (predeterminado) se muestra al usuario un calendario desplegable en el que puede seleccionar una fecha.

  • En el modo Formato de hora, el usuario selecciona un campo en el visor de fecha (por ejemplo, el mes, el día, el año, etc.) y establece su valor con la flecha hacia arriba o hacia abajo situada a la derecha del control.

Es posible personalizar la apariencia del calendario desplegable del control. Existen varios atributos de color como CalendarBackColor, CalendarForeColor, CalendarTitleBackColor, CalendarTitleForeColor y CalendarTrailingForeColor que le permiten crear combinaciones de colores exclusivos.

Se puede usar el control con el teclado o con el mouse (ratón) indistintamente. El calendario desplegable posee dos botones que permiten mostrar los meses siguientes y anteriores.

Nota El control DateTimePicker forma parte de un grupo de controles ActiveX incluidos dentro del archivo MSCOMCT2.OCX. Debe agregar el archivo MSCOMCT2.OCX al proyecto para poder usar el control DateTimePicker en su aplicación. Cuando distribuya su aplicación, instale el archivo MSCOMCT2.OCX en el directorio System o System32 de Microsoft Windows. Para obtener más información acerca de cómo agregar un control ActiveX a un proyecto, vea "Agregar controles a un proyecto" en el Manual del programador.


FlatScrollBar (Control)

A diferencia de la barra de desplazamiento estándar de Windows, el control FlatScrollBar es una versión sensible al movimiento del mouse (ratón) que ofrece opciones de formato en dos dimensiones. También puede reemplazar a la barra de desplazamiento estándar en tres dimensiones de Windows. El control FlatScrollBar mejora la interacción con el usuario cuando se utilizan las flechas y el cuadro (o cursor) de desplazamiento.

Sintaxis

FlatScrollBar

Comentarios

El control FlatScrollBar ofrece tres opciones de formato.

  • Una apariencia en dos dimensiones que reproduce la apariencia de la barra de desplazamiento incluida en Internet Explorer 4.0. El cursor y las flechas de desplazamiento son sensibles a los movimientos del mouse; cambian de color cuando el puntero del mouse pasa por encima.

  • De dos dimensiones, pasa a aparentar tres dimensiones para responder al puntero del mouse. Las flechas y el cursor de desplazamiento sobresalen cuando el puntero pasa por encima. Esto reproduce la apariencia de la barra de desplazamiento que se puede ver en la enciclopedia Microsoft Encarta.

  • Una apariencia idéntica a la de la barra de desplazamiento en tres dimensiones de Windows. Los modos en tres dimensiones no disponen de características sensibles al mouse.

Es posible deshabilitar cualquiera de las flechas de desplazamiento con el control FlatScrollBar para proporcionar mayor grado de interacción con el usuario al indicarle que se desplace en un sentido determinado, en función de otros factores dentro del programa.

El control FlatScrollBar permite obtener una barra de desplazamiento horizontal o vertical dependiendo del valor establecido en la propiedad Orientation.

Nota para la distribución El control FlatScrollBar forma parte de un grupo de controles ActiveX que se encuentran en el archivo MSCOMCT2.OCX. Para usar el control FlatScrollBar en su aplicación, debe agregar el archivo MSCOMCT2.OCX al proyecto. Cuando distribuya su aplicación, instale el archivo MSCOMCT2.OCX en el directorio System o System32 de Microsoft Windows. Para más información sobre como agregar un control ActiveX al proyecto, vea "Agregar controles a un proyecto" en el Manual del Programador.


MonthView (Control)

Utilice el control MonthView para crear aplicaciones que permitan a los usuarios mostrar y establecer información de fecha mediante una interfaz parecida a un calendario.

Sintaxis

MonthView

Comentarios

La propiedad Valor del control MonthView devuelve la fecha seleccionada actualmente.

Para permitir a los usuarios del programa seleccionar un intervalo continuo de fechas, asigne a la propiedad MultiSelect el valor True y especifique con MaxSelProperty el número de días que podrán seleccionar. Las propiedades SelStart y SelEnd devuelven las flechas del principio y el final de una selección.

Existen muchas formas de personalizar la apariencia de un control MonthView. Existen varios atributos de colores, como MonthBackColor, TitleBackColor, TitleForeColor y TrailingForeColor, que le permiten crear combinaciones de colores exclusivas para el control.

Establezca las propiedades MonthRows y MonthColumns para mostrar más de un mes a la vez (hasta 12 meses) en un control MonthView. El número total de propiedades MonthRows y MonthColumns debe ser inferior o igual a 12.

Nota El control MonthView forma parte de un grupo de controles ActiveX incluidos dentro del archivo MSCOMCT2.OCX. Es necesario agregar el archivo MSCOMCT2.OCX al proyecto para poder usar el control MonthView en su aplicación. Al distribuir su aplicación, instale el archivo MSCOMCT2.OCX.ocx en el directorio System o System32 de Microsoft Windows. Para obtener más información acerca de cómo agregar un control ActiveX a un proyecto, vea "Agregar controles a un proyecto" en el Manual del programador.


UpDown (Control)

El control UpDown tiene dos botones con flechas en los que el usuario puede hacer clic para incrementar o disminuir un valor, por ejemplo una posición de desplazamiento o el valor de un control asociado, denominado control auxiliar.

Sintaxis

UpDown

Comentarios

Para el usuario, el control UpDown y su control auxiliar parecen a menudo un control único. El control auxiliar puede ser cualquiera de los que pueden vincularse al control UpDown a través de la propiedad BuddyControl y normalmente muestra datos, como un control TextBox o CommandButton.

Nota Los controles ligeros sin ventana, como el control intrínseco de etiqueta, no pueden usarse como un control auxiliar.

Si establece la propiedad AutoBuddy, el control UpDown tomará automáticamente como control auxiliar el control anterior del orden de tabulación. Si no hay ningún control previo en el orden de tabulación, tomará el siguiente. Otra forma de establecer el control auxiliar es con la propiedad BuddyControl. En tiempo de diseño, cuando se establece la propiedad AutoBuddy o la propiedad BuddyControl, puede asociar automáticamente el control auxiliar al control UpDown si ajusta su tamaño y lo coloca junto a él. Puede colocar el control UpDown a la izquierda o a la derecha del control auxiliar mediante la propiedad Alignment.

Las propiedades Increment, Min, Max y Wrap especifican la forma en que cambia la propiedad Value del control UpDown cuando el usuario hace clic en los botones de dicho control. Por ejemplo, si los valores son múltiplos de 10 y van de 20 a 80, puede establecer las propiedades Increment, Min y Max a 10, 20 y 80, respectivamente. La propiedad Wrap permite que la propiedad Value siga incrementándose después de superar el valor de la propiedad Max y que comience de nuevo por el valor de Min o viceversa.

Un control UpDown sin control auxiliar se comporta en cierto modo como una barra de desplazamiento simplificada.

Nota El control UpDown debe usarse en lugar del control SpinButton de Visual Basic 4.0.

Nota para la distribución El control UpDown forma parte de un grupo de controles ActiveX que se encuentran en el archivo MSCOMCT2.OCX. Para usarlo en una aplicación, debe agregar el archivo MSCOMCT2.OCX al proyecto. Al distribuir la aplicación, instale el archivo MSCOMCT2.OCX en el directorio SYSTEM de Microsoft Windows del usuario. Si desea más información acerca de cómo agregar un control personalizado a un proyecto, vea el Manual del programador.


No se encuentra el tema

No se halló el tema correspondiente. A continuación enumeramos algunas posibles razones y sus soluciones:

  • El archivo (.chm) que contiene el tema de destino no se encuentra en la ubicación esperada.

    Solución: vuelva a ejecutar la instalación de la Biblioteca MSDN.

  • El archivo (.chm) que contiene el tema actual o el de destino no está actualizado y el vínculo ya no es válido.

    Solución: instale la última versión de la Biblioteca MSDN.

  • El CD de la Biblioteca MSDN no está en la unidad de CD-ROM.

    Solución: inserte el CD en la unidad.


Constantes de error (ComCtl32)

Constante | Valor | Descripción
cc2InvalidProcedureCall | 5 | Llamada a procedimiento no válida.
cc2BadFileNameOrNumber | &H34 | Nombre o número de archivo incorrecto.
cc2FileNotFound | &H35 | Archivo no encontrado.
cc2InvalidPropertyValue | &H17C | El valor de la propiedad no es válido.
cc2SetNotSupportedAtRuntime | &H17E | No se puede establecer la propiedad en tiempo de ejecución.
cc2SetNotSupported | &H17F | La propiedad es de sólo lectura.
cc2InvalidObjectUse | &H1A9 | Uso no válido del objeto.
cc2WrongClipboardFormat | &H1CD | El formato especificado no coincide con el formato de los datos.
cc2DataObjectLocked | &H2A0 | La lista de formatos de DataObject no se puede borrar o expandir fuera del evento OLEStartDrag.
cc2ExpectedAnArgument | &H2A1 | Se esperaba al menos un argumento.
cc2RecursiveOleDrag | &H2A2 | Llamada recursiva no válida de arrastrar y colocar OLE.
cc2FormatNotByteArray | &H2A3 | Los formatos de arrastrar y colocar OLE no intrínsecos que se usan con SetData necesitan datos en una matriz de Byte. GetData puede devolver más bytes que los proporcionados por SetData.
cc2DataNotSetForFormat | &H2A4 | Los datos solicitados no se han proporcionado al objeto DataObject durante el evento OLESetData.
cc2InconsistentObject | &H8BA6 | El estado interno del control está dañado.
cc2ErrorDuringSet | &H8BA7 | No se puede establecer la propiedad.
cc2ErrorOpeningVideo | &H8BA8 | No se puede abrir el archivo AVI
cc2ErrorPlayingVideo | &H8BA9 | No se puede reproducir el archivo AVI.
cc2NoValidBuddyCtl | &H8BAA | Es necesario establecer primero la propiedad BuddyControl.
cc2VideoNotOpen | &H8BAB | Debe abrir primero el archivo AVI.
cc2AutoBuddyNotSet | &H8BAC | AutoBuddy no está establecida; no se encontraron posibles controles relacionados.
cc2ErrorStoppingVideo | &H8BAD | Error al intentar detener la reproducción del archivo AVI.
cc2ErrorClosingVideo | &H8BAE | Error al cerrar el archivo AVI abierto.
cc2CantStopAutoPlay | &H8BAF | El método Stop no afecta a la propiedad AutoPlay.
cc2BuddyNotASibling | &H8BB0 | BuddyControl debe ser un control independiente dentro del mismo contenedor.
cc2NoUpDownAsBuddy | &H8BB1 | No se puede relacionar un control UpDown con otro control UpDown.


BuddyProperty (Propiedad)

Establece o devuelve la propiedad empleada para sincronizar el control UpDown con su control auxiliar.

Sintaxis

objeto.BuddyProperty [= valor]

La sintaxis de la propiedad BuddyProperty consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
valor | Un valor Variant que especifica una propiedad del control indicado en la propiedad BuddyControl. Si no especifica valor, se utiliza la propiedad predeterminada del control.

Comentarios

Si el valor de la propiedad SyncBuddy es True, el control sincroniza su propiedad Value con la propiedad especificada en la propiedad BuddyProperty.

Puede establecer BuddyProperty en tiempo de diseño si selecciona la propiedad en una lista desplegable de la ventana Propiedades.

Debe establecer la propiedad BuddyControl antes que la propiedad BuddyProperty; de lo contrario se producirá un error.


CallbackKeyDown (Evento)

Ocurre cuando se presiona una tecla mientras el cursor se encuentra dentro de un campo de devolución de llamada.

Sintaxis

Private Sub objeto_CallbackKeyDown([Index As Integer], KeyCode As Integer, Shift As Integer, CallbackField As String, CallbackDate As Date)

La sintaxis del evento CallbackKeyDown consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
Index | Un entero que identifica un control de forma exclusiva cuando éste no se encuentra en una matriz de controles.
KeyCode | Una expresión numérica que especifica el código ASCII de teclado de la tecla presionada.
Shift | Una expresión numérica que especifica el estado de las teclas MAYÚS, CTRL y ALT cuando se produce el evento.
CallbackField | Una expresión de cadena que especifica la subcadena de devolución.
CallbackDate | Una expresión de fecha que especifica el valor de fecha del control.

Comentarios

El evento CallbackKeyDown es una variante del evento KeyDown que permite procesar una subcadena en la devolución de la llamada.

Vea la propiedad CustomFormat para obtener más información acerca del proceso de devolución de llamada.

El evento se produce también cuando el usuario presiona las teclas de dirección hacia arriba o hacia abajo.


Change (Evento, control UpDown)

Este evento se produce cuando se modifica la propiedad Value.

Sintaxis

Private Sub objeto_Change([índice As Integer])

La sintaxis del evento Change consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
índice | Un entero que identifica unívocamente un control si se encuentra en una matriz de controles.

Comentarios

El evento Change se produce siempre que cambia la propiedad Value. El cambio en Value puede hacerse a través del código, con un clic en los botones de flechas o mediante el cambio de valor del control auxiliar cuando la propiedad SyncBuddy está establecida a True.


CloseUp (Evento)

Ocurre cuando se cierra el calendario desplegable.

Sintaxis

Private Sub objeto_CloseUp([Index As Integer])

La sintaxis del evento CloseUp consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
index | Un entero que identifica un control de forma exclusiva cuando éste no se encuentra en una matriz de controles.

Comentarios

Utilice el evento CloseUp para responder al cierre del calendario desplegable por parte del usuario.


DateClick (Evento)

Ocurre cuando se hace clic en una fecha del control.

Sintaxis

Private Sub objeto_DateClick([Index As Integer], DateClicked As Date)

La sintaxis del evento DateClick consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
Index | Un entero que identifica de forma exclusiva un control cuando éste no se encuentra en una matriz de controles.
DateClicked | Una expresión de fecha que especifica la fecha sobre la que el usuario hizo clic.

Comentarios

El evento DateClick permite reaccionar ante un clic del usuario en una fecha concreta. Utilice DateClicked para determinar la fecha en la que el usuario hizo clic.


DateDblClick (Evento)

Ocurre cuando el usuario hace doble clic en una fecha del control.

Sintaxis

Private Sub objeto_DateDblClick([Index As Integer], DateDblClicked As Date)

La sintaxis del evento DateDblClick consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
Index | Un entero que identifica de forma exclusiva un control cuando éste no se encuentra en una matriz de controles.
DateDblClicked | Una expresión de fecha que especifica la fecha en la que el usuario hizo clic.

Comentarios

Utilice el evento DateDblClick para responder al usuario cuando hace doble clic en una fecha concreta. Utilice DateDblClicked para determinar la fecha en la que el usuario hizo doble clic.


DownClick (Evento)

Este evento ocurre cuando se hace clic en el botón de flecha abajo o de flecha a la izquierda.

Sintaxis

Private Sub objeto_DownClick([índice As Integer])

La sintaxis del evento DownClick consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
índice | Un entero que identifica unívocamente un control si se encuentra en una matriz de controles.

Comentarios

El evento DownClick se produce después del evento Change.


Evento DropDown (Evento, control DateTimePicker)

Ocurre cuando el calendario desplegable está a punto de desplegarse.

Sintaxis

Private Sub objeto_DropDown()

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.


Format (Evento, control DateTimePicker)

Ocurre cuando el control solicita el texto para ser mostrado en un campo de devolución de llamada.

Sintaxis

Private Sub objeto_Format([Index As Integer], CallbackField As String, FormattedString As String)

La sintaxis del evento Format consta de las siguientes partes:

Parte | Descripción
Objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
Index | Un entero que identifica un control de forma exclusiva cuando éste no se encuentra en una matriz de controles.
CallbackField | Una expresión de cadena que especifica la subcadena de devolución.
FormattedStringField | Una expresión de cadena que especifica la cadena con formato mostrada.

Comentarios

El evento Format sirve para establecer el texto mostrado en un campo de devolución de llamada.

Vea la propiedad CustomFormat para obtener más información acerca del proceso de devolución de llamada.


CustomFormat (Propiedad), Format y FormatSize (Eventos), Ejemplo de evento

En el ejemplo se muestra la fecha actual con el nombre del mes en español entre paréntesis. CallbackField está establecido a "XXXX" en el evento Load mediante la asignación de la propiedad CustomFormat a una cadena que incluye las cuatro "X". El evento FormatSize ocurre antes que el evento Format y es utilizado para determinar el tamaño del campo de devolución de llamada. Se produce entonces el evento Format que devuelve una cadena con formato para reemplazar el texto del campo de devolución de llamada. Para probar este ejemplo, sitúe un control DateTimePicker en un formulario y pegue el código dentro de la sección Declaraciones.

Option Base 1
Private sSpanishMonthLong(12) As String

Private Sub DTPicker1_Format(ByVal CallbackField As String, FormattedString As String)
   If CallbackField = "XXXX" Then
      FormattedString = sSpanishMonthLong(DTPicker1.Month)
   End If
End Sub

Private Sub DTPicker1_FormatSize(ByVal CallbackField As String, Size As Integer)
   Dim iMaxMonthLen As Integer

   If CallbackField = "XXXX" Then
      iMaxMonthLen = 0
      For i = 1 To 12
         If iMaxMonthLen < Len(sSpanishMonthLong(i)) Then
            iMaxMonthLen = Len(sSpanishMonthLong(i))
         End If
      Next
   End If
   Size = iMaxMonthLen
End Sub

Private Sub Form_Load()
   DTPicker1.CustomFormat = "MMMM(XXXX) dd, yyy"
   DTPicker1.Format = dtpCustom

   sSpanishMonthLong(1) = "Enero"
   sSpanishMonthLong(2) = "Febrero"
   sSpanishMonthLong(3) = "Marzo"
   sSpanishMonthLong(4) = "Abril"
   sSpanishMonthLong(5) = "Mayo"
   sSpanishMonthLong(6) = "Junio"
   sSpanishMonthLong(7) = "Julio"
   sSpanishMonthLong(8) = "Agosto"
   sSpanishMonthLong(9) = "Septiembre"
   sSpanishMonthLong(10) = "Octubre"
   sSpanishMonthLong(11) = "Noviembre"
   sSpanishMonthLong(12) = "Diciembre"
End Sub


FormatSize (Evento)

Ocurre después de que cambie la propiedad CustomFormat y antes de que ocurra el evento Format. El evento permite definir la longitud máxima permitida de la cadena con formato de forma que el control puede dibujarse en la pantalla dejando espacio suficiente para la cadena con formato del usuario.

Sintaxis

Private Sub objeto_FormatSize([Index As Integer], CallbackField As String, Size As Long)

La sintaxis del evento FormatSize consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
Index | Un entero que identifica un control de forma exclusiva cuando éste no se encuentra en una matriz de controles.
CallbackField | Una expresión de cadena que especifica la subcadena de devolución.
Size | Un entero largo que especifica la longitud de la cadena que devolverá el evento Format.

Comentarios

El evento FormatSize permite establecer el tamaño del texto mostrado en un campo de devolución de llamada.


GetDayBold (Evento)

Ocurre cuando el control necesita mostrar una fecha, para obtener la información mostrada en negrita.

Sintaxis

Private Sub objeto_GetDayBold([Index As Integer], StartDate As Date, Count As Integer, State( ) As Array)

La sintaxis del evento DateDblClick consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
Index | Un entero que identifica de forma exclusiva cuando éste no se encuentra en una matriz de controles.
StartDate | Una expresión de fecha que especifica la primera fecha mostrada.
Count | Una expresión numérica que especifica el número de días mostrado.
State( ) | Una matriz de valores booleanos que especifican las fechas que utilizan la fuente en negrita.

Comentarios

Utilice el evento GetDayBold para destacar los días mostrados.


Ejemplo de la propiedad GetDayBold

En el código siguiente se muestran todos los viernes en negrita. Para probar el ejemplo, inserte un control MonthView en un formulario y pegue el código en la sección Declaraciones. Ejecute a continuación el proyecto.

Private Sub MonthView1_GetDayBold(ByVal StartDate As Date, ByVal Count As Integer, State() As Boolean)
   ' Suponiendo que la semana comienza en domingo, se establece la variable intBold
   ' (hasta el quinto viernes). Se asigna el valor True
   ' a la propiedad State de todos los viernes.
   Dim intBold As Integer
   intBold = mvwFriday
   While intBold < Count
      State(intBold - 1) = True
      intBold = intBold + 7
   Wend
End Sub


SelChange (Evento, control MonthView)

Ocurre cuando el usuario selecciona una nueva fecha o un nuevo intervalo de fechas.

Sintaxis

Private Sub objeto_SelChange(StartDate As Date, EndDate As Date, Cancel As Boolean)

La sintaxis del evento SelChange consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
StartDate | La primera fecha seleccionada.
EndDate | La última fecha seleccionada
Cancel | Determina si se canceló la selección.


Ejemplo del evento SelChange

En el ejemplo se imprime el intervalo de fechas seleccionadas por el usuario. Para probar el ejemplo, inserte un control MonthView en un formulario y pegue el código dentro de la sección Declaraciones del módulo de programa. Ejecute el proyecto y seleccione varios intervalos de fechas (asigne a la propiedad MultiSelect el valor True).

Private Sub MonthView1_SelChange(ByVal StartDate As Date, ByVal EndDate As Date, Cancel As Boolean)
   Dim d As Date
   d = StartDate
   Debug.Print "Empezando"
   While d <= EndDate
      Debug.Print d
      d = d + 1
   Wend
   Debug.Print "Terminado"
End Sub


UpClick (Evento)

Este evento ocurre cuando se hace clic en el botón de flecha arriba o de flecha a la derecha.

Sintaxis

Private Sub objeto_UpClick([índice As Integer])

La sintaxis del evento UpClick consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
índice | Un entero que identifica unívocamente un control si se encuentra en una matriz de controles.

Comentarios

El evento UpClick se produce después del evento Change.


Errores interceptables de los Windows Common Controls (ComCtl2)

En las tablas siguientes se relacionan los errores interceptables y sus constantes para los Windows Common Controls contenidos en el archivo ComCt232.OCX.

Los errores siguientes corresponden a los controles comunes de Windows del archivo ComCtl32.OCX. Estos controles son UpDown, Calendar y Animation.

Constante | Valor | Descripción
cc2InvalidProcedureCall | 5 | Llamada a procedimiento no válida.
cc2BadFileNameOrNumber | 52 | Nombre o número de archivo incorrecto.
cc2FileNotFound | 53 | Archivo no encontrado.
cc2InvalidPropertyValue | 380 | El valor de la propiedad no es válido.
cc2SetNotSupportedAtRuntime | 382 | La propiedad no se puede establecer en tiempo de ejecución.
cc2SetNotSupported | 383 | La propiedad es de sólo lectura.
cc2InvalidObjectUse | 425 | Uso no válido del objeto.
cc2WrongClipboardFormat | 461 | El formato especificado no coincide con el formato de los datos.
cc2DataObjectLocked | 672 | La lista de formatos de DataObject no se puede borrar o expandir fuera del evento OLEStartDrag.
cc2ExpectedAnArgument | 673 | Se esperaba al menos un argumento.
cc2RecursiveOleDrag | 674 | Llamada recursiva no válida de arrastrar y colocar OLE.
cc2FormatNotByteArray | 675 | Los formatos de arrastrar y colocar OLE no intrínsecos que se usan con SetData necesitan datos en una matriz de Byte. GetData puede devolver más bytes que los proporcionados por SetData.
cc2DataNotSetForFormat | 676 | Los datos solicitados no se han proporcionado al objeto DataObject durante el evento OLESetData.
cc2InconsistentObject | 35750 | El estado interno del control está dañado.
cc2ErrorDuringSet | 35751 | No se puede establecer la propiedad.
cc2ErrorOpeningVideo | 35752 | No se puede abrir el archivo AVI.
cc2ErrorPlayingVideo | 35753 | No se puede reproducir el archivo AVI.
cc2NoValidBuddyCtl | 35754 | Es necesario establecer primero la propiedad BuddyControl.
cc2VideoNotOpen | 35755 | Debe abrir primero el archivo AVI.
cc2AutoBuddyNotSet | 35756 | AutoBuddy no está establecida; no se encontraron posibles controles relacionados.
cc2ErrorStoppingVideo | 35757 | Error al intentar detener la reproducción del archivo AVI.
cc2ErrorClosingVideo | 35758 | Error al cerrar el archivo AVI abierto.
cc2CantStopAutoPlay | 35759 | El método Stop no afecta a la propiedad AutoPlay.
cc2BuddyNotASibling | 35760 | BuddyControl debe ser un control independiente dentro del mismo contenedor.
cc2NoUpDownAsBuddy | 35761 | No se puede relacionar un control UpDown con otro control UpDown.
cc2InvalidRange | 35770 | Se especificó un intervalo de fechas no válido.
cc2InvalidMaxDate | 35771 | Se especificó un intervalo de fechas no válido en la propiedad MaxDate.
cc2InvalidMinDate | 35772 | Se especificó un intervalo de fechas no válido en la propiedad MinDate.
cc2DateOutOfRange | 35773 | Se especificó una fecha que no está en el intervalo indicado por las propiedades MinDate y MaxData.
cc2InvalidMaxDateMin | 35774 | Se especificó un valor para la propiedad MaxDate que es menor que el valor actual de MinDate.
cc2InvalidMinDateMax | 35775 | Se especificó un valor para la propiedad MinDate que es mayor que el valor actual de MaxDate.
cc2InvalidRowColValue | 35776 | Se especificó un valor para MonthRows o MonthColumns que no está entre 1 y 12.
cc2InvalidRowColTotal | 35777 | Se especificó un valor para MonthRows o MonthCols que haría que el número total de meses (MonthRows * MonthCols) fuera mayor que 12.
cc2MonthViewError | 35778 | Error al llamar al control MonthView de Windows.
cc2SetDayMultiSelectOn | 35779 | No se puede establecer la propiedad Day cuando MultiSelect = True.
cc2SetDayOfWeekMultiSelectOn | 35780 | No se puede establecer la propiedad DayOfWeek cuando MultiSelect = True.
cc2SetMonthMultiSelectOn | 35781 | No se puede establecer la propiedad Month cuando MultiSelect = True.
cc2SetWeekMultiSelectOn | 35782 | No se puede establecer la propiedad Week cuando MultiSelect = True.
cc2SetYearMultiSelectOn | 35783 | No se puede establecer la propiedad Year cuando MultiSelect = True.
cc2SetMaxSelCountMultiSelectOff | 35784 | No se puede establecer la propiedad MaxSelCount cuando MultiSelect = False.
cc2SetSelEndMultiSelectOff | 35785 | No se puede establecer la propiedad SelEnd cuando MultiSelect = False.
cc2SetSelStartMultiSelectOff | 35786 | No se puede establecer la propiedad SelStart cuando MultiSelect = False.
cc2NullValueNotAllowed | 35787 | No se puede establecer Value a NULL cuando la propiedad CheckBox = False.
cc2DTPickerError | 35788 | Error al llamar al control de Windows DTPicker.
cc2ScrollValueOutOfRange | 35789 | El valor de desplazamiento está fuera del intervalo.


Close (Método, control Animation)

El método Close hace que el control Animation cierre el archivo AVI abierto actualmente. Si no hay ningún archivo cargado, Close no hace nada y no se genera ningún error.

Sintaxis

objeto.Close

El marcador de posición objeto representa una expresión de objeto que da como resultado un control Animation.

Comentarios

Para terminar la reproducción de un archivo, utilice el método Stop. Sin embargo, si la propiedad AutoPlay tiene el valor True, establezca AutoPlay a False para terminar la reproducción del archivo.


ComputeControlSize (Método)

Devuelve el ancho y el alto de un control MonthView para un número determinado de filas y columnas.

Sintaxis

objeto.ComputeControlSize(Rows, Columns, Width, Height)

La sintaxis del método ComputeControlSize consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
Rows | Especifica un entero que indica el número de filas.
Columns | Especifica un entero que indica el número de columnas.
Width | Devuelve un número de precisión simple que corresponde al ancho del control proyectado.
Height | Devuelve un número de precisión simple que corresponde al alto del control proyectado.

Comentarios

Antes de cambiar el tamaño del control MonthView restableciendo sus propiedades MonthColumns o MonthRows, utilice el método ComputeControlSize para calcular su tamaño y ajuste el tamaño del formulario en consonancia.

Para usar el método ComputeControlSize, declare primero dos variable con tipo Single. A continuación, llame al método pasando como argumentos las variables Width y Height.


Ejemplo del método ComputeControlSize

En el ejemplo se utiliza el método ComputeControlSize para calcular el ancho de un control MonthView después de incrementar su tamaño mediante las propiedades MonthRows y MonthColumns. Para probar el ejemplo, inserte un control MonthView en un formulario y pegue el código dentro de la sección Declaraciones del módulo de programa. Ejecute el proyecto y haga doble clic en el formulario.

Private_Sub Form_Load()
   ' Define las propiedades Top y Left del control.
   With MonthView1
      .Left = 200 ' Se asume que ScaleMode = Twip
      .Top = 400
   End With
End Sub

Private Sub Form_DblClick()
   Dim sWidth As Single
   Dim sHeight As Single

   With MonthView1 ' Calcula el tamaño del control y agrega columnas y filas.
      .ComputeControlSize 3, 4, sWidth, sHeight
      .MonthColumns = 4
      .MonthRows = 3  '
   End With

   ' Cambia el tamaño del control usando los valores devueltos por el método.
   Me.Width = MonthView1.Left + sWidth + 500
   Me.Height = MonthView1.Top + sHeight + 500
End Sub


HitTest (Método, control MonthView)

Devuelve la fecha ubicada en conjunto de coordenadas determinado. Se suele usar en operaciones de arrastrar y colocar para determinar si existe un elemento en la ubicación de destino de la operación.

Sintaxis

objeto.HitTest(x as Single, y As Single, Date As Date)

La sintaxis del método HitTest consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
x, y | Coordenadas de una fecha de destino.
Date | Una expresión de fecha devuelta cuando se realiza una operación sobre una fecha del control con el mouse (ratón).

Valores devueltos

Los valores devueltos por el método HitTest especifican la parte del calendario sobre la que se sitúa el cursor del mouse y son los siguientes:

Constante | Valor | Descripción
mvwCalendarBack | 0 | El color de fondo del calendario.
mvwCalendarDate | 1 | Fecha de calendario.
mvwCalendarDateNext | 2 | Cuando se hace clic en esta área, el calendario muestra el mes siguiente.
mvwCalendarDatePrev | 3 | Cuando se hace clic en esta área, el calendario muestra el mes anterior.
mvwCalendarDay | 4 | Las etiquetas de días encima de las fechas.
mvwCalendarWeekNum | 5 | El número de la semana, si ShowWeekNumbers tiene el valor True.
mvwNoWhere | 6 | Parte inferior del calendario.
mvwTitleBack | 7 | Color de fondo del título del calendario.
mvwTitleBtnNext | 8 | El botón Siguiente en el área de título.
mvwTitleBtnPrev | 9 | El botón Anterior en el área de título.
mvwTitleMonth | 10 | La cadena del mes en el título.
mvwTitleYear | 11 | La cadena del año en el título.
mvwTodayLink | 12 | Cuando se hace clic en esta área, el calendario muestra el mes y día actuales. Sólo está disponible si ShowToday tiene el valor True.

Comentarios

Utilice el método HitTest para determinar el área del calendario sobre la que opera el mouse.

El método HitTest devuelve Null si no existe ninguna fecha en las coordenadas especificadas. Date también es Null si no existe ninguna fecha en las coordenadas.


Ejemplo del método HitTest (Control MonthView)

En este ejemplo se utiliza el método HitTest para mostrar la fecha en un control de etiqueta cada vez que el mouse pasa por encima de ésta. Para probar el ejemplo, inserte controles MonthView y Label en un formulario. Pegue a continuación el código siguiente en la sección Declaraciones.

Private Sub MonthView1_MouseMove(Button As Integer, Shift As Integer, x As Single, y As Single)
   Dim iResult As Integer
   Dim dtMyDate As Date
   iResult = MonthView1.HitTest(x, y, dtMyDate)
   Label1.Caption = dtMyDate
End Sub


Open (Método, control Animation)

Abre un archivo .avi para su reproducción. Si la propiedad AutoPlay tiene el valor True, el clip empezará a reproducirse en cuanto termine de cargarse. Continuará reproduciéndose hasta que se cierre el archivo .avi o hasta que la propiedad AutoPlay se establezca con el valor False.

Sintaxis

objeto.Open archivo

La sintaxis del método Open consta de las siguientes partes:

Parte | Descripción
objeto | Requerido. Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
archivo | Requerido. El nombre del archivo que se va a reproducir.

Comentarios

El control Animation no puede reproducir archivos .avi que incluyan sonido. Además, el control Animation sólo puede reproducir archivos .avi sin comprimir o archivos .avi comprimidos mediante RLE (Run-Length Encoding). Se producirá un error cuando se llame al método Open con un archivo que incluya sonido o que se encuentre comprimido en un formato no compatible.


Ejemplo del método Open (Control Animation)

El siguiente ejemplo abre un archivo .avi mediante el cuadro de diálogo Abrir e inicia su reproducción automáticamente. Para probar este ejemplo, coloque un control Animation y un control CommonDialog en un formulario y pegue el código en la sección Declaraciones del formulario. Ejecute el ejemplo y elija el archivo .avi que va a abrir.

Private Sub Animation1_Click ()
   With CommonDialog1
      .Filter = "avi (*.avi)|*.avi"
      .ShowOpen
   End With
   With Animation1
      .Autoplay = True
      .Open CommonDialog1.Filename
   End With
End Sub


Play (Método)

Reproduce un archivo .avi en el control Animation.

Sintaxis

objeto.Play [= repetir, inicio, final]

La sintaxis del método Play consta de las siguientes partes:

Parte | Descripción
objeto | Requerido. Una expresión de objeto que da como resultado un control Animation.
repetir | Opcional. Un entero que especifica el número de veces que va a reproducirse el clip. El valor predeterminado es -1, que hace que el clip se repita de forma indefinida.
inicio | Opcional. Un entero que especifica la imagen inicial. El valor predeterminado es 0, que inicia el clip desde la primera imagen. El valor máximo es 65535.
final | Opcional. Un entero que especifica la imagen final. El valor predeterminado es -1, que indica la última imagen del clip. El valor máximo es 65535.

Tipo de datos

Integer

Comentarios

Para terminar la reproducción de un archivo .avi, utilice el método Stop.


Stop (Método, control Animation)

Termina la reproducción de un archivo .avi en el control Animation.

Sintaxis

objeto.Stop

El marcador de posición objeto representa una expresión de objeto que da como resultado un control Animation.

Comentarios

El método Stop sólo termina las animaciones iniciadas con el método Play. Si intenta usar el método Stop cuando la propiedad AutoPlay esté asignada con el valor True, se produce el error 35759.


Alignment (Propiedad, control UpDown)

Devuelve o establece un valor que determina la alineación del control UpDown con su control auxiliar.

Sintaxis

objeto.Alignment [= valor]

La sintaxis de la propiedad Alignment consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
valor | Un valor que especifica la alineación del control UpDown con su control auxiliar, como se describe en Valores.

Valores

Los valores válidos para valor son:

Constante | Valor | Descripción
cc2alignmentLeft | 0 | El control UpDown se alinea a la izquierda de su control auxiliar.
cc2alignmentRight | 1 | (Predeterminado). El control UpDown se alinea a la derecha de su control auxiliar.

Comentarios

Puede usar la propiedad Alignment para especificar la colocación del control UpDown junto a su control auxiliar. De forma predeterminada, el control UpDown se coloca a la derecha del control auxiliar.

Si establece la propiedad Alignment se vuelve a alinear automáticamente el control UpDown con su control auxiliar. El ancho del control auxiliar se reduce al ancho del control UpDown, de forma que el ancho total de los dos controles coincide con el que tenía el control auxiliar en solitario.

Nota La propiedad Alignment pasa por alto la propiedad Orientation cuando se alinea con el control UpDown.


Appearance (Propiedad, control FlatScrollBar)

Devuelve o establece la apariencia de un control FlatScrollBar.

Sintaxis

objeto.Appearance [= entero]

La sintaxis de la propiedad Appearance consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
entero | Una expresión numérica que especifica el estilo de la barra de desplazamiento, como se describe en Valores.

Valores

Los valores admitidos para entero son:

Constante | Valor | Descripción
fsb3D | 0 | La barra de desplazamiento se mostrará con las tres dimensiones estándar de una barra de desplazamiento de Windows.
fsbFlat | 1 | (Predeterminado) La barra de desplazamiento se mostrará con dos dimensiones.
fsbTrack3D | 2 | La barra de desplazamiento se mostrará con dos dimensiones, y los botones del cursor y de las flechas adoptarán tres dimensiones cuando el mouse pase por encima.

Comentarios

La propiedad Appearance define la apariencia de la barra de desplazamiento, que puede ser 2D, 3D o una combinación de ambas. La forma combinada cambia de 2 a 3 dimensiones la apariencia del cursor y las flechas de desplazamiento como respuesta al puntero del cursor, y permite crear una interfaz dinámica.


Arrows (Propiedad)

Devuelve o establece un valor que determina qué flechas de desplazamiento estarán habilitadas.

Sintaxis

objeto.Arrows [= entero]

La sintaxis de la propiedad Arrows consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
entero | Una expresión numérica que especifica el botón o los botones de desplazamiento que están habilitados, como se describe en Valores.

Valores

Los valores admitidos para entero son:

Constante | Valor | Descripción
cc2Both | 0 | (Predeterminado) Se habilitarán las flechas de desplazamiento izquierda y derecha (o hacia arriba y abajo, según valor de Orientation).
cc2LeftUp | 1 | Sólo se habilitará el botón de desplazamiento izquierdo (o superior).
cc2RightDown | 2 | Sólo se habilitará el botón de desplazamiento derecho (o inferior).

Comentarios

Cuando la propiedad Orientation del control FlatScrollBar cambia de horizontal a vertical, las flechas de desplazamiento izquierda y derecha corresponden a la flecha hacia arriba y la flecha hacia abajo, respectivamente.

El uso más común de la propiedad Arrows es deshabilitar la flecha de desplazamiento apropiada cuando se alcanza el valor máximo o mínimo del control.


AutoBuddy (Propiedad)

Establece o devuelve un valor que determina si el control UpDown utiliza automáticamente un control como control auxiliar en base a su orden de tabulación.

Sintaxis

objeto.AutoBuddy [= valor]

La sintaxis de la propiedad AutoBuddy consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
valor | Una expresión booleana que determina el control auxiliar, como se describe en Valores.

Valores

Los valores válidos para valor son:

Valor | Descripción
True | El control UpDown utiliza como control auxiliar el anterior en el orden de tabulación. Si no hay ningún control con un índice de tabulación inferior que pueda usar como control auxiliar, el control UpDown usará el primero que haya disponible con un índice de tabulación superior.
False | (Predeterminado) El control UpDown utiliza el valor indicado en la propiedad BuddyControl como su control auxiliar.

Comentarios

Si establece AutoBuddy a True, también se establece la propiedad BuddyControl. Si establece AutoBuddy a False, se borra el valor de BuddyControl.


AutoPlay (Propiedad)

Devuelve o establece un valor que determina si el control Animation empezará a reproducir un archivo .avi cuando éste se cargue en el control.

Sintaxis

objeto.AutoPlay [= booleano]

La sintaxis de la propiedad AutoPlay consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un control Animation.
booleano | Una expresión booleana que especifica si la propiedad AutoPlay está activada.

Valores

Los valores admitidos para booleano son:

Valor | Descripción
True | El archivo .avi se reproduce automáticamente en un bucle sin fin en cuanto se carga en el control Animation.
False | Un archivo .avi, una vez cargado, no se reproduce hasta que se utiliza el método Play.

Tipo de datos

Integer (Boolean)

Comentarios

Un archivo .avi que se reproduzca mediante la propiedad AutoPlay continuará reproduciéndose hasta que AutoPlay se establezca a False.


BackStyle (Propiedad, control Animation)

Devuelve o establece un valor que determina si el control Animation presenta la animación sobre un fondo transparente o sobre un fondo con el color especificado en el clip de la animación. Esta propiedad es de sólo lectura en tiempo de ejecución.

Sintaxis

objeto.BackStyle [= valor]

La sintaxis de la propiedad BackStyle consta de las siguientes partes:

Parte | Descripción
Objeto | Una expresión de objeto que da como resultado un control Animation.
Valor | Una expresión numérica que especifica la transparencia, como se describe en Valores.

Valores

Los valores admitidos para valor son:

Valor | Descripción
0 | (Predeterminado) Transparente: es visible el color de fondo del control.
1 | Opaco: el color de fondo especificado en el clip de la animación ocupa todo el control y oculta los colores que hay detrás de él.

Comentarios

Puede usar la propiedad BackStyle para ejecutar una animación que muestre el color de fondo del control Animation en lugar de mostrar el color de fondo de la propia animación.

Tipo de datos

Integer (Boolean)


BuddyControl (Propiedad)

Establece o devuelve el control utilizado como control auxiliar.

Sintaxis

objeto.BuddyControl [= valor]

La sintaxis de la propiedad BuddyControl consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
valor | Un valor Variant que especifica el control auxiliar, como se describe a continuación.

Comentarios

La propiedad BuddyControl puede establecerse en tiempo de diseño o en tiempo de ejecución. En tiempo de diseño, establezca BuddyControl en la ventana Propiedades. Para establecerla en tiempo de ejecución, utilice el código siguiente:

UpDown1.BuddyControl = Text1

También puede establecer implícitamente la propiedad BuddyControl si establece AutoBuddy a True. En este caso, BuddyControl se establecerá automáticamente al control anterior del orden de tabulación.

Si establece la propiedad BuddyControl a Nothing, AutoBuddy se establecerá automáticamente a False.

Nota Si especifica en la propiedad BuddyControl un control que no puede ser auxiliar, como el control intrínseco de etiqueta, se producirá un error.


CalendarBackColor, CalendarForeColor (Propiedades)

Devuelve o establece los colores de fondo o de primer plano de la parte del calendario desplegable del control.

Sintaxis

objeto.CalendarBackColor [= color]

objeto.CalendarForeColor [= color]

Las sintaxis de las propiedades CalendarBackColor y CalendarForeColor constan de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
color | Un valor o una constante que determina el color usado.

Valores

Los valores admitidos para color son:

Valor | Descripción
Colores RGB | Colores especificados mediante la paleta de colores o por programa, con las funciones RGB o QBColor.
Colores predeterminados del sistema | Colores especificados a partir de la lista de constantes de colores de sistema de la biblioteca de objetos de Visual Basic (VBRUN) obtenida con el Examinador de objetos. El entorno operativo Windows sustituye la selección del usuario tal y como especifica la configuración del Panel de control.

Comentarios

Utilice las propiedades CalendarBackColor y CalendarForeColor con las propiedades CalendarTitleBackColor, CalendarTitleForeColor y CalendarTrailingForeColor para personalizar los colores del control.

El intervalo permitido para un color RGB normal está comprendido entre 0 y 16,777,215 (&HFFFFFF). En dicho intervalo, el byte superior de un número es igual a 0; los 3 bytes inferiores, del menos significativo al más significativo, determinan respectivamente la cantidad de rojo, verde y azul. Tres números comprendidos entre 0 y 255 (&HFF) representan los componentes respectivos de rojo, verde y azul. Si el byte superior es distinto de 0, Visual Basic utiliza los colores del sistema, tal y como vienen definidos en el Panel de control del usuario y por la lista de constantes de colores de sistema de la biblioteca de objetos de Visual Basic (VBRUN) en el Examinador de objetos.


Ejemplo de las propiedades CalendarBackColor, CalendarTitleForeColor

En el ejemplo se cambia la apariencia del calendario del control DateTimePicker restableciendo varias de sus propiedades de color. Para probar el ejemplo, inserte un control DateTimePicker y un control CommandButton en un formulario. Pegue el código en la sección Declaraciones del módulo de programa. Ejecute el proyecto y haga clic en el control DateTimePicker para ver los colores predeterminados. Haga clic en el control CommandButton y de nuevo en el control DateTimePicker para mostrar los colores nuevos.

Private Sub Command1_Click()
   With DTPicker1
      .CalendarBackColor = vbYellow
      .CalendarTitleBackColor = vbRed
      .CalendarTitleForeColor = vbWhite
      .CalendarTrailingForeColor = vbGreen
   End With
End Sub


CalendarTitleBackColor, CalendarTitleForeColor (Propiedades)

Devuelve o establece un valor que especifica los colores de fondo o de primer plano del título en la parte del calendario desplegable del control.

Sintaxis

objeto.CalendarTitleBackColor [= color]

objeto.CalendarTitleForeColor [= color]

Las sintaxis de las propiedades CalendarTitleBackColor y CalendarTitleForeColor constan de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
color | Un valor o constante que determina el color usado.

Valores

Los valores admitidos para color son:

Valor | Descripción
Colores RGB | Colores especificados mediante la paleta de colores o por programa, con las funciones RGB o QBColor.
Colores predeterminados del sistema | Colores especificados a partir de la lista de constantes de colores de sistema de la biblioteca de objetos de Visual Basic (VBRUN) obtenida con el Examinador de objetos. El entorno operativo Windows sustituye la selección del usuario tal y como especifica la configuración del Panel de control.

Comentarios

Utilice las propiedades CalendarTitleBackColor y CalendarTitleForeColor con las propiedades CalendarBackColor, CalendarForeColor y CalendarTrailingForeColor para personalizar los colores del control.

El intervalo permitido para un color RGB normal está comprendido entre 0 y 16,777,215 (&HFFFFFF). En dicho intervalo, el byte superior de un número es igual a 0; los 3 bytes inferiores, del menos significativo al más significativo, determinan respectivamente la cantidad de rojo, verde y azul. Tres números comprendidos entre 0 y 255 (&HFF) representan los componentes respectivos de rojo, verde y azul. Si el byte superior es distinto de 0, Visual Basic utiliza los colores del sistema, tal y como vienen definidos en el Panel de control del usuario y por la lista de constantes de colores de sistema de la biblioteca de objetos de Visual Basic (VBRUN) en el Examinador de objetos.


CalendarTrailingForeColor (Propiedad)

Devuelve o establece un valor que especifica el color de fondo de las fechas restantes mostradas en el calendario desplegable.

Sintaxis

objeto.CalendarTrailingForeColor [= color]

La sintaxis de la propiedad CalendarTrailingForeColor consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
color | Un valor o una constante que determina el color de fechas tentativas que pertenezcan al es anterior o a los siguientes, como se describe en Valores.

Valores

Los valores admitidos para color son:

Valor | Descripción
Colores RGB | Colores especificados mediante la paleta de colores o por programa, con las funciones RGB o QBColor.
Colores predeterminados del sistema | Colores especificados a partir de la lista de constantes de colores de sistema de la biblioteca de objetos de Visual Basic (VBRUN) obtenida con el Examinador de objetos. El entorno operativo Windows sustituye la selección del usuario tal y como especifica la configuración del Panel de control.

Comentarios

Las fechas restantes muestran los números de días que preceden o siguen a los días del mes seleccionado en el calendario desplegable. De forma predeterminada, las fechas restantes se muestran con color vbWhite.

Utilice la propiedad CalendarTrailingForeColor con las propiedades CalendarBackColor, CalendarForeColor, CalendarTitleBackColor y CalendarTitleForeColor para personalizar los colores del control.

El intervalo permitido para un color RGB normal está comprendido entre 0 y 16,777,215 (&HFFFFFF). En dicho intervalo, el byte superior de un número es igual a 0; los 3 bytes inferiores, del menos significativo al más significativo, determinan respectivamente la cantidad de rojo, verde y azul. Tres números comprendidos entre 0 y 255 (&HFF) representan los componentes respectivos de rojo, verde y azul. Si el byte superior es distinto de 0, Visual Basic utiliza los colores del sistema, tal y como vienen definidos en el Panel de control del usuario y por la lista de constantes de colores de sistema de la biblioteca de objetos de Visual Basic (VBRUN) en el Examinador de objetos.


Center (Propiedad)

Determina si el archivo .avi se centrará dentro del control Animation. Cuando se asigna con el valor True (valor predeterminado), el archivo .avi se presenta centrado en el control, según el tamaño de la imagen. Cuando se asigna con el valor False, el archivo .avi se coloca en las coordenadas 0,0 del control.

Sintaxis

objeto.Center [= booleano]

La sintaxis de la propiedad Center consta de las siguientes partes:

Parte | Descripción
objeto | Requerido. Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
booleano | Requerido. Una expresión booleana que especifica si el archivo AVI está centrado dentro del control.

Tipo de datos

Integer (Boolean)

Comentarios

Si la propiedad Center tiene el valor True y el tamaño de la imagen del .avi es mayor que el del control, los bordes de las imágenes del .avi no se podrán ver al reproducir el archivo.


CheckBox (Propiedad)

Devuelve o establece un valor que determina si debe mostrarse una casilla de verificación a la izquierda de la fecha seleccionada.

Sintaxis

objeto.CheckBox [= booleano]

La sintaxis de la propiedad CheckBox consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
booleano | Una expresión booleana que especifica si se muestra o no una casilla de verificación.

Valores

Los valores admitidos para booleano son:

Valor | Descripción
True | Se muestra una casilla de verificación a la izquierda de la fecha seleccionada.
False | (Predeterminado) No se muestra una casilla de verificación a la izquierda de la fecha seleccionada.

Comentarios

La casilla de verificación permite al usuario determinar si puede establecerse la fecha mediante el control. No hay ninguna fecha seleccionada cuando la casilla de verificación está vacía.


CustomFormat (Propiedad)

Devuelve o establece un valor que especifica el formato empleado por el control para mostrar la información de fecha y hora.

Sintaxis

objeto.CustomFormat [= cadena]

La sintaxis de la propiedad CustomFormat consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
cadena | Una expresión de cadena que especifica el formato de presentación.

Valores

El control DateTimePicker admite los siguientes caracteres de formato:

Fragmento de cadena | Descripción
d | El día con uno o dos dígitos.
dd | El día con dos dígitos. Los valores de un solo dígito llevan un cero a la izquierda.
ddd | El día de la semana abreviado a tres caracteres.
dddd | El nombre completo del día de la semana.
h | Formato de 12 horas con uno o dos dígitos.
hh | Formato de 12 horas con dos dígitos. Los valores de un solo dígito llevan un cero a la izquierda.
H | Formato de 24 horas con uno o dos dígitos.
HH | Formato de 24 horas con dos dígitos. Los valores de un solo dígito llevan un cero a la izquierda.
m | Los minutos con uno o dos dígitos.
mm | Los minutos con dos dígitos. Los valores de un solo dígito llevan un cero a la izquierda.
M | El número del mes con uno o dos dígitos.
MM | El número del mes con dos dígitos. Los valores de un solo dígito llevan un cero a la izquierda.
MMM | El mes abreviado a tres caracteres.
MMMM | El nombre completo del mes.
s | Los segundos con uno o dos dígitos.
ss | Los segundos con dos dígitos. Los valores de un solo dígito llevan un cero a la izquierda.
t | La expresión AM/PM abreviada en la primera letra (es decir, "AM" se muestra como "A").
tt | La expresión AM/PM abreviada con dos letras (es decir, "AM" se muestra como "AM").
X | Un campo de devolución de llamada. El control sigue utilizando los otros caracteres de formato válidos, pero solicita al propietario que llene la parte que contiene caracteres "X". El propietario debe estar preparado para responder a eventos que le soliciten información acerca de cómo introducir datos en estos campos. Utilice series de varios caracteres 'X' para distinguir entre campos de devolución de llamada.
y | El año con un solo dígito (es decir, 1997 se muestra como "7").
yy | Los dos últimos dígitos del año (es decir, 1997 se muestra como "97").
yyy | El año completo (es decir, 1997 se muestra como "1997").

Comentarios

La propiedad CustomFormat actúa como una máscara de entrada. Debe asignar a la propiedad Format el valor dtpCustom para presentar un formato personalizado

Es posible agregar texto literal a la cadena de formato. Por ejemplo, si desea usar el control para mostrar la fecha actual con el formato "Hoy es: Viernes 25 Julio 1997 Hora: 8:34 AM", la cadena CustomFormat es "'Hoy es:' ddddMMMM yyy ' Hora: 'h:mtt". El texto literal debe escribirse entre comillas sencillas (').

Uno de los campos con formato personalizado descrito anteriormente es un campo de devolución de llamada. Es posible personalizar el resultado especifica como campos de devolución de llamada ciertas partes de una cadena de formato. Para declarar un campo de devolución de llamada, incluya uno o más caracteres 'X' (código ASCII 88) en cualquier lugar dentro de la cadena de formato. Los campos de devolución de llamada se muestran de izquierda a derecha.

Cuando se usa un formato con uno o más campos de devolución de llamada para mostrar una nueva fecha, se generan eventos Format y FormatSize para cada uno de ellos. Utilice el evento Format para especificar una cadena de respuesta personalizada y el evento FormatSize para determinar el espacio requerido para mostrar la cadena. Este comportamiento proporciona un control completo sobre la presentación de un campo de devolución de llamada.

Cada secuencia de caracteres X tiene un significado específico. Por ejemplo, X podría significar "º" (correspondiente a "1º", "2º", etc.) y "XX" correspondería a "primero", "segundo". Estos campos no aplican formato al texto del usuario; dan a la fecha un formato que se puede mostrar.

Por ejemplo, suponga que su equipo está configurado para un país de habla inglesa y desea mostrar el mes tanto en español como en inglés con un formato como el siguiente:

July (Julio) 29

Podría crear un formato de cadena parecido al siguiente:

MMMM XXXX d

Al procesar los eventos Format y FormatSize puede determinar a qué tipo de campo de devolución de llamada corresponde el evento si compara la cadena de formato de entrada con "XXXX". Si la cadena del campo coincide, puede generar una cadena de resultado "(Julio)" y calcular su longitud.

El número de caracteres X sólo sirve para que una aplicación determine qué texto debe suministrarse para un campo de devolución de llamada. Durante el tratamiento del evento FormatSize, es posible calcular el tamaño del texto mediante programa.

Para crear campos de devolución exclusivos, repita el carácter "X". De esta forma, la cadena de formato "XXddddMMMdd', 'yyyXXX" contiene dos campos de devolución de llamada. Los campos de devolución de llamada se consideran campos válidos, por lo que conviene que la aplicación esté preparada para atender eventos Key.


DayBold (Propiedad)

Devuelve o establece un valor que determina si la fecha se muestra en negrita.

Sintaxis

objeto.DayBold(fecha) [= booleano]

La sintaxis de la propiedad DayBold consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
fecha | Una expresión de fecha que especifica una fecha tomada de la propiedad VisibleDays.
booleano | Una expresión booleana que especifica si la fecha se muestra con fuente en negrita.

Valores

Los valores admitidos para booleano son:

Valor | Descripción
True | Se muestra la fecha en negrita.
False | (Predeterminado) No se muestra la fecha en negrita.

Comentarios

La propiedad DayBold es una matriz que corresponde a la propiedad VisibleDays. Cada elemento booleano indica si la fecha correspondiente debe mostrarse o no en negrita.

Son válidas únicamente las fechas mostradas actualmente. Las fechas válidas pueden buscarse en la propiedad VisibleDays.

A medida que pasa de un mes a otro, no se conserva la información de la propiedad.


Ejemplo de la propiedad DayBold

En el código siguiente se establecen los días primero y último que deben mostrarse en negrita. Para probar el ejemplo, inserte un control MonthView en un formulario y pegue el código en la sección Declaraciones. Ejecute el proyecto y haga doble clic en el formulario.

Private Sub Form_DblClick()
   With MonthView1
      .DayBold(MonthView1.VisibleDays(1)) = True
      .DayBold(MonthView1.VisibleDays(42)) = True
   End With
End Sub


DayOfWeek (Propiedad)

Devuelve o establece un valor que especifica el día de la semana actual.

Sintaxis

objeto.DayOfWeek [= número]

La sintaxis de la propiedad DayOfWeek consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
número | Una expresión numérica que especifica el día de la semana, como se indica en Valores.

Valores

Los valores admitidos para número son:

Constante | Valor | Descripción
mvwSunday | 1 | (Predeterminado) Domingo
mvwMonday | 2 | Lunes
mvwTuesday | 3 | Martes
mvwWednesday | 4 | Miércoles
mvwThursday | 5 | Jueves
mvwFriday | 6 | Viernes
mvwSaturday | 7 | Sábado

Comentarios

La propiedad DayOfWeek puede tomar cualquier valor entero entre 1 y 7.


Day (Propiedad)

Devuelve o establece un valor que especifica el número del día actual.

Sintaxis

objeto.Day [= número]

La sintaxis de la propiedad Day consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
número | Una expresión numérica que calcula y devuelve un entero correspondiente al número del día.

Comentarios

La propiedad Day puede tomar cualquier valor entero entre 1 y 31.


FormatStyle (Propiedad, control DateTimePicker )

Devuelve o establece un valor que determina el tipo de formato empleado para mostrar texto en el control.

Sintaxis

objeto.FormatStyle [= entero]

La sintaxis de la propiedad FormatStyle consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
entero | Un valor que especifica el estilo de formato empleado para mostrar texto en el control, como se indica en Valores.

Valores

Los valores admitidos para entero son:

Constante | Valor | Descripción
dtpLongDate | 0 | Formato de fecha largo (por ejemplo, "Viernes 14 Nov 1972").
dtpShortDate | 1 | Formato de fecha corto (por ejemplo, "14/11/72").
dtpTime | 2 | Formato de hora (por ejemplo, "5:31:47 PM").
dtpCustom | 3 | Formato personalizado.

Comentarios

Establezca la propiedad FormatStyle a dtpCustom para usar la propiedad CustomFormat.


Hour (Propiedad)

Devuelve o establece un valor que especifica la hora actual mostrada.

Sintaxis

objeto.Hour [= valor]

La sintaxis de la propiedad Hour consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
valor | Una expresión numérica que especifica la presentación de la hora actual.

Comentarios

La propiedad Hour puede tomar cualquier valor entero entre 0 y 23.


Increment (Propiedad)

Establece o devuelve un valor que determina la cantidad en que varía la propiedad Value cuando se hace clic en los botones del control UpDown.

Sintaxis

objeto.Increment [= valor ]

La sintaxis de la propiedad Increment consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
valor | Un entero largo que determina la cantidad en que varía la propiedad Value. Este parámetro no puede ser un número negativo. Su valor predeterminado es 1.

Comentarios

La propiedad Increment determina la cantidad en que varía la propiedad Value al hacer clic en los botones de flechas del control UpDown. Al hacer clic en la flecha arriba o en la flecha a la derecha, Value se aproxima al valor de Max en la cantidad especificada en la propiedad Increment. Al hacer clic en la flecha abajo o en la flecha a la izquierda, Value se aproxima al valor de Min también en la cantidad especificada en Increment.


MaxDate, MinDate (Propiedades)

Devuelve o establece la primera y la última fecha permitida por el calendario.

Sintaxis

objeto.MaxDate [= fecha ]

objeto.MinDate [= fecha ]

La sintaxis de las propiedades MaxDate y MinDate consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
fecha | Una expresión de fecha que da como resultado una fecha válida.

Comentarios

La propiedad MaxDate sirve para definir el límite superior del calendario.

La propiedad MinDate se utiliza para establecer el límite inferior del calendario.


Max (Propiedad)

Establece o devuelve el valor máximo del intervalo de desplazamiento del control UpDown.

Sintaxis

objeto.Max [= valor]

La sintaxis de la propiedad Max consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
valor | Un valor entero largo que especifica el valor máximo, como se describe a continuación. El valor de este parámetro puede ser un número negativo.

Comentarios

Normalmente, al presionar la flecha arriba o la flecha a la derecha, el control UpDown incrementará la propiedad Value. Sin embargo, si el valor de la propiedad Max es inferior al de Min, el control UpDown funciona en el sentido opuesto.

Siempre que se presiona la flecha arriba o la flecha a la derecha, el valor de la propiedad Value se aproxima al valor de Max. Al presionar la flecha abajo o la flecha a la izquierda, Value se aproxima al valor de Min.


MaxSelCount (Propiedad)

Devuelve o establece el número máximo de días consecutivos que es posible seleccionar de una vez.

Sintaxis

objeto.MaxSelCount [= número]

La sintaxis de la propiedad MaxSelCount consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
número | Una expresión numérica que da como resultado el número de días que pueden incluirse en la misma selección.

Comentarios

La propiedad MaxSelCount tiene validez solamente cuando la propiedad MultiSelect tiene el valor True. Además, el valor asignado a la propiedad MaxSelCount debe ser superior a la diferencia entre las propiedades SelStart y SelEnd. Por ejemplo, si selecciona el periodo del 15/9 al 18/9, MonthView.SelEnd - MonthView.SelStart = 3. Sin embargo, son cuatro los días seleccionados realmente, por lo que MaxSelCount debe tener asignado el valor 4.

El valor predeterminado de la propiedad es una semana (7 días).


Min (Propiedad)

Establece o devuelve el valor mínimo del intervalo de desplazamiento del control UpDown.

Sintaxis

objeto.Min [= valor]

La sintaxis de la propiedad Min consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
valor | Un valor entero largo que especifica el valor mínimo, como se describe a continuación. El valor de este parámetro puede ser un número negativo.

Comentarios

Normalmente, al presionar la flecha abajo o la flecha a la izquierda, el control UpDown disminuirá el valor de la propiedad Value. Sin embargo, si el valor de la propiedad Min es superior al de Max, el control UpDown funciona en el sentido opuesto.

Siempre que se presiona la flecha abajo o la flecha a la izquierda, el valor de la propiedad Value se aproxima al valor de Min. Al presionar la flecha arriba o la flecha a la derecha, Value se aproxima al valor de Max.


Minute (Propiedad)

Devuelve o establece un valor que especifica el minuto actual mostrado.

Sintaxis

objeto.Minute [= valor]

La sintaxis de la propiedad Minute consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
valor | Una expresión numérica que especifica la presentación del minuto actual.

Comentarios

La propiedad Minute puede tomar cualquier valor entero entre 0 y 59.


MonthBackColor (Propiedad)

Devuelve o establece un valor que especifica el color de fondo mostrado para un mes.

Sintaxis

objeto.MonthBackColor [= color]

La sintaxis de la propiedad MonthBackColor consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
color | Un valor o una constante que determina el color de fondo mostrado dentro del mes, como se describe en Valores.

Valores

Visual Basic utiliza el esquema de color RGB (rojo,verde,azul) empleado por el entorno operativo Microsoft Windows. Los valores admitidos para color son:

Valor | Descripción
Colores RGB normales | Colores especificados mediante la paleta de colores o por programa, con las funciones RGB o QBColor.
Colores predeterminados del sistema | Colores especificados por las constantes de colores de sistema de la librería de objetos de Visual Basic (VBRUN) en el Examinador de objetos. El entorno operativo Windows sustituye las elecciones del usuario tal y como especifica la configuración del Panel de Control.

Comentarios

Utilice la propiedad MonthBackColor con las propiedades TitleBackColor, TitleForeColor y TrailingForeColor para personalizar los colores del control.

El intervalo permitido para un color RGB normal está comprendido entre 0 y 16.777.215 (&HFFFFFF). En dicho intervalo, el byte superior de un número es igual a 0; los tres bytes inferiores, del byte menos significativo al más significativo, determinan respectivamente la cantidad de rojo, verde y azul. Tres números comprendidos entre 0 y 255 (&HFF) representan los componentes respectivos de rojo, verde y azul. Si el byte superior es distinto de 0, Visual Basic utiliza los colores del sistema, tal y como vienen definidos en el Panel de Control del usuario y por la lista de constantes de librería de objetos de Visual Basic (VBRUN) en el Examinador de objetos.


MonthColumns, MonthRows (Propiedades)

Devuelve o establece un valor que especifica el número de meses que se muestran en sentido horizontal o vertical.

Sintaxis

objeto.MonthColumns [= número]

objeto.MonthRows [= número]

La sintaxis de las propiedades MonthColumns y MonthRows consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
número | Una expresión numérica que especifica el número de meses.

Comentarios

Las propiedades MonthColumns y MonthRows permiten mostrar más de un mes simultáneamente.

La propiedad MonthColumns permite especificar el número de meses que se muestran en horizontal. La propiedad MonthRows permite especificar el número de meses que se muestran en vertical.

El control puede mostrar hasta doce meses.


Month (Propiedad)

Devuelve o establece un valor que especifica el mes actual.

Sintaxis

objeto.Month [= número]

La sintaxis de la propiedad Month consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
número | Una constante o expresión numérica que calcula y devuelve un entero correspondiente al mes, como se indica en Valores.

Valores

Los valores admitidos para número son:

Constante | Valor | Descripción
mvwJanuary | 1 | Enero
mvwFebruary | 2 | Febrero
mvwMarch | 3 | Marzo
mvwApril | 4 | Abril
mvwMay | 5 | Mayo
mvwJune | 6 | Junio
mvwJuly | 7 | Julio
mvwAugust | 8 | Agosto
mvwSeptember | 9 | Septiembre
mvwOctober | 10 | Octubre
mvwNovember | 11 | Noviembre
mvwDecember | 12 | Diciembre

Comentarios

La propiedad Month puede tomar cualquier valor entero entre 1 y 12.


MultiSelect (Propiedad, control MonthView)

Devuelve o establece un valor que determina si es posible realizar una selección múltiple de fechas.

Sintaxis

objeto.MultiSelect [= booleano]

La sintaxis de la propiedad MultiSelect consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
booleano | Una expresión booleana que especifica el comportamiento de la selección presentada por el control.

Valores

Los valores admitidos para booleano son:

Valor | Descripción
True | (Predeterminado) Se permite al usuario seleccionar múltiple de días.
False | No se permite al usuario seleccionar múltiples días.

Comentarios

De forma predeterminada, el control permite al usuario seleccionar un intervalo de fechas. El intervalo máximo predeterminado es una semana (7 días). Establezca la propiedad MaxSelCount para cambiar el intervalo de selección máximo. La propiedad Value estará comprendida dentro de este intervalo, señalando de esta forma la fecha que tiene el enfoque.


Orientation (Propiedad)

Establece o devuelve la orientación de los botones de flechas del control UpDown. Esta propiedad es de sólo lectura en tiempo de ejecución.

Sintaxis

objeto.Orientation

El marcador de posición objeto es una expresión de objeto que da como resultado un objeto de la lista Se aplica a.

Valores

Los valores de la propiedad Orientation son:

Constante | Valor | Descripción
cc2orientationVertical | 0 | (Predeterminado). Los botones de flechas se disponen verticalmente.
cc2orientationHorizontal | 1 | Los botones de flechas se disponen horizontalmente.

Comentarios

En tiempo de diseño, esta propiedad se puede establecer en la ventana Propiedades o en la página de propiedades del control.

Al establecer la propiedad Orientation, el control UpDown cambia automáticamente su posición junto al control auxiliar.


Orientation (Propiedad, control FlatScrollBar)

Devuelve o establece un valor que determina la orientación (horizontal o vertical) del objeto.

Sintaxis

objeto.Orientation [= entero]

La sintaxis de la propiedad Orientation consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
entero | Una expresión numérica que especifica la orientación del control, como se muestra en Valores.

Valores

Los valores para entero son:

Constante | Valor | Descripción
cc2OrientationHorizontal | 0 | (Predeterminado) El control está orientado horizontalmente.
cc2OrientationVertical | 1 | El control está orientado verticalmente.


ScrollRate (Propiedad)

Devuelve o establece un valor que especifica el número de meses que se desplazará cuando el usuario haga clic en uno de los botones de desplazamiento.

Sintaxis

objeto.ScrollRate [= número]

La sintaxis de la propiedad ScrollRate consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
número | Una expresión numérica que especifica el número de meses que se desplaza cada vez.

Comentarios

La propiedad ScrollRate permite al usuario realizar desplazamientos de más de un mes cada vez.


Second (Propiedad)

Establece o devuelve el entero correspondiente al segundo que se muestra como actual.

Sintaxis

objeto.Second [= entero]

La sintaxis de la propiedad Second consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
entero | Una expresión numérica comprendida entre 0 y 59 que representa los segundos.


SelEnd, SelStart (Propiedades, control MonthView)

Devuelve o establece los límites inferior y superior del intervalo de fechas seleccionado.

Sintaxis

objeto.SelEnd [= fecha ]

objeto.SelStart [= fecha ]

La sintaxis de las propiedades SelEnd y SelStart consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
fecha | Una expresión de fecha que da como resultado una fecha válida.

Comentarios

La propiedad SelStart define el límite inferior del intervalo de fechas seleccionado. La propiedad SelEnd define el límite superior del intervalo de fechas seleccionado.

El intervalo de fechas seleccionado puede abarcar varios meses. Es posible incluir fechas que no están visibles actualmente.

Para que la selección múltiple de fechas funcione correctamente, asigne a la propiedad MaxSelCount un valor superior a la diferencia de los valores de las propiedades SelStart y SelEnd.

Los valores SelStart y SelEnd sólo son válidos cuando la propiedad MultiSelect tiene el valor True.


Ejemplo de las propiedades SelEnd, SelStart

En el código siguiente se asume que la propiedad MaxSelCount tiene el valor 7 y se procede a seleccionar los días comprendidos entre el 8 de noviembre 1998 y el 14 de noviembre 1998:

With MonthView1
   .MultiSelect = True
   .Value = CDate("11/11/98")
   .SelStart = CDate("11/11/98")
   .SelEnd = CDate("14/11/98")
End With

Cuando se establece la propiedad Value, la misma fecha se aplica de forma implícita a las propiedades SelStart y SelEnd. De no establecerse primero la propiedad Value, se seleccionarían todos los días comprendidos entre la fecha seleccionada actualmente y la fecha de SelStart.


ShowToday (Propiedad)

Devuelve o establece un valor que determina si se muestra la fecha actual en la parte inferior del control.

Sintaxis

objeto.ShowToday [= booleano]

La sintaxis de la propiedad ShowToday consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
booleano | Una expresión booleana que especifica el estado de los indicadores de la fecha actual.

Valores

Los valores admitidos para booleano son:

Valor | Descripción
True | (Predeterminado) Se muestra la fecha actual.
False | No se muestra la fecha actual.


ShowWeekNumbers (Propiedad)

Devuelve o establece un valor que determina si los números de semana aparecen junto a la semana.

Sintaxis

objeto.ShowWeekNumbers [= booleano]

La sintaxis de la propiedad ShowWeekNumbers consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
booleano | Una expresión booleana que especifica el estado de los indicadores de la fecha actual.

Valores

Los valores admitidos para booleano son:

Valor | Descripción
True | Se muestran los números de semana.
False | (Predeterminado) No se muestran los números de semana.

Comentarios

Se muestran los números de semana a la izquierda de ésta, contando desde la primera semana del año de calendario.


StartOfWeek (Propiedad)

Devuelve o establece un valor que especifica el primer día de la semana.

Sintaxis

objeto.StartOfWeek [= entero]

La sintaxis de la propiedad StartOfWeek consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
entero | Una expresión numérica que especifica el primer día de la semana, como se indica en Valores.

Valores

Los valores admitidos para entero son:

Constante | Valor | Descripción
mvwSunday | 1 | (Predeterminado) Domingo
mvwMonday | 2 | Lunes
mvwTuesday | 3 | Martes
mvwWednesday | 4 | Miércoles
mvwThursday | 5 | Jueves
mvwFriday | 6 | Viernes
mvwSaturday | 7 | Sábado

Comentarios

La propiedad StartOfWeek permite especificar el día que aparecerá en el extremo izquierdo del calendario. Esto puede ser útil cuando se diseñan aplicaciones destinadas a diferentes países.


SyncBuddy (Propiedad)

Establece o devuelve un valor que determina si el control UpDown sincroniza la propiedad Value con una propiedad del control auxiliar.

Sintaxis

objeto.SyncBuddy [= valor]

La sintaxis de la propiedad SyncBuddy consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
valor | Una expresión booleana que determina si el control auxiliar se sincroniza con el control UpDown, como se describe en Valores.

Valores

Los valores válidos para valor son:

Valor | Descripción
True | El control UpDown sincroniza la propiedad Value con una propiedad del control auxiliar, especificada en la propiedad BuddyProperty. Si no especificó ninguna propiedad en BuddyProperty, se usará la propiedad predeterminada del control auxiliar.
False | (Predeterminado) El control UpDown no sincroniza su propiedad Value con ninguna propiedad del control auxiliar.

Comentarios

Utilice la propiedad SyncBuddy para sincronizar automáticamente una propiedad del control auxiliar con la propiedad Value del control UpDown. Por ejemplo, puede sincronizarla con la propiedad Text de un control TextBox. Siempre que cambia el valor de Value se actualiza la propiedad Text del control TextBox y viceversa. También puede sincronizar la propiedad Value del control UpDown con otras propiedades, como Top, Left, BackColor y ForeColor, entre otras.

Para ver la lista de las propiedades disponibles que puede sincronizar con la propiedad Value (después de establecer la propiedad BuddyControl), seleccione la propiedad BuddyProperty en la ventana Propiedades o en la página de propiedades.


TitleBackColor, TitleForeColor (Propiedades)

Devuelven o establecen valores que especifican los colores de fondo y primer plano del área de título del control.

Sintaxis

objeto.TitleBackColor [= color]

objeto.TitleForeColor [= color]

La sintaxis de las propiedades TitleBackColor y TitleForeColor consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
color | Un valor o una constante que determina el color usado.

Valores

Visual Basic utiliza el esquema de color RGB (rojo,verde,azul) del entorno operativo Microsoft Windows. Los valores admitidos para color son:

Valor | Descripción
Colores RGB normales | Colores especificados con la paleta de colores o por programa, con las funciones RGB o QBColor.
Colores predeterminados del sistema | Colores especificados por las constantes de colores de sistema de la librería de objetos de Visual Basic (VBRUN) en el Examinador de objetos. El entorno operativo Windows sustituye las elecciones del usuario tal y como especifica la configuración del Panel de Control.

Comentarios

Utilice las propiedades TitleBackColor y TitleForeColor con las propiedades MonthBackColor y TrailingForeColor para personalizar los colores del control.

El intervalo permitido para un color RGB normal está comprendido entre 0 y 16.777.215 (&HFFFFFF). En dicho intervalo, el byte superior de un número es igual a 0; los tres bytes inferiores, del byte menos significativo al más significativo, determinan respectivamente la cantidad de rojo, verde y azul. Tres números comprendidos entre 0 y 255 (&HFF) representan los componentes respectivos de rojo, verde y azul. Si el byte superior es distinto de 0, Visual Basic utiliza los colores del sistema, tal y como vienen definidos en el Panel de Control del usuario y por la lista de constantes de librería de objetos de Visual Basic (VBRUN) en el Examinador de objetos.


Ejemplo de las propiedades TitleBackColor, TitleForeColor, TrailingForeColor

El ejemplo restablece las propiedades TitleBackColor, TitleForeColor y TrailingForeColor para modificar la apariencia de un control MonthView. Para probar el ejemplo, inserte un control MonthView en un formulario y pegue el código dentro de la sección Declaraciones del módulo de programa. Ejecute el proyecto y haga doble clic en el formulario para ver la modificación del calendario.

Private Sub Form_DblClick()
   With MonthView1
      .TitleBackColor = vbBlue
      .TitleForeColor = vbWhite
      .TrailingForeColor = vbRed
   End With
End Sub


TrailingForeColor (Propiedad)

Devuelve o establece un valor que especifica el color de primer plano de las fechas restantes visibles actualmente.

Sintaxis

objeto.TrailingForeColor [= color]

La sintaxis de la propiedad TrailingForeColor consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
color | Un valor o una constante que determina el color de las fechas restantes, como se describe en Valores.

Valores

Visual Basic utiliza el esquema de color RGB (rojo,verde,azul) empleado por el entorno operativo Microsoft Windows. Los valores admitidos para color son:

Valor | Descripción
Colores RGB normales | Colores especificados con la paleta de colores o por programa, con las funciones RGB o QBColor.
Colores predeterminados del sistema | Colores especificados por las constantes de colores de sistema de la librería de objetos de Visual Basic (VBRUN) en el Examinador de objetos. El entorno operativo Windows sustituye las elecciones del usuario tal y como especifica la configuración del Panel de Control.

Comentarios

Las fechas restantes muestran los números de los días que preceden o siguen a los días del mes seleccionado. De forma predeterminada, las fechas restantes se muestran con color vbWhite.

Utilice la propiedad TrailingForeColor con las propiedades MonthBackColor, TitleBackColor y TitleForeColor para personalizar los colores del control.

El intervalo permitido para un color RGB normal está comprendido entre 0 y 16.777.215 (&HFFFFFF). En dicho intervalo, el byte superior de un número es igual a 0; los tres bytes inferiores, del byte menos significativo al más significativo, determinan respectivamente la cantidad de rojo, verde y azul. Tres números comprendidos entre 0 y 255 (&HFF) representan los componentes respectivos de rojo, verde y azul. Si el byte superior es distinto de 0, Visual Basic utiliza los colores del sistema, tal y como vienen definidos en el Panel de Control del usuario y por la lista de constantes de librería de objetos de Visual Basic (VBRUN) en el Examinador de objetos.


UpDown (Propiedad)

Devuelve o establece un valor que determina si se muestra un control de dos flechas hacia arriba y hacia abajo a la derecha del control DateTimePicker.

Sintaxis

objeto.UpDown [= booleano]

La sintaxis de la propiedad UpDown consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
booleano | Una expresión booleana que especifica si se muestra un control UpDown a la derecha del control DateTimePicker.

Valores

Los valores admitidos para booleano son:

Valor | Descripción
True | Aparece un control UpDown.
False | (Predeterminado) No aparece un control UpDown.

Comentarios

Para seleccionar una fecha, es posible usar los botones de flecha hacia arriba y hacia abajo en lugar del calendario desplegable.


Value (Propiedad, controles MonthView, DatePicker)

Devuelve o establece la fecha que se muestra actualmente.

Sintaxis

objeto.Value [= fecha]

La sintaxis de la propiedad Value consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
fecha | Una expresión de fecha que especifica una fecha mostrada por el control.

Comentarios

La propiedad Value es la propiedad predeterminada del control.


Value (Propiedad, control UpDown)

Establece o devuelve la posición actual del valor de desplazamiento.

Sintaxis

objeto.Value [= long]

La sintaxis de la propiedad Value consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
long | Un entero largo que especifica el valor actual, como se describe a continuación.

Comentarios

La propiedad Value especifica el valor actual dentro del intervalo indicado por las propiedades Min y Max. Esta propiedad aumenta o disminuye al hacer clic en los botones de flechas. Los valores de las propiedades Min y Max determinan si el valor aumenta o disminuye al hacer clic en los botones de flechas.

Si el valor de la propiedad SyncBuddy es True, la propiedad BuddyProperty se sincronizará cuando haya un cambio en la propiedad Value o cuando se modifique el valor de la propiedad BuddyProperty.


VisibleDays (Propiedad)

Devuelve una matriz que contiene las fechas mostradas actualmente.

Sintaxis

objeto.VisibleDays(Index)

La sintaxis de la propiedad VisibleDays consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
Index | Un entero que especifica la fecha mostrada en el calendario.

Comentarios

Index puede ser cualquier valor comprendido entre 1 y 42. Un valor 1 corresponde a la primera fecha mostrada actualmente.

Con la propiedad VisibleDays, tan sólo es posible encontrar fechas visibles actualmente. Además, el número de días visibles puede cambiar dependiendo de los valores de las propiedades MonthColumns y MonthRows.

A medida que pasa de un mes a otro, no se conserva la información de la propiedad.


Ejemplo de la propiedad VisibleDays

En el código siguiente se muestran las fechas de todos los días mostrados en el calendario. Para probar el ejemplo, inserte un control MonthView en un formulario y pegue el código en la sección Declaraciones. Ejecute el proyecto y haga doble clic en el formulario.

Private Sub Form_DblClick()
   Dim i As Integer
   For i = 1 To 42
      Debug.Print MonthView1.VisibleDays(i)
   Next i
End Sub


Week (Propiedad)

Devuelve o establece un valor que especifica el número de la semana actual.

Sintaxis

objeto.Week [= número]

La sintaxis de la propiedad Week consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
número | Una expresión numérica que calcula y devuelve un entero correspondiente al número de la semana.

Comentarios

La propiedad Week puede tomar cualquier valor entero entre 1 y 52.


Wrap (Propiedad)

Establece o devuelve un valor que determina si la propiedad Value del control se ajusta al comienzo o al final del intervalo cuando llega al valor de Max o Min, respectivamente.

Sintaxis

objeto.Wrap [= valor]

La sintaxis de la propiedad Wrap consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
valor | Una expresión booleana que determina si el control UpDown ajusta su propiedad Value, como se describe en Valores.

Valores

Los valores válidos para valor son:

Valor | Descripción
True | El control UpDown ajusta la propiedad Value al principio o al final del intervalo cuando el usuario sobrepasa los valores de Max o Min con los botones de flechas.
False | (Predeterminado) El control UpDown no ajusta la propiedad Value.

Comentarios

Cuando el valor de Wrap es True, la propiedad Value se ajusta según el valor de las propiedades Min, Max e Increment.

Cuando se ajusta la propiedad Value, el primer salto es al valor Min. Por ejemplo, si Min es 20, Max es 70, Increment es 10, Value es 70 y el usuario hace clic en el botón de flecha arriba o flecha a la derecha, la propiedad Value se ajusta a 20.


Ejemplo de la propiedad Wrap

En este ejemplo se utiliza la propiedad Wrap con el control UpDown para crear un control numérico ajustable cuyos valores van de 10 a 70 con un incremento de 10. Para probar este ejemplo, coloque un control TextBox y un control UpDown en un formulario y agregue el código siguiente:

Private Sub Form_Load()
   UpDown1.BuddyControl = Text1
   With UpDown1
      .Min = 10
      .Max = 70
      .Increment = 10
      .Wrap = True
      .SyncBuddy = True
   End With

   ' Así el control TextBox refleja el valor inicial
   Text1.Text = UpDown1.Value
End Sub


Year (Propiedad)

Devuelve o establece un valor que especifica un año de calendario.

Sintaxis

objeto.Year [= número]

La sintaxis de la propiedad Year consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
número | Una expresión numérica que calcula y devuelve un entero correspondiente al año.

Comentarios

Es posible asignar a la propiedad Year cualquier entero comprendido entre 1601 y 9999.


Year (Propiedad, controles ActiveX)

Devuelve o establece el año que se muestra como actual.

Sintaxis

objeto.Year [= número]

La sintaxis de la propiedad Year consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
número | Una expresión numérica comprendida entre los valores de las propiedades MinDate y MaxDate.