CoolBar (Control)

Un control CoolBar contiene una colección de objetos Band usados para crear una barra de herramientas configurable que se asociará a un formulario.

Comentarios

Un control CoolBar es un control contenedor que suele contener dos o más objetos Band que el usuario puede cambiar de tamaño y reorganizar. Cada objeto Band contiene un único control Child.


No se encuentra el tema

No se halló el tema correspondiente. A continuación enumeramos algunas posibles razones y sus soluciones:

  • El archivo (.chm) que contiene el tema de destino no se encuentra en la ubicación esperada.

    Solución: vuelva a ejecutar la instalación de la Biblioteca MSDN.

  • El archivo (.chm) que contiene el tema actual o el de destino no está actualizado y el vínculo ya no es válido.

    Solución: instale la última versión de la Biblioteca MSDN.

  • El CD de la Biblioteca MSDN no está en la unidad de CD-ROM.

    Solución: inserte el CD en la unidad.


Bands (Colección)

Una colección cuyos elementos representan las bandas de un control CoolBar. La colección Bands tiene una propiedad Count que especifica el número de objetos Band de la colección.

Sintaxis

objeto.Bands.Count

objeto.Bands(índice)

La sintaxis de la colección Bands tiene estas tres partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un control CoolBal.
índice | Un entero entre 1 y Bands.Count.

Comentarios

La colección Bands enumera las bandas de un control CoolBar. Por ejemplo, puede usarla para cambiar la propiedad BackColor de todas las bandas de un control.

Nota La colección Bands no es miembro de la clase Collection de Visual Basic; no puede crear instancias de ella.


HeightChanged (Evento)

Ocurre cuando cambia la propiedad Height de un control CoolBar.

Sintaxis

Private Sub objeto_HeightChanged([índice As Integer], nuevoAlto As Single)

La sintaxis del evento HeightChanged tiene estas partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un control CoolBar.
índice | Un entero que identifica de forma exclusiva un control si está en una matriz de controles.
nuevoAlto | Número de signo flotante de precisión simple que especifica el nuevo alto del control.

Comentarios

El evento HeightChanged ocurre después del evento Resize cuando es necesario cambiar el alto de CoolBar. Esto puede ocurrir cuando el usuario reorganiza las bandas en tiempo de ejecución o cuando el alto de una o más bandas se cambia mediante programación.

Este evento es útil cuando el control CoolBar está dentro de un contenedor que es capaz de suprimir cambios. En este caso, quizás no sea confiable leer la propiedad Height durante el evento Resize o puede que se suprima el evento Resize. El evento HeightChanged le permite agregar código para conseguir que el control CoolBar se muestre correctamente.


Add (Método, colección Bands)

Agrega un nuevo objeto Band a la colección Bands.

Sintaxis

objeto.Add ([índice As Long], [clave As String], [título As String], [imagen As Variant], [nuevaFila As Boolean], [secundario As Object], [visible As Boolean])

La sintaxis del método Add tiene estas partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado la colección Bands de un control CoolBar.
índice | Opcional. Un entero largo que identifica de forma exclusiva una banda de la colección Bands.
clave | Opcional. Una cadena exclusiva que identifica el objeto Band. Use este valor para recuperar un objeto Band específico.
título | Opcional. Una cadena que contiene el título que se mostrará en la banda.
imagen | Opcional. Un entero o una cadena exclusiva que especifica el objeto ListImage para usar con objeto. El entero es el valor de la propiedad Index; la cadena es el valor de la propiedad Key.
nuevaFila | Opcional. Predeterminado = False. Una expresión booleana que indica si el nuevo objeto Band se mostrará en su propia fila.
secundario | Opcional. Una referencia a un objeto que especifica el control secundario de la banda.
visible | Opcional. Predeterminado = False. Una expresión booleana que indica si una nueva banda será visible en tiempo de ejecución.


Band (Objeto)

Un objeto Band representa una banda individual de la colección Bands del control CoolBar.

Comentarios

Una banda es una región dentro de un control CoolBar que puede contener un único control secundario, un título y una imagen. El usuario puede mover y cambiar el tamaño de cada objeto Band de forma independiente en tiempo de ejecución.

En tiempo de diseño, puede usar los botones Insertar banda y Quitar banda de la ficha Bandas en la página de propiedades del control CoolBar para insertar y quitar objetos Band de la colección Bands. En tiempo de ejecución, puede agregar y quitar objetos Band mediante los métodos Add y Remove de la colección Bands.


AllowVertical (Propiedad, objeto Band)

Devuelve o establece un valor que indica si una banda se mostrará cuando la orientación del control CoolBar sea vertical.

Sintaxis

objeto.AllowVertical [= booleano]

La sintaxis de la propiedad AllowVertical tiene estas partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto Band de un control CoolBar.
booleano | Una expresión booleana que especifica si la banda es visible o está oculta.

Valores

Los valores posibles de booleano son:

Valor | Descripción
True | (Predeterminado) La banda es visible.
False | La banda está oculta.

Comentarios

Para ocultar una banda en el proceso de inicio cuando Orientation tiene el valor Vertical, asigne a la propiedad AllowVertical el valor False en tiempo de diseño. Establecer esta propiedad mediante código le permite ocultar y volver a mostrar más tarde una banda en tiempo de ejecución para responder a un evento determinado.

Nota Cuando la propiedad Orientation tiene el valor Vertical, tanto AllowVertical como Visible deben ser True para que la banda sea visible. Si una de las dos es False, la banda no será visible.


BandBorders (Propiedad)

Devuelve o establece un valor que indica si un control CoolBar muestra líneas estrechas para separar las bandas.

Sintaxis

objeto.BandBorders [= booleano]

La sintaxis de la propiedad BandBorders tiene estas partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un control CoolBar.
booleano | Una expresión booleana que indica si el borde de la banda es visible o está oculto.

Valores

Los valores posibles de booleano son:

Valor | Descripción
True | (Predeterminado) Los bordes son visibles.
False | Los bordes están ocultos.

Comentarios

Para quitar los bordes entre las bandas, asigne a la propiedad BandBorders el valor False en tiempo de diseño. Establecer esta propiedad mediante código le permite ocultar o mostrar los bordes entre bandas en tiempo de ejecución para responder a un evento determinado. Establecer esta propiedad afecta a todas las bandas de un control CoolBar.

Nota La propiedad BandBorders no tiene ningún efecto sobre el borde externo del control CoolBar propiamente dicho. El borde del control CoolBar se muestra siempre.


Bands (Propiedad)

Devuelve una referencia a una colección de objetos Band del control CoolBar.

Sintaxis

objeto.Bands

El marcador de posición objeto es una expresión de objeto que da como resultado un control CoolBar.

Comentarios

Puede manipular objetos Band mediante métodos estándar de la colección (por ejemplo, los métodos Add y Remove). Es posible tener acceso a cada elemento de la colección mediante su índice, el valor de la propiedad Index o mediante una clave única, el valor de la propiedad Key.


Caption (Propiedad, objeto Band)

Devuelve o establece el título que aparece en un objeto Band de un control CoolBar.

Sintaxis

objeto.Caption [= cadena]

La sintaxis de la propiedad Caption tiene estas partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto Band de la colección Bands de un control CoolBar.
cadena | Una expresión de cadena que da como resultado el texto que se muestra en el título.

Comentarios

El título se muestra alineado a la izquierda entre el controlador de movimiento y el control secundario. Cuando un control Band se muestra verticalmente, el ancho de la banda depende del ancho del título.


Child (Propiedad, objeto Band)

Devuelve o establece una referencia a un control secundario de un objeto Band de un control CoolBar.

Sintaxis

Set objeto.Child = control

objeto.Child

La sintaxis de la propiedad Child tiene estas partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto Band en la colección Bands de un control CoolBar.
control | Una expresión que da como resultado un control del objeto Band de un control CoolBar.

Comentarios

Puede establecer la propiedad Child de una banda en tiempo de diseño si selecciona un control de la lista Secundarios en la ficha Bandas de la página de propiedades del control CoolBar. En tiempo de ejecución puede recuperar el nombre del control en un objeto Band si lee el valor de la propiedad Child.

Para asignar un nuevo control secundario a una banda en tiempo de ejecución, use la palabra clave Set. Esto reemplazará el control existente en el objeto Band.


EmbossHighlight (Propiedad)

Devuelve o establece el color de resalte de una imagen mostrada en un control CoolBar.

Sintaxis

objeto.EmbossHighlight [= color]

La sintaxis de la propiedad EmbossHighlight tiene estas partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un control CoolBar.
color | Un valor o una constante que determina los colores de fondo o de primer plano de un objeto, como se describe en Valores.

Valores

Visual Basic usa la combinación de colores rojo-verde-azul (RGB) del entorno operativo Microsoft Windows. Los valores para color son:

Valor | Descripción
Colores normales RGB | Colores especificados usando la paleta de colores o mediante las funciones RGB o QBColor en el código.
Colores predeterminados del sistema | Colores especificados por las constantes de colores del sistema de la biblioteca de objetos de Visual Basic (VB) en el Examinador de objetos. El entorno operativo Windows sustituye la elección del usuario, tal como se establece en la configuración del Panel de control.

Comentarios

El valor predeterminado de la propiedad EmbossHighlight es el color predeterminado del sistema especificado por la constante vbButtonHighlight.

El intervalo válido para un color normal RGB va desde 0 a 16.777.215 (&HFFFFFF). El byte superior de un número en este intervalo es 0; los tres bytes inferiores, del menos significativo al más significativo, determinan la cantidad de rojo, verde y azul, respectivamente. Cada uno de los componentes rojo, verde y azul se representan por un número entre 0 y 255 (&HFF). Si el byte superior no es 0, Visual Basic usa los colores del sistema, tal como se definen en la configuración del Panel de control y por las constantes de la biblioteca de objetos de Visual Basic (VB) en el Examinador de objetos.

Nota Esta propiedad no afecta a la presentación de una imagen a menos que la propiedad Picture de un control CoolBar contenga una imagen válida y la propiedad EmbossPicture sea True.


EmbossPicture (Propiedad)

Devuelve o establece un valor que indica si la imagen de fondo de un control CoolBar se mostrará con dos colores o con múltiples colores.

Sintaxis

objeto.EmbossPicture [= booleano]

La sintaxis de la propiedad EmbossPicture tiene estas partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un control CoolBar.
booleano | Una expresión booleana que especifica si la imagen de fondo se muestra en dos colores o con múltiples colores.

Valores

Los valores posibles de booleano son:

Valor | Descripción
False | (Predeterminado) La imagen de fondo se muestra con múltiples colores.
True | La imagen de fondo se muestra con dos colores.

Comentarios

De forma predeterminada, la imagen de fondo de un control CoolBar se mostrará con los colores contenidos en el archivo de imagen asignado a la propiedad Picture. Cuando la propiedad EmbossPicture es True, la imagen de fondo se convierte a los dos colores especificados en las propiedades EmbossHighlight y EmbossShadow.

Nota Esta propiedad no tiene efecto hasta que la propiedad Picture de un control CoolBar contenga una imagen válida. Si la propiedad UseCoolbarPicture de un objeto Band contenido es False, esta propiedad no tiene efecto sobre este objeto Band.


EmbossShadow (Propiedad)

Devuelve o establece el color de sombra de una imagen mostrada en un control CoolBar.

Sintaxis

objeto.EmbossShadow [= color]

La sintaxis de la propiedad EmbossShadow tiene estas partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un control CoolBar.
color | Un valor o una constante que determina los colores de fondo y de primer plano de un objeto, como se describe en Valores.

Valores

Visual Basic usa la combinación de colores rojo-verde-azul (RGB) del entorno operativo de Microsoft Windows. Los valores para color son:

Valor | Descripción
Colores normales RGB | Colores especificados mediante la paleta de colores o las funciones RGB o QBColor en el código.
Colores predeterminados del sistema | Colores especificados por las constantes de colores del sistema de la biblioteca de objetos de Visual Basic (VB) en el Examinador de objetos. El entorno operativo Windows sustituye la elección del usuario, tal como se establece en la configuración del Panel de control.

Comentarios

El valor predeterminado de la propiedad EmbossShadow es el color predeterminado del sistema especificado por la constante vbButtonFace.

El intervalo válido para un color normal RGB va desde 0 a 16.777.215 (&HFFFFFF). El byte superior de un número en este intervalo es 0; los tres bytes inferiores, del menos significativo al más significativo, determinan la cantidad de rojo, verde y azul, respectivamente. Los componentes rojo, verde y azul se representan por un número entre 0 y 255 (&HFF). Si el byte superior no es 0, Visual Basic usa los colores del sistema, tal como se definen en la configuración del Panel de control y por las constantes de la biblioteca de objetos de Visual Basic (VB) en el Examinador de objetos.

Nota Esta propiedad no afecta a la presentación de una imagen a menos que la propiedad Picture de un control CoolBar contenga una imagen válida y la propiedad EmbossPicture sea True.


FixedBackground (Propiedad, objeto Band)

Devuelve o establece un valor que indica si la imagen de fondo de un control CoolBar permanece fija cuando se organizan las bandas.

Sintaxis

objeto.FixedBackground [= booleano]

La sintaxis de la propiedad FixedBackGround tiene estas partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto Band.
booleano | Una expresión booleana que especifica si la imagen de fondo está fija o se puede mover.

Valores

Los valores de booleano son:

Valor | Descripción
True | (Predeterminado) La imagen de fondo es fija.
False | La imagen de fondo no es fija.

Comentarios

El comportamiento predeterminado de la propiedad Picture de un control CoolBar es mostrar la imagen en mosaico en todas las bandas del control, usando las propiedades Top y Left del control CoolBar como origen. Si se organizan o se cambian de tamaño las bandas, la imagen se vuelve a dibujar en todas las bandas.

Cuando la propiedad FixedBackground es False, la imagen se pone en mosaico dentro de cada banda del control. Si se organizan o se cambian de tamaño las bandas, la imagen permanece fija dentro de cada banda.

Nota Esta propiedad sólo se aplica a la propiedad Picture del control CoolBar propiamente dicho. Si se asigna una imagen a la propiedad Picture de un objeto Band y la propiedad UseCoolBarPicture de esa banda es False, la propiedad FixedBackground no tiene ningún efecto sobre esa banda.


FixedOrder (Propiedad)

Devuelve o establece un valor que indica si el usuario puede cambiar el orden de las bandas de un control CoolBar en tiempo de ejecución.

Sintaxis

objeto.FixedOrder [= booleano]

La sintaxis de la propiedad FixedOrder tiene estas partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un control CoolBar.
booleano | Una expresión booleana que especifica si la banda es visible o está oculta.

Valores

Los valores posibles para booleano son:

Valor | Descripción
False | (Predeterminado) Las bandas se pueden organizar.
True | Las bandas no se pueden organizar.

Comentarios

Para arreglar la colocación de las bandas en un control CoolBar, asigne a la propiedad FixedOrder el valor True en tiempo de diseño. Esto evitará que el usuario organice las bandas mediante arrastrar y colocar. Si establece esta propiedad mediante código podrá deshabilitar o habilitar la posibilidad de organizar bandas en tiempo de ejecución en respuesta a un evento determinado. Establecer esta propiedad afecta a todas las bandas contenidas en un control CoolBar.


Image (Propiedad, objeto Band)

Devuelve o establece un valor que especifica qué objeto ListImage de un control ImageList aparecerá en un objeto Band de un control CoolBar.

Sintaxis

objeto.Image [= índice]

La sintaxis de la propiedad Image tiene estas partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto Band.
índice | Un entero o una cadena única que especifica el objeto ListImage que se usa con objeto. El entero es el valor de la propiedad Index; la cadena es el valor de la propiedad Key.

Comentarios

Antes de establecer la propiedad Image, debe asociar un control ImageList con el control CoolBar; para ello asigne a la propiedad ImageList del control CoolBar un control ImageList.

En tiempo de ejecución, la imagen contenida en el objeto ListImage especificado en la propiedad Image se mostrará en el objeto Band entre el controlador de movimiento y el título. La imagen no se muestra en tiempo de diseño.


MinHeight, MinWidth (Propiedades, objeto Band)

Devuelve o establece un valor que indica el alto o el ancho mínimo al que se puede cambiar de tamaño un objeto Band.

Sintaxis

objeto.MinHeight [= single]

objeto.MinWidth [= single]

La sintaxis de las propiedades MinHeight y MinWidth tiene estas partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto Band.
single | Un valor de signo flotante de precisión simple que indica el alto o el ancho.

Comentarios

El valor predeterminado de MinHeight es igual a la propiedad Height del control secundario del objeto Band. Puede asignar a MinHeight un valor mayor, pero no puede cambiar el tamaño de Band por debajo del valor predeterminado.

Nota Cuando la propiedad Orientation del objeto CoolBar es Vertical, MinHeight se convierte en MinWidth y MinWidth se convierte en MinHeight.


NewRow (Propiedad)

Devuelve o establece si un objeto Band se mostrará en una nueva fila del control CoolBar.

Sintaxis

objeto.NewRow [= booleano]

La sintaxis de la propiedad NewRow tiene estas partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto Band.
booleano | Una expresión booleana que especifica si la banda se mostrará en una nueva fila.

Valores

Los valores posibles de booleano son:

Valor | Descripción
False | (Predeterminado) La banda se agregará a la última fila existente.
True | La banda comenzará en una nueva fila.

Nota La propiedad NewRow no afecta al primer objeto Band de una colección Bands. El primer control Band siempre empieza en una nueva fila.


Orientation (Propiedad, control Coolbar)

Establece un valor que indica si el control CoolBar tiene orientación vertical u horizontal.

Sintaxis

objeto.Orientation [= enum]

La sintaxis de la propiedad Orientation tiene estas partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un control CoolBar.
enum | Una constante o un valor que especifica la orientación, tal como se describe en Valores.

Valores

Los posibles valores de enum son:

Constante | Valor | Descripción
cc3OrientationHorizontal | 0 | (Predeterminado) Orientación horizontal.
cc3OrientationVertical | 1 | Orientación vertical.


Picture (Propiedad, control Coolbar)

Devuelve o establece el gráfico que se mostrará en un control.

Sintaxis

objeto.Picture = LoadPicture(nombreRuta)

objeto.Picture [= imagen]

La sintaxis de la propiedad Picture tiene estas partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
nombreRuta | Una expresión de cadena que especifica la ruta y el nombre del archivo que contiene un gráfico, tal como se describe en Valores.
imagen | La propiedad Picture de un objeto Form, un control PictureBox o un control Image.

Valores

Los valores posibles para imagen son:

Valor | Descripción
(None) | (Predeterminado) Sin imagen.
(Bitmap, GIF, JPEG) | Especifica un gráfico. Puede cargar un gráfico desde la página de propiedades en tiempo de diseño. En tiempo de ejecución, puede establecer también esta propiedad mediante la función LoadPicture.

Comentarios

La propiedad Picture de un control CoolBar muestra un gráfico de fondo en todas las bandas del control CoolBar, detrás de cualquier control secundario. Cada objeto Band de un control CoolBar tiene también una propiedad Picture y una propiedad UseCoolBarPicture que se puede usar para invalidar la propiedad Picture del control.


Position (Propiedad, objeto Band)

Devuelve la posición de un objeto Band dentro de un control CoolBar.

Sintaxis

objeto.Position [= entero]

La sintaxis de la propiedad Position tiene estas partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto Band.
entero | Un entero que indica la posición actual.

Comentarios

Puede usar la propiedad Position para determinar la ubicación actual de un objeto Band dentro de un control CoolBar. Aunque la propiedad Index de un objeto Band permanece constante, el valor de Position cambia a medida que se organizan las bandas.

La propiedad Position comienza con un valor 1 para el objeto Band de la posición superior izquierda y se incrementa de izquierda a derecha y de arriba abajo cuando la orientación de CoolBar es horizontal. Cuando la orientación es vertical, Position se incrementa de arriba abajo y de izquierda a derecha.


RowCount (Propiedad, control CoolBar)

Devuelve el número de filas mostradas en un control CoolBar.

Sintaxis

objeto.RowCount [= número]

La sintaxis de la propiedad RowCount tiene estas partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un control CoolBar.
número | Un entero largo que indica el número de filas.

Comentarios

El número de filas mostradas por un control CoolBar no es necesariamente el mismo que el número de bandas, ya que es posible mostrar más de una banda en una misma fila.


Style (Propiedad, objeto Band)

Devuelve o establece un valor que indica el comportamiento de tamaño de un objeto Band en un control CoolBar.

Sintaxis

objeto.Style [= enum]

La sintaxis de la propiedad Style tiene estas partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto Band.
enum | Una constante o un valor que especifica el estilo, tal como se describe en Valores.

Valores

Los valores posibles para enum son:

Constante | Valor | Descripción
cc3BandNormal | 0 | (Predeterminado) Es posible cambiar el tamaño de la banda. El control de tamaño se muestra sólo si hay dos o más bandas en el control CoolBar.
cc3BandFixedSize | 1 | No es posible cambiar el tamaño de la banda. El control de tamaño no se muestra.


UseCoolbarColors (Propiedad)

Devuelve o establece si un objeto Band usará las propiedades ForeColor y BackColor del control CoolBar.

Sintaxis

objeto.UseCoolbarColors [= booleano]

La sintaxis de la propiedad UseCoolbarColors tiene estas partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto Band.
booleano | Una expresión booleana que especifica si la banda invalidará las propiedades ForeColor y BackColor del control CoolBar.

Valores

Los valores posibles de booleano son:

Valor | Descripción
True | (Predeterminado) Band se mostrará usando las propiedades ForeColor y BackColor del control CoolBar.
False | Band se mostrará usando sus propias propiedades ForeColor y BackColor.


UseCoolbarPicture (Propiedad)

Devuelve o establece si un objeto Band usará la propiedad Picture del control CoolBar.

Sintaxis

objeto.UseCoolbarPicture [= booleano]

La sintaxis de la propiedad UseCoolbarPicture tiene estas partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto Band.
booleano | Una expresión booleana que especifica si la propiedad Picture de la banda invalidará la propiedad Picture del control CoolBar.

Valores

Los valores posibles para booleano son:

Valor | Descripción
True | (Predeterminado) Band mostrará la propiedad Picture del control CoolBar.
False | Band mostrará su propia propiedad Picture.


VariantHeight (Propiedad)

Devuelve o establece un valor que indica si un control CoolBar muestra todas las bandas con el mismo alto.

Sintaxis

objeto.VariantHeight [= booleano]

La sintaxis de la propiedad VariantHeight tiene estas partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un control CoolBar.
booleano | Una expresión booleana que especifica si todas las bandas tienen un alto uniforme.

Valores

Los valores posibles para booleano son:

Valor | Descripción
True | (Predeterminado) El alto de las bandas puede cambiar.
False | El alto de las bandas es igual.

Comentarios

Cuando esta propiedad se establece a False, el control CoolBar mostrará todas las bandas basándose en el mayor valor de las propiedades MinHeight de todas las bandas visibles. Cuando esta propiedad se establece a True, el alto de cada banda se basa en su propia propiedad MinHeight si hay una sola banda en la fila. Si hay más de una banda en una fila, las bandas se mostrarán usando el mayor valor de la propiedad MinHeight de todas las bandas visibles de esta fila.