MAPIMessages (Control)

Los controles de la Interfaz de programación de aplicaciones de mensajería (MAPI) le permiten crear aplicaciones MAPI de Visual Basic con correo electrónico. Hay dos controles MAPI:

  • MAPISession

  • MAPIMessages

El control MAPISession inicia una sesión y establece una sesión MAPI. También se utiliza para terminar una sesión MAPI. El control MAPISession permite al usuario realizar diversas funciones del sistema de mensajería.

Los controles MAPI son invisibles en tiempo de ejecución. Además, estos controles no tienen eventos. Para usarlos, debe especificar los métodos adecuados.

Después de establecer una sesión de mensajería con el control MAPISession, el control MAPIMessages realiza diversas funciones del sistema de mensajería.

Para que los controles funcionen, deben estar presentes los servicios MAPI. Se proporcionan servicios MAPI con los sistemas de correo electrónico compatibles con MAPI.

Nota Si intenta ejecutar un programa que utiliza los controles MAPI, asegúrese de que tiene instalados correctamente los archivos DLL de MAPI de 32 bits; de lo contrario, no podrá utilizar funciones sencillas de MAPI como SignOn. Por ejemplo, en Windows 95 debe instalar Mail durante el proceso de instalación del sistema operativo o realizar después la instalación desde el Panel de control para poder usar desde Visual Basic las funciones de MAPI o los controles personalizados MAPI.

Sintaxis

MAPIMessages

Comentarios

Con el control MAPIMessages puede:

  • Tener acceso a los mensajes actuales de la Bandeja de entrada.

  • Redactar un nuevo mensaje.

  • Agregar y eliminar destinatarios de mensajes y datos adjuntos.

  • Enviar mensajes (con o sin interfaz de usuario).

  • Guardar, copiar y eliminar mensajes.

  • Mostrar el cuadro de diálogo Libreta de direcciones.

  • Mostrar el cuadro de diálogo Detalles.

  • Tener acceso a datos adjuntos, incluyendo los de Vinculación e incrustación de objetos (OLE).

  • Resolver un nombre de destinatario durante el direccionamiento.

  • Efectuar acciones de responder, responder a todos y reenviar mensajes.

La mayoría de las propiedades del control MAPIMessages pueden agruparse en cuatro áreas funcionales: libreta de direcciones, archivos adjuntos, mensajes y destinatarios. Las propiedades de archivos adjuntos, mensajes y destinatarios están controladas por las propiedades AttachmentIndex, MsgIndex y RecipIndex, respectivamente.

Búferes de mensajes

Cuando se utiliza el control MAPIMessages es necesario hacer un seguimiento de los dos búferes, el búfer de redacción y el búfer de lectura. El búfer de lectura consta de un conjunto indizado de mensajes traídos de la Bandeja de entrada del usuario. Se utiliza la propiedad MsgIndex para tener acceso a mensajes individuales dentro de este conjunto, empezando con un valor 0 para el primer mensaje e incrementando en uno cada mensaje hasta llegar al final del conjunto.

El conjunto de mensajes se crea mediante el método Fetch. El conjunto incluye todos los mensajes del tipo FetchMsgType y se ordena según lo especificado en la propiedad FetchSorted. Los mensajes leídos previamente pueden incluirse o dejarse fuera del conjunto de mensajes mediante la propiedad FetchUnreadOnly. El usuario no puede modificar los mensajes que hay en el búfer de lectura, pero puede copiarlos al búfer de redacción para modificarlos.

Es posible crear o modificar mensajes en el búfer de redacción. El búfer de redacción es el búfer activo cuando la propiedad MsgIndex tiene el valor – 1. Muchas de las acciones de mensajería sólo son válidas dentro del búfer de redacción, como enviar mensajes, enviar mensajes con un cuadro de diálogo, guardar mensajes o eliminar destinatarios y datos adjuntos.

Vea la biblioteca de objetos en el Examinador de objetos para obtener las constantes de propiedades y de error para el control.


MAPISession (Control)

Los controles de la Interfaz de programación de aplicaciones de mensajería (MAPI) le permiten crear aplicaciones MAPI de Visual Basic con correo electrónico. Hay dos controles MAPI:

  • MAPISession

  • MAPIMessages

El control MAPISession inicia y establece una sesión MAPI. También se utiliza para terminar una sesión MAPI. El control MAPIMessages permite al usuario realizar una gran variedad de funciones del sistema de mensajería.

Sintaxis

MAPISession

Comentarios

Después de completar correctamente el inicio de sesión, la propiedad SessionID contiene el controlador para la sesión MAPI. Es necesario pasar el controlador de sesión al control MAPIMessages; de lo contrario, se producirá un error al usar el control MAPIMessages.

El control MAPISession no es visible en tiempo de ejecución. Además, el control no tiene eventos. Para usarlo, debe especificar las propiedades y los métodos apropiados.

Para que los controles funcionen, deben estar presentes los servicios MAPI. Se proporcionan servicios MAPI con los sistemas de correo electrónico compatibles con MAPI.

Nota Si intenta ejecutar un programa que usa los controles MAPI, asegúrese de que tiene instaladas correctamente los archivos DLL de MAPI de 32 bits; de lo contrario, no podrá utilizar funciones MAPI sencillas como SignOn. Por ejemplo, en Windows 95 debe instalar Exchange durante el proceso de instalación del sistema operativo o realizar después la instalación desde el Panel de control para poder usar correctamente desde Visual Basic las funciones MAPI o los controles personalizados MAPI.


No se encuentra el tema

No se halló el tema correspondiente. A continuación enumeramos algunas posibles razones y sus soluciones:

  • El archivo (.chm) que contiene el tema de destino no se encuentra en la ubicación esperada.

    Solución: vuelva a ejecutar la instalación de la Biblioteca MSDN.

  • El archivo (.chm) que contiene el tema actual o el de destino no está actualizado y el vínculo ya no es válido.

    Solución: instale la última versión de la Biblioteca MSDN.

  • El CD de la Biblioteca MSDN no está en la unidad de CD-ROM.

    Solución: inserte el CD en la unidad.


Mensajes de error (Controles MAPI)

En la tabla siguiente se indican los errores interceptables en los controles MAPI.

Constante | Valor | Descripción
mapSuccessSuccess | 32000 | Acción concluida con éxito.
mapUserAbort | 32001 | Proceso cancelado por el usuario.
 |  | No se completó la acción actual porque el usuario canceló el proceso.
mapFailure | 32002 | Ocurrió un fallo no determinado.
 |  | Se ha producido un error no especificado durante la acción actual. Por ejemplo, la acción no pudo eliminar o dirigir correo correctamente.
mapLoginFail | 32003 | Falló el inicio de sesión.
 |  | No había inicio de sesión predeterminado y el usuario no pudo iniciar la sesión correctamente.
mapDiskFull | 32004 | Disco lleno.
 |  | El disco está lleno. La acción actual no ha podido crear un archivo en el disco.
mapInsufficientMem | 32005 | No hay suficiente memoria.
 |  | No hay memoria suficiente para realizar la acción actual.
mapAccessDenied | 32006 | Acceso denegado.
mapGeneralFailure | 32007 | Fallo general.
 |  | Es un error sin especificar.
mapTooManySessions | 32008 | Demasiadas sesiones abiertas.
 |  | El usuario tiene demasiadas sesiones abiertas a la vez.
mapTooManyFiles | 32009 | Hay demasiados archivos.
 |  | El mensaje contiene demasiados archivos adjuntos. El correo no se ha enviado o no se ha leído.
mapTooManyRecipients | 32010 | Hay demasiados destinatarios.
 |  | Hay especificados demasiados destinatarios para el mensaje. El correo no se ha enviado o no se ha leído.
mapAttachmentNotFound | 32011 | No se encontró el adjunto.
 |  | No se ha encontrado el adjunto especificado y no se ha enviado el correo.
mapAttachmentOpenFailure | 32012 | Error al abrir el adjunto.
 |  | No se ha podido encontrar el adjunto. El correo no se ha enviado. Compruebe si la propiedad AttachmentPathName es válida.
mapAttachmentWriteFailure | 32013 | Error al intentar escribir un adjunto.
 |  | No se ha podido escribir un adjunto en un archivo temporal. Compruebe los permisos de los directorios.
mapUnknownRecipient | 32014 | Destinatario desconocido.
 |  | El destinatario no aparece en la lista de direcciones. No se ha enviado el correo.
mapBadRecipType | 32015 | Tipo de destinatario no válido.
 |  | El tipo de destinatario no es correcto. Los valores válidos para el tipo son 1 (destinatario principal), 2 (destinatario de copia) y 3 (destinatario de copia oculta).
mapNoMessages | 32016 | No hay mensajes.
 |  | No se puede encontrar el mensaje siguiente.
mapInvalidMessage | 32017 | El mensaje no es válido.
 |  | Se ha utilizado un Id. de mensaje no válido. No se ha completado la acción actual.
mapTextTooLarge | 32018 | Texto demasiado extenso.
 |  | El texto del mensaje es demasiado extenso para su envío. No se ha enviado el correo. El límite del texto es 32 KB.
mapInvalidSession | 32019 | Sesión no válida.
 |  | Se ha utilizando un Id. de sesión no válido. Para asociar el control de mensajes MAPI a una sesión de mensajes válida, establezca la propiedad SessionID en el Id. del control de la sesión MAPI.
mapTypeNotSupported | 32020 | Tipo no admitido.
mapAmbiguousRecipient | 32021 | Destinatario ambiguo.
 |  | Una o más direcciones de destinatarios no son válidas. Asegúrese de que las direcciones de la propiedad RecipAddress son válidas.
mapMessageInUse | 32022 | El mensaje está en uso.
mapNetworkFailure | 32023 | Fallo en la red.
mapInvalidEditFields | 32024 | Campos de edición no válidos.
 |  | El valor de la propiedad AddressEditFieldCount no es válido. Los valores válidos son de 0 a 4.
mapInvalidRecips | 32025 | Destinatarios no válidos.
 |  | Una o más direcciones de destinatarios no son válidas. Asegúrese de que las direcciones de la propiedad RecipAddress son válidas.
mapNotSupported | 32026 | No compatible.
 |  | El sistema de correo subyacente no admite la acción actual.
mapSessionExist | 32050 | Error de inicio de sesión: ya existe el Id. de sesión válido.
 |  | El control de mensajes MAPI ya está utilizando un Id. de sesión válido.
mapInvalidBuffer | 32051 | La propiedad es de sólo lectura cuando no se usa el búfer de edición. Establezca MsgIndex = –1.
mapInvalidReadBufferAction | 32052 | La acción sólo es válida para el búfer de redacción. Establezca MsgIndex = –1.
mapNoSession | 32053 | Error de MAPI: no existe un Id. de sesión válido.
 |  | El control de mensajes MAPI no tiene un controlador de sesión válido del control de sesión MAPI.
mapInvalidRecipient | 32054 | No hay creador en el búfer de redacción.
 |  | No puede ver la información del creador del mensaje en el búfer de redacción (MsgIndex tiene el valor –1).
mapInvalidComposeBufferAction | 32055 | Acción no válida en el búfer de redacción.
 |  | La acción que ha intentado no es válida en el búfer de redacción (MsgIndex tiene el valor –1).
mapControlFailure | 32056 | Imposible realizar la acción; no hay mensajes en la lista.
mapNoRecipients | 32057 | Imposible realizar la acción; no hay destinatarios.
mapNoAttachment | 32058 | Imposible realizar la acción; no hay adjuntos.


Constantes del control MAPI

Constantes de acción de MAPISession

Constante | Valor | Descripción
mapSignOn | 1 | Inicia una sesión de usuario con una cuenta
mapSignOff | 2 | Finaliza una sesión de mensajería

Constantes de eliminación de MAPIMESSAGES

Constante | Valor | Descripción
mapMessageDelete | 0 | Elimina el mensaje actual
mapRecipientDelete | 1 | Elimina el destinatario indizado actualmente
mapAttachmentDelete | 2 | Elimina el dato adjunto indizado actualmente

Constantes de error para los controles MAPI

Constante | Valor | Descripción
mapSuccessSuccess | 32000 | La acción ha terminado correctamente
mapUserAbort | 32001 | El usuario ha cancelado el proceso
mapFailure | 32002 | Error no especificado
mapLoginFail | 32003 | Error al iniciar la sesión
mapDiskFull | 32004 | Disco lleno
mapInsufficientMem | 32005 | Memoria insuficiente
mapAccessDenied | 32006 | Acceso denegado
mapGeneralFailure | 32007 | Error general
mapTooManySessions | 32008 | Demasiadas sesiones
mapTooManyFiles | 32009 | Demasiados archivos
mapTooManyRecipients | 32010 | Demasiados destinatarios
mapAttachmentNotFound | 32011 | No se encontró el dato adjunto
mapAttachmentOpenFailure | 32012 | Error al abrir el dato adjunto
mapAttachmentWriteFailure | 32013 | Error al escribir el dato adjunto
mapUnknownRecipient | 32014 | Destinatario desconocido
mapBadRecipType | 32015 | Tipo de destinatario no válido
mapNoMessages | 32016 | No hay mensajes
mapInvalidMessage | 32017 | Mensaje no válido
mapTextTooLarge | 32018 | Texto demasiado grande
mapInvalidSession | 32019 | Sesión no válida
mapTypeNotSupported | 32020 | Tipo no compatible
mapAmbiguousRecipient | 32021 | Destinatario ambiguo
mapMessageInUse | 32022 | Mensaje en uso
mapNetworkFailure | 32023 | Error en la red
mapInvalidEditFields | 32024 | Campos de edición no válidos
mapInvalidRecips | 32025 | Destinatarios no válidos
mapNotSupported | 32026 | La acción actual no está permitida
mapSessionExist | 32050 | El Id. de sesión ya existe
mapInvalidBuffer | 32051 | Sólo lectura en el búfer de lectura
mapInvalidReadBufferAction | 32052 | Sólo es válido en el búfer de redacción
mapNoSession | 32053 | Id. de sesión no válido
mapInvalidRecipient | 32054 | Información de destinatario no disponible
mapInvalidComposeBufferAction | 32055 | Acción no válida para el búfer de redacción
mapControlFailure | 32056 | No hay mensajes en la lista
mapNoRecipients | 32057 | No hay destinatarios
mapNoAttachment | 32058 | No hay datos adjuntos

Constantes de tipo de destinatario para MAPIMessages

Constante | Valor | Descripción
mapOrigList | 0 | Remitente del mensaje
mapToList | 1 | El destinatario es primario
mapCcList | 2 | El destinatario está en la copia
mapBccList | 3 | El destinatario tiene copia oculta

Constantes de tipo de dato adjunto para MAPIMessages

Constante | Valor | Descripción
mapData | 0 | El dato adjunto es un archivo de datos
mapEOLE | 1 | El dato adjunto es un objeto OLE incrustado
mapSOLE | 2 | El dato adjunto es un objeto OLE estático


Compose (Método)

Redacta un mensaje.

Sintaxis

objeto.Compose

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.

Comentarios

Este método borra todos los componentes del búfer de redacción y asigna a la propiedad MsgIndex el valor -1.


Copy (Método, control MAPIMessages)

Copia el mensaje indizado actualmente al búfer de redacción.

Sintaxis

objeto.Copy

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.

Comentarios

Este método asigna a la propiedad MsgIndex el valor -1.


Delete (Método, control MAPIMessages)

Elimina un mensaje, un destinatario o un dato adjunto.

Sintaxis

objeto.Delete [ valor ]

La sintaxis del método Delete consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
valor | Una expresión de tipo Integer que especifica el elemento que se va a eliminar, como se describe en Valores.

Valores

Los valores admitidos para valor son:

Constante | Valor | Descripción
mapMessageDelete | 0 | Elimina todos los componentes del mensaje indizado actualmente, reduce la propiedad MsgCount en 1 y reduce el número de índice en 1 para cada mensaje que haya a continuación del mensaje eliminado.
 |  | Si el mensaje eliminado era el último del conjunto, este método reduce la propiedad MsgIndex en 1.
mapRecipientDelete | 1 | Elimina el destinatario indizado actualmente. Reduce automáticamente la propiedad RecipCount en 1 y reduce el número de índice en 1 para cada destinatario que haya a continuación del destinatario eliminado.
 |  | Si el destinatario eliminado era el último del conjunto, este método reduce la propiedad RecipIndex en 1.
mapAttachmentDelete | 2 | Elimina el dato adjunto indizado actualmente. Reduce automáticamente la propiedad AttachmentCount en 1 y reduce el número de índice en 1 para cada dato adjunto que haya a continuación del dato adjunto eliminado.
 |  | Si el dato adjunto eliminado era el último del conjunto, este método reduce la propiedad AttachmentIndex en 1.


Fetch (Método)

Crea un conjunto de mensajes a partir de los mensajes seleccionados en la Bandeja de entrada.

Sintaxis

objeto.Fetch

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.

Comentarios

El conjunto de mensajes incluye todos los mensajes de la Bandeja de entrada que son de los tipos especificados por la propiedad FetchMsgType. Se ordenan según se especifica en la propiedad FetchSorted. Si la propiedad FetchUnreadOnly tiene el valor True, en el conjunto de mensajes sólo se incluirán los mensajes no leídos.

Todos los archivos adjuntos del búfer de lectura se eliminan cuando ocurre la siguiente acción de recuperación.


Forward (Método)

Reenvía un mensaje.

Sintaxis

objeto.Forward

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.

Comentarios

Este método copia el mensaje indizado actualmente al búfer de redacción como un mensaje reenviado y agrega RV: al principio de la línea Asunto. También asigna a la propiedad MsgIndex el valor -1.


Reply (Método)

Responde a un mensaje.

Sintaxis

objeto.Reply

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.

Comentarios

Este método copia el mensaje indizado actualmente al búfer de redacción y agrega RE: al comienzo de la línea Asunto. También asigna a la propiedad MsgIndex el valor -1.

El remitente del mensaje indizado actualmente se convierte en el destinatario del mensaje saliente.


ReplyAll (Método)

Responde a todos los destinatarios del mensaje.

Sintaxis

objeto.ReplyAll

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.

Comentarios

Este método copia el mensaje indizado actualmente al búfer de redacción y agrega RE: al principio de la línea Asunto. También asigna a la propiedad MsgIndex el valor -1.

El mensaje se envía al remitente del mensaje indizado actualmente y a todos los destinatarios incluidos en las líneas Para: y CC:.


ResolveName (Método)

Resuelve el nombre del destinatario indizado actualmente.

Sintaxis

objeto.ResolveName

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.

Comentarios

Este método busca en la Libreta de direcciones una coincidencia con el nombre del destinatario indizado actualmente. Si no se encuentra ninguna coincidencia, se devuelve un error. No proporciona resolución adicional del nombre o la dirección del remitente del mensaje.

La propiedad AddressResolveUI determina si se presenta o no un cuadro de diálogo para resolver nombres ambiguos.

Este método puede provocar cambios en la propiedad RecipType.


Save (Método)

Guarda el mensaje que hay actualmente en el búfer de redacción (con MsgIndex = -1).

Sintaxis

objeto.Save

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.


Send (Método)

Envía un mensaje.

Sintaxis

objeto.Send [ valor ]

La sintaxis del método Send consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
valor | Una expresión booleana que especifica si se muestra o no el cuadro de diálogo, como se describe en Valores.

Valores

Los valores admitidos para valor son:

Valor | Descripción
True | Envía un mensaje dentro de un cuadro de diálogo. Pide al usuario los diversos componentes del mensaje y entrega el mensaje al servidor de correo para su distribución.
 | Todas las propiedades asociadas con el mensaje que se está creando en el búfer de redacción forman la base para el cuadro de diálogo del mensaje. Sin embargo, los cambios realizados en el cuadro de diálogo no alteran la información contenida en el búfer de redacción.
False | (Predeterminado) Envía el mensaje saliente al servidor de correo sin presentar un cuadro de diálogo. Se producirá un error si intenta enviar un mensaje sin destinatarios o sin los nombres de las rutas de acceso a los datos adjuntos.


Show (Método, control MAPIMessages)

Presenta el cuadro de diálogo Libreta de direcciones o los detalles del destinatario indizado actualmente.

Sintaxis

objeto.Show [ valor ]

La sintaxis del método Show consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
valor | Una expresión booleana que especifica el tipo del cuadro de diálogo, como se describe en Valores.

Valores

Los valores admitidos para valor son:

Valor | Descripción
True | Presenta un cuadro de diálogo que muestra los detalles del destinatario indizado actualmente. La cantidad de información presentada en el cuadro de diálogo está determinada por el sistema de mensajería. Como mínimo, contiene el nombre y la dirección del destinatario.
False | (Predeterminado) Presenta el cuadro de diálogo Libreta de direcciones. Puede usar la Libreta de direcciones para crear o modificar un conjunto de destinatarios. Cualquier cambio que realice a la Libreta de direcciones fuera del búfer de redacción no se guardará.


SignOff (Método)

Finaliza la sesión de mensajería y desconecta al usuario de la cuenta especificada por las propiedades UserName y Password.

Sintaxis

objeto.SignOff

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.


SignOn (Método)

Conecta al usuario con la cuenta especificada por las propiedades UserName y Password, y proporciona un controlador de sesión al subsistema de mensajería subyacente.

Sintaxis

objeto.SignOn

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.

Comentarios

El controlador de sesión se almacena en la propiedad SessionID. Dependiendo del valor de la propiedad NewSession, el controlador de sesión se puede referir a una sesión recién creada o a una existente.


Action (Propiedad, control MAPIMessages)

Determina qué acción se realiza cuando se invoca el control MAPIMessages. Esta propiedad no está disponible en tiempo de diseño. Al establecer la propiedad Action en tiempo de ejecución se invoca el control. Esta propiedad es de sólo escritura en tiempo de ejecución.

Nota La propiedad Action se incluye por compatibilidad con versiones anteriores de Visual Basic. Para obtener funcionalidad adicional, utilice los nuevos métodos enumerados en la tabla Métodos para el control MAPIMessages.

Sintaxis

objeto.Action [ = valor ]

La sintaxis de la propiedad Action consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
valor | Una expresión de tipo Integer que indica la acción que se va a realizar.

Comentarios

La siguiente tabla enumera los valores de la propiedad Action usados por compatibilidad con versiones anteriores y los nuevos métodos correspondientes.

Valor de la propiedad Action | Método correspondiente
MESSAGE_FETCH | Método Fetch
MESSAGE_SENDDLG | Método Send
MESSAGE_SEND | Método Send
MESSAGE_SAVEMSG | Método Save
MESSAGE_COPY | Método Copy
MESSAGE_COMPOSE | Método Compose
MESSAGE_REPLY | Método Reply
MESSAGE_REPLYALL | Método ReplyAll
MESSAGE_FORWARD | Método Forward
MESSAGE_DELETE | Método Delete
MESSAGE_SHOWADBOOK | Método Show
MESSAGE_SHOWDETAILS | Método Show
MESSAGE_RESOLVENAME | Método ResolveName
RECIPIENT_DELETE | Método Delete
ATTACHMENT_DELETE | Método Delete

Tipo de datos

Integer


Action (Propiedad, control MAPISession)

Determina qué acción se realiza cuando se invoca un control MAPISession. Esta propiedad no está disponible en tiempo de diseño. Al establecer la propiedad Action en tiempo de ejecución se invoca el control. La propiedad Action es de sólo escritura en tiempo de ejecución.

Nota La propiedad Action se incluye por compatibilidad con versiones anteriores de Visual Basic. Para obtener funcionalidad adicional, utilice los nuevos métodos enumerados en la tabla Métodos para el control MAPISession.

Sintaxis

objeto.Action [ = valor ]

La sintaxis de la propiedad Action consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
valor | Una expresión booleana que especifica la acción que se va a realizar, como se describe en Valores.

Valores

Los valores admitidos para valor son:

Constante | Valor | Descripción
mapSignOn | 1 | Conecta al usuario en la cuenta especificada por las propiedades UserName y Password, y proporciona un controlador de sesión para el subsistema de mensajes subyacente. El controlador de sesión se almacena en la propiedad SessionID. Dependiendo del valor de la propiedad NewSession, el controlador de sesión puede referirse a una sesión recién creada o a una sesión existente.
mapSignOff | 2 | Finaliza la sesión de mensajería y desconecta al usuario de la cuenta especificada.

Comentarios

Esta propiedad se utiliza para seleccionar entre la conexión o desconexión de una sesión de mensajería. Al conectarse, se devuelve un controlador de sesión a la propiedad SessionID.

Tipo de datos

Integer


AddressCaption (Propiedad)

Especifica el título que aparece en la parte superior del cuadro de diálogo Libreta de direcciones cuando se especifica el método Show con el argumento valor False o sin especificar.

Sintaxis

objeto.AddressCaption [ = valor ]

La sintaxis de la propiedad AddressCaption consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
valor | Una expresión de cadena que especifica el título del cuadro de diálogo Libreta de direcciones.

Comentarios

Si esta propiedad es una cadena nula o vacía, se usará el valor predeterminado de la Libreta de direcciones.

Tipo de datos

String


AddressEditFieldCount (Propiedad)

Especifica el número de controles de edición que se van a mostrar al usuario en el cuadro de diálogo Libreta de direcciones cuando el método Show se especifica sin el argumento valor o con dicho argumento establecido a False.

Sintaxis

objeto.AddressEditFieldCount [ = valor ]

La sintaxis de la propiedad AddressEditFieldCount consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
valor | Una expresión de tipo Integer que especifica los controles de edición que se mostrarán, como se describe en Valores.

Valores

Los valores admitidos para valor son:

Valor | Descripción
0 | Sin controles de edición; sólo está permitido examinar.
1 | (Predeterminado) Sólo el control de edición Para debe estar presente en el cuadro de diálogo.
2 | Los controles de edición Para y CC (copia) deben estar presentes en el cuadro de diálogo.
3 | Los controles de edición Para, CC (copia) y CCO (copia oculta) deben estar presentes en el cuadro de diálogo.
4 | Sólo los controles de edición compatibles con el sistema de mensajes deben estar presentes en el cuadro de diálogo.

Comentarios

Por ejemplo, si AddressEditFieldCount es 3, el usuario puede seleccionar los controles de edición Para, CC y CCO en el cuadro de diálogo Libreta de direcciones. El valor de AddressEditFieldCount se ajusta de forma que sea, al menos, el número mínimo de controles de edición requeridos por el conjunto de destinatarios.

Tipo de datos

Integer


AddressLabel (Propiedad)

Especifica la apariencia del control de edición Para en la Libreta de direcciones cuando se especifica el método Show sin el argumento valor o como False.

Sintaxis

objeto.AddressLabel [ = valor ]

La sintaxis de la propiedad AddressLabel consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
valor | Una expresión de cadena que especifica una etiqueta de dirección.

Comentarios

Esta propiedad se suele pasar por alto y debe contener una cadena vacía para usar la etiqueta predeterminada "Para". Sin embargo, cuando la propiedad AddressEditFieldCount es 1, el usuario tiene la opción de especificar explícitamente otra etiqueta (siempre y cuando el número de controles de edición requerido por el conjunto de destinatarios sea igual a 1).

Tipo de datos

String


AddressModifiable (Propiedad)

Especifica si es posible modificar la Libreta de direcciones.

Sintaxis

objeto.AddressModifiable [ = valor ]

La sintaxis de la propiedad AddressModifiable consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
valor | Una expresión booleana que especifica cómo se puede modificar la Libreta de direcciones, como se describe en Valores.

Valores

Los valores admitidos para valor son:

Valor | Descripción
True | El usuario puede modificar su Libreta personal de direcciones.
False | (Predeterminado) El usuario no puede modificar su Libreta personal de direcciones.

Tipo de datos

Boolean


AddressResolveUI (Propiedad)

Especifica si se presenta o no un cuadro de diálogo para la resolución del nombre del destinatario durante el direccionamiento, cuando se ha especificado el método ResolveName.

Sintaxis

objeto.AddressResolveUI [ = valor ]

La sintaxis de la propiedad AddressResolveUI consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
valor | Una expresión booleana que especifica si se muestra o no un cuadro de diálogo, como se describe en Valores.

Valores

Los valores admitidos para valor son:

Valor | Descripción
True | Se presenta un cuadro de diálogo con nombres parecidos al nombre del destinatario propuesto.
False | (Predeterminado) No se presenta un cuadro de diálogo para los nombres ambiguos. Se producirá un error si no se encuentran posibles coincidencias (que no existan coincidencias no es una situación ambigua).

Tipo de datos

Boolean


AttachmentCount (Propiedad)

Devuelve el número total de datos adjuntos asociados con el mensaje indizado actualmente. Esta propiedad no está disponible en tiempo de diseño y es de sólo lectura en tiempo de ejecución.

Sintaxis

objeto.AttachmentCount

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.

Comentarios

El valor predeterminado es 0. El valor de AttachmentCount depende del número de datos adjuntos que haya en el mensaje indizado actual.

Tipo de datos

Long


AttachmentIndex (Propiedad)

Establece el dato adjunto indizado actualmente. Esta propiedad no está disponible en tiempo de diseño.

Sintaxis

objeto.AttachmentIndex [ = valor ]

La sintaxis de la propiedad AttachmentIndex consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
valor | Una expresión de tipo Long que especifica el dato adjunto indizado.

Comentarios

Especifica un número de índice para identificar un determinado mensaje adjunto. El número de índice de esta propiedad determina los valores de las propiedades AttachmentName, AttachmentPathName, AttachmentPosition y AttachmentType. El dato adjunto identificado por la propiedad AttachmentIndex se llama el dato adjunto indizado actualmente. El valor de AttachmentIndex puede ir de 0 (el valor predeterminado) a AttachmentCount -1.

Para agregar un nuevo dato adjunto, asigne a AttachmentIndex un valor mayor o igual que el número de datos adjuntos actual mientras esté en el búfer de redacción (MsgIndex = -1). La propiedad AttachmentCount se actualiza automáticamente para reflejar el nuevo número de datos adjuntos.

Por ejemplo, si la propiedad AttachmentCount actual tiene el valor 3, al asignar a la propiedad AttachmentIndex el valor 4 se agregan dos nuevos datos adjuntos y se incrementa la propiedad AttachmentCount a 5.

Para eliminar un dato adjunto existente, especifique el método Delete con 2 en el parámetro valor. Los datos adjuntos sólo se pueden agregar o eliminar cuando la propiedad MsgIndex tiene el valor -1.

Tipo de datos

Long


AttachmentName (Propiedad)

Especifica el nombre del archivo adjunto indizado actualmente. Esta propiedad no está disponible en tiempo de diseño. Es de sólo lectura a menos que MsgIndex tenga el valor -1.

Sintaxis

objeto.AttachmentName [ = valor ]

La sintaxis de la propiedad AttachmentName consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
valor | Una expresión de cadena que especifica el nombre del archivo adjunto indizado actualmente.

Comentarios

El nombre de archivo especificado es el nombre de archivo que ven los destinatarios del mensaje indizado actualmente. Si AttachmentName es una cadena vacía, se usará el nombre de archivo de la propiedad AttachmentPathName.

Si el dato adjunto es un objeto OLE, AttachmentName contiene el nombre de clase del objeto; por ejemplo, "Hoja de cálculo de Microsoft Excel".

Los datos adjuntos del búfer de lectura se eliminan cuando ocurre la siguiente acción de recuperación. El valor de AttachmentName depende del mensaje indizado actualmente, según lo seleccionado por la propiedad AttachmentIndex.

Tipo de datos

String


AttachmentPathName (Propiedad)

Especifica el nombre completo de la ruta de acceso al dato adjunto indizado actualmente. Esta propiedad no está disponible en tiempo de diseño. Es de sólo lectura a menos que MsgIndex tenga el valor -1.

Sintaxis

objeto.AttachmentPathName [ = valor ]

La sintaxis de la propiedad AttachmentPathName consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
valor | Una expresión de cadena que especifica el nombre completo de la ruta de acceso al archivo adjunto indizado actualmente.

Comentarios

Si intenta enviar un mensaje con una cadena vacía como nombre de ruta, se producirá un error. Los datos adjuntos del búfer de lectura se eliminan cuando tiene lugar la siguiente acción de recuperación. Los datos adjuntos del búfer de redacción deben eliminarse manualmente. El valor de AttachmentPathName depende del mensaje indizado actualmente, como queda establecido en la propiedad AttachmentIndex.

Tipo de datos

String


AttachmentPosition (Propiedad)

Especifica la posición del dato adjunto indizado actualmente dentro del cuerpo del mensaje. Esta propiedad no está disponible en tiempo de diseño. Es de sólo lectura a menos que MsgIndex tenga el valor 1.

Sintaxis

objeto.AttachmentPosition [ = valor ]

La sintaxis de la propiedad AttachmentPosition consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
valor | Una expresión de tipo Long que indica la posición del dato adjunto indizado actualmente.

Comentarios

Para determinar dónde poner un dato adjunto, cuente los caracteres que hay en el cuerpo del mensaje y decida qué posición de carácter desea reemplazar con el dato adjunto. Deberá usarse el número de posición de ese carácter para el valor de AttachmentPosition.

Por ejemplo, en el cuerpo de un mensaje que tenga una longitud de cinco caracteres podría poner un dato adjunto al final del mensaje si asigna a AttachmentPosition el valor 4. (El cuerpo del mensaje ocupa las posiciones desde el carácter 0 hasta el 4.)

No puede poner dos datos adjuntos en la misma posición dentro del mismo mensaje. Además, no puede poner un dato adjunto más allá del final del cuerpo del mensaje.

El valor de AttachmentPosition depende del mensaje indizado actualmente, según establece la propiedad AttachmentIndex.

Tipo de datos

Long


AttachmentType (Propiedad)

Especifica el tipo de archivo adjunto indizado actualmente. Esta propiedad no está disponible en tiempo de diseño. Es de sólo lectura a menos que MsgIndex tenga el valor -1.

Sintaxis

objeto.AttachmentType [ = valor ]

La sintaxis de la propiedad AttachmentType consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
valor | Una expresión de tipo Integer que especifica el tipo del archivo adjunto indizado actualmente, como se describe en Valores.

Valores

Los valores admitidos para valor son:

Constante | Valor | Descripción
mapData | 0 | El dato adjunto es un archivo de datos.
mapEOLE | 1 | El dato adjunto es un objeto OLE incrustado.
mapSOLE | 2 | El dato adjunto es un objeto OLE estático.

Comentarios

El valor de AttachmentType depende del mensaje indizado actualmente, según lo seleccionado por la propiedad AttachmentIndex.

Tipo de datos

Integer


DownloadMail (Propiedad)

Especifica cuándo se descargan los mensajes nuevos desde el servidor de correo para el usuario designado.

Sintaxis

objeto.DownloadMail [ = valor ]

La sintaxis de la propiedad DownloadMail consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
valor | Una expresión booleana que especifica cuándo se descarga el correo nuevo, como se describe en Valores.

Valores

Los valores admitidos para valor son:

Valor | Descripción
True | (Predeterminado) Todos los mensajes nuevos del servidor de correos se desvían a la Bandeja de entrada del usuario durante el proceso de inicio de sesión.
False | Los nuevos mensajes del servidor no se desvían inmediatamente a la Bandeja de entrada del usuario, sino que se descargan en el intervalo de tiempo establecido por el usuario.

Comentarios

Puede asignar a esta propiedad el valor True cuando desee tener acceso a todos los mensajes del usuario cuando inicia la sesión. Sin embargo, como resultado puede incrementarse el tiempo de procesamiento.

Tipo de datos

Boolean


FetchMsgType (Propiedad)

Especifica el tipo de mensajes para llenar el conjunto de mensajes.

Sintaxis

objeto.FetchMsgType [ = valor ]

La sintaxis de la propiedad FetchMsgType consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
valor | Una expresión de cadena que especifica el tipo de mensaje.

Comentarios

Esta propiedad determina qué tipos de mensajes se agregan al conjunto de mensajes cuando se especifica el método Fetch. Una cadena nula o vacía en esta propiedad especifica un tipo de mensaje interpersonal (IPM), que es el predeterminado.

Nota La disponibilidad de otros tipos de mensajes además de IPM depende de su sistema de correo. Vea la documentación del mismo para obtener más detalles.

Tipo de datos

String


FetchSorted (Propiedad)

Especifica el orden de los mensajes cuando se llena el conjunto de mensajes con mensajes procedentes de la Bandeja de entrada.

Sintaxis

objeto.FetchSorted [ = valor ]

La sintaxis de la propiedad FetchSorted consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
valor | Una expresión booleana que especifica el orden de los mensajes, como se describe en Valores.

Valores

Los valores admitidos para valor son:

Valor | Descripción
True | Los mensajes se agregan al conjunto de mensajes en el orden en que se reciben (primero en entrar, primero en salir).
False | (Predeterminado) Los mensajes se agregan en el orden especificado en la Bandeja de entrada del usuario.

Tipo de datos

Boolean


FetchUnreadOnly (Propiedad)

Determina si se deben restringir los mensajes del conjunto únicamente a los mensajes no leídos.

Sintaxis

objeto.FetchUnreadOnly [ = valor ]

La sintaxis de la propiedad FetchUnreadOnly consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
valor | Una expresión booleana que especifica si se van a restringir mensajes del conjunto de mensajes, como se describe en Valores.

Valores

Los valores admitidos para valor son:

Valor | Descripción
True | (Predeterminado) Sólo se agregan al conjunto de mensajes los mensajes no leídos del tipo especificado en la propiedad FetchMsgType.
False | Se agregan todos los mensajes del tipo correcto que haya en la Bandeja de entrada.

Tipo de datos

Boolean


LogonUI (Propiedad)

Especifica si se presentará o no un cuadro de diálogo para iniciar la sesión.

Sintaxis

objeto.LogonUI [ = valor ]

La sintaxis de la propiedad LogonUI consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
valor | Una expresión booleana que especifica si se muestra o no un cuadro de diálogo de inicio de sesión, como se describe en Valores.

Valores

Los valores admitidos para valor son:

Valor | Descripción
True | (Predeterminado) Un cuadro de diálogo pregunta a los nuevos usuarios su nombre de usuario y su contraseña (a menos que ya exista una sesión de mensajería válida). Vea la propiedad NewSession para obtener más información.
False | No presenta ningún cuadro de diálogo.

Comentarios

El valor False es útil cuando desea comenzar una sesión de correo sin intervención del usuario, y ya tiene el nombre de la cuenta y la contraseña del usuario. Sin embargo, si los valores suministrados son insuficientes o incorrectos, se generará un error.

Tipo de datos

Boolean


MsgCount (Propiedad)

Devuelve el número total de mensajes presentes en el conjunto de mensajes durante la sesión actual de mensajería. Esta propiedad no está disponible en tiempo de diseño y es de sólo lectura en tiempo de ejecución.

Sintaxis

objeto.MsgCount

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.

Comentarios

Esta propiedad se utiliza para obtener el número actual de mensajes que hay en el conjunto de mensajes. El valor predeterminado es 0. Esta propiedad se restablece cada vez que se realiza una acción de recuperación.

Tipo de datos

Long


MsgConversationID (Propiedad)

Especifica el valor de identificación de la secuencia de conversación para el mensaje indizado actualmente. Es de sólo lectura a menos que MsgIndex tenga el valor –1.

Sintaxis

objeto.MsgConversationID [ = valor ]

La sintaxis de la propiedad MsgConversationID consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
valor | Una expresión de cadena que especifica el valor de identificación de la conversación.

Comentarios

Se utiliza una secuencia de conversación para identificar un conjunto de mensajes comenzando con el mensaje original e incluyendo todas las respuestas subsiguientes. Cuando los Id. de conversación son iguales, los mensajes forman parte de la misma secuencia. El sistema de mensajes asigna un Id. a los mensajes nuevos. El valor de MsgConversationID depende del mensaje indizado actualmente, como especifica la propiedad MsgIndex.

Tipo de datos

String


MsgDateReceived (Propiedad)

Devuelve la fecha en que se recibió el mensaje indizado actualmente. Esta propiedad no está disponible en tiempo de diseño y es de sólo lectura en tiempo de ejecución.

Sintaxis

objeto.MsgDateReceived

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.

Comentarios

El formato de esta propiedad es AAAA/MM/DD HH:MM. Las horas se miden sobre la base estándar de 24 horas. El sistema de mensajería establece el valor de MsgDateReceived, que depende del mensaje indizado actualmente, tal como se haya seleccionado mediante la propiedad MsgIndex.

Tipo de datos

String


MsgID (Propiedad)

Devuelve el identificador de cadena del mensaje indizado actualmente. Esta propiedad no está disponible en tiempo de diseño y es de sólo lectura en tiempo de ejecución.

Sintaxis

objeto.MsgID

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.

Comentarios

La cadena de identificación de mensajes es una cadena específica del sistema, de 64 caracteres de longitud, que se utiliza para identificar un mensaje de forma exclusiva. El valor de MsgID depende del mensaje indizado actualmente, como especifica la propiedad MsgIndex.

Tipo de datos

String


MsgIndex (Propiedad)

Especifica el número de índice del mensaje indizado actualmente. Esta propiedad no está disponible en tiempo de diseño.

Sintaxis

objeto.MsgIndex [ = valor ]

La sintaxis de la propiedad MsgIndex consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
valor | Una expresión de tipo Long que indica el número de índice del mensaje indizado actualmente.

Comentarios

La propiedad MsgIndex determina los valores de todas las demás propiedades relacionadas con los mensajes del control MAPIMessages. El número de índice puede ser de -1 a MsgCount -1.

Nota Al cambiar la propiedad MsgIndex también se cambia todo el conjunto de datos adjuntos y de destinatarios.

El mensaje identificado por la propiedad MsgIndex se llama mensaje indizado actualmente. Cuando se cambia este índice, todas las demás propiedades del mensaje cambian para reflejar las características del mensaje indizado. Un valor -1 significa que se está creando un mensaje en el búfer de redacción; es decir, es un mensaje de salida.

Tipo de datos

Long


MsgNoteText (Propiedad)

Especifica el cuerpo de texto del mensaje. Esta propiedad no está disponible en tiempo de diseño. Es de sólo lectura a menos que MsgIndex tenga el valor –1.

Sintaxis

objeto.MsgNoteText [ = valor ]

La sintaxis de la propiedad MsgNoteText consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
valor | Una expresión de cadena que especifica el texto del mensaje.

Comentarios

Esta propiedad contiene toda la parte de texto del cuerpo del mensaje (menos cualquier dato adjunto). Una cadena vacía indica que no hay texto.

Para los mensajes de entrada, cada párrafo termina con una pareja de retorno de carro y avance de línea (0x0d0a). Para los mensajes de salida, los párrafos pueden estar delimitados con un retorno de carro (0x0d), un avance de línea (0x0a) o una pareja de retorno de carro y avance de línea (0x0d0a). El valor de MsgNoteText depende del mensaje indizado actualmente, como establece la propiedad MsgIndex.

Tipo de datos

String


MsgOrigAddress (Propiedad)

Devuelve la dirección de correo del autor del mensaje indizado actualmente. Esta propiedad no está disponible en tiempo de diseño y es de sólo lectura en tiempo de ejecución. El sistema de mensajería establece automáticamente esta propiedad cuando se envía un mensaje.

Sintaxis

objeto.MsgOrigAddress

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.

Comentarios

El valor de MsgOrigAddress depende del mensaje indizado actualmente, tal y como especifica la propiedad MsgIndex. El valor es nulo en el búfer de redacción.

Tipo de datos

String


MsgOrigDisplayName (Propiedad)

Devuelve el nombre del remitente para el mensaje indizado actualmente. Esta propiedad no está disponible en tiempo de diseño y es de sólo lectura en tiempo de ejecución. El sistema de mensajería establece esta propiedad automáticamente.

Sintaxis

objeto.MsgOrigDisplayName

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.

Comentarios

El nombre contenido en esta propiedad es el nombre del remitente, como se muestra en el encabezado del mensaje. El valor de MsgOrigDisplayName depende del mensaje indizado actualmente, según especifica la propiedad MsgIndex. El valor es nulo en el búfer de redacción.

Tipo de datos

String


MsgRead (Propiedad)

Devuelve una expresión booleana que indica si el mensaje ya se ha leído. Esta propiedad no está disponible en tiempo de diseño y es de sólo lectura en tiempo de ejecución.

Sintaxis

objeto.MsgRead

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.

Valores

Los valores de la propiedad MsgRead son:

Valor | Descripción
True | El usuario ya ha leído el mensaje indizado actualmente.
False | (Predeterminado) El mensaje sigue sin leer.

Comentarios

El valor de MsgRead depende del mensaje indizado actualmente, como especifica la propiedad MsgIndex. El mensaje se marca como leído cuando se tiene acceso al texto de la nota o a cualquier información de los datos adjuntos. Sin embargo, cuando se tiene acceso a la información del encabezado no se marca el mensaje como leído.

Tipo de datos

Boolean


MsgReceiptRequested (Propiedad)

Especifica si se requiere una confirmación de recibo para el mensaje indizado actualmente. Esta propiedad no está disponible en tiempo de diseño.

Sintaxis

objeto.MsgReceiptRequested [ = valor ]

La sintaxis de la propiedad MsgReceiptRequested consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
valor | Una expresión booleana que especifica si se solicita o no una confirmación de recibo, como se describe en Valores.

Valores

Los valores admitidos para valor son:

Valor | Descripción
True | Se devuelve una confirmación de recibo al remitente cuando el destinatario abre el mensaje.
False | (Predeterminado) No se genera una confirmación de recibo.

Comentarios

El valor de MsgReceiptRequested depende del mensaje indizado actualmente, como establece la propiedad MsgIndex.

Tipo de datos

Boolean


MsgSent (Propiedad)

Especifica si el mensaje indizado actualmente ya se ha enviado al servidor de correo para su distribución. Esta propiedad no está disponible en tiempo de diseño y es de sólo lectura en tiempo de ejecución. El sistema de mensajería establece esta propiedad automáticamente cuando se envía un mensaje.

Sintaxis

objeto.MsgSent

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.

Valores

Los valores de la propiedad MsgSent son:

Valor | Descripción
True | El mensaje indizado actualmente ya se ha enviado al servidor de correo como un mensaje saliente.
False | El mensaje indizado actualmente no se ha entregado todavía al servidor.

Comentarios

El valor de MsgSent depende del mensaje indizado actualmente, como establece la propiedad MsgIndex.

Tipo de datos

Boolean


MsgSubject (Propiedad)

Especifica la línea del asunto para el mensaje indizado actualmente como se presenta en el encabezado del mensaje. Esta propiedad no está disponible en tiempo de diseño y es de sólo lectura a menos que MsgIndex tenga el valor -1.

Sintaxis

objeto.MsgSubject [ = valor ]

La sintaxis de la propiedad MsgSubject consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
valor | Una expresión de cadena que especifica la línea del asunto.

Comentarios

El valor de MsgSubject depende del mensaje indizado actualmente, como establece la propiedad MsgIndex. MsgSubject está limitada a 64 caracteres, incluyendo el carácter nulo.

Tipo de datos

String


MsgType (Propiedad)

Especifica el tipo de mensaje indizado actualmente. Esta propiedad no está disponible en tiempo de diseño y es de sólo lectura a menos que MsgIndex tenga el valor -1.

Sintaxis

objeto.MsgType [ = valor ]

La sintaxis de la propiedad MsgType consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
valor | Una expresión de cadena que especifica el tipo de mensaje.

Comentarios

La propiedad MsgType es para uso de aplicaciones distintas al correo interpersonal (tipo de mensaje IPM). No todos los sistemas de correo aceptan tipos de mensaje que no son IPM y pueden no proporcionar (o pueden pasar por alto) este parámetro.

Una cadena nula o vacía indica un tipo de mensaje IPM. El valor de MsgType depende del mensaje indizado actualmente, como establece la propiedad MsgIndex. Esta propiedad no está destinada para usarla como un filtro con el fin de aislar mensajes por remitente, hora de recepción y otras categorías.

Tipo de datos

String


NewSession (Propiedad)

Especifica si se debe establecer una nueva sesión de correo, aunque exista actualmente una sesión válida.

Sintaxis

objeto.NewSession[ = valor]

La sintaxis de la propiedad NewSession consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
valor | Una expresión booleana que especifica si se debe establecer una nueva sesión de correo, como se describe en Valores.

Valores

Los valores admitidos para valor son:

Valor | Descripción
True | Se establece una nueva sesión de mensajería, independientemente de si ya existe o no una sesión válida.
False | (Predeterminado) Utiliza la sesión existente establecida por el usuario.

Tipo de datos

Boolean


Password (Propiedad, control MAPISession)

Especifica la contraseña de cuenta asociada con la propiedad UserName.

Sintaxis

objeto.Password[ = valor]

La sintaxis de la propiedad Password consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
valor | Una expresión de cadena que especifica la contraseña de la cuenta.

Comentarios

Una cadena vacía en esta propiedad indica que se debe generar un cuadro de diálogo de inicio de sesión con el campo de contraseña vacío. El valor predeterminado es una cadena vacía.

Tipo de datos

String


RecipAddress (Propiedad)

Especifica la dirección de correo electrónico del destinatario indizado actualmente. Esta propiedad no está disponible en tiempo de diseño y es de sólo lectura a menos que MsgIndex tenga el valor -1.

Sintaxis

objeto.RecipAddress [ = valor ]

La sintaxis de la propiedad RecipAddress consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
valor | Una expresión de cadena que especifica una dirección de correo electrónico.

Comentarios

El valor de RecipAddress depende del destinatario indizado actualmente, como establece la propiedad RecipIndex.

Tipo de datos

String


RecipCount (Propiedad)

Devuelve el número total de destinatarios para el mensaje indizado actualmente como un entero de tipo Long. Esta propiedad no está disponible en tiempo de diseño y es de sólo lectura en tiempo de ejecución.

Sintaxis

objeto.RecipCount

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.

Comentarios

El valor predeterminado es 0. El valor de RecipCount depende del mensaje indizado actualmente, como establece la propiedad MsgIndex.

Tipo de datos

Long


RecipDisplayName (Propiedad)

Especifica el nombre del destinatario indizado actualmente. Esta propiedad no está disponible en tiempo de diseño y es de sólo lectura a menos que MsgIndex tenga el valor -1.

Sintaxis

objeto.RecipDisplayName [ = valor ]

La sintaxis de la propiedad RecipDisplayName consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
valor | Una expresión de cadena que especifica el nombre del destinatario.

Comentarios

El nombre contenido en esta propiedad es el nombre del destinatario, como se muestra en el encabezado del mensaje. El valor de RecipDisplayName depende del mensaje indizado actualmente, como establece la propiedad RecipIndex. El método ResolveName utiliza el nombre del destinatario tal como está almacenado aquí.

Tipo de datos

String


RecipIndex (Propiedad)

Establece el destinatario indizado actualmente. Esta propiedad no está disponible en tiempo de diseño.

Sintaxis

objeto.RecipIndex [ = valor ]

La sintaxis de la propiedad RecipIndex consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
valor | Una expresión de tipo Long que especifica el destinatario indizado actualmente.

Comentarios

Especifica un número de índice para identificar un determinado destinatario de mensaje. El número de índice de esta propiedad determina los valores de las propiedades RecipAddress, RecipCount, RecipDisplayName y RecipType.

El destinatario identificado por la propiedad RecipIndex se llama destinatario indizado actualmente. El valor de RecipIndex puede ser de 0 (el predeterminado) a RecipCount -1. Cuando RecipIndex tiene el valor -1, los valores de las demás propiedades del destinatario muestran la información del remitente del mensaje. El valor predeterminado es 0.

Para agregar un nuevo destinatario, asigne a RecipIndex un valor mayor o igual que el número de destinatarios actuales mientras está en el búfer de redacción. La propiedad RecipCount se actualiza automáticamente para reflejar el nuevo número de destinatarios. Por ejemplo, si la propiedad RecipCount actual tiene un valor 3, al asignar a la propiedad RecipIndex el valor 4 se agregan 2 nuevos destinatarios y se incrementa la propiedad RecipCount a 5.

Para eliminar un destinatario existente, especifique el método Delete con el parámetro valor 1. Sólo se puede agregar o eliminar destinatarios cuando la propiedad MsgIndex tiene el valor -1.

Tipo de datos

Long


RecipType (Propiedad)

Especifica el tipo del destinatario indizado actualmente. Esta propiedad no está disponible en tiempo de diseño y es de sólo lectura a menos que MsgIndex tenga el valor -1.

Sintaxis

objeto.RecipType [ = valor ]

La sintaxis de la propiedad RecipType consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
valor | Una expresión de tipo Integer que especifica el tipo de destinatario, como se describe en Valores.

Valores

Los valores admitidos para valor son:

Constante | Valor | Descripción
mapOrigList | 0 | El remitente del mensaje.
mapToList | 1 | El destinatario es un destinatario primario.
mapCcList | 2 | El destinatario es un destinatario con copia.
mapBccList | 3 | El destinatario es un destinatario con copia oculta.

Comentarios

El valor de RecipType depende del mensaje indizado actualmente, como establece la propiedad RecipIndex. No puede establecer el tipo de destinatario como 0 (el sistema de mensajería utiliza un valor 0 para indicar el remitente del mensaje).

Tipo de datos

Integer


SessionID (Propiedad, control MAPIMessages)

Almacena el controlador de sesión de mensajería actual. Esta propiedad no está disponible en tiempo de diseño.

Sintaxis

objeto.SessionID [ = valor ]

La sintaxis de la propiedad SessionID consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
valor | Una expresión de tipo Long que especifica el controlador de sesión actual.

Comentarios

Esta propiedad contiene el controlador de sesión de mensajería devuelto por la propiedad SessionID del control MAPISession. Para asociar el control MAPIMessages con una sesión de mensajería válida, asigne a esta propiedad el SessionID de un control MAPISession que se abrió correctamente.


SessionID (Propiedad, control MAPISession)

Devuelve el controlador de sesión de mensajería actual. Esta propiedad no está disponible en tiempo de diseño y es de sólo lectura en tiempo de ejecución.

Sintaxis

objeto.SessionID

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.

Comentarios

Esta propiedad se establece cuando especifica el método SignOn. La propiedad SessionID contiene un controlador único de sesión de mensajería. El valor predeterminado es 0.

Utilice esta propiedad para establecer la propiedad SessionID del control MAPIMessages.

Tipo de datos

Long


UserName (Propiedad)

Especifica el nombre de usuario de la cuenta.

Sintaxis

objeto.UserName [ = valor ]

La sintaxis de la propiedad UserName consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
valor | Una expresión de cadena que especifica la cuenta de usuario.

Comentarios

Esta propiedad contiene el nombre de la cuenta de usuario deseada para iniciar o cerrar la sesión. Si la propiedad LogonUI es True, una cadena vacía en la propiedad UserName indica que se deberá generar un cuadro de diálogo de inicio de sesión con el campo de nombre vacío. El valor predeterminado es una cadena vacía.

Tipo de datos

String