Multimedia MCI (Control)

El control Multimedia MCI administra la grabación y la reproducción de los archivos multimedia en dispositivos de interfaz de control de medios (MCI, Media Control Interface). Conceptualmente, este control está constituido por una serie de botones que envían comandos MCI a dispositivos como tarjetas de audio, secuenciadores MIDI, unidades de CD-ROM, reproductores de CD de audio, reproductores de videodiscos y grabadores y reproductores de vídeo. El control MCI admite también la reproducción de archivos de vídeo para Windows (*.AVI).

Cuando agrega un control Multimedia MCI a un formulario en tiempo de diseño, el control aparece en el formulario de la forma siguiente:

Los botones están definidos como Prev, Next, Play, Pause, Back, Step, Stop, Record y Eject, respectivamente.

Comentarios

La aplicación debe tener el dispositivo MCI abierto y los botones apropiados del control Multimedia MCI activados antes de que el usuario pueda elegir un botón del control Multimedia MCI. En Visual Basic, coloque el comando Open de MCI en el evento Form_Load.

Cuando desee grabar audio con el control Multimedia MCI, abra un archivo nuevo. Esta acción asegura que el archivo de datos que contiene el sonido grabado tendrá un formato compatible con la capacidad de grabación del sistema. Además, ejecute el comando Save de MCI antes de cerrar el dispositivo MCI para almacenar los datos grabados en el archivo.

El control Multimedia MCI se puede programar de varias formas:

  • El control puede ser visible o invisible en tiempo de ejecución.

  • Puede aumentar o volver a definir completamente la funcionalidad de los botones del control.

  • Puede controlar varios dispositivos en un único formulario.

Si desea usar los botones del control Multimedia MCI, establezca las propiedades Visible y Enabled a True. Si no desea usar los botones del control, pero desea usar el control Multimedia MCI por su funcionalidad multimedia, establezca las propiedades Visible y Enabled a False. Una aplicación puede controlar los dispositivos MCI con o sin la interacción del usuario.

Los eventos (definiciones de botones) del control Multimedia MCI son programables. Puede aumentar o volver a definir completamente la funcionalidad de los botones si desarrolla código para los eventos que se producen al hacer clic en un botón.

Las extensiones MCI aceptan varias instancias del control Multimedia MCI en un único formulario para permitir un control simultáneo de varios dispositivos MCI. Puede usar un control por cada dispositivo.

Nota para la distribución Cuando cree y distribuya aplicaciones con el control Multimedia MCI, tendrá que instalar y registrar los archivos apropiados en el directorio System o System32 de Microsoft Windows del cliente. El Asistente de empaquetado y distribución que incluye Visual Basic le proporciona herramientas que le ayudarán a escribir los programas que instalan las aplicaciones correctamente.


No se encuentra el tema

No se halló el tema correspondiente. A continuación enumeramos algunas posibles razones y sus soluciones:

  • El archivo (.chm) que contiene el tema de destino no se encuentra en la ubicación esperada.

    Solución: vuelva a ejecutar la instalación de la Biblioteca MSDN.

  • El archivo (.chm) que contiene el tema actual o el de destino no está actualizado y el vínculo ya no es válido.

    Solución: instale la última versión de la Biblioteca MSDN.

  • El CD de la Biblioteca MSDN no está en la unidad de CD-ROM.

    Solución: inserte el CD en la unidad.


Mensajes de error (Control Multimedia MCI)

La siguiente lista enumera los errores interceptables del control Multimedia MCI.

Constante | Valor | Descripción
mciInvalidProcedureCall | 5 | Llamada al procedimiento no válida.
mciInvalidProertyValue | 380 | El valor de la propiedad no es válido.
mciSetNotSupported | 383 | La propiedad es de sólo lectura.
mciGetNotSupported | 394 | La propiedad es de sólo escritura.
mciInvalidObjectUse | 425 | Uso no válido del objeto.
mciWrongClipboardFormat | 461 | El formato especificado no coincide con el formato de los datos.
mciObjectLocked | 672 | La lista de formatos de DataObject no se puede borrar o expandir fuera del evento OLEStartDrag.
mciExpectedArgument | 673 | Se espera al menos un argumento.
mciRecursiveOleDrag | 674 | Llamada recursiva no válida de arrastrar y colocar OLE.
mciFormatNotByteArray | 675 | Los formatos de arrastrar y colocar OLE no intrínsecos que se usan con SetData necesitan datos en una matriz de Byte. GetData puede devolver más bytes que los proporcionados por SetData.
mciDataNotSetForFormat | 676 | Los datos solicitados no se han proporcionado al objeto DataObject durante el evento OLESetData.
mciCantCreateButton | 30001 | No es posible crear el botón.
mciCantCreateTimer | 30002 | No es posible crear el recurso de cronómetro.
mciUnsupportedFunction | 30004 | Función no compatible.

La lista que aparece a continuación enumera las cadenas y los números de error MCI relacionados con el control Multimedia MCI.

Cadena de error MCI | Número de error MCI
MCIERR_BASE | 256
MCIERR_INVALID_DEVICE_ID | 257
MCIERR_UNRECOGNIZED_KEYWORD | 259
MCIERR_UNRECOGNIZED_COMMAND | 261
MCIERR_HARDWARE | 262
MCIERR_INVALID_DEVICE_NAME | 263
MCIERR_OUT_OF_MEMORY | 264
MCIERR_DEVICE_OPEN | 265
MCIERR_CANNOT_LOAD_DRIVER | 266
MCIERR_MISSING_COMMAND_STRING | 267
MCIERR_PARAM_OVERFLOW | 268
MCIERR_MISSING_STRING_ARGUMENT | 269
MCIERR_BAD_INTEGER | 270
MCIERR_PARSER_INTERNAL | 271
MCIERR_DRIVER_INTERNAL | 272
MCIERR_MISSING_PARAMETER | 273
MCIERR_UNSUPPORTED_FUNCTION | 274
MCIERR_FILE_NOT_FOUND | 275
MCIERR_DEVICE_NOT_READY | 276
MCIERR_INTERNAL | 277
MCIERR_DRIVER | 278
MCIERR_CANNOT_USE_ALL | 279
MCIERR_MULTIPLE | 280
MCIERR_EXTENSION_NOT_FOUND | 281
MCIERR_OUTOFRANGE | 282
MCIERR_FLAGS_NOT_COMPATIBLE | 283
MCIERR_FILE_NOT_SAVED | 286
MCIERR_DEVICE_TYPE_REQUIRED | 287
MCIERR_DEVICE_LOCKED | 288
MCIERR_DUPLICATE_ALIAS | 289
MCIERR_BAD_CONSTANT | 290
MCIERR_MUST_USE_SHAREABLE | 291
MCIERR_MISSING_DEVICE_NAME | 292
MCIERR_BAD_TIME_FORMAT | 293
MCIERR_NO_CLOSING_QUOTE | 294
MCIERR_DUPLICATE_FLAGS | 295
MCIERR_INVALID_FILE | 296
MCIERR_NULL_PARAMETER_BLOCK | 297
MCIERR_UNNAMED_RESOURCE | 298
MCIERR_NEW_REQUIRES_ALIAS | 299
MCIERR_NOTIFY_ON_AUTO_OPEN | 300
MCIERR_NO_ELEMENT_ALLOWED | 301
MCIERR_NONAPPLICABLE_FUNCTION | 302
MCIERR_ILLEGAL_FOR_AUTO_OPEN | 303
MCIERR_FILENAME_REQUIRED | 304
MCIERR_EXTRA_CHARACTERS | 305
MCIERR_DEVICE_NOT_INSTALLED | 306
MCIERR_GET_CD | 307
MCIERR_SET_CD | 308
MCIERR_SET_DRIVE | 309
MCIERR_DEVICE_LENGTH | 310
MCIERR_DEVICE_ORD_LENGTH | 311
MCIERR_NO_INTEGER | 312
MCIERR_WAVE_OUTPUTSINUSE | 320
MCIERR_WAVE_SETOUTPUTINUSE | 321
MCIERR_WAVE_INPUTSINUSE | 322
MCIERR_WAVE_SETINPUTINUSE | 323
MCIERR_WAVE_OUTPUTUNSPECIFIED | 324
MCIERR_WAVE_INPUTUNSPECIFIED | 325
MCIERR_WAVE_OUTPUTSUNSUITABLE | 326
MCIERR_WAVE_SETOUTPUTUNSUITABLE | 327
MCIERR_WAVE_INPUTSUNSUITABLE | 328
MCIERR_WAVE_SETINPUTUNSUITABLE | 329
MCIERR_SEQ_DIV_INCOMPATIBLE | 336
MCIERR_SEQ_PORT_INUSE | 337
MCIERR_SEQ_PORT_NONEXISTENT | 338
MCIERR_SEQ_PORT_MAPNODEVICE | 339
MCIERR_SEQ_PORT_MISCERROR | 340
MCIERR_SEQ_TIMER | 341
MCIERR_SEQ_PORTUNSPECIFIED | 342
MCIERR_SEQ_NOMIDIPRESENT | 343
MCIERR_NO_WINDOW | 346
MCIERR_CREATEWINDOW | 347
MCIERR_FILE_READ | 348
MCIERR_FILE_WRITE | 349
MCIERR_CUSTOM_DRIVER_BASE | 512


ButtonClick (Evento, control Multimedia MCI)

Se produce cuando el usuario presiona y suelta el botón del mouse (ratón) con el puntero encima de uno de los botones del control Multimedia MCI.

Sintaxis

Private Sub ControlMM_ButtonClick (Cancel As Integer)

Comentarios

Botón (Button) puede ser cualquiera de los siguientes: Back, Eject, Next, Pause, Play, Prev, Record, Step o Stop.

Cada uno de los eventos BotónClick ejecuta un comando MCI, de forma predeterminada, cuando el usuario elige un botón. En la tabla siguiente se enumeran los valores de los comandos MCI que ejecuta cada botón del control.

Botón | Comando
Back | MCI_STEP.
Step | MCI_STEP.
Play | MCI_PLAY.
Pause | MCI_PAUSE.
Prev | MCI_SEEK.
Next | MCI_SEEK.
Stop | MCI_STOP.
Record | MCI_RECORD.
Eject | MCI_SET con el parámetro MCI_SET_DOOR_OPEN.

Si establece el parámetro Cancel a True para el evento BotónClick, evitará que se ejecute el comando MCI predeterminado. El parámetro Cancel puede tomar cualquiera de los dos valores siguientes.

Valor | Descripción
True | Evita que se ejecute el comando MCI predeterminado.
False | Ejecuta el comando MCI que está asociado al botón después de ejecutar el cuerpo principal del evento BotónClick correspondiente.

El cuerpo principal de un procedimiento de evento se realiza antes de ejecutar el comando MCI predeterminado que está asociado a ese evento. Si agrega código al cuerpo de los eventos BotónClick, se incrementa la funcionalidad de los botones. Si establece el parámetro Cancel a True dentro del cuerpo de un procedimiento de evento o pasa el valor True como argumento para un procedimiento de evento BotónClick, no se ejecutará el comando MCI predeterminado asociado al evento.

Nota Si envía un comando Pause para reiniciar un dispositivo que está en pausa, es posible que se anulen las notificaciones pendientes del comando Play original, en caso de que el dispositivo no admita el comando MCI Resume. El control Multimedia MCI usa el comando Play para reiniciar los dispositivos que no admiten el comando MCI Resume. Las notificaciones del comando Play, que reinicia un dispositivo en pausa, cancelan las condiciones de devolución de llamada e invalidan las notificaciones pendientes del comando Play.


ButtonCompleted (Evento, control Multimedia MCI)

Se produce al finalizar el comando MCI que se ha activado con un botón del control Multimedia MCI.

Sintaxis

Private Sub ControlMM_ButtonCompleted (ErrorCode As Long)

Comentarios

Botón (Button) puede ser cualquiera de los siguientes: Back, Eject, Next, Pause, Play, Prev, Record, Step o Stop.

El argumento ErrorCode puede tener uno de los valores siguientes.

Valor | Descripción
0 | El comando se completó correctamente.
Cualquier otro valor | El comando no se completó correctamente.

Si el argumento Cancel está establecido a True durante un evento BotónClick, no se ejecuta el evento BotónCompleted.


ButtonGotFocus (Evento, control Multimedia MCI)

Se produce cuando un botón del control Multimedia MCI recibe el enfoque de entrada.

Sintaxis

Private Sub ControlMM_ButtonGotFocus ()

Comentarios

Botón (Button) puede ser cualquiera de los siguientes: Back, Eject, Next, Pause, Play, Prev, Record, Step o Stop.


ButtonLostFocus (Evento, control Multimedia MCI)

Se produce cuando un botón del control Multimedia MCI pierde el enfoque de entrada.

Sintaxis

Private Sub ControlMM_ButtonLostFocus ()

Comentarios

Botón (Button) puede ser cualquiera de los siguientes: Back, Eject, Next, Pause, Play, Prev, Record, Step o Stop.


Done (Evento, control Multimedia MCI)

Se produce cuando termina un comando MCI para el que la propiedad Notify está establecida a True.

Sintaxis

Private Sub ControlMM_Done (NotifyCode As Integer)

Comentarios

El argumento NotifyCode indica si el comando MCI se completó correctamente. Puede tener cualquiera de los valores siguientes.

Valor | Constante y resultado
1 | mciSuccessful El comando se completó correctamente.
2 | mciSuperseded El comando fue invalidado por otro comando.
4 | mciAborted El usuario anuló el comando.
8 | mciFailure El comando falló.


StatusUpdate (Evento, control Multimedia MCI)

Se produce automáticamente cada vez que transcurre el intervalo establecido en la propiedad UpdateInterval.

Sintaxis

Private Sub ControlMM_StatusUpdate ()

Comentarios

Este evento permite que una aplicación actualice la presentación para informar al usuario acerca del estado del dispositivo MCI actual. La aplicación puede obtener información acerca del estado en propiedades como Position, Length y Mode.


Constantes del control Multimedia MCI

Constantes de Mode

Constante | Valor | Descripción
mciModeNotOpen | 524 | El dispositivo no está abierto.
MciModeStop | 525 | Parar dispositivo.
mciModePlay | 526 | Reproducir dispositivo.
mciModeRecord | 527 | Grabar dispositivo.
mciModeSeek | 528 | Buscar dispositivo.
mciModePause | 529 | Pausa dispositivo.
mciModeReady | 530 | Dispositivo preparado.

Constantes de Notify

Constante | Valor | Descripción
mciNotifySuccessful | 1 | El comando se completó satisfactoriamente.
mciNotifySuperseded | 2 | El comando se sustituyó por otro comando.
mciAborted | 4 | El usuario anuló el comando.
mciFailure | 8 | El comando falló.

Constantes de Orientation

Constante | Valor | Descripción
mciOrientHorz | 0 | Botones dispuestos horizontalmente.
mciOrientVert | 1 | Botones dispuestos verticalmente.

Constantes de RecordMode

Constante | Valor | Descripción
mciRecordInsert | 0 | Modo de insertar grabación.
mciRecordOverwrite | 1 | Modo de sobrescribir grabación.

Constantes de Format

Constante | Valor | Descripción
mciFormatMilliseconds | 0 | Formato de milisegundos.
mciFormatHms | 1 | Formato de horas, minutos y segundos.
mciFormatMsf | 2 | Formato de minutos, segundos e imágenes.
mciFormatFrames | 3 | Formato de imágenes.
mciFormatSmpte24 | 4 | Formato SMPTE de 24 imágenes.
mciFormatSmpte25 | 5 | Formato SMPTE de 25 imágenes.
mciFormatSmpte30 | 6 | Formato SMPTE de 30 imágenes.
mciFormatSmpte30Drop | 7 | Formato SMPTE de 30 imágenes desplegables.
mciFormatBytes | 8 | Formato de bytes.
mciFormatSamples | 9 | Formato de ejemplos.
mciFormatTmsf | 10 | Formato de pistas, minutos, segundos e imágenes.


Multimedia MCI

El control Multimedia MCI está compuesto por una serie de comandos de alto nivel e independientes de los dispositivos que controlan los periféricos de audio y vídeo. El primer comando MCI que se utiliza es Open. Este comando abre el dispositivo MCI especificado e identifica el archivo que va a reproducir o a grabar el dispositivo. Algunos dispositivos como CDAudio, VCR y videodisco no usan archivos y no requieren nombres de archivo.

Una vez abierto el dispositivo, puede enviarle cualquier otro comando MCI (Prev, Next, Pause, etc.). El comando Close es el último que se envía al dispositivo, para devolverlo al grupo de recursos del sistema disponibles. El comando Close cierra también el archivo de datos asociado al dispositivo.

Para ver una lista de los comandos MCI compatibles con el control Multimedia MCI, vea la propiedad Command. Para obtener información adicional acerca del control Multimedia MCI, vea Microsoft Win32 Software Development Kit Multimedia Programmer's Reference.


Ejemplos del control Multimedia MCI

Ejemplo de Visual Basic

El ejemplo siguiente ilustra el procedimiento que se usa para abrir un dispositivo MCI con un archivo de datos compatible. Coloque este código en el procedimiento Form_Load para que la aplicación pueda usar el control Multimedia MCI "tal cual" para reproducir, grabar y rebobinar el archivo multimedia Gong.wav. Para probar este ejemplo, cree primero un formulario con un control Multimedia MCI.

Private Sub Form_Load ()
   ' Establece las propiedades necesarias para abrir MCI.
   MMControl1.Notify = FALSE
   MMControl1.Wait = TRUE
   MMControl1.Shareable = FALSE
   MMControl1.DeviceType = "WaveAudio"
   MMControl1.FileName = "C:\WINDOWS\MMDATA\GONG.WAV"

   ' Abre el dispositivo MCI WaveAudio.
   MMControl1.Command = "Open"
End Sub

Para administrar correctamente los recursos multimedia, debe cerrar los dispositivos MCI que estén abiertos antes de salir de la aplicación. Puede colocar la siguiente instrucción en el procedimiento Form_Unload para cerrar cualquier dispositivo MCI que esté abierto antes de salir del formulario que contiene el control Multimedia MCI.

Private Sub Form_Unload (Cancel As Integer)
   MMControl1.Command = "Close"
End Sub


AutoEnable (Propiedad, control Multimedia MCI)

Determina si el control Multimedia MCI puede activar y desactivar automáticamente botones individuales del control. Si la propiedad AutoEnable está establecida a True, el control Multimedia MCI activa aquellos botones que sean apropiados para el modo actual del tipo de dispositivo MCI especificado. Esta propiedad también desactiva aquellos botones que no sean compatibles con el modo actual del dispositivo MCI.

Sintaxis

[formulario.]ControlMM.AutoEnable[ = {True | False}]

Comentarios

El efecto de la propiedad AutoEnable queda invalidado por la propiedad Enabled. La propiedad AutoEnable puede activar y desactivar automáticamente botones individuales del control cuando está activado el control Multimedia MCI (la propiedad Enabled está establecida a True). Cuando la propiedad Enabled está establecida a False, está desactivado el acceso en tiempo de ejecución del teclado y del mouse (ratón) al control Multimedia MCI, independientemente del valor que tenga la propiedad AutoEnable.

En la tabla siguiente se enumeran los valores de la propiedad AutoEnable para el control Multimedia MCI.

Valor | Descripción
False | No activa ni desactiva botones. El programa controla el estado de los botones al establecer las propiedades Enabled y ButtonEnabled.
True | (Predeterminado) Activa los botones cuyas funciones están disponibles y desactiva aquellos cuyas funciones no lo están.

Las tablas siguientes muestran cómo se refleja la configuración del modo MCI en los valores de las propiedades del control.

Modo reproducir

Modo grabar

Modo pausa

Modo detener

Modo abrir

Modos buscar o no preparado

El efecto de la propiedad AutoEnable invalida los efectos de las propiedades Botón Enabled. Cuando las propiedades Enabled y AutoEnable están establecidas a True, no se utilizan las propiedades Botón Enable.

Tipo de datos

Integer (booleano)


Modo abrir

Botón | Estado
Back* | Desactivado.
Eject* | Activado.
Next | Desactivado.
Pause | Desactivado.
Play* | Desactivado.
Prev | Desactivado.
Record* | Desactivado.
Step* | Desactivado.
Stop | Desactivado.

*El botón se activa si la operación es compatible con el dispositivo MCI abierto.


Modo pausa

Botón | Estado
Back* | Activado.
Eject* | Activado.
Next | Activado.
Pause | Activado.
Play* | Activado.
Prev | Activado.
Record* | Activado.
Step* | Activado.
Stop | Activado.

*El botón se activa si la operación es compatible con el dispositivo MCI abierto.


Modo reproducir

Botón | Estado
Back* | Activado.
Eject* | Activado.
Next | Activado.
Pause | Activado.
Play* | Desactivado.
Prev | Activado.
Record* | Desactivado.
Step* | Activado.
Stop | Activado.

*El botón se activa si la operación es compatible con el dispositivo MCI abierto.


Modo grabar

Botón | Estado
Back* | Activado.
Eject* | Activado.
Next | Activado.
Pause | Activado.
Play* | Desactivado.
Prev | Activado.
Record* | Desactivado.
Step* | Activado.
Stop | Activado.

*El botón se activa si la operación es compatible con el dispositivo MCI abierto.


Modos buscar o no preparado

Botón | Estado
Back* | Desactivado.
Eject* | Desactivado.
Next | Desactivado.
Pause | Desactivado.
Play* | Desactivado.
Prev | Desactivado.
Record* | Desactivado.
Step* | Desactivado.
Stop | Desactivado.

*El botón se activa si la operación es compatible con el dispositivo MCI abierto.


Modo detener

Botón | Estado
Back* | Activado.
Eject* | Activado.
Next | Activado.
Pause | Desactivado.
Play* | Activado.
Prev | Activado.
Record* | Activado.
Step* | Activado.
Stop | Desactivado.

*El botón se activa si la operación es compatible con el dispositivo MCI abierto.


ButtonEnabled (Propiedad, control Multimedia MCI)

Determina si un botón del control está activado o desactivado (un botón desactivado aparece atenuado).

Sintaxis

[formulario.]ControlMM.ButtonEnabled[ = {True | False}]

Comentarios

Los efectos de las propiedades Botón Enabled quedan invalidados por las propiedades Enabled y AutoEnable. Las propiedades Botón Enabled de cada botón activan o desactivan los botones asociados en el control Multimedia MCI cuando el control Multimedia MCI está activado (propiedad Enabled establecida a True) y la propiedad AutoEnable está desactivada (establecida a False).

Para esta propiedad, Botón puede ser cualquiera de los siguientes: Back, Eject, Next, Pause, Play, Prev, Record, Step o Stop. Por ejemplo, para desactivar el botón Play, utilice:

[formulario.]ControlMM.PlayEnabled = False

Para comprobar si el botón Record está activado, utilice:

If [formulario.]ControlMM.RecordEnabled Then ..

En la tabla siguiente se relacionan los valores de la propiedad Botón Enabled para el control Multimedia MCI.

Valor | Descripción
False | (Predeterminado) Desactiva (atenúa) el botón especificado en Botón. La función de este botón no está disponible en el control.
True | Activa el botón especificado en Botón. La función de este botón está disponible en el control.

Tipo de datos

Integer (booleano)


ButtonVisible (Propiedad, control Multimedia MCI)

Determina si el botón especificado se presenta en el control.

Sintaxis

[formulario.]ControlMM.ButtonVisible[ = {True | False}]

Comentarios

Los efectos de las propiedades Botón Visible quedan invalidados por la propiedad Visible. Las propiedades Botón Visible de cada botón presentan u ocultan los botones asociados en el control Multimedia MCI cuando el control Multimedia MCI es visible (propiedad Visible establecida a True). Si el control Multimedia MCI es invisible, no se usan estas propiedades.

Para esta propiedad, Botón puede ser cualquiera de los siguientes: Back, Eject, Next, Pause, Play, Prev, Record, Step o Stop.

En la tabla siguiente se relacionan los valores de la propiedad Botón Visible para el control Multimedia MCI.

Valor | Descripción
False | No presenta el botón especificado en Botón. La función de este botón no está disponible en el control.
True | (Predeterminado) Presenta el botón especificado en Botón.

Tipo de datos

Integer (booleano)


CanEject (Propiedad, control Multimedia MCI)

Determina si el dispositivo MCI abierto puede expulsar su medio. Esta propiedad no está disponible en tiempo de diseño y es de sólo lectura en tiempo de ejecución.

Sintaxis

[formulario.]ControlMM.CanEject

Comentarios

En la tabla siguiente se enumeran los valores de la propiedad CanEject para el control Multimedia MCI.

Valor | Descripción
False | (Predeterminado) El dispositivo no puede expulsar su medio.
True | El dispositivo puede expulsar su medio.

El valor de CanEject se recupera mediante MCI_GETDEVCAPS durante el procesamiento de un comando Open.

Tipo de datos

Integer (booleano)


CanPlay (Propiedad, control Multimedia MCI)

Determina si el dispositivo MCI abierto es capaz de reproducir. Esta propiedad no está disponible en tiempo de diseño y es de sólo lectura en tiempo de ejecución.

Sintaxis

[formulario.]Control.CanPlay

Comentarios

En la tabla siguiente se enumeran los valores de la propiedad CanPlay para el control Multimedia MCI.

Valor | Descripción
False | (Predeterminado) El dispositivo no puede reproducir.
True | El dispositivo puede reproducir.

El valor de CanPlay se recupera mediante MCI_GETDEVCAPS durante el procesamiento de un comando Open.

Tipo de datos

Integer (booleano)


CanRecord (Propiedad, control Multimedia MCI)

Determina si el dispositivo MCI abierto puede grabar. Esta propiedad no está disponible en tiempo de diseño y es de sólo lectura en tiempo de ejecución.

Sintaxis

[formulario.]ControlMM.CanRecord

Comentarios

En la tabla siguiente se enumeran los valores de la propiedad CanRecord para el control Multimedia MCI.

Valor | Descripción
False | (Predeterminado) El dispositivo no puede grabar.
True | El dispositivo puede grabar.

El valor de CanRecord se recupera mediante MCI_GETDEVCAPS durante el procesamiento de un comando Open.

Tipo de datos

Integer (booleano)


CanStep (Propiedad, control Multimedia MCI)

Determina si el dispositivo MCI abierto puede avanzar un paso cada vez. Esta propiedad no está disponible en tiempo de diseño y es de sólo lectura en tiempo de ejecución.

Sintaxis

[formulario.]ControlMM.CanStep

Comentarios

En la tabla siguiente se enumeran los valores de la propiedad CanStep para el control Multimedia MCI.

Valor | Descripción
False | (Predeterminado) El dispositivo no puede avanzar un paso cada vez.
True | El dispositivo puede avanzar un paso cada vez.

Actualmente, sólo los dispositivos MCI MMMovie, Overlay y VCR pueden avanzar un paso cada vez. Como no hay ninguna forma de comprobar si un dispositivo puede avanzar paso a paso, los programas establecen el valor de esta propiedad comprobando si el tipo del dispositivo es MMMovie, Overlay o VCR durante el procesamiento de un comando Open.

Tipo de datos

Integer (booleano)


Command (Propiedad, control Multimedia MCI)

Especifica el comando MCI que se va a ejecutar. Esta propiedad no está disponible en tiempo de diseño.

Sintaxis

[formulario.]ControlMM.Command[ = cmdCadena$]

Comentarios

El argumento cmdCadena$ proporciona el nombre del comando MCI que se va a ejecutar: Open, Close, Play, Pause, Stop, Back, Step, Prev, Next, Seek, Record, Eject, Sound o Save. El comando se ejecuta inmediatamente y el código de error se almacena en la propiedad Error.

En la siguiente tabla se describe cada comando y se enumeran las propiedades que usa. Si una propiedad no está establecida, se usa un valor predeterminado (que aparece entre paréntesis a continuación del nombre de la propiedad) o no se usa (si no aparece ningún valor predeterminado).

Comando | Descripción y propiedades utilizadas
Open | Abre un dispositivo mediante el comando MCI_OPEN.
 | Notify (False).
 | Wait (True).
 | Shareable.
 | DeviceType.
 | FileName.
Close | Cierra un dispositivo mediante el comando MCI_CLOSE.
 | Notify (False).
 | Wait (True).
Play | Reproduce un dispositivo mediante el comando MCI_PLAY.
 | Notify (True).
 | Wait (False).
 | From.
 | To.
Pause | Hace una pausa en la reproducción o en la grabación mediante el comando MCI_PAUSE. Si se ejecuta cuando el dispositivo está en pausa, intenta reanudar la reproducción o la grabación mediante el comando MCI_RESUME.
 | Notify (False).
 | Wait (True).
Stop | Detiene la reproducción o la grabación mediante el comando MCI_STOP.
 | Notify (False).
 | Wait (True).
Back | Retrocede mediante el comando MCI_STEP.
 | Notify (False).
 | Wait (True).
 | Frames.
Step | Avanza mediante el comando MCI_STEP.
 | Notify (False).
 | Wait (True).
 | Frames.
Prev | Va al comienzo de la pista actual mediante el comando Seek. Si se ejecuta otra vez antes de que transcurran tres segundos desde el anterior comando Prev, va al comienzo de la pista anterior o al comienzo de la primera pista, si es la que se está usando.
 | Notify (False).
 | Wait (True).
Next | Va al comienzo de la pista siguiente (si se está usando la última pista, va al comienzo de la última pista) mediante el comando Seek.
 | Notify (False).
 | Wait (True).
Seek | Si no se está reproduciendo, busca una posición mediante el comando MCI_SEEK. Si se está reproduciendo, continúa la reproducción desde la posición definida mediante el comando MCI_PLAY.
 | Notify (False).
 | Wait (True).
 | To.
Record | Graba mediante el comando MCI_RECORD.
 | Notify (True).
 | Wait (False).
 | From.
 | To.
 | RecordMode (0–Insert).
Eject | Expulsa el medio mediante el comando MCI_SET.
 | Notify (False).
 | Wait (True).
Sound | Reproduce un sonido mediante el comando MCI_SOUND.
 | Notify (False).
 | Wait (False).
 | FileName.
Save | Guarda un archivo abierto mediante el comando MCI_SAVE.
 | Notify (False).
 | Wait (True).
 | FileName.

Tipo de datos

String


DeviceID (Propiedad, control Multimedia MCI)

Especifica el Id. del dispositivo MCI que está abierto. Esta propiedad no está disponible en tiempo de diseño y es de sólo lectura en tiempo de ejecución.

Sintaxis

[formulario.]ControlMM.DeviceID[ = id%]

Comentarios

El argumento id% es el Id. del dispositivo MCI que está abierto. Este Id. se obtiene de MCI_OPEN como resultado de un comando Open. Si no hay ningún dispositivo abierto, este argumento es 0.

Tipo de datos

Integer


DeviceType (Propiedad, control Multimedia MCI)

Especifica el tipo de dispositivo MCI que se va a abrir.

Sintaxis

[formulario.]ControlMM.DeviceType[ = dispositivo$]

Comentarios

El argumento dispositivo$ es el tipo de dispositivo MCI que se va a abrir: AVIVideo, CDAudio, DAT, DigitalVideo, MMMovie, Other, Overlay, Scanner, Sequencer, VCR, Videodisc o WaveAudio.

Es necesario establecer el valor de esta propiedad cuando se abren dispositivos sencillos (como un CD de audio que no usa archivos). También hay que establecerlo cuando se abren dispositivos MCI compuestos, si la extensión del nombre de archivo no especifica el dispositivo que se va a usar.

Tipo de datos

String


hWndDisplay (Propiedad, control Multimedia MCI)

Especifica la ventana de resultado de dispositivos MCI MMMovie y Overlay que usan una ventana para mostrar el resultado. Esta propiedad no está disponible en tiempo de diseño.

Sintaxis

[formulario.]ControlMM.hWndDisplay

Comentarios

Esta propiedad es un controlador de la ventana que usa el dispositivo MCI para mostrar el resultado. Si el controlador es 0, se usa una ventana predeterminada (llamada también "ventana de presentaciones").

Para determinar si un dispositivo usa esta propiedad, compruebe el valor de la propiedad UsesWindows.

Para obtener un controlador de un control en Visual Basic, use primero el método SetFocus para establecer el enfoque en el control que desee. Luego llame a la función de Windows GetFocus.

Para obtener un controlador de un formulario de Visual Basic, use la propiedad hWnd de ese formulario.

Tipo de datos

Integer


Enabled (Propiedad, control Multimedia MCI)

Determina si el control puede responder a los eventos generados por el usuario, como los eventos KeyPress y los eventos del mouse (ratón).

Sintaxis

[formulario.]ControlMM.Enabled[ = {True | False}]

Comentarios

Esta propiedad permite activar y desactivar el control Multimedia MCI en tiempo de ejecución. El efecto de la propiedad Enabled invalida los efectos de las propiedades AutoEnable y Botón Enabled. Por ejemplo, si la propiedad Enabled está establecida a False, el control Multimedia MCI no permite tener acceso a sus botones, cualquiera que sea el valor de las propiedades AutoEnable y Botón Enabled.

En la tabla siguiente se enumeran los valores de la propiedad Enabled para el control Multimedia MCI.

Valor | Descripción
False | Todos los botones del control están desactivados (atenuados).
True | (Predeterminado) El control está activado. Use la propiedad AutoEnable para permitir que el control Multimedia MCI active o desactive automáticamente los botones del control. O bien, use las propiedades Botón Enable para activar o desactivar botones individuales del control.

Tipo de datos

Integer (booleano)


ErrorMessage (Propiedad, control Multimedia MCI)

Describe el código de error almacenado en la propiedad Error. Esta propiedad no está disponible en tiempo de diseño y es de sólo lectura en tiempo de ejecución.

Sintaxis

[formulario.]ControlMM.ErrorMessage

Tipo de datos

String


Error (Propiedad, control Multimedia MCI)

Especifica el código de error devuelto por el último comando MCI. Esta propiedad no está disponible en tiempo de diseño y es de sólo lectura en tiempo de ejecución.

Sintaxis

[formulario.]ControlMM.Error

Comentarios

Si el último comando MCI no ha causado ningún error, este valor es 0.

Tipo de datos

Integer


FileName (Propiedad, control Multimedia MCI)

Especifica el archivo que se va a abrir con el comando Open o a guardar con el comando Save. Para cambiar la propiedad FileName en tiempo de ejecución, debe cerrar y volver a abrir el control Multimedia MCI.

Sintaxis

[formulario.]ControlMM.FileName[ = expresiónCadena$]

Comentarios

El argumento expresiónCadena$ especifica el archivo que se va a abrir o a guardar.

Tipo de datos

String


Ejemplo de la propiedad FileName del control Multimedia MCI

Ejemplo de Visual Basic

Para cambiar la propiedad FileName de un control Multimedia MCI en tiempo de ejecución, debe cerrar y volver a abrir el control Multimedia MCI.

El ejemplo siguiente busca un elemento seleccionado, cierra el control Multimedia MCI, restablece la propiedad DeviceType, restablece la propiedad FileName con el elemento seleccionado y después vuelve a abrir el control Multimedia MCI. Para probar este ejemplo, coloque un control Multimedia MCI y un FileListBox en un formulario y pegue el código en la sección Declaraciones del formulario.

Private Sub File1_Click()
   Dim i As Integer
   For i = 0 To File1.ListCount - 1
      If File1.Selected(i) = True Then
         MMControl1.Command = "close"
         MMControl1.DeviceType = "WaveAudio"
         MMControl1.FileName = "c:\windows\" & File1.List(i)
         MMControl1.Command = "open"
      End If
   Next i
End Sub


Frames (Propiedad, control Multimedia MCI)

Especifica el número de imágenes que avanza el comando Step o que retrocede el comando Back. Esta propiedad no está disponible en tiempo de diseño.

Sintaxis

[formulario.]ControlMM.Frames[ = imágenes& ]

Comentarios

El argumento imágenes& especifica el número de imágenes que se avanzará o retrocederá.

Tipo de datos

Long


From (Propiedad, control Multimedia MCI)

Especifica el punto de inicio, como se define en la propiedad TimeFormat del control Multimedia MCI, para el comando Play o Record. Esta propiedad no está disponible en tiempo de diseño.

Sintaxis

[formulario.]ControlMM.From[ = ubicación&]

Comentarios

El argumento ubicación& especifica el punto de partida para la operación de reproducir o grabar. El formato de hora activo se establece en la propiedad TimeFormat.

El valor que asigne a esta propiedad sólo se usará con el siguiente comando MCI. Los comandos MCI subsiguientes pasan por alto la propiedad From hasta que le asigne otro valor (diferente o idéntico).

Tipo de datos

Long


Length (Propiedad, control Multimedia MCI)

Especifica la longitud de los medios de un dispositivo MCI abierto, como se especifica en la propiedad TimeFormat del control Multimedia MCI. Esta propiedad no está disponible en tiempo de diseño y es de sólo lectura en tiempo de ejecución.

Sintaxis

[formulario.]ControlMM.Length

Tipo de datos

Long


Mode (Propiedad, control Multimedia MCI)

Devuelve el modo actual de un dispositivo MCI que está abierto. Esta propiedad no está disponible en tiempo de diseño y es de sólo lectura en tiempo de ejecución.

Sintaxis

[formulario.]ControlMM.Mode

Comentarios

En la tabla siguiente se enumeran los valores devueltos de la propiedad Mode para el control Multimedia MCI.

Valor | Constante y modo del dispositivo | Descripción
524 | mciModeNotOpen | El dispositivo no está abierto.
525 | mciModeStop | Parar dispositivo.
526 | mciModePlay | Reproducir dispositivo.
527 | mciModeRecord | Grabar dispositivo.
528 | mciModeSeek | Buscar dispositivo.
529 | mciModePause | Pausa dispositivo.
530 | mciModeReady | Dispositivo preparado.

Tipo de datos

Long


Notify (Propiedad, control Multimedia MCI)

Determina si el siguiente comando MCI usa el servicio de notificación de MCI. Si está establecida a True, la propiedad Notify genera un evento de devolución de llamada (evento Done), que se produce cuando se ha completado el siguiente comando MCI. Esta propiedad no está disponible en tiempo de diseño.

Sintaxis

[formulario.]ControlMM.Notify[ = {True | False}]

Comentarios

En la tabla siguiente se enumeran los valores de la propiedad Notify para el control Multimedia MCI.

Valor | Descripción
False | (Predeterminado) El comando siguiente no genera el evento Done.
True | El comando siguiente genera el evento Done.

El valor que se asigna a esta propiedad se usa sólo con el comando MCI siguiente. Los comandos MCI subsiguientes pasan por alto la propiedad Notify hasta que le asigne otro valor (diferente o idéntico).

Nota Los mensajes de notificación se anulan cuando envía un comando nuevo que impide que se cumplan las condiciones de devolución de llamada establecidas por un comando anterior. Por ejemplo, para reiniciar un dispositivo que está en pausa y que no admite el comando MCI Resume, el control Multimedia MCI envía el comando Play al dispositivo que está en pausa. No obstante, el comando Play que reinicia el dispositivo establece condiciones de devolución de llamada, invalidando así las condiciones de devolución de llamada y las notificaciones pendientes de los comandos anteriores.

Tipo de datos

Integer (booleano)


NotifyMessage (Propiedad, control Multimedia MCI)

Describe el código de notificación devuelto en el evento Done desencadenado por la propiedad Notify. La propiedad NotifyMessage no está disponible en tiempo de diseño y es de sólo lectura en tiempo de ejecución.

Sintaxis

[formulario.]ControlMM.NotifyMessage

Tipo de datos

String


NotifyValue (Propiedad, control Multimedia MCI)

Especifica el resultado del último comando MCI que ha pedido una notificación. Esta propiedad no está disponible en tiempo de diseño y es de sólo lectura en tiempo de ejecución.

Sintaxis

[formulario.]ControlMM.NotifyValue

Comentarios

En la tabla siguiente se enumeran los valores devueltos de la propiedad NotifyValue para el control Multimedia MCI.

Valor | Constante y modo del dispositivo
1 | mciNotifySuccessful
 | El comando se completó satisfactoriamente.
2 | mciNotifySuperseded
 | El comando se sustituyó por otro comando.
4 | mciNotifyAborted
 | El usuario anuló el comando.
8 | mciNotifyFailure
 | El comando falló.

El programa puede comprobar el código Notify devuelto en el evento Done para determinar el último comando MCI que ha producido este valor.

Tipo de datos

Integer (Enumerado)


Orientation (Propiedad, control Multimedia MCI)

Determina si los botones del control se disponen de forma horizontal o vertical.

Sintaxis

[formulario.]ControlMM.Orientation[ = orientación%]

Comentarios

En la tabla siguiente se enumeran los valores de la propiedad Orientation para el control Multimedia MCI.

Constante | Valor | Descripción
mciOrientHorz | 0 | Botones dispuestos horizontalmente.
mciOrientVert | 1 | Botones dispuestos verticalmente.

Tipo de datos

Integer (Enumerado)


Position (Propiedad, control Multimedia MCI)

Especifica la posición actual de un dispositivo MCI como se define en la propiedad TimeFormat del control Multimedia MCI. Esta propiedad no está disponible en tiempo de diseño y es de sólo lectura en tiempo de ejecución.

Sintaxis

[formulario.]ControlMM.Position

Tipo de datos

Long


RecordMode (Propiedad, control Multimedia MCI)

Especifica el modo de grabación actual de los dispositivos MCI compatibles con grabación.

Sintaxis

[formulario.]ControlMM.RecordMode[ = modo%]

Comentarios

En la tabla siguiente se enumeran los valores de la propiedad RecordMode para el control Multimedia MCI.

Constante | Valor | Modo de grabación
mciRecordInsert | 0 | Modo de insertar grabación.
mciRecordOverwrite | 1 | Modo de sobrescribir grabación.

Para determinar si un dispositivo permite grabar, compruebe la propiedad CanRecord.

Un dispositivo que permite grabar puede admitir uno o los dos modos de grabación. No hay ninguna forma de saber previamente qué modo admite un dispositivo. Si falla la grabación en un modo, pruebe el otro.

Los dispositivos WaveAudio sólo admiten el modo Insertar.

Tipo de datos

Integer (Enumerado)


Shareable (Propiedad, control Multimedia MCI)

Determina si varios programas pueden compartir el mismo dispositivo MCI.

Sintaxis

[formulario.]Control.Shareable[ = {True | False}]

Comentarios

En la tabla siguiente se enumeran los valores de la propiedad Shareable para el control Multimedia MCI.

Valor | Descripción
False | Ningún otro control o aplicación puede tener acceso a este dispositivo.
True | Más de un control o aplicación pueden abrir este dispositivo.

Tipo de datos

Integer (booleano)


Silent (Propiedad, control Multimedia MCI)

Determina si se reproduce el sonido.

Sintaxis

[formulario.]ControlMM.Silent[ = {True | False}]

Comentarios

En la tabla siguiente se enumeran los valores de la propiedad Silent para el control Multimedia MCI.

Valor | Descripción
False | Se puede reproducir cualquier sonido.
True | Se desactiva el sonido.

Tipo de datos

Integer (booleano)


Start (Propiedad, control Multimedia MCI)

Especifica la posición inicial del medio actual, como se define en la propiedad TimeFormat del control Multimedia MCI. Esta propiedad no está disponible en tiempo de diseño y es de sólo lectura en tiempo de ejecución.

Sintaxis

[formulario.]ControlMM.Start

Tipo de datos

Long


TimeFormat (Propiedad, control Multimedia MCI)

Especifica el formato de hora que se usa para indicar toda la información de posición.

Sintaxis

[formulario.]ControlMM.TimeFormat[ = formato& ]

Comentarios

En la tabla siguiente se enumeran los valores de la propiedad TimeFormat para el control Multimedia MCI.

Valor | Constante y formato de hora
0 | mciFormatMilliseconds
 | Los milisegundos se almacenan como variables de enteros de 4 bytes.
1 | mciFormatHms
 | Las horas, minutos y segundos se empaquetan en un entero de 4 bytes. Los valores de cada dato, del byte menos significativo al byte más significativo, son los siguientes:
 | Horas (byte menos significativo).
 | Minutos.
 | Segundos.
 | Sin usar (byte más significativo).
2 | mciFormatMsf
 | Los minutos, los segundos y las imágenes se empaquetan en un entero de 4 bytes. Los valores de cada dato, del byte menos significativo al byte más significativo, son los siguientes:
 | Minutos (byte menos significativo).
 | Segundos.
 | Tramas.
 | Sin usar (byte más significativo).
3 | mciFormatFrames
 | Las imágenes se almacenan como variables de enteros de 4 bytes.
4 | mciFormatSmpte24
 | El formato SMPTE de 24 imágenes empaqueta los valores siguientes en una variable de 4 bytes, del byte menos significativo al byte más significativo:
 | Horas (byte menos significativo).
 | Minutos.
 | Segundos.
 | Imágenes (byte más significativo).
 | La hora SMPTE (Society of Motion Picture and Television Engineers) es un formato de tiempo absoluto que se expresa en horas, minutos, segundos e imágenes. Los tipos de división estándar de SMPTE son 24, 25 y 30 imágenes por segundo.
5 | mciFormatSmpte25
 | El formato SMPTE de 25 imágenes empaqueta los datos en la variable de 4 bytes en el mismo orden que el SMPTE de 24 imágenes.
6 | mciFormatSmpte30
 | El formato SMPTE de 30 imágenes empaqueta los datos en la variable de 4 bytes en el mismo orden que el SMPTE de 24 imágenes.
7 | mciFormatSmpte30Drop
 | El formato SMPTE de 30 imágenes desplegables empaqueta los datos en la variable de 4 bytes en el mismo orden que el SMPTE de 24 imágenes.
8 | mciFormatBytes
 | Los bytes se almacenan como variables de enteros de 4 bytes.
9 | mciFormatSamples
 | Los ejemplos se almacenan como variables de enteros de 4 bytes.
10 | mciFormatTmsf
 | Las pistas, minutos, segundos e imágenes se empaquetan en variables de 4 bytes, del byte menos significativo al byte más significativo:
 | Pistas (byte menos significativo).
 | Minutos.
 | Segundos.
 | Imágenes (byte más significativo).
 | Nota Tenga en cuenta que MCI usa una numeración continua de pistas.

Nota No todos los dispositivos admiten todos los formatos. Si intenta establecer un formato no válido, se pasará por alto el valor asignado.

La información de tiempo actual se pasa siempre a los programas en forma de un entero de 4 bytes. En algunos formatos, la información de tiempo que se devuelve no es realmente un entero, sino bytes sencillos de información empaquetados en el entero largo. Las propiedades que tienen acceso a la información o la envían en el formato de hora actual son: From, Length, Position, Start, To, TrackLength y TrackPosition.

Tipo de datos

Long (Enumerado)


To (Propiedad, control Multimedia MCI)

Especifica el punto final, como se define en la propiedad TimeFormat del control Multimedia MCI, para los comandos Play o Record. Esta propiedad no está disponible en tiempo de diseño.

Sintaxis

[formulario.]ControlMM.To[ = ubicación&]

Comentarios

El argumento ubicación& especifica el punto final para las operaciones de reproducir o grabar. El formato de hora actual se establece en la propiedad TimeFormat.

El valor asignado a esta propiedad se usa únicamente con el siguiente comando MCI. Los comandos MCI subsiguientes pasan por alto la propiedad To hasta que se le asigne otro valor (diferente o idéntico).

Tipo de datos

Long


Track (Propiedad, control Multimedia MCI)

Especifica la pista acerca de la cual devuelven información las propiedades TrackLength y TrackPosition. Esta propiedad no está disponible en tiempo de diseño.

Sintaxis

[formulario.]ControlMM.Track[ = pista&]

Comentarios

El argumento pista& especifica el número de pista.

Esta propiedad se usa sólo para obtener información acerca de una pista determinada. No tiene ninguna relación con la pista activa.

Tipo de datos

Long


TrackLength (Propiedad, control Multimedia MCI)

Especifica la longitud de la pista definida por la propiedad Track, como se define en la propiedad TimeFormat del control Multimedia MCI. Esta propiedad no está disponible en tiempo de diseño y es de sólo lectura en tiempo de ejecución.

Sintaxis

[formulario.]ControlMM.TrackLength

Tipo de datos

Long


TrackPosition (Propiedad, control Multimedia MCI)

Especifica la posición inicial de la pista definida por la propiedad Track, como se define en la propiedad TimeFormat del control Multimedia MCI. Esta propiedad no está disponible en tiempo de diseño y es de sólo lectura en tiempo de ejecución.

Sintaxis

[formulario.]ControlMM.TrackPosition

Tipo de datos

Long


Tracks (Propiedad, control Multimedia MCI)

Especifica el número de pistas disponibles en el dispositivo MCI actual. Esta propiedad no está disponible en tiempo de diseño y es de sólo lectura en tiempo de ejecución.

Sintaxis

[formulario.]ControlMM.Tracks

Tipo de datos

Long


UpdateInterval (Propiedad, control Multimedia MCI)

Especifica el número de milisegundos que transcurren entre dos eventos StatusUpdate sucesivos.

Sintaxis

[formulario.]ControlMM.UpdateInterval[ = milisegundos%]

Comentarios

El argumento milisegundos% especifica el número de milisegundos transcurridos entre dos eventos. Si milisegundos es 0, no se produce el evento StatusUpdate.

Tipo de datos

Integer


UsesWindows (Propiedad, control Multimedia MCI)

Determina si el dispositivo MCI que está abierto usa una ventana para mostrar el resultado. Esta propiedad no está disponible en tiempo de diseño y es de sólo lectura en tiempo de ejecución.

Sintaxis

[formulario.]ControlMM.UsesWindows

Comentarios

En la tabla siguiente se enumeran los valores devueltos de la propiedad UsesWindows para el control Multimedia MCI.

Valor | Descripción
False | El dispositivo actual no usa una ventana para mostrar el resultado.
True | El dispositivo actual usa una ventana.

Actualmente, sólo los dispositivos MMMovie y Overlay usan ventanas para presentar su resultado. Como no hay ningún modo de saber si un dispositivo usa ventanas, el valor de UsesWindows se establece durante el procesamiento del comando Open, que comprueba el tipo de dispositivo. Si el tipo de dispositivo es MMMovie, Overlay o VCR, el dispositivo usa ventanas.

Con los dispositivos que usan ventanas es posible usar la propiedad hWndDisplay para establecer la ventana que presentará el resultado.

Tipo de datos

Integer (booleano)


Visible (Propiedad, control Multimedia MCI)

Determina si el control Multimedia MCI será visible o invisible en tiempo de ejecución.

Sintaxis

[formulario.]ControlMM.Visible[ = {True | False}]

Comentarios

El efecto de la propiedad Visible invalida los efectos de las propiedades Botón Visible individuales. Cuando el control Multimedia MCI es visible, las propiedades Botón Visible individuales controlan la visibilidad de los botones asociados al control. Cuando la propiedad Visible está establecida a False, no se ve el control y no se usan las propiedades Botón Visible.

En la tabla siguiente se enumeran los valores de la propiedad Visible para el control Multimedia MCI.

Valor | Descripción
False | El control no es visible.
True | (Predeterminado) Cada botón se ve o se oculta individualmente, dependiendo de su propiedad Botón Visible. La función de cada botón está disponible en el control.

Tipo de datos

Integer (booleano)


Wait (Propiedad, control Multimedia MCI)

Determina si el control Multimedia MCI espera a completar el siguiente comando MCI antes de devolver el control a la aplicación. Esta propiedad no está disponible en tiempo de diseño.

Sintaxis

[formulario.]ControlMM.Wait[ = {True | False}]

Comentarios

En la tabla siguiente se enumeran los valores de la propiedad Wait para el control Multimedia MCI.

Valor | Descripción
False | El control Multimedia MCI no espera a que se complete el comando MCI antes de devolver el control a la aplicación.
True | El control Multimedia MCI espera a que se complete el siguiente comando MCI antes de devolver el control a la aplicación.

El valor que asigne a esta propiedad sólo se usará con el siguiente comando MCI. Los comandos MCI subsiguientes pasan por alto la propiedad Wait hasta que le asigne otro valor (diferente o idéntico).

Tipo de datos

Integer (booleano)