MSChart (Control)

Un gráfico que muestra datos en forma gráfica.

Sintaxis

MSChart

Comentarios

El control MSChart acepta las características siguientes:

  • Verdadera representación tridimensional.

  • Acepta los principales tipos de gráficos.

  • Rellena las cuadrículas de datos mediante datos aleatorios y matrices de datos.

El control MSChart está asociado con una cuadrícula de datos (objeto DataGrid). Esta cuadrícula de datos es una tabla que contiene los datos que se mostrarán en el gráfico. La cuadrícula de datos también puede incluir etiquetas para identificar las series y categorías del gráfico. La persona que diseña la aplicación de gráficos rellena la cuadrícula de datos con información al insertar los datos o al importarlos de una hoja de cálculo o de una matriz.


No se encuentra el tema

No se halló el tema correspondiente. A continuación enumeramos algunas posibles razones y sus soluciones:

  • El archivo (.chm) que contiene el tema de destino no se encuentra en la ubicación esperada.

    Solución: vuelva a ejecutar la instalación de la Biblioteca MSDN.

  • El archivo (.chm) que contiene el tema actual o el de destino no está actualizado y el vínculo ya no es válido.

    Solución: instale la última versión de la Biblioteca MSDN.

  • El CD de la Biblioteca MSDN no está en la unidad de CD-ROM.

    Solución: inserte el CD en la unidad.


DataPoints (Colección)

Un grupo de puntos de datos de un gráfico.

Sintaxis

objeto.DataPoints (índice)

La sintaxis de la colección DataPoints consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
índice | Identifica un punto de datos específico de la serie actual. En esta versión del gráfico, el único valor válido para este argumento es –1. Esto le permite realizar cambios en la configuración predeterminada de todos los puntos de datos de la serie. No se puede cambiar la configuración de puntos de datos individuales de la serie.


Ejemplo de la colección DataPoints

El ejemplo siguiente establece los marcadores de un punto de datos de un gráfico.

Private Sub Command1_Click()
   With MSChart1.Plot.SeriesCollection(1).DataPoints(-1)
   ' Hace que el marcador de DataPoint sea visible.
      .Marker.Visible = True
      .Marker.Style = VtMarkerStyleDiamond
   End With
End Sub

El método Item de la colección Datapoints utiliza el argumento especial (–1) para designar las propiedades predeterminadas de todos los puntos de datos de la serie. El objeto Datapoint devuelto por Item(–1) se puede manipular como un objeto Datapoint normal. Establecer una propiedad en este punto de datos predeterminado afecta a todos los puntos de datos de la serie, excepto a aquellos puntos de datos para los que se ha establecido esta propiedad individualmente. En el ejemplo, la etiqueta del punto de datos para cada serie se establece en tres ubicaciones diferentes. El hecho de que las configuraciones de los puntos de datos individuales vayan delante o detrás de la configuración predeterminada no supone ninguna diferencia; la configuración individual siempre prevalece sobre la configuración predeterminada. Se puede usar el método ResetCustom para eliminar la configuración individual de un punto de datos y hacer que utilice la configuración predeterminada de la serie.

Option Explicit
Option Base 1
Private Sub Command1_Click()
   With MSChart1.Plot
      .SeriesCollection(1).DataPoints.Item(-1) _
      .DataPointLabel.LocationType = VtChLabelLocationTypeAbovePoint

      .SeriesCollection(2).DataPoints.Item(-1) _
      .DataPointLabel.LocationType = VtChLabelLocationTypeCenter

      .SeriesCollection(3).DataPoints.Item(-1) _
      .DataPointLabel.LocationType = VtChLabelLocationTypeBase
   End With
End Sub


Labels (Colección)

Un grupo de etiquetas de un eje del gráfico.

Sintaxis

eje.Labels (index)

La sintaxis de la colección Labels consta de las siguientes partes:

Parte | Descripción
eje | Un objeto Axis.
index | Identifica una etiqueta específica del eje (objeto Label) de la colección actual.


Ejemplo de la colección LightSource

El ejemplo siguiente establece las coordenadas e intensidad de un origen de luz y se agrega un origen de luz de un gráfico. Para probar el ejemplo, dibuje un gráfico con un control MSChart y dos controles CommandButton en un formulario. Pegue el código en el módulo de código del objeto Form y ejecute el proyecto. Haga clic en los botones para cambiar el origen de luz.

Option Explicit

Private Sub Form_Load()
   ' Configura el gráfico y su origen de luz.
   With MSChart1
      .chartType = VtChChartType3dBar
      .Plot.Light.AmbientIntensity = 0.01 ' Intensidad del 1 %.
      .Plot.Light.EdgeIntensity = 0.5      ' Intensidad del 50 %.
      .Plot.Light.EdgeVisible = True
   End With
End Sub

Private Sub Command1_Click()
   Dim LightSource As Object
   Set LightSource = _
   MSChart1.Plot.Light.LightSources(1)
   ' Establece las coordenadas del origen de luz 1
   ' así como su intensidad.
   LightSource.X = 1
   LightSource.y = 0.5
   LightSource.Z = 1
   LightSource.Intensity = 1
End Sub

Private Sub Command2_Click()
   ' Agrega un nuevo origen de luz.
   MSChart1.Plot.Light.LightSources.Add 0.5, 0.1, 1, 1
End Sub


LightSources (Colección)

Un grupo de objetos LightSource de un gráfico.

Sintaxis

objeto.LightSources (index)

La sintaxis de la colección LightSources tiene las partes siguientes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
index | Integer. Un número que identifica de forma única a un miembro de la colección.


Series (Colección)

Una colección de series del gráfico.

Sintaxis

Series (índice)

La sintaxis de la colección Series consta de la siguiente parte:

Parte | Descripción
índice | Integer. Identifica la serie del gráfico. Las series se identifican en el orden de las columnas de la cuadrícula de datos, a partir de 1.


SeriesCollection (Colección)

Proporciona información acerca de la serie que conforma un gráfico.

Sintaxis

SeriesCollection (índice)

La sintaxis de la colección SeriesCollection consta de la siguiente parte:

Parte | Descripción
índice | Identifica una serie específica de la colección de series.


Ejemplo de las colecciones SeriesCollection y Series

El ejemplo siguiente oculta todas las series de un gráfico.

Private Sub Command1_Click()
   Dim serX As Series
   ' Oculta todas las series.
   For Each serX In MSChart1.Plot.SeriesCollection
      serX.Position.Hidden = True
   Next
End Sub


AngleUnits (Constantes)

Las constantes VtAngleUnits proporcionan las unidades válidas para medir los ángulos del gráfico.

Constantes | Descripción
VtAngleUnitsDegrees | Los ángulos del gráfico se miden en grados.
VtAngleUnitsRadians | Los ángulos del gráfico se miden en radianes.
VtAngleUnitsGrads | Los ángulos del gráfico se miden en gradientes.


AxisId (Constantes)

Las constantes VtChAxisId proporcionan opciones para identificar un eje del gráfico.

Constantes | Descripción
VtChAxisIdX | Identifica el eje x.
VtChAxisIdY | Identifica el eje y.
VtChAxisIdY2 | Identifica el eje y secundario.
VtChAxisIdZ | Identifica el eje z.


AxisTickStyle (Constantes)

Las constantes VtChAxisTickStyle proporcionan opciones para indicar la ubicación de las marcas del eje.

Constantes | Descripción
VtChAxisTickStyleNone | No se muestran marcas en el eje.
VtChAxisTickStyleCenter | Las marcas se centran a lo largo del eje.
VtChAxisTickStyleInside | Las marcas se muestran dentro del eje.
VtChAxisTickStyleOutside | Las marcas se muestran fuera del eje.


BorderStyle (Constantes, control MSChart)

Las constantes VtBorderStyle proporcionan opciones para el tipo de borde que se colocará alrededor del control del gráfico.

Constante | Descripción
VtBorderStyleFixedSingle | Se coloca un borde simple alrededor del control del gráfico.
VtBorderStyleNone | No se coloca ningún borde alrededor del control del gráfico.


BrushHatch (Constantes)

Las constantes VtBrushHatch proporcionan los tipos de pincel válidos si la constante VtBrushStyle está establecida a VtBrushStyleHatch.

Constante | Descripción
VtBrushHatchHorizontal | Líneas horizontales de trama.
VtBrushHatchVertical | Líneas verticales de trama.
VtBrushHatchDownDiagonal | Líneas diagonales hacia abajo de trama.
VtBrushHatchUpDiagonal | Líneas diagonales hacia arriba de trama.
VtBrushHatchCross | Líneas cruzadas de trama.
VtBrushHatchDiagonalCross | Líneas diagonales cruzadas de trama.


BrushPattern (Constantes)

Las constantes VtBrushPattern proporcionan los tipos válidos de pincel cuando la constante VtBrushStyle está establecida a VtBrushStylePattern.

Constantes | Descripción
VtBrushPattern94percent | 94 por ciento de color de patrón.
VtBrushPattern88percent | 88 por ciento de color de patrón.
VtBrushPattern75percent | 75 por ciento de color de patrón.
VtBrushPattern50percent | 50 por ciento de color de patrón.
VtBrushPattern25percent | 25 por ciento de color de patrón.
VtBrushPatternBoldHorizontal | Líneas horizontales gruesas.
VtBrushPatternBoldVertical | Líneas verticales gruesas.
VtBrushPatternBoldDownDiagonal | Líneas diagonales hacia abajo gruesas.
VtBrushPatternBoldUpDiagonal | Líneas diagonales hacia arriba gruesas.
VtBrushPatternChecks | Comprueba patrones.
VtBrushPatternWeave | Patrón entrelazado.
VtBrushPatternHorizontal | Líneas horizontales.
VtBrushPatternVertical | Líneas verticales.
VtBrushPatternDownDiagonal | Líneas diagonales hacia abajo.
VtBrushPatternUpDiagonal | Líneas diagonales hacia arriba.
VtBrushPatternGrid | Patrón de cuadrícula.
VtBrushPatternTrellis | Patrón enrejado.
VtBrushPatternInvertedTrellis | Patrón enrejado invertido.


BrushStyle (Constantes)

Las constantes VtBrushStyle proporcionan los tipos de pincel válidos.

Constante | Descripción
VtBrushStyleNull | Sin pincel (se muestra el fondo).
VtBrushStyleSolid | Pincel de color sólido.
VtBrushStylePattern | Pincel con patrón de mapa de bits.
VtBrushStyleHatched | Pincel tramado.


ChartType (Constantes)

Las constantes VtChChartType proporcionan las opciones del tipo de gráfico.

Constante | Descripción
VtChChartType3dBar | Barra 3D.
VtChChartType2dBar | Barra 2D.
VtChChartType3dLine | Línea 3D.
VtChChartType2dLine | Línea 2D.
VtChChartType3dArea | Área 3D.
VtChChartType2dArea | Área 2D.
VtChChartType3dStep | Paso 3D.
VtChChartType2dStep | Paso 2D.
VtChChartType3dCombination | Combinación 3D.
VtChChartType2dCombination | Combinación 2D.
VtChChartType2dPie | Gráfico circular 2D.
VtChChartType2dXY | XY 2D.


DrawMode (Constantes)

Las constantes VtChDrawMode proporcionan opciones para volver a mostrar el gráfico después de modificarlo.

Constantes | Descripción
VtChDrawModeDraw | Modo de dibujo. El gráfico se vuelve a dibujar en la pantalla cada vez que varían sus valores.
VtChDrawModeBlit | Modo de ajuste. El gráfico se vuelve a dibujar fuera de la pantalla y se muestra cuando ha terminado de dibujarse.

El modo de ajuste almacena una copia de mapa de bits del gráfico en la memoria cuando está diseñado el gráfico. Para volver a dibujar el gráfico, se utiliza el mapa de bits y se dibuja muy rápido. Necesita más memoria que el modo de dibujo, pero puede ahorrar el tiempo de volver a dibujar el gráfico en la pantalla. El modo de ajuste es particularmente útil cuando se trabaja con gráficos que contienen muchos elementos.


FillStyle (Constantes)

Las constantes VtFillStyle proporcionan opciones para indicar el tipo de relleno utilizado para pintar el fondo.

Constante | Descripción
VtFillStyleNull | Sin relleno (fondo transparente).
VtFillStyleBrush | Relleno de patrón o de color sólido.


FontEffect (Constantes)

Las constantes VtFontEffect proporcionan métodos para alterar las fuentes con el efecto deseado.

Constante | Descripción
VtFontEffectStrikeThrough | Aplica a la fuente el atributo tachado.
VtFontEffectUnderline | Aplica a la fuente el atributo subrayado.


FontStyle (Constantes)

Las constantes VtFontStyle proporcionan opciones válidas de atributos de fuentes.

Constante | Descripción
VtFontStyleBold | Aplica a la fuente el atributo negrita.
VtFontStyleItalic | Aplica a la fuente el atributo cursiva.
VtFontStyleOutline | Aplica a la fuente el atributo contorno.


FrameStyle (Constantes)

Las constantes VtFrameStyle proporcionan opciones para mostrar marcos de fondo.

Constante | Descripción
VtFrameStyleNull | Sin marco.
VtFrameStyleSingleLine | Se rodea el fondo con una línea simple.
VtFrameStyleDoubleLine | Se rodea el fondo con dos líneas del mismo ancho.
VtFrameStyleThickInner | Se rodea el fondo con una línea gruesa interior y una línea delgada exterior.
VtFrameStyleThickOuter | Se rodea el fondo con una línea delgada interior y una línea gruesa exterior.


HorizontalAlignment (Constantes)

Las constantes VtHorizontalAlignment proporcionan opciones para la alineación del texto.

Constante | Descripción
VtHorizontalAlignmentLeft | Todas las líneas del texto se alinean en el margen izquierdo.
VtHorizontalAlignmentRight | Todas las líneas del texto se alinean en el margen derecho.
VtHorizontalAlignmentCenter | Todas las líneas se centran horizontalmente.


LabelComponent (Constantes)

Las constantes VtChLabelComponent proporcionan opciones para mostrar las etiquetas del gráfico.

Constante | Descripción
VtChLabelComponentValue | El valor del punto de datos aparece en la etiqueta. Los puntos de datos de los gráficos XY, polar y de burbuja tienen realmente dos o tres valores. La etiqueta predeterminada de estos tipos de gráficos mostrará todos los valores en un formato estándar. Puede personalizar este formato para resaltar un valor de datos individual.
VtChLabelComponentPercent | El valor del punto de datos se muestra en la etiqueta como un porcentaje del valor total de la serie.
VtChLabelComponentSeriesName | El nombre de la serie se utiliza para colocar una etiqueta en el punto de datos. Este nombre se obtiene de la etiqueta asociada a la columna en la cuadrícula de datos.
VtChLabelComponentPointName | El nombre del punto de datos se utiliza para colocar una etiqueta en el punto de datos.


LabelLineStyle (Constantes)

Las constantes VtChLabelLineStyle proporcionan opciones para mostrar líneas que conectan etiquetas y series.

En la tabla siguiente se enumeran las constantes válidas de VtChLabelLineStyle:

Constantes | Descripción
VtChLabelLineStyleNone | No hay ninguna línea que conecte la etiqueta y la serie.
VtChLabelLineStyleStraight | La etiqueta y la serie se conectan con una línea recta.
VtChLabelLineStyleBent | La etiqueta y la serie se conectan con una línea inclinada.


LabelLocationType (Constantes)

Las constantes VtChLabelLocationType proporcionan opciones para determinar la ubicación de las etiquetas de la serie.

En la tabla siguiente se enumeran las constantes válidas de VtChLabelLocationType:

Constantes | Descripción
VtChLabelLocationTypeNone | No se muestra ninguna etiqueta.
VtChLabelLocationTypeAbovePoint | La etiqueta se muestra sobre el punto de datos.
VtChLabelLocationTypeBelowPoint | La etiqueta se muestra debajo del punto de datos.
VtChLabelLocationTypeCenter | La etiqueta se centra sobre el punto de datos.
VtChLabelLocationTypeBase | La etiqueta se muestra en la base, a lo largo del eje de categoría, directamente debajo del punto de datos.
VtChLabelLocationTypeInside | La etiqueta se muestra dentro de un sector de un gráfico circular.
VtChLabelLocationTypeOutside | La etiqueta se muestra fuera de un sector de un gráfico circular.
VtChLabelLocationTypeLeft | La etiqueta se muestra a la izquierda del punto de datos.
VtChLabelLocationTypeRight | La etiqueta se muestra a la derecha del punto de datos.


LocationType (Constantes)

Las constantes VtChLocationType proporcionan opciones de ubicación para los elementos del gráfico.

Constante | Ejemplo
VtChLocationTypeTop | Arriba.
VtChLocationTypeTopLeft | Arriba a la izquierda.
VtChLocationTypeTopRight | Arriba a la derecha.
VtChLocationTypeLeft | Izquierda.
VtChLocationTypeRight | Derecha.
VtChLocationTypeBottom | Abajo.
VtChLocationTypeBottomLeft | Abajo a la izquierda.
VtChLocationTypeBottomRight | Abajo a la derecha.
VtChLocationTypeCustom | Personalizada.


MarkerStyle (Constantes)

Las constantes VtMarkerStyle proporcionan opciones para mostrar marcadores de puntos de datos.

Constante | Descripción
VtMarkerStyleNull | Sin marcador.
VtMarkerStyleDash | Marcador de raya.
VtMarkerStylePlus | Marcador de signo más.
VtMarkerStyleX | Marcador X.
VtMarkerStyleStar | Marcador de estrella.
VtMarkerStyleCircle | Marcador circular.
VtMarkerStyleSquare | Marcador cuadrado.
VtMarkerStyleDiamond | Marcador de rombo.
VtMarkerStyleUpTriangle | Marcador de triángulo.
VtMarkerStyleDownTriangle | Marcador de triángulo invertido.
VtMarkerStyleFilledCircle | Marcador de círculo relleno.
VtMarkerStyleFilledSquare | Marcador de cuadrado relleno.
VtMarkerStyleFilledDiamond | Marcador de rombo relleno.
VtMarkerStyleFilledUpTriangle | Marcador de triángulo relleno.
VtMarkerStyleFilledDownTriangle | Marcador de triángulo invertido relleno.
VtMarkerStyle3dBall | Marcador de bola tridimensional.


MouseFlag (Constantes)

Las constantes VtChMouseFlag indican qué tecla está presionada mientras se hace clic con el botón del mouse (ratón).

Constante | Descripción
VtChMouseFlagShiftKeyDown | Está presionada la tecla MAYÚS mientras se hace clic con el botón del mouse.
VtChMouseFlagControlKeyDown | Está presionada la tecla CTRL mientras se hace clic con el botón del mouse.


MousePointer (Constantes)

Las constantes VtMousePointer proporcionan los tipos de punteros siguientes:

Constante | Descripción
VtMousePointerArrow | Puntero en forma de flecha.
VtMousePointerArrowHourGlass | Con flecha y reloj de arena.
VtMousePointerArrowQuestion | Con flecha y signo de interrogación.
VtMousePointerCross | Puntero en forma de cruz.
VtMousePointerDefault | Puntero predeterminado del gráfico.
VtMousePointerHourGlass | Puntero de reloj de arena.
VtMousePointerIbeam | Puntero en forma de I.
VtMousePointerIcon | Pequeño cuadrado dentro de un puntero cuadrado.
VtMousePointerNoDrop | Sin puntero para colocar.
VtMousePointerSize | Flechas de cambio de tamaño.
VtMousePointerSizeAll | Flechas de cambio de tamaño en todas las direcciones.
VtMousePointerSizeNESW | Puntero de doble flecha noreste y sudoeste.
VtMousePointerNS | Puntero de doble flecha norte y sur.
VtMousePointerNWSE | Puntero de doble flecha noroeste y sudeste.
VtMousePointerWE | Puntero de doble flecha este y oeste.
VtMousePointerUpArrow | Flecha hacia arriba.


Orientation (Constantes)

Las constantes VtOrientation proporcionan opciones para colocar texto.

Constante | Descripción
VtOrientationHorizontal | El texto se muestra horizontalmente.
VtOrientationVertical | Las letras del texto se dibujan una encima de otra de arriba a abajo.
VtOrientationUp | El texto se rota para que se lea de abajo a arriba.
VtOrientationDown | El texto se rota para que se lea de arriba a abajo.


PartType (Constantes)

Las constantes VtChPartType proporcionan opciones para los elementos del gráfico.

Constante | Descripción
VtChPartTypeChart | Identifica el control del gráfico.
VtChPartTypeTitle | Identifica el título del gráfico.
VtChPartTypeFootnote | Identifica las notas a pie de página del gráfico.
VtChPartTypeLegend | Identifica la leyenda del gráfico.
VtChPartTypePlot | Identifica el trazado del gráfico.
VtChPartTypeSeries | Identifica una serie del gráfico.
VtChPartTypePoint | Identifica un punto de datos individual.
VtChPartTypePointLabel | Identifica una etiqueta de un punto de datos.
VtChPartTypeAxis | Identifica un eje.
VtChPartTypeAxisLabel | Identifica una etiqueta de eje.
VtChPartTypeAxisTitle | Identifica un título de eje.


PenCap (Constantes)

Las constantes VtPenCap proporcionan métodos para mostrar los finales de línea.

Constante | Descripción
VtPenCapButt | La línea se corta en cuadrado al final.
VtPenCapRound | Se dibuja un semicírculo con el diámetro del espesor de la línea al final de la línea.
VtPenCapSquare | La línea continúa más allá del punto final en una distancia igual a la mitad del espesor de la línea y se corta en cuadrado.


PenJoin (Constantes)

Las constantes VtPenJoin proporcionan opciones para unir segmentos de líneas en una serie.

Constante | Descripción
VtPenJoinMiter | Los límites externos de las dos líneas se extienden hasta que se encuentran.
VtPenJoinRound | Se dibuja un arco circular alrededor del punto donde se encuentran las dos líneas.
VtPenJoinBevel | Se rellena el punto entre los finales de las dos líneas que se unen.


PenStyle (Constantes)

Las constantes VtPenStyle proporcionan las opciones del lápiz que se utiliza para dibujar las líneas del gráfico.

Constante | Descripción
VtPenStyleNull | No se aplica el lápiz.
VtPenStyleSolid | Lápiz de línea sólida.
VtPenStyleDashed | Lápiz de línea rayada.
VtPenStyleDotted | Lápiz de línea punteada.
VtPenStyleDashDot | Lápiz de línea raya y punto.
VtPenStyleDashDotDot | Lápiz de línea raya, punto y punto.
VtPenStyleDitted | Lápiz de línea punteada.
VtPenStyleDashDit | Lápiz de línea raya y punteada.
VtPenStyleDashDitDit | Lápiz de línea raya, punto y punto.


PercentAxisBasis (Constantes)

Las constantes VtChPercentAxisBasis proporcionan métodos para mostrar ejes de porcentaje.

Constante | Descripción
VtChPercentAxisBasisMaxChart | Se considera que el valor mayor del gráfico es el 100 por ciento y los demás valores del gráfico se muestran como porcentajes de dicho valor.
VtChPercentAxisBasisMaxRow | Se considera que el valor mayor de cada fila es el 100 por ciento y los demás valores de la fila se muestran como porcentajes de dicho valor.
VtChPercentAxisBasisMaxColumn | Se considera que el valor mayor de cada serie es el 100 por ciento y los demás valores de la serie se muestran como porcentajes de dicho valor.
VtChPercentAxisBasisSumChart | Se suman todos los valores del gráfico y este valor se considera el 100 por ciento. Los demás valores se muestran como porcentajes de dicho valor.
VtChPercentAxisBasisSumRow | Se suman todos los valores de cada fila y se considera que el valor total de cada fila es el 100 por ciento. Los demás valores de la fila se muestran como porcentajes de dicho valor. Esta es la base de cálculo para los gráficos superpuestos de 100 por ciento.
VtChPercentAxisBasisSumColumn | Se suman todos los valores de cada serie para obtener el valor total de cada serie. Todos los valores se muestran como un porcentaje del valor total de su serie.


PieWeightBasis (Constantes)

Las constantes VtChPieWeightBasis proporcionan opciones para mostrar sectores de un gráfico circular.

Constante | Descripción
VtChPieWeightBasisNone | Todos los gráficos circulares se dibujan con el mismo tamaño.
VtChPieWeightBasisTotal | Los valores de los sectores de cada gráfico circular se suman y se identifica el gráfico circular con mayor total. El tamaño de cada gráfico circular se determina mediante la proporción del valor total respecto al mayor gráfico circular.
VtChPieWeightBasisSeries | La primera columna de datos de la cuadrícula contiene el índice de tamaño relativo. Es decir, si tiene 5 categorías, puede controlar el tamaño de los gráficos circulares que representan cada categoría si utiliza la primera columna de la cuadrícula de datos para numerar las filas de 1 a 5. El tamaño del gráfico circular se determina mediante la proporción del valor de la primera columna y el mayor valor de la primera columna. El gráfico circular con el 1 es el mayor y el que tiene el 5 es el menor. Lo normal es excluir esta primera columna de datos para que los valores no se dibujen como sectores del gráfico circular.


PieWeightStyle (Constantes)

Las constantes VtChPieWeightStyle proporcionan opciones para mostrar gráficos circulares individuales en un único gráfico.

Constante | Descripción
VtChPieWeightStyleArea | El área de los gráficos circulares individuales cambia según su peso.
VtChPieWeightStyleDiameter | El diámetro de los gráficos circulares individuales cambia según su peso.


ProjectionType (Constantes)

Las constantes VtProjectionType proporcionan opciones de punto de vista y de perspectiva para mostrar y ver un gráfico.

Constantes | Descripción
VtProjectionTypePerspective | Proporciona la apariencia tridimensional más real. Los objetos lejanos convergen hacia un punto de fuga. Es la proyección predeterminada.
VtProjectionTypeOblique | A veces se denomina de dimensión 2,5. El gráfico tiene profundidad, pero el plano xy no cambia cuando se eleva o se rota el gráfico.
VtProjectionTypeOrthogonal | En esta vista tridimensional no se aplica perspectiva. La ventaja principal de usar este tipo de proyección consiste en que las líneas verticales permanecen verticales, lo que facilita la lectura de algunos gráficos.


ScaleType (Constantes)

Las constantes VtChScaleType proporcionan métodos para trazar los valores de un gráfico y mostrar la escala del gráfico.

Constante | Descripción
VtChScaleTypeLinear | Los valores del gráfico se trazan en una escala lineal con un intervalo de valores que va del mínimo al máximo valor del intervalo del gráfico.
VtChScaleTypeLogarithmic | Los valores del gráfico se trazan en una escala logarítmica y se basan en una escala logarítmica específica establecida en el argumento baseLog de esta función.
VtChScaleTypePercent | Los valores del gráfico se trazan en una escala lineal y se basan en los porcentajes de los valores del intervalo del gráfico.


SeriesType (Constantes)

Las constantes VtChSeriesType proporcionan opciones para los tipos de serie.

Constante | Tipo de serie
VtChSeriesType3dBar | Barra 3D.
VtChSeriesType2dBar | Barra 2D.
VtChSeriesType3dLine | Línea 3D.
VtChSeriesType2dLine | Línea 2D.
VtChSeriesType3dArea | Área 3D.
VtChSeriesType2dArea | Área 2D.
VtChSeriesType3dStep | Paso 3D.
VtChSeriesType2dStep | Paso 2D.
VtChSeriesType2dXY | XY 2D.
VtChSeriesType2dPie | Gráfico circular 2D.


ShadowStyle (Constantes)

Las constantes VtShadowStyle proporcionan las opciones de sombreado.

Constante | Descripción
VtShadowStyleNull | Sin sombra.
VtShadowStyleDrop | Sombra.


SortType (Constantes)

Las constantes VtSortType proporcionan opciones para ordenar los gráficos circulares.

Constante | Descripción
VtSortTypeNone | Los sectores del gráfico circular se dibujan en el orden en que aparecen los datos en la cuadrícula de datos.
VtSortTypeAscending | Los sectores se dibujan en orden, de menor a mayor, a partir del ángulo de inicio y de la dirección de trazado definidos.
VtSortTypeDescending | Los sectores del gráfico circular se dibujan en orden, de mayor a menor, a partir del ángulo de inicio y de la dirección de trazado definidos.


StatsType (Constantes)

Las constantes VtChStats proporcionan métodos para mostrar las líneas de estadísticas de un gráfico.

Constante | Descripción
VtChStatsMinimum | Mostrar el valor mínimo de la serie.
VtChStatsMaximum | Mostrar el valor máximo de la serie.
VtChStatsMean | Mostrar la media matemática de los valores de la serie.
VtChStatsStddev | Mostrar la desviación estándar de los valores de la serie.
VtChStatsRegression | Mostrar la tendencia indicada por los valores de la serie.


SubPlotLabelLocationType (Constantes)

Las constantes VtSubPlotLabelLocationType proporcionan métodos para mostrar la etiqueta del subtrazado.

Constante | Descripción
VtChSubPlotLabelLocationTypeNone | No se muestra la etiqueta del subtrazado.
VtChSubPlotLabelLocationTypeAbove | La etiqueta del subtrazado se muestra por encima del gráfico circular.
VtChSubPlotLabelLocationTypeBelow | La etiqueta del subtrazado se muestra por debajo del gráfico circular.
VtChSubPlotLabelLocationTypeCenter | La etiqueta del subtrazado se centra en el gráfico circular.


TextLengthType (Constantes)

Las constantes VtTextLengthType proporcionan opciones para optimizar el diseño del texto para la pantalla o para la impresora.

Constante | Descripción
VtTextLengthTypeVirtual | Elija esta constante para usar las medidas de las fuentes virtuales TrueType para optimizar el diseño del texto que imprimir. Las medidas de las fuentes virtuales TrueType no son muy precisas en los textos mostrados en pantalla. El texto mostrado en la pantalla puede ser mayor o menor que la medida virtual solicitada. Es posible que el texto más grande no quepa donde se desea y que se corte parte de un carácter, un carácter completo o, en algunos casos, palabras completas.
VtTextLengthTypeDevice | Elija esta constante para optimizar el diseño del texto en la pantalla. El texto de gráficos diseñado para la pantalla siempre se ajusta correctamente al área del gráfico. El texto impreso es, generalmente, un poco más pequeño y, por tanto, puede que el texto aparezca más pequeño en diversos sitios.


TextOutputType (Constantes)

Las constantes VtTextOutputType proporcionan métodos para la salida de texto.

Constante | Descripción
VtTextOutputTypeHardware | Tipo de contexto de dispositivo Null.
VtTextOutputTypePolygon | Tipo de contexto de dispositivo de metarchivo.


UpdateFlags (Constantes)

Las constantes UpdateFlags que se muestran a continuación se pueden usar en algunos eventos para determinar qué parte del gráfico está siendo actualizado.

Constante | Valor | Descripción
VtChNoDisplay | 0 | No hay indicadores de actualización; no afecta a la vista del gráfico.
VtChDisplayPlot | 1 | La actualización hará que se vuelva a dibujar el trazado.
VtChLayoutPlot | 2 | La actualización hará que se vuelva a diseñar el trazado.
VtChDisplayLegend | 4 | La actualización hará que se vuelva a dibujar la leyenda.
VtChLayoutLegend | 8 | La actualización hará que se vuelva a diseñar la leyenda.
VtChLayoutSeries | 16 | La actualización hará que se vuelva a diseñar la serie.
VtChPositionSection | 32 | Se ha movido o cambiado el tamaño de una sección del gráfico.

Comentarios

Estas constantes pueden usarse en los siguientes eventos:

AxisLabelUpdated (evento)

AxisTitleUpdated (evento)

AxisUpdated (evento)

ChartUpdated (evento)

DataUpdated (evento)

FootnoteUpdated (evento)

LegendUpdated (evento)

PlotUpdated (evento)

PointLabelUpdated (evento)

PointUpdated (evento)

SeriesUpdated (evento)

TitleUpdated (evento)


VerticalAlignment (Constantes)

Las constantes VtVerticalAlignment proporcionan métodos para alinear verticalmente el texto.

Constante | Descripción
VtVerticalAlignmentTop | Todas las líneas del texto se alinean en el margen superior.
VtVerticalAlignmentBottom | Todas las líneas del texto se alinean en el margen inferior.
VtVerticalAlignmentCenter | Todas las líneas del texto se centran verticalmente.


AxisActivated (Evento)

Se produce cuando el usuario hace doble clic en el eje de un gráfico.

Sintaxis

Private Sub objeto_AxisActivated (axisId As Integer, axisIndex As Integer, mouseFlags As Integer, cancel As Integer)

La sintaxis del evento AxisActivated consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
axisId | Integer. Un entero que identifica un eje específico, como se describe en Valores.
axisIndex | Integer. Un entero reservado para uso futuro. Para esta versión del control MSChart, el único valor válido de este argumento es 1.
mouseFlags | Integer. Un entero que indica si está presionada una tecla mientras se hace clic con el botón del mouse (ratón), como se describe en Valores.
cancel | Integer. Un entero que no se utiliza en este momento.

Valores

El controlador del evento determina el eje activado y establece axisId a:

Constantes | Descripción
VtChAxisIdX | Si se afecta al eje x.
VtChAxisIdY | Si se afecta al eje y.
VtChAxisIdY2 | Si se afecta al eje y secundario.
VtChAxisIdZ | Si se afecta al eje z.

El controlador del evento determina si está presionada una tecla cuando se hace clic con el botón del mouse (ratón) y establece mouseFlags a:

Constantes | Descripción
VtChMouseFlagShiftKeyDown | Si está presionada la tecla Mayús.
VtChMouseFlagControlKeyDown | Si está presionada la tecla Ctrl.


AxisLabelActivated (Evento)

Se produce cuando el usuario hace doble clic en una etiqueta de eje.

Sintaxis

Private Sub objeto_AxisLabelActivated (axisId As Integer, axisIndex As Integer, labelSetIndex As Integer, labelIndex As Integer, mouseFlags As Integer, cancel As Integer)

La sintaxis del evento AxisLabelActivated consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
axisId | Integer. Un entero que identifica un eje específico, como se describe en Valores.
axisIndex | Integer. Un entero reservado para uso futuro. En esta versión del control MSChart, el único valor válido de este argumento es 1.
labelSetIndex | Integer. Un entero que identifica el nivel de etiquetas en el que está haciendo doble clic. Los niveles de etiquetas se numeran desde el exterior del eje, a partir de 1.
labelIndex | Integer. Un entero que no se utiliza actualmente.
mouseFlags | Integer. Un entero que indica si está presionada una tecla cuando se hace clic con el botón del mouse (ratón).
cancel | Integer. Un entero que no se utiliza en este momento.

Valores

El controlador del evento determina la etiqueta del eje que está activada y establece axisId a:

Constantes | Descripción
VtChAxisIdX | Si se afecta al eje x.
VtChAxisIdY | Si se afecta al eje y.
VtChAxisIdY2 | Si se afecta al eje y secundario.
VtChAxisIdZ | Si se afecta al eje z.

El controlador del evento determina si está presionada una tecla cuando se hace clic con el botón del mouse (ratón) y establece mouseFlags a:

Constantes | Descripción
VtChMouseFlagShiftKeyDown | Si está presionada la tecla Mayús.
VtChMouseFlagControlKeyDown | Si está presionada la tecla Ctrl.


AxisLabelSelected (Evento)

Se produce cuando el usuario hace clic en una etiqueta del eje.

Sintaxis

Private Sub objeto_AxisLabelSelected (axisId As Integer, axisIndex As Integer, labelSetIndex As Integer, labelIndex As Integer, mouseFlags As Integer, cancel As Integer)

La sintaxis del evento AxisLabelSelected consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
axisId | Integer. Un entero que identifica un eje específico, como se describe en Valores.
axisIndex | Integer. Un entero reservado para uso futuro. En esta versión del control MSChart, el único valor válido de este argumento es 1.
labelSetIndex | Integer. Un entero que identifica el nivel de las etiquetas en el que está haciendo doble clic. Los niveles de las etiquetas se numeran desde el exterior del eje, a partir de 1.
labelIndex | Integer. Un entero que no se utiliza actualmente.
mouseFlags | Integer. Un entero que indica si está presionada una tecla cuando se hace clic con el botón del mouse (ratón), como se describe en Valores.
cancel | Integer. Un entero que no se utiliza en este momento.

Valores

El controlador del evento determina qué etiqueta del eje está seleccionada y establece axisId como se muestra a continuación:

Constantes | Descripción
VtChAxisIdX | Si se afecta al eje x.
VtChAxisIdY | Si se afecta al eje y.
VtChAxisIdY2 | Si se afecta al eje y secundario.
VtChAxisIdZ | Si se afecta al eje z.

El controlador del evento determina si hay una tecla presionada cuando se hace clic con el botón del mouse (ratón) y establece mouseFlags a:

Constantes | Descripción
VtChMouseFlagShiftKeyDown | Si está presionada la tecla Mayús.
VtChMouseFlagControlKeyDown | Si está presionada la tecla Ctrl.


AxisLabelUpdated (Evento)

Se produce cuando una etiqueta del eje ha cambiado.

Sintaxis

Private Sub objeto_AxisLabelUpdated (axisId As Integer, axisIndex As Integer, labelSetIndex As Integer, labelIndex As Integer, updateFlags As Integer)

La sintaxis del evento AxisLabelUpdated consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
axisId | Integer. Un entero que identifica un eje específico, como se describe en Valores.
axisIndex | Integer. Un entero reservado para uso futuro. En esta versión del control MSChart, el único valor válido de este argumento es 1.
labelSetIndex | Integer. Un entero que identifica el nivel de las etiquetas en el que está haciendo doble clic. Los niveles de las etiquetas se numeran desde el exterior del eje, a partir de 1.
labelIndex | Integer. Un entero que no se utiliza actualmente.
updateFlags | Integer. Un entero que proporciona información acerca de la actualización de la etiqueta, como se describe en Valores.

Valores

El controlador del evento determina la etiqueta del eje actualizada y establece axisId a:

Constantes | Descripción
VtChAxisIdX | Si se afecta al eje x.
VtChAxisIdY | Si se afecta al eje y.
VtChAxisIdY2 | Si se afecta al eje y secundario.
VtChAxisIdZ | Si se afecta al eje z.

El controlador del evento determina el efecto de la actualización y establece updateFlags a:

Constantes | Descripción
VtChNoDisplay | No hay indicadores de actualización; no afecta a la vista del gráfico. (Definido como 0.)
VtChDisplayPlot | La actualización hará que se vuelva a dibujar el trazado.
VtChLayoutPlot | La actualización hará que se vuelva a diseñar el trazado.
VtChDisplayLegend | La actualización hará que se vuelva a dibujar la leyenda.
VtChLayoutLegend | La actualización hará que se vuelva a diseñar la leyenda.
VtChLayoutSeries | La actualización hará que se vuelva a diseñar la serie.
VtChPositionSection | Se ha movido o cambiado el tamaño de una sección del gráfico.


AxisSelected (Evento)

Se produce cuando el usuario hace clic en un eje del gráfico.

Sintaxis

Private Sub objeto_AxisSelected (axisId As Integer, axisIndex As Integer, mouseFlags As Integer, cancel As Integer)

La sintaxis del evento AxisSelected consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
axisId | Integer. Un entero que identifica un eje específico, como se describe en Valores.
axisIndex | Integer. Un entero reservado para uso futuro. En esta versión del control MSChart, el único valor válido para este argumento es 1.
mouseFlags | Integer. Un entero que indica si está presionada una tecla cuando hace clic con el botón del mouse (ratón), como se describe en Valores.
cancel | Integer. Un entero que no se utiliza en este momento.

Valores

El controlador del evento determina qué eje está seleccionado y establece axisId a:

Constantes | Valor | Descripción
VtChAxisIdX | 0 | Si se afecta al eje x.
VtChAxisIdY | 1 | Si se afecta al eje y.
VtChAxisIdY2 | 2 | Si se afecta al eje y secundario.
VtChAxisIdZ | 3 | Si se afecta al eje z.
VtChAxisIDNone | 4 | No se afecta a ningún eje.

El controlador del evento determina si está presionada una tecla cuando se hace clic con el botón del mouse (ratón) y establece mouseFlags a:

Constantes | Descripción
VtChMouseFlagShiftKeyDown | Si está presionada la tecla Mayús.
VtChMouseFlagControlKeyDown | Si está presionada la tecla Ctrl.


AxisTitleActivated (Evento)

Se produce cuando el usuario hace doble clic en un título de un eje.

Sintaxis

Private Sub objeto_AxisTitleActivated (axisId As Integer, axisIndex As Integer, mouseFlags As Integer, cancel As Integer)

La sintaxis del evento AxisTitleActivated consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
axisId | Integer. Un entero que identifica un eje específico.
axisIndex | Integer. Un entero reservado para uso futuro. En esta versión del control MSChart, el único valor válido de este argumento es 1.
mouseFlags | Integer. Un entero que indica si está presionada una tecla cuando se hace clic con el botón del mouse (ratón).
cancel | Integer. Este argumento no se utiliza en este momento.

Valores

El controlador del evento determina qué título de eje está activado y establece axisId a:

Constantes | Valor | Descripción
VtChAxisIdX | 0 | Si se afecta al eje x.
VtChAxisIdY | 1 | Si se afecta al eje y.
VtChAxisIdY2 | 2 | Si se afecta al eje y secundario.
VtChAxisIdZ | 3 | Si se afecta al eje z.
VtChAxisIDNone | 4 | No se afecta a ningún eje.

El controlador del evento determina si está presionada una tecla cuando se hace clic con el botón del mouse (ratón) y establece mouseFlags a:

Constantes | Descripción
VtChMouseFlagShiftKeyDown | Si está presionada la tecla Mayús.
VtChMouseFlagControlKeyDown | Si está presionada la tecla Ctrl.


AxisTitleSelected (Evento)

Se produce cuando el usuario hace clic en un título de un eje.

Sintaxis

Private Sub objeto_AxisTitleSelected (axisId As Integer, axisIndex As Integer, mouseFlags As Integer, cancel As Integer)

La sintaxis del evento AxisTitleSelected consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
axisId | Integer. Un entero que identifica un eje específico.
axisIndex | Integer. Un entero reservado para uso futuro. En esta versión del control MSChart, el único valor válido de este argumento es 1.
mouseFlags | Integer. Un entero que indica si está presionada una tecla cuando se hace clic con el botón del mouse (ratón).
cancel | Integer. Este argumento no se utiliza en este momento.

Valores

El controlador del evento determina qué titulo de eje está seleccionado y establece axisId a:

Constantes | Valor | Descripción
VtChAxisIdX | 0 | Si se afecta al eje x.
VtChAxisIdY | 1 | Si se afecta al eje y.
VtChAxisIdY2 | 2 | Si se afecta al eje y secundario.
VtChAxisIdZ | 3 | Si se afecta al eje z.
VtChAxisIDNone | 4 | No se afecta a ningún eje.

El controlador del evento determina si está presionada una tecla cuando se hace clic con el botón del mouse (ratón) y establece mouseFlags a:

Constantes | Descripción
VtChMouseFlagShiftKeyDown | Si está presionada la tecla Mayús.
VtChMouseFlagControlKeyDown | Si está presionada la tecla Ctrl.


AxisTitleUpdated (Evento)

Se produce cuando el título de un eje ha cambiado.

Sintaxis

Private Sub objeto_AxisTitleUpdated (axisId As Integer, axisIndex As Integer, updateFlags As Integer)

La sintaxis del evento AxisTitleUpdated consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
axisId | Integer. Un entero que identifica un eje específico.
axisIndex | Integer. Un entero reservado para uso futuro. En esta versión del control MSChart, el único valor válido de este argumento es 1.
updateFlags | Integer. Un entero que proporciona información acerca de la actualización del título.

Valores

El controlador del evento determina qué título de eje se ha actualizado y establece axisId a:

Constantes | Valor | Descripción
VtChAxisIdX | 0 | Si se afecta al eje x.
VtChAxisIdY | 1 | Si se afecta al eje y.
VtChAxisIdY2 | 2 | Si se afecta al eje y secundario.
VtChAxisIdZ | 3 | Si se afecta al eje z.
VtChAxisIDNone | 4 | No se afecta a ningún eje.

En la tabla siguiente se enumeran las constantes para updateFlags.

Constantes | Descripción
VtChNoDisplay | No hay indicadores de actualización; no afecta a la vista del gráfico. (Definido como 0.)
VtChDisplayPlot | La actualización hará que se vuelva a dibujar el trazado.
VtChLayoutPlot | La actualización hará que se vuelva a diseñar el trazado.
VtChDisplayLegend | La actualización hará que se vuelva a dibujar la leyenda.
VtChLayoutLegend | La actualización hará que se vuelva a diseñar la leyenda.
VtChLayoutSeries | La actualización hará que se vuelva a diseñar la serie.
VtChPositionSection | Se ha movido o cambiado de tamaño una sección del gráfico.


AxisUpdated (Evento)

Se produce cuando se ha modificado un eje.

Sintaxis

Private Sub objeto_AxisUpdated (axisId As Integer, axisIndex As Integer, updateFlags As Integer)

La sintaxis del evento AxisUpdated consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
axisId | Integer. Un entero que identifica un eje específico.
axisIndex | Integer. Un entero reservado para uso futuro. En esta versión del control MSChart, el único valor válido de este argumento es 1.
updateFlags | Integer. Un entero que proporciona información acerca de la actualización del eje.

Valores

El controlador del evento determina qué eje se ha actualizado y establece axisId a:

Constantes | Valor | Descripción
VtChAxisIdX | 0 | Si se afecta al eje x.
VtChAxisIdY | 1 | Si se afecta al eje y.
VtChAxisIdY2 | 2 | Si se afecta al eje y secundario.
VtChAxisIdZ | 3 | Si se afecta al eje z.
VtChAxisIDNone | 4 | No se afecta a ningún eje.

En la tabla siguiente se enumeran las constantes para updateFlags.

Constantes | Descripción
VtChNoDisplay | No hay indicadores de actualización; no afecta a la vista del gráfico. (Definido como 0.)
VtChDisplayPlot | La actualización hará que se vuelva a dibujar el trazado.
VtChLayoutPlot | La actualización hará que se vuelva a diseñar el trazado.
VtChDisplayLegend | La actualización hará que se vuelva a dibujar la leyenda.
VtChLayoutLegend | La actualización hará que se vuelva a diseñar la leyenda.
VtChLayoutSeries | La actualización hará que se vuelva a diseñar la serie.
VtChPositionSection | Se ha movido o cambiado de tamaño una sección del gráfico.


ChartActivated (Evento)

Se produce cuando el usuario hace doble clic en el control Microsoft Chart, pero no en un elemento específico del gráfico.

Sintaxis

Private Sub objeto_ChartActivated (mouseFlags As Integer, cancel As Integer)

La sintaxis del evento ChartActivated consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
mouseFlags | Integer. Indica si está presionada una tecla cuando se hace clic con el botón del mouse, como se describe en Valores.
cancel | Integer. Este argumento no se utiliza en este momento.

Valores

El controlador del evento determina si está presionada una tecla cuando se hace clic con el botón del mouse y establece mouseFlags a:

Constante | Descripción
VtChMouseFlagShiftKeyDown | Si está presionada la tecla Mayús.
VtChMouseFlagControlKeyDown | Si está presionada la tecla Ctrl.


ChartSelected (Evento)

Se produce cuando el usuario hace clic en el control MSChart, pero no en un elemento específico del gráfico.

Sintaxis

Private Sub objeto_ChartSelected (mouseFlags As Integer, cancel As Integer)

La sintaxis del evento ChartSelected consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
mouseFlags | Integer. Indica si está presionada una tecla cuando se hace clic con el botón del mouse (ratón), como se describe en Valores.
cancel | Integer. Este argumento no se utiliza en este momento.

Valores

El controlador del evento determina si está presionada una tecla cuando se hace clic con el botón del mouse (ratón) y establece mouseFlags a:

Constante | Descripción
VtChMouseFlagShiftKeyDown | Si está presionada la tecla Mayús.
VtChMouseFlagControlKeyDown | Si está presionada la tecla Ctrl.


ChartUpdated (Evento)

Se produce cuando se modifica el gráfico.

Sintaxis

Private Sub objeto_ChartUpdated (updateFlags As Integer)

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
updateFlags | Integer. Proporciona información acerca de la actualización del gráfico, como se describe en Valores.

Valores

En la tabla siguiente se enumeran las constantes para updateFlags.

Constante | Descripción
VtChNoDisplay | No hay indicadores de actualización; no afecta a la vista del gráfico. (Definido como 0.)
VtChDisplayPlot | La actualización hará que se vuelva a dibujar el trazado.
VtChLayoutPlot | La actualización hará que se vuelva a diseñar el trazado.
VtChDisplayLegend | La actualización hará que se vuelva a dibujar la leyenda.
VtChLayoutLegend | La actualización hará que se vuelva a diseñar la leyenda.
VtChLayoutSeries | La actualización hará que se vuelva a diseñar la serie.
VtChPositionSection | Se ha movido o cambiado de tamaño una sección del gráfico.


DataUpdated (Evento)

Se produce cuando se ha modificado la cuadrícula de datos del gráfico.

Sintaxis

Private Sub objeto_DataUpdated (row As Integer, column As Integer, labelRow As Integer, labelColumn As Integer, labelSetIndex As Integer, updateFlags As Integer)

La sintaxis del evento DataUpdated consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
row | Integer. Indica la fila de la cuadrícula de datos.
column | Integer. Indica la columna de la cuadrícula de datos.
labelRow | Integer. Indica la etiqueta de fila.
labelColumn | Integer. Indica la etiqueta de columna.
labelSetIndex | Integer. Identifica el nivel de etiquetas. Los niveles de etiquetas se numeran desde el exterior del eje, a partir de 1.
updateFlags | Integer. Proporciona información acerca de la actualización de los datos, como se describe en Valores.

Valores

En la tabla siguiente se enumeran las constantes de updateFlags.

Constante | Descripción
VtChNoDisplay | No hay indicadores de actualización; no afecta a la vista del gráfico. (Definido como 0.)
VtChDisplayPlot | La actualización hará que se vuelva a dibujar el trazado.
VtChLayoutPlot | La actualización hará que se vuelva a diseñar el trazado.
VtChDisplayLegend | La actualización hará que se vuelva a dibujar la leyenda.
VtChLayoutLegend | La actualización hará que se vuelva a diseñar la leyenda.
VtChLayoutSeries | La actualización hará que se vuelva a diseñar la serie.
VtChPositionSection | Se ha movido o cambiado de tamaño una sección del gráfico.

Comentarios

Si la fila y la columna son distintas de cero, la modificación se produce en la celda de datos indicada. Si labelRow o labelColumn, junto con labelSetIndex, no son cero, cambia la etiqueta de fila o de columna indicada. Si ninguna de ellas es cero, no habrá información disponible específica acerca de la modificación.


DonePainting (Evento)

Se produce inmediatamente después de volver a dibujar o trazar el gráfico.

Sintaxis

Private Sub objeto_DonePainting ()

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.


FootnoteActivated (Evento)

Se produce cuando el usuario hace doble clic en las notas a pie de página del gráfico.

Sintaxis

Private Sub objeto_FootnoteActivated (mouseFlags As Integer, cancel As Integer)

La sintaxis del evento FootnoteActivated consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
mouseFlags | Integer. Indica si está presionada una tecla cuando se hace clic con el botón del mouse (ratón), como se describe en Valores.
cancel | Este argumento no se utiliza en este momento.

Valores

El controlador del evento determina si está presionada una tecla cuando se hace clic con el botón del mouse (ratón) y establece mouseFlags a:

Constantes | Descripción
VtChMouseFlagShiftKeyDown | Si está presionada la tecla Mayús.
VtChMouseFlagControlKeyDown | Si está presionada la tecla Ctrl.


FootnoteSelected (Evento)

Se produce cuando el usuario hace clic en las notas a pie de página del gráfico.

Sintaxis

Private Sub objeto_FootnoteSelected (mouseFlags As Integer, cancel As Integer)

La sintaxis del evento FootnoteSelected consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
mouseFlags | Integer. Indica si está presionada una tecla cuando se hace clic con el botón del mouse (ratón), como se describe en Valores.
cancel | Este argumento no se utiliza en este momento.

Valores

El controlador del evento determina si está presionada una tecla cuando se hace clic con el botón del mouse (ratón) y establece mouseFlags a:

Constantes | Descripción
VtChMouseFlagShiftKeyDown | Si está presionada la tecla Mayús.
VtChMouseFlagControlKeyDown | Si está presionada la tecla Ctrl.


FootnoteUpdated (Evento)

Se produce cuando cambia la nota a pie de página del gráfico.

Sintaxis

Private Sub objeto_FootnoteUpdated (updateFlags As Integer)

La sintaxis del evento FootnoteUpdated consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
updateFlags | Integer. Proporciona información acerca de la actualización de la nota a pie de página, como se describe en Valores.

Valores

En la tabla siguiente se enumeran las constantes de updateFlags.

Constante | Descripción
VtChNoDisplay | No hay indicadores de actualización; no afecta a la vista del gráfico. (Definido como 0.)
VtChDisplayPlot | La actualización hará que se vuelva a dibujar el trazado.
VtChLayoutPlot | La actualización hará que se vuelva a diseñar el trazado.
VtChDisplayLegend | La actualización hará que se vuelva a dibujar la leyenda.
VtChLayoutLegend | La actualización hará que se vuelva a diseñar la leyenda.
VtChLayoutSeries | La actualización hará que se vuelva a diseñar la serie.
VtChPositionSection | Se ha movido o cambiado el tamaño de una sección del gráfico.


LegendActivated (Evento)

Se produce cuando el usuario hace doble clic en la leyenda del gráfico.

Sintaxis

Private Sub objeto_LegendActivated (mouseFlags As Integer, cancel As Integer)

La sintaxis del evento LegendActivated consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
mouseFlags | Integer. Indica si está presionada una tecla cuando se hace clic con el botón del mouse (ratón), como se describe en Valores.
cancel | Integer. Este argumento no se utiliza en este momento.

Valores

El controlador del evento determina si está presionada una tecla cuando se hace clic con el botón del mouse (ratón) y establece mouseFlags a:

Constantes | Descripción
VtChMouseFlagShiftKeyDown | Si está presionada la tecla Mayús.
VtChMouseFlagControlKeyDown | Si está presionada la tecla Ctrl.


LegendSelected (Evento)

Se produce cuando el usuario hace clic en la leyenda del gráfico.

Sintaxis

Private Sub objeto_LegendSelected (mouseFlags As Integer, cancel As Integer)

La sintaxis del evento LegendSelected consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
mouseFlags | Integer. Indica si está presionada una tecla cuando se hace clic con el botón del mouse (ratón).
cancel | Integer. Este argumento no se utiliza en este momento.

Valores

El controlador del evento determina si está presionada una tecla cuando se hace clic con el botón del mouse (ratón) y establece mouseFlags a:

Constantes | Descripción
VtChMouseFlagShiftKeyDown | Si está presionada la tecla Mayús.
VtChMouseFlagControlKeyDown | Si está presionada la tecla Ctrl.


LegendUpdated (Evento)

Se produce cuando se ha modificado la leyenda del gráfico.

Sintaxis

Private Sub objeto_LegendUpdated (updateFlags As Integer)

La sintaxis del evento LegendUpdated consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
updateFlags | Integer. Proporciona información acerca de la actualización de la leyenda, como se describe en Valores.

Valores

En la tabla siguiente se enumeran las constantes de updateFlags.

Constante | Descripción
VtChNoDisplay | No hay indicadores de actualización; no afecta a la vista del gráfico. (Definido como 0.)
VtChDisplayPlot | La actualización hará que se vuelva a dibujar el trazado.
VtChLayoutPlot | La actualización hará que se vuelva a diseñar el trazado.
VtChDisplayLegend | La actualización hará que se vuelva a dibujar la leyenda.
VtChLayoutLegend | La actualización hará que se vuelva a diseñar la leyenda.
VtChLayoutSeries | La actualización hará que se vuelva a diseñar la serie.
VtChPositionSection | Se ha movido o cambiado de tamaño una sección del gráfico.


PlotActivated (Evento)

Se produce cuando el usuario hace doble clic en el trazado del gráfico.

Sintaxis

Private Sub objeto_PlotActivated (mouseFlags As Integer, cancel As Integer)

La sintaxis del evento PlotActivated consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
mouseFlags | Integer. Indica si está presionada una tecla cuando se hace clic con el botón del mouse (ratón), como se describe en Valores.
cancel | Integer. Este argumento no se utiliza en este momento.

Valores

El controlador del evento determina si está presionada una tecla cuando se hace clic con el botón del mouse y establece mouseFlags a:

Constantes | Descripción
VtChMouseFlagShiftKeyDown | Si está presionada la tecla Mayús.
VtChMouseFlagControlKeyDown | Si está presionada la tecla CTRL.


PlotSelected (Evento)

Se produce cuando el usuario hace clic en el gráfico.

Sintaxis

Private Sub objeto_PlotSelected (mouseFlags As Integer, cancel As Integer)

La sintaxis del evento PlotSelected consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
mouseFlags | Integer. Indica si está presionada una tecla cuando se hace clic con el botón del mouse (ratón), como se describe en Valores.
cancel | Integer. Este argumento no se utiliza en este momento.

Valores

El controlador del evento determina si está presionada una tecla cuando se hace clic con el botón del mouse y establece mouseFlags a:

Constantes | Descripción
VtChMouseFlagShiftKeyDown | Si está presionada la tecla Mayús.
VtChMouseFlagControlKeyDown | Si está presionada la tecla Ctrl.


PlotUpdated (Evento)

Se produce cuando ha cambiado el trazado del gráfico.

Sintaxis

Private Sub objeto_PlotUpdated (updateFlags As Integer)

La sintaxis del evento PlotUpdated consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
updateFlags | Integer. Proporciona información acerca de la actualización del trazado, como se describe en Valores.

Valores

En la tabla siguiente se enumeran las constantes de updateFlags.

Constante | Descripción
VtChNoDisplay | No hay indicadores de actualización; no afecta a la vista del gráfico. (Definido como 0.)
VtChDisplayPlot | La actualización hará que se vuelva a dibujar el trazado.
VtChLayoutPlot | La actualización hará que se vuelva a diseñar el trazado.
VtChDisplayLegend | La actualización hará que se vuelva a dibujar la leyenda.
VtChLayoutLegend | La actualización hará que se vuelva a diseñar la leyenda.
VtChLayoutSeries | La actualización hará que se vuelva a diseñar la serie.
VtChPositionSection | Se ha movido o cambiado de tamaño una sección del gráfico.


PointActivated (Evento)

Se produce cuando el usuario hace doble clic en un punto de datos.

Sintaxis

Private Sub objeto_PointActivated (series As Integer, dataPoint As Integer, mouseFlags As Integer, cancel As Integer)

La sintaxis del evento PointActivated consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
series | Integer. Identifica la serie que contiene el punto de datos. Las series se numeran en el orden en que aparecen sus columnas en la cuadrícula de datos, a partir de 1.
dataPoint | Integer. Identifica la ubicación del punto de datos en la serie. Los puntos se numeran en el orden en que aparecen sus filas en la cuadrícula de datos, a partir de 1.
mouseFlags | Integer. Indica si está presionada una tecla cuando se hace clic con el botón del mouse (ratón), como se describe en Valores.
cancel | Integer. Este argumento no se utiliza en este momento.

Valores

El controlador del evento determina si está presionada una tecla cuando se hace clic con el botón del mouse y establece mouseFlags a:

Constantes | Descripción
VtChMouseFlagShiftKeyDown | Si está presionada la tecla Mayús.
VtChMouseFlagControlKeyDown | Si está presionada la tecla Ctrl.


PointLabelActivated (Evento)

Se produce cuando el usuario hace doble clic en la etiqueta de un punto de datos.

Sintaxis

Private Sub objeto_PointLabelActivated (serie As Integer, dataPoint As Integer, mouseFlags As Integer, cancel As Integer)

La sintaxis del evento PointLabelActivated consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
series | Integer. Identifica la serie que contiene el punto de datos. Las series se numeran en el orden en que aparecen sus columnas en la cuadrícula de datos, a partir de 1.
dataPoint | Integer. Identifica la ubicación del punto de datos en la serie. Los puntos se numeran en el orden en que aparecen sus filas en la cuadrícula de datos, a partir de 1.
mouseFlags | Integer. Indica si está presionada una tecla cuando se hace clic con el botón del mouse (ratón), como se indica en Valores.
cancel | Integer. Este argumento no se utiliza en este momento.

Valores

El controlador del evento determina si está presionada una tecla mientras se hace clic con el botón del mouse y establece mouseFlags a:

Constantes | Descripción
VtChMouseFlagShiftKeyDown | Si está presionada la tecla Mayús.
VtChMouseFlagControlKeyDown | Si está presionada la tecla Ctrl.


PointLabelSelected (Evento)

Se produce cuando el usuario hace clic en una etiqueta de un punto de datos.

Sintaxis

Private Sub objeto_PointLabelSelected (series As Integer, dataPoint As Integer, mouseFlags As Integer, cancel As Integer)

La sintaxis del evento PointLabelSelected consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
series | Integer. Identifica la serie que contiene el punto de datos. Las series se numeran en el orden en que aparecen sus columnas en la cuadrícula de datos, a partir de 1.
DataPoint | Integer. Identifica la ubicación del punto de datos en la serie. Los puntos se numeran en el orden en que aparecen sus filas en la cuadrícula de datos, a partir de 1.
mouseFlags | Integer. Indica si hay una tecla presionada cuando se hace clic con el botón del mouse (ratón), como se indica en Valores.
cancel | Este argumento no se utiliza en este momento.

Valores

El controlador del evento determina si está presionada una tecla mientras se hace clic con el botón del mouse y establece mouseFlags a:

Constantes | Descripción
VtChMouseFlagShiftKeyDown | Si está presionada la tecla Mayús.
VtChMouseFlagControlKeyDown | Si está presionada la tecla Ctrl.


PointLabelUpdated (Evento)

Se produce cuando ha cambiado una etiqueta de un punto de datos.

Sintaxis

Private Sub objeto_PointLabelUpdated (series As Integer, dataPoint As Integer, updateFlags As Integer)

La sintaxis del evento PointLabelUpdated consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
series | Integer. Identifica la serie que contiene el punto de datos. Las series se numeran en el orden en que aparecen sus columnas en la cuadrícula de datos, a partir de 1.
dataPoint | Integer. Identifica la ubicación del punto de datos en la serie. Los puntos se numeran en el orden en que aparecen sus filas en la cuadrícula de datos, a partir de 1.
updateFlags | Integer. Proporciona información acerca de la actualización de la etiqueta del punto de datos, como se describe en Valores.

Valores

En la tabla siguiente se enumeran las constantes para updateFlags.

Constante | Descripción
VtChNoDisplay | No hay indicadores de actualización; no afecta a la vista del gráfico. (Definido como 0.)
VtChDisplayPlot | La actualización hará que se vuelva a dibujar el trazado.
VtChLayoutPlot | La actualización hará que se vuelva a diseñar el trazado.
VtChDisplayLegend | La actualización hará que se vuelva a dibujar la leyenda.
VtChLayoutLegend | La actualización hará que se vuelva a diseñar la leyenda.
VtChLayoutSeries | La actualización hará que se vuelva a diseñar la serie.
VtChPositionSection | Se ha movido o cambiado de tamaño una sección del gráfico.


PointSelected (Evento)

Se produce cuando el usuario hace clic en un punto de datos.

Sintaxis

Private Sub objeto_PointSelected (series As Integer, dataPoint As Integer, mouseFlags As Integer, cancel As Integer)

La sintaxis del evento PointSelected consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
series | Integer. Identifica las series que contienen el punto de datos. Las series se numeran en el orden en que aparecen sus columnas en la cuadrícula de datos, a partir de 1.
dataPoint | Integer. Identifica la ubicación del punto de datos en la serie. Los puntos se numeran en el orden en que aparecen sus filas en la cuadrícula de datos, a partir de 1.
mouseFlags | Integer. Indica si está presionada una tecla cuando se hace clic con el botón del mouse (ratón), como se indica en Valores.
cancel | Integer. Este argumento no se utiliza en este momento.

Valores

El controlador del evento determina si está presionada una tecla mientras se hace clic con el botón del mouse y establece mouseFlags a:

Constantes | Descripción
VtChMouseFlagShiftKeyDown | Si está presionada la tecla Mayús.
VtChMouseFlagControlKeyDown | Si está presionada la tecla Ctrl.


PointUpdated (Evento)

Se produce cuando ha cambiado un punto de datos.

Sintaxis

Private Sub objeto_PointUpdated (series As Integer, dataPoint As Integer, updateFlags As Integer)

La sintaxis del evento PointUpdated consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
series | Integer. Identifica la serie que contiene el punto de datos. Las series se numeran en el orden en que aparecen sus columnas en la cuadrícula de datos, a partir de 1.
dataPoint | Integer. Identifica la ubicación del punto de datos en la serie. Los puntos de datos se numeran en el orden en que aparecen sus filas en la cuadrícula de datos, a partir de 1.
updateFlags | Integer. Proporciona información acerca de la actualización del punto de datos, como se describe en Valores.

Valores

En la tabla siguiente se enumeran las constantes para updateFlags.

Constante | Descripción
VtChNoDisplay | No hay indicadores de actualización; no afecta a la vista del gráfico. (Definido como 0).
VtChDisplayPlot | La actualización hará que se vuelva a dibujar el trazado.
VtChLayoutPlot | La actualización hará que se vuelva a diseñar el trazado.
VtChDisplayLegend | La actualización hará que se vuelva a dibujar la leyenda.
VtChLayoutLegend | La actualización hará que se vuelva a diseñar la leyenda.
VtChLayoutSeries | La actualización hará que se vuelva a diseñar la serie.
VtChPositionSection | Se ha movido o cambiado de tamaño una sección del gráfico.


SeriesActivated (Evento)

Se produce cuando el usuario hace doble clic en una serie del gráfico. Puede reemplazar la interfaz estándar de usuario si cancela el evento y muestra su propio cuadro de diálogo.

Sintaxis

Private Sub objeto_SeriesActivated (series As Integer, mouseFlags As Integer, cancel As Integer)

La sintaxis del evento SeriesActivated consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
series | Integer. Identifica la serie que contiene el punto de datos. Las series se numeran en el orden en que aparecen sus columnas en la cuadrícula de datos, a partir de 1.
mouseFlags | Integer. Indica si está presionada una tecla cuando se hace clic con el botón del mouse (ratón), como se indica en Valores.
cancel | Integer. Este argumento no se utiliza en este momento.

Valores

El controlador del evento determina si está presionada una tecla mientras se hace clic con el botón del mouse y establece mouseFlags a:

Constantes | Descripción
VtChMouseFlagShiftKeyDown | Si está presionada la tecla Mayús.
VtChMouseFlagControlKeyDown | Si está presionada la tecla Ctrl.


SeriesSelected (Evento)

Se produce cuando el usuario hace clic en una serie del gráfico.

Sintaxis

Private Sub objeto_SeriesSelected (series As Integer, mouseFlags As Integer, cancel As Integer)

La sintaxis del evento SeriesSelected consta de las siguientes partes:

Parte | Descripción
objeto Una expresión de objeto que da como resultado un objeto de la
lista Se aplica a.
series | Integer. Identifica la serie que contiene el punto de datos. Las series se numeran en el orden en que aparecen sus columnas en la cuadrícula de datos, a partir de 1.
mouseFlags | Integer. Indica si está presionada una tecla cuando se hace clic con el botón del mouse (ratón), como se indica en Valores.
cancel | Integer. Este argumento no se utiliza en este momento.

Valores

El controlador del evento determina si está presionada una tecla mientras se hace clic con el botón del mouse y establece mouseFlags a:

Constantes | Descripción
VtChMouseFlagShiftKeyDown | Si está presionada la tecla Mayús.
VtChMouseFlagControlKeyDown | Si está presionada la tecla Ctrl.


SeriesUpdated (Evento)

Se produce cuando ha cambiado una serie del gráfico.

Sintaxis

Private Sub objeto_SeriesUpdated (series As Integer, updateFlags As Integer)

La sintaxis del evento SeriesUpdated consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
series | Integer. Identifica la serie que contiene el punto de datos. Las series se numeran en el orden en que aparecen sus columnas en la cuadrícula de datos, a partir de 1.
updateFlags | Integer. Proporciona información acerca de la actualización de la serie, como se describe en Valores.

Valores

En la tabla siguiente se enumeran las constantes de updateFlags.

Constante | Descripción
VtChNoDisplay | No hay indicadores de actualización; no afecta a la vista del gráfico. (Definido como 0.)
VtChDisplayPlot | La actualización hará que se vuelva a dibujar el trazado.
VtChLayoutPlot | La actualización hará que se vuelva a diseñar el trazado.
VtChDisplayLegend | La actualización hará que se vuelva a dibujar la leyenda.
VtChLayoutLegend | La actualización hará que se vuelva a diseñar la leyenda.
VtChLayoutSeries | La actualización hará que se vuelva a diseñar la serie.
VtChPositionSection | Se ha movido o cambiado de tamaño una sección del gráfico.


TitleActivated (Evento)

Se produce cuando el usuario hace doble clic en el título del gráfico. Puede reemplazar la interfaz estándar de usuario si cancela el evento y muestra su propio cuadro de diálogo.

Sintaxis

Private Sub objeto_TitleActivated (mouseFlags As Integer, cancel As Integer)

La sintaxis del evento TitleActivated consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
mouseFlags | Integer. Indica si está presionada una tecla cuando se hace clic con el botón del mouse (ratón), como se indica en Valores.
cancel | Integer. Este argumento no se utiliza en este momento.

Valores

El controlador del evento determina si está presionada una tecla mientras se hace clic con el botón del mouse y establece mouseFlags a:

Constantes | Descripción
VtChMouseFlagShiftKeyDown | Si está presionada la tecla Mayús.
VtChMouseFlagControlKeyDown | Si está presionada la tecla Ctrl.


TitleSelected (Evento)

Se produce cuando el usuario hace clic en el título del gráfico.

Sintaxis

Private Sub objeto_TitleSelected (mouseFlags As Integer, cancel As Integer)

La sintaxis del evento TitleSelected consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
mouseFlags | Integer. Indica si está presionada una tecla cuando se hace clic con el botón del mouse (ratón), como se indica en Valores.
cancel | Integer. Este argumento no se utiliza en este momento.

Valores

El controlador del evento determina si está presionada una tecla mientras se hace clic con el botón del mouse y establece mouseFlags a:

Constantes | Descripción
VtChMouseFlagShiftKeyDown | Si está presionada la tecla Mayús.
VtChMouseFlagControlKeyDown | Si está presionada la tecla Ctrl.


TitleUpdated (Evento)

Se produce cuando cambia el título del gráfico.

Sintaxis

Private Sub objeto_TitleUpdated (updateFlags As Integer)

La sintaxis del evento TitleUpdated consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
updateFlags | Proporciona información acerca de la actualización del título, como se describe en Valores.

Valores

En la tabla siguiente se enumeran las constantes para updateFlags.

Constante | Descripción
VtChNoDisplay | No hay indicadores de actualización; no afecta a la vista del gráfico. (Definido como 0.)
VtChDisplayPlot | La actualización hará que se vuelva a dibujar el trazado.
VtChLayoutPlot | La actualización hará que se vuelva a diseñar el trazado.
VtChDisplayLegend | La actualización hará que se vuelva a dibujar la leyenda.
VtChLayoutLegend | La actualización hará que se vuelva a diseñar la leyenda.
VtChLayoutSeries | La actualización hará que se vuelva a diseñar la serie.
VtChPositionSection | Se ha movido o cambiado de tamaño una sección del gráfico.


Mensajes de error (Control MSChart)

Los errores del control MSChart que se producen durante la ejecución del programa se controlan de la misma forma que el resto de los errores. Debe escribir su propia rutina de control de errores para interceptar y gestionar los errores.

En la tabla siguiente se enumeran los errores que se pueden interceptar mediante el tratamiento de excepciones.

Nombre del error | Explicación
GetNotSupported | Se intentó leer una propiedad de sólo escritura.
InvalidPropertyValue | El valor no es apropiado para la propiedad utilizada.
SetNotSupported | Se intentó escribir una propiedad de sólo lectura.
VtChError | La función falló con un error no especificado.
VtChErrorInvalidAxis | Uno de los argumentos de un método es una referencia a un eje que no existe en el gráfico.
VtChErrorInvalidHandle | Se pasó un controlador de gráfico no válido.
VtChErrorInvalidSeriesNumber | Uno de los argumentos de un método es una referencia a una serie que no existe en el gráfico.
VtChErrorNoData | Los datos necesarios para completar la tarea no están disponibles.
VtChErrorRestrictedVersion | La característica solicitada no está disponible en esta versión del producto.
VtErrorActionCanceled | El usuario canceló la operación. El usuario hizo clic fuera del menú en lugar de seleccionar un elemento.
VtErrorArchivePointerMismatch | Se intentó cargar un puntero en una referencia.
VtErrorArchiveTypeMismatch | Se encontró un tipo de clase inesperado.
VtErrorArchiveVersion | Se intentó cargar una versión incompatible.
VtErrorBufferTooSmall | El búfer de la cadena no es suficientemente grande para contener la cadena solicitada. La cadena se truncó para ajustarse al tamaño del búfer.
VtErrorCannotOpenFile | No se puede abrir el archivo solicitado.
VtErrorCopyingObject | Error al copiar el objeto.
VtErrorCorruptArchive | El almacenamiento persistente está dañado.
VtErrorCorruptData | Error interno que indica que el control MSChart encontró datos dañados y que no es posible continuar con la acción solicitada.
VtErrorCreateWindow | No se puede crear una ventana.
VtErrorDefaultFontSubstituted | Predeterminada sustituida por la fuente solicitada.
VtErrorDeletingDeletedObject | Error interno que indica que el control MSChart intentó eliminar un objeto que ya se había eliminado.
VtErrorDeletingUsedObject | Error interno que indica que el control MSChart intentó eliminar un objeto que todavía se está utilizando.
VtErrorDisplay | El control MSChart no puede comunicarse correctamente con los controladores de pantalla.
VtErrorDuplicateObject | Se encontró un objeto duplicado.
VtErrorDuplicateSymbol | Símbolo duplicado.
VtErrorIconNotFound | No se puede cargar el icono.
VtErrorIdentifierTooBig | El identificador es demasiado grande.
VtErrorInvalidArgument | Uno de los argumentos de la función era erróneo.
VtErrorInvalidFont | La descripción de la fuente solicitada no es válida.
VtErrorInvalidFontName | El nombre de la fuente solicitada no está disponible.
VtErrorInvalidIndex | El índice especificado está fuera de los límites.
VtErrorInvalidObject | El objeto no está inicializado o no es válido.
VtErrorInvalidRequest | La acción solicitada no es apropiada o no es válida.
VtErrorInvalidSyntax | Se encontró una sintaxis no válida.
VtErrorInvalidTypeConversion | El tipo de conversión solicitado no es compatible.
VtErrorLoadPicture | Imposible cargar la imagen solicitada.
VtErrorNoDisplayResources | El control MSChart no tiene suficientes recursos de presentación para mostrar el gráfico correctamente.
VtErrorNoMemory | No hay suficiente memoria para llevar a cabo la acción solicitada.
VtErrorNotFound | No se puede encontrar el elemento buscado por la función.
VtErrorNotImplemented | Característica no implementada todavía.
VtErrorOSVersion | La versión de Windows no es compatible.
VtErrorStreamIo | Se encontró un error mientras se intentaba leer o escribir un archivo.
VtErrorTooSmall | El resultado devuelto es mayor que el tamaño del búfer de retorno. Se coloca en el búfer una cadena NULL.
VtErrorUnableToLoadString | Imposible cargar una cadena; es posible que la cadena sea demasiado larga.
VtErrorUnexpectedEOS | Se encontró un fin de cadena inesperado.
VtErrorUnrecognizedFunction | Se encontró una función no reconocida.
VtErrorUserIo | Se produjo un error en una función creada por el usuario al intentar escribir un archivo.
VtFail | Error de fallo general.
VtOk | No se ha producido ningún error.


Add (Método, Colección LightSources)

Agrega un objeto LightSource a la colección LightSources.

Sintaxis

objeto.Add (x, y, z, intensity)

La sintaxis del método Add consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
x, y, z | Integer. Indica la ubicación del origen de luz.
intensity | Single. Indica la intensidad del origen de luz.

Comentarios

Si se establece x, y y z a cero, se genera un error VtChInvalidArgument.


Count (Método)

Devuelve el número de objetos de una colección.

Sintaxis

objeto.Count

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.


DeleteColumnLabels (Método)

Elimina niveles de etiquetas de las columnas de datos de una cuadrícula de datos asociada a un gráfico.

Sintaxis

objeto.DeleteColumnLabels (labelIndex, count)

La sintaxis del método DeleteColumnLabels consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
labelIndex | Integer. Identifica el número del primer nivel de etiquetas que desea eliminar. Los niveles de etiquetas de columnas se numeran de abajo a arriba, a partir de 1.
count | Integer. Especifica el número de niveles de etiquetas que desea eliminar. El número de columnas a eliminar se calcula desde la columna identificada en labelIndex hacia arriba.


DeleteColumns (Método)

Elimina columnas de datos y sus etiquetas asociadas, de la cuadrícula de datos asociada a un gráfico.

Sintaxis

objeto.DeleteColumns (column, count)

La sintaxis del método DeleteColumns consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
column | Integer. Identifica una columna de datos específica. Las columnas se numeran de izquierda a derecha, a partir de 1.
count | Integer. Especifica el número de columnas que desea eliminar.


DeleteRowLabels (Método)

Elimina niveles de etiquetas de las filas de datos en una cuadrícula de datos asociada a un gráfico.

Sintaxis

objeto.DeleteRowLabels (labelIndex, count)

La sintaxis del método DeleteRowLabels consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
labelIndex | Integer. Identifica el número del primer nivel de etiquetas que desea eliminar. Las etiquetas de filas se numeran de derecha a izquierda, a partir de 1.
count | Integer. Especifica el número de niveles de etiquetas que desea eliminar. Las etiquetas de filas se eliminan desde la fila identificada mediante labelIndex hacia la izquierda.


DeleteRows (Método)

Elimina filas de datos y sus etiquetas asociadas de la cuadrícula de datos asociada a un gráfico.

Sintaxis

objeto.DeleteRows (row, count)

La sintaxis del método DeleteRows consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
row | Integer. Identifica una fila de datos específica. Las filas de datos se numeran de arriba a abajo, a partir de 1.
count | Integer. Especifica el número de filas que desea eliminar.


EditCopy (Método)

Copia una imagen del gráfico actual al Portapapeles, en formato de metarchivo de Windows. También copia al Portapapeles los datos que se utilizan para crear el gráfico.

Sintaxis

objeto.EditCopy

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.

Comentarios

Este método le permite pegar los datos del gráfico o una imagen del gráfico en otra aplicación. Como los datos y la imagen se almacenan en el Portapapeles, lo que se pega en la nueva aplicación varía según el tipo de aplicación. Por ejemplo, si ejecuta el método EditCopy del gráfico en su código y después va a una hoja de cálculo de Excel y selecciona Edición: Pegar, se coloca en la hoja de cálculo el conjunto de datos del gráfico. Para insertar una imagen del gráfico en la hoja de cálculo, seleccione Edición: Pegado especial y seleccione el tipo Imagen.


EditPaste (Método)

Pega un gráfico de metarchivo de Windows o un texto delimitado con tabuladores desde el Portapapeles a la selección actual de un gráfico.

Sintaxis

objeto.EditPaste

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.

Comentarios

El gráfico puede aceptar distintos tipos de información del Portapapeles, según el elemento seleccionado en el gráfico cuando se llama a EditPaste. Si está seleccionado todo el gráfico, éste busca los datos en el Portapapeles e intenta usar los nuevos datos para volver a dibujar el gráfico. Si un elemento puede aceptar una imagen, por ejemplo, cuando selecciona un gráfico de barras o uno con fondo, el gráfico busca un metarchivo en el Portapapeles. Si lo encuentra, utiliza dicho metarchivo para llenar el objeto seleccionado.


GetData (Método, control MSChart)

Devuelve el valor almacenado actualmente en un punto de datos específico en la cuadrícula asociada a un gráfico.

Sintaxis

objeto.GetData (row, column, dataPoint, nullFlag)

La sintaxis del método GetData consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
row | Integer. Identifica la fila que contiene el valor del punto de datos.
column | Integer. Identifica la columna que contiene el valor del punto de datos.
dataPoint | Double. El valor del punto de datos.
nullFlag | Integer. Indica si el valor del punto de datos es nulo.


GetSelectedPart (Método)

Identifica el elemento del gráfico seleccionado actualmente.

Sintaxis

objeto.GetSelectedPart (part, index1, index2, index3, index4)

La sintaxis del método GetSelectedPart consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
part | Integer. Especifica el elemento del gráfico. Las constantes válidas son VtChPartType.
index1 | Integer. Si el elemento hace referencia a una serie o a un punto de datos, este argumento especifica la serie. Las series se numeran en el orden en que sus columnas correspondientes aparecen en la cuadrícula de datos de izquierda a derecha, a partir de 1. Si el elemento hace referencia a un eje o a una etiqueta de eje, este argumento identifica el tipo de eje con una constante VtChAxisId.
index2 | Integer. Si el elemento hace referencia a un punto de datos, este argumento especifica el punto de datos de la serie identificada mediante el index1.
index3 | Integer. Si el elemento hace referencia a una etiqueta de eje, este argumento hace referencia al nivel de la etiqueta. Los niveles de etiquetas de ejes se numeran desde el exterior del eje, a partir de 1. Si el elemento no es una etiqueta de eje, no se utiliza este argumento.
index4 | Integer. Este argumento no se utiliza en este momento.


InitializeLabels (Método)

Asigna un identificador único a cada etiqueta del primer nivel de etiquetas de la cuadrícula de datos.

Sintaxis

objeto.InitializeLabels

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.


InsertColumnLabels (Método)

Inserta niveles de etiquetas en las columnas de datos de una cuadrícula de datos asociada a un gráfico.

Sintaxis

objeto.InsertColumnLabels (labelIndex, count)

La sintaxis del método InsertColumnLabels consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
labelIndex | Integer. Identifica el número del primer nivel de etiquetas que desea insertar. Los niveles de etiquetas de columnas se numeran de abajo a arriba, a partir de 1.
count | Integer. Especifica el número de niveles de etiquetas que desea insertar. El número de columnas que se inserta se calcula desde la columna identificada en labelIndex hacia arriba.


InsertColumns (Método)

Agrega una o más columnas de datos a la cuadrícula de datos asociada a un gráfico.

Sintaxis

objeto.InsertColumns (column, count)

La sintaxis del método InsertColumns consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
column | Integer. Identifica una columna de datos específica. Las columnas se numeran de izquierda a derecha, a partir de 1.
count | Integer. Especifica el número de columnas que desea insertar.


InsertRowLabels (Método)

Inserta niveles de etiquetas desde las filas de datos a una cuadrícula de datos asociada a un gráfico.

Sintaxis

objeto.InsertRowLabels (labelIndex, count)

La sintaxis del método InsertRowLabels consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
labelIndex | Integer. Identifica el número del primer nivel de etiquetas que desea insertar. Las etiquetas de filas se numeran de derecha a izquierda, a partir de 1.
count | Integer. Especifica el número de niveles de etiquetas que desea insertar. Las etiquetas de filas se insertan desde la fila identificada en labelIndex hacia la izquierda.


InsertRows (Método)

Agrega una o más filas de datos a la cuadrícula de datos asociada a un gráfico.

Sintaxis

objeto.InsertRows (row, count)

La sintaxis del método InsertRows consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
row | Integer. Identifica una fila de datos específica. Las filas se numeran de arriba a abajo, a partir de 1.
count | Integer. Especifica el número de filas que desea insertar. Las filas contienen datos nulos hasta que las rellene con datos.


Layout (Método)

Diseña un gráfico y fuerza que se vuelvan a calcular los valores automáticos.

Sintaxis

objeto.Layout

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.

Comentarios

Un gráfico se diseña la primera vez que se dibuja. Cuando cambia cualquier valor del gráfico, se vuelve a diseñar el gráfico la próxima vez que se dibuja. Hay un determinado número de valores que el gráfico calcula, como los valores mínimos y máximos de los ejes, según el tipo de gráfico u otros valores. Estos valores no se determinan hasta que se diseña el gráfico. Si intenta "obtener" esos valores automáticos antes de que el gráfico esté adecuadamente diseñado, no se reflejarán los valores nuevos.


MoveData (Método)

Mueve un intervalo de datos dentro de una cuadrícula de datos asociada a un gráfico.

Sintaxis

objeto.MoveData (top, left, bottom, right, overOffset, downOffset)

La sintaxis del método MoveData consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
top | Integer. Identifica la primera fila del intervalo que desea mover.
left | Integer. Identifica la primera columna del intervalo que desea mover.
bottom | Integer. Identifica la última fila del intervalo que desea mover.
right | Integer. Identifica la última columna del intervalo que desea mover.
overOffset | Integer. Identifica la dirección horizontal en que se moverán los datos. Un valor positivo mueve los datos hacia la derecha y uno negativo los mueve hacia la izquierda.
downOffset | Integer. Identifica la dirección vertical en que se moverán los datos. Un valor positivo los mueve hacia abajo y uno negativo los mueve hacia arriba.


RandomDataFill (Método)

Rellena la cuadrícula de datos asociada a un gráfico específico con datos generados de forma aleatoria.

Sintaxis

objeto.RandomDataFill

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.


RandomFillColumns (Método)

Llena un número de columnas de una cuadrícula de datos asociada a un gráfico con valores aleatorios.

Sintaxis

objeto.RandomFillColumns (column, count)

La sintaxis del método RandomFillColumns consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
column | Integer. Identifica la primera columna que desea rellenar. Las columnas se numeran de izquierda a derecha, a partir de 1.
count | Integer. Especifica el número de columnas que desea rellenar con datos aleatorios.


RandomFillRows (Método)

Rellena un número de filas de una cuadrícula de datos asociada a un gráfico con valores aleatorios.

Sintaxis

objeto.RandomFillRows (row, count)

La sintaxis del método RandomFillRows consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
row | Integer. Identifica la primera fila que desea rellenar. Las filas se numeran de arriba a abajo, a partir de 1.
count | Integer. Especifica el número de filas que desea rellenar con datos aleatorios.


Remove (Método, Colección LightSources)

Quita un objeto LightSource de la colección LightSources.

Sintaxis

objeto.Remove (index)

La sintaxis del método Remove consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
index | Integer. Un origen específico de la luz definido por su ubicación en la lista de orígenes de luz.


ResetCustomLabel (Método)

Restablece los atributos personalizados de una etiqueta de punto de datos del gráfico a los valores predeterminados de la serie.

Sintaxis

objeto.ResetCustomLabel

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.


ResetCustom (Método)

Restablece los atributos personalizados de un punto de datos a los valores predeterminados de la serie.

Sintaxis

objeto.ResetCustom

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.


Select (Método)

Selecciona el elemento especificado del gráfico.

Sintaxis

objeto.Select

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.


SelectPart (Método)

Selecciona la parte del gráfico especificada.

Sintaxis

objeto.SelectPart (part, index1, index2, index3, index4)

La sintaxis del método SelectPart consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
part | Integer. Especifica el elemento del gráfico. Las constantes válidas son VtChPartType.
index1 | Integer. Si part hace referencia a una serie o a un punto de datos, este argumento especifica la serie. Las series se numeran en el orden en que aparecen sus columnas correspondientes en la cuadrícula de datos de izquierda a derecha, a partir de 1. Si part hace referencia a un eje o a una etiqueta de eje, este argumento identifica el tipo de eje con una constante VtChAxisId.
index2 | Integer. Si part hace referencia a un punto de datos, este argumento especifica el punto de datos de la serie identificada por index1. Los puntos de datos se numeran en el orden en que aparecen sus filas correspondientes en la cuadrícula de datos de arriba a abajo, a partir de 1. Si part hace referencia a un eje, un título de eje o una etiqueta de eje, este argumento hace referencia al índice del eje que no se está utilizando actualmente. En este caso, el único valor válido para este argumento es 1.
index3 | Integer. Si part hace referencia a una etiqueta de eje, este argumento hace referencia al nivel de la etiqueta. Los niveles de etiquetas de eje se numeran desde el exterior del eje, a partir de 1. Si part no es una etiqueta de eje, no se utiliza el argumento.
index4 | Integer. Este argumento no se utiliza en este momento.


SetData (Método, control MSChart)

Establece el valor de un punto de datos específico de la cuadrícula de datos asociada a un gráfico.

Sintaxis

objeto.SetData (row, column, dataPoint, nullFlag)

La sintaxis del método SetData consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
row | Integer. Identifica la fila que contiene el valor del punto de datos.
column | Integer. Identifica la columna que contiene el valor del punto de datos.
dataPoint | Double. El valor del punto de datos.
nullFlag | Integer. Indica si el valor del punto de datos es nulo.


Set (Método, propiedad LightSource)

Establece las coordenadas x, y y z así como la intensidad de la ubicación del objeto LightSource.

Sintaxis

objeto.Set (x, y, z, intensity)

La sintaxis del método Set consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
x, y, z | Integer. Indican la ubicación del origen de luz.
intensity | Single. Indica la intensidad del origen de luz.


Set (Método, Coor, LCoor)

Establece los valores de las coordenadas x e y de un gráfico.

Sintaxis

objeto.Set (x, y)

La sintaxis del método Set consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
x | Single. (Long en el objeto LCoor.) Identifica el valor x de la coordenada.
y | Single. (Long en el objeto LCoor.) Identifica el valor y de la coordenada.


Set (Método, objeto View3D)

Establece la rotación y el grado de elevación de un gráfico tridimensional.

Sintaxis

objeto.Set (rotation, elevation)

La sintaxis del método Set consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
rotation Single. El grado de rotación.

El intervalo de rotación va de 0 a 360 grados. De forma predeterminada, se utilizan grados para medir la rotación. Sin embargo, estos valores utilizan la configuración actual de la propiedad AngleUnits. Las otras opciones son grados centesimales y radianes.
elevation Single. El grado de elevación.

La elevación es un número que va de 0 a 90 grados. Si establece la elevación a 90 grados, el gráfico se verá directamente desde arriba. Si establece la elevación a 0, el gráfico se verá desde un lado. La elevación predeterminada es de 30 grados. De forma predeterminada, se utilizan grados para medir la elevación. Sin embargo, estos valores utilizan la configuración actual de la propiedad AngleUnits. Las otras opciones son grados centesimales y radianes.


Set (Método, objeto VtColor)

Establece los valores de rojo, verde y azul del objeto VtColor.

Sintaxis

objeto.Set (red, green, blue)

La sintaxis del método Set consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
red, green, blue | Integer. Los valores de los componentes rojo, verde y azul del color.

Comentarios

RGB especifica la intensidad relativa de rojo, verde y azul para hacer que se muestre un color específico. El intervalo válido de un color RGB va de 0 a 16.777.215. El valor de cualquier argumento de RGB supere 255 toma el valor 255.


Set (Método, objeto Weighting)

Devuelve la base y el estilo del objeto Weighting.

Sintaxis

objeto.Set (basis, style)

La sintaxis del método Set consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
basis | Una constante VtChPieWeightBasis que identifica el tipo de medida.
style | Una constante VtChPieWeightStyle que identifica el método del factor de medida.


SetSize (Método)

Cambia, a la vez, el número de columnas y filas de datos, así como el número de niveles de las etiquetas de columnas y de filas de una cuadrícula de datos asociada a un gráfico.

Sintaxis

objeto.SetSize (rowLabelCount, columnLabelCount, dataRowCount, dataColumnCount)

La sintaxis del método SetSize consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
rowLabelCount | Integer. Devuelve o establece el número de niveles de etiquetas de fila que desea tener en la cuadrícula de datos.
columnLabelCount | Integer. Devuelve o establece el número de niveles de etiquetas de columna que desea tener en la cuadrícula de datos.
dataRowCount | Integer. Devuelve o establece el número de filas de datos que desea tener en la cuadrícula de datos.
dataColumnCount | Integer. Devuelve o establece el número de columnas de datos que desea tener en la cuadrícula de datos.

Comentarios

Este método se puede usar en lugar de los métodos RowCount, ColumnCount, RowLabelCount y ColumnLabelCount.

Si reduce el tamaño de la cuadrícula de datos, se destruyen los datos de las filas o las columnas eliminadas.


ToDefaults (Método)

Devuelve al gráfico su configuración inicial.

Sintaxis

objeto.ToDefaults

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.


TwipsToChartPart (Método)

Identifica un elemento del gráfico mediante la pareja de coordenadas x e y.

Sintaxis

objeto.TwipsToChartPart (xVal, yVal, part, index1, index2, index3, index4)

La sintaxis del método TwipsToChartPart consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
xVal, yVal | Long. Las coordenadas vertical y horizontal del punto.
part | Integer. Una constante VtChPartType que identifica la parte del gráfico ubicada en las coordenadas xVal e yVal.
index1 | Integer. Si part hace referencia a una serie o a un punto de datos, este argumento especifica la serie. Las series se numeran en el orden en que aparecen sus columnas correspondientes en la cuadrícula de datos de izquierda a derecha, a partir de 1. Si part hace referencia a un eje o a una etiqueta de eje, este argumento identifica el tipo de eje mediante la constante VtChAxisId.
index2 | Integer. Si part hace referencia a un punto de datos, este argumento especifica el punto de datos de la serie identificada por index1. Los puntos de datos se numeran en el orden en que aparecen sus filas correspondientes en la cuadrícula de datos de arriba a abajo, a partir de 1. Si part hace referencia a un eje, un título de eje o una etiqueta de eje, este argumento hace referencia al índice del eje que no se está utilizando actualmente. En este caso, el único valor válido para este argumento es 1.
index3 | Integer. Si part hace referencia a una etiqueta de eje, este argumento hace referencia al nivel de la etiqueta. Los niveles de etiquetas de eje se numeran desde el exterior del eje, a partir de 1. Si part no es una etiqueta de eje, no se utiliza el argumento.
index4 | Integer. Este argumento no se utiliza en este momento.


TypeByChartType (Método)

Devuelve el tipo de serie que se utiliza para dibujar una serie si el tipo de gráfico está establecido a tipoGráfico. Este método le permite obtener la información del tipo de serie basada en un tipo de gráfico específico sin tener que establecer realmente el tipo de gráfico.

Sintaxis

objeto.TypeByChartType (chtype)

La sintaxis del método TypeByChartType consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
chtype | Integer. Una constante VtChChartType que describe el tipo de gráfico.

Valores devueltos

Dependiendo del tipo de gráfico especificado con el argumento GraphicType, el método TypeByChartType devuelve uno de los valores de VtChSeriesType, como se muestra a continuación:

Constante | Valor | Descripción
VtChSeriesTypeDefault | -1 | Predeterminado.
VtChSeriesType3dBar | 0 | Barra 3D.
VtChSeriesType2dBar | 1 | Barra 2D.
VtChSeriesType3dLine | 5 | Línea 3D.
VtChSeriesType2dLine | 6 | Línea 2D.
VtChSeriesType3dArea | 7 | Área 3D.
VtChSeriesType3dStep | 9 | Paso 3D.
VtChSeriesType2dStep | 10 | Paso 2D.
VtChSeriesType2dXY | 11 | XY 2D.
VtChSeriesType2dPie | 24 | Gráfico circular 2D.


AxisGrid (Objeto)

Representa el área del plano que rodea al eje del gráfico.

Sintaxis

AxisGrid


Ejemplo del objeto AxisGrid

En el ejemplo siguiente se modifica la apariencia del estilo de las líneas del eje y con AxisGrid.

Private Sub Command1_Click()
   With MSChart1.Plot.Axis(VtChAxisIdY)
      .CategoryScale.Auto = False
      .ValueScale.MajorDivision = 10
      .ValueScale.MinorDivision = 5
      .AxisGrid.MajorPen.Style = VtPenStyleSolid
      .AxisGrid.MajorPen.VtColor.Green = 255
      .AxisGrid.MajorPen.Width = 2
      .AxisGrid.MinorPen.Style = VtPenStyleDashed
      .AxisGrid.MinorPen.VtColor.Red = 255
      .AxisGrid.MinorPen.Width = 1
      .AxisGrid.MinorPen.Cap = VtPenCapRound
   End With
End Sub


Axis (Objeto)

Representa un eje de un gráfico.

Sintaxis

Axis

Comentarios

Hay tres ejes disponibles: x, y y z. El eje z sólo es visible cuando el gráfico es un gráfico 3D.


Ejemplo del objeto Axis

En el ejemplo siguiente se lee el número de niveles de etiquetas del eje x mediante el objeto Axis x.

Private Sub Command1_Click()
   Dim XAxis As Object
   Dim NumberOfLevels As Integer
   ' Lee el número de niveles de etiquetas que hay en
   ' el eje X.
   Set XAxis = MSChart1.Plot.Axis(VtChAxisIdX, 1)
   NumberOfLevels = XAxis.LabelLevelCount
   MsgBox "Número de niveles de etiquetas = " _
   & Str(NumberOfLevels)
End Sub


AxisScale (Objeto)

Controla cómo se trazan los valores de un gráfico en un eje.

Sintaxis

AxisScale


Ejemplo de AxisScale

Los ejemplos siguientes establecen los ejes x e y a una escala de porcentaje o a una logarítmica para un gráfico de líneas de dos dimensiones. Para probar el ejemplo, dibuje un control MSChart y dos controles CommandButton en un formulario. Pegue el código dentro del módulo de código del objeto Form y ejecute el proyecto.

Private Sub Command1_Click()
   ' Cambia los ejes x e y a la escala Porcentaje
   ' para un gráfico de líneas 2D.
   Dim axisID As VtChAxisId
   MSChart1.ChartType = VtChChartType2dLine
   For AxisId = VtChAxisIdX To VtChAxisIdY
      With MSChart1.Plot.Axis(AxisId).AxisScale
         .Type = VtChScaleTypePercent
         .PercentBasis = VtChPercentAxisBasisSumChart
      End With
   Next
End Sub

Private Sub Command2_Click()
   Dim axisID As VtChAxisId
   ' Cambia los ejes x e y a la escala Logarítmica
   ' para un gráfico de líneas 2D.
   MSChart1.ChartType = VtChChartType2dLine
   For axisID = VtChAxisIdX To VtChAxisIdY
      With MSChart1.Plot.Axis(axisID).AxisScale
         .Type = VtChScaleTypeLogarithmic
         .LogBase = 12
      End With
   Next
End Sub


AxisTitle (Objeto)

Representa el título de un eje de un gráfico.

Sintaxis

AxisTitle


Ejemplo del objeto AxisTitle

El ejemplo siguiente hace visibles los títulos de todos los ejes de un gráfico en tres dimensiones.

Private Sub Command1_Click()
   ' Hace visibles los títulos de todos los
   ' ejes de un gráfico 3D.
   Dim axisID As VtChAxisId
   MSChart1.chartType = VtChChartType3dBar
   For axisId = VtChAxisIdX To VtChAxisIdZ
      With MSChart1.Plot.axis(axisId, 1)
         .AxisTitle.VtFont.Size = 14
         .AxisTitle.Visible = True
         Select Case axisId
            Case 0
               .AxisTitle.Text = "Título del eje X"
            Case 1
                .AxisTitle.Text = "Título del eje Y"
            Case 2
               .AxisTitle.Text = "Título del eje Y secundario"
            Case 3
               .Text = "Título del eje Z"
         End Select
      End With
   Next
End Sub


Backdrop (Objeto)

Representa una sombra o patrón que está detrás de un elemento del gráfico.

Sintaxis

Backdrop

Comentarios

Para los objetos Plot del objeto Backdrop, establezca la propiedad Style a VtFillStyleBrush para ver los efectos.


Brush (Objeto)

El tipo de relleno utilizado para mostrar un elemento del gráfico.

Sintaxis

Brush


Ejemplo del objeto Brush

El ejemplo siguiente establece un patrón de línea vertical en negrita para el fondo del gráfico mediante el objeto Brush.

Private Sub Command1_Click()
   ' Establece Backdrop a relleno, estilo de pincel.
   MSChart1.Backdrop.Fill.Style = VtFillStyleBrush
   ' Establece un patrón para el fondo del gráfico
   ' mediante el objeto Brush.
   With MSChart1.Backdrop.Fill.Brush
      .Style = VtBrushStylePattern
      .Index = VtBrushPatternBoldVertical
   ' Establece el patrón a líneas verticales en
   ' negrita.
      .FillColor.Set 255, 0, 0   ' Color del relleno = rojo.
      .PatternColor.Set 0, 0, 255   ' Color del patrón = azul.
   End With
End Sub


CategoryScale (Objeto)

La escala de un eje de la categoría correspondiente.

Sintaxis

CategoryScale


Ejemplo del objeto CategoryScale

El ejemplo siguiente establece los atributos de escala para un eje de la categoría.

Private Sub Command1_Click()
   ' Establece los atributos de escala de un eje de
   ' la categoría.
   MSChart1.ChartType = VtChChartType2dLine
   With MSChart1.Plot.Axis(VtChAxisIdX)
      .ValueScale.MajorDivision = 10
      .ValueScale.MinorDivision = 5
      .CategoryScale.Auto = False    ' Establece la escala
                                     ' manual.
      .CategoryScale.DivisionsPerLabel = 2 ' La etiqueta aparece
                                           ' cada dos divisiones.
      .CategoryScale.DivisionsPerTick = 2 ' Las marcas aparecen
                                           ' cada dos divisiones.
      .CategoryScale.LabelTick = True   ' Las etiquetas se muestran
                                       ' sobre las marcas.
   End With
End Sub


Coor (Objeto)

Describe una pareja de coordenadas flotantes x e y de un gráfico.

Sintaxis

Coor


DataGrid (Objeto)

Representa una matriz virtual que contiene etiquetas y puntos de datos para el control MSChart.

Sintaxis

DataGrid

Comentarios

El objeto DataGrid está configurado en filas y columnas. Puede agregar y quitar filas, columnas y etiquetas a esta matriz para cambiar la apariencia del gráfico.


Ejemplo del objeto DataGrid

El ejemplo siguiente establece los parámetros de un gráfico de barras en tres dimensiones, se rellena el gráfico con datos aleatorios y se colocan etiquetas en las columnas de la cuadrícula de datos.

Option Explicit
Option Base 1

Private Sub Command1_Click()
   Dim rowLabelCount, columnLabelCount, rowCount As Integer
   Dim columnCount, labelIndex, Column, Row As Integer
   MSChart1.ChartType = VtChChartType3dBar
   With MSChart1.DataGrid
   ' Establece los parámetros del gráfico mediante
   ' los métodos.
      rowLabelCount = 2
      columnLabelCount = 2
      rowCount = 6
      columnCount = 6
      .SetSize RowLabelCount, ColumnLabelCount, _
      RowCount, ColumnCount
      ' Rellena el gráfico con datos aleatoriamente.
      .RandomDataFill
      ' Asigna etiquetas al segundo nivel.
      labelIndex = 2
      column = 1
      .ColumnLabel(column, labelIndex) = "Producto 1"
      column = 4
      .ColumnLabel(column, labelIndex) = "Producto 2"
      row = 1
      .RowLabel(row, labelIndex) = "1994"
      row = 4
      .RowLabel(row, labelIndex) = "1995"
   End With
End Sub


DataPointLabel (Objeto)

La etiqueta de un punto de datos del gráfico.

Sintaxis

DataPointLabel


DataPoint (Objeto)

Un miembro de la colección DataPoints que describe los atributos de un punto de datos individual de un gráfico.

Sintaxis

DataPoint

Comentarios

Se tiene acceso a la colección DataPoints a través del objeto SeriesCollection.

Importante La colección DataPoints sólo contiene un miembro en este momento. Para tener acceso al mismo debe usar –1, como se muestra a continuación:

MSChart1.Plot.SeriesCollection(1).DataPoints(-1) _
.Brush.FillColor.Set 0, 255, 255


Ejemplo del objeto DataPoint

El ejemplo siguiente asigna una variable a un punto de datos establece el color y el marcador del punto de datos.

Private Sub Command1_Click()
   ' Modifica el color y el marcador del primer
   ' punto de datos de la primera serie.
   With MSChart1.Plot.SeriesCollection(1).DataPoints(-1)
      ' Cambia el color del punto de datos a azul.
      .Brush.Style = VtBrushStyleSolid
      ' Establece Color=Blue.
      .Brush.FillColor.Set 0, 255, 255
      ' Hace que el marcador del punto de datos sea
      ' visible.
      .Marker.Visible = True
   End With
End Sub


Fill (Objeto)

Describe el tipo y la apariencia del fondo de un objeto de un gráfico.

Sintaxis

Fill


Ejemplo del objeto Fill

El ejemplo siguiente establece un fondo de gradiente en un gráfico mediante el objeto Fill.

Private Sub Command1_Click()
   With MSChart1.backdrop.Fill
      ' Establece un fondo de patrón de pincel.
      .Style = VtFillStyleBrush
      .Brush.Style = VtBrushPattern50Percent
   End With
End Sub


Ejemplo de VtFontObject

El ejemplo siguiente establece los parámetros de la fuente del título del gráfico.

Private Sub Command1_Click()
   ' Pide al usuario que proporcione un título.
   MSChart1.Title.Text = InputBox("¿Título?")
   ' Hace que sea visible el título del gráfico.
   MSChart1.Title.Location.Visible = True
   ' Establece la fuente del título del gráfico.
   With MSChart1.Title.VtFont
      .Name = "Times New Roman"
      .Size = 18
      .Style = VtFontStyleBold Or _
      VtFontStyleItalic
      ' Utiliza Tachado y Subrayado en el texto.
      .Effect = VtFontEffectStrikeThrough Or _
      VtFontEffectUnderline
      ' Establece el color del texto a azul.
      .VtColor.Set 0, 0, 255
   End With
End Sub


Footnote (Objeto)

El texto de descripción que aparece debajo del gráfico.

Sintaxis

Footnote


Ejemplo del objeto Footnote

El ejemplo siguiente establece la ubicación, el texto y el color de las notas a pie de página del gráfico.

Private Sub Command1_Click()

   With MSChart1.Footnote
      ' Hace que Footnote sea visible.
      .Location.Visible = True
      .Location.LocationType = _
      VtChLocationTypeBottomLeft

      ' Establece las propiedades de Footnote.
      .text = "Notas a pie de página del gráfico"
      .VtFont.VtColor.Set 255, 0, 0
   End With

End Sub


Frame (Objeto)

Contiene información acerca de la apariencia del marco que hay alrededor de un elemento del gráfico.

Sintaxis

Frame


Ejemplo del objeto Frame

El ejemplo siguiente establece un marco azul con doble línea en el fondo del gráfico.

Private Sub Command1_Click()
   With MSChart1.Backdrop.Frame
      .Style = VtFrameStyleDoubleLine
      .Width = 2
      .FrameColor.Set 0, 0, 255   ' Marco azul.
      .SpaceColor.Set 255, 0, 0   ' Espaciado rojo.
   End With
End Sub


Intersection (Objeto)

El punto en que un eje se cruza con un eje de intersección del gráfico.

Sintaxis

Intersection


Ejemplo del objeto Intersection

El ejemplo siguiente establece manualmente las propiedades del punto de intersección y muestra las etiquetas con el eje.

Private Sub Command1_Click()
      With MSChart1.Plot.Axis(VtChAxisIdX).Intersection
      ' Establece los valores de Intersection.
      .Auto = False   ' Establece la ubicación
                     ' a manual.
      .Point = 20      ' Establece la intersección con
                     ' el eje Y a 20.
      .LabelsInsidePlot = True   ' Muestra etiquetas
                                 ' con el eje, pero
                                 ' no en la base.
   End With
End Sub


Label (Objeto)

Un elemento de una colección Labels que describe una etiqueta específica de un eje del gráfico.

Sintaxis

eje.Label


LCoor (Objeto)

Describe una pareja de coordenadas x e y con un entero largo.

Sintaxis

Lcoor


Legend (Objeto)

Representa la clave gráfica y el texto adjunto que describe una serie del gráfico.

Sintaxis

Legend


Ejemplo del objeto Legend

El ejemplo siguiente establece los parámetros de texto y fondo de la leyenda de un gráfico.

Private Sub Command1_Click()
   With MSChart1.Legend
      ' Hace que la layenda sea visible.
      .Location.Visible = True
      .Location.LocationType = VtChLocationTypeRight
      ' Establece las propiedades de la leyenda.
      .TextLayout.HorzAlignment = _
      VtHorizontalAlignmentRight   ' Justifica a la
                                 ' derecha.
      ' Utiliza texto amarillo.
      .VtFont.VtColor.Set 255, 255, 0
      .Backdrop.Fill.Style = VtFillStyleBrush
      .Backdrop.Fill.Brush.Style = VtBrushStyleSolid
      .Backdrop.Fill.Brush.FillColor.Set 255, 0, 255
   End With
End Sub


Light (Objeto)

Representa el origen de la luz que ilumina un gráfico tridimensional.

Sintaxis

Light


Ejemplo del objeto Light

El ejemplo siguiente establece la luz de ambiente y la intensidad de iluminación de los bordes de un gráfico. Para probar el ejemplo, dibuje un control MSChart y dos controles ComboBox en un formulario. Pegue el código en el módulo de código del objeto Form y ejecute el proyecto. Haga clic en los controles ComboBox para ver el cambio de la luz de ambiente y de la intensidad de iluminación.

Private Sub Form_Load()
  ' Configura el gráfico.
   Con MSChart1
      .Title = "Mantenga presionada la tecla Control y haga clic con el mouse en el gráfico"
      .chartType = VtChChartType3dBar
      .Plot.Light.AmbientIntensity = 1  ' Intensidad del 100 %.
      .Plot.Light.EdgeIntensity = 0.5    ' Intensidad del 50 %.
      .Plot.Light.EdgeVisible = True
   End With
  'Configura los controles ComboBox.
   ConfigCombo Combo1
   ConfigCombo Combo2
End Sub

Private Sub ConfigCombo(cmb As ComboBox)
   ' Rellena un cuadro combinado con valores.
   Dim i As Single
   For i = 0 To 1 Step 0.1
      cmb.AddItem i
   Next i
   cmb.ListIndex = 0
End Sub

Private Sub Combo1_Click()
   MSChart1.Plot.Light.AmbientIntensity = Combo1.Text
End Sub

Private Sub Combo2_Click()
   MSChart1.Plot.Light.EdgeIntensity = Combo2.Text
   End With
End Sub


LightSource (Objeto)

Representa el origen de luz que se utiliza para iluminar los elementos de un gráfico tridimensional.

Sintaxis

LightSource


Location (Objeto)

Representa la ubicación actual de un elemento de texto del gráfico como el título, la leyenda o la nota a pie de página.

Sintaxis

Location

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.


Ejemplo del objeto Location

El ejemplo siguiente establece la ubicación del título de un gráfico mediante el objeto Location. Para probar el ejemplo, dibuje un control MSChart y un control ComboBox en un formulario. Pegue el código en el módulo de código del objeto Form y ejecute el proyecto. Haga clic en el control ComboBox para cambiar la ubicación del título.

Option Explicit

Private Sub Combo1_Click()
   MSChart1.Title.Location.LocationType = Combo1.ListIndex
End Sub

Private Sub Form_Load()
   ' Establece el texto del título.
   With MSChart1
      .TitleText = "Prueba la ubicación del título"
      .Title.Location.Visible = True
   End With

   ' Agrega constantes LocationType a ComboBox.
   With Combo1
      .AddItem "VtChLocationTypeTopLeft"   ' 0
      .AddItem "VtChLocationTypeTop"     ' 1
      .AddItem "VtChLocationTypeTopRight"  ' 2
      .AddItem "VtChLocationTypeLeft"    ' 3
      .AddItem "VtChLocationTypeRight"    ' 4
      .AddItem "VtChLocationTypeBottomLeft" ' 5
      .AddItem "VtChLocationTypeBottom"   ' 6
      .AddItem "VtChLocationTypeBottomRight" ' 7
      .AddItem "VtChLocationTypeCustom"   ' 8
      .ListIndex = 0
   End With
End Sub


Marker (Objeto)

Un marcador que identifica un punto de datos en un gráfico.

Sintaxis

Marker


Ejemplo del objeto Marker

El ejemplo siguiente establece un estilo de marcador X azul para la serie de un gráfico.

Option Explicit
Option Base 1
Private Sub Command1_Click()
   ' Muestra los marcadores para la serie 1.
   Dim i As Integer
   For i = 1 To MSChart1.Plot.SeriesCollection.Count
      With MSChart1.Plot.SeriesCollection _
      .Item(i).DataPoints.Item(-1).Marker
         .Visible = True
         .Size = 20
         .Style = VtMarkerStyleX
         .FillColor.Automatic = False
         .FillColor.Set 0, 0, 255
      End With
   Next i
End Sub


Pen (Objeto)

Describe el color y el patrón de las líneas o bordes de un gráfico.

Sintaxis

Pen


Ejemplo de la propiedad GuideLinePen del objeto Pen

El ejemplo siguiente establece los atributos del lápiz para una serie de un gráfico xy bidimensional. La propiedad GuideLinePen devuelve una referencia a un objeto Pen.

Private Sub Command1_Click()
   ' Establece las líneas de guía de la Serie 1 de un
   ' gráfico XY 2D.
   MSChart1.ChartType = VtChChartType2dXY
   MSChart1.Plot.SeriesCollection.Item(1) _
   .ShowGuideLine(VtChAxisIdX) = True
   With _
   MSChart1.Plot.SeriesCollection.Item(1).GuideLinePen
      ' Establece los atributos del lápiz.
      .VtColor.Set 255, 255, 0
      .Width = 10
      .Style = VtPenStyleDashDot
      .Join = VtPenJoinRound
      .Cap = VtPenCapRound
   End With
End Sub


PlotBase (Objeto)

El área que hay debajo de un gráfico.

Sintaxis

PlotBase


Ejemplo del objeto PlotBase

El ejemplo siguiente establece los parámetros de la base del gráfico en un gráfico de barras tridimensional.

Private Sub Command1_Click()
   ' Cambia el tipo de gráfico a 3D.
   MSChart1.ChartType = VtChChartType3dBar
   With MSChart1.Plot.PlotBase
      ' Cambia el alto de la base.
      .BaseHeight = 20
      ' Utiliza el estilo del patrón para la base.
      .Brush.Style = VtBrushStylePattern
      .Brush.Index = VtBrushPatternHorizontal
      .Brush.FillColor.Set 255, 160, 160
      .Brush.PatternColor.Set 180, 180, 255
      .Pen.Style = VtPenStyleSolid
      .Pen.VtColor.Set 72, 72, 255
   End With
End Sub


Plot (Objeto)

Representa el área sobre la que se muestra el gráfico.

Sintaxis

Plot

Comentarios

El objeto Plot permite programar los siguientes objetos:

  1. Objeto Axis: representa los ejes x, y, y z del gráfico. El eje z sólo es visible en gráficos 3D.

  2. Objeto BackDrop: el área situada por detrás de los ejes.

  3. Objeto Light: la luz de ambiente e intensidad de iluminación del trazo.

  4. Objeto LocationRect: la ubicación del trazo.

  5. Objeto SeriesCollection: la colección de conjuntos de series.

  6. Objeto View3D: el ángulo de elevación y rotación de la imagen 3D.

  7. Objeto Wall: el área situada por detrás del trazo.


Ejemplo del objeto Plot

El ejemplo siguiente establece la distancia de vista del gráfico y el espaciado de las divisiones del eje.

Private Sub Command1_Click()
   ' Cambia el tipo de gráfico a Barras 3D.
   MSChart1.ChartType = VtChChartType3dBar
   With MSChart1.Plot
      ' Cambia la vista del gráfico de barras 3D.
      .DepthToHeightRatio = 2
      .WidthToHeightRatio = 2
      ' Cambia el espaciado entre las divisiones del
      ' eje X.
      .xGap = 0
      ' Cambia el espaciado entre las divisiones del
      ' eje Z.
      .zGap = 0.8
   End With
End Sub


Rect (Objeto)

Define una ubicación de coordenadas.

Sintaxis

Rect


Ejemplo de la propiedad LocationRect del objeto Rect

El ejemplo aumenta el tamaño del trazado del gráfico mediante la propiedad LocationRect y las propiedades X e Y del objeto Rect.

Private Sub Command1_Click()
   ' Aumenta el tamaño del trazado del gráfico.
   MSChart1.Plot.AutoLayout = False
   With MSChart1.Plot.LocationRect
      .Min.x = .Min.x * 1.2
      .Min.y = .Min.y * 1.2
      .Max.x = .Max.x * 1.2
      .Max.y = .Max.y * 1.2
   End With
End Sub


SeriesMarker (Objeto)

Describe un marcador que identifica todos los puntos de datos en una serie del gráfico.

Sintaxis

SeriesMarker


Ejemplo del objeto SeriesMarker

El ejemplo siguiente establece los parámetros del marcador de todas las series de un gráfico.

Private Sub Command1_Click()
   Dim series As Object
   ' Muestra los marcadores y deja de mostrar
   ' las líneas de todas las series.
   MSChart1.chartType = VtChChartType2dLine
   For Each serX In MSChart1.Plot.SeriesCollection
      serX.SeriesMarker.Show = True
      serX.ShowLine = False
   Next
End Sub


Series (Objeto)

Un elemento de la colección SeriesCollection que representa un grupo de puntos de datos de un gráfico.

Sintaxis

Series


Ejemplo del objeto Series

El siguiente ejemplo cambia la apariencia de las líneas en todas las series de un gráfico de líneas tridimensional.

Private Sub Command1_Click()
   Dim serX As Series
   ' Cambia el tipo de gráfico a líneas 3D y suaviza
   ' cada línea.
   MSChart1.chartType = VtChChartType3dLine
   MSChart1.ColumnCount = 4
   For Each serX In MSChart1.Plot.SeriesCollection
      serX.ShowGuideLine(VtChAxisIdY) = True
      serX.GuideLinePen.Style = VtPenStyleDitted
      serX.Pen.Style = 4
   Next
End Sub


SeriesPosition (Objeto)

La ubicación donde se dibuja una serie del gráfico en relación a las demás series. Si todas las series tienen el mismo orden (ubicación), se apilan.

Sintaxis

SeriesPosition


Shadow (Objeto)

Contiene información acerca de la apariencia del sombreado en un elemento del gráfico.

Sintaxis

Shadow


Ejemplo del objeto Shadow

El ejemplo siguiente establece un sombreado en el título de fondo del gráfico.

Private Sub Command1_Click()
   ' Muestra sombreado para el título.
   With MSChart1.Title
      .Location.Visible = True
      .Text = "Título del gráfico"
      .Backdrop.Frame.Width = 1
      .Backdrop.Frame.FrameColor.Set 255, 0, 0
      .Backdrop.Frame.Style = VtFrameStyleSingleLine
      .Backdrop.Shadow.Style = VtShadowStyleDrop
      .Backdrop.Shadow.Offset.x = 10
      .Backdrop.Shadow.Offset.y = 10
   End With
End Sub


StatLine (Objeto)

Describe cómo se muestran las líneas de estadísticas en el gráfico.

Sintaxis

StatLine


Ejemplo del objeto StatLine

El ejemplo siguiente establece los parámetros color y lápiz para una línea de estadísticas de un gráfico.

Private Sub Command1_Click()
   ' Muestra todas las líneas de estadísticas de la
   ' serie 2.
   MSChart1.ChartType = VtChChartType2dLine
   With MSChart1.plot.SeriesCollection(2).StatLine
      .VtColor.Set 128, 128, 255
      .Flag = VtChStatsMinimum Or VtChStatsMaximum _
      Or VtChStatsMean Or VtChStatsStddev Or _
      VtChStatsRegression
      .Style(vtChStatsMinimum) = VtPenStyleDotted
      .Width = 2
   End With
End Sub


TextLayout (Objeto)

Representa la ubicación y orientación del texto.

Sintaxis

TextLayout


Ejemplo del objeto TextLayout

El ejemplo siguiente establece la ubicación y la orientación del texto del título de un gráfico.

Private Sub Command1_Click()
   ' Establece la ubicación y la orientación del texto
   ' del título.
   With Form1.MSChart1.Title
      .Location.Visible = True
      .Location.LocationType = VtChLocationTypeLeft
      .Text = "TextLayout del título"
   End With
   With Form1.MSChart1.Title.TextLayout
      .Orientation = VtOrientationUp
      .HorzAlignment = VtHorizontalAlignmentCenter
      .VertAlignment = VtVerticalAlignmentCenter
   End With
End Sub


Tick (Objeto)

Un marcador que indica una división a lo largo de un eje del gráfico.

Sintaxis

Tick


Ejemplo del objeto Tick

El ejemplo siguiente establece en un gráfico la longitud la marca y el estilo del eje y.

Private Sub Command1_Click()
   ' Establece la marca para el eje y.
   With Form1.MSChart1.Plot.Axis(VtChAxisIdY, 1).Tick
      .Length = 500
      .Style = VtChAxisTickStyleOutside
   End With
End Sub


Title (Objeto)

El texto que identifica el gráfico.

Sintaxis

Title


ValueScale (Objeto)

La escala que se utiliza para mostrar un eje de valor.

Sintaxis

ValueScale


Ejemplo del objeto ValueScale

El ejemplo siguiente establece el color de la línea principal y secundaria de la cuadrícula en un gráfico de barras bidimensional, con el objeto ValueScale.

Private Sub Command1_Click()
   ' Establece el tipo de gráfico a barra 2D.
   MSChart1.ChartType = VtChChartType2dBar
   ' Utiliza la escala manual para mostrar el eje y
   '(eje de valor).
   With MSChart1.Plot.Axis(VtChAxisIdY).ValueScale
      .Auto = False
      .MajorDivision = 2
      .MinorDivision = 5
   End With
   ' Muestra la línea principal de la cuadrícula en
   ' rojo y la secundaria en azul
   With MSChart1.Plot.Axis(VtChAxisIdY).AxisGrid
      .MajorPen.VtColor.Set 255, 0, 0
      .MajorPen.Width = 4
      .MinorPen.VtColor.Set 0, 0, 255
      .MinorPen.Width = 2
   End With
End Sub


View3D (Objeto)

Representa la orientación física de un gráfico tridimensional.

Sintaxis

View3D


Ejemplo del objeto View3D

En el ejemplo siguiente se establece el grado de elevación y rotación del gráfico en un gráfico de barras tridimensional, con el objeto View.

Private Sub Command1_Click()
   ' Establece el tipo de gráfico a barra 3D.
   Form1.MSChart1.ChartType = VtChChartType3dBar
   With Form1.MSChart1.Plot.View3d
      .Elevation = 90   ' El gráfico se ve desde
                        ' arriba.
      .Rotation = 90
   End With
End Sub


Ejemplo del control MSChart

El ejemplo siguiente muestra un gráfico tridimensional con ocho columnas y ocho filas de datos y establece los parámetros de la leyenda.

Private Sub Command1_Click()
   With MSChart1
      ' Muestra un gráfico 3d con 8 columnas y 8 filas
      ' de datos.
      .ChartType = VtChChartType3dBar
      .ColumnCount = 8
      .RowCount = 8
      For column = 1 To 8
         For row = 1 To 8
            .Column = column
            .Row = row
            .Data = row * 10
         Next row
      Next column
      ' Utiliza el gráfico como fondo de la leyenda.
      .ShowLegend = True
      .SelectPart VtChPartTypePlot, index1, index2, _
      index3, index4
      .EditCopy
      .SelectPart VtChPartTypeLegend, index1, _
      index2, index3, index4
      .EditPaste
   End With
End Sub


VtColor (Objeto)

Describe el color de dibujo en un gráfico.

Sintaxis

VtColor


Ejemplo de la propiedad FillColor del objeto VtColor

El ejemplo siguiente establece el color de relleno del pincel de fondo de un gráfico. La propiedad FillColor devuelve una referencia al objeto VtColor.

Private Sub Command1_Click()
' Establece Backdrop a estilo Fill - Brush.
   MSChart1.Backdrop.Fill.Style = VtFillStyleBrush
   ' Establece el color de relleno del gráfico a rojo.
   With MSChart1.Backdrop.Fill.Brush.FillColor
      .Red = 255   ' Utiliza propiedades para
                  ' establecer el color.
      .Green = 0
      .Blue = 0
   End With
End Sub


VtFont (Objeto)

La fuente utilizada para mostrar el texto del gráfico.

Sintaxis

VtFont


Wall (Objeto)

El área del plano que representan los ejes x e y de un gráfico tridimensional.

Sintaxis

Wall


Ejemplo del objeto Wall

El ejemplo siguiente muestra una pared coloreada en un gráfico tridimensional.

Private Sub Command1_Click()
   ' Muestra una pared coloreada en un gráfico 3D.
   Form1.MSChart1.ChartType = VtChChartType3dBar
   With Form1.MSChart1.Plot.Wall
      .Brush.Style = VtBrushStylePattern
      .Brush.Index = VtBrushPatternChecks
      .Brush.FillColor.Set 255, 120, 120
      .Brush.PatternColor.Set 120, 120, 0
      .Width = 20
   End With
End Sub


Weighting (Objeto)

Representa el tamaño de un sector en relación a los otros del mismo gráfico circular.

Sintaxis

Weighting


Ejemplo del objeto Weighting

El ejemplo siguiente muestra la medida de un gráfico circular.

Private Sub Command1_Click()
   ' Muestra la masa del gráfico circular.
   Form1.MSChart1.ChartType = VtChChartType2dPie
   With Form1.MSChart1.Plot.Weighting
      .Basis = VtChPieWeightBasisTotal
      .Style = VtChPieWeightStyleArea
   End With
End Sub


ActiveSeriesCount (Propiedad)

Devuelve el número de series que aparecen en un gráfico según el número de columnas del objeto DataGrid y el tipo de gráfico que se está dibujando.

Sintaxis

objeto.ActiveSeriesCount

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.


AllowDithering (Propiedad)

Devuelve o establece un valor que determina si se desactivará la interpolación de color para los gráficos en los monitores a color de 8 bits con el fin de activar la utilización de la paleta de colores del control MSChart y mejorar la vista del gráfico.

Sintaxis

objeto.AllowDithering [ = booleano ]

La sintaxis de la propiedad AllowDithering consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
booleano | Una expresión booleana que especifica si se permite la interpolación de color, como se describe en Valores.

Valores

Los valores de booleano son:

Valor | Descripción
True | Se permite la interpolación de color.
False | (Predeterminado) Se utiliza la paleta de colores del control MSChart para mejorar la vista y el ajuste de los colores.


AllowDynamicRotation (Propiedad)

Devuelve o establece un valor que indica si los usuarios pueden girar interactivamente los gráficos tridimensionales si mantienen presionada la tecla Ctrl para mostrar el cursor de rotación.

Sintaxis

objeto.AllowDynamicRotation [ = booleano ]

La sintaxis de la propiedad AllowDynamicRotation consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
booleano | Una expresión booleana que especifica si se permite la rotación dinámica, como se describe en Valores.

Valores

Los valores de booleano son:

Valor | Descripción
True | (Predeterminado) El usuario puede girar el gráfico interactivamente con el cursor.
False | El usuario no puede girar el gráfico interactivamente con el cursor.


AllowSelections (Propiedad)

Devuelve o establece un valor que indica si los usuarios pueden seleccionar objetos gráficos.

Sintaxis

objeto.AllowSelections [ = booleano ]

La sintaxis de la propiedad AllowSelections consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
booleano | Una expresión booleana que especifica si se pueden seleccionar objetos gráficos, como se describe en Valores.

Valores

Los valores de booleano son:

Valor | Descripción
True | (Predeterminado) El usuario puede seleccionar interactivamente objetos gráficos.
False | El usuario no puede seleccionar objetos gráficos.


AllowSeriesSelection (Propiedad)

Devuelve o establece un valor que indica si se selecciona una serie cuando el usuario hace clic en un punto de datos de un gráfico.

Sintaxis

objeto.AllowSeriesSelection [ = booleano ]

La sintaxis de la propiedad AllowSeriesSelection consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
booleano | Una expresión booleana que especifica si se selecciona una serie, como se describe en Valores.

Valores

Los valores de booleano son:

Valor | Descripción
True | (Predeterminado) Los usuarios pueden seleccionar una serie haciendo clic en un punto de datos.
False | Al hacer clic en un punto de datos se selecciona sólo ese punto de datos, no la serie completa.


AmbientIntensity (Propiedad)

Devuelve o establece el porcentaje de luz de ambiente que ilumina un gráfico tridimensional.

Sintaxis

objeto.AmbientIntensity [ = intensidad ]

La sintaxis de la propiedad AmbientIntensity consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
intensidad | Single. Intensidad de luz del gráfico. Los valores válidos son 0 y 1. Si se establece a 1, se iluminan totalmente todas las caras de los elementos del gráfico, independientemente de los orígenes de luz que estén activados. Si se establece a 0, la luz de ambiente no aporta nada; sólo se iluminan las caras de los elementos del gráfico que estén frente a orígenes de luz activos.


AngleUnit (Propiedad)

Devuelve o establece la unidad de medida que se utiliza en todos los ángulos del gráfico.

Sintaxis

objeto.AngleUnit [ = unidad ]

La sintaxis de la propiedad AngleUnit consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
unidad | Integer. Una constante VtAngleUnits que describe la unidad de medida. Los ángulos se pueden medir en grados, radianes o grados centesimales.


AutoIncrement (Propiedad)

Devuelve o establece un valor que determina si las propiedades que establecen el punto de datos actual se incrementan durante la entrada de datos sin establecer manualmente las propiedades Column y Row.

Sintaxis

objeto.AutoIncrement [ = booleano ]

La sintaxis de la propiedad AutoIncrement consta de las siguientes partes:

Parte | Descripción
Objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
booleano | Una expresión booleana que especifica si se incrementa el punto de datos actual, como se describe en Valores.

Valores

Los valores de booleano son:

Valor | Descripción
True | Cuando se modifica la propiedad Data, la propiedad Row se actualiza a la siguiente fila de la columna. Si está al final de una columna, la propiedad Column se incrementa a la columna siguiente.
False | (Predeterminado) No se incrementa el punto de datos actual.


AutoLayout (Propiedad)

Devuelve o establece un valor que determina si un objeto Plot está en modo de diseño manual o automático.

Sintaxis

objeto.AutoLayout [ = booleano ]

La sintaxis de la propiedad AutoLayout consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
booleano | Una expresión booleana que especifica el modo de diseño, como se describe en Valores.

Valores

Los valores de booleano son:

Valor | Descripción
True | (Predeterminado) El objeto Plot determina automáticamente el tamaño y la ubicación adecuados del gráfico según el tamaño y la ubicación de los demás elementos.
False | Se utilizan las coordenadas especificadas en la propiedad LocationRect del objeto Plot para colocar el gráfico.


Automatic (Propiedad)

Devuelve o establece un valor que determina si el color se calcula automáticamente. Sólo se utiliza para lápices de los bordes en los elementos del gráfico.

Sintaxis

objeto.Automatic [ = booleano ]

La sintaxis de la propiedad Automatic consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
booleano | Una expresión booleana que determina si se calculará automáticamente el color, como se describe en Valores.

Valores

Los valores de booleano son:

Valor | Descripción
True | El color toma automáticamente el color de pincel utilizado en la serie del gráfico.
False | El color se determina según la configuración de Value.


Auto (Propiedad, objeto CategoryScale)

Devuelve o establece un valor que indica si el eje se escala automáticamente.

Sintaxis

objeto.Auto [ = booleano ]

La sintaxis de la propiedad Auto consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
booleano | Una expresión booleana que especifica si se muestra el elemento, como se describe en Valores.

Valores

Los valores de booleano son:

Valor | Descripción
True | (Predeterminado) El eje se escala automáticamente según los datos que se están representando en el gráfico.
False | El eje no se escala automáticamente. Se utilizan los valores de DivisionsPerLabel y DivisionsPerTick para determinar la escala.


Auto (Propiedad, objeto Intersection)

Devuelve o establece un valor que determina si el objeto Intersection utiliza el valor de la propiedad Point para colocar el eje.

Sintaxis

objeto.Auto [ = booleano ]

La sintaxis de la propiedad Auto consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
booleano | Una expresión booleana que especifica si se mostrará el elemento, como se describe en Valores.

Valores

Los valores de booleano son:

Valor | Descripción
True | (Predeterminado) El eje se coloca en su ubicación estándar.
False | El eje de intersección se coloca en el valor que indica la propiedad Point.


Auto (Propiedad, objeto Label)

Devuelve o establece un valor que determina si se rotarán automáticamente las etiquetas del eje para mejorar el diseño del gráfico.

Sintaxis

objeto.Auto [ = booleano ]

La sintaxis de la propiedad Auto consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
booleano | Una expresión booleana que especifica cómo estarán situadas las etiquetas de los ejes, como se describe en Valores.

Valores

Los valores de booleano son:

Valor | Descripción
True | (Predeterminado) Las etiquetas se pueden rotar.
False | No se rotan las etiquetas. Es posible que las etiquetas largas no se muestren correctamente.


Auto (Propiedad, objeto SeriesMarker)

Devuelve o establece un valor que determina si el objeto SeriesMarker asigna el siguiente marcador disponible a todos los puntos de datos de la serie.

Sintaxis

objeto.Auto [ = booleano ]

La sintaxis de la propiedad Auto consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
booleano | Una expresión booleana que controla cómo se asignan los marcadores, como se describe en Valores.

Valores

Los valores de booleano son:

Valor | Descripción
True | (Predeterminado) El objeto SeriesMarker asigna el marcador.
False | Puede asignar un marcador personalizado.

Comentarios

Si desea modificar el tipo de marcador de la serie, establezca esta propiedad a False.

Esta propiedad se establece automáticamente a False si está establecida la propiedad Marker del objeto DataPoint.


Auto (Propiedad, objeto ValueScale)

Devuelve o establece un valor que determina si se utiliza la escala automática para dibujar el eje de valor.

Sintaxis

objeto.Auto [ = booleano ]

La sintaxis de la propiedad Auto consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
booleano | Una expresión booleana que determina si se utiliza la escala automática, como se describe en Valores.

Valores

Los valores de booleano son:

Valor | Descripción
True | La escala se establece automáticamente según los datos que se están representando.
False | Se utilizan los valores de las propiedades Minimum, Maximum, MajorDivisions y MinorDivisions para escalar el eje.


AxisGrid (Propiedad)

Devuelve una referencia a un objeto AxisGrid que representa el área del plano que rodea al eje del gráfico.

Sintaxis

objeto.AxisGrid

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.


AxisId (Propiedad)

Devuelve un eje específico que se cruza con el eje actual.

Sintaxis

objeto.AxisId

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.

Valor devuelto

El valor devuelto es un entero que identifica el eje de intersección.


Axis (Propiedad)

Devuelve una referencia a un objeto Axis que describe un eje en un gráfico.

Sintaxis

objeto.Axis (axisId, index)

La sintaxis de la propiedad Axis consta de las siguientes partes:

Parte | Descripción
objeto | Requerido. Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
axisId | Requerido. Un entero o constante VtChAxisId que identifica un eje específico.
index | Opcional. Reservado para uso futuro. Identifica el eje específico cuando hay más de un eje con el mismo valor de axisId.

Comentarios

Hay tres ejes disponibles: x, y y z. El eje z sólo es visible cuando el gráfico es un gráfico 3D.


AxisScale (Propiedad)

Devuelve una referencia a un objeto AxisScale que describe cómo se trazan los valores del gráfico en un eje.

Sintaxis

objeto.AxisScale

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.


AxisTitle (Propiedad)

Devuelve una referencia a un objeto AxisTitle asociado con el eje de un gráfico.

Sintaxis

objeto.AxisTitle

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.


Backdrop (Propiedad)

Devuelve una referencia a un objeto Backdrop que describe la sombra, el patrón o el dibujo que está detrás de un gráfico o de un elemento del gráfico.

Sintaxis

objeto.Backdrop

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.


BarGap (Propiedad)

Devuelve o establece el espaciado de las barras de dos dimensiones o de las barras tridimensionales agrupadas dentro de una categoría.

Sintaxis

objeto.BarGap [ = valor ]

La sintaxis de la propiedad BarGap consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
valor | Single. El valor de espaciado de las barras. Se mide como un porcentaje del ancho de la barra. El valor 0 hace que se toquen las barras. El valor 100 significa que el espacio entre las barras es tan ancho como éstas.


BaseHeight (Propiedad)

Devuelve o establece el alto de la base de un gráfico tridimensional, en puntos.

Sintaxis

objeto.BaseHeight [ = alto ]

La sintaxis de la propiedad BaseHeight consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
alto | Single. El alto de la base.


Basis (Propiedad)

Devuelve o establece el tipo de medida que se utiliza para determinar el tamaño del sector en un gráfico.

Sintaxis

objeto.Basis [ = tipo ]

La sintaxis de la propiedad Basis consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
tipo | Una constante VtChPieWeightBasis que identifica el tipo de medida.


Blue (Propiedad)

Devuelve o establece el componente azul del valor RGB del gráfico.

Sintaxis

objeto.Blue [ = b ]

La sintaxis de la propiedad Blue consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
b | Integer. El valor de azul.

Comentarios

RGB especifica la intensidad relativa de rojo, verde y azul para hacer que se muestre un color específico. El intervalo válido de un color RGB va de 0 a 16.777.215. El valor de cualquier argumento de RGB que supere 255 toma el valor 255.


Brush (Propiedad)

Devuelve una referencia a un objeto Brush que describe el tipo de relleno utilizado para mostrar un elemento del gráfico.

Sintaxis

objeto.Brush

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.


Cap (Propiedad)

Devuelve o establece un valor que determina cómo se terminan los finales de línea.

Sintaxis

objeto.Cap [ = tipo ]

La sintaxis de la propiedad Cap consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
tipo | Integer. Una constante VtPenCap que describe el estilo de cierre del lápiz de línea.


CategoryScale (Propiedad)

Devuelve una referencia a un objeto CategoryScale que describe la información de escala para un eje de la categoría correspondiente.

Sintaxis

objeto.CategoryScale

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.


Chart3d (Propiedad)

Devuelve un valor que especifica si un gráfico es tridimensional.

Sintaxis

objeto.Chart3D

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.

Valores devueltos

Valor | Descripción
True | El gráfico es tridimensional.
False | El gráfico no es tridimensional.

Comentarios

Que un carácter sea o no tridimensional depende de los valores de la propiedad ChartType.


ChartData (Propiedad)

Devuelve o establece una matriz que contiene los valores que mostrará el gráfico.

Sintaxis

objeto.ChartData [ = datos ]

La sintaxis de la propiedad ChartData consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
datos | Variant. Una matriz de dos dimensiones que almacena los datos utilizados para dibujar el gráfico.

Comentarios

Si la primera serie de una matriz multidimensional contiene cadenas, éstas serán las etiquetas del gráfico.

ChartData es la propiedad predeterminada del control MSChart.


Ejemplo de la propiedad ChartData

El ejemplo siguiente utiliza una matriz de Visual Basic para cargar directamente la cuadrícula de datos del gráfico. Para probar el ejemplo, dibuje un control MSChart en un formulario, pegue el código dentro del módulo de código del objeto Form y ejecute el proyecto.

Option Explicit
Option Base 1

Private Sub Form_Load()
  Dim arrData(3, 1 To 3)
  arrData(1, 1) = "Ene"   ' Establece las etiquetas en la primera serie.
  arrData(2, 1) = "Feb"
  arrData(3, 1) = "Mar"

  arrData(1, 2) = 8
  arrData(2, 2) = 4
  arrData(3, 2) = 0.3

  arrData(1, 3) = 0.2
  arrData(2, 3) = 3
  arrData(3, 3) = 6.3
  MSChart1.ChartData = arrData
End Sub

En este ejemplo, se ha declarado el límite del subíndice inferior como 1 mediante la instrucción OptionBase 1, en vez del valor predeterminado 0. Se utiliza una matriz de tipo Variant donde los valores de la primera serie son variables de cadena y los valores de la segunda y la tercera serie están establecidos a valores numéricos. Esto permite asignar simultáneamente las etiquetas y los datos del gráfico. Observe que también es posible declarar la matriz como tipo String, siempre y cuando la segunda y la tercera serie contengan valores numéricos. Si sólo desea establecer los datos del gráfico, la matriz puede ser de los tipos numéricos Integer, Long, Single o Double. Observe que de este modo las etiquetas del gráfico existentes se reemplazarán por etiquetas predeterminadas de fila y columna. Además, una matriz de una dimensión funcionará tan bien como una de dos dimensiones, siempre y cuando los últimos valores sean numéricos o representaciones de texto de valores numéricos.

El ejemplo siguiente devuelve datos del gráfico. El ejemplo contiene un bucle para imprimir la matriz devuelta desde el gráfico. Observe la utilización de las funciones Lbound y Ubound para determinar los límites de la matriz del gráfico. Para probar el ejemplo, dibuje un control CommandButton en un formulario con un control MSChart. Pegue el código en el módulo de código, ejecute el proyecto y haga clic en el botón.

Option Explicit
Private Sub Command1_Click()
   Dim y() As Variant
   Dim i, j As Integer
y = MSChart1.ChartData
For i = LBound(y,2) To UBound(y,2)
      Debug.Print
      For j = LBound(y, 1) To UBound(y, 1)
         Debug.Print y(j, i)
      Next j
   Next i
End Sub

El valor del límite inferior de la matriz devuelta es 0. La matriz devuelta será siempre una matriz de dos dimensiones de tipo Variant. Dado que ChartData es la propiedad predeterminada del gráfico, puede reemplazarse el nombre del objeto, por ejemplo MSChart1, por MSChart1.ChartData. Por tanto, podría usar MSChart1 = datos o datos = MSChart1.


ChartType (Propiedad)

Devuelve o establece el tipo de gráfico que se utiliza para mostrar un gráfico.

Sintaxis

objeto.ChartType [ = tipo ]

La sintaxis de la propiedad ChartType consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
tipo | Integer. Una constante VtChChartType que describe el tipo de gráfico.


Clockwise (Propiedad)

Devuelve o establece un valor que especifica si los gráficos circulares se dibujarán en el sentido de las agujas del reloj.

Sintaxis

objeto.Clockwise [ = booleano ]

La sintaxis de la propiedad Clockwise consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
booleano | Una expresión booleana que controla la dirección utilizada para dibujar los gráficos circulares, como se describe en Valores.

Valores

Los valores de booleano son:

Valor | Descripción
True | (Predeterminado) Los gráficos circulares se dibujan en el sentido de las agujas del reloj.
False | Los gráficos se dibujan en sentido contrario al de las agujas del reloj.


ColumnCount (Propiedad)

Devuelve o establece el número de columnas de la cuadrícula actual de datos asociada a un gráfico.

Sintaxis

objeto.ColumnCount [ = número ]

La sintaxis de la propiedad ColumnCount consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
número | El número de columnas de datos.


ColumnLabelCount (Propiedad)

Devuelve o establece el número de niveles de etiqueta de las columnas de una cuadrícula de datos asociada a un gráfico.

Sintaxis

objeto.ColumnLabelCount [ = número ]

La sintaxis de la propiedad ColumnLabelCount consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
número | Integer. El número de niveles de etiqueta de las columnas. Establezca esta propiedad para agregar o eliminar niveles de etiqueta de las columnas de una cuadrícula de datos.

Comentarios

Los niveles de etiquetas de las columnas se numeran de abajo a arriba, a partir de 1 y se agregan o se restan desde arriba.


ColumnLabelIndex (Propiedad)

Devuelve o establece un nivel específico de las etiquetas de columna asociadas a un gráfico.

Sintaxis

objeto.ColumnLabelIndex [ = índice ]

La sintaxis de la propiedad ColumnLabelIndex consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
índice | Integer. Identifica un nivel de etiquetas de columna.

Comentarios

Para establecer una etiqueta en una columna con más de un nivel de etiquetas o para devolver el valor actual de una etiqueta, primero deberá identificar el nivel que desea. Los niveles de las etiquetas de columnas se numeran de abajo a arriba, a partir de 1.


ColumnLabel (Propiedad, control MSChart)

Devuelve o establece el texto de etiqueta asociado a una columna de la cuadrícula de datos de un gráfico.

Sintaxis

objeto.ColumnLabel [ = texto ]

La sintaxis de la propiedad ColumnLabel consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
texto | String. El texto de etiqueta que se asocia a una columna de la cuadrícula de datos.

Comentarios

Esta propiedad establece la etiqueta de la columna que identifica la propiedad Column.


ColumnLabel (Propiedad, objeto DataGrid)

Devuelve o establece la etiqueta de una columna de datos de la cuadrícula asociada a un gráfico.

Sintaxis

objeto.ColumnLabel (column, labelIndex) [ = texto ]

La sintaxis de la propiedad ColumnLabel consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
column | Integer. Identifica una columna de datos específica. Las columnas se numeran de izquierda a derecha, a partir de 1. Las columnas que contienen etiquetas no se cuentan como columnas de datos.
labelIndex | Integer. Identifica una etiqueta específica. Si hay más de un nivel de etiquetas de columna en una columna, deberá identificar una de ellas. Las etiquetas de columnas se numeran de abajo a arriba, a partir de 1.
texto | String. El texto de la etiqueta de columna.


Ejemplo de la propiedad ColumnLabel

El ejemplo agrega tres etiquetas de columna al eje z de un gráfico. Para probar el ejemplo, dibuje un control MSChart en un formulario. Pegue el código dentro del módulo de código del objeto Form y ejecute el proyecto. Haga clic en el formulairo para ver las etiquetas.

Option Explicit
Option Base 1

Private Sub Form_Click()
   With MSChart1
      .chartType = VtChChartType3dLine

      .Plot.Axis(VtChAxisIdZ).Labels(1).VtFont.Size = 24
      .DataGrid.ColumnLabel(1, 1) = "Etiqueta Z1"
      .DataGrid.ColumnLabel(2, 1) = "Etiqueta Z2"
      .DataGrid.ColumnLabel(3, 1) = "Etiqueta Z3"
   End With
End Sub

Private Sub Form_Load()
   ' La primera serie contiene etiquetas para el eje X.
   Dim arrData(4, 1 To 4)
   arrData(1, 1) = "Ene"
   arrData(2, 1) = "Feb"
   arrData(3, 1) = "Mar"
   arrData(4, 1) = "Abr"

   arrData(1, 2) = 8
   arrData(2, 2) = 4
   arrData(3, 2) = 0.3
   arrData(4, 2) = 3

   arrData(1, 3) = 0.2
   arrData(2, 3) = 3
   arrData(3, 3) = 6.3
   arrData(4, 3) = 2

   arrData(1, 4) = 5
   arrData(2, 4) = 7
   arrData(3, 4) = 2
   arrData(4, 4) = 9
   MSChart1.ChartData = arrData
End Sub


Column (Propiedad, control MSChart)

Devuelve o establece la columna actual de datos en la cuadrícula de datos.

Sintaxis

objeto.Column [ = col ]

La sintaxis de la propiedad Column consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
col | Integer. La columna actual de datos.

Comentarios

Debe seleccionar una columna antes de poder usar otras propiedades para modificar las series gráficas correspondientes de la columna o cualquier punto de datos de las series.


Component (Propiedad)

Devuelve o establece el tipo de etiqueta que se usará para identificar el punto de datos.

Sintaxis

objeto.Component [ = tipo ]

La sintaxis de la propiedad Component consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
tipo | Integer. Una constante VtChLabelComponent que identifica el tipo de etiqueta.


CompositeColumnLabel (Propiedad)

Devuelve la cadena de la etiqueta de nivel múltiple que identifica una columna de la cuadrícula de datos asociada a un gráfico.

Sintaxis

objeto.CompositeColumnLabel (column)

La sintaxis de la propiedad CompositeColumnLabel consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
column | Integer. Identifica una columna de datos específica. Las columnas se numeran de izquierda a derecha, a partir de 1. Las columnas que contienen etiquetas no se cuentan como columnas de datos.


CompositeRowLabel (Propiedad)

Devuelve la cadena de la etiqueta de nivel múltiple que identifica una fila de la cuadrícula de datos asociada a un gráfico.

Sintaxis

objeto.CompositeRowLabel (row)

La sintaxis de la propiedad CompositeRowLabel consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
row | Integer. Identifica una fila de datos específica. Las filas se numeran de arriba a abajo, a partir de 1. Las filas que contienen etiquetas no se cuentan como filas de datos.


Custom (Propiedad)

Devuelve o establece un valor que determina si se utiliza texto personalizado para colocar una etiqueta en un punto de datos del gráfico.

Sintaxis

objeto.Custom [ = booleano ]

La sintaxis de la propiedad Custom consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
booleano | Una expresión booleana que especifica si se utiliza texto personalizado, como se describe en Valores.

Valores

Los valores de booleano son:

Valor | Descripción
True | La etiqueta contiene texto personalizado.
False | (Predeterminado) Se utiliza la información especificada por la propiedad Components del objeto DataPointLabel para colocar una etiqueta en el punto de datos.


DataGrid (Propiedad)

Devuelve una referencia a un objeto DataGrid que describe la cuadrícula de datos asociada a un gráfico.

Sintaxis

objeto.DataGrid

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.


DataPointLabel (Propiedad)

Devuelve una referencia a un objeto DataPointLabel que describe una etiqueta de un punto de datos individual del gráfico.

Sintaxis

objeto.DataPointLabel

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.


DataPoints (Propiedad)

Devuelve una referencia a una colección DataPoint que describe los puntos de datos de una serie del gráfico.

Sintaxis

objeto.DataPoints

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.


Data (Propiedad, control MSChart)

Devuelve o establece un valor que está insertado en el punto de datos actual de la cuadrícula de datos de un gráfico.

Sintaxis

objeto.Data [ = valor ]

La sintaxis de la propiedad Data consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
valor | Integer. El valor del punto de datos.

Comentarios

Si el punto de actual ya contiene un valor, éste se reemplaza por el nuevo valor. Se vuelve a dibujar datos el gráfico para reflejar el nuevo valor del punto de datos actual.


DataSeriesInRow (Propiedad)

Devuelve o establece un valor que indica si los datos de la serie se leen desde una fila o desde una columna de una cuadrícula de datos asociada a un gráfico.

Sintaxis

objeto.DataSeriesInRow [ = booleano ]

La sintaxis de la propiedad DataSeriesInRow consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
booleano | Una expresión booleana que controla cómo se leen los datos de la serie, como se describe en Valores.

Valores

Los valores de booleano son:

Valor | Descripción
True | Los datos de la serie se leen desde una fila de una cuadrícula de datos.
False | (Predeterminado) Los datos de la serie se leen desde una columna.


DefaultPercentBasis (Propiedad)

Devuelve la base del porcentaje predeterminado del eje para el gráfico.

Sintaxis

objeto.DefaultPercentBasis

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.

Valor devuelto

Es un integer que especifica la base del porcentaje predeterminado del eje. Los valores devueltos posibles son constantes VtChPercentAxisBasis.


DepthToHeightRatio (Propiedad)

Devuelve o establece el porcentaje del alto del gráfico que se usará como profundidad del gráfico.

Sintaxis

objeto.DepthToHeightRatio [ = pctaje ]

La sintaxis de la propiedad DepthToHeightRatio consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
pctaje | Single. El porcentaje del alto del gráfico.

Comentarios

Esta propiedad sólo afecta a tipos de gráficos tridimensionales.


DivisionsPerLabel (Propiedad)

Devuelve o establece el número de divisiones que saltar entre etiquetas.

Sintaxis

objeto.DivisionsPerLabel [ = número ]

La sintaxis de la propiedad DivisionsPerLabel consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
número | Integer. Un entero que representa el número de divisiones.

Comentarios

Si se establece esta propiedad, la propiedad Auto del objeto se establece automáticamente a False.


DivisionsPerTick (Propiedad)

Devuelve o establece el número de divisiones que saltar entre las marcas principales.

Sintaxis

objeto.DivisionsPerTick [ = número ]

La sintaxis de la propiedad DivisionsPerTick consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
número | Integer. Un entero que representa el número de divisiones.

Comentarios

Si se establece esta propiedad, la propiedad Auto del objeto se establece automáticamente a False.


DoSetCursor (Propiedad)

Devuelve o establece un valor que indica si un gráfico puede configurar el cursor. La propiedad DoSetCursor determina si la aplicación puede controlar la apariencia del puntero del mouse (ratón).

Sintaxis

objeto.DoSetCursor [ = booleano ]

La sintaxis de la propiedad DoSetCursor consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
booleano | Una expresión booleana que especifica si se utiliza texto personalizado, como se describe en Valores.

Valores

Los valores de booleano son:

Valor | Descripción
True | (Predeterminado) La aplicación puede controlar la apariencia del puntero del mouse.
False | La aplicación no puede controlar la apariencia del puntero del mouse.


DrawMode (Propiedad, MSChart)

Devuelve o establece un valor que determina cuándo y cómo se volverá a dibujar un gráfico.

Sintaxis

objeto.DrawMode [ = modo ]

La sintaxis de la propiedad DrawMode consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
modo | Integer. Valor que determina cómo y cuándo se volverá a dibujar el gráfico, como se muestra en Valores.

Valores

Los valores de modo son:

Constante | Valor | Descripción
VtChDrawModeDraw | 0 | El gráfico se dibuja directamente en el dispositivo de pantalla.
VtChDrawModeBlit | 1 | Ajusta un dibujo mayor que la pantalla en el dispositivo de presentación.


EdgeIntensity (Propiedad)

Devuelve o establece la intensidad de la luz utilizada para dibujar los bordes de los objetos en un gráfico tridimensional.

Sintaxis

objeto.EdgeIntensity [ = intBorde ]

La sintaxis de la propiedad EdgeIntensity consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
intBorde | Single. Intensidad de la luz del borde. Los valores válidos van de 0 a 1. Una intensidad de 0 apaga los bordes y los dibuja como líneas negras; una intensidad de 1 ilumina totalmente los bordes con el color del lápiz del elemento.

Comentarios

Si se establece esta propiedad, la propiedad EdgeVisible del objeto Light se establece automáticamente a True.


EdgePen (Propiedad)

Devuelve el objeto Pen utilizado para dibujar el borde del punto de datos en un gráfico.

Sintaxis

objeto.EdgePen

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.


EdgeVisible (Propiedad)

Devuelve o establece un valor que determina si se mostrarán los bordes de los elementos de un gráfico tridimensional.

Sintaxis

objeto.EdgeVisible [ = booleano ]

La sintaxis de la propiedad EdgeVisible consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
booleano | Una expresión booleana que especifica si se mostrarán los bordes, como se describe en Valores.

Valores

Los valores de booleano son:

Valor | Descripción
True | Los bordes son visibles.
False | No se muestran los bordes de los elementos del gráfico tridimensional.


Effect (Propiedad)

Devuelve o establece los efectos de fuente de un gráfico.

Sintaxis

objeto.Effect [ = efectos ]

La sintaxis de la propiedad Effect consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
efectos | Integer. Una constante VtFontEffect que describe el efecto de la fuente.


Elevation (Propiedad)

Devuelve o establece un valor que describe el grado de elevación desde el que se ve un gráfico tridimensional.

Sintaxis

objeto.Elevation [ = grado ]

La sintaxis de la propiedad Elevation consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
grado Single. El grado de elevación.

La elevación es un número que va de 0 a 90 grados. Si establece la elevación a 90 grados, el gráfico se verá directamente desde arriba. Si establece la elevación a 0, el gráfico se verá desde un lado. La elevación predeterminada es de 30 grados. De forma predeterminada, se utilizan grados para medir la elevación. Sin embargo, estos valores utilizan la configuración actual de la propiedad AngleUnit. Las otras opciones son grados centesimales y radianes.


Excluded (Propiedad)

Devuelve o establece un valor que determina si una serie se incluye en el gráfico.

Sintaxis

objeto.Excluded [ = booleano ]

La sintaxis de la propiedad Excluded consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
booleano | Una expresión booleana que controla si una serie se incluye en el gráfico, como se describe en Valores.

Valores

Los valores de booleano son:

Valor | Descripción
True | El gráfico se dibuja sin incluir la serie.
False | (Predeterminado) La serie se incluye cuando se dibuja el gráfico. Es posible que haya una serie incluida en un gráfico, pero no se muestre todavía porque esté oculta (Hidden).


FillColor (Propiedad)

Devuelve una referencia a un objeto VtColor que describe el color utilizado para rellenar un elemento del gráfico.

Sintaxis

objeto.FillColor

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.

Comentarios

Si está establecida la propiedad FillColor del objeto Marker, la propiedad Visible del objeto Marker se establece automáticamente a True.


Fill (Propiedad)

Devuelve una referencia a un objeto Fill que describe el tipo y la apariencia del fondo de un objeto del gráfico.

Sintaxis

objeto.Fill

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.


Flag (Propiedad)

Devuelve o establece qué líneas de estadísticas se mostrarán para una serie .

Sintaxis

objeto.Flag [ = líneas ]

La sintaxis de la propiedad Flag consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
líneas | Integer. Una constante VtChStats que se utiliza para describir la línea de estadísticas. Si se muestra más de una línea de estadísticas, las constantes se combinan con un operador OR.


Font (Propiedad, control MSChart)

Devuelve una referencia a un objeto Font estándar que describe la fuente utilizada para mostrar texto en el gráfico.

Sintaxis

objeto.Font

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.


Footnote (Propiedad)

Devuelve una referencia a un objeto Footnote que proporciona información acerca del texto de descripción utilizado para realizar anotaciones en un gráfico.

Sintaxis

objeto.Footnote

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.


FootnoteText (Propiedad)

Devuelve o establece el texto utilizado como nota a pie de página.

Sintaxis

objeto.FootnoteText [ = texto ]

La sintaxis de la propiedad FootnoteText consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
texto | String. El texto de la nota a pie de página.

Comentarios

Se puede conseguir el mismo resultado con la propiedad Text del objeto Footnote.


FormatLength (Propiedad)

Devuelve la longitud de la cadena de formato.

Sintaxis

objeto.FormatLength

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.

Valor devuelto

Un entero


Format (Propiedad, objeto Label)

Devuelve o establece los caracteres que definen el formato utilizado para mostrar la etiqueta del eje.

Sintaxis

objeto.Format [ = formato ]

La sintaxis de la propiedad Format consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
formato | String. Define el formato utilizado para mostrar la etiqueta del eje.


FrameColor (Propiedad)

Devuelve una referencia a un objeto VtColor que especifica el color utilizado para enmarcar un elemento del gráfico.

Sintaxis

objeto.FrameColor

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.


Frame (Propiedad)

Devuelve una referencia a un objeto Frame que describe la apariencia del marco que hay alrededor de un elemento del gráfico.

Sintaxis

objeto.Frame

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.


Green (Propiedad)

Devuelve o establece el componente verde del valor RGB del gráfico.

Sintaxis

objeto.Green [ = g ]

La sintaxis de la propiedad Green consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
g | Integer. El valor de verde.

Comentarios

RGB especifica la intensidad relativa de rojo, verde y azul para hacer que se muestre un color específico. El intervalo válido de un color RGB va de 0 a 16.777.215. El color de cualquier argumento de RGB que supere 255 toma el valor 255.


GuidelinePen (Propiedad)

Devuelve una referencia a un objeto Pen que describe el patrón de línea y el color utilizados para mostrar las líneas de guía.

Sintaxis

objeto.GuidelinePen

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.

Comentarios

Establecer esta propiedad hace que la propiedad ShowGuideLines se establezca automáticamente a True.


Hidden (Propiedad, control MSChart)

Devuelve o establece un valor que determina si se muestra una serie en el gráfico.

Sintaxis

objeto.Hidden [ = booleano ]

La sintaxis de la propiedad Hidden consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
booleano | Una expresión booleana que controla si una serie se muestra en el gráfico, como se describe en Valores.

Valores

Los valores de booleano son:

Valor | Descripción
True | El gráfico se dibuja sin mostrar la serie. Sin embargo, se mantiene el espacio asignado para la serie.
False | (Predeterminado) Se muestra la serie.


Hide (Propiedad)

Devuelve o establece un valor que determina si los ejes de un gráfico están ocultos.

Sintaxis

objeto.Hide [ = booleano]

La sintaxis de la propiedad Hide consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
booleano | Una expresión booleana que especifica si los ejes están ocultos, como se describe en Valores.

Valores

Los valores de booleano son:

Valor | Descripción
True | La escala, líneas, marcas y título de los ejes están ocultos.
False | (Predeterminado) Se muestran los ejes en el gráfico.


HorzAlignment (Propiedad)

Devuelve o establece el método de alineación horizontal del texto.

Sintaxis

objeto.HorzAlignment [ = tipo ]

La sintaxis de la propiedad HorzAlignment consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
tipo | Integer. Una constante VtHorizontalAlignment que se utiliza para describir el método de alineación horizontal del texto.


Index (Propiedad, objeto Brush)

Devuelve o establece el patrón o trama utilizada en el pincel si su propiedad Style se establece a VtBrushStylePattern o a VtBrushStyleHatch.

Sintaxis

objeto.Index [ = número ]

La sintaxis de la propiedad Index consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
número | Una constante VtBrushPattern o una constante VtBrushHatch que describe el patrón del pincel.


Index (Propiedad, objeto Intersection)

Devuelve el eje que se cruza con otro eje cuando hay más de un eje con el mismo índice.

Sintaxis

objeto.Index

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.

Valor devuelto

El valor devuelto es un entero que especifica el índice del eje de intersección. Actualmente, el único valor válido para este argumento es 1.


Intensity (Propiedad)

Devuelve o establece la fuerza de la luz procedente del origen de luz.

Sintaxis

objeto.Intensity [ = fuerza ]

La sintaxis de la propiedad Intensity consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
fuerza | Single. Fuerza de la luz. Si se establece la intensidad a un cien por cien (1), se iluminan totalmente las superficies del gráfico que estén frente a la fuente de luz. Si se establece la luz al 50 por ciento (.5), estas superficies recibirán el 50 por ciento de iluminación de ese origen de luz. El intervalo válido va de 0 a 1.

Comentarios

Intensity es la propiedad predeterminada del objeto LightSource.


Intersection (Propiedad)

Devuelve una referencia a un objeto Intersection que describe el punto en que un eje se cruza con otro eje del gráfico.

Sintaxis

objeto.Intersection

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.


Item (Propiedad, control MSChart)

Devuelve una referencia a un objeto de una colección que describe un elemento de un gráfico.

Sintaxis

objeto.Item (index)

La sintaxis de la propiedad Item consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
index | Un entero único que identifica el miembro de la colección.


Join (Propiedad)

Devuelve o establece un valor que determina cómo se forman los segmentos de línea.

Sintaxis

objeto.Join [ = tipo ]

La sintaxis de la propiedad Join consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
tipo | Integer. Una constante VtPenJoin que describe el estilo de combinación del lápiz.


LabelLevelCount (Propiedad)

Devuelve el número de niveles de etiquetas para un eje determinado. No está disponible en tiempo de diseño.

Sintaxis

objeto.LabelLevelCount [ = número ]

La sintaxis de la propiedad LabelLevelCount consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
número | Integer. Un entero que describe el número de etiquetas.


LabelsInsidePlot (Propiedad)

Devuelve o establece un valor que determina si las etiquetas del eje se dejarán en la ubicación normal o si se las moverá con el eje al nuevo punto de intersección.

Sintaxis

objeto.LabelsInsidePlot [= booleano ]

La sintaxis de la propiedad LabelsInsidePlot consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
booleano | Una expresión booleana que especifica dónde se mostrarán las etiquetas del eje, como se describe en Valores.

Valores

Los valores de booleano son:

Valor | Descripción
True | (Predeterminado) Las etiquetas del eje permanecen en la ubicación normal.
False | Las etiquetas se mueven dentro del trazado al nuevo punto de intersección.

Comentarios

Al establecer esta propiedad, la propiedad Auto del objeto Intersection se establece automáticamente a False.


Labels (Propiedad)

Devuelve una referencia a una colección Labels que describe las etiquetas en un eje del gráfico.

Sintaxis

objeto.Labels

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.


LabelTick (Propiedad)

Devuelve o establece un valor que indica si las etiquetas de categoría de ejes están centradas en una marca del eje.

Sintaxis

objeto.LabelTick [ = booleano ]

La sintaxis de la propiedad LabelTick consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
booleano | Una expresión booleana que especifica si se muestra el elemento, como se describe en Valores.

Valores

Los valores de booleano son:

Valor | Descripción
True | Las etiquetas se centran en una marca.
False | (Predeterminado) Las etiquetas se centran entre dos marcas.

Comentarios

Si se establece esta propiedad, la propiedad Auto del objeto se establece automáticamente a False.


Legend (Propiedad)

Devuelve una referencia a un objeto Legend que contiene información acerca de la apariencia y el comportamiento de la clave gráfica y el texto adjunto que describe la serie del gráfico.

Sintaxis

objeto.Legend

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.


LegendText (Propiedad)

Devuelve o establece el texto que identifica la serie en la leyenda de un gráfico.

Sintaxis

objeto.LegendText [ = texto ]

La sintaxis de la propiedad LegendText consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
texto | String. El texto que identifica la serie actual en la leyenda.

Comentarios

De forma predeterminada, este texto es el mismo que el de la propiedad Text del objeto ColumnLabel.


Length (Propiedad, control MSChart)

Devuelve o establece la longitud de las marcas del eje, medida en puntos.

Sintaxis

objeto.Length [ = longitud ]

La sintaxis de la propiedad Length consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
longitud | Integer. La longitud de la marca del eje.


Light (Propiedad)

Devuelve una referencia a un objeto Light que proporciona información acerca de la luz que ilumina un gráfico tridimensional.

Sintaxis

objeto.Light

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.


LightSources (Propiedad)

Devuelve una referencia a una colección LightSources que describe todos los orígenes de luz utilizadosn para iluminar un gráfico tridimensional.

Sintaxis

objeto.LightSources

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.


Limit (Propiedad)

Devuelve o establece el límite de combinación de la línea, en puntos.

Sintaxis

objeto.Limit [ = combinación ]

La sintaxis de la propiedad Limit consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
combinación | Single. Un límite de combinación es un múltiplo del ancho de la línea. Si dos líneas se encuentran en un ángulo marcado, el resultado es una combinación en ángulo en un punto de la esquina que se extiende más allá de la esquina real. Si la distancia del punto de combinación interno al externo supera el valor de esta variable, la combinación cambia automáticamente a biselada.


LineStyle (Propiedad, objeto DataPointLabel)

Devuelve o establece el tipo de línea utilizado para conectar un punto de datos a una etiqueta del gráfico.

Sintaxis

objeto.LineStyle [ = tipo ]

La sintaxis de la propiedad LineStyle consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
tipo | Integer. Una constante VtChLabelLineStyle que identifica la línea de conexión.


Location (Propiedad)

Devuelve una referencia a un objeto Location que describe la ubicación de los elementos de texto del gráfico.

Sintaxis

objeto.Location

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.


LocationRect (Propiedad)

Devuelve una referencia a un objeto Rect que especifica la ubicación del trazado del gráfico mediante las coordenadas x e y.

Sintaxis

objeto.LocationRect

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.

Comentarios

Si la propiedad AutoLayout es False, se utilizan los valores de esta propiedad para colocar el trazado.

Si se establece esta propiedad, la propiedad AutoLayout se establece automáticamente a False.


LocationType (Propiedad)

Devuelve o establece la ubicación estándar que se utiliza para mostrar un elemento del gráfico.

Sintaxis

objeto.LocationType [ = tipo ]

La sintaxis de la propiedad LocationType consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
tipo Integer. En el objeto DataPointLabel, es una constante VtChLabelLocationType que identifica la ubicación de la etiqueta.

En el objeto Location, es una constante VtChLocationType que describe la ubicación del texto.


LogBase (Propiedad)

Devuelve o establece la base logarítmica que se usa para trazar los valores del gráfico en unos ejes logarítmicos.

Sintaxis

objeto.LogBase [ = base]

La sintaxis de la propiedad LogBase consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
base | Integer. Un entero que identifica la base logarítmica. La base predeterminada es 10. El intervalo válido es un valor comprendido entre 2 y 100.

Comentarios

Esta propiedad sólo es efectiva cuando la propiedad Type se establece a VtChScaleTypeLogarithmic.


MajorDivision (Propiedad)

Devuelve o establece el número de divisiones principales que se muestran en el eje.

Sintaxis

objeto.MajorDivision [ = número ]

La sintaxis de la propiedad MajorDivision consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
número | Integer. El número de divisiones.

Comentarios

Si se establece esta propiedad, la propiedad Auto del objeto ValueScale se establece automáticamente a False.


MajorPen (Propiedad)

Devuelve una referencia a un objeto Pen que describe la apariencia de las líneas principales en la cuadrícula del eje.

Sintaxis

objeto.MajorPen

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.


Marker (Propiedad)

Devuelve una referencia a un objeto Marker que describe el icono utilizado para identificar un punto de datos en un gráfico.

Sintaxis

objeto.Marker

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.


Maximum (Propiedad)

Devuelve o establece el valor mayor o final del eje de valor del gráfico.

Sintaxis

objeto.Maximum [ = valor ]

La sintaxis de la propiedad Maximum consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
valor | Double. El valor mayor del eje.

Comentarios

Si se establece esta propiedad, la propiedad Auto del objeto ValueScale se establece automáticamente a False.

Se debe establecer la propiedad Maximum antes de establecer la propiedad Minimum para evitar un error de vista del gráfico.


Max (Propiedad, control MSChart)

Devuelve una referencia a un objeto Coor que especifica la esquina final de un rectángulo.

Sintaxis

objeto.Max

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.


Minimum (Propiedad)

Devuelve o establece el valor menor o inicial del eje de valor del gráfico.

Sintaxis

objeto.Minimum [ = valor ]

La sintaxis de la propiedad Minimum consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
valor | Double. El valor menor del eje.

Comentarios

Si se establece esta propiedad, la propiedad Auto del objeto ValueScale se establece automáticamente a False.

Se debe establecer la propiedad Maximum antes de establecer la propiedad Minimum para evitar un error de vista del gráfico.


MinorDivision (Propiedad)

Devuelve o establece el número de divisiones secundarias que se muestran en el eje.

Sintaxis

objeto.MinorDivision [ = número ]

La sintaxis de la propiedad MinorDivision consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
número | Integer. El número de divisiones secundarias.

Comentarios

Si se establece esta propiedad, la propiedad Auto del objeto ValueScale se establece automáticamente a False.


MinorPen (Propiedad)

Devuelve una referencia a un objeto Pen que describe la apariencia de las líneas secundarias en la cuadrícula del eje.

Sintaxis

objeto.MinorPen

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.


Min (Propiedad, control MSChart)

Devuelve una referencia a un objeto Coor que especifica la esquina inicial de un rectángulo.

Sintaxis

objeto.Min

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.


MousePointer (Propiedad, control MSChart)

Devuelve o establece un valor que indica el tipo de puntero del mouse (ratón) que se muestra cuando éste está en una parte determinada de un objeto en tiempo de ejecución.

Sintaxis

objeto.MousePointer [ = valor ]

La sintaxis de la propiedad MousePointer consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
valor | Integer. Una constante VtMousePointer que especifica el tipo de puntero del mouse que se muestra.


Name (Propiedad, objeto VtFont)

Devuelve o establece el nombre de la fuente. Es la propiedad predeterminada del objeto VtFont.

Sintaxis

objeto.Name [ = texto ]

La sintaxis de la propiedad Name consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
texto | Integer. El texto que contiene el nombre de la fuente.


Offset (Propiedad)

Devuelve o establece la distancia a la que se desplazará o se alejará un elemento del gráfico desde su ubicación predeterminada.

Sintaxis

objeto.Offset [ = desplazamiento ]

La sintaxis de la propiedad Offset consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
desplazamiento En el objeto DataPoint, es un entero que describe la distancia de desplazamiento. El desplazamiento se mide en pulgadas o centímetros, según la configuración predeterminada de Windows.

En los objetos DataPointLabel y Shadow, es una referencia a un objeto Coor que describe los valores x e y del desplazamiento.

Comentarios

En el objeto DataPointLabel, esta propiedad indica la distancia a la que una etiqueta de un punto de datos se desplaza o se aleja desde una de las posiciones de etiqueta predefinidas (estándar). El desplazamiento se agrega a la ubicación calculada para el punto según el valor de la propiedad LocationType del objeto DataPointLabel.


Order (Propiedad)

Devuelve o establece la ubicación de la serie en el gráfico. Si la ubicación en el orden coincide con la de otra serie, las series se apilan.

Sintaxis

objeto.Order [ = orden ]

La sintaxis de la propiedad Order consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
orden | Integer. El orden de ubicación.


Orientation (Propiedad, control MSChart)

Devuelve o establece el método de orientación del texto.

Sintaxis

objeto.Orientation [ = tipo ]

La sintaxis de la propiedad Orientation consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
tipo | Integer. Una constante VtOrientation que se utiliza para describir el método de orientación.


PatternColor (Propiedad)

Devuelve una referencia a un objeto VtColor que describe el color del patrón utilizado para rellenar un elemento del gráfico.

Sintaxis

objeto.PatternColor

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.


Pen (Propiedad)

Devuelve o establece una referencia a un objeto Pen que describe el color y el patrón de las líneas o bordes de los elementos del gráfico.

Sintaxis

objeto.Pen

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.


PercentBasis (Propiedad)

Devuelve o establece el tipo de porcentaje que se usa para trazar los valores del gráfico en un eje de porcentaje.

Sintaxis

objeto.PercentBasis [ = tipo ]

La sintaxis de la propiedad PercentBasis consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
tipo | Una constante VtChPercentAxisBasis que se utiliza para describir el porcentaje usado para trazar los valores del eje de porcentaje.

Comentarios

Esta propiedad sólo es efectiva cuando la propiedad Type se establece a VtChScaleTypePercent.


PercentFormat (Propiedad)

Devuelve o establece una cadena que describe el formato utilizado para mostrar la etiqueta como un porcentaje.

Sintaxis

objeto.PercentFormat [ = formato ]

La sintaxis de la propiedad PercentFormat consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
formato | String. Describe el formato utilizado para mostrar una etiqueta como un porcentaje.

Comentarios

Utilice la propiedad Component del objeto DataPointLabel para modificar el tipo de etiqueta.

En la tabla siguiente se enumeran varios ejemplos de cadenas con formato de porcentaje. Los valores enumerados a la izquierda son los formatos válidos.

 | 3 | -3 | .3
0% | 300% | -300% | 30%
0,0% | 300,0% | -300,0% | 30,0%
0,00% | 300,00% | -300,00% | 30,00%


PlotBase (Propiedad)

Devuelve una referencia a un objeto PlotBase que describe la apariencia del área que está debajo de un gráfico.

Sintaxis

objeto.PlotBase

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.


Plot (Propiedad)

Devuelve una referencia a un objeto Plot que describe el área sobre la que se muestra el gráfico.

Sintaxis

objeto.Plot

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.


Point (Propiedad)

Devuelve o establece el punto en que el eje actual se cruza con otro eje.

Sintaxis

objeto.Point [ = punto ]

La sintaxis de la propiedad Point consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
punto | Double. El punto del eje donde se cruza el eje actual.

Comentarios

Si se establece esta propiedad, la propiedad Auto del objeto Intersection se establece automáticamente a False.


Position (Propiedad, control MSChart)

Devuelve una referencia a un objeto SeriesPosition que describe la ubicación de una serie en relación a las demás series del gráfico.

Sintaxis

objeto.Position

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.


Projection (Propiedad)

Devuelve o establece el tipo de proyección que se utiliza para mostrar el gráfico.

Sintaxis

objeto.Projection [ = tipo ]

La sintaxis de la propiedad Projection consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
tipo | Integer. Una constante VtProjectionType que se utiliza para describir el tipo de proyección del gráfico.

Comentarios

La propiedad Projection determina la apariencia de los gráficos tridimensionales.


Ejemplo de la propiedad Projection

El ejemplo le permite ver los distintos efectos que se pueden obtener al establecer la propiedad Projection. Para probar el ejemplo, dibuje un control MSChart y un control ComboBox en un formulario. Pegue el código en la sección Declarations y presione F5. Haga clic en el ComboBox para ver las distintas configuraciones.

Option Explicit

Private Sub Combo1_Click()
   ' Cambia la proyección al hacer clic.
   MSChart1.Plot.Projection = Combo1.ListIndex
End Sub

Private Sub Form_Load()
   ' Establece el gráfico a tipo 3D.
   MSChart1.chartType = VtChChartType3dBar
   ' Configura el ComboBox agregando las configuraciones válidas.
   With Combo1
      .AddItem "VtProjectionTypePerspective" ' 0
      .AddItem "VtProjectionTypeOblique"     ' 1
      .AddItem "VtProjectionTypeOrthogonal" ' 2
      .AddItem "VtProjectionTypeFrontal"     ' 3
      .AddItem "VtProjectionTypeOverhead"  ' 4
      .ListIndex = 0
   End With
End Sub


RandomFill (Propiedad)

Indica si los datos de la cuadrícula de un gráfico se generaron aleatoriamente.

Sintaxis

objeto.RandomFill [ = booleano ]

La sintaxis de la propiedad RandomFill consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
booleano | Una expresión booleana que controla cómo se generaron los datos, como se describe en Valores.

Valores

Los valores de booleano son:

Valor | Descripción
True | (Predeterminado) Se usaron datos aleatorios para dibujar el gráfico.
False | No se generan datos aleatorios. El usuario proporciona los datos del gráfico.


Rect (Propiedad)

Devuelve una referencia a un objeto Rect que define una ubicación de coordenadas.

Sintaxis

objeto.Rect

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.


Red (Propiedad)

Devuelve o establece el componente rojo del valor RGB del gráfico.

Sintaxis

objeto.Red [ = r ]

La sintaxis de la propiedad Red consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
r | Integer. El valor de rojo.

Comentarios

RGB especifica la intensidad relativa de rojo, verde y azul para hacer que se muestre un color específico. El intervalo válido de un color RGB va de 0 a 16.777.215. El valor de cualquier argumento de RGB que supere 255 toma el valor 255.


Repaint (Propiedad)

Devuelve o establece un valor que determina si el control MSChart se vuelve a dibujar tras producirse una modificación en el gráfico.

Sintaxis

objeto.Repaint [ = booleano ]

La sintaxis de la propiedad Repaint consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
booleano | Una expresión booleana que controla si se vuelve a dibujar el gráfico, como se describe en Valores.

Valores

Los valores de booleano son:

Valor | Descripción
True | (Predeterminado) Actualiza el control.
False | No permite que se vuelva a dibujar el control cuando se modifica el gráfico. Esto es conveniente cuando se llevan a cabo varias operaciones en el gráfico y no desea que el gráfico se esté dibujando continuamente durante el proceso.


Rotation (Propiedad)

Devuelve o establece un valor que describe el grado de rotación desde el que se ve un gráfico tridimensional.

Sintaxis

objeto.Rotation [ = grado ]

La sintaxis de la propiedad Rotation consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
grado Single. El grado de rotación.

El intervalo de rotación va de 0 a 360 grados. De forma predeterminada, se utilizan grados para medir la rotación. Sin embargo, estos valores utilizan la configuración actual de la propiedad AngleUnit. Las otras opciones son grados centesimales y radianes.


RowCount (Propiedad, control MSChart)

Devuelve o establece cuántas filas hay en cada columna de una cuadrícula de datos asociada a un gráfico.

Sintaxis

objeto.RowCount [ = número ]

La sintaxis de la propiedad RowCount consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
número | Integer. El número de filas de una columna.

Comentarios

La cuadrícula virtual de datos está representada por el objeto DataGrid.


RowLabelCount (Propiedad)

Devuelve o establece el número de niveles de etiquetas en las filas de una cuadrícula de datos asociada a un gráfico.

Sintaxis

objeto.RowLabelCount [ = número ]

La sintaxis de la propiedad RowLabelCount consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
número | Integer. El número de niveles de etiquetas. Establezca esta propiedad para agregar o eliminar niveles de etiquetas en las filas de una cuadrícula de datos. Los niveles de etiquetas de filas se numeran de derecha a izquierda, a partir de 1. Los niveles se agregan o se eliminan desde la izquierda.


RowLabelIndex (Propiedad)

Devuelve o establece un valor que especifica un nivel de etiquetas de fila.

Sintaxis

objeto.RowLabelIndex [ = índice ]

La sintaxis de la propiedad RowLabelIndex consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
índice | Integer. Un nivel de etiquetas de filas. Para establecer una etiqueta en una fila con más de un nivel de etiquetas o para devolver el valor actual de una etiqueta, primero debe identificar el nivel que desea. Los niveles de etiquetas de filas se numeran de derecha a izquierda, a partir de 1.


RowLabel (Propiedad, control MSChart)

Devuelve o establece una etiqueta de datos que se puede usar para identificar el punto de datos actual en un gráfico.

Sintaxis

objeto.RowLabel [ = texto ]

La sintaxis de la propiedad RowLabel consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
texto | String. El texto de una etiqueta de fila. La etiqueta especificada establece la etiqueta de los puntos de datos identificados por la propiedad Row. Esta etiqueta aparece a lo largo del eje de categoría en la mayoría de los tipos de gráficos y se utiliza como etiqueta de cada sector individual en un gráfico circular. Es posible que no se muestre el texto de la etiqueta si es demasiado largo para ajustarlo al gráfico.


RowLabel (Propiedad, objeto DataGrid)

Devuelve o establece la etiqueta de una fila específica de la cuadrícula de datos actual asociada a un gráfico.

Sintaxis

objeto.RowLabel (row, labelIndex) [ = texto ]

La sintaxis de la propiedad RowLabel consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
row | Integer. Especifica una fila. Las filas se numeran de arriba a abajo, a partir de 1.
labelIndex | Integer. Especifica un nivel específico de etiquetas de filas. Las etiquetas de filas se numeran de izquierda a derecha, a partir de 1.
texto | String. El texto de la etiqueta de fila.


Row (Propiedad, control MSChart)

Devuelve o establece una fila específica en la columna actual de una cuadrícula de datos asociada a un gráfico.

Sintaxis

objeto.Row [ = número ]

La sintaxis de la propiedad Row consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
número | Integer. El número de la fila en la columna actual. Las filas se numeran de arriba a abajo, a partir de 1.


SecondaryAxis (Propiedad)

Devuelve o establece un valor que determina si la serie se representa en el eje secundario.

Sintaxis

objeto.SecondaryAxis [ = booleano ]

La sintaxis de la propiedad SecondaryAxis consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
booleano | Una expresión booleana que controla si la serie se representa en el eje secundario, como se describe en Valores.

Valores

Los valores de booleano son:

Valor | Descripción
True | La serie se representa en el eje secundario.
False | (Predeterminado) La serie no se representa en el eje secundario.


SeriesCollection (Propiedad)

Devuelve una referencia a una colección SeriesCollection que proporciona información acerca de las series que componen un gráfico.

Sintaxis

objeto.SeriesCollection

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.


SeriesColumn (Propiedad)

Devuelve o establece la ubicación de columna para los datos de la serie actual.

Sintaxis

objeto.SeriesColumn [ = pos ]

La sintaxis de la propiedad SeriesColumn consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
pos | Integer. La ubicación de la columna que contiene los datos de la serie actual. Puede usar esta propiedad para volver a ordenar la serie. Si dos series tienen asignada la misma ubicación, se apilan.


SeriesMarker (Propiedad)

Devuelve una referencia a un objeto SeriesMarker que describe un marcador que identifica todos los puntos de datos en una serie del gráfico.

Sintaxis

objeto.SeriesMarker

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.


SeriesType (Propiedad)

Devuelve o establece el tipo que se utiliza para mostrar la serie actual.

Sintaxis

objeto.SeriesType [ = tipo ]

La sintaxis de la propiedad SeriesType consta de las siguientes partes:

Parte | Descripción
objeto Una expresión de objeto que da como resultado un objeto de la lista
Se aplica a.
tipo | Integer. Una constante VtChSeriesType que describe el método que se utiliza para mostrar la serie. Debe seleccionar la serie que modificar con la propiedad Column antes de usar la propiedad SeriesType.


Shadow (Propiedad)

Devuelve una referencia a un objeto Shadow que describe la apariencia del sombreado en los elementos del gráfico.

Sintaxis

objeto.Shadow

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.


ShowGuideLines (Propiedad)

Devuelve o establece un valor que determina si se muestran para una serie las líneas que conectan los puntos de datos en la serie.

Sintaxis

objeto.ShowGuideLines (axisId, index) [ = booleano ]

La sintaxis de la propiedad ShowGuideLine consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
axisId | Integer. Una constante VtChAxisId que describe el eje de la serie para el que desea establecer esta propiedad.
index | Integer. Un entero reservado para uso futuro. En esta versión del control MSChart, el único valor válido de este argumento es 1.
booleano | Una expresión booleana que controla si la serie se representa en el eje secundario, como se describe en Valores.

Valores

Los valores de booleano son:

Valor | Descripción
True | Se muestran las líneas de guía de la serie.
False | (Predeterminado) No se muestran las líneas de guía de la serie.


ShowLegend (Propiedad)

Devuelve o establece un valor que indica si una leyenda es visible en el gráfico.

Sintaxis

objeto.ShowLegend [ = booleano ]

La sintaxis de la propiedad ShowLegend consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
booleano | Una expresión booleana que controla si se muestra una leyenda en el gráfico, como se describe en Valores.

Valores

Los valores de booleano son:

Valor | Descripción
True | La leyenda aparece en el gráfico en la ubicación indicada por el objeto Location.
False | (Predeterminado) La leyenda no se muestra en el gráfico. La ubicación predeterminada de la leyenda es el lado derecho del gráfico.

Comentarios

La ubicación predeterminada de la leyenda es el lado derecho del gráfico.


ShowLine (Propiedad)

Devuelve o establece un valor que determina si son visibles las líneas que conectan los puntos de datos en un gráfico.

Sintaxis

objeto.ShowLine [ = booleano ]

La sintaxis de la propiedad ShowLine consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
booleano | Una expresión booleana que controla si se muestran las líneas, como se describe en Valores.

Valores

Los valores de booleano son:

Valores | Descripción
True | (Predeterminado) Se muestran en el gráfico las líneas que conectan los puntos de datos.
False | No se muestran las líneas de los puntos de datos.


Show (Propiedad)

Devuelve o establece un valor que determina si se muestran los marcadores de series en un gráfico.

Sintaxis

objeto.Show [ = booleano ]

La sintaxis de la propiedad Show consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
booleano | Una expresión booleana que controla si se muestran los marcadores de series, como se describe en Valores.

Valores

Los valores de booleano son:

Valores | Descripción
True | Se muestran los marcadores de series.
False | (Predeterminado) No se muestran los marcadores de series.


Size (Propiedad, control MSChart)

Devuelve o establece el tamaño de un elemento del gráfico en puntos.

Sintaxis

objeto.Size [ = tamaño ]

La sintaxis de la propiedad Size consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
tamaño | Single. El tamaño del elemento del gráfico en puntos.


Sort (Propiedad, control MSChart)

Devuelve o establece el tipo de orden utilizado en un gráfico circular.

Sintaxis

objeto.Sort [ = tipo ]

La sintaxis de la propiedad Sort consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
tipo | Integer. Una constante VtSortType que se utiliza para describir el orden del gráfico.


SpaceColor (Propiedad)

Devuelve una referencia a un objeto VtColor que especifica el color utilizado para rellenar el espacio entre los marcos dobles alrededor de un elemento del gráfico.

Sintaxis

objeto.SpaceColor

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.


Stacking (Propiedad)

Establece un valor que determina si todas las series del gráfico están apiladas.

Sintaxis

objeto.Stacking [ = booleano ]

La sintaxis de la propiedad Stacking consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
booleano | Una expresión booleana que controla si todas las series del gráfico están apiladas, como se describe en Valores.

Valores

Los valores de booleano son:

Valor | Descripción
True | Todas las series del gráfico están apiladas.
False | (Predeterminado) Las series del gráfico no están apiladas.


StackOrder (Propiedad)

Devuelve o establece la ubicación en que se dibuja la serie actual si está apilada con otra serie.

Sintaxis

objeto.StackOrder [ = ubicación ]

La sintaxis de la propiedad StackOrder consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
ubicación | Integer. El orden de la serie si está apilada con otra serie. Los órdenes inferiores de apilación están en la parte inferior de la pila.


Standing (Propiedad)

Devuelve o establece un valor que especifica si las etiquetas de eje se mostrarán horizontalmente en el plano x o z, o verticalmente en la línea de base del texto en el plano y.

Sintaxis

objeto.Standing [ = booleano ]

La sintaxis de la propiedad Standing consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
booleano | Una expresión booleana que especifica cómo se mostrarán las etiquetas de eje, como se describe en Valores.

Valores

Los valores de booleano son:

Valor | Descripción
True | (Predeterminado) Las etiquetas de eje se muestran verticalmente sobre la línea de base del texto en el plano y.
False | Las etiquetas de eje se muestran horizontalmente en el plano x o z.


StartingAngle (Propiedad)

Devuelve o establece la ubicación en que desea empezar a dibujar los gráficos circulares.

Sintaxis

objeto.StartingAngle [ = ángulo ]

La sintaxis de la propiedad StartingAngle consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
ángulo | Single. Este ángulo se puede medir en grados, radianes o grados centesimales, según el valor actual de AngleUnits . El valor 0 grados indica la ubicación de las tres en punto. Establecer el ángulo de inicio a 90 grados mueve la ubicación de inicio a las doce en punto si la propiedad Clockwise está establecida al sentido contrario de las agujas del reloj, o a las seis en punto si está establecida al sentido de las agujas del reloj. El intervalo válido va de -360 a 360 grados.


StatLine (Propiedad)

Devuelve una referencia a un objeto StatLine que describe cómo se muestran las líneas de estadísticas en el gráfico.

Sintaxis

objeto.StatLine

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.


Style (Propiedad, control MSChart)

Devuelve o establece el estilo utilizado para dibujar determinados elementos del gráfico.

Sintaxis

objeto.Style [ = estilo ]

La sintaxis de la propiedad Style consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
estilo Para el objeto Brush, una constante VtBrushStyle que describe el patrón del pincel.

Para el objeto Fill, una constante VtFillStyle que describe el estilo del relleno. Un relleno puede tener un pincel, que es un color sólido o un relleno con patrón.

Para el objeto Frame, una constante VtFrameStyle que describe el tipo de marco.

Para el objeto Marker, una constante VtMarkerStyle que enumera el tipo de marcador.

Para el objeto Pen, una constante VtPenStyle que describe el estilo del lápiz.

Para el objeto Shadow, una constante VtShadowStyle que se utiliza para describir el tipo de sombra.

Para el objeto Tick, una constante VtChAxisTickStyle que se utiliza para describir la ubicación de la marca en el eje.

Para el objeto VtFont, una constante VtFontStyle que describe el estilo de la fuente.

Para el objeto Weighting, una constante VtChPieWeightStyle que identifica el método del factor de medida.


Style (Propiedad, objeto StatLine)

Devuelve o establece el tipo de línea que se utiliza para mostrar la línea de estadísticas.

Sintaxis

objeto.Style (type)[ = estilo ]

La sintaxis de la propiedad Style consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
type | Integer. Una constante VtChStats que se utiliza para describir el tipo de línea.
estilo | Integer. Una constante VtPenStyle que se utiliza para describir el estilo de la línea de estadísticas.


SubPlotLabelPosition (Propiedad)

Devuelve o establece la ubicación que se utiliza para mostrar una etiqueta en cada gráfico circular.

Sintaxis

objeto.SubPlotLabelPosition [ = pos ]

La sintaxis de la propiedad SubPlotLabelPosition consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
pos | Integer. Una constante VtChSubPlotLabelLocationType que se utiliza para describir la ubicación de la etiqueta del gráfico.


TextLayout (Propiedad)

Devuelve una referencia a un objeto TextLayout que describe la ubicación y la orientación del texto.

Sintaxis

objeto.TextLayout

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.


TextLength (Propiedad)

Devuelve o establece el número de caracteres en el texto del título de un eje del gráfico, una etiqueta de punto de datos, una nota a pie de página o el título del gráfico.

Sintaxis

objeto.TextLength [ = tamaño ]

La sintaxis de la propiedad TextLength consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
tamaño | Integer. Número de caracteres del texto.


TextLengthType (Propiedad)

Devuelve o establece un valor que especifica cómo se dibujará el texto para optimizar su apariencia en la pantalla o en la página impresa.

Sintaxis

objeto.TextLengthType [ = tipo ]

La sintaxis de la propiedad TextLengthType consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
tipo | Integer. Una constante VtTextLengthType que indica el método que se utiliza para dibujar el texto.


Text (Propiedad, control MSChart)

Devuelve o establece el texto que se utiliza para mostrar un elemento de un gráfico como el título de un eje, la etiqueta de un punto de datos, una nota a pie de página o el título del gráfico.

Sintaxis

objeto.Text [ = texto ]

La sintaxis de la propiedad Text consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
texto | String. Una cadena que contiene el texto utilizado para el elemento del gráfico.

Comentarios

La propiedad Text es la propiedad predeterminada para cada uno de los objetos a los que se aplica.


Tick (Propiedad)

Devuelve una referencia a un objeto Tick que describe un marcador que indica una división a lo largo de un eje del gráfico.

Sintaxis

objeto.Tick

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.


Title (Propiedad, control MSChart)

Hace referencia a un objeto Title que describe el texto utilizado para asignar un título a un gráfico.

Sintaxis

objeto.Title

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.


TitleText (Propiedad)

Devuelve o establece el texto que se muestra como el título del gráfico.

Sintaxis

objeto.TitleText [ = texto ]

La sintaxis de la propiedad TitleText consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
texto | El texto que se utiliza para mostrar el título del gráfico.

Comentarios

Esta propiedad proporciona un medio sencillo para establecer o devolver el título del gráfico. Funciona igual que MSChart.Title.Text.


Type (Propiedad, control MSChart)

Devuelve o establece el tipo de escala de un eje.

Sintaxis

objeto.Type [ = tipo ]

La sintaxis de la propiedad Type consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
tipo | Una constante VtChScaleType que describe el tipo de escala del eje.


UniformAxis (Propiedad)

Devuelve o establece un valor que especifica si es uniforme la escala de unidad para todos los valores de los ejes de un gráfico.

Sintaxis

objeto.UniformAxis [ = booleano ]

La sintaxis de la propiedad UniformAxis consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
booleano | Una expresión booleana que controla la escala de unidades, como se describe en Valores.

Valores

Los valores de booleano son:

Valor | Descripción
True | (Predeterminado) La escala de unidades para todos los valores de un eje es uniforme.
False | La escala de unidades no es uniforme. Se determina mediante el tamaño del trazo y el valor de ubicación de las propiedades AutoLayout o LocationRect. Si AutoLayout es True, el tamaño y la ubicación del trazo se basa en el tamaño y ubicación de otros elementos distribuidos automáticamente. Si es False, se utilizan las coordenadas especificadas por la propiedad LocationRect para colocar el trazo y determinar la escala de las unidades del eje.


ValueFormat (Propiedad)

Devuelve o establece el formato que se utiliza para mostrar la etiqueta como un valor.

Sintaxis

objeto.ValueFormat [ = formato ]

La sintaxis de la propiedad ValueFormat consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
formato | String. Describe el formato que se utiliza para mostrar la etiqueta como un valor.

Comentarios

Utilice la propiedad Component del objeto DataPointLabel para modificar el tipo de etiqueta.


ValueScale (Propiedad)

Devuelve una referencia a un objeto ValueScale que describe la escala utilizada para mostrar un eje de valor.

Sintaxis

objeto.ValueScale

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.


VertAlignment (Propiedad)

Devuelve o establece el método que se utiliza para alinear verticalmente el texto.

Sintaxis

objeto.VertAlignment [ = tipo ]

La sintaxis de la propiedad VertAlignment consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
tipo | Integer. Una constante VtVerticalAlignment que se utiliza para describir el método de alineación vertical del texto.


View3D (Propiedad)

Devuelve una referencia a un objeto View3D que describe la orientación física de un gráfico tridimensional.

Sintaxis

objeto.View3D

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.


Visible (Propiedad, control MSChart)

Devuelve o establece un valor que determina si se está mostrando un elemento del gráfico.

Sintaxis

objeto.Visible [ = booleano ]

La sintaxis de la propiedad Visible consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
booleano | Una expresión booleana que especifica si se está mostrando el elemento, como se describe en valores.

Valores

Los valores de booleano son:

Valor | Descripción
True | Se está mostrando el gráfico, el título del eje, la etiqueta o el marcador.
False | Los elementos están ocultos.


VtColor (Propiedad)

Devuelve una referencia a un objeto VtColor que describe el color de dibujo en un gráfico.

Sintaxis

objeto.VtColor

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.


VtFont (Propiedad)

Devuelve una referencia a un objeto VtFont que describe la fuente utilizada para mostrar el texto del gráfico.

Sintaxis

objeto.VtFont

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.


Wall (Propiedad)

Devuelve una referencia a un objeto Wall que describe el área del plano que representan los ejes x e y de un gráfico tridimensional.

Sintaxis

objeto.Wall

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.


Weighting (Propiedad)

Devuelve una referencia a un objeto Weighting que describe el tamaño de un sector en relación a otros del mismo gráfico circular.

Sintaxis

objeto.Weighting

El marcador de posición objeto representa una expresión de objeto que da como resultado un objeto de la lista Se aplica a.


Width (Propiedad, control MSChart)

Devuelve o establece el ancho en puntos de un elemento del gráfico.

Sintaxis

objeto.Width [ = ancho ]

La sintaxis de la propiedad Width consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
ancho | Single. El ancho del elemento del gráfico.


WidthToHeightRatio (Propiedad)

Devuelve o establece el porcentaje del alto del gráfico que se usará como ancho del gráfico.

Sintaxis

objeto.WidthToHeightRatio [ = pctaje ]

La sintaxis de la propiedad WidthToHeightRatio consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
pctaje | Single. El porcentaje del alto del gráfico.


WordWrap (Propiedad, control MSChart)

Devuelve o establece un valor que determina si el texto se ajusta en las líneas siguientes.

Sintaxis

objeto.WordWrap [ = booleano ]

La sintaxis de la propiedad WordWrap consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
booleano | Una expresión booleana que determina si el texto se ajusta en las líneas siguientes, como se describe en Valores.

Valores

Los valores de booleano son:

Valor | Descripción
True | El texto se ajusta en las líneas siguientes.
False | (Predeterminado) El texto no se ajusta.


XGap (Propiedad)

Devuelve o establece el espaciado de las barras entre las divisiones del eje x. Este espacio se mide como un porcentaje del ancho de la barra.

Sintaxis

objeto.xGap [ = espaciado ]

La sintaxis de la propiedad xGap consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
espaciado | Single. El porcentaje del ancho de barra. El valor 0 hace que las barras se toquen.


X (Propiedad)

Devuelve o establece el valor x de una pareja de coordenadas flotantes de un gráfico.

Sintaxis

objeto.X [ = x ]

La sintaxis de la propiedad X consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
x | Single. (Long en el objeto LCoor.) Identifica el valor x de la coordenada.


Y (Propiedad)

Devuelve o establece el valor y de una pareja de coordenadas flotantes de un gráfico.

Sintaxis

objeto.Y [ = y ]

La sintaxis de la propiedad Y consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
y | Single. (Long en el objeto LCoor.) Identifica el valor y de la coordenada.


ZGap (Propiedad)

Devuelve o establece el espaciado de las barras tridimensionales entre las divisiones del eje z. Este espacio se mide como un porcentaje de la profundidad de barra.

Sintaxis

objeto.zGap [ = espaciado ]

La sintaxis de la propiedad zGap consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
espaciado | Single. El porcentaje de la profundidad de la barra. El valor 0 hace que las barras se toquen en el eje z.


Z (Propiedad)

Devuelve o establece el valor z en una ubicación de coordenadas.

Sintaxis

objeto.Z [ = z ]

La sintaxis de la propiedad Z consta de las siguientes partes:

Parte | Descripción
objeto | Una expresión de objeto que da como resultado un objeto de la lista Se aplica a.
z | Single. (Long en el objeto Lcoor.) Identifica el valor z de la coordenada.