Introducción a Foxtools

Foxtools es una biblioteca API de Visual FoxPro que ofrece archivos DLL de Windows para su utilización en Visual FoxPro.

Las funciones de la biblioteca Foxtools le permiten establecer y obtener información de archivo, manipular rutas de acceso y nombres de archivo, usar avisos del sistema y realizar muchas otras funciones.

Nota Los servicios de soporte técnico de producto de Microsoft (PSS) no ofrecen soporte para las funciones de FoxTools ni por correo electrónico ni por teléfono. Muchas de estas funciones se incluyen por razones de compatibilidad con FoxPro 2.6. Algunas funciones tienen un comportamiento diferente en distintas plataformas.

Lo nuevo

Se han agregado a Visual FoxPro varias funciones de manipulación de nombres de archivo en Foxtools.fll. Ya no es necesario utilizar SET LIBRARY TO FOXTOOLS.FLL para llamar a estas funciones. Como ocurre con las funciones nativas de Visual FoxPro, puede llamarlas directamente en sus programas de Visual FoxPro. Estas funciones son las siguientes:

Función AddBS( )
Función AGetFileVersion( ) (GetFileVersion( ) en FoxTools)
Función DefaultExt( )
Función DriveType( )
Función ForceExt( )
Función ForcePath( )
Función JustDrive( )
Función JustExt( )
Función JustFName( )
Función JustPath( )
Función JustStem( )

Dónde se instala Foxtools

Cuando instale Visual FoxPro, Foxtools.fll se instala en el directorio principal de Visual FoxPro. Para usar las funciones de Foxtools, ejecute el siguiente comando:

SET LIBRARY TO Foxtools

Nota Las rutinas de la API están documentadas en la sección Referencia profesional de la Ayuda en Creación de bibliotecas API. Estas rutinas se asignan a funciones de editor y ventana, y le permiten extender Visual FoxPro con el lenguaje de programación C.

RegFn( ), RegFn32( ) y CallFn( )

La biblioteca API Foxtools permite a los programas de Visual FoxPro llamar a las funciones de archivos DLL de Windows que

  • utilicen los siguientes argumentos: integer, long, float, double, string/buffer. Se pueden pasar por referencia o por valor.

  • devuelvan los siguientes tipos: integer, long, float, double, string/buffer. Sólo se devuelven por valor.

RegFn( ) y RegFn32( ) registran una función y los argumentos que utiliza, y CallFn( ) llama a una función registrada. Las funciones de archivos DLL de Windows están documentadas en los libros incluidos en el Software Development Kit (SDK) de Windows. El SDK de Windows también se incluye en Microsoft C/C++ 7.0 y Visual C++.

Nota

  • Fll32_16.dll se usa para llamar a archivos DLL de 16 bits en win32s. Utiliza el procesador universal para llamar a archivos DLL de 16 bits.

  • Ddreg.EXE se usa para llamar a archivos DLL de 16 bits en win32. Utiliza DDE para llamar a archivos DLL de 16 bits.


AddBS( )

Agrega una barra invertida (si es necesario) a una expresión de ruta de acceso. También está disponible como una función nativa de Visual FoxPro.

Sintaxis

AddBS(cRuta)

cRuta

Especifica el nombre de la ruta de acceso a la que debe agregar la barra invertida.

Tipo devuelto

Character


CallFn( )

Llama a una función registrada y devuelve el valor que ha devuelto la función, con el tipo declarado por ReturnType en la llamada RegFn.

Sintaxis

CallFN(nControladorFunción, Arg1[, Arg2[, ...]])

nControladorFunción

El controlador de función de una llamada previa a RegFn( ) o RegFn32( ).

Arg1, Arg2, ....

Argumentos requeridos por la función a la que hace referencia FnNum. Debe pasar los argumentos como se declararon cuando se registró la función o se producirá un error.

Todos los argumentos deben coincidir con su tipo declarado:

  • F, D – debe ser un número de coma flotante.

  • I, L – debe ser un número entero.

  • C – debe ser una cadena pasada por valor o 0 (cero). Si es 0, se pasa un puntero nulo.

Tipos devueltos

Definidos por el usuario en RegFn( ) o RegFn32( ).


CleanPath( )

Devuelve un nombre de archivo corregido (mejor aproximación) para un nombre de archivo no válido y quita espacios, caracteres no válidos, barras invertidas duplicadas, etcétera.

Sintaxis

CleanPath(cNombreArchivo)

cNombreArchivo

Especifica el nombre de archivo que hay que limpiar.

Tipos devueltos

Character


CloseClip( )

Cierra el Portapapeles abierto previamente con OpenClip( ).

Sintaxis

CloseClip( )

Tipo devuelto

Logical

Comentarios

El valor devuelto informa del éxito (.T.) o fallo (.F.) del comando. Casi todas las funciones Clip se basan en abrir el Portapapeles antes de usar la función. Puede usar _CLIPTEXT para tener acceso al contenido del Portapapeles de Windows.

Nota Esta función se corresponde con la función del SDK de Windows con nombre similar. Para obtener más información, consulte la documentación del SDK de Windows.


CountClipF( )

Obtiene el número de distintos formatos de datos que hay actualmente en el Portapapeles de Windows.

Sintaxis

CountClipF( )

Tipo devuelto

Numeric

Comentarios

Casi todas las funciones Clip se basan en abrir el Portapapeles antes de usar la función. Puede usar _CLIPTEXT para tener acceso al contenido del Portapapeles de Windows.

Nota Esta función se corresponde con la función del SDK de Windows con nombre similar. Para obtener más información, consulte la documentación del SDK de Windows.


DefaultExt( )

Devuelve un nombre de archivo con una extensión nueva si no existe ya uno. También está disponible como una función nativa de Visual FoxPro.

Sintaxis

DefaultExt(cNombreArchivo, cPredeterminado)

cNombreArchivo

Especifica el nombre de archivo (con o sin ruta de acceso o extensión) que hay que devolver.

cPredeterminado

Especifica la extensión predeterminada sin punto.

Tipo devuelto

Character


DriveType( )

Devuelve el tipo de la unidad especificada. También está disponible como una función nativa de Visual FoxPro.

Sintaxis

DriveType(cUnidad)

cUnidad

Designa la unidad. Los dos puntos de nombres de unidad (por ejemplo, "C:") son opcionales.

Tipos devueltos

Numeric

Comentarios

La tabla siguiente explica el número que DriveType( ) devuelve y la correspondiente descripción de tipo de unidad.

Número | Tipo de unidad
0 | Sin tipo
2 | Disquete
3 | Disco duro
4 | Disco extraíble o unidad de red
5 | CD-ROM
6 | Disco RAM(1)

(1) Como hay muchos tipos diferentes de discos RAM, puede que obtenga resultados devueltos incoherentes.


EmptyClip( )

Vacía el Portapapeles y libera controladores de datos en el Portapapeles. Después asigna la propiedad del Portapapeles a la ventana en la que está abierto el Portapapeles.

Sintaxis

EmptyClip( )

Tipo devuelto

Logical

Comentarios

Casi todas las funciones Clip se basan en abrir el Portapapeles antes de usar la función. Puede usar _CLIPTEXT para tener acceso al Portapapeles de Windows.

Nota Esta función se corresponde con la función del SDK de Windows con nombre similare. Para obtener más información, consulte la documentación del SDK de Windows.


EnumClipFm( )

Enumera los formatos encontrados en una lista de formatos disponibles que pertenecen al Portapapeles.

Sintaxis

EnumClipFm(nFormato)

nFormato

Especifica un formato de Portapapeles.

Para determinar los formatos de portapapeles disponibles, establezca nFormato a 0; EnumClipFm( ) devolverá el primer formato de Portapapeles disponible. Para llamadas sucesivas a EnumClipFm( ), establezca nFormato al valor devuelto por la llamada anterior a EnumClipFm( ).

Tipo devuelto

Numeric

Comentarios

Cada llamada a EnumClipFm( ) especifica un formato disponible conocido; la función devuelve el siguiente formato de la lista.

Casi todas las funciones Clip se basan en abrir el Portapapeles antes de usar la función. Puede usar _CLIPTEXT para tener acceso al Portapapeles de Windows.

Nota Esta función se corresponde con la función del SDK de Windows que tiene un nombre similar. Para obtener más información, consulte la documentación del SDK de Windows.


ForceExt( )

Devuelve una cadena con la extensión de nombre de archivo antigua reemplazada por una extensión nueva. También está disponible como una función nativa de Visual FoxPro.

Sintaxis

ForceExt(cNombreArchivo, cExtensión)

cNombreArchivo

Especifica el nombre de archivo (con o sin una ruta o extensión) que obtendrá una nueva extensión.

cExtensión

Especifica la nueva extensión (sin punto) para cNombreArchivo.

Tipo devuelto

Character


ForcePath( )

Devuelve un nombre de archivo con un nombre de ruta de acceso nuevo sustituido por el antiguo. También está disponible como una función nativa de Visual FoxPro.

Sintaxis

ForceExt(cNombreArchivo, cRuta)

cNombreArchivo

Especifica el nombre de archivo (con o sin una ruta o extensión) que obtendrá una ruta nueva.

cRuta

Especifica la nueva ruta para cNombreArchivo.

Tipo devuelto

Character


FoxToolVer( )

Devuelve el número de versión de la biblioteca Foxtools.

Sintaxis

FoxToolVer( )

Tipo devuelto

Character


GetClipDat( )

Devuelve un controlador para los datos del Portapapeles de un formato especificado y lo pasa directamente a la aplicación que llama.

Sintaxis

GetClipDat(nFormato)

nFormato

Contiene un identificador para posibles formatos del Portapapeles.

nFormato | Descripción (tipo)
1 | cf_Text
2 | cf_Bitmap
3 | cf_MetaFilePict
4 | cf_SYLK
5 | cf_DIF
6 | cf_TIFF
7 | cf_OEMText
8 | cf_DIB
9 | cf_Palette

Tipo devuelto

Logical

Comentarios

El Portapapeles controla el controlador, no la aplicación. La aplicación debe copiar los datos inmediatamente. Casi todas las funciones Clip se basan en abrir el Portapapeles antes de usar la función. Puede usar _CLIPTEXT para tener acceso al Portapapeles de Windows.

Nota Esta función se corresponde con la función del SDK de Windows que tiene un nombre similar. Para obtener más información, consulte la documentación del SDK de Windows.


GetClipFmt( )

Obtiene el nombre de un formato de Portapapeles registrado.

Sintaxis

GetClipFmt(nFormato)

nFormato

Especifica el formato registrado que hay que obtener. Este argumento no debe especificar ninguno de los formatos de portapapeles predefinidos.

Tipo devuelto

Numeric

Comentarios

Casi todas las funciones Clip se basan en abrir el Portapapeles antes de usar la función. Puede usar _CLIPTEXT para tener acceso al Portapapeles de Windows.

Nota Esta función se corresponde con la función del SDK de Windows que tiene un nombre similar. Para obtener más información, consulte la documentación del SDK de Windows.


GetFileVersion( )

Devuelve información sobre un archivo. También está disponible como la función nativa AGETFILEVERSION( ) de Visual FoxPro.

Sintaxis

GetFileVersion(cNombreArchivo, @NombreMatriz)

cNombreArchivo

Especifica el nombre del archivo para el que se devuelve información.

NombreMatriz

Especifica el nombre de la matriz en la que se coloca la información de archivo. Se debe crear la matriz antes de ejecutar GetFileVersion( ) y ésta debe contener por lo menos 1 columna y 12 filas.

Tipo devuelto

Numeric

Comentarios

GetFileVersion( ) se usa normalmente para obtener información sobre archivos .exe y .dll.

Si la función tiene éxito devuelve cero; si no, devuelve –1.

La tabla siguiente muestra la información de archivo contenida en los doce elementos de matriz:

Número de elemento | Información de archivo
1 | Comentarios
2 | Nombre de compañía
3 | Descripción de archivo
4 | Versión de archivo
5 | Nombre interno
6 | Copyright legal
7 | Marcas comerciales legales
8 | Nombre de archivo original
9 | Build privado
10 | Nombre de producto
11 | Versión de producto
12 | Build especial


GetProStrg( )

Obtiene la cadena asociada a una entrada en la sección especificada del archivo de inicialización Win.ini.

Sintaxis

GetProStrg (lpszSección, lpszEntrada, lpszPredeterminado,
@lpszBúferDevolución, cbBúferDevolución)

lpszSección

Apunta a una cadena terminada en valor nulo que especifica la sección que contiene la entrada.

LpszEntrada

Apunta a la cadena terminada en valor nulo que contiene la entrada cuya cadena asociada hay que obtener. Si este valor es NULL, todas las entradas de la sección especificadas por el argumento lpszSección se copian en el búfer especificado por el argumento lpszBúferDevolución.

LpszPredeterminado

Puntero al valor predeterminado para la entrada dada si ésta no se puede encontrar en el archivo de inicialización. Este argumento nunca debe ser NULL; debe apuntar a una cadena válida, incluso si la cadena está vacía (si el primer carácter es cero).

LpszBúferDevolución

Puntero que recibirá la cadena de caracteres.

cbBúferDevolución

Especifica el tamaño en bytes del búfer al que apunta el argumento lpszBúferDevolución.

Valor devuelto

Numeric

Comentarios

Una aplicación puede usar la función GetProStrg( ) para obtener una cadena de un archivo especificado.

Si el argumento lpszEntrada es NULL, la función GetProStrg( ) copia todas las entradas de la sección especificada en el búfer suministrado. Cada cadena terminará en valor nulo y la cadena final termina con dos valores nulos. Si el búfer de destino es demasiado pequeño para contener todas las cadenas, la última cadena se truncará y terminará en dos caracteres nulos.

Si la cadena asociada a lpszEntrada está escrita entre comillas o comillas dobles, las marcas se descartan cuando GetProStrg devuelve la cadena.

GetProStrg( ) no distingue entre mayúsculas y minúsculas, de forma que las cadenas de los argumentos lpszSección y lpszEntrada pueden contener una combinación de letras mayúsculas y minúsculas.

El valor devuelto es el número de bytes copiados al búfer, sin incluir el cero final, si la función tiene éxito.


IsClipFmt( )

Indica si actualmente hay datos del formato especificado en el Portapapeles.

Sintaxis

IsClipFmt(nFormato)

nFormato

Contiene un valor numérico que indica el formato de los datos disponibles.

La tabla siguiente representa los formato predefinidos de Windows:

nFormato | Descripción (tipo)
1 | cf_Text
2 | cf_Bitmap
3 | cf_MetaFilePict
4 | cf_SYLK
5 | cf_DIF
6 | cf_TIFF
7 | cf_OEMText
8 | cf_DIB
9 | cf_Palette

Tipo devuelto

Logical

Comentarios

IsClipFmt( ) devuelve verdadero (.T.) si los datos del fomato especificado están en el Portapapeles o falso (.F.) en caso contrario.

Nota Esta función se corresponde con la función del SDK de Windows con nombre similar. Para obtener más información, consulte la documentación del SDK de Windows.


JustDrive( )

Devuelve la letra de unidad de una ruta completa. También está disponible como función nativa de Visual FoxPro.

Sintaxis

JustDrive(cRuta)

cRuta

Especifica el nombre de ruta completo del que sólo quiere la unidad.

Tipo devuelto

Character


JustExt( )

Devuelve la extensión de tres letras de una ruta de acceso completa. También está disponible como función nativa de Visual FoxPro.

Sintaxis

JustExt(cRuta)

cRuta

Especifica el nombre, que puede incluir la ruta de acceso completa, del archivo del que sólo quiere la extensión.

Tipo devuelto

Character


JustFName( )

Devuelve la parte del nombre de archivo de una ruta de acceso completa y un nombre de archivo. También está disponible como función nativa de Visual FoxPro.

Sintaxis

JustFName(cNombreArchivo)

cNombreArchivo

Especifica el nombre, que puede incluir la ruta de acceso completa, del archivo del que sólo quiere el nombre de archivo.

Tipo devuelto

Character


JustPath( )

Devuelve la parte de la ruta de acceso de una ruta de acceso completa y un nombre de archivo. También está disponible como función nativa de Visual FoxPro.

Sintaxis

JustPath(cNombreArchivo)

cNombreArchivo

Especifica el nombre completo (incluyendo la ruta de acceso) del archivo del que sólo quiere la ruta.

Tipo devuelto

Character


JustStem( )

Devuelve el nombre (primeros ocho caracteres del nombre de archivo) de una ruta de acceso completa y un nombre de archivo. También está disponible como función nativa de Visual FoxPro.

Sintaxis

JustStem(cNombreArchivo)

cNombreArchivo

Especifica el nombre (incluyendo la ruta de acceso) del archivo del que sólo quiere el nombre.

Tipo devuelto

Character


MainHwnd( )

Devuelve el controlador de ventana (HWND) de la ventana principal de Visual FoxPro.

Sintaxis

MainHwnd( )

Tipo devuelto

Numeric


MkDir( )

Crea un directorio.

Sintaxis

MkDir(cRuta)

cRuta

Especifica la ruta que se va a crear.

Tipo devuelto

Numeric

Comentarios

Esta función no comprobará la validez de la longitud y el formato de una cadena de directorio. Los valores devueltos son los siguientes:

0 | éxito
1 | fallo
6 | el directorio ya existe

Esta función sólo está disponible en Foxtools versión 1.01 o posterior.


MessageBox( )

Muestra un cuadro de diálogo modal centrado en la pantalla.

Sintaxis

MessageBox(cTexto, cTítulo, nTipo)

cTexto

Especifica el contenido del cuadro de diálogo.

cTítulo

Especifica el título de la ventana del cuadro de diálogo.

nTipo

Especifica el tipo del cuadro de diálogo:

nTipo | Tipo
0 | MB_OK
1 | MB_OKCANCEL
2 | MB_ABORTRETRYIGNORE
3 | MB_YESNOCANCEL
4 | MB_YESNO
5 | MB_RETRYCANCEL
16 | MB_ICONSTOP
32 | MB_ICONQUESTION
48 | MB_ICONEXCLAMATION
64 | MB_ICONINFORMATION

Tipo devuelto

Numeric

Comentarios

MessageBox( ) devuelve un valor que indica el botón en el que el usuario ha hecho clic.

Valor devuelto | Id del botón en el que se ha hecho clic
1 | idok
2 | idcancel
3 | idabort
4 | idretry
5 | idignore
6 | idyes
7 | idno


NextWord( )

Devuelve los caracteres entre un índice de caracteres especificado y el siguiente delimitador de palabras (o el final de la cadena).

Sintaxis

NextWord(cCadena, nPosición[, cDelimitador])

cCadena

Especifica la cadena que hay que buscar.

nPosición

Especifica la posición numérica del carácter en la cadena que será el carácter inicial devuelto por NextWord( ).

cDelimitador

Especifica los delimitadores de palabras opcionales; NextWord( ) devuelve la cadena de caracteres entre nPosición y este carácter. Si cDelimitador2 no se usa, los delimitadores predeterminados son espacios, tabulaciones y caracteres de retorno de carro (ASCII 13). El carácter delimitador no se incluye en la cadena devuelta.

Tipo devuelto

Character


OpenClip( )

Abre el Portapapeles para que funciones relacionadas con el Portapapeles tengan acceso.

Sintaxis

OpenClip(nControlador)

nControlador

Especifica el controlador de la ventana asociada al Portapapeles. Cero es aceptable. Para obtener el controlador de la ventana principal de Visual FoxPro, llame a MainHwnd( ).

Tipo devuelto

Logical

Comentarios

Casi todas las funciones Clip se basan en abrir el Portapapeles antes de usar la función. Puede usar _CLIPTEXT para tener acceso al Portapapeles de Windows.

Nota Esta función se corresponde con la función del SDK de Windows que tiene un nombre similar. Para obtener más información, consulte la documentación del SDK de Windows.


PutProStrg( )

Copia una cadena en la sección especificada del archivo de inicialización de Windows (Win.ini).

Sintaxis

PutProsStrg(lpszSección, lpszEntrada, lpszCadena)

lpszSección

Puntero a una cadena terminada en valor nulo que especifica la sección a la que se copia la cadena. Si la sección no existe, se crea. El nombre de la sección no distingue mayúsculas de minúsculas; la cadena puede ser cualquier combinación de mayúsculas y minúsculas.

lpszEntrada

Puntero a la cadena terminada en valor nulo que contiene la entrada que se va a asociar a la cadena. Si la entrada no existe en la sección especificada, se crea. Si el argumento es NULL, se elimina toda la sección y todas las entradas que contiene.

lpszCadena

Puntero a la cadena terminada en valor nulo que se va a escribir en el archivo. Si este argumento es NULL, la entrada especificada por el argumento lpszEntrada se elimina.

Tipo devuelto

Numeric

Comentarios

El valor devuelto es distinto de cero si la función tiene éxito; si no es así, vale cero.


Reduce( )

Reemplaza los caracteres especificados en una cadena por un espacio.

Sintaxis

Reduce(cBuscar, cReemplazar)

cBuscar

Especifica la cadena de caracteres que se va a cambiar.

cReemplazar

Especifica los caracteres que se van a buscar y reemplazar por un espacio. Si especifica más de un carácter, los caracteres se tratan por separado durante la reducción y no como una sola cadena multicaracter.

Tipo devuelto

Character

Comentarios

Reemplaza los caracteres especificados en cReemplazar por un espacio, a continuación quita los espacios iniciales y los espacios repetidos de la cadena. Esta función se usa normalmente para reemplazar un grupo de espacios en una cadena con un único espacio o para reemplazar delimitadores tales como tabuladores o marcas de párrafo con un espacio.


RegClipFmt( )

Registra un nuevo formato de Portapapeles.

Sintaxis

RegClipFmt(cFormato)

cFormato

Especifica una cadena que da nombre al nuevo formato.

Tipo devuelto

Numeric

Comentarios

El formato registrado se puede usar en funciones subsiguientes de portapapeles como un formato válido para proporcionar datos que aparecerá en la lista de formatos del Portapapeles.

El valor devuelto indica el formato recién registrado. Si se ha registrado anteriormente un nombre de formato idéntico, incluso por parte de una aplicación diferente, se incrementa la cuenta de referencia del formato (en una unidad) y se devuelve el mismo valor que cuando se registró originalmente el formato. El valor devuelto es cero si el formato no se puede registrar.

Casi todas las funciones Clip se basan en abrir el Portapapeles antes de usar la función. Puede usar _CLIPTEXT para tener acceso al Portapapeles de Windows.

Nota Esta función se corresponde con la función del SDK de Windows que tiene un nombre similar. Para obtener más información, consulte la documentación del SDK de Windows.


RGBComp( )

Devuelve los componentes rojo, verde y azul de un valor de color RGB compuesto.

Sintaxis

RGBComp( nColorRGB, @nValRojo, @nValVerde, @nValAzul )

nColorRGB

Especifica un valor de color RGB compuesto entre 0 y 16777215.

@nValRojo

Especifica una referencia a una variable en la que la función devuelve la intensidad del componente de color rojo de nColorRGB.

@nValVerde

Especifica una referencia a una variable en la que la función devuelve la intensidad de la componente de color verde de nColorRGB.

@nValAzul

Especifica una referencia a una variable en la que la función devuelve la intensidad del componente de color azul de nColorRGB.

Tipo devuelto

Logical


RmDir( )

Elimina un directorio.

Sintaxis

RmDir(cRuta)

cRuta

Especifica la ruta del directorio o carpeta que hay que quitar.

Tipo devuelto

Numeric

Comentarios

Esta función sólo está disponible en Foxtools versión 1.01 o posterior.

Devuelve 0 si tiene éxito y 1 si no tiene éxito.


SetClipDat( )

Establece los datos en el Portapapeles abierto.

Sintaxis

SetClipDat(nFormato, cDatos)

nFormato

Especifica un identificador para posibles formatos de Portapapeles.

nFormato | Descripción (tipo)
1 | cf_Text
2 | cf_Bitmap
3 | cf_MetaFilePict
4 | cf_SYLK
5 | cf_DIF
6 | cf_TIFF
7 | cf_OEMText
8 | cf_DIB
9 | cf_Palette

cDatos

Especifica los datos que se van a colocar en el Portapapeles.

Tipo devuelto

Logical

Comentarios

Debe abrir el Portapapeles con OpenClip( ) antes de llamar a esta función. Si el Portapapeles de Windows está en ejecución no actualizará su ventana para mostrar los datos colocados en el Portapapeles por la función SetClipDat( ) hasta que se llame a la función CloseClip( ).

Nota Esta función se corresponde con la función del SDK de Windows que tiene un nombre similar. Para obtener más información, consulte la documentación del SDK de Windows.


StrFilter( )

Quita todos los caracteres de una cadena excepto los especificados.

Sintaxis

StrFilter(cCadena, cBúsqueda)

cCadena

Especifica la cadena de caracteres que se va a buscar.

cBúsqueda

Especifica los caracteres que se buscan y conservan en cCadena.

Tipo devuelto

Character

Comentarios

StrFilter( ) quita todos los caracteres de cCadena que no están en cBúsqueda y, a continuación, devuelve los caracteres restantes. StrFilter( ) distingue mayúsculas de minúsculas.


ValidPath( )

Comprueba un nombre de archivo de MS-DOS válido o una expresión de ruta.

Sintaxis

ValidPath(cNombre)

cNombre

Especifica la ruta o el nombre de archivo que hay que comprobar.

Tipo devuelto

Logical

Comentarios

ValidPath( ) comprueba que un nombre de archivo o un nombre de ruta de acceso es sintácticamente válido; no comprueba la existencia del archivo o la ruta especificados. La función no es infalible y, a veces, puede interpretar que un archivo tiene un nombre válido cuando en realidad no lo es. Sin embargo, ValidPath( ) no rechazará un nombre válido.

No es compatible con sistemas de archivos que admitan espacios en nombres de ruta.


WordNum( )

Devuelve la palabra especificada en una cadena.

Sintaxis

WordNum(cCadena, nÍndice[, cDelimitador])

cCadena

Especifica la cadena que contiene la palabra que se va a devolver.

nÍndice

Especifica la posición del índice de la palabra que se va a devolver. Por ejemplo, si nÍndice es 3, WordNum( ) devuelve la tercera palabra (si cCadena contiene tres o más palabras).

cDelimitador

Especifica el carácter utilizado para delimitar palabras en cCadena. Los delimitadores predeterminados son espacio, tabulación y retorno de carro.

Tipo devuelto

Character

Comentarios

Si cCadena contiene menos palabras que el número especificado en cÍndice, WordNum( ) devuelve una cadena vacía.


Words( )

Cuenta el número de palabras de una cadena.

Sintaxis

Words(cCadena[, cDelimitador])

cCadena

Especifica la cadena de palabras que hay que contar.

cDelimitador

Especifica el carácter que se va a usar para delimitar palabras en cCadena. Los delimitadores predeterminados son el espacio y la tabulación.

Tipo devuelto

Numeric


RegFn( )

Registra una función de la API de Windows y los argumentos que la función utiliza.

Nota

  • En plataformas Windows de 16 bits, RegFn( ) llama a archivos DLL de 16 bits.

  • En plataformas Windows de 32 bits, RegFn( ) llama a archivos DLL de 32 bits (si pasa el número predeterminado de argumentos).

Sintaxis

RegFn(cNombreFunción, cTiposArg, cTipoDevuelto, cNombreDLL)

cNombreFunción

Especifica el nombre de valor ordinal de la función que se va a registrar.

cTiposArg

Especifica una cadena de caracteres que describe qué argumentos acepta la función. Están permitidos los siguientes valores:

Valor | Descripción
I | Entero (32 bits)
L | Entero largo
C | Cadena de caracteres
F | Número de coma flotante
D | Número de coma flotante de precisión doble
S | Entero corto (16 bits)

Cada tipo de argumento debe ir precedido por @ para indicar que el argumento se pasa por referencia. De forma predeterminada, se pasan argumentos por valor.

cTipoDevuelto

Especifica el tipo devuelto por la función. Los valores permitidos son los mismos que los dados para el argumento con la diferencia de que la devolución por referencia no está permitida.

cNombreDLL

Especifica el nombre de la biblioteca DLL que contiene la función. Es opcional si la función está en una de las bibliotecas de las plataformas Win16 (User.exe, Krnl386.exe y Gdi.exe) o Win32 (Kernel32.dll, Gdi32.dll User32.dll, Advapi32.dll y Mpr.dll).

Vea la función LoadLibrary del SDK de Windows para obtener detalles sobre cómo se busca el nombre de la DLL.

Tipo devuelto

Numeric

Comentarios

Si funciona correctamente, RegFn( ) devuelve un número que se puede utilizar para hacer referencia a la función en futuras llamadas a CallFn( ).

Devuelve –1 si la biblioteca no se pudo abrir y muestra un cuadro de mensaje.

La misma función se puede registrar más de una vez. Esto permite la utilización de funciones que usan argumentos diferentes declarándolas otra vez con distintos tipos de argumentos.


RegFn32( )

Registra una función de la API de Windows y los argumentos que utiliza la función. RegFn32( ) siempre llama a archivos DLL de 32 bits.

Sintaxis

RegFn(cNombreFunción, cTiposArg, cTipoDevuelto, cNombreDLL)

cNombreFunción

Especifica el nombre del valor ordinal de la función que se va a registrar.

cTiposArg

Especifica una cadena de caracteres que describe los argumentos que acepta la función. Se permiten los valores siguientes:

Valor | Descripción
I | Entero (32 bits)
L | Entero largo
C | Cadena de caracteres
F | Número de coma flotante
D | Número de coma flotante de precisión doble
S | Entero corto (16 bits)

Cada tipo de argumento puede ir precedido por @ para indicar que el argumento se pasa por referencia. De forma predeterminada se pasan argumentos por valor.

cTipoDevuelto

El tipo devuelto por la función. Los valores permitidos son los mismos que los dados para el argumento con la diferencia de que la devolución por referencia no está permitida.

cNombreDLL

Especifica el nombre de la DLL de 32 bits que contiene la función. Es opcional si la función está en una de las bibliotecas de las plataformas Win16 (User.exe, Krnl386.exe y Gdi.exe) o Win32 (Kernel32.dll, Gdi32.dll, User32.dll, Advapi32.dll y Mpr.dll).

Vea la función LoadLibrary del SDK de Windows para obtener detalles sobre cómo se busca el nombre de la DLL.

Tipo devuelto

Numeric

Comentarios

Si funciona correctamente, RegFn32( ) devuelve un número que se puede usar para hacer referencia a la función en futuras llamadas a CallFn( ).

Devuelve –1 si la biblioteca no se pudo abrir y muestra un cuadro de mensaje.

La misma función se puede registrar más de una vez. Esto permite la utilización de funciones que usan argumentos diferentes declarándolas otra vez con distintos tipos de argumentos.