Visual SourceSafe Start Page

Visual SourceSafe 6.0

Bienvenido a Visual SourceSafe 6.0, el sistema de control de versiones que le permite administrar sus proyectos individuales y de equipo más facilmente que nunca.

Visual SourceSafe 6.0 es un miembro de la familia de productos de desarrollo Visual Studio 6.0, que incluye:
  • Visual Basic
  • Visual C++
  • Visual FoxPro
  • Visual InterDev
  • Visual J++
  • Visual SourceSafe
  • Biblioteca MSDN

Copyright
Accesibilidad

Introducción a Visual SourceSafe 6.0
Si es la primera vez que utiliza Visual SourceSafe o un programa de control de versiones, comienze aquí.

¿Qué es nuevo en Visual SourceSafe 6.0?
Eche un vistazo a nuestras nuevas características.

Usar Visual SourceSafe 6.0
Visite esta sección para aprender cómo usar Visual SourceSafe.

Visual SourceSafe en el Web
Ir a la Web para obtener la última información de Visual SourceSafe.


Guía de la documentación

El sistema de Ayuda de Microsoft Visual SourceSafe 6.0 (VSS) describe las características de VSS y cómo utilizarlas.

Para obtener información sobre el entorno Windows, consulte la Ayuda en el menú Inicio.


Contenido

Características nuevas

Introducción a VSS.

Uso de VSS

Esta sección explica las características del Explorador de VSS y le ofrece procedimientos para llevar a cabo sus tareas. Se divide en varias secciones:

  • Archivos y proyectos. Trata de las características básicas de VSS.

  • Personalizar VSS. Explica cómo optimizar el rendimiento de VSS.

  • Control de versiones e Historial. Trata del control de versiones, del historial y de las combinaciones.

  • Bifurcar y compartir archivos y proyectos. Trata de las características de bifurcación y compartición de VSS.

  • Proyectos Web. Trata sobre las características del Explorador de Web de VSS.

  • Usar la línea de comandos. Trata de los comandos del Explorador de VSS para la línea de comandos.

Usar el Administrador de VSS

Esta sección explica las características del Administrador de VSS y le ofrece procedimientos para llevar a cabo las tareas del administrador. Se divide en varias secciones:

  • Tareas del Administrador de VSS

  • Instalación

  • Mantener la lista de usuarios

  • Administrar la base de datos

  • Propagar derechos

  • Ejemplos de los archivos SS.INI y SRCSAFE.INI

  • Seguridad de los derechos de acceso

  • Glosario

Esta sección le ofrece definiciones para términos que se encuentran en este sistema de Ayuda.

Referencia

Esta sección sirve de referencia, ya que contiene resúmenes de comandos, variables de inicialización y teclas de método abreviado para el Explorador y para el Administrador de VSS.

Soporte técnico

Esta sección le ofrece información sobre soporte técnico, solución de problemas y accesibilidad para personas con discapacidades.

Sitio Web

www.microsoft.com/spain/ssafe


Por dónde empezar

Si es nuevo a VSS, consulte la Introducción, que le explica las características clave de VSS.

Si ha usado VSS anteriormente, consulte las Nuevas características.

Si es un cliente de VSS y se ha instalado VSS, consulte Trabajar con el Explorador para ver una explicación de las características básicas de VSS, o consulte Comprender los proyectos para obtener información en el diseño y la organización de proyectos.


Novedades de Visual SourceSafe 6.0

Vea también

Microsoft VSS 6.0 tiene muchas características nuevas, incluidas:

  • Archivar y Restaurar. Estas operaciones se pueden realizar ahora con un sencillo asistente del Administrador de VSS. En versiones anteriores de VSS, los comandos Archivar y Restaurar estaban disponibles sólo desde la línea de comandos.

  • Mover archivos. Al mover un archivo ahora, VSS lo compartirá automáticamente en un nuevo proyecto, eliminándolo del proyecto original. El archivo aparecerá como compartido en el nuevo proyecto.

  • Compara diferencias en múltiples proyectos. Esta característica le permite comparar las diferencias de un proyecto frente a otro proyecto.

  • Distribuir archivos individuales. En versiones anteriores de VSS sólo podía distribuir una carpeta. Utilizando el nuevo asistente, podrá distribuir también un archivo.

  • Obtener más rápido. Gracias a las capacidades mejoradas de VSS, puede realizar una operación Obtener dos veces más rápido que en la versión anterior de VSS.

  • Filtrar la información del Historial. Ahora puede ver el historial de archivos y proyectos sin incluir las etiquetas.

  • Promoción de etiquetas. Esta característica le permite promocionar o agregar un archivo a una etiqueta existente.

  • Opción de borrar las carpetas temporales. Esta característica le permite borrar fácilmente las carpetas temporales.

  • Comprobar hipervínculos externos. En versiones anteriores de VSS, sólo los hipervínculos internos y los saltos dentro del proyecto se comprobaban. Ahora VSS le permite comprobar los hipervínculos y saltos fuera del proyecto

  • Crear accesos directos en el escritorio a bases de datos de VSS (desde el Explorador de VSS). Esta característica le permite crear un acceso directo en su escritorio que abra una base de datos de VSS específica.

  • Ayuda en formato HTML. Las versiones anteriores de VSS utilizaban la ayuda en formato Windows.


Optimizar VSS

Su instalación de VSS puede optimizarse para maximizar el rendimiento. Esta optimización se divide en dos categorías:

  • Características que puede desactivar

  • Optimización general


Características que puede desactivar

Vea también

Su administrador de VSS puede deshabilitar cualquiera de estas características para optimizar la velocidad de muchos comandos de VSS.

  • Carpetas centrales

  • Archivos de diario

  • Sistema de seguridad del proyecto


Optimización general

Vea también

Puede configurar estas opciones en la ficha Archivos locales del cuadro de diálogo Opciones, en el menú Herramientas.

  • Copiar archivos con palabras clave expandidas dentro de una carpeta de trabajo. Útil si utiliza expansión de palabras clave. Si selecciona esta casilla de texto forzará a VSS a copiar el archivo que contiene palabras clave expandidas en la carpeta de trabajo, después de que se halla protegido en la base de datos Si no selecciona esta casilla de verificación, puede que la velocidad sea mayor, ya que VSS no obtendrá un archivo después de protegerlo.

  • Comparar archivos por. Controla la forma en que VSS determina si ya dispone de la última versión de un archivo en su carpeta de trabajo. La opción Hora a veces no se comporta según lo previsto cuando intenta obtener versiones anteriores. A veces la solución consiste en eliminar su copia local para forzar una operación Obtener.


Usar VSS 4.0a y 5.0 con VSS 6.0

Vea también

VSS 6.0 tiene un nuevo formato de base de datos. Si actualiza a este nuevo formato, los usuarios de VSS 4.0a, VSS 5.0, Macintosh y UNIX 4.0/5.0 no podrá tener acceso a la base de datos hasta que se actualicen.

El formato nuevo de base de datos se debe activar para acelerar el rendimiento y la promoción de etiquetas.


Usar VSS para trabajar con múltiples versiones de un producto al mismo tiempo

Puede haber dos escenarios en el transcurso de desarrollo de un proyecto. El primero está donde no se espera cambiar muchos archivos, y el segundo donde se espera cambiar muchos archivos, potencialmente muchas veces. En el primer escenario, use la nueva característica de VSS de Promoción de etiquetas. En el segundo escenario, use la Compartir/Fijar/Bifurcar.

La promoción de etiquetas es el mejor método a utilizar cuando su desarrollo está hecho en el mismo árbol de proyecto y se corrigen errores de manera rutinaria antes de que se hayan hecho otros cambios en el proyecto. Un ejemplo común es cuando se trabaja sobre una revisión superior con muchas derivaciones, como Beta 1 y Beta 2. En este marco, se debería etiquetar el proyecto cuando se crea que alcanza Beta 1, después continuar trabajando hasta Beta 2. Se necesitan nuevas correcciones para Beta 1, en este punto se utiliza la característica de Promoción de etiquetas. Para obtener más información, consulte Mantener varias versiones de un proyecto.

Compartir/Fijar/Bifurcar es el mejor método para usar en desarrollo paralelo sobre un proyecto en un período de tiempo extendido. Un ejemplo común es cuando se está trabajando en dos versiones que comparten código, a la vez que ambas contienen bifurcaciones. Por ejemplo, ha enviado la Versión 1.0, y ahora está trabajando en la Versión 2.0, sin embargo se necesita una corrección parcial para varios errores. Esta corrección será numerada como Versión 1.1. En este marco, debería trabajar sobre la Versión 2.0 y la Versión 1.1 en diferentes árboles de proyecto, y después mezclar los cambios entre ellas como sea necesario. Si desea más información, consulte Compartir, Fijar y Bifurcar para Crear proyectos de Service Pack (Correcciones de errores).


Usar VSS con equipos UNIX y Macintosh

Vea también

Para usar VSS con equipos UNIX o Macintosh, póngase en contacto con MetroWerks (Macintosh) o MainSoft (UNIX). La instalación predeterminada de VSS es fácil de crear y utilizar, pero puede que no esté necesariamente optimizada en cuanto a rendimiento. Por tanto, puede personalizar su sistema para aumentar el rendimiento:

  • Copie tanta información como sea posible de la red a su unidad de disco. Este cambio es extremadamente útil para todos los usuarios de la red, pero para los usuarios de Macintosh en redes de PC es esencial. Puede usar el programa Netsetup.exe de VSS (en el servidor de VSS) para copiar los archivos ejecutables en su equipo local.

  • Ajuste los archivos de inicialización para conseguir un mejor rendimiento. La mayoría de las mejoras implican compromisos, al igual que la desactivación de ciertas características implica un elevado consumo de tiempo. Ninguna de estas optimizaciones proporciona tanto beneficio como copiar la información de la red a su unidad de disco.


Introducción a Visual SourceSafe 6.0

Para aprovechar completamente Microsoft VSS, es útil comprender lo que VSS puede hacer por usted, incluyendo cómo implementa el control de versiones, cómo configura las carpetas de trabajo y cómo trabaja con documentos. Para hacerlo consulte los siguientes temas:

  • Introducción a VSS

  • Comprender los proyectos

  • Comprender el control de versiones

  • Trabajar con el Explorador

  • Trabajar con archivos


Introducción

Vea también

Microsoft VSS le ayuda a administrar sus proyectos, sin tener en cuenta el tipo de archivo (archivos de texto, archivos gráficos, archivos binarios, archivos de sonido o archivos de vídeo) guardándolos en una base de datos. Cuando necesite compartir archivos entre dos o más proyectos, puede compartirlos de manera rápida y eficiente. Cuando agrega un archivo a VSS, se hace una copia de seguridad del archivo en la base de datos, se hace que esté disponible para las demás personas, y los cambios que se hagan en el archivo se guardan de forma que se pueda recuperar una versión anterior en cualquier momento. Los miembros de su equipo pueden ver la versión más reciente de cualquier archivo, hacer cambios y guardar una nueva versión en la base de datos.

La organización de proyectos de VSS hace que la coordinación del equipo sea fácil e intuitiva; para más información sobre proyectos, consulte Proyectos y para más información sobre archivos, consulte Archivos.

Cuando un archivo (o conjunto de archivos) está listo para entregar a otra persona, grupo, sitio Web o cualquier otra ubicación, VSS hace que sea fácil compartir y asegurar versiones diferentes del conjunto de archivos seleccionado.

Cada vez más, los programadores están teniendo acceso a funciones de VSS desde el interior de su entorno de desarrollo. VSS se puede integrar fácilmente con Microsoft Access, Visual Basic, Visual C++, Visual FoxPro y otras herramientas de desarrollo. Si VSS se integra en su entorno de desarrollo, no necesita ejecutar VSS de manera separada para darse cuenta de las ventajas del control de código fuente.

Para comprender mejor VSS, consulte:

  • Cómo trata VSS los archivos binarios

  • Comprender los proyectos

  • Comprender el control de versiones

  • Comprender las carpetas de trabajo

  • Trabajar con el Explorador

  • Trabajar con archivos

Entonces podrá comenzar a trabajar con documentos, incluyendo la realización de lo siguiente:

  • Agregar archivos, carpetas y proyectos

  • Bifurcar y compartir archivos

  • Proteger, Desproteger y Modificar archivos

  • Obtener y ver archivos

  • Etiquetas de archivos y proyectos

  • Combinar archivos

  • Mover archivos y proyectos

  • Fijar archivos

  • Para usar VSS, usted (o alguien de su grupo de trabajo) debe realizar algunas tareas administrativas para configurar una base de datos de VSS. Para aprender más sobre estas tareas, consulte Tareas del administrador de VSS.


Archivos

Vea también

Cuando desee modificar un documento, puede desprotegerlo de la base de datos, o decir a VSS que desea modificar el archivo. VSS copia el archivo de la base de datos en su carpeta de trabajo. Entonces podrá modificar el archivo. Si alguien intenta desproteger también el mismo archivo para su modificación, VSS genera un mensaje de estado para indicar que el archivo ya está desprotegido. Este simple protocolo de desprotección asegura que no surjan conflictos entre múltiples usuarios que trabajan con el mismo archivo. Si lo desea, puede cambiar las propiedades del proyecto para permitir desprotecciones múltiples del mismo archivo para usuarios diferentes. Tenga en cuenta que no se permite que los archivos binarios sean desprotegidos por varios usuarios.

Tras finalizar la edición del documento, puede protegerlo en VSS. Esto copia el documento modificado de su carpeta a la base de datos de VSS, haciendo los cambios accesibles a otros usuarios. VSS almacena todos los cambios que se han realizado en el documento; la copia más reciente está siempre disponible, pero también se pueden recuperar las versiones anteriores. La tecnología de delta inverso de VSS asegura que todas las versiones de un documento están disponibles, pero utiliza un espacio en disco mínimo.

Si no ha realizado cambios en el archivo, también puede deshacer su desprotección. El archivo vuelve a la forma que tenía antes de ser desprotegido.

Si sólo desea leer un archivo, y no necesita modificarlo, puede Obtener el archivo en su carpeta de trabajo, o usar el comando Ver archivo para obtener la versión más reciente del documento.


Cómo trata VSS archivos binarios

VSS hace una distinción entre los archivos de texto (archivos que sólo contienen caracteres) y los archivos binarios (todos los demás). Para la mayoría de las operaciones, puede tratar los archivos de texto y binarios exactamente igual; VSS utiliza su almacenamiento de delta inverso altamente eficiente para todos los archivos, tanto de texto como binarios.

Es importante comprender cómo determina VSS el tipo de archivo y cómo trata VSS a los dos tipos.

Cómo identifica VSS los archivos

Cuando agrega un archivo a VSS, se le asigna automáticamente un tipo: de texto o binario. El mecanismo predeterminado para crear esta asignación es una prueba simple: VSS busca en el archivo caracteres NULL (bytes con valor 0). Si encuentra este tipo de carácter, VSS identifica el archivo como binario.

Aunque generalmente acierta, el método de VSS puede asignar incorrectamente en algunas ocasiones el tipo de texto a un archivo binario. Por eso, VSS le permite establecer explícitamente el tipo del archivo.

Cuando agrega un archivo, puede establecer la opción de tipo de archivo: Detección automática, Binario o Texto. Detección automática es el valor predeterminado. Tras agregar un archivo, conserva el tipo que se le dio originalmente, a menos que lo cambie explícitamente.

Nota Utilice la ficha General del cuadro de diálogo Propiedades del menú Archivo para ver y cambiar la configuración del tipo de archivo.

Cómo controla VSS los archivos

Hay diferencias significativas entre la forma en que VSS trata los archivos binarios y los de texto:

  • Almacenar cambios: Internamente, los mecanismos de VSS para almacenar cambios difieren en los archivos de texto (que tienen líneas distintas como unidades de comparación) y los archivos binarios (que no tienen delimitadores de línea obvios). Esta es la razón por la que es tan importante para VSS identificar correctamente el tipo de archivo. VSS identifica archivos como binarios si existe un carácter NULL en el archivo.

  • Comando Mostrar diferencias: Con un archivo binario, VSS almacena cada cambio como un pequeño registro de los bytes que se mueven y hacia dónde, lo cual es útil para reconstruir versiones anteriores, pero no para mostrarlas. VSS puede indicarle que el archivo ha cambiado, pero no puede mostrar cómo ha cambiado.

  • Combinar archivos binarios: Esta operación no se realiza en VSS.

  • Desprotecciones múltiples sobre archivos binarios: Esta operación no se realiza en VSS.

  • Caracteres fin de línea: Con un archivo de texto, VSS traduce automáticamente los caracteres fin de línea entre diferentes sistemas operativos; con un archivo binario, VSS no altera el contenido del archivo excepto con la expansión de palabras clave.


Proyectos

Vea también

Un proyecto es una colección de archivos (de cualquier tipo) que se almacenan en VSS. Puede agregar, eliminar, modificar y compartir archivos dentro y entre los proyectos. Un proyecto tiene mucho en común con una carpeta del sistema operativo, pero tiene un soporte mejor para la combinación, historial y control de versión de archivos.

Sus proyectos existen en una base de datos de VSS. Para abrir una base de datos, consulte Abrir o Cerrar una base de datos.

Los archivos se almacenan en proyectos en la base de datos de VSS. Nunca se trabaja con la copia maestra del archivo que se almacena en VSS excepto ocasionalmente para examinarlo o para compararlo con otra copia.

VSS proporciona a cada usuario una copia del archivo para leer o cambiar en la carpeta de trabajo del usuario. Aunque puede ver un archivo sin una carpeta de trabajo, para trabajar realmente con VSS es necesario establecer una carpeta de trabajo. Consulte Cómo se establece una carpeta de trabajo.

Para aprender más sobre el diseño y la organización de proyectos, consulte Diseñar y organizar proyectos.


Control de versiones

Vea también

VSS puede mantener varias versiones de un archivo, incluyendo un registro de los cambios en el archivo de versión a versión.

El control de versiones abarca las siguientes áreas:

  • Coordinación de equipos — asegurándose, por defecto de que un archivo sólo es modificado por una persona en cada momento. Así se evita que los archivos sean sustituidos accidentalmente por las modificaciones de otro usuario. Su administrador puede cambiar este comportamiento predeterminado para permitir múltiples desprotecciones simultáneas en un archivo, al mismo tiempo que se sigue evitando que los restantes cambios queden sobrescritos.

  • Seguimiento de versiones — archivar y mantener un seguimiento de viejas versiones de código fuente y otros archivos, que más tarde pueden ser recuperadas para reparar errores, entre otras cosas.

  • Desarrollo interplataforma— seguimiento de los aspectos de portabilidad relacionados con el mantenimiento de un código básico en múltiples plataformas de desarrollo.

  • Código reutilizable u orientado a objetos— seguimiento de qué programas utilizan qué módulos para poder reutilizar el código.

  • Para obtener más información acerca del control de versiones, vea la sección Control de versiones e Historial de la Ayuda de VSS.


Carpetas de trabajo

Vea también

La carpeta de trabajo es el lugar en el que se trabaja con un archivo. Cuando Desprotege u Obtiene un archivo, VSS copia el elemento en su carpeta de trabajo para ese proyecto. Cuando termina de realizar los cambios en ese archivo y lo vuelve a proteger, VSS lo copia de nuevo en la base de datos desde su carpeta de trabajo.

Desde ese momento, VSS administra su carpeta de trabajo, creando en su ordenador las carpetas necesarias cuando desprotege archivos.

La carpeta de trabajo se puede establecer o cambiar en cualquier momento. Vea Establecer carpetas de trabajo para obtener más información. Los archivos también se pueden ver sin necesidad de que exista una carpeta de trabajo. Vea Obtener y ver archivos y proyectos para obtener información adicional.


Trabajar con el Explorador

Vea también

El Explorador de VSS muestra importante información de estado, como su carpeta de trabajo actual, criterios de búsqueda, número de archivos, etc. Parte de esta información se muestra en los encabezados de columna del panel de archivos y otras informaciones se muestran en la barra de estado, en la parte inferior de la ventana del Explorador de VSS. La barra de título del Explorador de VSS muestra la base de datos con la que está conectado. El Explorador de VSS utiliza símbolos para proporcionar información acerca de los archivos y los proyectos.

Cuando inicia Microsoft VSS, lo primero que hace es preguntarle su contraseña, si ha creado una. Si no ha establecido una contraseña, verá el Explorador de VSS. Desde la ventana del Explorador puede recorrer la base de datos VSS, ver su lista de proyecto, examinar las estadísticas de los archivos y ejecutar comandos que actúen sobre los proyectos ya archivos.

El panel de proyectos muestra la lista de proyectos, así como información acerca de proyectos especiales, como los que haya designado como proyectos de sitio Web, los proyectos escondidos o el proyecto abierto actualmente. El panel de archivos muestra la lista de archivos, que es una lista de todos los archivos del proyecto actual. El panel de resultados muestra los resultados de las operaciones de VSS. Por ejemplo, cuando protege un archivo, en este panel aparece el nombre del archivo que está protegiendo.

Justo debajo de la barra de menús, la barra de herramientas del Explorador de VSS proporciona botones de comando de forma que pueda tener acceso rápidamente a los comandos más comunes de VSS.

En la parte inferior del Explorador de VSS predeterminado aparece en panel Resultados. Este panel muestra los resultados de su operación VSS actual. Como en el caso de los otros paneles del Explorador, puede cambiar el tamaño de este panel. También puede eliminarlo totalmente desactivando la casilla de verificación Mostrar panel de Resultados en la ficha Ver del comando Opciones del menú Herramientas.

Para aprender más cosas sobre cómo trabajar con los archivos y proyectos en el Explorador de VSS, consulte:

  • Arrastrar y colocar

  • Símbolos de la lista de Archivos

  • Símbolos de la lista de Proyectos

  • Actualizar la vista Lista

  • Cambiar el tamaño de la vista Listas

  • Botón secundario del mouse

  • Ordenar la vista Listas

  • Botones de comando de la barra de herramientas


Utilizar Visual SourceSafe 6.0

Cuando trabaja con VSS, trabaja con los proyectos y archivos que contiene. En VSS puede almacenar cualquier tipo de archivo. Las operaciones que le permite realizar VSS son:

  • Agregar archivos, carpetas y proyectos

  • Bifurcar y compartir archivos y proyectos

  • Proteger y desproteger archivos

  • Proyectos escondidos

  • Crear nuevos proyectos

  • Personalizar los archivos SS.NI y SRCSAFE.INI

  • Personalizar VSS

  • Eliminar y recuperar archivos y proyectos

  • Editar archivos

  • Obtener y ver archivos y proyectos

  • Etiquetas de archivos y proyectos

  • Combinar archivos

  • Mover archivos y proyectos

  • Abrir o cerrar una base de datos

  • Fijar archivos y proyectos

  • Deshacer hasta versiones anteriores

  • Buscar archivos

  • Establecer las carpetas de trabajo

  • Establecer tipos de archivos predeterminados

  • Establecer contraseñas

  • Utilizar la línea de comandos

  • Utilizar el cuadro de diálogo Opciones

  • Control de versiones e historial

  • Ver o modificar las propiedades de un archivo o un proyecto

  • Trabajar con carpetas centrales

  • Trabajar con proyectos Web

  • Escribir archivos de proceso por lotes

  • Usar VSS sin conexión


Introducción a archivos y proyectos

Un proyecto es una colección de archivos interrelacionados que se almacenan en VSS. Puede agregar, eliminar, modificar y compartir archivos dentro y entre los proyectos. Un proyecto tiene mucho en común con una carpeta del sistema operativo, sin embargo, proporciona soporte adicional para el historial de archivos y el control de versiones.

Sus proyectos existen en una base de datos de VSS. Los archivos se almacenan en proyectos.

Puede leer o modificar una copia de un archivo en su carpeta de trabajo. Consulte Cómo se establece una carpeta de trabajo.

Para aprender más cosas sobre cómo trabajar con los archivos y proyectos, consulte:

  • Agregar archivos, carpetas y proyectos

  • Bifurcar y compartir archivos y proyectos

  • Proteger y desproteger archivos

  • Proyectos escondidos

  • Crear nuevos proyectos

  • Personalizar los archivos SS.NI y SRCSAFE.INI

  • Personalizar VSS

  • Eliminar y recuperar archivos y proyectos

  • Editar archivos

  • Obtener y ver archivos y proyectos

  • Etiquetas de archivos y proyectos

  • Combinar archivos

  • Mover archivos y proyectos

  • Abrir o cerrar una base de datos

  • Fijar archivos y proyectos

  • Deshacer hasta versiones anteriores

  • Buscar archivos

  • Establecer las carpetas de trabajo

  • Establecer tipos de archivos predeterminados

  • Establecer contraseñas

  • Utilizar la línea de comandos

  • Utilizar el cuadro de diálogo Opciones

  • Control de versiones e historial

  • Ver o modificar las propiedades de un archivo o un proyecto

  • Trabajar con carpetas centrales

  • Trabajar con proyectos Web

  • Escribir archivos de proceso por lotes


Agregar archivos, carpetas y proyectos a VSS

Vea también

Antes de poder agregar archivos a la base de datos VSS, debe tener un proyecto en el que colocar los archivos. Cuando comience a trabajar con VSS, lo primero que tiene que hacer es crear uno o más proyectos.

Cuando haya creado un proyecto, puede agregar archivos o carpetas desde su ordenador a la base de datos VSS.

Para obtener más información acerca de cómo agregar archivos, carpetas y proyectos a VSS, consulte:

  • Agregar archivos y carpetas utilizando arrastrar y colocar

  • Agregar carpetas

  • Agregar múltiples archivos

  • Agregar un único archivo


Cómo agregar archivos, carpetas y proyectos a VSS

Para obtener más información acerca de cómo agregar archivos, carpetas y proyectos a VSS, consulte:

  • Agregar archivos y carpetas utilizando arrastrar y colocar

  • Agregar carpetas

  • Agregar múltiples archivos

  • Agregar un único archivo


Bifurcar y compartir archivos y proyectos

Vea también

En VSS, un archivo puede estar compartido entre múltiples proyectos. Los cambios que se realizan en el archivo desde un proyecto son vistos automáticamente en los demás archivos que comparten el archivo. Así se alienta la reutilización del código. Utilice la ficha Vínculos del comando Propiedades del menú Archivo para ver una lista de los proyectos que están compartiendo un archivo.

La bifurcación es el proceso de tomar un archivo en dos direcciones (es decir, bifurcaciones o rutas) a la vez. VSS mantiene un seguimiento de estas bifurcaciones siguiendo las diferente rutas de un proyecto.

Nota En otros sistemas de control de versiones (no orientados a proyectos), se hace un seguimiento de las bifurcaciones mediante números de versión extendidos: por ejemplo, la versión "2.3.9.2" es la segunda revisión de la novena bifurcación de la versión 2.3. Sin embargo, en VSS, las bifurcaciones se siguen utilizando nombres de proyectos diferentes.

Al bifurcar un archivo se rompe el vínculo compartido, haciendo que el archivo de ese proyecto sea independiente de todos los demás proyectos. Los cambios que realice en el archivo no se reflejarán en ninguna otra parte y viceversa. Se ha creado una bifurcación: dos archivos (el archivo del proyecto y su contrapartida en otros proyectos) tienen un historial compartido hasta un cierto punto e historiales divergentes después de ese momento.

Tras bifurcar un archivo, la ficha Vínculos no muestra el vínculo que se ha roto. En su lugar, utilice la ficha Rutas (a la que también se accede desde el comando Propiedades del menú Archivo) para ver la historia de bifurcación del archivo.

Para obtener más información acerca de cómo bifurcar y compartir archivos, consulte:

  • Bifurcar archivos compartidos

  • Crear vínculos y rutas de archivos

  • Compartir y bifurcar un archivo en una sola operación

  • Compartir, fijar y bifurcar para crear proyectos de Service Pack (corrección de errores)


Cómo bifurcar y compartir archivos y proyectos

Para obtener más información acerca de cómo bifurcar y compartir archivos, consulte:

  • Bifurcar archivos compartidos

  • Crear vínculos y rutas de archivos

  • Compartir y bifurcar un archivo en una sola operación


Cómo compartir archivos

Nota Para ver los proyectos que comparten un archivo, seleccione el archivo y valla a la ficha Vínculos del comando Propiedades en el menú Archivo.

Para compartir un archivo:

  1. En el Explorador de VSS, seleccione el proyecto en el que quiere compartir un archivo.

  2. En el menú de SourceSafe, haga clic en Compartir para mostrar el cuadro de diálogo Compartir.

  3. En la lista Archivo a compartir, seleccione e l archivo que desea compartir. Si el archivo que desea compartir no aparece en la lista, seleccione el proyecto que contiene el archivo en la lista Proyectos.

  4. Haga clic en Compartir.

  5. Haga clic en Cerrar.


Proteger, desproteger y modificar archivos y proyectos

Vea también

Para realizar cambios en un archivo primero debe desprotegerlo en la base de datos VSS. Cuando Desprotege un elemento, VSS coloca una copia modificable en su carpeta de trabajo. Un archivo desprotegido no puede ser desprotegido por nadie más a menos que la instalación de VSS esté configurada para permitir múltiples desprotecciones; consulte su administrador de VSS para obtener más detalles. Puede ver para quién está desprotegido un archivo en la columna Usuario del panel de archivos. Puede desproteger un archivo, múltiples archivos o todos los archivos de un proyecto, dependiendo de los elementos que tenga seleccionados al realizar la operación de desprotección.

Además de desproteger un elemento, también puede Ver u Obtener el elemento. Vea Obtener y ver archivos y proyectos para obtener más información.

Cuando se desprotege un archivo, existen las siguientes opciones:

  • Proteger el archivo o proyecto actualizado, almacenando así los cambios en el proyecto actual en VSS.

  • Deshacer la desprotección, cancelando los cambios en VSS y en su carpeta de trabajo; el archivo o proyecto vuelve al punto en el que se encontraba antes de desprotegerlo.

Para obtener más información acerca de cómo proteger, desproteger y editar archivos, consulte:

  • Proteger archivos o proyectos

  • Desproteger archivos o proyectos

  • Editar archivos

  • Cambiar el nombre de archivos o proyectos

  • Deshacer una desprotección


Cómo proteger, desproteger y modificar archivos y proyectos

Para obtener más información acerca de cómo proteger, desproteger y editar archivos, vea:

  • Proteger archivos o proyectos

  • Desproteger archivos o proyectos

  • Editar archivos

  • Cambiar el nombre de archivos o proyectos

  • Deshacer una desprotección


Esconder proyectos

Vea también

Esconder es una forma de designar proyectos con los que no trabaja muy a menudo y, por tanto, de los que no quiere mantener copias locales. Si un proyecto está escondido, los comandos Obtener, Proteger, Desproteger, Deshacer desprotección y Diferencias de proyecto no afectarán al proyecto cuando los ejecute indirectamente (como parte de una operación recursiva). Los comandos directos (con el proyecto escondido seleccionado en el Explorador) seguirán funcionando con normalidad.

A modo de ejemplo: suponga que está trabajando en un proyecto llamado $/NuestraApl. En este proyecto hay unos subproyectos llamados Código y Tests que necesita y otro subproyecto llamado Docs, que no usa nunca. Es posible que decida obtener recursivamente $/NuestraApl y después eliminar la subcarpeta Docs del disco duro para conseguir la configuración que necesita.

La solución a su problema es ocultar $/NuestraApl/Docs. Incluso aunque el proyecto esté escondido, todavía puede obtener este proyecto o sus archivos en cualquier momento. Sin embargo, cuando obtenga recursivamente $/NuestraApl se pasará por alto el proyecto Docs (y sus subproyectos). Es decir, esconder un proyecto es como decir "Pasa por alto este proyecto cuando actúo recursivamente con proyectos de un nivel superior".

Al esconder un proyecto, sus subproyectos estarán escondidos implícitamente cuando utilice una operación recursiva sobre el proyecto escondido o en un proyecto superior dentro de la lista de proyectos. Es decir, una orden de esconder es como si dijera “cuando se produzca algo recursivo sobre mí, detenerse aquí”.

Para obtener más información acerca de cómo esconder proyectos, consulte:

  • Cómo esconder proyectos


Cómo esconder proyectos

Para esconder un proyecto:

  1. Haga clic en el proyecto que desea esconder.

  2. En el menú Archivo, haga clic en Propiedades y después en la ficha General si aun no hay ninguna seleccionada.

  3. Seleccione la casilla de verificación Este proyecto está escondido para mí.

  4. Haga clic en Cerrar.


Introducción a la línea de comandos

Vea también

VSS proporciona una interfaz de línea de comandos, que resulta especialmente útil para los siguientes usuarios:

  • Los programadores que trabajan en la línea de comandos y que consideran que es más rápido escribir los comandos de VSS que lanzar el Explorador de VSS y utilizar los menús.

  • Los administradores o constructores que escriben y mantienen archivos de proceso por lotes y macros que ejecutan muchos comandos VSS en rápida sucesión.

VSS es compatible con comandos de la línea de comandos mediante el uso del programa SS.exe, que normalmente se encuentra en la carpeta Win32 bajo la carpeta que eligió en el programa de instalación.

Utilice el símbolo de sistema de MS-DOS para acceder a la línea de comandos desde Windows NT o Windows 95. Puede utilizar la línea de comandos cambiando de la carpeta en la que se encuentre a la carpeta en la que se encuentre el archivo SS.exe, o desde cualquier otra carpeta si escribe la ruta completa hasta el archivo SS.exe; por ejemplo:

C:\Vss\Win32\SS.exe

La línea de comandos muestra el resultado de la mayoría de los comandos en el modo de carácter tradicional. Sin embargo, determinados comandos, como el comando Ver, muestran su resultado en una ventana. Cuando la acción del comando ha finalizado, VSS le devuelve al símbolo del sistema. Cada vez que introduzca un comando desde la línea de comandos, VSS le preguntará su nombre de usuario y, si está configurada, por su contraseña. Si quiere evitar este paso puede realizar ciertas acciones basadas en su entorno. Vea Evitar la pregunta de inicio de sesión para obtener más información.

Cuando está trabajando con la interfaz de VSS de línea de comandos, comandos como Obtener y Proteger colocan los archivos en la carpeta en la que se encuentra en ese momento, no en la carpeta de trabajo del proyecto, como lo harían en la interfaz para Windows.

Para obtener más información acerca de cómo utilizar la línea de comandos, consulte:

  • Evitar la pregunta de inicio de sesión

  • Introducir comentarios en la línea de comandos

  • Utilizar comandos alternativos para la línea de comandos

  • Utilizar comandos y opciones de la línea de comandos

  • Utilizar la sintaxis de la línea de comandos

  • Utilizar la línea de comandos después de ejecutar una instalación cliente

  • Utilizar la carpeta de trabajo en la línea de comandos


Cómo utilizar la línea de comandos de VSS

Para obtener más información acerca de cómo utilizar la línea de comandos, consulte:

  • Evitar la pregunta de inicio de sesión

  • Introducir comentarios en la línea de comandos

  • Utilizar comandos alternativos para la línea de comandos

  • Utilizar comandos y opciones de la línea de comandos

  • Utilizar la sintaxis de la línea de comandos

  • Utilizar la línea de comandos después de ejecutar una instalación cliente

  • Utilizar la carpeta de trabajo en la línea de comandos


Crear nuevos proyectos

Vea también

Un proyecto es un grupo de documentos relacionados o una colección de archivos. VSS le permite almacenar y organizar con facilidad sus proyectos, con cualquier jerarquía que desee.

Para crear un proyecto, utilice el comando Crear proyecto del menú Archivo. Para agregar archivos a un proyecto, utilice el comando Agregar archivos.

Para obtener más información acerca de cómo crear nuevos proyectos, consulte:

  • Cómo crear nuevos proyectos


Cómo crear nuevos proyectos

Puede crear un solo proyecto o múltiples proyectos en VSS.

Para agregar un único proyecto a VSS:

  1. En el menú Archivo, haga clic en Crear proyecto para mostrar el cuadro de diálogo Crear proyecto.

  2. En el cuadro Proyecto, escriba el nombre del proyecto.

  3. En el cuadro Comentario, introduzca una breve descripción del proyecto.

  4. Haga clic en Aceptar.


Personalizar VSS

Puede personalizar el comportamiento de VSS de muchos modos. Puede cambiar la forma en la que se comporta VSS para optimizar su rendimiento, cambiar la presentación o insertar palabras clave expansibles en sus archivos. La personalización de VSS puede aumentar su productividad, así como lograr que VSS se ejecute mejor para los usuarios de Macintosh y UNIX.

Puede personalizar las fuentes del Explorador de VSS utilizando el comando Fuente del menú Herramientas. También puede personalizar la barra de herramientas de VSS mediante el comando Personalizar barra de herramientas del menú Archivo.

Para obtener más información acerca de la personalización de VSS, consulte:

  • Desproteger múltiples archivos

  • Expandir palabras clave

  • Dar formato a las palabras clave

  • Optimizar el rendimiento

  • Ejecutar una desprotección exclusiva


Cómo personalizar VSS

Para obtener más información acerca de cómo personalizar VSS, vea los siguientes temas:

  • Desproteger múltiples archivos

  • Expandir palabras clave

  • Dar formato a las palabras clave

  • Optimizar el rendimiento

  • Ejecutar una desprotección exclusiva


Eliminar y recuperar archivos y proyectos

Cuando desee quitar un archivo de VSS, deberá decidir primero si sólo desea quitar el archivo de un proyecto, o de la base de datos de VSS. También deberá decidir si desea eliminar el archivo con la opción de recuperarlo, o si desea destruir el archivo de manera permanente.

VSS proporciona tres maneras de quitar archivos:

  • Eliminar

    Quita un archivo de un proyecto. Cuando se usa este comando, el archivo todavía está en la base de datos de VSS y en otros proyectos que lo compartan, y se puede recuperar. También puede usar este comando sobre proyectos.

  • Destruir

    El cuadro de diálogo Eliminar contiene la casilla de verificación Destruir definitivamente. Cuando seleccione esta casilla de verificación, quitará el archivo o proyecto seleccionado de la base de datos de VSS. Cuando destruya un archivo o un proyecto, ya no podrá recuperarlo.

  • Purgar

    Use este comando para quitar de manera permanente un archivo que ha eliminado, pero no ha destruido de manera permanente. Puede usar este comando para purgar un proyecto completo y todos los archivos que contiene. Cuando purgue un archivo o proyecto, ya no podrá recuperarlo.

La excepción a este comportamiento concierne archivos compartidos. Si un archivo se comparte entre dos o más proyectos, el comando Eliminar y el comando Destruir definitivamente quita el archivo sólo en el proyecto seleccionado actualmente. El archivo permanece en los demás proyectos que lo comparten y en la base de datos de VSS.

Para obtener más información acerca de cómo eliminar y recuperar archivos y proyectos en VSS, consulte:

  • Eliminar un archivo o proyecto

  • Destruir un archivo o proyecto

  • Purgar archivos eliminados

  • Recuperar archivos eliminados


Cómo eliminar y recuperar archivos y proyectos

Para obtener más información acerca de cómo eliminar y recuperar archivos y proyectos en VSS, consulte lo siguiente:

  • Eliminar un archivo o proyecto

  • Destruir un archivo o proyecto

  • Purgar archivos eliminados

  • Recuperar archivos eliminados


Obtener y ver archivos y proyectos

Vea también

Cuando quiera ver un archivo o proyecto, pero no modificarlo, use el comando Obtener o Ver. Obtener copia el archivo o proyecto desde el proyecto actual a su carpeta de trabajo. El archivo que se encuentra en su carpeta de trabajo es de sólo lectura: cualquier modificación que realice en este punto no se puede guardar en el proyecto de VSS.

Si no ha establecido una carpeta de trabajo, también puede recuperar una copia de sólo lectura de un archivo con el comando Ver.

Para obtener más información acerca de cómo obtener y ver archivos y proyectos en VSS, consulte:

  • Incluir siempre subproyectos

  • Mantener siempre los archivos desprotegidos

  • Obtener rápidamente

  • Obtener la versión anterior

  • Obtener la versión más reciente

  • Ver archivos sin una carpeta de trabajo

  • Ver archivos sin obtener o desproteger


Cómo obtener y ver archivos y proyectos

Para obtener más información acerca de cómo obtener y ver archivos y proyectos en VSS, consulte lo siguiente:

  • Incluir siempre subproyectos

  • Mantener siempre los archivos desprotegidos

  • Obtener rápidamente

  • Obtener la versión anterior

  • Obtener la versión más reciente

  • Ver archivos sin una carpeta de trabajo

  • Ver archivos sin obtener o desproteger


Etiquetar archivos y proyectos

Vea también

VSS usa números de versión para mantener un registro de cada cambio que se realiza en los archivos y proyectos. Así se le da la capacidad de recuperar cualquier versión de un archivo o proyecto.

VSS mantiene un registro de las versiones anteriores de 3 manera: mediante el número de versión interno, mediante la fecha, y mediante etiquetas definidas por el usuario.

Número de versión

El número de versión interna lo asigna y lo mantiene VSS. VSS da a cada versión de un archivo o proyecto un número de versión, y lo muestra en el cuadro de diálogo Historial de archivo o Historial del proyecto. El número de versión siempre es un número entero.

Etiquetas

Pero mucho más útiles son las etiquetas definidas por el usuario. Puede asociar una etiqueta con cualquier versión de un archivo o proyecto. Una etiqueta puede ser una cadena de hasta 31 caracteres. Cualquiera de las cadenas siguientes son etiquetas válidas: "1.0", "2.01b", "Beta final" y "Aprobado para QA". Tras aplicar esas etiquetas, puede recuperar archivos asociados con un estado particular de su proyecto desde el cuadro de diálogo Historial, al que se tiene acceso desde el comando Mostrar historial del menú Herramientas.

Probablemente encontrará que al nivel de un proyecto, se hace referencia a etiquetas definidas por el usuario, y no a números internos de versión. Por otra parte, es raro etiquetar archivos individuales.

Nota Cuando se etiqueta un proyecto con una cadena de texto descriptiva, todos los archivos de ese proyecto y sus subproyectos heredan la etiqueta.

  • Considere lo siguiente cuando utilice el comando Etiqueta:

  • Cuando use el comando Etiqueta, crea una nueva versión en el Historial del archivo o proyecto seleccionado, pero el archivo o proyecto permanece siendo el mismo.

  • Si asigna una etiqueta a una versión que ya tiene una etiqueta, se sobrescribe la etiqueta antigua. VSS emite una advertencia antes de quitar la etiqueta antigua.

  • Cuando modifica una etiqueta en el cuadro de diálogo Detalles de historial, no crea una nueva versión del archivo o proyecto, únicamente asigna una etiqueta nueva a una versión ya existente.

  • Si agrega una etiqueta a una versión de un archivo o proyecto en el que ya existe la etiqueta en otra versión, se le preguntará si desea quitar la etiqueta anterior.

Para obtener más información acerca de cómo etiquetar archivos y proyectos en VSS, consulte:

  • Cómo etiquetar archivos y proyectos

Si desea información sobre cómo mantener varias versiones de un producto al mismo tiempo, consulte:

  • Mantener varias versiones de un proyecto


Cómo etiquetar

Para obtener más información acerca de cómo etiquetar archivos y proyectos en VSS, consulte lo siguiente:

  • Cómo etiquetar archivos y proyectos

  • Mantener varias versiones de un proyecto


Cómo etiquetar archivos y proyectos

Vea también

Nota Cuando se etiqueta un proyecto con una cadena de texto descriptiva, todos los archivos de ese proyecto y sus subproyectos heredan la etiqueta.

Para etiquetar la versión actual de un archivo o proyecto:

  1. Seleccione el archivo o proyecto que desee en el Explorador de VSS.

  2. En el menú Archivo, haga clic en Etiqueta para mostrar el cuadro de diálogo Etiqueta.

  3. En el cuadro Etiqueta, escriba una cadena de hasta 31 caracteres; opcionalmente, en el cuadro Comentario, escriba un comentario.

  4. Haga clic en Aceptar.

Para etiquetar una versión anterior de un archivo o proyecto:

  1. Seleccione el archivo o proyecto que desee en el Explorador de VSS.

  2. En el menú Herramientas, haga clic en Mostrar historial para mostrar el cuadro de diálogo Historial.

  3. Haga clic en Detalles para mostrar el cuadro de diálogo Detalles de historial.

  4. En el cuadro Etiqueta, escriba una etiqueta definida por el usuario; opcionalmente, en el cuadro Comentario, escriba un comentario.

  5. Haga clic en Cerrar para salir del cuadro de diálogo Detalles de historial.

  6. Haga clic en Cerrar para salir del cuadro de diálogo Historial.


Mantener múltiples versiones de un proyecto

Vea también

Si está desarrollando un producto y tiene una bifurcación, tiene la opción de mantener varias versiones de ese proyecto a la vez. Mediante VSS puede usar las opciones de compartir, fijar y bifurcar tal y como se describe en el tema Compartir, Fijar y Bifurcar para crear proyectos de Service Pack (Correcciones de errores). O puede usar también las etiquetas.

Si su situación requiere unas ligeras correcciones con cambios mínimos en el proceso de generación, la manera correcta de hacerlo es mediante etiquetas. Sin embargo, si prevé hacer un montón de cambios en el desarrollo continuo, Compartir/Fijar/Bifurcar es el mejor método para hacerlo. Por ejemplo, podría usar la característica de promoción de etiquetas para congelar el árbol de código fuente durante una Beta, y también para hacer fijaciones en esa Beta. Sin embargo, si está trabajando en la Versión 1.1 y la Versión 2.0 de un producto al mismo tiempo, la manera de hacerlo es haciendo un nuevo proyecto para cada versión, y después compartir y fijar todos los archivos, bifurcándolos cuando sea necesario. Cuando se envíe la versión 1.1, puede etiquetar el proyecto 1.1 y después combinar los cambios con el proyecto de la versión 2.0.

Más adelante hay algunos escenarios sobre la utilización de la característica de promoción de etiquetas que se pueden utilizar como guía.

Escenario #1: El ideal

  1. Desarrolle y pruebe su proyecto en la unidad hasta la versión Beta 1.

  2. En el punto donde esté listo para ir a la versión Beta 1, etiquete el proyecto como "Beta 1" (o algo similar).

  3. Comience a trabajar en la versión Beta 2.

Escenario #2: en Beta 1 se necesita una versión diferente ya existente de un archivo

Nota La característica de promoción de etiquetas sólo funciona si se ha activado el nuevo formato de base de datos. Ejecute la utilidad DDUPD para activar el formato nuevo de base de datos. Vea DDUPD para obtener más información.

  1. Desarrolle y pruebe su proyecto en la unidad hasta la versión Beta 1.

  2. En el punto donde esté listo para ir a la versión Beta 1, etiquete el proyecto como "Beta 1" (o algo similar).

  3. Comience a trabajar en la versión Beta 2.

  4. Si la versión errónea del archivo se ha incluido en la etiqueta Beta 1 original, seleccione el archivo y después haga clic en Herramientas, Mostrar historial para mostrar el cuadro de diálogo Historial.

  5. Selecciona la versión del archivo que se debería incluir como parte de Beta 1 y etiquétela como "Beta 1."

  6. Obtenga el proyecto como Beta 1. Así obtendrá el proyecto como si tuviera la fecha y hora en la que lo etiquetó como "Beta 1" excepto con la nueva versión del archivo que acaba de etiquetar, que se obtiene de manera individual como "Beta 1."

Escenario #3: una fijación de la versión actual de un archivo necesita estar en Beta 1, mientras que ningún otro archivo ha cambiado

  1. Desarrolle y pruebe su proyecto en la unidad hasta la versión Beta 1.

  2. En el punto donde esté listo para ir a la versión Beta 1, etiquete el proyecto como "Beta 1" (o algo similar).

  3. Comience a trabajar en la versión Beta 2.

  4. Se da cuenta de que la versión del archivo incluido en la etiqueta Beta 1 (por ejemplo, Versión 4) tiene un error que se debe corregir. Ningún otro archivo del proyecto ha cambiado todavía.

  5. Desproteja el archivo, realice el cambio y protéjalo después.

  6. Etiquete el proyecto como "Beta 1" de nuevo. (Se le preguntará para confirmar que desea eliminar la etiqueta anterior.)

Escenario #4: una fijación de la versión actual de un archivo necesita estar en Beta 1, mientras que otros archivos HAN cambiado

Nota La característica de promoción de etiquetas sólo funciona si se ha activado el nuevo formato de base de datos. Ejecute la utilidad DDUPD para activar el formato nuevo de base de datos. Vea DDUPD para obtener más información.

  1. Desarrolle y pruebe su proyecto en la unidad hasta la versión Beta 1.

  2. En el punto donde esté listo para ir a la versión Beta 1, etiquete el proyecto como "Beta 1" (o algo similar).

  3. Comience a trabajar en la versión Beta 2.

  4. Se da cuenta de que la versión del archivo incluido en la etiqueta Beta 1 tiene un error que se debe corregir. Desgraciadamente, ya se han cambiado otros archivos del proyecto y los cambios se han protegido.

  5. Desproteja el archivo que necesita corregir, realice el cambio y protéjalo después, creando una versión nueva.

  6. Etiquete el archivo como "Beta 1" (la misma etiqueta con la que se etiquetó el proyecto). Así se promociona la versión nueva del archivo hasta la etiqueta "Beta 1."

Ahora, si realiza una operación Obtener del proyecto como Beta 1, obtendrá el proyecto como si tuviera la fecha y hora en la que lo etiquetó como "Beta 1" excepto con la nueva versión del archivo que acaba de etiquetar de manera individual como "Beta 1."

Escenario #5: una versión anterior de una archivo necesita ser corregida y agregada a Beta 1

Nota La característica de promoción de etiquetas sólo funciona si se ha activado el nuevo formato de base de datos. Ejecute la utilidad DDUPD para activar el formato nuevo de base de datos. Vea DDUPD para obtener más información.

  1. Desarrolle y pruebe su proyecto en la unidad hasta la versión Beta 1.

  2. En el punto donde esté listo para ir a la versión Beta 1, etiquete el proyecto como "Beta 1" (o algo similar).

  3. Comience a trabajar en la versión Beta 2.

  4. Se da cuenta de que la versión del archivo incluido en la etiqueta Beta 1 tiene un error que se debe corregir. Por ejemplo, la versión actual del archivo es la Versión 6 y contiene cambios hechos en el camino a Beta 2 que no quiere que se incluyan en Beta 1.

  5. Desproteja el archivo (Versión 6).

  6. Obtenga la Versión 4, sobrescribiendo la copia local de la Versión 6.

  7. Realice los cambios necesarios para corregir el error para Beta 1, y después proteja el archivo. Esto crea una versión 7 del archivo (Versión 4 más la corrección que acaba de realizar, menos todos los cambios entre las versiones 5 y 6)

  8. Etiquete la Versión 7 del archivo como "Beta 1". Así se promociona la Versión 7 del archivo hasta la etiqueta "Beta 1."

    Ahora, si realiza una operación Obtener del proyecto como Beta 1, obtendrá el proyecto como si tuviera la fecha y hora en la que lo etiquetó como "Beta 1" excepto al obtener la Versión 7 del archivo (el que acaba de etiquetar de manera individual)

  9. Para continuar trabajando hasta Beta 2, recupere los cambios realizados en las versiones 5 y 6, desproteja de nuevo el archivo (por ejemplo, desproteja la versión 7).

  10. Obtenga la Versión 6.

  11. Sobrescriba la copia local de la Versión 7, o combine las dos versiones de archivo (esto asegura que la copia local se convierta en la Versión 6 más la corrección que ha hecho en la Versión 7 para Beta 1).

  12. Realice cualquier otro cambio que desee, y después proteja el archivo. Así se crea la versión 8. Ahora podrá reanudar su trabajo hasta Beta 2.


Combinar archivos

Vea también

Combinar es el proceso de combinar diferencias de dos o más copias cambiadas de un archivo en una única versión nueva del archivo.

VSS no puede resolver conflictos de combinación, pero en cambio los presenta para que usted los pueda resolver. Hay dos métodos que se pueden usar para ver y resolver conflictos de combinación, la combinación visual y la combinación manual.

Puede seleccionar el método que va a usar en la ficha Opciones generales del cuadro de diálogo Opciones del menú Herramientas. Combinación visual se elige de forma predeterminada para todos los archivos combinados en los que se encuentren conflictos.

  • Combinación visual: el primer método, recomendado en la mayor parte de los casos es la combinación visual. Este método proporciona un cuadro de diálogo gráfico en el que se pueden resolver todos los conflictos rápidamente con un control máximo. Consulte Resolver conflictos de combinación con la combinación visual.

  • Combinación manual: si desea combinar los archivos manualmente, consulte resolver conflictos de combinación sin combinación manual.

En VSS, una combinación puede ocurrir en tres circunstancias diferentes, al usar desprotecciones múltiples, al combinar explícitamente archivos bifurcados previamente, y al obtener un archivo.

  • Desprotecciones múltiples: si varios usuarios ha desprotegido un archivo, el primer usuario simplemente protege el archivo. Los usuarios siguientes también lo protegen, pero sus cambios se combinan con los cambios de los demás, y VSS mantiene todas las modificaciones.

  • Bifurcar: Al bifurcar y volver a combinar un archivo en uno de los proyectos bifurcados, VSS toma los cambios realizados en una línea del proyecto y los combina con los de la otra línea.

En cualquier combinación, lo que ocurre es lo mismo. VSS toma el archivo con diferencias, lo compara con el archivo original y después crea un archivo resultante que contiene todos los cambios. Por ejemplo, si protege un archivo que produce una combinación, el archivo de su disco duro y el del proyecto se combinan en un archivo resultante que contiene ambos conjuntos de cambios. Esta operación a veces se conoce como combinación de tres vías.

Combinar sobre Obtener

Tras una desprotección múltiple, hay dos instancias cuando los cambios se pueden combinar, al Proteger, y durante un comando Obtener la versión más reciente (sólo si tiene la opción Reemplazar archivos modificables de la ficha Opciones de archivos locales establecida como Combinar).

En este caso, las diferencias entre su copia local de un archivo y la versión guardada en la base de datos de VSS se combinan en la copia local cuando se obtiene la versión más reciente.

Nota Si se desprotege un archivo de manera exclusiva, no hay combinación disponible al realizar un comando Obtener la versión más reciente.

Después de una combinación

Tras una combinación, el archivo de su carpeta de trabajo ha cambiado. Si la combinación se realizó con éxito, ese archivo representa la combinación completa. Si hay un conflicto de combinación, VSS abre la venta de Combinación visual (a menos que haya optado por la combinación manual). La ventana Combinación visual le permite elegir la forma de solucionar cada conflicto con sólo señalar y hacer clic; al final podrá guardar el archivo completamente combinado. Combinación visual es la forma recomendada de resolver los conflictos.

Para los que hayan trabajado con versiones anteriores de VSS o con secuencias de comandos por lotes que se deben ejecutar sin la intervención del usuario, puede elegir la combinación manual de VSS para colocar marcadores identificativos (seis signos igual consecutivos) en su archivo. En cualquier editor de texto es posible buscarlos y modificarlos manualmente.

Además, tras completar una combinación, VSS observa las reglas siguientes.

  • Si hay conflictos, VSS mantiene el archivo desprotegido. Debe resolver los conflictos para proteger el archivo en VSS.

  • Si utiliza el comando Combinar bifurcaciones para combinar un archivo en un proyecto donde ya tiene el archivo desprotegido, todavía tendrá el archivo desprotegido.

  • En todas las demás circunstancias, VSS le da la opción de proteger el archivo de manera automática tras la combinación o dejar el archivo desprotegido en su carpeta de trabajo de forma que pueda inspeccionarlo antes de actualizar.

Cuando se resuelvan los conflictos, proteja de nuevo el archivo. VSS vuelve a comprobar si hay conflictos nuevos, y si se han resuelto todos, entonces protege el archivo.

Para obtener más información acerca de la combinación en VSS, consulte:

  • Combinar archivos bifurcados

  • Resolver conflictos de combinación sin la combinación visual.

  • Resolver conflictos de combinación con la combinación visual


Cómo combinar

Para obtener más información acerca de la utilización de la combinación en VSS, consulte lo siguiente:

  • Combinar archivos bifurcados

  • Resolver conflictos de combinación sin la combinación visual.

  • Resolver conflictos de combinación con la combinación visual


Mover archivos y proyectos

Vea también

Mover archivos

La única manera de mover un archivo es compartirlo con el nuevo proyecto primario, y eliminar o destruir después el archivo en el proyecto original. Se mantendrá el historial del archivo. No puede mover archivos individuales con el comando Mover proyecto.

Mover proyectos

Nota Para usar el comando Mover, debe tener el derecho de acceso Agregar en el proyecto primario al que se está moviendo, y el derecho de acceso Destruir en el proyecto primario desde el que se está moviendo. Consulte con su administrador para cambiar sus derechos.

Puede volver a colocar un subproyecto desde un proyecto primario a otro mediante el comando Mover. Este comando vuelve a definir la ruta del proyecto como la de un subproyecto dado. Por ejemplo, selecciona el proyecto $/ProcesadorWord/Ortografia y lo mueve al proyecto ya existente $/BaseDatos. El proyecto nuevo es $/BaseDatos/Ortografia y es idéntico al proyecto anterior $/ProcesadorWord/Ortografia.

Este comando no cambia el nombre de un proyecto; use el comando Cambiar nombre para hacerlo. El comando Mover no cambia el contenido o el historial de un subproyecto. Sin embargo, afecta a los historiales de los proyectos primarios anterior y nuevo. Finalmente, Mover es muy diferente tanto de Compartir como de Bifurcar.

Advertencia Cuando mueve un proyecto, imposibilita la reconstrucción fiel de una versión anterior de su proyecto primario. Tras el ejemplo anterior, cualquier intento de obtener recursivamente una versión movida anteriormente de $/ProcesadorWord genera una advertencia de que el subproyecto $/Ortografía se ha movido y ya no está disponible.

Para obtener más información sobre cómo mover archivos y proyectos en VSS, consulte:

  • Mover archivos

  • Mover proyectos


Cómo mover archivos y proyectos

Para obtener información sobre cómo mover archivos y proyectos en VSS, consulte lo siguiente:

  • Mover archivos

  • Mover proyectos


Abrir o cerrar una base de datos

Vea también

Cuando usa VSS, sus archivos y proyectos se almacenan en una base de datos. Asi se almacena de manera segura su información y se proporciona importante información histórica y registro de versiones.

Para crear una nueva base de datos, consulte al administrador de VSS.

Para obtener información sobre cómo abrir y cerrar una base de datos en VSS, consulte:

  • Abrir una base de datos ya existente

  • Cerrar una base de datos


Cómo abrir o cerrar una base de datos

Cuando usa VSS, sus archivos y proyectos se almacenan en una base de datos. Para obtener información sobre cómo abrir y cerrar una base de datos en VSS, consulte lo siguiente:

  • Abrir una base de datos ya existente

  • Cerrar una base de datos


Opciones (Cuadro de diálogo)

Puede personalizar el número de opciones de VSS mediante el cuadro de diálogo Opciones. Algunas tareas que se pueden personalizar en VSS incluyen:

  • La forma en que se presentan los diálogos de comandos

  • La manera en que funcionan las opciones de la línea de comandos

  • La forma en que VSS presenta la información de diferencias de archivo

  • La manera en que se llevan a cabo las acciones rutinarias, como la protección y la desprotección.

  • Cómo y qué se establece para presentar en el Explorador de VSS (por ejemplo, la barra de herramientas, la barra de estado, etc.)

Para obtener información sobre el cuadro de diálogo Opciones, consulte:

  • Ficha Opciones de diálogos de comandos

  • Ficha Opciones de la línea de comandos

  • Ficha Opciones de diferencias

  • Ficha Opciones de tipos de archivo

  • Ficha Opciones generales

  • Ficha Opciones de archivos locales

  • Ficha Opciones de presentación

  • Ficha Opciones de advertencias


Opciones de cuadros de diálogo de comandos (Ficha)

En esta ficha puede especificar si los cuadros de diálogo de comandos se muestran cuando se realizan comandos de VSS.

Si no usa las opciones que se proporcionan en el cuadro de diálogo Obtener la última versión, por ejemplo, puede desactivar el cuadro de diálogo. Cuando se realice el comando Obtener la última versión, no se mostrará el cuadro de diálogo.

Puede especificar si aparece un cuadro de diálogo en los siguientes comandos de archivo:

  • Obtener la última versión

  • Desproteger

  • Deshacer Desproteger

  • Mostrar diferencias

  • Historial

  • Modificar y Ver

Puede especificar si aparece un cuadro de diálogo en los siguientes comandos de proyecto:

  • Obtener la última versión

  • Desproteger

  • Deshacer Desproteger

  • Mostrar diferencias

  • Historial

  • Distribuir

  • Crear mapa del sitios

Para mostrar la ficha Cuadros de diálogo de comandos:

  1. En el menú Herramientas, haga clic en Opciones.

  2. Haga clic en la ficha Cuadros de diálogo de comandos.

Importante Haga caso omiso de cualquier configuración que realice en este cuadro de diálogo manteniendo presionada la tecla MÁYUS al realizar cualquiera de los comandos anteriores. El cuadro de diálogo del comando aparecerá incluso si la casilla de verificación correspondiente de Opciones no se ha seleccionado.


Opciones de línea de comandos (Ficha)

Vea también

En esta ficha puede especificar cómo se realizan las opciones de la línea de comandos de VSS. Estas opciones no afectan al comportamiento del Explorador de VSS.

Para mostrar la ficha Línea de comandos:

  1. En el menú Herramientas, haga clic en Opciones.

  2. Seleccione la ficha Opciones de línea de comandos

Las dos primeras opciones afectan a la forma en que VSS interactúa con su carpeta de trabajo durante las operaciones de la línea de comandos. De forma predeterminada, en el Explorador, VSS espera que se establezca una carpeta de trabajo para cada proyecto y desprotegerá los archivos sólo en esa carpeta. De forma predeterminada, en la línea de comandos, VSS presupone que su proyecto y carpeta actuales son con los que desea trabajar e ignora cualquier otra carpeta de trabajo establecida para un proyecto determinado. Puede modificar este comportamiento activando una de las opciones siguientes.

Las dos primeras opciones de la ficha determinan cómo se utiliza la carpeta de trabajo que tiene establecida.

Asumir que la carpeta de trabajo se basa en el proyecto actual

  • Si se selecciona esta opción, se coloca un archivo en la carpeta de trabajo del proyecto, incluso aunque no sea la carpeta actual cuando ejecuta un comando sobre un archivo desde la línea de comandos.

  • Si no se selecciona esta opción, los subproyectos tendrán sus propias carpetas de trabajo respectivas.

Asumir que el proyecto se basa en la carpeta de trabajo

  • Si se selecciona esta opción, VSS buscará en su carpeta actual siempre que se ejecute cualquier comando de VSS. Si ésta es la carpeta de trabajo para un proyecto de VSS, VSS cambia automáticamente a ese proyecto antes de ejecutar el comando. si establece esta opción, se recomienda encarecidamente que no asigne a dos proyectos la misma carpeta de trabajo; VSS no sabrá a qué proyecto cambiar.

  • Si no se selecciona esta opción, VSS no cambia a su proyecto actual cuando se ejecute cualquier comando de VSS.

Comentarios de desprotección

  • Sin comentarios al desproteger: seleccione esta opción si no desea que se le pida un comentario por desprotección.

  • Aplicar el mismo comentario a todos los archivos: seleccione esta opción si desea que VSS tome un comentario (hasta 64 caracteres) y lo aplique a todos los archivos implicados en la operación de desprotección.

  • Aplicar diferentes comentarios a cada archivo: seleccione esta opción si desea agregar un comentario separada para cada archivo implicado en la operación de desprotección.

Petición de comentario

  • Pedir comentarios en la línea de comandos: seleccione esta opción si desea que VSS le pida comentarios en la línea de comandos.

  • Utilizar editor para pedir comentarios: seleccione esta opción si desea usar un editor para escribir sus comentarios en la línea de comandos. Tras seleccionarlo, escriba la ruta de acceso del editor seleccionado en el cuadro Editor. Haga clic en Examinar para buscar en su sistema de archivos esta información.

  • Usar cadena de petición: seleccione esta opción si desea especificar que una cadena de caracteres solicitada (al pedir un comentario) se inserte en su editor cuando se abra. La cadena solicitada no se guarda con su comentario a menos que cambie la cadena en su editor.

  • Editor: escriba la ruta de acceso del editor seleccionado. Haga clic en Examinar para buscar un editor.

Nota Esta opción está desactivada cuando se selecciona Pedir comentarios en la línea de comandos.


Opciones de diferencia (Ficha)

Vea también

En esta ficha puede especificar opciones para ver diferencias entre archivos o proyectos. Estas opciones se utilizan en otros cuadros de diálogo de VSS como por ejemplo el cuadro de diálogo Diferencia de proyecto, el cuadro de diálogo Combinación visual, el editor de VSS predeterminado y el panel de resultados de VSS.

Para mostrar la ficha Opciones de diferencias

  1. En el menú Herramientas, haga clic en Opciones.

  2. Seleccione la ficha Diferencias

Opciones de la ficha

Puede especificar/modificar todas las opciones siguientes.

Colores

Seleccione los colores de línea que usará VSS. El color de línea seleccionado se muestra en el cuadro Ejemplo.

Primer plano

Seleccione el color del primer plano.

Fondo

Seleccione el color del fondo.

Fuente

Seleccione la fuente que se utiliza en el Explorador de VSS y en todos sus cuadros de diálogo. Para modificar la fuente, haga clic en el botón Modificar.

Ejemplo

Las opciones que haya seleccionado se muestran en este cuadro.

Restablecer

Haga clic aquí para restaurar todos los valores de esta ficha a sus valores predeterminados.

Ancho de tabulación

Especifique el número de espacios al que equivale cada tabulador.

Mostrar números de línea

Seleccione esta casilla para mostrar los números de línea en los visores de diferencias visuales.

Ignorar diferencias en espacios en blanco al combinar archivos

Seleccione esta casilla para ignorar las diferencias de espacios en blanco (tabuladores, caracteres de escape, etc.) al combinar dos archivos.


Tipos de archivo (Ficha)

Vea también

En esta ficha puede especificar opciones para los tipos de archivos que se almacenan en VSS.

Para mostrar la ficha Tipos de archivos:

  1. En el menú Herramientas, haga clic en Opciones.

  2. Seleccione la ficha Tipos de archivos:

Muchos de los cuadros de diálogo de VSS contienen listas de archivos que le permiten seleccionar varios archivos para una operación específica. Puede usar esta ficha para filtrar esa lista de archivos de forma que sean más significativos al tipo de trabajo que realiza.

Opciones de la ficha

Puede especificar/modificar todas las opciones siguientes.

Archivos binarios

Modifica la detección automática de VSS de los archivos de texto y binarios con el fin de permitirle considerar siempre algunos tipos de archivos como binarios. Por ejemplo, puede escribir *.obj, *.xls, *.frx en este cuadro para especificar que todos los archivos de objetos, las hojas de Microsoft Excel y lo archivos .frx de Visual Basic de deberían tratar como archivos binarios.

Crear archivo SCC

Esta casilla es útil sólo para los usuarios de Visual Basic y Visual C++. Cuando trabaja con un proyecto de Visual Basic en VSS, se crea un archivo especial en su carpeta de trabajo llamada Mssccprj.scc. Este archivo no se puede agregar nunca a VSS: permanece en su carpeta de trabajo y almacena información importante utilizada para la integración de VSS en Visual Basic.

La opción Crear archivo SCC determina cuándo VSS debe crear este archivo. Su extensión predeterminada (*.vbp, *.mak) significa que nunca se obtiene o agrega un archivo con una extensión .vbp (archivo de proyecto de Visual Basic 4.0) o .mak (utilizando en versiones anteriores de Visual Basic), VSS crea el archivo Mssccprj.scc. Este archivo es muy importante, ya que sin él la integración de VSS en Visual Basic no funcionará correctamente.

Visual C++ realiza algunas cosas del archivo SCC. Agregue "*.dsp files" a este campo para ayudar a Visual C++ a localizar fácilmente proyectos de VSS.

Grupos de archivos

Junto con la opción Tipos de archivo incluidos en el grupo de archivos, esta opción le permite agrupar tipos de archivos en grupos lógicos, que se muestran después en la Lista de archivos de tipo de muchos cuadros de diálogo de VSS. Por ejemplo, si usted es un programador en C++, puede que desee almacenar los archivos .cpp, .h, .rc y .bmp en VSS. Si es usted un programador en Visual Basic, en cambio, puede que desee almacenar los archivos .vbp y .frm. Es posible usar la ficha con el fin de restringir las listas de archivos y mostrar solamente esos tipos de archivos en lugar de todos los de una carpeta específica.

Agregar

Haga clic aquí para agregar un nuevo grupo de extensiones de archivo a la lista. En el cuadro de diálogo Agregar grupo de archivos, escriba un nombre para el nuevo grupo de archivos que desee agregar, como "VC" o "VB".

Eliminar

Haga clic aquí para eliminar el grupo seleccionado actualmente.

Nota El grupo de archivos <Máscaras relevantes> es un caso único. No se puede eliminar, e indica qué archivos se podrían colocar normalmente en un proyecto.

Tipos de archivo incluidos en grupo de archivos

Esta opción le permite modificar un grupo de archivos específico, tal y como se muestra en la lista de tipos de archivo (extensiones) que se incluye en los grupos de archivos seleccionados. Para modificar un grupo de archivos, modifique el contenido de los tipos de archivo que se incluyen en los grupos que se muestran en el cuadro Grupos de archivo.


General (Ficha, cuadro de diálogo Opciones)

En esta ficha puede establecer las propiedades del proyecto seleccionado.

Para mostrar la ficha Opciones generales

  1. Seleccione un proyecto en el explorador de VSS.

  2. En el menú Herramientas, haga clic en Opciones.

  3. Haga clic en la ficha General, si no está ya seleccionada.

Nota Para mostrar esta ficha desde Visual Basic, tras agregar un proyecto Visual Basic a VSS, en el menú Complementos de Visual Basic, elija SourceSafe, y después elija Propiedades de SourceSafe.

Opciones de la ficha

Puede especificar/modificar todas las opciones siguientes.

Mantener los archivos desprotegidos siempre

Seleccione esta casilla para mantener un archivo desprotegido en su carpeta de trabajo, incluso si lo protege en la base de datos del proyecto. El archivo se copia en la base de datos de VSS, pero se deja desprotegido, por lo que puede actualizar la base de datos con sus cambios, pero continuar trabajando sobre el archivo.

Actuar recursivamente en los proyectos

Seleccione esta casilla para realizar todas las acciones sobre un proyecto seleccionado de manera recursiva, esto es, el comando se aplica a los subproyectos (y a sus subproyectos, y así sucesivamente) así como al proyecto seleccionado. Esto es útil si tiene un proyecto con muchos subproyectos que desea desproteger y proteger como una unidad.

Volver a usar el último comentario

Seleccione esta casilla para volver a usar el último comentario para el comando siguiente. Por ejemplo, si protege un archivo con el comentario "Agregados hipervínculos a nuestro menú Ayuda", y después protege otro archivo, se escribe el mismo comentario en el cuadro de comentario de ese archivo. Si modifica el comentario, VSS utilizará el comentario cambiado para el siguiente comando.

Proteger los archivos no modificados

Cuando protege un archivo, y no ha realizado cambios sobre el, VSS mira esta opción para determinar qué debe hacer.

Seleccione una opción de las siguientes:

  • Proteger: indica a VSS que registre la protección como una versión nueva, incluso si no se han detectado cambios en el archivo.

  • Deshacer desprotección: indica a VSS que deshaga la desprotección automáticamente sobre cualquier archivo no cambiado que se intente proteger.

  • Preguntar: indica a VSS que presente un cuadro de diálogo preguntando qué desea hacer para archivo no cambiado.

  • Predeterminado: indica a VSS que actúe dependiendo de los valores de configuración específicos del archivo de inicialización de cada proyecto. Así se indica a VSS cómo determinar lo que debe hacer con los archivos que no han cambiado.

La selección predeterminada es Deshacer desprotección.

Usar combinación visual

Especifique aquí cuándo desea que VSS use la característica de Combinación visual. VSS usa la Combinación visual al combinar archivos tras una bifurcación o una desprotección múltiple. Sus opciones incluyen la utilización de la Combinación visual sólo si hay conflictos, usarla siempre (sí) o no usarla nunca (no). El valor predeterminado es Usar sólo si hay conflictos. Cambie el valor a Sí para ver todos los cambios durante una combinación.

Doble clic en un archivo

Especifica qué comando debería ejecutar VSS al hacer doble clic sobre un archivo.

Sus opciones incluyen:

  • Preguntar: indica a VSS que presente un cuadro de diálogo preguntando qué le gustaría hacer en cada operación.

  • Ver archivo: indica a VSS que presente un cuadro de diálogo automáticamente para ver: no tiene la capacidad de modificar el archivo.

  • Modificar archivo: indica a VSS que desproteja el archivo automáticamente en su carpeta de trabajo, y lo abra para su modificación.

El valor predeterminado es Preguntar.

Editor para ver archivos

Si quiere usar un editor para ver archivos de texto, especifique la ruta de acceso del editor seleccionado en este cuadro, o haga clic en Examinar para buscar un editor.

Carpeta para archivos temporales

Especifique aquí dónde desea que VSS almacene los archivos temporales, o haga clic en Examinar para buscar y seleccionar una ubicación de archivo temporal. El valor predeterminado es la carpeta Temp que se encuentra bajo la carpeta en la que se almacena SRCSAFE.INI.

Nota La creación de su carpeta Temp localmente, en lugar de hacerlo en un servidor, puede aumentar el rendimiento de VSS.


Archivos locales (Ficha)

Vea también

En esta ficha puede establecer o cambiar la manera en que se controlan los archivos en la carpeta de trabajo.

Para ver la ficha Archivos locales:

  1. En el menú Herramientas, haga clic en Opciones.

  2. Seleccione la ficha Archivos locales:

Opciones de la ficha

Quitar copia local después de Agregar o Proteger

Esta opción hacer que VSS elimine automáticamente la copia local de los archivos después de agregarlos o protegerlos. Ayuda a reducir al mínimo la utilización del disco y asegura que siempre tendrá la versión más reciente cuando empiece a trabajar con un archivo. No utilice esta opción si utiliza VSS integrado con Visual Bsic, Visual C++ u otros programas similares.

Quitar copia local después de Eliminar

Esta opción hace que VSS elimine automáticamente la copia de un archivo de la carpeta de trabajo al eliminarlo en VSS. Esto ayuda a mantener la saturación del disco al mínimo. Y, mientras no hay destruido o purgado el archivo en la base de datos VSS, siempre podrá recuperar el archivo más adelante.

Utilizar indicador de sólo lectura para archivos no desprotegidos

Seleccione esta opción para marcar los archivos de su carpeta de trabajo como de sólo lectura.

VSS asumirá entonces que los archivos de su carpeta de trabajo que no están desprotegidos son de sólo lectura. Es altamente recomendable que deje esta opción activada.

Copiar los archivos de claves expandidas a la carpeta de trabajo

Seleccione esta opción para actualizar la información de palabras clave en su carpeta de trabajo al proteger un archivo. Cuando protege un archivo y tiene activada la expansión de palabras, VSS actualiza la información de palabras clave en su archivo. El archivo modificado se reemplaza directamente en VSS. Si no activa esta opción, no se colocará automáticamente una copia de este archivo en su carpeta de trabajo. Si no utiliza esta opción aumentará el rendimiento, pero la copia de su carpeta de trabajo podría no estar actualizada.

Agregar fin de línea a todos los archivos de texto

Utilice esta opción para agregar un carácter de fin de línea siempre que VSS recupere un archivo de texto que no lo incluya. Algunos compiladores requieren que todos los archivos que compilan terminen con un carácter de fin de línea. Si está trabajando en un entorno como éstos, puede que necesite establecer esta opción.

Comparar archivos por

Esta opción le permite configurar cómo determina VSS si su copia local está actualizada. Las siguientes opciones están en el orden apropiado para incrementar la velocidad:

  • Contenido: compara el contenido completo del archivo local con la copia de VSS. Es el método más lento, pero el más preciso.

  • Suma de comprobación: compara mediante una suma de comprobación almacenada por VSS. Utilice la comparación por suma de verificación en la mayoría de los posibles usos de VSS.

  • Hora: compara los indicadores de fecha y hora. El método exacto de comparación de fecha depende de la configuración de la opción Establecer fecha y hora en archivos locales: si está configurada como Protección, VSS reemplaza la copia local si la hora de la última protección (o adición) es más reciente que la fecha de modificación de la copia local. Si está configurada como Actual (predeterminado) o Modificación, VSS sustituye la copia local si la hora de modificación del archivo de VSS es distinta a la hora de modificación del archivo local.

Reemplazar archivos modificables

Cuando obtiene o desprotege un archivo, VSS copia el archivo a su carpeta de trabajo. Si ya hay una copia editable del archivo en la carpeta de trabajo, reemplazar el archivo puede borrar su trabajo. Esta opción le permite especificar cómo quiere que VSS se encargue de los archivos modificables.

  • Preguntar: Indica a un cuadro de diálogo que le pregunte qué desea hacer para cada operación que vaya a realizar.

  • Reemplazar: Reemplaza (sobrescribe) el archivo local.

  • Saltar: no sustituye el archivo local y genera un error en el panel Resultados si lo tiene en pantalla.

  • Combinar: combina los cambios entre el archivo desprotegido y el que se está obteniendo o desprotegiendo en ese momento. Si el archivo no se puede combinar (es decir, si se trata de un archivo binario), se muestra un error en el panel Resultados si lo tiene en pantalla. Para que esta opción funcione correctamente, su administrador de VSS debe habilitar las desprotecciones múltiples para los archivos implicados en la acción.

Establecer fecha y hora en archivos locales

Esta opción le permite especificar el módo en el que VSS establece la fecha y la hora de los archivos de su carpeta de trabajo. La opción que elija será la hora que verá cuando vea los archivos en el Explorador de Windows.

  • Actual: Cambia la fecha y la hora del archivo por la fecha y la hora actual, siempre que VSS obtiene un archivo. Esto indica al compilador que el archivo acaba de cambiar y hay que volver a compilarlo de nuevo. Es el predeterminado.

  • Modificación: establece la copia local a la fecha y la hora en que se modificó el archivo por última vez.

  • Protección: establece la copia local a la fecha y la hora en que se protegió el archivo por última vez.


Ver (Ficha, cuadro de diálogo Opciones)

Es esta ficha puede establecer las opciones de visualización del Explorador de VSS

Para mostrar la ficha de opciones Ver:

  1. En el menú Herramientas, haga clic en Opciones.

  2. Seleccione la ficha Ver

Opciones de la ficha

Ventana SourceSafe

  • Mostrar panel de resultados — Seleccione esta opción para mostrar el panel Resultados en el Explorador de VSS. El panel Resultados, situado en la parte inferior del Explorador de VSS, muestra los resultados de sus comandos VSS.

  • Mostrar barra de herramientas — Seleccione esta opción para mostrar la Barra de herramientas en VSS. La Barra de herramientas contiene un conjunto de botones que puede utilizar para ejecutar los comandos más habituales.

  • Mostrar barra de estado — Seleccione esta opción para mostrar la barra de estado en el Explorador de VSS. La barra de estado muestra información de estado acerca de VSS, como es la ordenación actual de los archivos en el panel de archivos, el nombre de usuario actual y el número de elementos de la lista de archivos.

Lista de archivos

  • Usar siempre los nombres de archivos en formato MS-DOS — Seleccione esta opción para truncar los nombres de archivo largos que se pueden utilizar en las plataformas de 32 bits. Esta opción permite que la columna correspondiente al nombre de archivo sea más pequeña y también es útil si la base de datos VSS es utilizada por ordenadores con varios sistemas operativos diferentes.

  • Convertir el proyecto seleccionado en el proyecto actual — Esta opción normalmente está seleccionada. Sin embargo, si su red tiene un rendimiento pobre, puede que desee poder desplazarse por la lista de proyectos sin que VSS actualice el proyecto actual. En este caso, desactive esta opción. Si está desactivada, puede presionar la tecla ENTRAR en un proyecto (o hacer doble clic en él con el mouse) para convertirlo en el proyecto actual.

  • Actualizar automáticamente la lista de archivos — Seleccione esta opción para hacer que VSS actualice automáticamente la lista de archivos. La actualización mantiene actualizado el Explorador de VSS, pero también provoca un retraso momentáneo (y una carga de la red). Si selecciona esta opción, especifique el intervalo de actualización en el cuadro de abajo. Si no selecciona esta opción, podrá refrescar la lista de archivos manualmente seleccionando la opción Actualizar lista de archivos del menú Ver.


Advertencias (Ficha, cuadro de diálogo Opciones)

En esta ficha puede especificar si se mostrarán advertencias antes de realizar acciones que puedan producir la pérdida o eliminación accidental de datos.

Para mostrar la ficha de opciones de Advertencias:

  1. En el menú Herramientas, haga clic en Opciones.

  2. Haga clic en la ficha Advertencias

Opciones de la ficha

Cuando elimina un archivo de la base de datos de VSS, VSS le pregunta "¿Realmente desea eliminar?". Algunos usuarios encontrarán útil la advertencia, puesto que impide la eliminación accidental de datos. Otros la encontrarán molesta, puesto que requiere presionar una tecla más. Ésta y otras advertencias de VSS son completamente configurables.

Puede elegir si desea recibir advertencias antes de que VSS ejecute lo siguiente:

  • Deshace la desprotección de un archivo modificado.

  • Eliminar un archivo o proyecto

  • Destruir un archivo o proyecto

  • Purgar un archivo o proyecto

  • Vuelve a la versión anterior de un archivo

  • Desproteger un archivo ya desprotegido — Si esta opción está deshabilitada, las desprotecciones múltiples están desactivadas — consulte con su Administrador de VSS.

  • Salir de VSS


Contraseñas

Vea también

Utilice el comando Cambiar contraseña para establecer y cambiar su contraseña. Para cambiar su contraseña, primero debe saber cuál es. Si olvida su contraseña, pídale a su Administrador de VSS que la cambie por usted.

Al acceder al sistema, VSS le pedirá una contraseña si el sistema operativo no le permite determinar la identidad del usuario. Si el Administrador de VSS ha indicado que el nombre de red del usuario es el mismo que el nombre de inicio de sesión del usuario, VSS no le pedirá una contraseña.

Nota Aunque su contraseña para VSS puede ser la misma que su contraseña para el sistema operativo u otra diferente, no está creada para sustituir la contraseña del sistema operativo.

Para obtener más información sobre cómo cambiar su contraseña, consulte:

  • Cómo cambiar su contraseña


Cómo cambiar su contraseña

Para cambiar su contraseña:

  1. Desde el menú Herramientas, haga clic en la opción Cambiar contraseña para mostrar el cuadro de diálogo Contraseña.

  2. En el cuadro Contraseña anterior, escriba su contraseña actual.

  3. En el cuadro Contraseña nueva escriba su nueva contraseña.

    Nota Una contraseña puede estar formada por cualquier combinación de 1 a 15 caracteres válidos. A medida que los escribe, los caracteres se muestran como asteriscos. Las contraseñas de Microsoft VSS no distinguen entre mayúsculas y minúsculas.

  4. En el cuadro Comprobar, vuelva a escribir su nueva contraseña para confirmar el cambio.

  5. Haga clic en Aceptar.


Fijar archivos y proyectos

Vea también

La fijación muestra toda su utilidad cuando se aplica en archivos compartidos, aunque no está limitada a estos: Puede fijar cualquier archivo. sin embargo, cuando fija un archivo compartido ya no se pueden realizar cambios en él. La fijación no es lo mismo que la bifurcación, por un lado, no se crea una copia de un archivo. Por otro, no está pensando en cambiar el archivo. Está fijando un archivo para que una determinada versión de ese archivo se convierta en la versión que forme parte del proyecto.

Si se comparte un archivo que ya está fijado, y la versión fijada es la versión que es compartida, entonces los proyectos que comparten dicho archivo no podrán cambiarlo. Si se fija en un proyecto un archivo que ya está compartido, los restantes proyectos pueden seguir modificando y actualizando ese archivo.

Para obtener más información acerca de cómo fijar y liberar un archivo en VSS, consulte:

  • Fijar archivos

  • Liberar archivos


Cómo fijar archivos y proyectos

Para obtener más información acerca de cómo fijar y quitar la fijación de archivos en VSS, consulte lo siguiente:

  • Fijar archivos

  • Liberar archivos


Propiedades

VSS le permite ver o modificar ciertas propiedades de los archivos o proyectos utilizando el comando Propiedades del menú Archivo. Por ejemplo, puede cambiar el tipo del archivo, sus comentarios o especificar si sólo se guardará la última versión para ahorrar espacio en disco.

Para obtener más información acerca de cómo ver o modificar las propiedades de un archivo o de un proyecto, consulte:

  • Agregar fin de línea a todos los archivos de texto

  • Editar propiedades

  • Ver la Lista de archivos eliminados

  • Ver los vínculos del archivo

  • Ver las rutas del archivo

  • Ver las propiedades del archivo

  • Ver el tamaño del archivo seleccionado


Cómo ver o modificar las propiedades de un archivo

Para obtener más información acerca de cómo ver o modificar las propiedades de un archivo o de un proyecto en VSS, consulte:

  • Agregar fin de línea a todos los archivos de texto

  • Editar propiedades

  • Ver la Lista de archivos eliminados

  • Ver los vínculos del archivo

  • Ver las rutas del archivo

  • Ver las propiedades del archivo

  • Ver el tamaño del archivo seleccionado


Deshacer para volver a la versión anterior

Vea también

Deshacer para volver devuelve un archivo a una versión anterior, borrando todas las versiones y cambios realizados desde entonces. Se pierden todos los cambios realizados después de la versión a la que se vuelve. Por ejemplo, si hace clic en la versión 5 y después elige Deshacer, se perderán todos los cambios realizados a partir de la versión 5.

SI el archivo al que vuelve está compartido por más de un proyecto, la operación sólo afecta al proyecto que especifique (por defecto será el proyecto actual). Para realizarlo, deshacer para volver utilice una bifurcación implícita, es decir, bifurca el archivo en el proyecto especificado, separándolo del mismo archivo en los restantes proyectos, y crea una nueva ruta de desarrollo. Para volver a reunir las rutas de desarrollo, si ha realizado cambios en el proyecto especificado, tendrá que combinar los archivos.

Nota También puede realizar una operación de Deshacer virtual, sin eliminar todas las versiones y cambios de un archivo. Este es el método más aconsejable para realizar una operación de Deshacer.

Para obtener más información acerca de cómo deshacer para volver a versiones anteriores en VSS, consulte:

  • Deshacer para volver a una versión anterior de un archivo

  • Deshacer virtual para volver a una versión anterior de un archivo


Cómo volver a las versiones anteriores

Para obtener más información acerca de cómo deshacer para volver a versiones anteriores en VSS, consulte:

  • Deshacer para volver a una versión anterior de un archivo

  • Deshacer virtual para volver a una versión anterior de un archivo


Ejemplos

Vea también

Para ver ejemplos acerca de cuando utilizar estas operaciones en VSS, consulte:

  • Ejemplo de bifurcación

  • Ejemplo de estampación de fecha y hora

  • Ejemplo de etiquetado

  • Ejemplo de archivo de proceso por lotes

  • Ejemplo de compartición


Ejemplo de bifurcación

Vea también

Ejemplo 1: Versiones personalizadas de un programa

Suponga que está trabajando con dos programas para dos clientes. Los dos programas son virtualmente idénticos, pero desea adaptar el comportamiento de los programas en uno o los dos archivos.

Para empezar, deberá compartir un proyecto, $/WORD, con un nuevo proyecto, $/CLIENT2. (Si $/WORD tiene subproyectos, puede compartirlos también de forma recursiva.) Ahora tiene dos proyectos que son idénticos en todos los aspectos.

Después, seleccione el archivo o los archivos que desee adaptar en $/CLIENT2 y bifúrquelos. Ahora, cuando modifique estos archivos específicos en $/CLIENT2, los cambios no se propagarán a $/WORD. Sin embargo, todos los demás archivos, aún se comparten entre los dos proyectos. Si modifica cualquiera de los archivos compartidos, los cambios serán reproducidos en Word.

Bifurcar es rápido y fácil, además de muy poderoso. Pero recuerde que si agrega un archivo a un proyecto y después decide que desea incluirlo en otro proyecto, tendrá que agregarlo o compartirlo en ese proyecto. Si elimina un archivo de un proyecto, también tendrá que eliminarlo en el otro.

Nota Esta técnica también puede utilizarse cuando está trabajando con un programa bajo múltiples plataformas o en otros casos en los que dos versiones siguen a otras en el tiempo, pero mantienen código diferente en caminos especificados.

Ejemplo 2: Versiones paralelas de un mismo programa

Suponga que, después de alcanzar la versión 3.1 de uno de sus proyectos, el desarrollo se separa en dos direcciones diferentes. Un equipo está trabajando para la siguiente versión superior, la versión 4.0. El otro equipo trabaja en una versión de mantenimiento, la versión 3.2.

Crea un nuevo proyecto, etiquetado $/PATCH, para representar la versión 3.2. Comparte y bifurca todos los archivos que están en él. Lo bifurca porque no quiere que los proyectos mantengan un seguimiento mutuo, ya que las versiones 3.2 t 4.0 van en direcciones distintas. De esta forma, los cambios realizados en uno no se reflejan automáticamente en el otro.

Ahora, los proyectos proceden en direcciones diferentes, independientes entre sí. Es posible que más adelante quiera combinar los cambios de la versión 3.2, las correcciones de errores o las pequeñas mejoras en las características, por ejemplo, en la versión 4.0. Entonces podrá combinar esos cambios mediante el comando "combinar bifurcaciones".


Ejemplo de marca de fecha u hora

Vea también

En este ejemplo, un programador en C tiene el archivo Help.c en VSS y en su carpeta de trabajo. Su compilador convierte este archivo de código fuente en el módulo de objeto Help.obj. En cualquier momento del ciclo de desarrollo, ambos archivos, Help.obj y Help.c, pueden existir en la misma carpeta. Cada vez que el desarrollador escribe MAKE en el sistema operativo, su utilidad Make compara la fecha y hora estampadas en el archivo Help.c con los del archivo Help.obj para determinar si debe realizarse la compilación, utilizando las siguientes reglas.

  • Si Help.c es más reciente que Help.obj, el código ha cambiado y es necesario volver a realizar la compilación.

  • Si Help.obj es más reciente que Help.c, el código ya ha sido compilado y no hace falta volver a compilar.

Este comportamiento es simple, lógico y consistente y asegurar que cada vez que se ejecuta Make el programa se construye lo más rápidamente posible a partir de la versión más reciente del código.

Veamos ahora las ramificaciones para VSS. Help.c se compila en Help.obj, asignando una nueva fecha y hora a este último. Si vuelve a ejecutar Make sin cambiar nada, Help.c no se vuelve a compilar. Cuando esté satisfecho con sus cambios, proteja Help.c en VSS y, a la mañana siguiente, vuelva a obtener Help.c.

Si Help.c no ha cambiado, VSS reconocerá que su copia y la suya son idénticas. No ejecuta Obtener, la fecha y la hora no cambian y el archivo no vuelve a ser combinado, tal y como debería suceder.

Si otro desarrollador ha cambiado Help.c, VSS reconoce que el archivo es diferente. Obtiene Help.c y fija la fecha y la hora del archivo con la hora actual (en lugar de utilizar la hora en la que se protegió el archivo). Cuando ejecute el comando Make, el archivo será recompilado, de nuevo tal y como debería suceder. Así, el comportamiento de VSS envía la señal correcta a la utilidad Make sin importar si alguien ha cambiado el archivo o no.


Ejemplo de etiquetado

Vea también

Este ejemplo muestra cómo las etiquetas de proyectos son diferentes de las etiquetas de archivos. Recuerde que las etiquetas también son independientes y diferentes de los números de versión.

Ejemplo

Supongamos que etiqueta el proyecto como $/NorWind "Versión 2.2". Luego revisa el archivo

Hyper.c del proyecto $/NorWind y lo etiqueta como "Versión 2.2." Como esa versión del archivo no existía cuando etiquetó el archivo, si obtiene el proyecto en la etiqueta "Versión 2.2", no obtendrá la última versión del archivo Hyper.c. En otras palabras, si selecciona la "Versión 2.2." del proyecto $/NorthWind en el cuadro de diálogo Historial de archivo y hace clic en el botón Obtener, no obtendrá la última versión del archivo Hyper.c, si no la versión del archivo que estaba en el proyecto $/NorthWind cuando se etiquetó como "Versión 2.2".


Ejemplo de archivo de proceso por lotes

Vea también

Si escribe ss Checkout Help.c Help.H y uno de los dos archivos ya está desprotegido, VSS desprotegerá el otro archivo. El siguiente archivo de proceso por lotes evita esta situación comprobando el estado de todos los archivos especificados y desprotegiéndolos tan sólo si ninguno de ellos está desprotegido.

El siguiente ejemplo demuestra muchas de las características descritas en los dos temas de ayuda Cómo redirigir el resultado y Cómo deshabilitar la entrada, incluyendo la utilización de las siguientes opciones:

  • -o para deshabilitar el resultado

  • -y para especificar un nombre de usuario

  • -c para especificar un comentario

Este ejemplo también utiliza el código de salida del comando status para determinar si los archivos están desprotegidos.

Ejemplo de un archivo de proceso por lotes

@echo off
ss status -o- -yThomas %1 %2 %3 %4 %5 %6 %7 %8 %9
if errorlevel 100 goto BAD_FAILURE
if errorlevel 1 goto CHECKED_OUT

rem Exit code 0, no se ha desprotegido ningún archivo
echo No hay desprotegido ningún archivo especificado: desprotegiendo todos.
ss checkout "-cChecked out automatically" -yThomas %1 %2 %3 %4 %5 %6 %7 %8 %9
goto END

rem Exit code 1, algún archivo está desprotegido
:CHECKED_OUT
echo Uno o más archivos están desprotegidos: salir sin desproteger nada.
goto END

rem Exit code 100, se ha producido algún error.
:BAD_FAILURE
echo Visual SourceSafe no se pudo ejecutar satisfactoriamente

:END


Ejemplo de compartición

Vea también

Para apreciar las ventas de compartir archivos, piense en la siguiente situación:

Su equipo desarrolla un conjunto de herramientas que realizan diferentes tareas, pero que trabajan con el mismo formato de datos. Están construidas alrededor de un núcleo central de código común, módulos y archivos de cabecera que son utilizados por muchos programas. Los archivos de cada herramienta se guardan en su propio proyecto. También comparte entre los proyectos los archivos comunes, de forma que cualquier cambio realizado en uno de ellos se propague automáticamente a todas las herramientas.

Por ejemplo, el grupo de base de datos de las herramientas de oficina quiere agregar un corrector ortográfico. El grupo del procesador de textos ya tiene un corrector ortográfico. El grupo de la base de datos podría agregar a su proyecto los archivos correspondientes al corrector ortográfico, pero los dos grupos no estarían conectados. Si el equipo de la base de datos encontrase un error en el corrector ortográfico, el grupo del procesador de textos tendría que duplicar el cambio. Compartiendo los archivos, ambos grupos trabajarían con archivos comunes y todos los cambios serían vistos automáticamente en ambos proyectos.


Buscar archivos

Normalmente, la vista de Listas muestra todos los archivos del proyecto actual. Sin embargo, también puede utilizar el comando Buscar para ver tan sólo los archivos que cumplan determinado criterio, como los archivos con extensión *.c (búsqueda con caracteres comodín) o para ver sólo los archivos desprotegidos. Las búsquedas pueden ser recursivas, para buscar en todos los subproyectos del proyecto actual, o globales, para buscar en toda la lista de proyectos.

Las cadenas de búsqueda pueden tener hasta 63 caracteres.

Para obtener más información acerca de la búsqueda en VSS, consulte:

  • Cancelar búsqueda

  • Búsqueda por cadena

  • Búsqueda por archivos desprotegidos

  • Buscar con un carácter comodín


Cómo buscar archivos

Para obtener más información acerca de la utilización de la búsqueda en VSS, consulte lo siguiente:

  • Cancelar búsqueda

  • Búsqueda por cadena

  • Búsqueda por archivos desprotegidos

  • Buscar con un carácter comodín


Configurar los tipos de archivos predeterminados

Vea también

Cada usuario puede cambiar o establecer sus propios valores de tipos de archivos predeterminados. El administrador de VSS también puede establecer valores predeterminados que se aplicarán a todos los usuarios. Los tipos de archivos predeterminados son utilizados por VSS en los cuadros de diálogo agregar/compartir para ayudarle a filtrar los archivos especificados.

Para obtener más información acerca de como establecer los tipos de archivos predeterminados en VSS, consulte:

  • Cómo configurar los tipos de archivos predeterminados


Cómo configurar los tipos de archivos predeterminados. Configuraciones individuales

Vea también

Para configurar los tipos de archivos predeterminados para un usuario individual de VSS:

  1. En el menú Herramientas de VSS, haga clic en Opciones para mostrar el cuadro de diálogo Opciones de SourceSafe.

  2. Haga clic en la ficha Tipos de archivos:

  3. Introduzca o seleccione la información aplicable en esta ficha, incluyendo:
    • Archivos binarios

      Escriba las máscaras para los archivos que quiere que VSS trate como binarios. Por defecto, cuando VSS debe saber de qué tipo es un archivo, utiliza su mecanismo de detección automática. Sin embargo, al introducir valores en este cuadro de edición, indicará a VSS que debe considerar binarios todos los archivos del tipo introducido. Por ejemplo, si escribe "*.objm *.exe, *.doc", VSS siempre tratará como binarios todos los archivos con estas extensiones.

    • Crear archivo SCC

      Escriba las máscaras de los archivos que quiere que VSS incluya en su archivo SCC.

      Esta casilla sólo sirve para los usuarios de Visual Basic. Cuando trabaja con un proyecto de Visual Basic en VSS, se crea un archivo especial en su carpeta de trabajo llamada Mssccprj.scc. Este archivo no se puede agregar nunca a VSS: permanece en su carpeta de trabajo y almacena información importante utilizada para la integración de VSS en Visual Basic.

      La opción Crear archivo SCC determina cuándo VSS debe crear este archivo. Su extensión predeterminada (*.vbp, *.mak) significa que nunca se obtiene o agrega un archivo con una extensión .vbp (archivo de proyecto de Visual Basic ) o .mak (utilizando en versiones anteriores de Visual Basic), VSS crea el archivo Mssccprj.scc. Este archivo es muy importante, ya que sin él la integración de VSS en Visual Basic no funcionará correctamente.

      Por su lado, Visual C++ y los otros entornos de desarrollo no utilizan este archivo para nada. Puede que no le interese mostrar este archivo inservible en su carpeta de Visual C++. Para evitar que el archivo Mssccprj.scc aparezca en su carpeta de Visual C++, elimine *.mak en este campo. (Sólo debería realizar este cabmio si no utilza los archivos *.mak de Visual Basic.)

    • Grupos de archivos

      Seleccione un grupo de archivos al que quiere desea asignar máscaras de archivo. Agregar o Eliminar le permitirá agregar o eliminar grupos de archivos, con una excepción: no puede eliminar el grupo <Máscaras Relevantes>. Esta máscara ha sido creada por su propia comodidad. Le permite crear un grupo relevante con los archivos que utiliza más a menudo, este grupo <Máscaras Relevantes> se convierte entonces en el grupo de los tipos de archivos predeterminados en los cuadros de diálogo Agregar archivo, Compartir y otros cuadros de diálogo utilizados para manipular archivos en los proyectos.

    • Tipos de archivos incluidos en grupo de archivos

      Escriba en este cuadro las máscaras de archivos correspondientes al grupo seleccionado en el cuadro Grupos de archivos. Por ejemplo, cuando haga clic en Archivos de Visual Basic en el cuadro Grupos de archivos, escriba los tipos de archivos que formarán parte de este grupo. *.bas, *.frx, *.vbp, *.vbx.

  4. Haga clic en Aceptar.


Configurar las carpetas de trabajo

VSS es una herramienta para almacenar y administrar archivos, pero la edición o la compilación de archivos se realiza en la carpeta que le indique a VSS que debe utilizar. Esta carpeta se denomina carpeta de trabajo. Una carpeta de trabajo puede ser una carpeta existente o una nueva carpeta que VSS creará por usted. El Explorador de VSS muestra la ruta hasta su carpeta de trabajo sobre la vista Listas.

Existe una carpeta de trabajo por cada usuario, cada proyecto y cada máquina. Si Joe trabaja en los proyectos $/SpreadSheet y $/WordProcessor, tendrá dos carpetas de trabajo diferentes, una para cada proyecto. Si Hanna trabaja en los mismos proyectos, tendrá sus propias carpetas de trabajo para cada uno de ellos.

Cuando se establece una carpeta de trabajo para un proyecto, puede establecerse para todo el proyecto, incluyendo todos los subproyectos del mismo. Sin embargo, puede establecer una carpeta de trabajo para cada subproyecto de forma explícita.

Debe especificar una carpeta de trabajo para realizar cualquier acción que copie un archivo fuera de VSS, incluyendo los comandos, Desproteger y Obtener última versión. Cuando intenta utilizar cualquiera de estos comandos sin una carpeta de trabajo, VSS muestra un mensaje preguntándoles si desearía establecer una carpeta de trabajo. Si decide no configurar una carpeta de trabajo, VSS detendrá la ejecución del comando.

La única operación que puede realizar sin una carpeta de trabajo es ver un archivo. Vea Obtener y ver archivos y proyectos para obtener información adicional.

Para obtener más información acerca de la configuración de las carpetas de trabajo en VSS, consulte:

Cómo se establece una carpeta de trabajo


Cómo configurar una carpeta de trabajo

Debe especificar una carpeta de trabajo para realizar cualquier acción que copie un archivo fuera de VSS, incluyendo los comandos, Desproteger, Proteger, Deshacer desprotección, Obtener la última versión y Combinar.

Para configurar una carpeta de trabajo:

  1. Seleccione el proyecto para el que quiere configurar una carpeta de trabajo.

  2. En el menú Archivo, haga clic en Establecer carpeta de trabajo para mostrar el cuadro de diálogo Establecer carpeta de trabajo.

  3. Seleccione la unidad en la que se encuentra la carpeta que desea utilizar.

  4. En el cuadro Carpetas, vaya hasta la carpeta que desea utilizar como carpeta de trabajo.

  5. Haga clic en Aceptar. La ruta hasta su carpeta de trabajo aparece en el Explorador de VSS sobre la vista de listas.


Carpetas centrales

Vea también

Una carpeta central es una carpeta centralizada del servidor de red que contiene todos los archivos de un proyecto. Las carpetas centrales deben ser configuradas por su administrador VSS.

Una carpeta central no contiene la copia maestra de los archivos (la copia maestra de todos los archivos está en la base de datos VSS) y no contiene la copia local de los archivos de su carpeta de trabajo. Contiene una copia de la versión protegida más recientemente de cada archivo del proyecto. Por tanto, sirve como un área centralizada para ver y compilar su código fuente.

Una carpeta central es completamente opcional. Generalmente se utiliza en una de estas dos situaciones:

  • Para permitir a los usuarios ver, pero no modificar, los archivos. Puede que haya usuarios que deseen ver los archivos, pero que no tengan acceso a VSS.

  • Para impedir que su carpeta de trabajo conserve su propia copia compilable del proyecto. Para asegurarse de que cada usuario tiene la versión más reciente de los archivos, puede ser conveniente para todos los usuarios compilar el código fuente fuera de una carpeta centralizada, en lugar de hacerlo en las carpetas de trabajo personales. En este caso, las carpetas centrales se utilizan frecuentemente junto a la opción Eliminar la copia local después de Agregar o Desproteger de la ficha Archivos locales del cuadro de diálogo Opciones del menú Herramientas.

Importante Las carpetas centrales no realizan un seguimiento de los cambios en sus subproyectos. Por ejemplo, si tiene un proyecto centralizado $/A que contiene dos subproyectos, $/A/1 y $/A/2 y cambia el nombre de $/A/2 por $/A/B, el cambio de nombre no estará centralizado. Los cambios a nivel de proyecto deben seguirse manualmente, o puede utilizar de vez en cuando la opción Sincronizar todos del cuadro de diálogo Diferencias de proyecto para actualizar la carpeta central. También puede reparar una carpeta central en la que haya archivos desfasados si ejecuta Obtener en la carpeta central.


Introducción a los archivos SS.INI y SRCSAFE.INI

Vea también

VSS proporciona dos archivos de inicialización que contienen configuraciones que puede utilizar para personalizar su entorno de VSS:

  • Ss.ini, para variables de usuario individual

  • SRCSAFE.INI, para las variables globales de la base de datos de VSS.

Cada usuario tiene un archivo Ss.ini que puede modificarse.

Importante Sólo el administrador de VSS debería editar el archivo SRCSAFE.INI.

No es recomendable editar a mano los archivos de inicialización a menos que esté muy familiarizado con las variables de inicialización de VSS y su comportamiento. En su lugar, debería configurar la mayoría de las variables de inicialización directamente desde VSS, en el cuadro de diálogo Opciones del menú Herramientas. Puede configurar las variables de SRCSAFE.INI en el cuadro de diálogo Opciones del Administrador de VSS.

Para obtener más información acerca de cómo personalizar los archivos SS.INI y SRCSAFE.INI, consulte:

  • Personalizar los archivos SS.INI y SRCSAFE.INI

  • Configurar una carpeta de trabajo en el archivo SS.INI

  • Utilizar encabezados de proyecto en el archivo SS.INI


Cómo personalizar los archivos SS.INI y SRCSAFE.INI

Para obtener más información acerca de cómo personalizar los archivos SS.INI y SRCSAFE.INI, vea los siguiente:

  • Personalizar los archivos SS.INI y SRCSAFE.INI

  • Configurar una carpeta de trabajo en el archivo SS.INI

  • Utilizar encabezados de proyecto en el archivo SS.INI


Utilizar VSS sin conexión

Puede utilizar VSS para trabajar sin conexión en las siguientes situaciones.

  • Cuando la red no está disponible

  • Cuando trabaja en un equipo portátil

  • Cuando trabaja desde casa utilizando RAS


Trabajar desde casa (utilizando RAS)

VSS 6.0 ha sido mejorado para utilizar una conexión RAS, sin embargo, la transferencia de archivos mediante módem suele ser lenta. Aquí hay algunos consejos para acelerar las cosas:

  • Si está llevándose los archivos a casa en un disco portátil, copie el archivo vsserver.scc y todos los archivos originales en el mismo archivo. El archivo vssserver.scc ayuda a VSS a determinar si se está utilizando la última versión, lo que minimizará el tráfico de red a través de la línea telefónica. Si utiliza este consejo, deberá copiar todos los archivos a su ordenador de casa o VSS podría pensar que tiene versiones más modernas que las que tiene en realidad y producir un fallo al obtener ciertos archivos.

  • Ejecutar un comando obtener mediante RAS cuando hay muchos archivos modificados es una operación lenta, incluso después de las mejoras de rendimiento de VSS 6.0. Para obtener mejores resultados, ejecute el comando obtener en un disco portátil antes de salir del trabajo y deje para casa las protecciones y desprotecciones. Obtenga los archivos a través de RAS sólo cuando realmente lo necesite, ahorrará tiempo. (Por ejemplo, si desprotege la última versión de un archivo utilizando RAS, la operación de desprotección podría copiar un archivo que necesite otros archivos nuevos para compilarse. En este caso, tendría que obtener el proyecto completo, algo que exige mucho tiempo.)

  • Para evitar ejecutar el comando obtener a través de RAS, puede desproteger las versiones anteriores de un archivo desde el cuadro de diálogo Historial de VSS (desde Herramientas, Mostrar historial) o desde la línea de comandos. La desprotección múltiples debe estar activada para utilizar esta característica. Consulte con su administrador VSS para habilitar las desprotecciones múltiples.

  • Si se trabaja desde casa la línea de comandos suele ser más rápida que la GUI.

Aquí hay algunos métodos para configurar VSS para que funcione más rápidamente a través de RAS:

  • Configure VSS para utilizar un directorio temporal local.

  • Configure VSS para que compare los archivos por su suma de comprobación en lugar de hacerlo por su contenido (la suma de comprobación es la opción predeterminada).

  • No utilice la característica de expansión de palabras clave.

  • Cambie el archivo users.txt para configurar VSS para que utilice un archivo ss.ini local, del siguiente modo:

Nota Asegúrese de realizar primero una copia de seguridad

Cambie:USER_NAME=\USERS\USER_NAME\SS.INI

por:USER_NAME=<unidad local>\SS\USER\SS.INI

Si trabaja desde casa a menudo, también podría pedir a su administrador VSS que configure VSS para acelerar el acceso a través de RAS mediante alguna de las siguientes posibilidades:

  • Desactivar las carpetas centrales.

  • Desactivar el archivo de diario.

  • Desactivar la seguridad del proyecto.


Trabajar en un equipo portátil

Cuando se utiliza VSS en un equipo portátil, desproteja cualquier archivo que piense que vaya a cambiar antes de salir de la oficina.

Si la opción de desprotecciones múltiples está activada, desproteja con total libertad todos los archivos del proyecto. Puede deshacer la desprotección más tarde en los archivos que no haya necesitado. Si la opción de desprotecciones múltiples no está habilitada, desproteja tan sólo aquellos archivos que considere que podría necesitar.

Al desproteger los archivos binarios impedirá que alguien más los desproteja, por lo que deberá tener cuidado al realizarlo.


Trabajar cuando la red no está disponible

Si no puede acceder a la red y necesita desproteger un archivo, no todo está perdido, pero tendrá que realizar algo de trabajo adicional. Estos son los pasos a seguir:

  1. Cambie el atributo de sólo lectura del archivo para poder modificarlo mediante el comando attrib o el Explorador de Windows.

  2. Realice los cambios en el archivo.

  3. Cuando vuelva a tener acceso a la red, utilice el cuadro de diálogo Historial (desde Herramientas, Mostrar historial) y el botón diff para determinar el número de la versión que se llevó a casa. Puede hacerlo buscando las diferencias con versiones anteriores hasta que encuentre una que sólo contenga los cambios que ha realizado en casa.

  4. Desproteja esa versión del archivo desde el cuadro de diálogo Historial, utilizando la opción No obtener la copia local. (Puede que necesite mantener pulsada la tecla Mays para ver esta opción.) Esta opción también está disponible desde la línea de comandos.

    Ahora, el archivo está exactamente en el mismo estado que antes de que se desconectase la red y puede seguir adelante con total seguridad.

Nota El administrador de VSS debe habilitar las desprotecciones múltiples antes de que pueda desproteger las versiones anteriores de un archivo. Si la opción de desprotecciones múltiples no está habilitada, puede desproteger la última versión del archivo si selecciona la opción No obtener la copia local, pero deberá combinar manualmente cualquier cambio que se haya producido desde que se marchó.

  5. Es posible que necesite combinar los archivos antes de protegerlos. Asegúrese de que al combinar los archivos no destruye el trabajo de alguien que los haya protegido desde que se desconectó la red (o desde que usted salió de la oficina).


Control de versiones e Historial

Vea también

VSS proporciona servicios de control de versiones e historial para asegurar que se puede recuperar cada versión de un archivo. Para registrar el momento en el que se cambian o desprotejen los archivos se utilizan la fecha y la hora. Vea Cómo utiliza VSS la estampación de fecha y hora para obtener más información.

VSS utiliza tres métodos para realizar el seguimiento de las versiones de archivos o proyectos:

  • Números de versión. Son números internos mantenidos por VSS. El usuario no tiene control sobre estos números. Cada versión de cada archivo y proyecto de VSS tiene un número de versión. El número de versión siempre es un número entero y siempre se incrementa.

  • Etiquetas Son cadenas que puede aplicar a cualquier versión de un proyecto o archivo. Una etiqueta es una cadena en formato libre de hasta 31 caracteres. Las siguientes son etiquetas válidas: "1.0", "2.01b", "Prueba de campo 3" y "Aprobado por QA".

  • Estampación de fecha y hora. Indica cuándo se ha modificado un archivo por última vea o cuando ha sido protegido. VSS permite utilizar el formato de 12 horas (utilizando una "a" o una "p" como sufijo) y el formato de 24 horas.

La siguiente tabla compara y contrasta los números de versión y las etiquetas.

Número de versión | Etiqueta
Asignado automáticamente por VSS. | Asignado por el usuario, utilizando el comando Etiqueta del menú Archivo o del cuadro de diálogo Historial.
Siempre es un valor numérico. | Cualquier combinación de letras, números, símbolos y espacios, hasta 31 caracteres.
Siempre se incrementa al siguiente número entero. | Cualquier cosa que asigne el usuario.
Se incrementa cada vez que se realice en un archivo o proyecto una acción que afecte al almacenamiento, como agregar, proteger o bifurcar. | Se asigna cuando el usuario considera que ha alcanzado un punto importante.
Aparece en los cuadros de diálogo historial, rutas, vínculos, compartir y propiedades de archivo y en el panel de archivos del Explorador de VSS. | Aparece en los cuadros de diálogo del historial como una cadena proporcionada por el usuario. Indicado por el icono de una etiqueta que aparece junto al nombre del proyecto en lugar de un número de versión. La cadena proporcionada por el usuario abra la etiqueta aparece en la columna Acción del cuadro de diálogo Historial.
No crea una nueva versión, simplemente la identifica. | Al crear una etiqueta se puede crear una nueva versión del archivo o proyecto y la etiqueta estará asociada con la nueva versión.
No puede ser editada o modificada por el usuario. | Puede ser editada en el cuadro de diálogo Detalles de historial.

Nota Algunos grupos de desarrollo de software etiquetan VSS con cada compilación. Puede obtener una funcionalidad equivalente con menor saturación si obtiene los archivos de un historial correspondientes a una fecha y hora específicas.

Para obtener más información acerca de cómo utiliza VSS la estampación de fecha y hora, consulte:

  • Cómo utiliza VSS la estampación de fecha y hora


Cómo utiliza VSS la estampación de fecha y hora

Vea también

Cuando obtiene o desprotege un archivo de VSS en su carpeta de trabajo VSS fija una fecha de modificación de la cual realiza un seguimiento para cada archivo el sistema operativo.

VSS utiliza las siguientes reglas para determinar la fecha y la hora que asigna a sus archivos:

  • Si ya tiene una copia local del archivo y es idéntica al archivo que está recuperando, VSS no hace nada, la fecha y la hora del archivo permanecen inalteradas.

  • Si VSS recupera el archivo (aún no lo tenía o su copia local no está actualizada), asigna la fecha y la hora actual en el momento de realizar la recuperación.

Porqué trabaja así VSS

La fecha y la hora de modificación la utilizan muchos compiladores y sistemas de compilación como una especie de señal de si un archivo ha cambiado y, por tanto, debe recompilarse. El tratamiento que realiza VSS de la fecha y la hora está diseñado para optimizar este proceso, asegurando así que la compilación sólo se realiza cuando es necesaria.

Cambiar la marca de fecha y hora

El comportamiento descrito anteriormente es el comportamiento predeterminado de VSS. Si tiene otras necesidades, puede cambiar el comportamiento con las opciones que se encuentran en la ficha Archivos locales del cuadro de diálogo Opciones del menú Herramientas o utilizando las opciones Avanzadas en algunos cuadros de diálogo, como el cuadro de diálogo Obtener.

Si su ordenador está desincronizado con otro ordenador se pueden producir resultados impredecibles. Por ejemplo, podría proteger un archivo después de que lo haya hecho alguien más, pero VSS podría considerar que usted lo había protegido primero, puesto que el reloj de su sistema estaba apagado. La mejor solución para este problema consiste en sincronizar regularmente su fecha y hora local con la de la red. Así se asegurará que todos los usuarios están sicronizados. Con NT esto puede realizarse con un Servidor de Tiempo del Dominio. Visite la dirección http://www.novell.com/corp/intl/spain para obtener más información sobre la sincronización horaria con servidores Novell NetWare.


Ver el historial del archivo

Cada archivo VSS mantiene un registro detallado de su historial. Desde el cuadro de diálogo Historial puede ver la información de versión, los comentarios y los detalles generales del historial de un archivo, así como obtener una versión antigua de un archivo o desprotegerlo.

Nota En el cuadro de diálogo Historial sólo se pueden desproteger archivos, no proyectos.

Desde el cuadro de diálogo también puede obtener, establecer diferencias, fijar, liberar, deshacer y crear informes de archivos.

Para obtener más información acerca de cómo ver el historial de un archivo, consulte:

  • Ver información de protección

  • Ver comentarios de protección

  • Ver los detalles del historial del archivo


Cómo ver el historial del archivo

Desde el cuadro de diálogo Historial, VSS le permite hacer lo siguiente:

  • Ver información de protección

  • Ver comentarios de protección

  • Ver los detalles del historial del archivo


Proyectos Web

Vea también

VSS tiene varias características diseñadas para asistir a los Webmasters y a los autores Web que están encargados de organizar y mantener un sitio World Wide Web. Generalmente, los sitios Web incluyen multitud de archivos HTML y gráficos organizados en varias carpetas. Como estos archivos cambian frecuentemente, VSS es un método ideal para mantener un seguimiento de las versiones de los archivos, archivarlos y seguir los cambios para solucionar los vínculos rotos y otros problemas.

La idea básica es que se recopila un conjunto de páginas HTML, gráficos y archivos de apoyo que forman un sitio Web y se incluyen en un proyecto VSS. Entonces, su administrador VSS designa ese proyecto como un proyecto de sitio Web. Una vez que lo ha hecho, se utiliza un icono especial ( [image]) en el Explorador de VSS para mostrar que el proyecto es un proyecto de sitio Web.

Cuando se selecciona un proyecto de sitio Web se activan los comandos del menú Web. Son los siguientes:

  • Comprobar hipervínculos — esto le permite comprobar los vínculos entre los archivos de los proyectos.

  • Crear mapa de sitios — permite crear un mapa de todos los archivos HTML que forman el proyecto.

  • Distribuir — le permite distribuir un conjunto de archivos Web en el servidor Web designado.

VSS también soporta una nueva forma de expansión de palabras clave que simplifica mucho el agregar a los archivos HTML la cadena "Actualizado por última vez el"

Para obtener más información acerca del trabajo con proyectos Web, consulte:

  • Comprobar hipervínculos en un proyecto Web

  • Crear un mapa del sitio

  • Distribuir archivos Web a un servidor

  • Utilizar la expansión de palabras clave en archivos HTML


Cómo trabajar con proyectos Web

Para obtener más información acerca del trabajo con proyectos Web, consulte:

  • Comprobar hipervínculos en un proyecto Web

  • Crear un mapa del sitio

  • Distribuir archivos Web a un servidor

  • Utilizar la expansión de palabras clave en archivos HTML


Escribir archivos de proceso por lotes

Vea también

En los archivos de proceso por lotes y las macros hay muchos motivos para modificar la forma en la que la línea de comandos interactúa con el usuario. A continuación hay algunos ejemplos:

  • Deshabilitar la entrada de datos — puede deshabilitar la entrada de datos para que los archivos de proceso por lotes puedan ejecutarse sin ser molestados, sin detenerse a esperar a que el usuario introduzca los datos.

  • Redireccionar el resultado — Puede redireccionar a un archivo el resultado de un programa.

  • Utilizar códigos de salida de la línea de comandos — Puede utilizar los códigos de salida de VSS para comprobar que el archivo de proceso por lotes se ha ejecutado correctamente.

Para obtener más información acerca de cómo trabajan los archivos de proceso por lotes, consulte:

  • Deshabilitar la entrada de dato

  • Redireccionar el resultado

  • Utilizar códigos de salida de la línea de comandos


Cómo trabajar con archivos de proceso por lotes

Para obtener más información acerca del trabajo archivos de proceso por lotes, consulte:

  • Deshabilitar la entrada de dato

  • Redireccionar el resultado

  • Utilizar códigos de salida de la línea de comandos


Tareas del Administrador de VSS

Como administrador de VSS, su trabajo consiste en hacer que la base de datos de VSS sea lo más útil posible para los clientes de VSS. Existen varios modos de cambiar el comportamiento de VSS, por ejemplo para permitir a los clientes realizar desprotecciones múltiples o para sacar provecho de las nuevas características Web de VSS.

Como administrador puede hacer lo siguiente:

  • Crear una base de datos nueva

  • Crear proyectos de sitios Web

  • Crear carpetas centrales

  • Personalizar los archivos SRCSAFE.INI o SS.INI

  • Activar la expansión de claves

  • Activar desprotecciones múltiples

  • Abrir una base de datos

  • Establecer tipos de archivos predeterminados


Cómo ejecutar tareas de administrador

Como administrador, puede hacer lo siguiente:

  • Crear una base de datos nueva

  • Crear proyectos de sitios Web

  • Crear carpetas centrales

  • Personalizar los archivos SRCSAFE.INI o SS.INI

  • Activar la expansión de claves

  • Activar desprotecciones múltiples

  • Abrir una base de datos

  • Establecer tipos de archivos predeterminados


Crear una base de datos nueva

Vea también

Como administrador de VSS, utilice el programa MkSS.exe con el fin de crear una nueva base de datos vacía.

Para crear una nueva base de datos vacía:

  1. Cree una carpeta para la nueva base de datos, llámela por ejemplo "data".

  2. Abra un ventana de petición de comando.

  3. En la petición de comando, vaya a la carpeta \Win32 de instalación de su servidor de VSS.

  4. Ejecute MkSS para la base de datos y su nueva carpeta.

    Por ejemplo, MkSS d:\vss\data

  5. Ejecute Ddnconv para la base de datos y la nueva carpeta.

    Por ejemplo, Ddnconv d:\vss\data

Nota Si actualiza al nuevo formato de VSS para la función Fast Get, debe ejecutar también el programa Ddupd después de completar los pasos 1 a 5.


Crear proyectos de sitios Web

Vea también

VSS incluye numerosas características que facilitan la administración de sitios World Wide Web. Por ejemplo, puede designar un proyecto de VSS específico como proyecto de sitio Web y a continuación crear rápidamente un mapa del sitio con los archivos HTML del proyecto (y de los subproyectos), comprobar los hipervínculos en los archivos de proyecto y una vez preparados transferir éstos a una ubicación de servidor de Internet. Para poder utilizar cualquiera de estas características, necesita designar primero el proyecto como un proyecto Web.

Para crear un proyecto de sitios Web:

  1. En el menú Herramientas del Administrador de VSS, haga clic en Opciones.

  2. Haga clic en la ficha Proyectos Web.

  3. Haga clic en Examinar para buscar el proyecto que desea designar como proyecto Web y a continuación haga clic en Aceptar para salir del cuadro de diálogo Establecer sitio Web en.

  4. Escriba una dirección de Web en el cuadro Dirección URL.

  5. Haga clic en Aceptar para salir del cuadro de diálogo Opciones de SourceSafe.

  6. Salga del Administrador y haga que todos sus clientes salgan y vuelvan a iniciar el explorador de VSS.

Debería ver un icono especial ( [image]) en el proyecto del explorador de VSS que designó como proyecto Web.

Nota Es necesario establecer un proxy si tiene previsto transferir los archivos mediante FTP. Vea la ficha Web en el cuadro de diálogo Opciones en el menú Herramientas.


Crear carpetas centrales

Vea también

El administrador de VSS es responsable de la creación de carpetas centrales ya que éstas afectan a todos los usuarios.

Una carpeta central es opcional. Se utiliza generalmente en una de las dos situaciones siguientes:

  • Para usuarios que desean ver los archivos, pero que no tienen acceso a VSS. Una carpeta central les permite ver archivos, pero no modificarlos.

  • Para impedir que las carpetas de trabajo puedan conservar sus propias copias del proyecto. Para asegurarse de que todos los usuarios disponen de las versiones más recientes, puede ser conveniente que todos los usuarios compilen el código fuente en una carpeta centralizada, en lugar de hacerlo en carpetas de trabajo personales.

Al establecer una carpeta central para un proyecto particular crea una asignación para el árbol de proyecto completo, a menos que modifique dicha asignación en un subproyecto.

Nota Asegúrese que todos los usuarios tienen derechos para Agregar o Proteger disponen de permisos de acceso a la carpeta central.

Para crear una carpeta central:

  1. En el menú Herramientas del Administrador de VSS, haga clic en Opciones con el fin de mostrar el cuadro de diálogo Opciones de SourceSafe.

  2. Haga clic en la ficha Carpetas centrales.

  3. En el cuadro Establecer la carpeta central para el proyecto, escriba el nombre del proyecto centralizado o bien haga clic en Examinar para buscar un proyecto en la lista de proyectos de VSS.

  4. En el cuadro Establecer la carpeta central en, escriba el nombre del proyecto que usará como proyecto central o bien haga clic en Examinar para buscar una carpeta.

  5. Haga clic en Aceptar y espere a que se genere la carpeta.


Personalizar el archivo SRCSAFE.INI o SS.INI

Vea también

VSS proporciona dos archivos de inicialización con valores que permiten personalizar su entorno de VSS:

  • SS.INI, para las variables de usuario individuales. Vea ejemplo de archivo SS.INI .

  • SRCSAFE.INI, para las variables globales de la base de datos de VSS. Vea Ejemplo de archivo SRCSAFE.INI.

Cada usuario posee un archivo SS.INI que puede modificar. Tan sólo el administrador de VSS debería modificar el archivo global SRCSAFE.INI.

Importante No se recomienda la modificación manual de los archivos de inicialización a menos que esté realmente familiarizado con las variables y comportamiento de las variables de inicialización de VSS. En lugar de ello, los usuarios puede establecer la mayor parte de las variables de inicialización directamente en el cuadro de diálogo Opciones de SourceSafe del explorador de VSS en el menú Herramientas. Los administradores de VSS pueden establecer las variables de SRCSAFE.INI en el cuadro de diálogo Opciones de SourceSafe del Administrador de VSS Opciones de SourceSafe en el menú Herramientas. Para obtener una lista de todas las variables de los archivos de inicialización, vea Variables de inicialización en la sección Guía de referencia de la Ayuda de VSS.

Cuando utiliza el cuadro de diálogo Opciones de SourceSafe, VSS guarda sus modificaciones en memoria, pero no los escribe en el archivo SS.INI o SRCSAFE.INI hasta que salga de VSS. Por consiguiente, si inicia una segunda sesión de VSS antes de salir de la primera, sus cambios siguen sin tomarse en cuenta. Los cambios sólo se toman en cuenta tras salir de VSS e iniciar una sesión nueva.

Puede leer y modificar los archivos de inicialización con cualquier editor de texto. La longitud de línea del archivo de inicialización tiene un límite de 511 caracteres, aunque dicho máximo puede llegar a verse restringido por el límite de 31 caracteres para los nombres de variables (como los en la ruta de proyecto).

Normalmente, los archivos SS.INI están ubicados en la carpeta secundaria "Users" de la carpeta en que instaló VSS. Cada usuario agregado por el administrador posee un archivo SS.INI en la carpeta secundaria "Users". Por ejemplo, si el administrado agrega un usuario llamado JoseMartin, su proprio archivo SS.INI está ubicado en la carpeta secundaria Users\JoseMartin de la carpeta VSS. La ubicación exacta del archivo SS.INI de cada usuario se registra en el archivo Users.txt, ubicado en la carpeta VSS. Puede mover su archivo SS.INI siempre que informe del cambio a VSS: para ello, debe modificar el archivo Users.txt.

En un servidor, el archivo SrcSafe.INI se coloca normalmente en la carpeta primaria de VSS.

Nota Los valores de las variables de inicialización en SS.INI modifican los valores del archivo SRCSAFE.INI.

Formato de archivo

Existen tres tipos de líneas en los archivos SS.INI y SRCSAFE.INI:

  • Las variables de inicialización, que son líneas funcionales, tienen el formato siguiente:
    Variable de inicialización = valor

    Los valores pueden establecerse como Yes, No, True o False.

  • Los comentarios empiezan con un carácter punto y coma (;):
    ; Se trata de una línea de comentario.

    VSS pasa por alto todos los comentarios.

  • Los encabezados se proporcionan entre corchetes:
    [$/Word]

    La mayoría de los encabezados especifican rutas de proyectos particulares. Otros encabezados, como [Keyword Comments], sirven propósitos específicos.

El orden de las variables dentro del archivo de inicialización no tiene importancia, sin embargo, sí la tiene el encabezado bajo el que se coloca una variable. Si coloca una variable bajo el encabezado incorrecto (por ejemplo, si coloca un variable de propósito general bajo [Keyword Comments]) dicha variable se pasa por alto.

SS.INI en plataformas múltiples

Si está ejecutando una instalación multiplataforma de VSS, probablemente querrá que ciertas variables tengan valores diferentes según la plataforma. En tal situación, puede colocar un especificador de plataforma entre paréntesis después de la variable con el fin de indicar que ésta sólo se aplica a la plataforma indicada, por ejemplo:

Use_ReadOnly (Win) = Yes

La configuración del ejemplo se aplica tan sólo bajo Microsoft Windows. Los valores incluyen UNIX, Win, NT, MAC y PC; éste último es genérico comodín para los sistemas operativos de los equipos personales.

VSS reconoce los nombres de equipo y los considera como especificadores de plataforma. Tan sólo se permiten 10 especificadores de plataforma por cada usuario, o 10 especificadores por cada archivo SS.INI.


Activar la expansión de claves

La expansión de claves hace referencia a la capacidad de VSS para colocar una determinada información directamente en su archivo con el fin sustituirlo por un encabezado de archivo. Para utilizar esta característica, coloque algunas claves dentro del texto de su archivo dentro de comentarios con el fin de que no afecten a su código. Cuando agrega o comprueba el archivo, VSS busca dichas claves y coloca la información relevante detrás de éstas.

La expansión de claves exige que VSS analice cada archivo en busca de claves, lo que puede ralentizar considerablemente los comandos Proteger y Agregar archivos.

Nota De modo predeterminado, la expansión de claves está desactivada para todos los archivos. Como administrador de VSS, después de activar la expansión de claves (desde el programa Administrador de VSS), debe indicar a VSS qué archivos deben analizarse en busca de claves.

Para activar la expansión de claves:

  1. En el menú Herramientas del Administrador de VSS, haga clic en Opciones.

  2. Haga clic en la ficha General si no está seleccionada.

  3. En el cuadro Expandir palabras clave en archivos de tipo, escriba los tipos de archivos en los que desea que ocurra la expansión de claves; por ejemplo, *.txt.

    Si utiliza más de una extensión, sepárelas con comas; por ejemplo, *.txt, *.c, *.bas.

  4. Haga clic en Aceptar.

Nota También puede activar la expansión de claves al agregar la línea Keyword_Masks = *.txt al archivo SRCSAFE.INI en el servidor. Colóquela delante la primera aparición de un encabezado de sección, por ejemplo, [$/MyProj]. Aquí de nuevo, si utiliza más de una extensión, sepárelas con comas.


Activar desprotecciones múltiples

De forma predeterminada, VSS impide que más de un único usuario pueda desproteger el mismo archivo al mismo tiempo. Sin embargo, como administrador de VSS puede permitir que múltiples usuarios puedan desproteger un archivo simultáneamente.

Nota Para activar desprotecciones múltiples a nivel de proyectos, debe modificar la variable .INI apropiada para cada uno de los proyectos en los que desea activar dicha característica.

Por ejemplo, para habilitar desprotecciones múltiples en el proyecto "Features", el archivo .INI debería mostrar:

[$/Features]
Multiple_Checkouts = yes

Para activar desprotecciones múltiples:

  1. En el menú Herramientas del Administrador de VSS, haga clic en Opciones.

  2. Haga clic en la ficha General si no está seleccionada.

  3. Active la casilla de verificación Permitir varias desprotecciones.

  4. Haga clic en Aceptar.


Abrir una base de datos

Para abrir una base de datos de VSS:

  1. En el menú Usuarios del Administrador de VSS, haga clic en Abrir base de datos de SourceSafe para mostrar el cuadro de diálogo Abrir base de datos de SourceSafe.

  2. Seleccione una base de datos en la lista.

    Nota Si la base de datos no se encuentra en la lista de bases disponibles, haga clic en Examinar. Explore hasta el archivo SRCSAFE.INI de una base de datos de VSS existente y a continuación haga clic en el archivo. Haga clic en Abrir para agregar una base de datos a la lista.

  3. Haga clic en Abrir en el cuadro de diálogo Abrir base de datos de SourceSafe.


Establecer tipos de archivo predeterminados: valores de administración

Vea también

Como administrador de VSS, puede establece tipos de archivos predeterminados para VSS. VSS compara a continuación los tipos predeterminados a los archivos de las listas que aparecen en numerosos cuadros de diálogo. Los valores predeterminados se aplican a todos los usuarios.

Los usuarios individuales pueden sin embargo cambiar o establecer su valores de tipos de archivos predeterminados mediante el comando Opciones del menú Herramientas del explorador de VSS.

Para establecer tipos de archivo predeterminados para todos los usuarios:

  1. En el menú Herramientas del Administrador de VSS, haga clic en Opciones con el fin de mostrar el cuadro de diálogo Opciones de SourceSafe.

  2. Haga clic la ficha Tipos de archivos.

  3. Escriba o seleccione la información aplicable en esta ficha, incluyendo:
    • Archivos binarios

      Escriba máscaras de tipos para aquellos archivos que desea que VSS considere como binarios. De forma predeterminada, cuando VSS necesita conocer el tipo del archivo, utiliza el mecanismo de detección automática. Sin embargo, al escribir valores en este campo, informa a VSS de que debe considerar como binarios todos los archivos del tipo indicado. Por ejemplo, si escribe *.obj y *.exe, VSS siempre trata a los archivos con dichas extensiones como binarios.

    • Grupos de archivos

      Seleccione un grupo de archivos al que desea asignar máscaras de archivos. Los botones Agregar y Eliminar permiten agregar o eliminar grupos de archivos, con una sola excepción: no puede eliminar el grupo <Máscaras relevantes>. Este grupo se proporciona para su comodidad. Le permite crear un grupo con los archivos que utiliza más a menudo; este grupo de <Máscaras relevantes> se convierte en el grupo de los tipos de archivo predeterminados en los cuadros de diálogo Agregar archivos, Compartir y otros que se utilizan para manejar archivos entre proyectos.

    • Tipos de archivo incluidos en grupo de archivos

      Escriba máscaras de archivos en este campo para el grupo seleccionado en el cuadro Grupos de archivos. Por ejemplo, cuando hace clic en archivos de Visual Basic en el cuadro Grupos de archivos, escriba los tipos de archivos que constituyen este grupo: *.bas, *.frm, *.frx.

  4. Haga clic en Aceptar.


Instalación

Antes de poder instalar y utilizar VSS en un equipo de usuario (instalación de cliente), usted mismo como administrador de VSS debe instalar primero la base de datos de control de código fuente administrada por VSS en una unidad a la que tiene acceso todos los usuarios de VSS (instalación del servidor).

El método de trabajo más versátil con VSS consiste en realizar una instalación del servidor en una unidad de red y a continuación una instalación de cliente en cada estación de trabajo. Actualmente, tan sólo se requiere configurar el servidor; pero contar con una única configuración de servidor puede generar grandes cantidades de tráfico de red lo que algunas veces perjudica el rendimiento. Con el fin de evitar los grandes volúmenes de tráfico de red, realice una instalación de cliente en cada estación de trabajo además de instalar los servidores.

El programa de instalación detecta la plataforma en que se ejecuta (Intel o Alpha, por ejemplo) e instala tan sólo los archivos y ejecutables necesarios para dicha plataforma. Por consiguiente, si tiene previsto utilizar VSS en un entorno de plataforma mixta (equipos Alpha e Intel, que utilizan todos la misma base de datos de VSS, por ejemplo), debe instalar el servidor una vez por cada tipo diferente de plataforma de su entorno y apuntar a la misma ubicación de servidor. Podrá entonces contar con todos los archivos binarios que necesitan sus clientes.

Nota La instalación de archivos binarios no modifica ningún dato existente que pueda tener.

Para obtener información acerca de cómo instalar VSS, consulte:

  • Instalación de cliente desde un disco. Permite a los usuarios instalar desde un CD a una unidad de disco de su equipo de cliente tan sólo los archivos necesarios para ejecutar VSS. La instalación de cliente no instala la base de datos de VSS.

  • Instalación de cliente desde una red. Permite a los usuarios instalar desde la red a una unidad de disco de su equipo de cliente tan sólo los archivos necesarios para ejecutar VSS. La instalación de cliente no instala la base de datos de VSS.

  • Instalación del servidor. Permite al administrador de VSS instalar VSS en un equipo al que pueden acceder todos los usuarios.

  • Instalación personalizada. Permite al administrador de VSS seleccionar las partes de la instalación del servidor que desea instalar.


Cómo instalar VSS

Durante la instalación, VSS le pide que elija el tipo de instalación que desea realizar. Seleccione una de las posibilidades siguientes:

  • Instalación de cliente desde un disco. Permite a los usuarios instalar desde un CD a una unidad de disco de su equipo de cliente tan sólo los archivos necesarios para ejecutar VSS. La instalación de cliente no instala la base de datos de VSS.

  • Instalación de cliente desde una red. Permite a los usuarios instalar de la red a una unidad de disco de su equipo de cliente tan sólo los archivos necesarios para ejecutar VSS. La instalación de cliente no instala la base de datos de VSS.

  • Instalación del servidor. Permite al administrador de VSS instalar VSS en un equipo al que pueden acceder todos los usuarios.

  • Instalación personalizada. Permite al administrador de VSS seleccionar las partes de la instalación del servidor que desea instalar.

En función de la opción de instalación elegida, VSS instala carpetas en ubicaciones de proyecto específicas; vea Carpetas instaladas por el programa de instalación para obtener detalles.


Instalación de cliente desde un disco

Vea también

Esta opción instala a una unidad de disco de un equipo de cliente tan sólo los archivos necesarios para ejecutar VSS. No instala la base de datos de VSS ni los archivos auxiliares. Normalmente, es el propio usuario de VSS quién realiza la instalación de cliente, y no un administrador.

Nota La instalación de cliente debería hacerse después de un instalación de servidor y no puede utilizarse independientemente.

Elija esta opción en las situaciones siguientes:

  • Tiene un tráfico muy pesado en su red. La opción de cliente puede ayudarle a reducir la carga de red y mejorar el rendimiento del equipo de cliente en relación con la ejecución de VSS desde un servidor.

  • Realiza la integración de VSS con Microsoft Access, Visual FoxPro, Visual Test, Visual Basic o Visual C++. La instalación de cliente (bien desde un CD o mediante Netsetup) es necesaria para que VSS pueda funcionar correctamente con Visual Basic o Visual C++.

    Importante Para integrar VSS con Visual Basic, realice primero una instalación de servidor de VSS, instale Visual Basic y ejecute Netsetup o bien ejecute una instalación de cliente desde disco. Para integrar VSS con Visual C++, puede ejecutar Netsetup o realizar una instalación de cliente desde disco tanto antes como después de instalar Visual C++. Para obtener más información acerca de la integración de VSS con Visual Basic, Visual C++, Visual FoxPro, Visual Test y Microsoft Access, vea la documentación de dichos productos.

Para realizar una instalación de cliente desde disco:

  1. Introduzca el CD en la unidad CDROM.

  2. Haga doble clic en Instalar.exe.

  3. Siga las instrucciones de instalación en el asistente de instalación.

  4. Cuando el programa le pregunte el tipo de instalación que desea, haga clic en Cliente.


Instalación de cliente desde una red

Vea también

Esta opción instala a una unidad de disco de un equipo de cliente tan sólo los archivos necesarios para ejecutar VSS. No instala la base de datos de VSS ni los archivos auxiliares. Normalmente, es el propio usuario de VSS quién realiza la instalación de cliente, y no un administrador.

El programa Netsetup realiza una instalación de cliente a través de una red. Netsetup no necesita que disponga de un disco de instalación en su equipo.

Nota Netsetup debe ejecutarse después de una instalación de servidor.

Elija esta opción en las situaciones siguientes:

  • Tiene un tráfico muy pesado en su red. La opción de cliente puede ayudarle a reducir la carga de red y mejorar el rendimiento del equipo de cliente en relación con la ejecución de VSS desde un servidor.

  • Realiza la integración de VSS con Microsoft Access, Visual FoxPro, Visual Test, Visual Basic o Visual C++. La instalación de cliente (bien desde un CD o mediante Netsetup) es necesaria para que VSS pueda funcionar correctamente con Visual Basic o Visual C++.

    Importante Para integrar VSS con Visual Basic, realice primero una instalación de servidor de VSS, instale Visual Basic y ejecute Netsetup o bien ejecute una instalación de cliente desde disco. Para integrar VSS con Visual C++, puede ejecutar Netsetup o realizar una instalación de cliente desde disco tanto antes como después de instalar Visual C++. Para obtener más información acerca de la integración de VSS con Visual Basic, Visual C++, Visual FoxPro, Visual Test y Microsoft Access, vea la documentación de dichos productos.

Para realizar una instalación de cliente desde una red:

  1. En la carpeta del servidor en la que instaló VSS haga doble clic en Netsetup.

  2. Siga la instrucciones de instalación en el asistente de instalación.


Instalación personalizada

Vea también

La opción le permite instalar tan sólo aquellas partes de VSS que desea. Ofrece las opciones siguientes y muestra la cantidad de espacio necesaria en disco para cada una:

  • Crear una base de datos de VSS

  • Instalación del programa cliente

  • Instalación del programa administrador

  • Activar la integración de VSS

  • Archivos de Ayuda

  • Herramientas de conversión (Pvcs y Delta)

  • Instalación de cliente de red

Utilice la opción de instalación personalizada cuando desea omitir algunas partes de la instalación del servidor.

Nota La opción de instalación personalizada es el único modo de instalar la base de datos de VSS en su disco duro y poder integrarla con Visual Basic y Visual C++. Para obtener más información acerca de la integración de VSS con Visual Basic y Visual C++, vea la documentación de dichos productos.

Para realizar una instalación personalizada:

  1. Introduzca el CD de VSS en la unidad CDROM.

  2. Haga doble clic en Instalar.exe.

  3. Siga la instrucciones de instalación en el asistente de instalación.

  4. Cuando el programa le pregunte el tipo de instalación que desea, haga clic en Personalizada.

  5. Active las opciones personalizadas que desea instalar y a continuación haga clic en Continuar.


Instalación del servidor

Vea también

Como administrador de VSS, utilice este método con el fin de instalar VSS en un equipo al que pueden acceder todos los usuarios.

Para realizar una instalación del servidor:

  1. Introduzca el CD de VSS en la unidad CDROM del servidor o de un equipo conectado al servidor.

  2. Haga doble clic en Instalar.exe.

  3. Siga la instrucciones de instalación en el asistente de instalación.

  4. Cuando el programa le pregunte el tipo de instalación que desea, haga clic en Servidor.


Carpetas instaladas por el programa de instalación

La estructura de directorio de VSS instalada por el programa de instalación es parecida para las dos opciones de servidor y de cliente. La persona que realiza la instalación especifica la carpeta en la que debe instalarse VSS. En un servidor, todas las carpetas y archivos deben estar presentes. En un cliente, tan sólo se instalan las carpetas \Win32 y \Setup.

La tabla siguiente da la lista y el contenido de las carpetas de VSS en las instalaciones más comunes.

Listado y contenido de las carpetas de VSS en instalaciones comunes

Carpeta | Contenido | Tipo de instalación
\Data | Base de datos de todos los archivos y proyectos | Servidor
\Users | Archivos de inicialización de usuario (SS.INI) | Servidor
\Temp | Archivos temporales | Servidor
\Win32 | Programas de aplicaciones Intel de 32 bits de Windows 95 y Windows NT | Servidor, cliente
\Setup | Archivos utilizados por el programa Setup.exe para instalar componentes adicionales o el programa de desinstalación de VSS | Servidor, cliente
\Netsetup | Archivos usados por el programa Netsetup.exe para instalar VSS en un equipo de cliente | Servidor
\Ntaxp | Programas RISC para Windows NT en AXP | Servidor


Mantenimiento de la lista de usuarios: tareas básicas

La lista de usuarios del Administrador de VSS le permite controlar quién tiene acceso a la base de datos de VSS, así como el nivel de acceso del que dispone. El Administrador de VSS le permite agregar y eliminar usuarios de la lista de usuarios, asignar derechos de acceso a usuarios específicos y cambiar sus contraseñas para VSS.

  • Cuando agrega un usuario nuevo, VSS crea automáticamente un archivo SS.INI para dicho usuario basado en la plantilla predeterminada del archivo SS.INI de la carpeta \VSS\Users. Puede modificar esta plantilla con el fin de crear un archivo SS.INI predeterminado diferente para cada usuario nuevo. Para obtener más información, vea Personalizar los archivos SRCSAFE.INI

Para obtener información acerca de cómo administrar la lista de usuarios de VSS, consulte:

  • Agregar un usuario

  • Cambiar contraseñas

  • Crear una lista de usuarios

  • Eliminar un usuario

  • Modificar los atributos de usuario


Cómo mantener la lista de usuarios

Como administrador de VSS, lleva a cabo el mantenimiento de la lista de usuarios de VSS mediante cualquiera de las tareas siguientes:

  • Agregar un usuario

  • Cambiar contraseñas

  • Crear una lista de usuarios

  • Eliminar un usuario

  • Modificar los atributos de usuario


Agregar un usuario

Vea también

Para agregar un usuario a una base de datos de VSS:

  1. Asegúrese de que está seleccionada la base de datos correcta en el Administrador de VSS. Para obtener más información, vea Abrir una base de datos de VSS.

  2. En el menú Usuarios del Administrador de VSS, haga clic en Agregar usuario con el fin de mostrar el cuadro de diálogo Agregar usuario.

  3. Escriba un nombre en el cuadro Nombre de usuario. Puede también escribir una contraseña en el cuadro Contraseña.

    Nota Los nombres de usuario puede tener hasta 32 caracteres de longitud, no pueden empezar o acabar por un espacio ni incluir caracteres de puntuación. Una contraseña puede tener hasta 15 caracteres de longitud y contener cualquier carácter.

  4. Para otorgar derechos de sólo lectura al usuario, active la casilla de verificación Sólo lectura.

    Nota Si no activa dicha casilla de verificación, el nuevo usuario dispone de derechos de lectura y escritura. Vea Derechos de acceso de seguridad para obtener más información.

  5. Haga clic en Aceptar.


Cambiar contraseñas

Vea también

La seguridad en VSS descansa en contraseñas almacenadas con los datos. Todos los usuarios deben tener una contraseña que le proporciona acceso a VSS. No hay forma de determinar cuál es la contraseña de un usuario. Si un usuario olvida su contraseña, el administrador de VSS puede utilizar este cuadro de diálogo con el fin de asignarle una contraseña nueva. No puede recuperar una contraseña antigua.

En muchos casos, puede ser interesante cambiar la contraseña por una que sea muy sencilla, como el propio nombre de usuario y comunicar al usuario que cree una nueva contraseña desde VSS. Remita a los usuarios al tema Cómo cambiar su contraseña para obtener instrucciones acerca de cómo modificar sus contraseñas.

Como administrador, posee una contraseña especial que sirve para ejecutar el Administrador de VSS. Debe escribir la contraseña antigua con el fin de poder modificarla. Si no puede recordar su contraseña anterior, póngase en contacto con el servicio de soporte técnico de Microsoft.


Cambiar la contraseña de administrador

Para obtener una explicación acerca de este procedimiento, vea Cambiar contraseñas.

Para cambiar la contraseña de administrador:

  1. En la lista de usuarios del Administrador de VSS, seleccione el usuario Admin.

  2. En el menú Usuarios, haga clic en Cambiar contraseña para mostrar el cuadro de diálogo Cambiar contraseña

  3. En el cuadro Contraseña anterior, escriba la contraseña anterior.

  4. En el cuadro Contraseña nueva, escriba la contraseña nueva.

  5. En el cuadro Confirmar contraseña, escriba de nuevo la contraseña nueva para comprobarla.

  6. Haga clic en Aceptar.


Cambiar la contraseña de un usuario

Para obtener una explicación acerca de este procedimiento, vea Cambiar contraseñas.

Para cambiar la contraseña de un usuario:

  1. En la lista de usuario del Administrador de VSS, seleccione un usuario.

  2. En el menú Usuarios, haga clic en Cambiar contraseña para mostrar el cuadro de diálogo Cambiar contraseña

  3. En el cuadro Contraseña nueva, escriba la contraseña nueva.

  4. En el cuadro Confirmar contraseña, escriba de nuevo la contraseña nueva para comprobarla.

  5. Haga clic en Aceptar.

Nota Si indica a VSS que utilice el nombre de usuario de red, permite pasar por alto el cuadro de diálogo de inicio de sesión de VSS.


Crear una lista de usuarios

Vea también

Para crear una lista de usuarios de VSS:

  1. Seleccione la base de datos deseada en el Administrador de VSS. Para obtener más información, vea Abrir una base de datos de VSS.

  2. En el menú Usuarios del Administrador de VSS, haga clic en Agregar usuario con el fin de mostrar el cuadro de diálogo Agregar usuario.

  3. Escriba el nombre del primer usuario en cuadro Nombre de usuario. Un nombre de usuario puede tener hasta 31 caracteres de longitud, no puede empezar o terminar con un espacio ni incluir ningún carácter de puntuación.

  4. Escriba la contraseña del usuario en el cuadro Contraseña. Una contraseña puede tener hasta 15 caracteres de longitud y contener cualquier carácter.

  5. Para otorgar derechos de sólo lectura al usuario, active la casilla de verificación Sólo lectura.

    Nota Si no activa dicha casilla de verificación, el nuevo usuario dispone de derechos de lectura y escritura. Vea Derechos de acceso de seguridad para obtener más información

  6. Haga clic en Aceptar.

  7. Repita los pasos 1 a 6 hasta tener completa la lista de usuarios de VSS.


Eliminar usuario

Vea también

Cuando elimina un usuario de la lista de usuarios, VSS elimina automáticamente el archivo SS.INI creado para dicho usuario.

Nota No puede eliminar al usuario Admin.

Para eliminar un usuario:

  1. Seleccione un usuario en la lista del Administrador de VSS.

  2. En el menú Usuarios, haga clic en Eliminar usuario.

  3. VSS muestra un cuadro de advertencia y le pregunta "¿Realmente desea eliminar?"

  4. Haga clic en Sí.


Modificar los atributos de usuario

Vea también

Para modificar los atributos de usuario:

  1. Seleccione un usuario en la lista del Administrador de VSS.

  2. En el menú Usuarios, haga clic en Modificar usuario para mostrar el cuadro de diálogo Modificar usuario.

  3. Active la casilla Sólo lectura para otorgar derechos de sólo lectura al usuario. (De forma predeterminada, VSS otorga derechos de lectura y escritura a los usuarios nuevos).

    -O bien-

    Cambie el nombre del usuario: para ello, escriba un nuevo nombre.

  4. Haga clic en Aceptar. VSS modifica los derechos del usuario, su nombre de inicio de sesión, o ambos a la vez.


Administrar la base de datos

Como administrador de VSS, su trabajo consiste en administrar la base de datos. Esto comprende el análisis de la carpeta de datos en busca de señales de corrupción, la operación de archivo de la base de datos cuando alcanza un gran tamaño y la limpieza de la carpeta Temp.

Puede ser necesario bloquear la base de datos antes de poder realizar alguna de esas acciones con el fin de impedir que las acciones de los usuarios puedan interferir.

Algunas veces, un usuario deja un archivo desprotegido inadvertidamente. Si no es posible encontrar al usuario, el administrador de VSS puede deshacer la desprotección del usuario.

Para obtener información acerca de cómo administrar la base de datos, consulte:

  • Analizar la carpeta de datos

  • Archivar bases de datos

  • Limpiar la carpeta temporal

  • Bloquear una base de datos

  • Restaurar bases de datos

  • Deshacer la desprotección de un archivo o de un proyecto

  • Uso de DDUPD para beneficiarse de las mejoras de rendimiento y de la promoción de etiquetas

  • Trabajar con bases de datos múltiples


Cómo administrar la base de datos

Como administrador de VSS, administra la base de datos de VSS al realizar las tareas siguientes:

  • Analizar la carpeta de datos

  • Archivar bases de datos

  • Limpiar la carpeta temporal

  • Bloquear una base de datos

  • Restaurar bases de datos

  • Deshacer la desprotección de un archivo o de un proyecto

  • Uso de DDUPD para beneficiarse de las mejoras de rendimiento y de la promoción de etiquetas

  • Trabajar con bases de datos múltiples


Analizar la carpeta de datos

Vea también

Nota Se recomienda fuertemente realizar de modo regular una copia de seguridad completa de la carpeta Data.

La carpeta de datos de VSS contiene la base de datos de todos sus archivos y proyectos. Aunque todas las precauciones se tomaron para asegurarse de la integridad de los archivos de VSS, puede producirse una corrupción de éstos causada por la red o el sistema operativo. La utilidad Analyze.exe permite buscar y corregir cualquier corrupción o error.

Para ejecutar Analyze.exe:

  1. Impida la conexión de todos los usuarios y pídales que salgan de VSS. Vea Bloquear una base de datos para obtener más información.

    Nota Los usuarios de VSS pueden tener archivos desprotegidos cuando se bloquea una base de datos.

  2. Abra un ventana de petición de comando con el fin de ejecutar la utilidad Analyze.

    Por ejemplo, podría escribir:

    C:\vss\win32\analyze ..\data

El programa explora la base de datos de VSS e informa de cualquier problema potencial. Si descubre errores o archivos corruptos puede corregirlos mediante los parámetros -F, -C y -D.

Recomendamos ejecutar Analyze dos veces: la primera vez con la opción -F (con el fin de corregir cualquier error que se encuentre) y la segunda vez para comprobar si quedan errores. Si sigue encontrando errores después de una primera ejecución, examine el artículo Q152807 de la Microsoft Knowledge Base para obtener más información.


Archivar bases de datos

Vea también

Periódicamente, conviene hacer una copia de seguridad de la base de datos de VSS en totalidad o en parte. Ahora es posible archivar bases de datos desde el programa Administrador de VSS. En las versiones anteriores de VSS, los programas Archive y Restore estaban disponibles desde la línea de comandos tan sólo.

La operación de archivo le permite:

  • Ahorrar el espacio disco del servidor de la base de datos de VSS.

  • Hacer que el comando Mostrar historial funcione más rápidamente.

  • Transferir archivos y proyectos entre bases de datos de VSS, manteniendo la información de historial intacta.

  • Hacer una copia de seguridad de parte o de la totalidad de la base de datos de VSS en un archivo comprimido

Para archivar una base de datos:

  1. Abra la base de datos cuya información desea archivar. Vea Cómo abrir una base de datos para obtener más información.

  2. En el menú Archivar, haga clic en Archivar proyectos para mostrar el Asistente para archivar.

  3. Seleccione el proyecto que desea archivar.

  4. Haga clic en Aceptar.

  5. Si existen proyectos adicionales que desea agregar al archiva, hágalo en el paso 1 del asistente.

  6. Haga clic en Siguiente.

  7. En el paso 2 del asistente, especifique cómo desea archivar el proyecto.

  8. Si está activada la casilla Guardar datos en archivo o Guardar datos en archivo y después eliminar de la base de datos para ahorrar espacio, escriba el nombre del archivo en el que deben guardarse los proyectos en el cuadro Archivo de almacenamiento.

    -O bien-

    Haga clic en Examinar par buscar y seleccionar un archivo almacenado. Esto sobrescribirá los archivos existentes.

    -O bien-

    Si está activada la casilla Eliminar datos definitivamente, se deshabilitará el cuadro Archivo de almacenamiento.

  9. Haga clic en Siguiente.

  10. En el paso 3 del asistente, especifique la versión de los datos que desea archivar (intervalo de versión). Puede también agregar un comentario en el cuadro Comentario si lo desea.

Nota Para archivar por el número de versión, escriba tan sólo el número en el cuadro de versión, por ejemplo: 5. Para archivar por etiqueta, escriba L seguido de la cadena de la etiqueta, por ejemplo: "LmiEtiqueta". Para archivar por fechas, escriba D seguido de una cadena de fecha, por ejemplo: D26/11/98.

  11. Haga clic en Finalizar para completar la operación de archivo.


Limpiar la carpeta temporal

Vea también

Como administrador de VSS, tiene la responsabilidad de limpiar la carpeta Temp apuntada por la variable de inicialización Temp_Path en el archivo SRCSAFE.INI.

VSS coloca normalmente archivos en la carpeta Temp durante su ejecución y los elimina antes de salir. Algunas circunstancias, como la necesidad de reiniciar, pueden hacer que archivos permanezcan en la carpeta Temp, malgastando el espacio de disco.

Limpie la carpeta Temp cada pocas semanas, cuando no hay usuarios ejecutando VSS o el Administrador de VSS.

Para limpiar la carpeta temporal:

  1. En el menú Herramientas, haga clic en Limpiar directorio de temporales para mostrar el cuadro de diálogo Limpiar directorio local de archivos temporales.

  2. Haga clic en Aceptar.


Bloquear una base de datos

Vea también

El bloqueo de una base de datos no evita automáticamente el acceso de aquellos usuarios que tengan iniciada una sesión en ese momento. El administrador de VSS debería pedir a los usuarios que salgan de VSS antes de cerrar la base de datos.

Para bloquear una base de datos de VSS:

  1. En el menú Herramientas del Administrador de VSS haga clic en Bloquear la base de datos de SourceSafe para mostrar el cuadro de diálogo Bloquear la base de datos de Visual SourceSafe.

  2. Active la casilla Evitar la conexión para todos los usuarios de Visual SourceSafe.

  3. Haga clic en Cerrar.

    Importante Deberá desactivar la casilla de verificación Evitar la conexión para todos los usuarios de Visual SourceSafe antes de que sus usuarios puedan de nuevo acceder a VSS.


Restaurar bases de datos

Vea también

Puede ahora restaurar bases de datos mediante el programa Administrador de VSS. En las versiones anteriores de VSS, los programas Archive y Restore estaban disponibles desde la línea de comandos tan sólo.

Para restaurar una base de datos:

  1. Abra la base de datos en la que desea restaurar información. Vea Cómo abrir una base de datos para obtener más información.

  2. En el menú Archivar haga clic en Restaurar proyectos para mostrar el Asistente para restaurar.

  3. Haga clic en Examinar para seleccionar el archivo almacenado que desea restaurar.

  4. Haga clic en Abrir.

  5. En el paso 1 del asistente, haga clic en Siguiente.

  6. En el paso 2 del asistente, seleccione el proyecto o los proyectos que desea restaurar.

  7. Haga clic en Siguiente.

  8. En el paso 3 del asistente, especifique dónde desea restaurar los proyectos. Puede también agregar un comentario en cuadro Comentario si lo desea.

  9. Haga clic en Finalizar para completar la restauración.


Deshacer la desprotección de un archivo o de un proyecto

Vea también

Para deshacer la desprotección de un archivo o de un proyecto:

  1. Inicie la sesión en el explorador de VSS como usuario Admin, mediante la contraseña de administrador si existe.

  2. Seleccione el archivo desprotegido en proyecto apropiado.

  3. En el menú SourceSafe haga clic en Deshacer desprotección.


Uso de DDUPD para beneficiarse de las mejoras de rendimiento y de la promoción de etiquetas

Vea también

Para beneficiarse de las mejoras de rendimiento de VSS 6.0 y de la promoción de etiquetas, ejecute la herramienta de la línea de comandos DDUPD.exe con el fin de actualizar su base de datos. DDUPD.exe está ubicado en la carpeta \Win32 de instalación de su servidor de VSS. Es posible usar también DDUPD para deshacer una actualización.

Nota Pida a los usuarios que salgan de VSS antes de ejecutar DDUPD.

Para ejecutar DDUPD.exe:

  1. Vaya a la carpeta \Win32 de su instalación del servidor de VSS en una ventana de petición de comando.

  2. Escriba lo siguiente:
    DDUPD <ruta del directorio de datos> [-undo] [-redo]

Para actualizar un base de datos, por ejemplo, escriba:

   DDUPD \\server\share\vss\data

Para deshacer una actualización (para dejar de beneficiarse de las mejoras de rendimiento y de la promoción de etiquetas), escriba:

   DDUPD \\server\share\vss\data -UNDO

Si encuentra problemas en los que proyectos con subproyectos no aparecen en la lista con el símbolo de expansión correcto ([+] o [-]) o tiene problemas para obtener las etiquetas, puede ser necesario ejecutar DDUPD de nuevo con el fin de corregir la presentación, o bien escribir:

   DDUPD \\server\share\vss\data -REDO


Trabajar con bases de datos múltiples

Vea también

Una instalación predeterminada de VSS almacena todos sus archivos en una base de datos centralizada. Si es posible, almacene siempre todos sus archivos de proyecto en una sala base de datos. Esto suele ser preferible a disponer de más de una base de datos debido a las limitaciones inherentes de los sistemas de bases de datos múltiples:

  • No puede compartir archivos entre bases de datos múltiples.

  • Es difícil volcar bases de datos múltiples en un sistema centralizado único (es necesario utilizar la herramienta Archive).

  • Por razones de seguridad, la lista de usuarios de VSS y las contraseñas se almacenan con los datos. Este acercamiento representa una ventaja considerable si la separación de bases de datos se debe a razones de seguridad, pero debe agregar usuarios nuevos de forma separada para cada base de datos.

Por estas razones, el método recomendado es organizar sus archivos en proyectos dentro de una única base de datos siempre que sea posible hacerlo. En algunas ocasiones, sin embargo, es requisito contar con más de una base de datos. Por ejemplo, las organizaciones de gran tamaño grande pueden necesitar descentralizarlas, en especial cuando las personas trabajan en muchos proyectos relativamente poco ligados entre ellos.


Propagación de derechos

Vea también

Cuando agrega un usuario nuevo y establece los derechos de dicho usuario para un proyecto particular, crea una asignación en la base de datos de VSS. Dicha asignación se propaga por los niveles secundarios del proyecto mientras no encuentre otra asignación.

Tome el ejemplo en que asignó los derechos de Agregar (RCA) al usuario María en $/, el proyecto primario. En el proyecto $/Samples no le dio una asignación explícita, por lo que tiene automáticamente los mismos derechos (RCA) que en el proyecto primario, $/. Sin embargo, en el proyecto $/Samples/BusinessObject, establece una nueva asignación y le otorga derechos de sólo lectura (R).

Esta acción impide que la asignación en el proyecto primario $/Samples pueda propagarse por los niveles secundarios del árbol, de modo que posee derechos de sólo lectura en el proyecto $/Samples/BusinessObjects y en cualquier otro proyecto secundario.

En el proyecto $/NorWind, no hizo ninguna asignación específica para María, por lo que sus derechos en el proyecto primario ($/) se propagan por el árbol hasta el proyecto $/NorWind. Por consiguiente, posee derechos RCA en $/NorWind y en los subproyectos.

Los derechos de acceso se propagan siempre del mismo modo y lo derechos de un usuario en el proyecto primario ($/) constituye un conjunto de derechos predeterminados para dicho usuario. Estos derechos predeterminados sólo se aplican a todos los proyectos para los que no estableció asignaciones explícitamente.

Cuando agrega por primera vez un usuario, dicho usuario recibe derechos para el proyecto primario basados en los derechos predeterminados que estableció en la ficha Seguridad del proyecto. Es posible, en su caso, cambiar los derechos de usuario con el fin de modificar globalmente el nivel de permisos del usuario.


Ejemplos de archivos SS.INI y SRCSAFE.INI

Se proporcionan ejemplos para:

  • Archivo SS.INI

  • Archivo SRCSAFE.INI


Ejemplo de archivo SS.INI

Vea también

El ejemplo siguiente muestra un archivo SS.INI de ejemplo.

; SS.INI
;
; Este archivo contiene todas las variables que permiten "personalizar" Visual SourceSafe
; para sus necesidades particulares. La documentación acerca de las variables de SS.INI están incluidas en la
; Ayuda en línea. Este archivo incluye tan sólo unas pocas variable de modo predeterminado.

; Conviene que los programadores en C eliminen el punto y coma
; de la línea siguiente, con el fin de quitarle el comentario.
; Otros programadores pueden SUSTITUIR la línea por máscaras diferentes.
; Relevant_Masks = *.c, *.h, *., *.asm

; La línea siguiente evita que el programa le pida un comentario
; al desproteger.
Checkout_Comment = -

Project = $/Samples
Maximized (Win) = No
Sort_Order = Date
[$/Features]
[$/MyProject]

Si ejecuta una instalación multiplataforma de VSS, puede que utilice un archivo SS.INI bajo numerosos sistemas operativos distintos. En tal caso, probablemente le convenga que ciertas variables posean valores diferentes en plataformas diferentes. Puede colocar un identificador entre paréntesis después del nombre de la variable con el fin de indicar que la variable debería aplicarse tan sólo a la plataforma a la que dicho identificador hace referencia. Por ejemplo:

Use_ReadOnly (NT) = Yes

Dicho valor tal y como se especifica se aplica tan sólo bajo Microsoft Windows 95 y Windows NT. El mismo archivo SS.INI puede tener otros valores para otras plataformas o situaciones. Puede por ejemplo establecer variables de inicialización con el fin de distinguir entre la línea de comandos (CL) y el explorador (UI). Por ejemplo:

Force_Dir (UI) = No
Force_Dir (CL) = Yes

Si los valores anteriores son los únicos con expresiones entre paréntesis que aparecen dentro de su archivo SS.INI, Force_Dir tiene el valor No cuando ejecuta el explorador y el valor Yes cuando invoca VSS desde la línea de comandos. Sin embargo, si en el archivo aparece una línea Force_Dir que contiene (por ejemplo) el nombre de su equipo o "NT", ésta tiene prioridad sobre las dos líneas mencionadas en este ejemplo.

VSS considera los nombres de equipo como especificadores de plataforma. Tan sólo se permiten 10 especificadores de plataforma por cada usuario, o un total de 10 especificadores por archivo SS.INI.


Ejemplo de archivo SRCSAFE.INI

Vea también

El ejemplo siguiente muestra un archivo SRCSAFE.INI de ejemplo.

; SRCSAFE.INI
;
; Tres de estas variables (Data_Path, Users_Path y Users_Txt) deben
; aparecer en SRCSAFE.INI, y es posible modificar cualquiera de éstas en el archivo SS.INI.
; De forma similar, cualquier variable de SS.INI puede colocarse en un archivo SRCSAFE.INI con el fin de establecer un
; valor "predeterminado" por el sistema que los usuarios individuales pueden seguir modificando en el archivo SS.INI.

; Las dos rutas importantes utilizadas por SourceSafe.
Data_Path = data
Temp_Path = temp

; Esto indica al administrador dónde debe ubicar los directorios personales de los usuarios nuevos.
Users_Path = users

; Desde éste, encuentra el archivo users.txt; el cual a su vez le permite encontrar el archivo SS.INI correspondiente a un usuario.
Users_Txt = users.txt

; La línea siguiente contiene agrupaciones de archivos comunes.
File_Types = Visual Basic (*.bas;*.cls;*.frm;*.frx;*.res;*.vbp;*.mak), Visual C++ (*.cpp;*.c;*.hpp;*.h;*.rc;*.mak), Visual FoxPro (*.h;*.pjt;*.pjx;*.prg;*.frx;*.frt;*.scx;*.sct;*.vcx;*.vct;*.lbx;*.lbt;*.qpr;*.mnx;*.mnt), Visual Test (*.mst;*.inc)
Img_File = HTMLFILE.GIF
Img_Folder = FOLDER.GIF
[$/Features]
[$/MyProject]


Derechos de acceso de seguridad

Cuando instala VSS se activa el sistema de seguridad predeterminado. Sin embargo puede personalizar la seguridad de su instalación con el fin de permitir a usuarios específicos tener acceso a determinados proyectos y comandos.

Seguridad predeterminada

La seguridad predeterminada en una instalación de VSS es sencilla. El administrador puede elegir tan sólo entre dos niveles de derechos de acceso cuando agrega usuarios nuevos a la instalación de VSS:

  • Derechos de sólo lectura: el usuario puede verlo todo en VSS pero no puede modificar nada.

  • Derechos de lectura y escritura: El usuario puede ver y modificar cualquier cosa en la base de datos de VSS.

Cada vez que agrega un usuario a su instalación, debe determinar el nivel de derechos de acceso del mismo. El cuadro de diálogo Agregar usuario contiene una casilla de verificación con el título Sólo lectura. Cuando activa esta casilla de verificación, el nuevo usuario puede leer los archivos pero no puede modificarlos. Cuando desactiva la casilla, el nuevo usuario tiene acceso a todos los comandos de lectura y escritura y a todos los proyectos.

Si estos niveles de derechos de acceso son correctos para su instalación, no necesita hacer nada más para mejorar la seguridad. Con este nivel de seguridad, los comandos relacionados con la seguridad disponibles en el menú Herramientas están deshabilitados. Para ver más opciones vea "Derechos de acceso de usuario en la seguridad de proyecto" más adelante en este tema.

Configurar la seguridad para el Administrador de VSS

Toda la seguridad en VSS está gobernada desde el interior del Administrador de VSS. En la práctica, cualquier usuario que puede ejecutar dicho programa puede hacer cualquier cosa con VSS por lo que conviene proteger el acceso al programa Administrador. Dispone de dos modos para controlar el acceso:

  • Asigne una contraseña al usuario Admin con el comando Cambiar contraseña.

    Importante Si olvida la contraseña asignada al administrador, no podrá ejecutar el Administrador de VSS con el fin de modificarla. Escriba su contraseña en un lugar que sea muy seguro. Si pierde la contraseña del administrador, póngase en contacto con el servicio de soporte técnico de Microsoft.

  • Proteja el Administrador de VSS: para ello, controle el acceso a la carpeta donde se ejecuta a nivel del sistema operativo.

Derechos de acceso de usuario en la seguridad de proyecto

La seguridad de proyecto en VSS está basada en los derechos de acceso del usuario. Cada proyecto es asequible tan sólo para aquellos usuarios que poseen los derechos apropiados. Cada comando puede utilizarse tan sólo por aquellos usuarios que poseen los derechos asociados con el mismo.

Existen cuatro derechos de acceso de usuario, descritos en la tabla siguiente.

Nota Cada derecho incluye todos los derechos que le preceden. Por ejemplo, el derecho para Desproteger incluye el derecho para Leer.

Derechos | Descripción
Leer (R) | Ver, pero no modificar, archivos mediante comandos como Ver y Obtener.
Desproteger (C) | Modificar archivos mediante comandos como Desproteger, Proteger y Deshacer Desprotección. Estos derechos se suelen asignar a ingenieros de control de calidad y a redactores técnicos.
Agregar (A) | Modifica la lista de archivos mediante comandos como Agregar, Eliminar, Etiqueta y Cambiar nombre. Algunas organizaciones proporcionan este derecho a todos los programadores mientras otras lo reservan para los directores de proyecto.
Destruir (D) | Lleva a cabo operaciones destructivas en archivos mediante comandos como Destruir, Purgar y Deshacer. En organizaciones donde la seguridad es importante, este derecho se otorga solamente a los directores de proyecto o al administrador. Debe disponer de derechos para Destruir para poder distribuir un sitio Web.

Al activar la seguridad a nivel de proyecto se habilitan los comandos del menú Herramientas relacionados con la seguridad: Derechos por proyecto, Asignaciones de derechos para usuario y Copiar derechos de usuario.

Cada uno de los comandos de VSS tiene ciertos derechos asociados con él. Por ejemplo, el comando Etiqueta requiere derechos para Agregar. Para obtener más información, consulte el artículo Q138479 de la Microsoft Knowledge Base.

Para obtener información acerca de cómo establecer los derechos de acceso de seguridad, consulte:

  • Asignar derechos por proyecto

  • Activar la seguridad de proyecto

  • Establecer derechos de seguridad predeterminados


Cómo establecer derechos de acceso de seguridad

Como administrador de VSS, puede reforzar la seguridad de VSS mediante cualquiera de las opciones siguientes:

  • Asignar derechos por proyecto

  • Activar la seguridad de proyecto

  • Establecer derechos de seguridad predeterminados


Asignar derechos por proyecto

Vea también

Para asignar derechos por proyecto:

  1. En el menú Herramientas del Administrador de VSS haga clic en Derechos por proyecto con el fin de mostrar el cuadro de diálogo Derechos por proyecto.

  2. En Proyectos, seleccione un proyecto.

  3. En Usuarios, seleccione un usuario. El Administrador de VSS muestra los derechos actuales del usuario en el proyecto seleccionado.

  4. Puede agregar o eliminar derechos: para ello active o desactive las casillas de verificación Derechos de usuario.

  5. Para agregar un usuario al proyecto actualmente seleccionado, haga clic en Agregar usuario. El Administrador de VSS muestra el cuadro de diálogo Agregar usuarios a proyecto con una lista de usuarios que no tienen actualmente derechos para el proyecto seleccionado. Active la casilla de verificación junto a los derechos que desea asignar al usuario y a continuación haga clic en Aceptar.

  6. Para eliminar un usuario del proyecto actualmente seleccionado, haga clic en Eliminar usuario.

    Cuando elimina el acceso de un usuario a un proyecto, el Administrador de VSS lleva a cabo la eliminación sin pedir confirmación.

  7. Haga clic en Cerrar.

Utilice el comando Asignaciones de derechos para usuario para mostrar todos los derechos de seguridad de proyecto de un usuario particular.


Activar la seguridad de proyecto

Vea también

Para activar la seguridad de proyecto:

  1. En el menú Herramientas del Administrador de VSS haga clic en Opciones con el fin de mostrar el cuadro de diálogo Opciones de SourceSafe.

  2. Haga clic en la ficha Seguridad del proyecto.

  3. Active la casilla de verificación Activar seguridad del proyecto con el fin de activar la seguridad del proyecto.

  4. En Derechos predeterminados del usuario, desactive las casillas de verificación de los derechos de acceso que no desea otorgar.

De forma predeterminada, cuando activa la seguridad a nivel de proyecto los usuarios nuevos disponen del conjunto completo de derechos de acceso a la base de datos.

Puede establecer un conjunto nuevo de derechos de usuario: para ello, active sólo la casilla correspondiente al nivel de derecho más alto que desea utilizar de modo predeterminado.


Establecer derechos de seguridad predeterminados

Vea también

Para cambiar el nivel de seguridad predeterminado de un usuario:

  1. Seleccione al usuario deseado en la lista de usuarios del Administrador de VSS.

  2. En el menú Usuarios haga clic en Modificar usuario.

  3. Active la casilla de verificación Sólo lectura con el fin de restringir los derechos de un usuario a sólo lectura.

    -O bien-

    Desactive la casilla de verificación Sólo lectura para otorgar derechos de acceso de lectura y escritura.


Acerca de VSS (Menú Ayuda)

Muestra un cuadro de diálogo con información acerca de su copia de Microsoft VSS, incluyendo el número de versión, el tipo de plataforma y los avisos sobre derechos de autor, legales y licencia.

Haga clic en Aceptar para cerrar el cuadro de diálogo.


Agregar usuario (Comando, menú Usuarios)

Vea también

Agrega un nuevo usuario a la lista de usuarios del Administrador de VSS.

Comentarios

Es posible cambiar después el nombre de usuario y los derechos de acceso de Sólo lectura con el comando Modificar usuario y se puede cambiar la contraseña con el comando Cambiar contraseña del Administrador de VSS. Los usuarios también pueden cambiar sus propias contraseñas mediante el comando Cambiar contraseña del Explorador de VSS.

Opciones del cuadro de diálogo

Nombre de usuario

Escriba el nombre del usuario que desea agregar al sistema.

Contraseña

Escriba una contraseña opcional de VSS. A medida que los escribe, los caracteres se muestran como asteriscos.

Sólo lectura

Asigna el derecho de acceso Leer. Selecciónelo si no desea que el usuario tenga el derecho de acceso Leer y escribir.

Aceptar

Agrega el usuario.

Cancelar

Cancela el comando Agregar usuario y vuelve al Administrador de VSS.


Cambiar contraseña (Comando, menú Usuarios)

Vea también

Establece la contraseña de los usuarios, incluido el usuario Admin.

Comentarios

El administrador raramente tiene que cambiar la contraseña de un usuario, ya que éstos pueden cambiar sus contraseñas en el Explorador de VSS (comando Cambiar contraseña del menú Herramientas). Sin embargo, cuando los usuarios olvidan la contraseña no pueden ejecutar VSS. No es posible averiguar la contraseña del usuario. Sin conocer la contraseña puede utilizar el comando Cambiar contraseña para cambiarla.

Nota Cuando ejecute el Administrador de VSS, se le pedirá la contraseña del usuario Admin. Si desea proporcionar una contraseña para el usuario Admin, utilice el comando Cambiar contraseña para darle una contraseña. Tras hacerlo, no olvide la contraseña del usuario Admin, ya que no hay ninguna forma de descubrirla y deberá llamar a los Servicios de soporte técnico de Microsoft.

Opciones del cuadro de diálogo

Nombre de usuario

Nombre del usuario seleccionado en el Administrador de VSS.

Contraseña nueva

Escriba la contraseña nueva. Una contraseña consiste en cualquier combinación de uno a 15 caracteres. A medida que los escribe, los caracteres se muestran como asteriscos. Las contraseñas de VSS no distinguen entre mayúsculas y minúsculas.

Confirmar contraseña

Vuelva a escribir la nueva contraseña para comprobarla.

Aceptar

Confirma la nueva contraseña.

Cancelar

Cancela el comando Cambiar contraseña.


Copiar derechos de usuario (Comando, menú Herramientas)

Vea también

Actúa como plantilla y copia los derechos de acceso de un usuario a otro.

Comentarios

En vez de agregar los derechos de acceso de un usuario en cada proyecto en el que trabaja un usuario, puede simplemente copiar todos los derechos de acceso de otro usuario similar.

Para copiar derechos de un usuario

  1. En la lista de usuarios, haga clic en el usuario cuyos derechos de acceso desea modificar.

  2. En el menú Herramientas, haga clic en Copiar derechos de usuario. Aparecerá el cuadro de diálogo Copiar asignaciones de derechos a usuario con una lista de todos los usuarios de VSS.

  3. Haga clic en el usuario que va a utilizar como plantilla de derechos de acceso y haga clic en Copiar.

Tras haber copiado los derechos, los dos usuarios tienen derechos de acceso idénticos en todos los proyectos. Sin embargo, puede cambiar los derechos de acceso individualmente en proyectos específicos. Los futuros cambios realizados en un usuario no se duplicarán en el otro, a menos que utilice este comando para copiar de nuevo los derechos de usuario.

Opciones del cuadro de diálogo

Copiar desde

Usuario cuyos derechos de acceso desea copiar.

Copiar

Copia los derechos de acceso del usuario seleccionado en Copiar desde al usuario seleccionado en el Administrador de VSS.

Cancelar

Cancela el comando Copiar derechos de usuario.


Eliminar usuario (Comando, menú Usuarios)

Elimina un usuario de la lista de usuarios del Administrador de VSS.

Comentarios

Para eliminar un usuario

  • Haga clic en el usuario que desea eliminar de la lista de usuarios del Administrador de VSS y, en el menú Usuarios, elija Eliminar usuario. Haga clic en Sí para confirmar la eliminación.

Se eliminará al usuario de la lista y ya no podrá ejecutar VSS.

Si el usuario eliminado tiene archivos desprotegidos, no se generará un mensaje de advertencia. Para desbloquear estos archivos, ejecute VSS como el usuario Admin y utilice el comando Deshacer desprotección.


Modificar usuario (Comando, menú Usuarios)

Vea también

Cambia el nombre de usuario y los derechos de acceso del usuario seleccionado en el Administrador de VSS.

Comentarios

Utilice el comando Cambiar contraseña del menú Usuarios para cambiar la contraseña de un usuario.

Nota Un método abreviado para mostrar el cuadro de diálogo Modificar usuario consiste en seleccionar el nombre de usuario en la lista de usuarios del Administrador de VSS y presionar ENTRAR.

Opciones del cuadro de diálogo

Nombre de usuario

Escriba el nombre nuevo para cambiar el nombre del usuario seleccionado en el Administrador de VSS.

Sólo lectura

Asigna el derecho de acceso Leer. Selecciónelo si no desea que el usuario tenga el derecho de acceso Leer y escribir.

Aceptar

Confirma los cambios.

Cancelar

Cancela el comando Editar usuario.


Salir (Comando, menú Archivo)

Sale de VSS.

Derechos de acceso

Cualquier usuario de VSS puede utilizar este comando.


Fuente (Comando, menú Herramientas)

Cambia la fuente utilizada en el Explorador de VSS o en el Administrador de VSS.

Comentarios

Establezca el nombre, estilo y tamaño de fuente de VSS en el cuadro de dialogo Fuente. El cuadro Ejemplo muestra una vista previa de la fuente actualmente seleccionada.

Los valores de fuente no afectan a la fuente utilizada en el visor de diferencias de archivo. Para establecer estas opciones, utilice la ficha Opciones de diferencia.


Menú Ayuda (Comandos)

Los comandos del menú Ayuda proporcionan Ayuda acerca de la utilización de VSS y de comandos específicos de VSS. Además, puede presionar F1 en cualquier momento para ver Ayuda acerca del elemento de menú o del cuadro de diálogo seleccionado actualmente.

Comando de Ayuda | Acción
Contenido | Ejecuta la Ayuda y muestra la Tabla de contenido de VSS.
Buscar ayuda acerca de | Muestra el cuadro de diálogo Buscar Ayuda de forma que pueda encontrar rápidamente la información que desea.
Soporte técnico | Muestra información acerca del Soporte técnico de productos de Microsoft.
Acerca de Microsoft Visual SourceSafe | Muestra un cuadro de diálogo con información acerca de su copia de Microsoft VSS, incluyendo el número de versión y los avisos sobre derechos de autor, consideraciones legales y licencia.

Derechos de acceso

Cualquier usuario de VSS puede utilizar estos comandos.

Comentarios

Una forma rápida de encontrar información consiste en utilizar Buscar y un índice automático con cientos de entradas de índices y referencias cruzadas.

También puede buscar temas de ayuda en la Tabla de contenido de VSS.

A medida que lee un tema en la Ayuda de VSS, puede desplazarse por el tema con la barra de desplazamiento, las teclas de dirección o las teclas RE PÁG y AV PÁG.


Bloquear la base de datos de SourceSafe (Comando, menú Herramientas)

Vea también

Le permite impedir la conexión de todos los usuarios a la base de datos de VSS mientras ejecute un programa, actualice los ejecutables o haga copia de seguridad de la base de datos.

Derechos de acceso

Debe tener el permiso de Administrador para usar este comando.

Comentarios

Utilice este comando si necesita archivar, hacer una copia de seguridad o ejecutar un programa de VSS en la base de datos. Tenga en cuenta que el hecho de activar la casilla de verificación Bloquear la base de datos de SourceSafe hace que realmente queden bloqueados los usuarios. Después de activar esta casilla, nadie podrá conectarse a la base de datos. Los usuarios de la lista que ya están conectados no se verán afectados; necesitará comunicarles manualmente que deben desconectarse.


Abrir base de datos de SourceSafe (Comando, menú Archivo)

Vea también

Le permite alternar entre bases de datos de VSS a través del Explorador de VSS.

Derechos de acceso

Debe disponer del derecho de acceso Leer para utilizar este comando.

Comentarios

Utilice este comando si necesita tener acceso periódicamente a varias bases de datos de VSS. Por supuesto, necesitará tener permisos de acceso al servidor donde se encuentre la base de datos y a la base de datos a la que intenta tener acceso. Cuando utilice este comando, la base de datos actual de VSS se cerrará y se abrirá la recién especificada.

Puede asignar un nombre fácil de recordar a cada base de datos y, cada vez que se conecte a una nueva base de datos, se agregará a la lista en el cuadro de diálogo Abrir base de datos de SourceSafe.

Nota Si ha utilizado Visual SourceSafe 4.0 con varias bases de datos, es probable que haya usado el antiguo método de variable inicialización que consiste en alternar entre bases de datos. En la mayoría de los casos, cada base de datos tendrá su propio archivo SRCSAFE.INI y puede utilizar el botón Examinar una vez para encontrar cada base de datos y agregarla a la lista de base de datos; a partir de ese momento, puede utilizar el comando Abrir base de datos de SourceSafe.

Si tiene una base de datos sin un archivo SRCSAFE.INI, cree un archivo SRCSAFE.INI para dicha base de datos. Ponga ese archivo SRCSAFE.INI en la carpeta situada inmediatamente encima de la carpeta DATA.


Opciones (Comando, menú Herramientas)

Vea también

Le permite personalizar el entorno de VSS para todos los usuarios.

Comentarios

Haga clic en la ficha que contiene la información que desea. Cada ficha contiene grupos de opciones que puede establecer para modificar el comportamiento de VSS en ciertas situaciones. Las fichas del cuadro de diálogo Opciones de SourceSafe cambian el comportamiento de VSS para todos los usuarios incluidos en la lista de usuarios del Administrador de VSS. (Los usuarios pueden pasar por alto alguna de las configuraciones mediante el comando Opciones del menú Herramientas del Explorador de VSS.)

Fichas del cuadro de diálogo

General

Establece las opciones generales aplicables a una serie de comandos de VSS.

Seguridad del proyecto

Establece las opciones de seguridad, como si la seguridad del proyecto está activada, y la asignación de derechos de acceso predeterminados del usuario.

Proyectos Web

Designa un proyecto como proyecto de sitio Web.

Web

Establece cómo se transmite cierta información de Internet para proyectos Web.

Tipos de archivo

Establece cómo se determina la información de tipo de archivo para todos los usuarios.


Asignaciones de derechos para usuario (Comando, menú Herramientas)

Vea también

Muestra y cambia los derechos de acceso de un proyecto en la base de datos de VSS asignados explícitamente al usuario seleccionado en la lista de usuarios.

Comentarios

Se asignan los derechos de acceso predeterminados a cada nuevo usuario con la seguridad predeterminada o mediante la ficha Seguridad del proyecto del cuadro de diálogo Opciones de SourceSafe del menú Herramientas.

Nota Para utilizar el comando Agregar asignación de derechos de usuario, primero debe seleccionar la casilla de verificación Activar seguridad del proyecto en la ficha Seguridad del proyecto del cuadro de diálogo Opciones de SourceSafe del menú Herramientas.

El cuadro de diálogo Asignaciones para usuario sólo muestra los derechos de acceso que se han modificado explícitamente; no se muestra el efecto de la propagación de derechos. Para ver la propagación de derechos de acceso, utilice el comando Derechos por proyecto del menú Herramientas.

Opciones del cuadro de diálogo

Derechos de usuario

Especifica el nivel de derechos de acceso [image] Leer, Desproteger, Agregar o Destruir [image] que tiene el usuario en el proyecto seleccionado en Proyectos. Para cambiar estas asignaciones, haga clic en el proyecto que desee y seleccione después la casilla de verificación correspondiente al derecho de acceso apropiado.

Derechos

Nivel de los derechos de acceso asignados al usuario seleccionado para cada proyecto. Puede cambiar el tamaño de esta columna si arrastra el separador de columna tras la palabra "Derechos".

Proyectos

Proyectos en los que el usuario seleccionado tiene asignados derechos de acceso explícitamente.

Cerrar

Cierra el cuadro de diálogo y vuelve al Administrador de VSS.

Agregar asignación

Muestra el cuadro de diálogo Agregar asignación para usuario. Para agregar proyectos y asignar o cambiar derechos de acceso para el usuario seleccionado, seleccione un proyecto de la lista de proyectos, haga clic en el nivel de derechos de acceso que desee asignarle y luego haga clic en Aceptar.

Eliminar asignación

Elimina derechos de acceso de un usuario en los proyectos seleccionados.


Derechos por proyecto (Comando, menú Herramientas)

Vea también

Muestra y cambia los derechos de acceso para los usuarios seleccionados en los proyectos seleccionados.

Comentarios

Se asignan los derechos de acceso predeterminados a cada nuevo usuario con la seguridad predeterminada o mediante la ficha Seguridad del proyecto del cuadro de diálogo Opciones de SourceSafe del menú Herramientas.

Este comando muestra el efecto de la propagación de derechos en el cuadro de diálogo Derechos por proyecto. Por ejemplo, si un usuario tiene el derecho de acceso Destruir en el proyecto raíz, en Proyectos verá que el usuario tiene el derecho de acceso Destruir en todos los subproyectos [image] a menos que cambie explícitamente los derechos de acceso. Los cambios explícitos se muestran en el cuadro de diálogo Asignaciones para usuario, disponible en el menú Herramientas.

Nota Para utilizar el comando Derechos por proyecto, deberá primero seleccionar la casilla Activar seguridad del proyecto en la ficha Seguridad del proyecto del cuadro de diálogo Opciones de SourceSafe del menú Herramientas.

Opciones del cuadro de diálogo

Proyectos

Lista de proyectos de la base de datos de VSS actual. Seleccione el proyecto en el que desea ver o cambiar los derechos del usuario.

Derechos

Derechos de acceso asignados al usuario.

Usuarios

Usuarios que tienen derechos de acceso en el proyecto seleccionado.

Derechos de usuario

Especifica el nivel de derechos de acceso [image] Leer, Desproteger, Agregar o Destruir [image] que desea asignar al usuario seleccionado en la columna Usuario. Para cambiar los derechos de acceso del usuario seleccionado en el proyecto seleccionado, seleccione la casilla de verificación correspondiente.

Cerrar

Cierra este cuadro de diálogo y vuelve al Administrador de VSS.

Agregar usuario

Muestra el cuadro de diálogo Agregar usuario a proyecto, que agrega usuarios al proyecto seleccionado en Proyectos.

Eliminar usuario

Elimina los derechos de acceso del usuario seleccionado en el proyecto seleccionado, tras mostrar un mensaje de advertencia.


Agregar asignación para usuario (Cuadro de diálogo)

Vea también

Cambia los derechos de acceso del usuario seleccionado en la lista de usuarios.

Para mostrar el cuadro de diálogo Agregar asignación para usuario:

  1. En el menú Herramientas, haga clic en Asignaciones de derechos para usuario.

  2. En el cuadro de diálogo Asignaciones de derechos para usuario, haga clic en Agregar asignación.

Comentarios

Para asignar o cambiar derechos de acceso para el usuario seleccionado, en Proyecto, seleccione un proyecto de la lista de proyectos, y haga clic en la casilla de verificación Derechos de usuario con el nivel de derechos de acceso que desee asignar.

Nota Para utilizar el cuadro de diálogo Agregar asignación para usuario, primero debe activar la casilla de verificación Activar seguridad del proyecto en la ficha Seguridad del proyecto del cuadro de diálogo Opciones de SourceSafe del menú Herramientas.

Opciones del cuadro de diálogo

Proyecto

Lista de proyectos de la base de datos de VSS actual.

Derechos de usuario

Especifica el nivel de derechos de acceso (Leer, Desproteger, Agregar o Destruir) que tiene el usuario en el proyecto seleccionado.

Aceptar

Confirma las selecciones.

Cancelar

Cancela las selecciones y vuelve al cuadro de diálogo Asignaciones para usuario.


Agregar grupo de archivos (Cuadro de diálogo)

Vea también

Agrega un nuevo grupo de archivos a la ficha Tipos de archivo del cuadro de diálogo Opciones de SourceSafe (menú Herramientas).

Para ver el cuadro de diálogo Agregar grupo de archivos

  • En el menú Herramientas haga clic en Opciones y a continuación en la ficha Tipos de archivos. Haga clic en el botón Agregar.

Opciones del cuadro de diálogo

Nombre

Escriba el nombre del grupo de archivos de la forma en que le gustaría identificarlo en la lista de grupos de archivos de la ficha Tipos de archivo.

Aceptar

Agrega el grupo de archivos.

Cancelar

Cancela el comando Agregar grupo de archivos.


Agregar usuarios a proyecto (Cuadro de diálogo)

Vea también

Agrega usuarios al proyecto seleccionado en Proyectos en el cuadro de diálogo Derechos por proyecto.

Comentarios

Los usuarios que se muestran en este cuadro de diálogo son usuarios de la base de datos de VSS que no tienen derechos de acceso en el proyecto seleccionado en el cuadro de diálogo Derechos por proyecto.

Para mostrar el cuadro de diálogo Agregar usuarios a proyecto:

  • En el menú Herramientas, haga clic en Derechos por proyecto y, luego, en el cuadro de diálogo Derechos por proyecto, haga clic en Agregar usuario.

Nota Para utilizar el cuadro de diálogo Agregar usuarios a proyecto, primero debe activar la casilla de verificación Activar seguridad del proyecto en la ficha Seguridad del proyecto del cuadro de diálogo Opciones de SourceSafe del menú Herramientas.

Opciones del cuadro de diálogo

Derechos

Derechos de acceso asignados al usuario.

Usuarios

Usuarios que no tienen derechos de acceso en el proyecto seleccionado.

Derechos de usuario

Especifica el nivel de derechos de acceso (Leer, Desproteger, Agregar o Destruir) que desea asignar al usuario seleccionado en la columna Usuario. Tras hacer clic en una casilla de verificación, se muestran en Derechos los derechos de acceso.

Nota Si el usuario que desea agregar al proyecto tiene el derecho de acceso Sólo lectura y desea asignarle derechos de acceso adicionales, en el menú Usuarios, haga clic en Editar usuario y desactive la casilla de verificación Sólo lectura.

Aceptar

Confirma las selecciones.

Cancelar

Cancela las selecciones y vuelve al cuadro de diálogo Derechos por proyecto.


Examinar la carpeta (Cuadro de diálogo)

Para obtener más información acerca del cuadro de diálogo Establecer la carpeta de trabajo, vea el tema Establecer la carpeta de trabajo (Comando, menú Archivo).

Opciones del cuadro de diálogo

Nombre

Nombre y ruta de acceso de la carpeta.

Carpeta

La carpeta actual.

Carpetas

Especifica una carpeta.

Unidades

Selecciona la unidad que contiene la carpeta.

Aceptar

Confirma la selección de la carpeta.

Cancelar

Cancela la selección, cierra el cuadro de diálogo y devuelve el control al Administrador de VSS.

Crear carpeta

Crea una nueva carpeta especificada. Escriba un nuevo nombre de carpeta en el cuadro Nombre y haga clic en Crear carpeta para crear la carpeta.


Examinar la base de datos de Visual SourceSafe (Cuadro de diálogo)

Vea también

Permite nombrar una base de datos de VSS.

Opciones del cuadro de diálogo

Ruta de la base de datos

Especifica la ruta para la base de datos seleccionada. No puede cambiar este valor aquí.

Nombre de la base de datos

Especifica el nombre amigable que desea dar a esta base de datos. Dicho nombre aparece en el cuadro de diálogo Abrir base de datos de SourceSafe.

Aceptar

Confirma sus selecciones.

Cancelar

Cancela sus selecciones.


Tipos de archivo - Administrador VSS (Ficha)

Vea también

Establece las opciones relativas a los tipos de archivo que los usuarios almacenan en VSS.

Comentarios

Muchos de los cuadros de diálogo de VSS contienen listas de archivos que permiten a los usuarios seleccionar varios archivos para una operación determinada. Utilice esta ficha para filtrar estas listas de archivos de forma que tengan más sentido de acuerdo con el tipo de trabajo que realicen los usuarios. Por ejemplo, si sus usuarios son desarrolladores de Microsoft Visual C++, puede que quieran guardar archivos .c, .h, .obj, y .exe en VSS. Por otra parte, si son programadores de Microsoft Visual Basic, preferirán archivos .mak y .frm.

Para mostrar la ficha Tipos de archivos:

  • En el menú Herramientas, haga clic en Opciones y, después, haga clic en la ficha Tipos de archivo.

Opciones del cuadro de diálogo

Archivos binarios

Pasa por alto la detección automática de archivos de texto y binarios de VSS e indica que ciertos tipos de archivo son siempre binarios. Por ejemplo, puede especificar en este cuadro *.obj, *.xls, *.frx para especificar que todos los archivos de objeto, las hojas de cálculo de Microsoft Excel y los archivos .frx de Microsoft Visual Basic deben tratarse como archivos binarios.

Grupos de archivos

Agrupa tipos de archivos según el tipo de trabajo de los usuarios, junto con la opción Tipos de archivo incluidos en grupo de archivos. Estos grupos se muestran en Mostrar archivos de tipo en muchos de los cuadros de diálogo de VSS, de modo que pueda especificar grupos que filtren de forma eficiente para sus usuarios la lista de archivos.

Agregar

Agrega a la lista un nuevo grupo de tipos de archivos. En el cuadro de diálogo Agregar grupo de archivos, escriba un nombre para el nuevo grupo de archivos que desee agregar, como "VC" o "VB".

Eliminar

Elimina el grupo seleccionado actualmente.

Tipos de archivo incluidos en grupo de archivos

Muestra la lista de los tipos de archivo incluidos en el grupo de archivos seleccionado actualmente en Grupos de archivos. Para modificar un grupo específico, seleccione el grupo en Grupos de archivos y agregue o elimine las extensiones en este cuadro.

Aceptar

Confirma las selecciones.

Cancelar

Cancela las selecciones.


General (Opciones de la ficha, menú Herramientas)

Establece las opciones generales del usuario.

Comentarios

La configuración afecta a todos los usuarios de la lista de usuarios del Administrador de VSS.

Para mostrar la ficha General:

  • En el menú Herramientas, haga clic en Opciones y, después, haga clic en la ficha General.

Opciones del cuadro de diálogo

Permitir varias desprotecciones

Controla si varias personas pueden desproteger un archivo simultáneamente. En circunstancias normales, sólo una persona puede tener desprotegido un archivo de VSS cada vez. Sin embargo, si activa esta casilla de verificación, VSS permitirá que varias personas desprotejan el mismo archivo. Cuando el primer usuario protege el archivo, VSS lo actualiza; más tarde, VSS combina todos los cambios subsiguientes.

Usar el nombre de red para iniciar la sesión del usuario automáticamente

Establece si VSS lee el nombre de inicio de sesión del usuario del sistema operativo. Si activa esta casilla de verificación, VSS intentará obtener automáticamente los nombres de usuario del sistema operativo. Desactive esta casilla de verificación si desea que los usuarios utilicen nombres de inicio de sesión diferentes de sus nombres de inicio de sesión en la red; VSS mostrará un cuadro de diálogo Inicio de sesión a menos que los usuarios especifiquen el nombre de usuario de otra forma (por ejemplo, mediante una variable de entorno).

Nombre de la base de datos predeterminada

Establece el nombre de la base de datos VSS actual como se muestra en la barra de título del Explorador de VSS. Si no se define, en la barra de título del Explorador de VSS aparece "Explorador de Visual SourceSafe", sin el nombre de la base de datos.

Sugerencia Si tiene diferentes bases de datos de VSS, a menudo puede terminar ejecutando VSS sin saber a cuál está conectado. Puede utilizar la opción Nombre de la base de datos predeterminada para identificar de forma única la base de datos y en qué carpeta está la copia de VSS y puede incluir la carpeta o el nombre de recurso compartido con el nombre de la base de datos. Hay un límite de 31 caracteres para el nombre de la base de datos.

Nota Si desea utilizar el nombre de la base de datos antes de que alguien ejecute VSS o contenga usuarios, elimine la lista del su registro HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SourceSafe\Databases y comience entonces una nueva sesión de VSS.

Expandir palabras clave en archivos de tipo

Indica en qué archivos utilizar la expansión de palabras clave. De forma predeterminada, VSS no explora los archivos en busca de expansión de palabras clave cuando ejecuta los comandos Proteger o Agregar.

Registrar todas las acciones en el archivo de diario

Establece el archivo donde se registran todos los comandos de VSS que modifican datos almacenados. (Los comandos que no modifican datos en la base de datos de SourceSafe no se registran.) Si selecciona esta opción, el archivo especificado es un archivo de texto que muestra todas las acciones de VSS que realiza el usuario.

Aceptar

Confirma las selecciones.

Cancelar

Cancela las selecciones.


Bloquear la base de datos de VSS (Cuadro de diálogo)

Vea también

Le permite impedir la conexión de todos los usuarios a la base de datos de VSS mientras ejecute un programa, actualice los ejecutables o haga copia de seguridad de la base de datos.

Opciones del cuadro de diálogo

Evitar la conexión para todos los usuarios de Visual SourceSafe

Active esta casilla de verificación para bloquear la conexión de todos los usuarios a la base de datos de VSS. Recuerde desactivar esta casilla de verificación cuando termine las tareas administrativas.

Tenga en cuenta que el hecho de activar la casilla de verificación Bloquear la base de datos de SourceSafe hace que realmente queden bloqueados los usuarios. Cuando active esta casilla de verificación, nadie podrá conectarse a la base de datos. Los usuarios de la lista que ya están conectados no se verán afectados; necesitará comunicarles manualmente que deben desconectarse.

X usuarios conectados

Esta sección del cuadro de diálogo muestra los usuarios que están conectados actualmente.

Cerrar

Cierra este cuadro de diálogo.


Abrir base de datos (Cuadro de diálogo)

Vea también

Este cuadro de diálogo le permite examinar un archivo SRCSAFE.INI asociado a una base de datos de VSS.

Opciones del cuadro de diálogo

Nombre del archivo

Escriba el nombre del archivo que desea buscar. Cuando busque una base de datos de VSS, utilice el archivo SRCSAFE.INI.

Archivos de tipo

Filtra el cuadro de lista de archivos y muestra únicamente los archivos del tipo seleccionado. Base de datos de SourceSafe es la opción predeterminada.

Carpetas

Seleccione la carpeta en la que desea buscar.

Unidades

Seleccione la letra de unidad donde buscar.

Aceptar

Selecciona el archivo de base de datos que se muestra en el cuadro Nombre de archivo.

Cancelar

Cancela la operación de examinar.

Red

Le permite asignar una unidad de unidad a otro servidor de red diferente, si es necesario.


Abrir (Cuadro de diálogo)

Opciones del cuadro de diálogo

Nombre de archivo

El nombre del archivo que está buscando. Puede especificar caracteres comodín, como *.exe, para buscar más de un archivo que coincida con el carácter comodín.

Mostrar archivos de tipo

Especifique el tipo de archivos que desea incluir en el cuadro de lista Nombre de archivo.

Carpetas

Especifica una carpeta.

Unidades

Selecciona la unidad que contiene la carpeta.

Aceptar

Confirma la selección de archivo.

Cancelar

Cancela la selección, cierra el cuadro de diálogo y vuelve al Administrador de VSS.

Red

Le permite conectar con una unidad de red para buscar.


Abrir base de datos de SourceSafe (Cuadro de diálogo)

Vea también

Le permite abrir diferentes bases de datos de VSSy almacenar sus ubicaciones.

Opciones del cuadro de diálogo

Bases de datos disponibles

Especifica las bases de datos que visitó, proporcionando un nombre descriptivo e información de la ruta de acceso para cada una de ellas. Si la base de datos que desea no está en la lista, puede hacer clic en el botón Examinar para buscarla. Cuando la encuentre y haga clic en el botón Aceptar del cuadro de diálogo Examinar con un determinado archivo SRCSAFE.INI seleccionado, tendrá la oportunidad de proporcionar a la base de datos un nombre descriptivo fácil de recordar cuando vuelva a conectarse más tarde.

Nombre de usuario

Especifica el nombre de usuario con el que desea conectarse a la nueva base de datos. Si lo cambia a un nuevo nombre de usuario con una contraseña diferente, se le pedirá que escriba la nueva contraseña. No puede cambiar esta opción en el programa Administrador.

Abrir esta base de datos la próxima vez que ejecute Visual SourceSafe

Active esta casilla de verificación para designar esta base de datos como la base de datos de inicio.

Quitar

Quita de la lista una base de datos seleccionada. No puede quitar de la lista la base de datos actual.

Aceptar

Confirma sus selecciones.

Cancelar

Cancela sus selecciones.


Opciones de la ficha Seguridad del proyecto

Vea también

Controla la seguridad de un proyecto de VSS. Utilice esta ficha para activar o desactivar la seguridad; si la seguridad está activada, puede establecer los derechos de acceso predeterminados de los usuarios.

Comentarios

Su primera decisión es si debe activar la seguridad del proyecto. Si la casilla de verificación Activar seguridad del proyecto está desactivada, la seguridad de proyecto está desactivada (la seguridad predeterminada de VSS está siempre operativa). Si la casilla de verificación Activar seguridad del proyecto está activada, puede establecer los derechos de acceso de los nuevos usuarios que se agreguen a la lista de usuarios del Administrador de VSS. El comando Agregar usuario del menú Usuarios agrega usuarios a la lista.

Por ejemplo, si las casillas de verificación Leer, Desproteger, Proteger, Agregar, Cambiar nombre o Eliminar están activadas, los nuevos usuarios tienen el derecho de acceso Agregar en el proyecto raíz (y, por tanto, en todos los proyectos) de forma predeterminada. Puede cambiar estos derechos en cualquier proyecto mediante los comandos Derechos por proyecto o Asignaciones de derechos para usuario.

Para mostrar la ficha Seguridad del proyecto:

  • En el menú Herramientas, haga clic en Opciones y, después, haga clic en la ficha Seguridad del proyecto.

Opciones de la ficha

Activar seguridad del proyecto

Activa el sistema de seguridad del proyecto, que proporciona los cuatro niveles de derechos de acceso mostrados a continuación.

Leer

Permite al usuario ver copias de sólo lectura de los archivos.

Desproteger/Proteger

Permite al usuario utilizar los comandos Desproteger y Proteger, pero no le permite cambiar el nombre, agregar y eliminar archivos o proyectos y así sucesivamente.

Agregar/Cambiar nombre/Eliminar

Permite al usuario utilizar los comandos Agregar, Cambiar nombre, Eliminar, Desproteger y Proteger pero no le permite realizar acciones que destruyan de forma permanente archivos o proyectos.

Destruir

Permite al usuario utilizar todos los comandos de VSS. Es igual a los derechos de acceso de lectura y escritura en el sistema de seguridad predeterminado.


Establecer carpeta central o sitio Web (Cuadro de diálogo)

Seleccione un proyecto para el que quiera establecer una carpeta central o un sitio Web en su base de datos VSS.

Opciones del cuadro de diálogo

Proyecto

Seleccione el proyecto para que desee establecer una carpeta central o un sitio Web.

Aceptar

Acepta el proyecto seleccionado.

Cancelar

Cancela la selección de la carpeta central o el sitio web.


Carpetas centrales (Opciones de la ficha)

Vea también

Establece las carpetas centrales.

Comentarios

Utilice la opción Establecer la carpeta central para el proyecto con el fin de especificar un proyecto. Una vez especificado, todas las demás opciones de la ficha se aplicarán sólo al proyecto especificado.

Para mostrar la ficha Carpetas centrales:

  • En el menú Herramientas, haga clic en Opciones y, después, haga clic en la ficha Carpetas centrales.

Opciones del cuadro de diálogo

Establecer la carpeta central para el proyecto

Especifica el proyecto en el que desea establecer la carpeta central. Haga clic en Examinar para examinar la base de datos de VSS en busca del proyecto que desea. Después de que haya especificado el nombre del proyecto, cualquier información acerca de las carpetas centrales existentes se muestra en los campos restantes de la ficha. Recuerde que la configuración central de un determinado proyecto se puede establecer explícitamente o se hereda de sus proyectos primarios.

Establecer la carpeta central en

Especifica la carpeta central. Puede ser cualquier carpeta de la red, pero en la mayoría de los casos está en el servidor con la base de datos de VSS. Haga clic en Examinar para buscar en el sistema de archivos una ubicación adecuada.

Establecer otra

Aplica la carpeta central especificada en los demás campos de este cuadro de diálogo y borra el cuadro de diálogo para que pueda establecer otra carpeta central. Este botón no está disponible a menos que haya especificado una carpeta y un proyecto válidos en los dos campos siguientes.

Establecer indicador de sólo lectura para todos los archivos

Controla si los archivos de la carpeta central son de sólo lectura.

Carácter de fin de línea para archivos

Establece el carácter de fin de línea utilizado en la carpeta central. Cuando VSS copia un archivo a la carpeta central, utiliza el carácter de fin de línea utilizado por su propio sistema operativo. Por ejemplo, VSS para Windows utiliza la combinación retorno de carro y salto de línea. En un entorno multiplataforma, los archivos de la carpeta central son una combinación de caracteres de fin de línea, basándose en el último sistema operativo en que se actualizó el archivo.

Esta configuración pasa por alto ese mecanismo, obligando a que todas las versiones de VSS utilicen el carácter de fin de línea especificado. Establezca este campo como AL para salto de línea (el valor predeterminado en UNIX), RC para retorno de carro o RC/AL para parejas de retorno de carro y salto de línea (valor predeterminado para Intel). Observe que los compiladores de Macintosh generalmente pueden aceptar parejas de retorno de carro y salto de línea, por lo que RC/AL es una buena opción para las instalaciones Intel-Macintosh.

Fecha y hora del archivo

Establece la marca de fecha y hora proporcionada a los archivos de la carpeta central.

De forma predeterminada, siempre que VSS coloca un archivo en la carpeta central, asigna a la fecha y hora del archivo la fecha y hora actuales.

Sin embargo, si asigna a esta variable el valor Modificación o Protección, VSS asignará al archivo de la carpeta central la fecha y hora que tenía el archivo la última vez que se modificó o protegió, respectivamente.

Aceptar

Confirma las selecciones y guarda la configuración central en el archivo SRCSAFE.INI.

Cancelar

Cancela las selecciones y vuelve al Administrador de VSS.


Web (Opciones de la ficha)

Vea también

Hay tres valores generales que se aplican a la vez a todos los proyectos Web de su base de datos de VSS. Dos de ellos se aplican a proyectos Web que se distribuyen mediante FTP a través de un servidor de seguridad y otro se aplica al comando Comprobar hipervínculos. Estos valores se establecen en la ficha Web. No confunda la ficha Web con la ficha Proyectos Web, que establece opciones para un determinado proyecto Web, no para todos los proyectos Web simultáneamente.

Proxy para distribuir sobre ftp

Si necesita distribuir de forma remota a través de un servidor de seguridad, utilice este campo para especificar un proxy. Establece la variable de inicialización Deploy_Proxy en el archivo SRCSAFE.INI.

No usar el proxy para estos servidores locales

Use este campo para especificar los servidores locales para los cuales el proxy no es apropiado porque están dentro de un servidor de seguridad. Establece la variable de inicialización Deploy_Host_Local en el archivo SRCSAFE.INI.

Nombre predeterminado para las páginas Web

Use este campo para especificar el nombre de archivo que VSS anexa a una dirección URL que termina con un nombre de carpeta durante la ejecución del comando Comprobar hipervínculos. El valor predeterminado es "Default.htm"; sólo necesita especificarlo si desea usar otro nombre diferente. Establece la variable de inicialización Web_Default_Filename en el archivo SRCSAFE.INI.

Aceptar

Confirma las selecciones y guarda los valores de Web en el archivo SRCSAFE.INI.

Cancelar

Cancela las selecciones y vuelve al Administrador de VSS.


Proyectos Web (Opciones de la ficha)

Vea también

Establece información que se aplica a los proyectos; es decir, proyectos que tienen archivos con significado para los exploradores de HTML. No confunda la ficha Proyectos Web con la ficha Web, que establece opciones para todos los proyectos Web de una vez, no para los proyectos Web individuales.

Comentarios

Use el cuadro de lista de arriba para especificar un proyecto de VSS existente como un proyecto Web. Una vez especificado, todas las demás opciones de la ficha (excepto la información de proxy, que es global) se aplicarán únicamente al proyecto especificado.

Para quitar de un proyecto la designación de proyecto Web, borre el contenido del campo Dirección URL y haga clic en Aceptar.

Para ver la ficha Proyectos Web:

  • En el menú Herramientas, haga clic en Opciones y, después, haga clic en la ficha Proyectos Web.

Opciones del cuadro de diálogo

Esta ficha contiene cinco campos de texto. El primer campo y uno o ambos de los campos Dirección URL y Raíz virtual deben completarse antes de poder designar un proyecto como proyecto Web. Los dos campos restantes son opcionales.

Este proyecto representa un sitio Web

Escriba en este campo el nombre del proyecto o utilice el botón Examinar para encontrar el proyecto. Todos los demás valores se aplican a este proyecto.

Dirección URL

Escriba en este campo la dirección del Localizador de recursos universal para el proyecto Web.

Raíz virtual

Cierto software de servidor Web lo acepta; si ha especificado una raíz virtual en el software servidor, debe especificarlo aquí, sin una barra oblicua inicial. Si escribe un valor en este campo se establecerá una variable Virtual_Root en el archivo SRCSAFE.INI. Las búsquedas comprueban el archivo SRCSAFE.INI para cualquier proyecto que tenga la raíz virtual especificada.

Nombre de archivo del mapa de sitios

Escriba en este campo el nombre del archivo que desea que VSS utilice cuando cree un mapa de sitios. (Si no especifica ningún valor, se usará de forma predeterminada Sitemap.htm.)

Cuando haya completado los campos de la ficha, haga que los clientes del proyecto Web salgan de VSS y reinicien. El Explorador de VSS mostrará el proyecto designado con un icono especial para indicar que se trata de un proyecto Web.

Nota Debe designar una dirección URL y una raíz virtual para el proyecto. Los demás campos son opcionales cuando el proyecto se designa como proyecto Web.

Ruta de distribución

Una ubicación de distribución puede estar en una unidad de disco duro del equipo o en otro lugar de una red de área local. Si una ruta de distribución es local, especifíquela con una letra de unidad o en formato UNC. Haga clic en el botón Examinar para buscar servidores de la red. Si escribe un valor en este campo establecerá una variable de inicialización Deploy_Path en el archivo SRCSAFE.INI.

Como alternativa, la ubicación puede ser remota, en cuyo caso se llegará a ella mediante el Protocolo de transferencia de archivos (FTP). Utilice el formato URL para especificar una ruta de acceso FTP. La ruta de acceso debe incluir la especificación de protocolo ("ftp://") y la ubicación. En este caso puede agregar un nombre de usuario o un nombre de usuario y una contraseña y, si es necesario, una ruta de acceso de carpeta. Separe el nombre de usuario y la contraseña con un signo de dos puntos (:). Puede especificar más de una ruta de acceso en este campo; separe las rutas de acceso mediante comas.

Por ejemplo:

ftp://www.trassi.com/

ftp://SamBal@www.trassi.com/ssafe

ftp://SamBal:baDJak@www.trassi.com/ssafe

ftp://www.trassi.com/ssafe,\\mi\servidor\ssafe

VSS almacena toda la ruta de acceso ftp en la variable Deploy_Path.

Nota Puede distribuir cualquier proyecto que se haya designado como proyecto Web, cualesquiera que sean los tipos de archivo que contiene. Un único comando envía todo el proyecto a la ubicación o ubicaciones remotas que haya especificado.

Puede especificar varias rutas de distribución en este cuadro, separadas por comas. Por ejemplo, puede establecer que cuando un usuario distribuya este sitio Web, vaya a su ubicación ftp y también a una carpeta de su servidor local.

Al definir una ruta para un sitio FTP, la información de la carpeta se obtiene de la raíz del servidor FTP. Al usar comandos típicos de FTP para PC o UNIX, no suele ser la sesión en el servidor FTP comenzando en la ruta particular que normalmente no es la raíz del servidor. Puede pensar que es una especie de raíz "particular".

Por ejemplo, si desea colocar un archivo en su sitio Web en Argentina, debe realizar los siguientes pasos:

  1. ftp://ftp.eos.ncsu.edu

  2. Escriba el nombre de usuario y su contraseña.

  3. Cambie a la carpeta temp (una subcarpeta).

  4. Use el comando de FTP "put" para escribir el archivo.

Para especificar esta ubicación en el cuadro de diálogo Distribuir, tiene que escribir lo siguiente:

ftp://usuario:contraseña@ftp.eos.ncsu.edu/usr/name/temp

Tenga en cuenta que es necesario especificar /usr/name/, ya que la distribución a FTP funciona desde la raíz del servidor y no desde la carpeta actual. Tenga en cuenta también que muchos sistemas usan el carácter tilde (~) para especificar la carpeta principal del usuario. Por tanto, tendrá que escribir lo siguiente (donde el servidor UNIX admita esta sintaxis de comandos):

ftp://usuario:contraseña@ftp.eos.ncsu.edu/~/temp

Además, debe tener cuidado cuando escriba el carácter "/". Por ejemplo, "cd ~/temp" es un comando de FTP válido pero "cd /~/temp" no lo es.

Establecer otra

Aplica la información de sitio Web especificada en los demás campos de este cuadro de diálogo y borra el cuadro de diálogo para que pueda establecer otro proyecto de sitio Web. Este botón no está activado a menos que haya especificado un proyecto y una dirección URL válidos en el campo de arriba.

Aceptar

Confirma las selecciones y guarda las opciones del sitio Web en el archivo SRCSAFE.INI.

Cancelar

Cancela las selecciones y vuelve al Administrador de VSS.

Para quitar la designación de proyecto Web

Borre los campos Dirección URL y Raíz virtual de esta ficha; después, haga clic en Aceptar.


-? (Opción de línea de comandos)

Utilice la opción -? con cualquier comando para obtener Ayuda en pantalla acerca de dicho comando. También puede utilizar la opción -H para obtener Ayuda en pantalla.

La siguiente lista enumera una forma de utilizar la opción -?

Opción | Descripción
ss Share -? | Muestra Ayuda acerca del comando Share.


-C (Opción de línea de comandos)

Vea también

Utilice la opción -C para cualquier comando que requiera un comentario. Si no especifica la opción -C, VSS le pedirá un comentario para cada elemento que especifique en la línea de comandos. Si especifica la opción, todos los elementos recibirán el mismo comentario.

La siguiente tabla enumera formas de utilizar la opción -C.

Opción | Descripción
-C | Pide un comentario y después lo utiliza para todos los elementos.
-C- | No utiliza ningún comentario.
-Ctexto | Utiliza la cadena texto como comentario para todos los elementos.
-C@Archivo.txt | Utiliza el contenido de Archivo.txt como comentario para todos los elementos.
-C? | Vuelve al valor predeterminado de VSS; pide un comentario para cada archivo individual.

Para establecer cualquiera de las opciones enumeradas en la tabla como valor predeterminado para el comando CheckOut, utilice la variable de inicialización Checkout Comment de SS.INI. Si ha establecido una opción predeterminada en el archivo SS.INI, puede reemplazarla para un determinado comando mediante la opción -C? y VSS le pedirá un comentario para cada archivo individual (opción predeterminada de VSS).

Puede establecer la variable Comment_Editor de SS.INI para invocar el editor ejecutable que desee como alternativa al método de solicitar la entrada de comentarios que utiliza VSS.


-G (Opción de línea de comandos)

Vea también

El comando Get copia archivos de un proyecto de VSS a una carpeta. VSS obtiene archivos como respuesta al comando Get y también como respuesta a muchos otros comandos como CheckOut, UndoCheckOut y Share.

Para cualquiera de esos comandos, puede utilizarse la opción -G para cambiar la naturaleza de la operación Obtener. Muchas de estas opciones suplantan acciones específicas de comandos y pueden establecerse en el archivo SS.INI.

La tabla siguiente muestra las formas de utilizar la opción -G.

Opción | Descripción
-G- | No realiza una operación Obtener.
-GCC | Determina si la copia local del archivo está actualizada, comparando el contenido del archivo.
-GCD | Utiliza una comparación de la fecha y la hora para determinar si la copia local del archivo está actualizada.
-GCK | Suma de control. Se utiliza para determinar si la copia local del archivo es actual.
-GF | Activa la variable de inicialización Force_Dir para este comando.
-GF- | Desactiva la variable de inicialización Force_Dir para este comando.
-GLpath | Copia un archivo a la carpeta especificada, no a la actual ni a la carpeta de trabajo.
-GN | Especifica el avance de línea como el carácter de fin de línea en archivos de texto
-GR | Especifica el retorno de carro como el carácter de fin de línea en archivos de texto.
-GRN | Especifica el par retorno de carro-avance de línea como el carácter de fin de línea en archivos de texto.
-GTC | Se proporciona a la copia local la fecha y la hora actual.
-GTM | Se proporciona a la copia local la fecha y la hora en la que el archivo fue modificado por última vez, no la fecha ni la hora actual.
-GTU | Se proporciona a la copia local la fecha y la hora en la que el archivo fue actualizado por última vez, no la fecha ni la hora actual.
-GWA | Muestra un cuadro de diálogo que pide al usuario que elija entre reemplazar, saltar o combinar archivos modificables en operaciones Obtener la última versión y Desproteger.
-GWM | Combina archivos de sólo escritura en ciertas operaciones (Obtener y Desproteger).
-GWR | Reemplaza archivos modificables en ciertas operaciones (Obtener y Desproteger).
-GWS | Salta archivos modificables en ciertas operaciones (Obtener y Desproteger).


-I (Opción de línea de comandos)

Hay una serie de circunstancias en las cuales los comandos de VSS piden datos al usuario; por ejemplo, con advertencias que contienen preguntas de tipo Sí o No. Esto no es deseable cuando escribe secuencias de comandos o macros que ejecutan la línea de comandos de VSS desde dentro de otros programas. Utilizar la opción -I- para asegurarse de que VSS no pida nunca datos al usuario.

Cuando utilice –I, incluya la opción -C para impedir la solicitud de comentarios.

La tabla siguiente enumera las formas de utilizar la opción -I.

Opción | Descripción
-I-Y | Fuerza a VSS a responder Sí a todas las preguntas de tipo Sí o No.
-I-N | Fuerza a VSS a responder No a todas las preguntas de tipo Sí o No.


-N (Opción de línea de comandos)

En los sistemas operativos que aceptan nombres de archivo largos, la opción -N cambia entre los modos de nombres largos y cortos, para un comando cada vez.

La tabla siguiente enumera las formas de utilizar la opción -N.

Opción | Descripción
-NL | Utiliza el modo de nombre de archivo largo.
-NS | Utiliza el modo de nombre de archivo corto.


-O (Opción de línea de comandos)

La opción -O controla el resultado de los comandos que podrían mostrar grandes volúmenes de información. Si no especifica la opción -O, la información se desplazará por la pantalla muy rápidamente y no podrá leerla.

La siguiente tabla muestra las formas de utilizar la opción -O.

Opción | Descripción
-O | Proporciona toda la información.
-O- | No proporciona más información que los errores.
-O@Archivo.txt | Envía todo el resultado al archivo Archivo.txt. Es el método de la línea de comandos para exportar informes, como el informe Historial, a un archivo o a una impresora. Si el nombre de archivo ya existe, el resultado se anexará a dicho archivo.
"-O&Archivo.txt" | Envía los errores estándar al archivo Archivo.txt, además de enviarlos al resultado del comando. Observe las comillas son necesarias en las plataformas Windows NT y son opcionales en las demás. Si el nombre de archivo ya existe, el resultado se anexará a ese archivo.
-O&- | No proporciona ninguna información.


-R (Opción de línea de comandos)

La opción -R se utiliza con los comandos de VSS que operan sobre proyectos; convierte los comandos en recursivos en los subproyectos. Normalmente, los comandos actúan sólo sobre el proyecto especificado y los archivos que contiene. Por ejemplo, si obtiene un proyecto, obtendrá todos los archivos contenidos en ese proyecto. Sin embargo, se pasan por alto los subproyectos y los archivos y subproyectos que contienen. Cuando utiliza la opción -R para hacer un comando recursivo, el comando actúa sobre toda la jerarquía del proyecto. Por ejemplo, si escribe SS Get nombreProyecto -R, se crean carpetas para los subproyectos de ese proyecto, para los subproyectos que contienen y así sucesivamente.


-S (Opción de línea de comandos)

Vea también

La variable de inicialización Smart_Mode del archivo SS.INI pone VSS en modo SmartMode. Con SmartMode activado:

  • Tras crear un proyecto, SmartMode lo configura como proyecto actual.

  • Al eliminar o destruir un archivo, VSS elimina automáticamente el archivo local correspondiente.

  • Al cambiar el nombre de un archivo, VSS cambia automáticamente el nombre del archivo local correspondiente.

La opción -S anula la variable Smart_Mode para un determinado comando.

La tabla siguiente enumera las formas de utilizar la opción -S.

Opción | Descripción
-S | Activa el modo SmartMode.
-S- | Desactiva el modo SmartMode.


-V (Opción de línea de comandos)

La opción -V permite especificar versiones anteriores de archivos o proyectos. Por ejemplo, puede que desee ver un archivo o un proyecto exactamente como era el mes pasado.

La tabla siguiente muestra las formas de utilizar la opción -V.

Opción | Descripción
-V14 | Muestra la versión 14.
-Vd29-2-92 | Muestra la versión con fecha del 29-2-92.
"-VL Beta final " | Muestra la versión cuya etiqueta es Beta final.

La opción -V muestra todos los archivos y proyectos identificados por el número de versión especificado en la línea de comandos. También puede especificar un número de versión para un elemento en particular si escribe a continuación de ese elemento un signo de punto y coma y, después, el número de versión.

La tabla siguiente muestra cómo especificar un determinado elemento en la línea de comandos.

Opción | Descripción
Help.C;14 | Muestra la versión 14 de Help.C.
Show.prg;d2-29-92 | Muestra Show.prg tal y como era el 29-2-92.
"$/CW;L Beta 1" | Muestra la versión del proyecto $/CW que tiene la etiqueta Beta 1.

Algunas veces, deseará hacer referencia a una hora junto con la fecha en un comando de Visual SourceSafe. Para ello, haga referencia a la hora junto con la fecha mediante la opción -vd.

Por ejemplo, para ver una lista del historial del proyecto $/Test desde las 9 de la mañana a las 3 de la tarde del día 3/3/95, emita el comando:

ss history $/test -vd3/03/95;3:00p~3/03/95;9:00a

En el comando que precede "a" o "p" se refieren a la mañana (a.m.) o a la tarde (p.m.), respectivamente. La tilde (~) se utiliza para indicar que desea el historial entre las fechas y horas especificadas. Observe que la fecha y la hora más tardía deben especificarse primero.


-W (Opción de línea de comandos)

Vea también

Cuando no tiene un archivo desprotegido, su copia local está bloqueada o es de sólo lectura para recordarle que no debe cambiarla. La variable Use_ReadOnly del archivo SS.INI cambia su comportamiento predeterminado. La opción -W lo cambia para un comando específico.

La tabla siguiente enumera las formas de utilizar la opción -W.

Opción | Descripción
-W | Convierte los archivos locales en lectura y escritura.
-W- | Hace los archivos locales de sólo lectura.


-Y (Opción de línea de comandos)

La opción -Y especifica un nombre de usuario en caso de que desee ejecutar un comando como si fuera otro usuario distinto.

La tabla siguiente enumera las formas de utilizar la opción -Y.

Opciones | Descripción
-YMario | Especifica un nombre de usuario.
-YMario,Mypass | Especifica un nombre de usuario y una contraseña.


Agregar al control de código fuente (Cuadro de diálogo)

Utilice este cuadro de diálogo para colocar archivos bajo control de código fuente en el proyecto asociado con su espacio de trabajo. Puede agregar archivos al empezar, cuando crea el espacio de trabajo o bien más tarde, una vez creado el mismo.

Opciones del cuadro de diálogo

Archivos

Enumera todos los archivos presentes en su proyecto que no están actualmente bajo control de código fuente, con una marca junto a los archivos seleccionados en Ver archivo. Si la lista no incluye los archivos que desea, haga clic en las casillas de verificación para cambiar la selección.

Mantener desprotegido

Desprotege los archivos a su nombre tras agregar las versiones maestras de los archivos del proyecto de control de código fuente.

Comentario

Agrega un comentario acerca de los archivos que va a agregar.

Avanzadas

Da paso a opciones adicionales. Este botón está deshabilitado si su sistema de control de código fuente no admite opciones como éstas.


Agregar a un proyecto de SourceSafe (Cuadro de diálogo, Entorno de desarrollo)

Agrega el proyecto del entorno de desarrollo actual a la base de datos de control de código fuente.

Para agregar un proyecto al control de código fuente:

  • En el menú Herramientas, seleccione Control de código fuente y a continuación haga clic en Agregar al control de código fuente.

Nota Si especifica el nombre de su proveedor de control de código fuente, dicho nombre aparece en lugar de "Control de código fuente".

Opciones del cuadro de diálogo

Proyecto

Especifica el proyecto de VSS al que deben agregarse los archivos.

$/

Muestra el árbol del proyecto de VSS así como el proyecto de VSS al que se agregarán los archivos.

Botón de comando Crear

Crea un proyecto nuevo en la base de datos de VSS.

Comentarios

El comando Agregar proyecto al control de código fuente toma los archivos seleccionados en la ventana de proyecto del entorno de desarrollo y crea un proyecto de control de código fuente que contiene dichos archivos. Este comando sólo está disponible cuando selecciona un proyecto que no está todavía bajo control de código fuente. Cada uno de los archivos seleccionados se agrega automáticamente en ese momento.


Opciones avanzadas de Desproteger (Cuadro de diálogo)

Establece las opciones predeterminadas del comando Desproteger.

Para mostrar las opciones avanzadas de Desproteger:

  • Haga clic en el botón Avanzadas en el cuadro de diálogo Desproteger.

Opciones del cuadro de diálogo

Reemplazar modificable

Determina el comportamiento de VSS cuando intenta desproteger un archivo marcado como modificable en su directorio de trabajo. Seleccione una de las posibilidades siguientes en el cuadro de lista:

  • Preguntar: Le pregunta lo que debe hacer con cada archivo.

  • Reemplazar: Reemplaza el archivo por una versión de sólo lectura.

  • Saltar: Salta la operación de desprotección.

  • Combinar: combina los cambios entre el archivo desprotegido y el que está obteniendo o desprotegiendo.

  • Predeterminado: Utiliza los valores predeterminados establecidos en la ficha Archivos locales del cuadro de diálogo Opciones de SourceSafe (en el menú Herramientas).

Establecer hora de archivo

Cambia la fecha asociada a la operación de desprotección. Seleccione una de las posibilidades siguientes en el cuadro de lista: Actual, Modificación, Protección o la fecha predeterminada (establecida en la ficha Archivos locales).

No obtener copia local

Indica a VSS que no debe copiar el archivo a su directorio de trabajo. VSS registra la desprotección del archivo pero no le proporciona una copia nueva del mismo.


Comentario Avanzado (Cuadro de diálogo)

Opciones avanzadas

Guardar sólo la última versión

Indica que no desea guardar versiones antiguas del archivo o los archivos que se agregan a la base de datos de VSS. VSS mantiene un historial de los cambios al archivo y sus respectivos comentarios. De todas formas, la versiones antiguas del archivo no se almacenan y, por tanto, no se pueden recuperar.

Nota Para incrementar el rendimiento y ahorrar espacio del disco, use esta opción cuando almacene programas ejecutables en VSS.

Desproteger inmediatamente

Desprotege el archivo justo después de agregarlo a VSS.

Quitar copia local

Elimina el archivo de la carpeta de trabajo después de agregarlo a VSS.

Tipo de archivo

Seleccione una opción del cuadro de lista.

  • Detección automática: VSS determina el tipo de archivo.

  • Binario: VSS trata al archivo como un archivo binario.

  • Texto: VSS trata al archivo como un archivo de texto.

Nota Cuando agregue una carpeta, VSS pasará por alto el valor del campo Tipos de archivo. No obstante, VSS filtrará los archivos agregados durante la operación Agregar archivos a una carpeta según el valor de Relevant_Masks en la ficha Tipos de archivo del cuadro de diálogo Opciones de SourceSafe.


Opciones avanzadas de obtención (Cuadro de diálogo)

Establece las opciones predeterminadas del comando Desproteger.

Para mostrar el cuadro de diálogo Opciones avanzadas de obtención :

  • En el menú Herramientas haga clic en Obtener y a continuación en el botón Avanzadas.

Opciones del cuadro de diálogo

Reemplazar modificable

Determina el comportamiento de VSS cuando intenta obtener un archivo ya marcado como modificable en su directorio de trabajo. Seleccione una de las posibilidades siguientes en el cuadro de lista:

  • Preguntar: Le pregunta lo que debe hacer en cada caso.

  • Reemplazar: VSS reemplaza el archivo por una versión de sólo lectura.

  • Saltar: Salta la operación Obtener.

  • Combinar: combina los cambios entre el archivo desprotegido y el que está obteniendo o desprotegiendo.

Predeterminado: Utiliza los valores predeterminados establecidos en la ficha Archivos locales, mediante el comando Herramientas, Opciones.

Establecer hora de archivo

Cambia la fecha asociada a la operación de obtención. Seleccione una de las posibilidades siguientes en el cuadro de lista: Actual, Modificación, Protección o la fecha predeterminada (establecida en la ficha Archivos locales).

Permitir escribir

Recupera el archivo y permite escribir en él. Esta operación no equivale a una operación Desproteger porque el comando Obtener no es exclusivo, es decir, que más personas pueden ejecutar el comando Obtener sobre el mismo archivo. No puede proteger los cambios después de una operación Obtener con esta opción establecida.


Comprobar hipervínculos (Cuadro de diálogo)

Vea también

Le permite especificar opciones para comprobar si un conjunto de archivos HTML tiene vínculos no válidos a otros archivos.

Opciones del cuadro de diálogo

Proyecto

Especifica el proyecto en el que se comprobará si existen vínculos HTML no válidos.

Dirección URL

Muestra la dirección URL representada por este proyecto. El administrador de VSS establece esta dirección URL para cada proyecto de sitio Web mediante el programa Administrador.

¿Qué archivos desea comprobar?

Esta área sirve para especificar los archivos que desea comprobar. Puede elegir entre proteger los archivos de la carpeta de trabajo o los del proyecto de VSS. Si ha modificado sus archivos después de desprotegerlos, elija Comprobar los archivos de mi carpeta de trabajo. Si está comprobando un proyecto que tiene subproyectos, active la casilla de verificación Recursivo para incluir dichos subproyectos.

Básicamente hay dos situaciones. En primer lugar, todos los archivos HTML están protegidos, usted está a punto de realizar la distribución y desea confirmar que hay nada estropeado. En este caso, compruebe los archivos del proyecto. En segundo lugar, está a punto de proteger los archivos, pero desea confirmar que no ha estropeado nada antes de hacerlo: en ese caso, compruebe los archivos de la carpeta de trabajo.

Aceptar

Confirma sus selecciones.

Cancelar

Cancela sus selecciones.


Resultados de comprobar hipervínculos (Cuadro de diálogo)

Este cuadro de diálogo se muestra después de que VSS haya explorado sus archivos de Web en busca de hipervínculos rotos. VSS diferencia entre dos tipos de hipervínculos: internos y externos.

Los vínculos internos están dentro de su sitio Web: es decir, un archivo hace referencia a otro archivo del mismo árbol de proyectos de VSS. VSS comprueba todos los vínculos internos y muestra cualquier posible problema. Los problemas no se determinan buscando realmente archivos en el sitio Web; en su lugar, VSS busca archivos dentro del árbol de proyectos. Por ejemplo, suponga que el archivo $/Mi/Web/FU.ASP contiene la siguiente línea:

<A HREF="ORDER.HTM">

VSS se asegurará que existe $/My/Web/ORDER.HTM. Si el archivo existe el hipervínculo es válido y no es mostrado. Si el archivo no existe, este hipervínculo se mostrará como roto.

Los hipervínculos externos son saltos a sitios del World Wide Web que no están en su árbol de proyectos. VSS intentará resolver los hipervínculos externos de su página Web.

Resultados de comprobar hipervínculos

Archivo - Hipervínculos no válidos - Hipervínculos ignorados

Enumera el archivo que va a desprotegerse junto con un resumen de los hipervínculos no válidos y el número de hipervínculos pasados por alto.

Hay vínculos no válidos en el archivo

Enumera los hipervínculos internos y externos que VSS determina como no válidos.

Hipervínculos no comprobados en el archivo

Enumera los hipervínculos internos y externos que no fueron comprobados.

Nota Al hacer clic en un hipervínculo pasado por alto, se iniciará Internet Explorer que intentará resolver el hipervínculo y mostrar los resultados.


Proteger archivos en <Nombre de proyecto> (Cuadro de diálogo)

Comprueba las modificaciones hechas en el directorio de trabajo de su entorno de desarrollo con la base de datos de control de código fuente.

Para utilizar el comando Proteger:

  • En el menú Herramientas de Visual Basic haga clic en Obtener.

Opciones del cuadro de diálogo

Archivos para proteger

Presenta una lista con los archivos que pueden ser protegidos. Haga clic en los archivos que quiere proteger o en Seleccionar todo para seleccionar todos los archivos que aparecen en la lista

Comentario

Escriba un comentario opcional.

Mantener desprotegido

Actualiza la base de datos de control de código fuente con los cambios pero mantiene el archivo desprotegido a su nombre.

Aceptar

Protege los archivos seleccionados.

Cancelar

Cancela el comando Proteger.


Desproteger archivos desde (Cuadro de diálogo)

Desprotege uno o varios archivos seleccionados en su proveedor de control de código fuente y coloca una copia modificable en el directorio de trabajo del entorno de desarrollo correspondiente.

Para utilizar el comando Desproteger:

  • En el menú Herramientas de Visual Basic haga clic en Desproteger.

Opciones del cuadro de diálogo

Archivos para desproteger

Enumera los archivos disponibles para la desprotección. Haga clic en los archivos que desea desproteger o haga clic en Seleccionar todo para seleccionar todos los archivos de la lista.

Comentario

Describa brevemente la razón por la que desprotege el archivo.

Avanzadas

Muestra el cuadro de diálogo Desprotección avanzada.

Aceptar

Confirmar Desproteger.

Cancelar

Cancela el comando Desproteger.

Seleccionar todo

Selecciona todos los archivos que se enumeran.


Estado de desprotección (Ficha, cuadro de diálogo Propiedades )

Vea también

Muestra información de desprotección acerca de un archivo de VSS.

Para ver la ficha Estado de desprotección

  1. Haga clic en un archivo del panel de archivos del Explorador de VSS.

  2. En el menú Archivo, elija Propiedades y después elija la ficha Estado de desprotección.

Derechos de acceso

Debe disponer del derecho de acceso Leer para utilizar esta ficha.

Comentarios

Si más de un usuario tiene un archivo desprotegido, al hacer clic en Estado de desprotección se muestra una lista de todas las desprotecciones. Haga doble clic en una determinada desprotección para ver los detalles de esa desprotección. También puede proteger un archivo o deshacer la desprotección de un archivo.

Si el archivo seleccionado no se ha desprotegido, cuando elija Estado de desprotección VSS indicará que el archivo no está desprotegido y no mostrará las opciones de la ficha.

Opciones de la ficha

Nombre

Nombre del archivo seleccionado.

Por

Usuario que desprotegió el archivo seleccionado.

Fecha

Fecha y hora en que se desprotegió el archivo seleccionado.

Versión

Número de versión del archivo seleccionado.

Equipo

Nombre del equipo desde el que se desprotegió este archivo.

Carpeta

Carpeta de trabajo en la que está el archivo desprotegido.

Proyecto

Nombre del proyecto en el que está el archivo.

Desprotección exclusiva

Si aparece debajo del nombre, significa que el archivo o el proyecto está desprotegido exclusivamente para un usuario.

Comentario

Comentario que se especificó para el archivo. Es posible modificar o agregar un nuevo comentario en este cuadro de texto, con la condición de que no supere los 64 caracteres.

Cerrar

Cierra el cuadro de diálogo Propiedades y vuelve al Explorador de VSS.

Informe

Envía un informe al Portapapeles, a un archivo o a una impresora.


Desprotegidos (Cuadro de diálogo)

Muestra las distintas ubicaciones en las que tiene desprotegido un archivo.

Para ver el cuadro de diálogo Desprotecciones

  • En el menú Archivo, haga clic en Propiedades de archivo y seleccione la ficha Lista de desprotegidos.

Opciones del cuadro de diálogo

Desprotegidos

Enumera las ubicaciones en las que está desprotegido el archivo.

Detalles

Muestra los detalles del archivo seleccionado.

Proteger

Protege el archivo seleccionado.

Deshacer Desproteger

Deshace la desprotección del archivo seleccionado.

Cerrar

Cierra el cuadro de diálogo y cancela el comando.


Elegir proyecto de SourceSafe (Entorno de desarrollo)

Permite al usuario especificar la ubicación del proyecto de VSS que contiene los archivos sobre los que desea trabajar.

Opciones del cuadro de diálogo

Carpeta de trabajo

Especifica la ubicación del directorio que usará VSS para almacenar las copias de trabajo de los archivos recuperados de la base de datos de VSS.

Proyecto de SourceSafe que desea utilizar

Permite al usuario seleccionar el proyecto de VSS que contiene los archivos sobre los que desea trabajar.


Opciones de cuadros de diálogo de comandos (Ficha)

Especifica si se muestran los cuadros de diálogo de comandos al usar los comandos.

Para mostrar la ficha Cuadros de diálogo de comandos:

  • En el menú Herramientas haga clic en Opciones y a continuación en Cuadros de diálogo de comandos.

Derechos de acceso

Cualquier usuario de VSS puede utilizar esta ficha.

Comentarios

Si no utiliza nunca las opciones que ofrece por ejemplo el cuadro de diálogo Obtener la última versión, puede desactivar éstas de modo que VSS deje de mostrar el cuadro de diálogo Obtener la última versión cuando ejecuta el comando correspondiente. Es posible especificar un comportamiento diferente según esté seleccionado un proyecto o un directorio mediante los cinco comandos siguientes.

  • Obtener la última versión

  • Desproteger

  • Deshacer desproteger

  • Mostrar diferencias

  • Mostrar historial

Puede especificar diálogos de comandos para los comandos Distribuir y Crear mapa de sitios a nivel de proyecto.

Puede pasar por alto cualquier configuración del cuadro al presionar la tecla MAYÚSCULAS cuando selecciona alguno de los comandos anteriores. En este caso el cuadro de diálogo del comando se mostrará aunque la casilla de verificación correspondiente no esté activada.


Opciones de línea de comandos (Ficha)

Controla las opciones que afectan a la línea de comandos de VSS. Estas opciones no afectan al comportamiento del Explorador de VSS.

Para ver la ficha Opciones de línea de comandos

  • En el menú Herramientas, haga clic en Opciones y después haga clic en Opciones de línea de comandos.

Derechos de acceso

Cualquier usuario de VSS puede utilizar esta ficha.

Opciones de la ficha

Las dos primeras opciones afectan a la forma en que VSS interactúa con su carpeta de trabajo durante las operaciones de la línea de comandos. De forma predeterminada, en el Explorador, VSS espera que se establezca una carpeta de trabajo para cada proyecto y desprotegerá los archivos sólo en esa carpeta. De forma predeterminada, en la línea de comandos, VSS presupone que su proyecto y carpeta actuales son con los que desea trabajar e ignora cualquier otra carpeta de trabajo establecida para un proyecto determinado. Para cambiar los proyectos actuales, es necesario utilizar el comando CP. Puede modificar este comportamiento si activa una de las dos opciones siguientes:

Asume la Carpeta de trabajo basada en el proyecto actual

Determina cómo se utiliza la carpeta de trabajo que ha establecido:

  • Si se selecciona esta opción, se coloca un archivo en la carpeta de trabajo del proyecto, incluso aunque no sea la carpeta actual cuando ejecuta un comando sobre un archivo desde la línea de comandos.

  • Si no se selecciona esta opción, los subproyectos van en sus respectivas carpetas de trabajo en lugar de hacerlo en subcarpetas bajo la carpeta principal.

Proyecto basado en la carpeta de trabajo

Establece automáticamente el proyecto actual, basándose en la carpeta actual. Si está establecida, SourceSafe examina su carpeta actual siempre que ejecute cualquier comando de VSS. Si ésta es la carpeta de trabajo para un proyecto de VSS, VSS cambia automáticamente a ese proyecto antes de ejecutar el comando. Por tanto, puede cambiar las carpetas para desplazarse por sus proyectos sin ejecutar nunca el comando ss Cp. Si establece esta opción, se recomienda encarecidamente que no asigne a dos proyectos la misma carpeta de trabajo, ya que VSS no sabrá a qué proyecto cambiar.

Si no se establece, SourceSafe no cambia a su proyecto actual cuando ejecute cualquier comando de VSS.

Sin comentarios en desprotegido

No solicita un comentario para la desprotección.

Aplicar el mismo comentario a todos los archivos

Le solicita sólo un comentario (hasta 64 caracteres), que VSS aplica a todos los archivos implicados en esa operación de desprotección.

Aplicar diferentes comentarios a cada archivo

Le solicita un comentario distinto para cada archivo implicado en la operación de desprotección.

Pedir comentarios en la línea de comandos

Pide comentarios en la línea de comandos.

Utilizar editor para pedir comentarios

Le permite especificar un comentario para indicar sus comentarios de la línea de comandos. Una vez seleccionada esta opción, puede especificar la ruta de acceso del editor seleccionado en el cuadro Editor. Puede examinar el sistema de archivos en busca de esta información mediante el botón Examinar. Si deja en blanco el cuadro Cadena de petición, no se mostrará ninguna petición en su editor.

Usar cadena de petición

Determina que se insertará una cadena de petición de comentario en su editor específico siempre que se abra. Aparecerá desactivada cuando seleccione Pedir comentarios en la línea de comandos. La cadena de petición no se guardará con el comentario (no tendrá que eliminarla), a menos que modifique la cadena en su editor.


Comentario (Cuadro de diálogo)

Permite especificar un comentario para los comandos Agregar archivos, Compartir o Combinar bifurcaciones.

Opciones del cuadro de diálogo

Comentario

Escriba un comentario para esta operación.

Aceptar

Escribe el comentario o los comentarios seleccionados en la base de datos de VSS

Cancelar

Cancela los comandos Agregar archivos, Compartir o Combinar bifurcaciones.

Las siguientes opciones están disponibles durante la operación Agregar archivos.

Aplicar el mismo comentario para todos

Aplica el mismo comentario a todos los archivos seleccionados para la operación de Agregar archivos. Si esta casilla de verificación está desactivada, puede escribir un comentario distinto para cada archivo. De forma predeterminada, esta casilla de verificación está activada (su comentario se aplicará a todos los archivos seleccionados para esta operación).

Recursiva

Indica que quiere agregar todos los archivos de las subcarpetas cuando selecciona toda una carpeta para agregar. Sólo está disponible cuando selecciona una carpeta y hace clic en Agregar.

Opciones avanzadas

Guardar sólo la última versión

Indica que no desea guardar versiones antiguas del archivo o los archivos que se agregan a la base de datos de VSS. VSS mantiene un historial de los cambios al archivo y sus respectivos comentarios. De todas formas, las versiones antiguas del archivo no se almacenan y, por tanto, no se pueden recuperar.

Nota Para incrementar el rendimiento y ahorrar espacio del disco, use esta opción cuando almacene programas ejecutables en VSS.

Desproteger inmediatamente

Desprotege el archivo justo después de agregarlo a VSS.

Quitar copia local

Elimina el archivo de la carpeta de trabajo después de agregarlo a VSS.

Tipo de archivo

Seleccione una opción del cuadro de lista.

  • Detección automática: VSS determina el tipo de archivo.

  • Binario: VSS trata al archivo como un archivo binario.

  • Texto: VSS trata al archivo como un archivo de texto.

Nota Cuando agregue una carpeta, VSS pasará por alto el valor del campo Tipos de archivo. No obstante, VSS filtrará los archivos agregados durante la operación Agregar archivos a una carpeta según el valor de Relevant_Masks en la ficha Tipos de archivo del cuadro de diálogo Opciones de SourceSafe.


Conectarse a VSS (Cuadro de diálogo)

Permite al usuario seleccionar la ubicación de la base de datos a la que desea conectarse.

Para mostrar el cuadro de diálogo Conectarse a VSS:

  • En el menú Complementos haga clic en SourceSafe y a continuación en Abrir nuevo proyecto de SourceSafe.

Opciones del cuadro de diálogo

Ruta de la base de datos de SourceSafe

Escriba la ruta completa y el nombre de la base de datos de VSS con la que desea conectar. Utilice el botón Examinar para determinar el nombre completo.

Ruta de datos (opcional)

Escriba el identificador deseado para el proyecto de datos. Consulte su administrador de VSS para obtener ayuda acerca del uso de este identificador. (Su administrador de VSS debe establecer este identificador mediante la variable Data_Path).

Aceptar

Conecta con la base de datos especificada, si está disponible.

Cancelar

Cancela la conexión a la base de datos.


Contenido de <Nombre de proyecto> (Cuadro de diálogo)

Muestra el contenido del proyecto seleccionado de VSS

Para mostrar el cuadro de diálogo Contenido de <Nombre de proyecto>:

  1. Seleccione un proyecto en el Explorador de VSS.

  2. En el menú Herramientas, haga clic en Mostrar historial.

  3. Haga clic en Aceptar en el cuadro de diálogo Opciones de historial.

  4. Seleccione un archivo en la lista del cuadro de diálogo Historial del proyecto.

  5. Haga clic en Ver.

Opciones del cuadro de diálogo

Marca de fecha y hora

Muestra la marca de fecha de la última versión del archivo en VSS.

Archivos

Enumera los archivos del proyecto junto con sus números de versión actual.


Crear un proyecto local de SourceSafe (Cuadro de diálogo)

Permite al usuario crear un nuevo proyecto de desarrollo a partir un proyecto de VSS existente.

Para usar el comando Descargar proyecto de SourceSafe:

  1. En el menú Archivo haga clic en Abrir espacio de trabajo.

  2. Seleccione el botón Control de código fuente en la esquina inferior derecha del cuadro de diálogo.

Opciones del cuadro de diálogo

Crear un proyecto nuevo en esta carpeta

La carpeta de trabajo correspondiente al proyecto seleccionado. Haga clic en Examinar para crear o cambiar la carpeta de trabajo.

Proyecto de SourceSafe para descargar

lista de proyecto de VSS. Haga clic en el proyecto que desea abrir.

Aceptar

VSS obtiene los archivos, los coloca en el su carpeta de trabajo y abre el proyecto en su entorno de desarrollo con el fin de que pueda modificarlos.

Cancelar

Cancela el comando Descargar proyecto de SourceSafe.


Crear mapa de sitios (Cuadro de diálogo)

Vea también

Le permite crear un mapa de su sitio Web, utilizando los archivos HTML comprobados en su proyecto de VSS como destinos para saltos HTML.

Opciones del cuadro de diálogo

En

Especifica el archivo que contiene el código de mapa de sitios HTML resultante. Haga clic en Examinar para buscar en el sistema de archivos una ubicación adecuada.

Proteger con VSS

Active esta casilla de verificación para proteger el archivo resultante en el proyecto de VSS.

Aceptar

Confirma sus selecciones.

Cancelar

Cancela sus selecciones.


Elementos eliminados (Ficha, cuadro de diálogo Propiedades)

Vea también

Muestra una lista de los archivos y subproyectos que se han quitado del proyecto actual.

Para ver la ficha Elementos eliminados

  1. Haga clic en un proyecto del panel de proyectos del Explorador de VSS.

  2. En el menú Archivo, haga clic en Propiedades y después haga clic en la ficha Elementos eliminados.

Derechos de acceso

Debe disponer del derecho de acceso Leer para utilizar esta ficha.

Comentarios

Cuando utilice el comando Eliminar para eliminar un archivo o un proyecto de VSS, el elemento eliminado se quita del Explorador de VSS. Sin embargo, VSS continúa almacenando el elemento, de forma que puede recuperarlo si desea generar una versión anterior del proyecto. No obstante, después de recuperar o purgar un elemento, deja de aparecer en la lista de la ficha Elementos eliminados.

Opciones de la ficha

Elementos

Lista de todos los archivos y subproyectos eliminados del proyecto actual.

Recover

Recupera (deshace la eliminación) un elemento y lo coloca en la lista de archivos o lista de proyectos.

Purgar

Elimina de forma permanente un elemento, de forma que no puede recuperarse.

Cerrar

Cierra la ficha Elementos eliminados y vuelve al Explorador de VSS.

Informe

Envía un informe al Portapapeles, a un archivo de texto o a una impresora.


Distribuir (Cuadro de diálogo)

Le permite establecer opciones para la distribución de su proyecto de sitio Web.

Opciones del cuadro de diálogo

Si activa el cuadro de diálogo del comando Distribuir en la ficha Diálogos de comandos del cuadro de diálogo Opciones de SourceSafe (menú Herramientas), o si mantiene presionada la tecla MAYÚSCULAS mientras hace clic en el comando Distribuir, tendrá las opciones siguientes:

En

Escriba la ruta de acceso en la que desea que VSS coloque los archivos. Puede examinar la ubicación apropiada.

Permitir escritura

Establece el indicador de lectura y escritura de forma que el archivo sea modificable. No es el comportamiento predeterminado, pero puede resultar útil si desea probar un cambio temporal en el archivo o desea cambiar el nombre del archivo después de obtenerlo.


Designar archivo de proyecto (Cuadro de diálogo)

Permite al usuario especificar qué archivo de proyecto de Visual Basic en VSS puede usarse para generar un nuevo proyecto de Visual Basic.

Nota Este cuadro de diálogo aparecerá tan sólo cuando un usuario hace clic en el comando Crear un proyecto de SourceSafe y existen dos o más archivos de proyecto de Visual Basic almacenados en el mismo proyecto de VSS. Dado que Visual Basic no sabe a partir de qué elementos de VSS debe crear un nuevo proyecto, Visual Basic pregunta al usuario para que éste decida.

Opciones del cuadro de diálogo

Seleccione el archivo de Visual Basic

Muestra al usuario la lista de los archivos de proyecto de Visual Basic almacenados en VSS que puede utilizar para crear un nuevo archivo de proyecto de Visual Basic.

Aceptar

VSS creará un nuevo archivo de Visual Basic a partir del elemento seleccionado en la lista Seleccione el archivo de Visual Basic.

Cancelar

Cancela el comando Crear un proyecto de VSS.


Diferencias de proyecto (Cuadro de diálogo)

Muestra las diferencias entre los archivos del proyecto seleccionado de la base de datos de VSS y los de la carpeta de trabajo establecida para ese proyecto. También puede ver qué hay de diferente dentro del archivo y sincronizar las diferencias, si lo desea.

Para ver el cuadro de diálogo Diferencias de proyecto

  1. Haga clic en un proyecto del panel de proyectos del Explorador de VSS.

  2. En el menú Herramientas, haga clic en Mostrar diferencias. Realice las selecciones deseadas en el cuadro de diálogo Diferencias de proyecto si está activado y haga clic en Aceptar.

Nota Active la presentación del cuadro de diálogo Diferencias de proyecto en la ficha Diálogos de comandos del cuadro de diálogo Opciones de SourceSafe (menú Herramientas).

Opciones del cuadro de diálogo

Este importante cuadro de diálogo se compone de dos paneles: en uno se muestran los archivos que hay en su proyecto actual (a la izquierda) y en el otro los archivos que se encuentran en la carpeta de trabajo asignada al proyecto actual (a la derecha). Este cuadro de diálogo también tiene su propia barra de herramientas, con botones para agregar, eliminar, obtener, proteger y desproteger archivos, deshacer desprotecciones, ver archivos, sincronizar las diferencias entre el proyecto y la carpeta de trabajo, etc.

En ambos paneles, los archivos están ordenados alfabéticamente por nombre de archivo o de carpeta (si hay subcarpetas). Recuerde que la lista de archivos en los paneles derecho e izquierdo se ha filtrado de acuerdo con las opciones elegidas en el diálogo del comando Mostrar diferencias. Por ejemplo, si ha elegido mostrar sólo los archivos que sean diferentes en ambos sitios, no verá los archivos que sean iguales en la carpeta de trabajo y en el proyecto actual. Puede cambiar el tamaño de las columnas en el panel izquierdo si arrastra la barra de la columna con el botón primario del mouse. Si presiona F5 se actualizará la información del cuadro de diálogo (pero es posible que sea lento para proyectos de gran tamaño).

En las listas pueden aparecer cuatro tipos de archivo.

  • De forma predeterminada, los archivos que son iguales en el proyecto y en la carpeta de trabajo aparecen con letras negras sobre un fondo blanco. No es necesario que haga nada con estos archivos.

  • De forma predeterminada, los archivos que están en el proyecto, pero no en la carpeta de trabajo, aparecen de color azul sobre un fondo gris. Un archivo así normalmente representa un archivo agregado al proyecto por otro usuario (en cuyo caso es posible que desee obtenerlo) o un archivo que eliminó de su carpeta de trabajo (en cuyo caso es posible que desee eliminarlo de VSS).

  • De forma predeterminada, los archivos que se encuentran en la carpeta de trabajo, pero no en el proyecto, aparecen de color verde sobre un fondo gris. Un archivo así suele representar un archivo creado por usted (en cuyo caso es posible que desee agregarlo a VSS) o que otro usuario ha eliminado del proyecto (en cuyo caso puede que desee eliminar su copia local).

  • De forma predeterminada, los archivos que están en ambos sitios, pero que son diferentes, aparecen de color rojo sobre un fondo gris. Un archivo así generalmente representa un archivo que usted ha protegido (puede que desee protegerlo) o un archivo protegido por otro usuario (y que es posible que desee obtener).

Nota Puede establecer los colores predeterminados para texto agregado, modificado y eliminado mediante la ficha Diferencias del cuadro de diálogo Opciones del menú Herramientas.

Anteriormente se ha ofrecido una lista completa de los cuatro tipos de archivo, aunque no se describen todas sus posibilidades. Por ejemplo, si otro usuario cambia el nombre de un archivo en VSS verá un archivo que no tiene realmente, en la lista de archivos para ese proyecto en el Explorador de VSS; en la carpeta de trabajo para el proyecto habrá un archivo que no está presente en la base de datos de VSS. Por tanto, es posible que desee obtener el archivo de VSS y eliminar el suyo local para sincronizar las diferencias.

Los iconos de archivo del panel izquierdo del cuadro de diálogo representan las mismas cosas que en la ventana principal del Explorador, una marca de verificación situada junto a un archivo indica que el archivo está desprotegido, etc. Los iconos de archivo del panel derecho representan condiciones específicas del usuario, por ejemplo, una marca de verificación en el panel derecho indica que el archivo está desprotegido concretamente para usted en su directorio de trabajo. Al hacer doble clic sobre un archivo puede verlo. Si hace doble clic en una carpeta no sucede nada.

Los comandos de la barra de herramientas de este cuadro de diálogo suelen funcionar igual que los comandos estándar de VSS, con las siguientes diferencias:

  • El comando Agregar mueve un archivo o una carpeta del panel derecho al panel izquierdo. Es decir, agrega un archivo de su carpeta de trabajo al proyecto de VSS. La tecla de método abreviado para este comando es la tecla de aplicación de Windows 95 + A.

  • El comando Eliminar funciona normalmente si hay un archivo seleccionado en el panel izquierdo. Si se selecciona un archivo en el panel derecho, puede utilizar el comando Eliminar para eliminar la carpeta o el archivo local de su carpeta de trabajo. La tecla de método abreviado para este comando es la tecla SUPR.

  • El comando Obtener la última versión funciona como siempre, obteniendo un archivo o un proyecto del panel izquierdo al panel derecho. La tecla de método abreviado para este comando es la tecla de aplicación de Windows 95 + G.

  • El comando Desproteger funciona como siempre, sincronizando las diferencias entre un archivo que es distinto en los dos paneles y que no está desprotegido en el panel derecho, desprotegiendo el archivo y sobrescribiendo el archivo en su carpeta de trabajo local. La tecla de método abreviado para este comando es la tecla de aplicación de Windows 95 + O.

  • El comando Proteger funciona normalmente, sincronizando un archivo que se encuentra en ambos paneles, aunque sea distinto, y que está desprotegido en los dos paneles. Con este comando guardará las últimas modificaciones realizadas al archivo en la carpeta de trabajo. La tecla de método abreviado para este comando es la tecla de aplicación de Windows 95 + I.

  • El comando Deshacer desprotección funciona como siempre, sincronizando un archivo que es distinto en ambos paneles y que está desprotegido en ambos mediante la desprotección del archivo. Con este comando se pierden las últimas modificaciones del archivo en la carpeta de trabajo. La tecla de método abreviado para este comando es la tecla de aplicación de Windows 95 + U.

  • El comando Ver funciona sobre un archivo seleccionado en el panel izquierdo igual que el comando Ver del Explorador; muestra el archivo en la base de datos de VSS. El comando Ver funciona sobre un archivo seleccionado en el panel derecho abriendo directamente el visor adecuado en el archivo en la carpeta. La tecla de método abreviado para este comando es la tecla de aplicación de Windows95 + V.

  • El comando Diferencias compara dos archivos seleccionados. Si sólo hay un archivo seleccionado, Diferencias lo compara entre el proyecto y la carpeta de VSS. La tecla de método abreviado para este comando es la tecla de aplicación de Windows 95 + S.

  • El comando Actualizar lista de archivos pone al día la lista de archivos.

  • El comando Sincronizar todo sincroniza las diferencias encontradas entre los proyectos comparados. La sincronización puede hacer referencia a varias cosas distintas, dependiendo de las opciones elegidas en los cuadros de diálogo que se presentan después de elegir este comando.

  • El comando Informe genera el cuadro de diálogo estándar Informe. La tecla de método abreviado para este comando es la tecla F5.

Nota Si utiliza un mouse, puede acceder a muchos de los comandos anteriores con el botón secundario del mouse.


Opciones de diferencia (Cuadro de diálogo)

Muestra las diferencias entre la copia local de un archivo o proyecto y la copia almacenada en la base de datos de VSS.

Para ver el cuadro de diálogo Historial de archivo

  1. Seleccione un archivo o un proyecto en el Explorador de VSS.

  2. En el menú Herramientas, haga clic en Mostrar diferencias.

Opciones del cuadro de diálogo

Comparar

Escriba el nombre del archivo que desea comparar. Utilice el botón Examinar si necesita buscar el archivo. Puede elegir entre examinar los archivos en el proyecto de VSS o en las carpetas de Windows del disco duro. Para comparar una determinada versión de un archivo, debe agregar un signo de punto y coma y el número de versión al nombre del archivo. Por ejemplo:

HELP.C; 5

Con

Escriba el nombre del archivo con el que desea comparar el primer archivo. Utilice el botón Examinar si necesita buscar el archivo. Puede elegir entre examinar los archivos en el proyecto de VSS o en las carpetas de Windows del disco duro.

Formato

Elija Visual si desea utilizar el visor Visual de VSS (lado a lado), SourceSafe si desea utilizar el antiguo formato de SourceSafe (mostrar únicamente las líneas agregadas, eliminadas o modificadas) o Unix si desea utilizar el formato Unix (mostrar únicamente las líneas modificadas, marcando las versiones antigua y nueva).

Ignorar espacios en blanco

Active esta casilla de verificación si desea que VSS pase por alto las diferencias en cuanto a espacios en blanco; es decir, las líneas que sólo se diferencian en cuanto a espacio, tabulador u otros caracteres de espacios en blanco.

Pasar por alto MAY/min

Active esta casilla de verificación si desea que VSS pase por alto las diferencias en cuanto a mayúsculas y minúsculas.

Aceptar

Confirma sus selecciones.

Cancelar

Cancela sus selecciones.

Informe

Le permite imprimir un informe con información de error en el Portapapeles, una impresora o un archivo.

Opciones avanzadas

Haga clic en este botón para especificar opciones avanzadas de Diferencia de archivo.

Ignorar diferencias del SO

Active esta casilla de verificación si desea que VSS pase por alto las diferencias en el archivo debidas al desarrollo de distintos sistemas operativos (como los caracteres de fin de línea).

Guardar configuración

Active esta casilla de verificación si desea guardar las opciones elegidas para utilizarlas en posteriores operaciones de Mostrar diferencias.

Mostrar contexto

Active esta casilla de verificación si desea mostrar información contextual. (Básicamente, esto significa que además de mostrar únicamente una línea modificada, VSS también mostrará las líneas que rodean a dicha línea para proporcionar cierto contexto a la información.) Esta opción no es aplicable cuando está utilizando el formato visual; sólo se aplica para los formatos SourceSafe y Unix.

Líneas

Si ha activado la casilla de verificación Mostrar contexto, este cuadro le permite especificar el número de líneas de información contextual desea ver.

Mostrar sólo cuando se presiona Máyus

Salta este cuadro de diálogo en las futuras operaciones de diferencias de archivos y utiliza los valores especificados como predeterminados. Para restaurar el cuadro de diálogo, desactive la casilla de verificación correspondiente en la ficha Diálogos de comandos del cuadro de diálogo Opciones de SourceSafe. Si presiona la tecla MAYÚSCULAS mientras hace clic en el comando Mostrar diferencias, siempre se mostrará este cuadro de diálogo, invalidando el valor especificado en la ficha Diálogos de comandos.


Opciones de diferencia (Ficha)

Vea también

Le permite especificar opciones para ver diferencias entre archivos y proyectos. Estas opciones se utilizan en otros cuadros de diálogo de VSS como el cuadro de diálogo Diferencias de proyecto y Combinación visual.

Opciones del cuadro de diálogo

Restablecer

Restablece todos los valores predeterminados de esta ficha.

Colores

En esta área de la ficha hay una lista de los tipos de texto y de línea. A medida que seleccione cada tipo irá viendo el color correspondiente utilizado para ese tipo de línea o de texto en el área Ejemplo.

Nota El color de un marcador en los visores es el mismo que el color de fondo de Texto de la selección.

Primer plano

Este control es una lista desplegable que se utiliza para seleccionar el color del primer plano.

Fondo

Este control es una lista desplegable que se utiliza para seleccionar el color de fondo.

Fuente

Muestra la fuente seleccionada utilizada en las distintas ventanas de visor. Haga clic en Modificar para cambiar la fuente.

Ancho de tabulación

Muestra el número de espacios en blanco al que equivale cada tabulador.

Mostrar números de línea

Muestra los números de línea en los distintos visores.

Ignorar diferencias en espacios en blanco al combinar archivos

Active esta casilla de verificación para pasar por alto las diferencias que aparezcan en cuanto a espacios en blanco (tabuladores, espacios, etc.) al combinar archivos.

Aceptar

Confirma sus selecciones.

Cancelar

Cancela sus selecciones.


Diferencias de archivo (Cuadro de diálogo)

Vea también

Muestra las diferencias existentes entre la versión de la carpeta de trabajo del archivo seleccionado y la versión de la base de datos de VSS de dicho archivo.

Para mostrar el cuadro de diálogo Diferencias de archivo

  1. Haga clic en un archivo del panel de archivos del Explorador de VSS.

  2. En el menú Herramientas, haga clic en Mostrar diferencias.

  3. Si los archivos comparados son iguales, se mostrará un mensaje para indicar que los archivos son idénticos. VSS no puede mostrar las diferencias de los archivos binarios; sólo puede indicar si los archivos binarios son distintos o no. Si los archivos de texto difieren, VSS mostrará el cuadro de diálogo Diferencias de archivo.

  4. Haga las selecciones deseadas en el cuadro de diálogo Diferencias de archivo, si está activado, y haga clic en Aceptar.

Nota Active la presentación del cuadro de diálogo Opciones de diferencia en la ficha Diálogos de comandos del cuadro de diálogo Opciones de SourceSafe (menú Herramientas).

Comentarios

El cuadro de diálogo Diferencias de archivo muestra dos archivos puestos lado a lado. Utiliza tres colores con el fin de señalar la líneas eliminadas, modificadas o agregadas. Puede cambiar los colores al establecer las opciones de la ficha Diferencias del cuadro de diálogo Opciones de Herramientas. No puede hacer cambios a los archivos en este cuadro de diálogo: sólo permite mostrar las diferencias.

Nota Para comparar un archivo actual de VSS con una versión anterior del mismo archivo, haga clic en el archivo en el panel de archivos del Explorador de VSS y, en el menú Herramientas, haga clic en Mostrar historial. Después, haga clic en Diferencias.

Opciones del cuadro de diálogo

Dicho cuadro dispone de una barra de herramientas que contiene todos los comandos que necesita para buscar y marcar diferencias:

Buscar

Permite buscar una cadena en el archivo. La tecla de método abreviado es Alt-F3.

Buscar siguiente

Permite buscar la aparición siguiente de una cadena en el archivo. La tecla de método abreviado es F3.

Buscar anterior

Permite buscar la aparición anterior de una cadena en el archivo. La tecla de método abreviado es Mayús-F3.

Alternar marcador

Permite activar o desactivar un marcador en un archivo. La tecla de método abreviado es Ctrl-F2.

Marcador siguiente

Permite ir al marcador siguiente en el archivo. La tecla de método abreviado es F2.

Marcador anterior

Permite ir al marcador anterior en el archivo. La tecla de método abreviado es Mayús-F2.

Borrar todos los marcadores

Permite borrar todos los marcadores en el archivo.

Diferencia anterior

Permite encontrar la diferencia anterior en el archivo. La tecla de método abreviado es Mayús-F7.

Diferencia siguiente

Permite buscar la diferencia siguiente en el archivo. La tecla de método abreviado es F7.


Diferencias de archivo (Cuadro de diálogo)

Vea también

Muestra las diferencias existentes entre la versión de la carpeta de trabajo del archivo seleccionado y la versión de la base de datos de VSS de dicho archivo.

Para mostrar el cuadro de diálogo Diferencias de archivo

  1. Asegúrese que el botón SourceSafe o Unix está seleccionado en el cuadro de diálogo Opciones de Diferencias.

  2. Haga clic en un archivo del panel de archivos del Explorador de VSS.

  3. En el menú Herramientas, haga clic en Mostrar diferencias.

  4. Si los archivos comparados son iguales, se mostrará un mensaje para indicar que los archivos son idénticos. VSS no puede mostrar las diferencias de los archivos binarios; sólo puede indicar si los archivos binarios son distintos o no. Si los archivos de texto difieren, VSS mostrará el cuadro de diálogo Diferencias de archivo.

  5. Haga las selecciones deseadas en el cuadro de diálogo Diferencias de archivo, si está activado, y haga clic en Aceptar.

Nota Active la presentación del cuadro de diálogo Opciones de diferencia en la ficha Diálogos de comandos del cuadro de diálogo Opciones de SourceSafe (menú Herramientas).

Comentarios

Este cuadro de diálogo sólo se utiliza cuando no ha seleccionado la comparación visual de diferencias. (En el caso de las diferencias visuales, asegúrese de seleccionar la opción Visual en el cuadro de diálogo Opciones de diferencia.) De manera predeterminada, VSS utiliza el cuadro de diálogo Diferencia visual. La diferencia Visual muestra los archivos uno al lado del otro y le permite hacer fácilmente cambios a uno de ellos. La diferencia de tipo SourceSafe muestra una simple lista de líneas que se han agregado, eliminado y cambiado, optimizada para facilitar su lectura. La opción Unix muestra las diferencias en el formato utilizado por el programa Diff de UNIX.

Si especifica la presentación UNIX, VSS usará las opciones de presentación de SourceSafe para Pasar por alto MAY/min e Ignorar espacios en blanco. La opción de presentación SourceSafe calcula los anchos de línea para que quepan en la pantalla y no muestra líneas de contexto.

Nota Para comparar un archivo actual de VSS con una versión anterior del mismo archivo, haga clic en el archivo en el panel de archivos del Explorador de VSS y, en el menú Herramientas, haga clic en Mostrar historial. Después, haga clic en Diferencias.


Opciones de historial de archivos (Cuadro de diálogo)

Le permite especificar opciones para presentar el historial del proyecto.

Opciones del cuadro de diálogo

Incluir etiquetas

Permite controlar si se mostrarán las etiquetas de archivo en el historial correspondiente al archivo especificado.

Sólo etiquetas

Sólo incluye etiquetas en el historial del proyecto si ha seleccionado la opción Incluir etiquetas. Puede utilizar esta casilla de verificación con los campos Desde y En para buscar todos los proyectos que tienen la etiqueta designada, pero no buscará los archivos de esos proyectos que tengan las etiquetas designadas.

Desde

Restringe el informe de historial al principio de la fecha especificada. Escriba una fecha, fecha y hora, versión o etiqueta. Utilice el prefijo D para indicar una fecha o fecha y hora, y el prefijo L para indicar una etiqueta. Por ejemplo "D02/29/95;12:15" o "Lbeta1". Las fechas pueden especificarse en el formato 08.15.95, 08-15-95 u 08/15/95, pero no como 15 de agosto de 1995.

En

Restringe el informe de historial al final de la fecha especificada. Escriba una fecha, fecha y hora, versión o etiqueta. Utilice el prefijo D para indicar una fecha o fecha y hora, y el prefijo L para indicar una etiqueta. Por ejemplo "D02/29/95;12:15" o "Lbeta1". Las fechas pueden especificarse en el formato 08.15.95, 08-15-95 u 08/15/95, pero no como 15 de agosto de 1995.

Usuario

Muestra un historial de los archivos en los que ha trabajado el usuario especificado.

Aceptar

Muestra el cuadro de diálogo Historial del proyecto. En este cuadro de diálogo, haga clic en cualquiera de los elementos de la lista y, después, haga clic en Detalles para mostrar el cuadro de diálogo Detalles de historial. Desde el cuadro de diálogo Detalles de historial, puede hacer clic en los botones Siguiente y Anterior para desplazarse hacia arriba y hacia abajo por la pantalla del historial. También puede modificar el comentario y la etiqueta asociados con la versión que está viendo.

Mostrar sólo cuando se presiona Mayús

Salta este cuadro de diálogo en las futuras operaciones de Mostrar historial y utiliza los valores especificados como predeterminados. Para restaurar el cuadro de diálogo, haga clic en la casilla de verificación apropiada de la ficha Diálogos de comandos del cuadro de diálogo Opciones de SourceSafe.


Opciones de historial de archivos/proyectos (Cuadro de diálogo)

Le permite especificar opciones para presentar el historial del proyecto.

Opciones del cuadro de diálogo

Incluir historiales de archivos (sólo para historiales de proyectos)

Incluye archivos en el historial del proyecto.

Recursivo (sólo para historiales de proyectos)

Incluye subproyectos y todos los archivos que contienen.

Sólo etiquetas

Sólo incluye etiquetas en el historial del proyecto si ha seleccionado la opción Incluir etiquetas. Puede utilizar esta casilla de verificación con los campos Desde y En para buscar todos los proyectos que tienen la etiqueta designada, pero no buscará los archivos de esos proyectos que tengan las etiquetas designadas.

Desde

Restringe el informe de historial al principio de la fecha especificada. Escriba una fecha, fecha y hora, versión o etiqueta. Utilice el prefijo D para indicar una fecha o fecha y hora, y el prefijo L para indicar una etiqueta. Por ejemplo "D02/29/95;12:15" o "Lbeta1". Las fechas pueden especificarse en el formato 08.15.95, 08-15-95 u 08/15/95, pero no como 15 de agosto de 1995.

En

Restringe el informe de historial al final de la fecha especificada. Escriba una fecha, fecha y hora, versión o etiqueta. Utilice el prefijo D para indicar una fecha o fecha y hora, y el prefijo L para indicar una etiqueta. Por ejemplo "D02/29/95;12:15" o "Lbeta1". Las fechas pueden especificarse en el formato 08.15.95, 08-15-95 u 08/15/95, pero no como 15 de agosto de 1995.

Usuario

Muestra un historial de los archivos en los que ha trabajado el usuario especificado.

Aceptar

Muestra el cuadro de diálogo Historial de proyecto. En este cuadro de diálogo, haga clic en cualquiera de los elementos de la lista y, después, haga clic en Detalles para mostrar el cuadro de diálogo Detalles de historial. Desde el cuadro de diálogo Detalles de historial, puede hacer clic en los botones Siguiente y Anterior para desplazarse hacia arriba y hacia abajo por la pantalla del historial. También puede modificar el comentario y la etiqueta asociados con la versión que está viendo.

Mostrar sólo cuando se presiona Mayús

Salta este cuadro de diálogo en las futuras operaciones de Mostrar historial y utiliza los valores especificados como predeterminados. Para restaurar el cuadro de diálogo, haga clic en la casilla de verificación apropiada de la ficha Diálogos de comandos del cuadro de diálogo Opciones de SourceSafe.


Tipos de archivos (Ficha Opciones)

Existen dos fichas de opciones de tipos de archivo disponibles, una para el usuario de VSS y la otra para el administrador de VSS.

Seleccione una de las posibilidades siguientes:

  • Administrador de VSS - Ficha opciones de tipos de archivo

  • Usuario de VSS - Ficha opciones de tipos de archivo


Tipos de archivos (Ficha Opciones, usuario de VSS)

Vea también

Establece opciones relacionadas con el tipo de los archivos que almacena en VSS.

Para mostrar la ficha Tipos de archivos:

  • En el menú Herramientas haga clic en Opciones y a continuación en la ficha Tipos de archivos.

Derechos de acceso

Cualquier usuario de VSS puede utilizar esta ficha.

Comentarios

Muchos de los cuadros de diálogo de VSS contienen listas de archivos que le permiten seleccionar archivos múltiples para una operación específica. Utilice esta ficha para filtrar estas listas de archivos de forma que tengan más sentido para el tipo de trabajo que realice. Por ejemplo, si es un desarrollador de C++, es posible que quiera guardar archivos .CPP, .H, .RC, y .BMP en VSS. Por otro lado, si es un programador en Visual Basic, puede preferir almacenar archivos .VBP y .FRM. Es posible usar la ficha con el fin de restringir las listas de archivos y mostrar solamente esos tipos de archivos en lugar de todos los de una carpeta específica.

Opciones de la ficha

Archivos binarios

Modifica la detección automática de VSS de los archivos de texto y binarios con el fin de permitirle considerar siempre algunos tipos de archivos como binarios. Por ejemplo, puede escribir *.OBJ, *.XLS, *.FRX en este campo con el fin de especificar que todos los archivos de objeto, las hojas de cálculo de Microsoft Excel y los archivos .FRX de Visual Basic siempre deben considerarse como archivos binarios.

Crear archivo SCC

Esta casilla sólo sirve para los usuarios de Visual Basic. Cuando trabaja con un proyecto de Visual Basic en VSS, se crea un archivo especial en su carpeta de trabajo llamado MSSCCPRJ.SCC. Este archivo nunca puede ser agregado a VSS: permanece en su carpeta de trabajo y almacena información importante utilizada para la integración de VSS en Visual Basic.

La opción Crear archivo SCC determina cuándo VSS debe crear este archivo. Su valor predeterminado (*.VBP, *.MAK) significa que siempre que obtenga o agrege un archivo con una extensión .VBP (archivo de proyecto de Visual Basic 4.0) o .MAK (utilizado por las versiones anteriores de Visual Basic), VSS creará el archivo MSSCCPRJ.SCC. Este archivo es muy importante, ya que sin él la integración de VSS en Visual Basic no funcionará correctamente.

Por su lado, Visual C++ y los otros entornos de desarrollo no utilizan este archivo para nada. Puede que no le interese mostrar este archivo inservible en su carpeta de Visual C++. Para impedir que aparezca el archivo MSSCCPRJ.SCC en su carpeta de Visual C++, elimine el archivo *.MAK de este campo. (Conviene hacer este cambio tan sólo si no utiliza archivos .MAK de Visual Basic 3.0)

Grupos de archivos

Junto con la opción "Tipos de archivo incluidos en grupo de archivos", esta opción permite agrupar tipos de archivos en agrupaciones lógicas. Estos grupos se muestran en las opciones Mostrar archivos de tipo de muchos de los cuadros de diálogo de VSS con el fin de especificar grupos que filtren eficientemente la lista de archivos durante su trabajo.

Utilice el botón Agregar para agregar un nuevo grupo de extensiones a la lista, y el botón Eliminar para eliminar el grupo actualmente seleccionado. El ejemplo siguiente podría crear grupos de archivos que incluyen archivos .FRM y .BAS pero excluyen explícitamente el archivo HELP.FRM:

*.frm; *.bas; !HELP.FRM

El grupo de archivos <Máscaras relevantes> es un caso especial. No es posible eliminar este grupo y sirve para indicar qué archivos podría colocar en un proyecto típico. Esto no le impide colocar otros archivos dentro del proyecto; sin embargo tiene efectos potencialmente útiles.

  1. Si agrega a VSS una carpeta completa con un único comando (al escribir ss add * en la línea de comandos de VSS o al arrastrar una carpeta desde el Administrador de archivos dentro de VSS), tan solo se agregan los archivos que coinciden con las máscaras relevantes. Es posible agregar otros archivos individualmente.

  2. Cuando ejecuta el comando de VSS Mostrar diferencias a nivel de proyecto con el fin de comparar el proyecto actual con su carpeta de trabajo, no se muestran como diferencias los archivos que no coinciden con las máscaras relevantes.

  3. La máscaras relevantes se utilizan como opción predeterminada en Agregar archivos de tipo en el cuadro de diálogo Agregar archivos; por consiguiente, tan sólo se muestran esos archivos de forma predeterminada.

Tipos de archivo incluidos en grupo de archivos

Muestra la lista de los tipos de archivo (sus extensiones) incluidos en el grupo de archivos actualmente seleccionado en Grupos de archivos. Para modificar un grupo específico, seleccione el grupo bajo Grupos de archivos y a continuación agregue o elimine extensiones.

Agregar

Agregue un nuevo grupo de extensiones de archivo a la lista Grupos de archivos.

Eliminar

Elimina el Grupo de archivos actualmente seleccionado.


Buscar (Cuadro de diálogo)

Le permite especificar una cadena a buscar en el archivo actual.

Para ver el cuadro de diálogo Buscar

  • En el visor de archivos de SourceSafe, haga clic en el botón Buscar de la barra de herramientas. (Utilice el visor de archivos de SourceSafe cuando vea un archivo para el cual no haya establecido otra asociación de archivo.)

Opciones del cuadro de diálogo

Buscar

Escriba la cadena que desee buscar.

Sólo palabras completas

Active esta casilla para encontrar la cadena especificada tan sólo si ésta corresponde a una palabra completa y no a una parte de palabra solamente.

Coincidir mayúsculas y minúsculas

Active esta casilla de verificación para que la búsqueda distinga entre mayúsculas y minúsculas.

Usar expresiones normales

Si esta casilla está desactivada, los caracteres * y ? se interpretarán literalmente. Por tanto, A*B sólo coincidirá con una cadena, A*B.

Si esta casilla está activada, los caracteres * y ? se interpretarán como comodines. Por tanto, A?B servirá tanto para ABB como AQB, y A*B coincidirá con ADSFFDFDSB, dentro de una línea.

Establecer marcadores en todo

Establece marcadores en todas las coincidencias del archivo.

Dirección

Especifica si la búsqueda debe proseguir hacia delante o hacia atrás en el archivo.

Buscar siguiente

Confirma la selección de búsqueda.

Cancelar

Cancela la búsqueda.


Buscar archivo (Cuadro de diálogo)

Le permite examinar la base de datos de VSS para buscar un archivo y realizar una comparación con otro archivo diferente (mediante el comando Mostrar diferencias). Presione TAB o utilice el mouse (ratón) para elegir entre los paneles de proyectos y de archivos de este cuadro de diálogo y, después, seleccione el archivo con el que desea comparar otro.


Resultados de la búsqueda en archivos (Cuadro de diálogo)

Este cuadro de diálogo muestra el resultado del comando Buscar en archivos ejecutado

Opciones del cuadro de diálogo

Archivo

Muestra el nombre del archivo o los archivos que contienen cadenas coincidentes con la buscada.

Coincidencias

Muestra el número de coincidencias encontradas en el archivo.

Coincidencias

Muestra una lista den las coincidencias encontradas en el contexto.

Cerrar

Cierra el cuadro de diálogo Resultados de la búsqueda en archivos.

Informe

Permite imprimir un informe con la información obtenida, ya sea en la impresora, en el Portapapeles o en un archivo.

Vínculos

Muestra cualquier vínculo que tenga el archivo a otros proyectos.


General (Ficha, cuadro de diálogo Propiedades de archivo)

Muestra las propiedades generales del archivo seleccionado.

Para ver la ficha General del cuadro de diálogo Propiedades de archivo:

  1. Haga clic en un archivo del panel de archivos del Explorador de VSS.

  2. En el menú Archivo, haga clic en Propiedades y después haga clic en General.

Nota Para ver esta ficha desde dentro de Visual Basic, después de agregar un proyecto de Visual Basic a VSS, en el menú Complementos de Visual Basic haga clic en SourceSafe y después haga clic en Propiedades de SourceSafe.

Derechos de acceso

Debe disponer del derecho de acceso Leer para utilizar esta ficha.

Comentarios

Si tiene un archivo seleccionado, la ficha General del cuadro de diálogo Propiedades de un archivo muestra el nombre del archivo, el tipo de archivo (de texto o binario), el tamaño, si se almacenan todas las versiones o sólo la última en la base de datos de VSS, el número de versión y la fecha de la versión, y cualquier comentario que se aplique al archivo. También muestra la última etiqueta aplicada al archivo, si hay alguna. Desde este cuadro de diálogo puede cambiar el comentario, el tipo de archivo y si se almacena sólo la última versión. Si cambia un archivo de almacenar sólo la última versión a almacenar todas las versiones, el cambio se hará efectivo desde el momento en que lo haga y no será retroactivo.


General (Ficha, cuadro de diálogo Opciones)

Vea también

Establece y cambia opciones generales de configuración.

Para ver la ficha General desde VSS:

  • En el menú Herramientas, haga clic en Opciones y después haga clic en la ficha General.

Derechos de acceso

Cualquier usuario de VSS puede utilizar esta ficha.

Opciones de la ficha

Mantener los archivos desprotegidos siempre

Mantiene un archivo desprotegido en su carpeta de trabajo, incluso si lo ha protegido. Con esta opción, se copia un archivo en la base de datos VSS, pero para el usuario permanece desproteguido, de forma que se pueda actualizar la base de datos con los cambios, al tiempo que sigue trabajando en el archivo.

Actuar recursivamente en los proyectos

Realiza todas las acciones sobre un proyecto seleccionado de forma recursiva, es decir, el comando se aplica a los subproyectos (y a sus subproyectos y así sucesivamente) y también al proyecto seleccionado. Esto es útil si tiene un proyecto con muchos subproyectos que desea desproteger y proteger como una unidad.

Volver a usar el último comentario

Utiliza el último comentario para el siguiente comando. Por ejemplo, si protege un archivo con el comentario "Hipervínculos agregados al menú de Ayuda" y después protege otro archivo, el comentario "Hipervínculos agregados al menú de Ayuda" aparecerá automáticamente en el cuadro de comentario. Si modifica el comentario, VSS utilizará el comentario cambiado para el siguiente comando.

Proteger los archivos no modificados

Cuando protege un archivo sin haber realizado cambios en él, VSS, comprueba esta opción para determinar lo que tiene que hacer. Haga clic en Proteger para que VSS actualice automáticamente la bases de datos VSS incluso aunque detecte que no se han realizado cambios en el archivo que va a proteger. Así también se incrementa el número de versión del archivo. Haga clic en Deshacer desprotección para que VSS deshaga automáticamente la desprotección de cualquier archivo no modificado cuando intente protegerlo. Haga clic en Preguntar para que VSS muestre un cuadro de diálogo preguntándole lo que tiene que hacer para cada uno de los archivos no modificados que está intentando proteger. Haga clic en Predeterminado para que VSS trabaje basándose en los valores de inicialización específicos de cada proyecto, determinando según ellos lo que deberá hacer con los archivos no modificados.

Usar combinación visual

Elija Sí si desea utilizar siempre la característica Combinación visual de SourceSafe cuando combine archivos después de una bifurcación o una desprotección múltiple. Elija No para utilizar la característica de combinación manual de SourceSafe (utilizada en versiones anteriores de SourceSafe). Elija Sólo si hay conflictos para utilizar la característica Combinación visual de SourceSafe siempre que haya cambios conflictivos en los dos archivos que se van a combinar y utilice la combinación automática de SourceSafe en el resto de los casos.

Doble clic en un archivo

Esta opción controla qué comando ejecutará VSS cuando haga doble clic en un archivo en el Explorador de VSS. Elija Preguntar (la opción predeterminada) para que siempre se le pregunte si desea ver un archivo o modificarlo cuando haga una selección mediante doble clic desde el Explorador de VSS. Elija Ver archivo si desea ver siempre la versión de la base de datos de VSS de este archivo (aunque sin poder modificarlo) o elija Editar archivo para que siempre se modifique el archivo (abra el archivo, con el estado de desprotección, en su carpeta de trabajo). Si mantiene presionada la tecla MAYÚSCULAS mientras hace doble clic en un archivo se invalidará el valor y se elegirá Preguntar.

Editor para ver archivos

Establece el editor que se utiliza para mostrar los archivos cuando selecciona el comando Ver. Haga clic en Examinar para ver el cuadro de diálogo Abrir y seleccionar un editor.

Carpeta para archivos temporales

Establece una carpeta en la cual almacenar los archivos temporales utilizados por VSS. El valor predeterminado corresponde a la subcarpeta TEMP de la carpeta en la que se guarda el archivo SRCSAFE.INI. Haga clic en Examinar para mostrar el cuadro de diálogo Seleccione una carpeta temporal.


General (Ficha, cuadro de diálogo Propiedades de proyecto)

Muestra las propiedades del proyecto seleccionado.

Para ver la ficha General del cuadro de diálogo Propiedades de proyecto:

  1. Haga clic en un proyecto del panel de proyectos del Explorador de VSS.

  2. En el menú Archivo, haga clic en Propiedades y después haga clic en General.

Nota Para ver esta ficha desde dentro de Visual Basic, después de agregar un proyecto de Visual Basic a VSS, en el menú Complementos de Visual Basic haga clic en SourceSafe y después haga clic en Propiedades de SourceSafe.

Derechos de acceso

Debe disponer del derecho de acceso Leer para utilizar esta ficha.

Comentarios

Si tiene un proyecto seleccionado, la ficha General del cuadro de diálogo Propiedades de un proyecto muestra el nombre del proyecto, cualquier carpeta central de este proyecto, el número de archivos y subproyectos del proyecto (incluyendo el número de archivos y subproyectos eliminados, si los hay), el número de versión y la fecha de esa versión, y el comentario del proyecto. También muestra la última etiqueta aplicada al proyecto, si hay alguna. Desde esta ficha puede cambiar el comentario del proyecto.

En esta ficha también se encuentra la casilla de verificación Este proyecto está escondido para mí. Si esta casilla está activada para este proyecto, los comandos Obtener, Desproteger, Proteger, Deshacer desprotección o Mostrar diferencias de proyecto incluidos recursivamente en este proyecto, no se aplicarán a éste. Esta característica está pensada para gente que prefiere tener la estructura completa de proyecto en su equipo local, pero que no desean ocupar espacio con archivos con los que no trabajan. Para obtener más información acerca de Esconder, vea el tema Esconder proyectos de VSS.


Obtener desde <Nombre de proyecto> (Cuadro de diálogo)

Obtiene los archivos seleccionados de su proveedor de control de código fuente y coloca un archivo de sólo lectura en el proyecto de entorno de desarrollo.

Para usar el comando Obtener:

  • En el menú Herramientas de Visual Basic haga clic en Obtener.

Opciones del cuadro de diálogo

Archivos para obtener o proteger

Selecciona el archivo o los archivos que desea obtener o proteger.

Avanzadas

Muestra el cuadro de diálogo Opciones avanzadas.

Aceptar

Confirma sus selecciones.

Cancelar

Cancela sus selecciones.

Seleccionar todos

Selecciona todos los archivos que se enumeran.


Ir a (Cuadro de diálogo)

Salta a una posición especificada de un archivo.

Para ver el cuadro de diálogo Ir a:

  1. Haga clic en un archivo del panel de archivos del Explorador de VSS.

  2. En el menú Herramientas, haga clic en Mostrar diferencias y, en el cuadro de diálogo Opciones de diferencias, haga clic en Aceptar.

    Nota Active la presentación del cuadro de diálogo Opciones de diferencia en la ficha Diálogos de comandos del cuadro de diálogo Opciones de SourceSafe (menú Herramientas).

  3. En el cuadro de diálogo Diferencias de archivo, haga clic en Informe.

  4. En el cuadro de diálogo Informe de diferencias de archivo, haga clic en Vista previa.

  5. Presione Alt-G.

Opciones del cuadro de diálogo

Ir a

Seleccione el tipo de elemento al que desea ir. Habrá diferentes opciones disponibles dependiendo de la operación que vaya a realizar, por ejemplo, puede ir a un marcador, conflicto, diferencia, línea o desplazamiento (el número de bytes totales contados desde el principio del archivo). Quizá desee utilizar Desplazamiento si está recibiendo un error durante la carga a partir de un cierto byte o si tiene un archivo con una longitud de bytes fija y necesita encontrar un determinado byte dentro del archivo.

Número de línea

Escriba la posición a la que desea ir. (La posición es relativa al tipo especificado en el cuadro Ir a.)

Ir a

Se dirige a la ubicación especificada.

Anterior

Se dirige al elemento anterior del tipo especificado en el campo Ir a.

Cerrar

Cancela el comando Ir a.


Detalles de historial (Cuadro de diálogo)

Vea también

Muestra los detalles del historial de un archivo o proyecto.

Para ver el cuadro de diálogo Detalles de historial de un archivo:

  1. Haga clic en un archivo del panel de archivos del Explorador de VSS.

  2. En el menú Herramientas, elija Mostrar historial.

    Realice las selecciones deseadas en el cuadro de diálogo Opciones de historial si está activado y haga clic en Aceptar.

    Nota Active la presentación del cuadro de diálogo Opciones de historial en la ficha Diálogos de comandos del cuadro de diálogo Opciones de SourceSafe (menú Herramientas).

  3. En el cuadro de diálogo Historial de archivo, haga clic en Detalles.

Para ver el cuadro de diálogo Detalles de historial para un proyecto:

  1. Haga clic en un proyecto del panel de proyectos del Explorador de VSS.

  2. En el menú Herramientas, haga clic en Mostrar historial.

    Realice las selecciones deseadas en el cuadro de diálogo Opciones de historial de proyectos si está activado y haga clic en Aceptar.

    Nota Active la presentación del cuadro de diálogo Opciones de historial de proyectos en la ficha Diálogos de comandos del cuadro de diálogo Opciones de SourceSafe (menú Herramientas).

  3. En el cuadro de diálogo Historial de proyecto, haga clic en Detalles.

Derechos de acceso

Cualquier usuario de VSS puede usar este cuadro de diálogo.

Opciones del cuadro de diálogo

Archivo

Nombre del archivo seleccionado.

Versión

Número de versión del archivo seleccionado.

Fecha

Fecha y hora en que se creó o se desprotegió por última vez el archivo seleccionado.

Usuario

Usuario que creó la versión.

Etiqueta

Muestra la etiqueta, si la hay, del archivo o el proyecto. También puede cambiarla.

Comentario

Agrega un nuevo comentario o cambia un comentario ya existente de una versión específica de un archivo o proyecto. Cada versión de cada archivo o proyecto de VSS se asocia con un comentario definido por el usuario. El nuevo comentario reemplaza al antiguo, que no puede recuperarse.

Comentario de etiqueta

Muestra el comentario especificado en el momento en que se aplicó una etiqueta.

Siguiente

Muestra información sobre el siguiente elemento de la lista Historial.

Anterior

Muestra información sobre el elemento anterior de la lista Historial.

Cerrar

Cierra el cuadro de diálogo Detalles de historial.


Historial de archivo (Cuadro de diálogo)

Vea también

Muestra la información histórica del archivo seleccionado.

Para ver el cuadro de diálogo Historial de archivo

  1. Haga clic en un archivo del panel de archivos del Explorador de VSS.

  2. En el menú Herramientas, haga clic en Mostrar historial.

    Haga la selecciones deseadas en el cuadro de diálogo Opciones de historial si está activado y haga clic en Aceptar.

Nota Active la presentación del cuadro de diálogo Opciones de historial en la ficha Diálogos de comandos del cuadro de diálogo Opciones de SourceSafe (menú Herramientas). El cuadro de diálogo le ofrece la opción de restringir el historial sólo a las etiquetas, a un usuario especificado o a un intervalo de fechas.

Derechos de acceso

Debe disponer del derecho de acceso Leer para utilizar este cuadro de diálogo.

Comentarios

El cuadro de diálogo Historial de archivo muestra el historial de un archivo seleccionado, incluyendo todos los eventos significativos, como la fecha de creación, las fechas de protección y el número de versión actual. Los eventos se muestran con el más reciente en la parte superior de la pantalla. En VSS sólo se puede tener acceso a versiones anteriores de archivos a través de este cuadro de diálogo.

Desde este cuadro de diálogo están disponibles varios comandos. Puede realizar un comando sobre una versión si selecciona primero un evento (o varios eventos) y después hace clic en un botón de comando.

Opciones del cuadro de diálogo

Cerrar

Cierra el cuadro de diálogo y vuelve al Explorador de VSS.

Ver

Abre un editor, en el cual puede ver el archivo seleccionado tal y como está almacenado en la base de datos de VSS. El editor puede configurarse en la ficha General del cuadro de diálogo Opciones de SourceSafe.

Detalles

Muestra los comentarios asociados a un evento, junto con información sobre eventos más detallada, como información sobre la etiqueta, información de versión, comentarios de desprotección, etc.

Obtener

Realiza el comando Obtener la última versión sobre la versión seleccionada.

Diferencias

Realiza el comando Mostrar diferencias sobre el archivo seleccionado. Puede comparar la versión seleccionada de un archivo con la versión actual, con cualquier otra versión o con un archivo de su carpeta de trabajo. Para comparar dos versiones diferentes de un archivo, mantenga presionada la tecla CTRL mientras selecciona las dos versiones deseadas. Después haga clic en el botón Diferencias.

Fijar/Liberar

Realiza el comando Fijar o Liberar sobre el archivo seleccionado. (Este botón cambia entre Fijar y Liberar dependiendo del estado de protección o desprotección del archivo seleccionado.)

Deshacer

Realiza el comando Deshacer sobre el archivo o el subproyecto seleccionado. El comando Deshacer descarta todas las versiones de un archivo después de la versión seleccionada y devuelve la versión actual del archivo a la versión seleccionada.

Informe

Envía un informe al Portapapeles, a un archivo o a una impresora.


Historial de proyecto (Cuadro de diálogo)

Vea también

Muestra información histórica sobre el proyecto seleccionado.

Para ver el cuadro de diálogo Historial de proyecto:

  1. Haga clic en un proyecto del panel de proyectos del Explorador de VSS.

  2. En el menú Herramientas, haga clic en Mostrar historial.

    Realice las selecciones deseadas en el cuadro de diálogo Opciones de historial de proyectos si está activado y haga clic en Aceptar.

    Nota Active la presentación del cuadro de diálogo Opciones de historial de proyectos en la ficha Diálogos de comandos del cuadro de diálogo Opciones de SourceSafe (menú Herramientas). El cuadro de diálogo le ofrece la opción de restringir el historial sólo a la etiquetas, incluir archivos en la lista de historial del proyecto, hacer que la lista del historial sea recursiva hacia abajo en la jerarquía del proyecto o restringir la lista del historial a un usuario especificado o a un intervalo de fechas.

  3. Haga clic en Aceptar.

Derechos de acceso

Debe disponer del derecho de acceso Leer para utilizar este cuadro de diálogo.

Comentarios

El cuadro de diálogo Historial de proyecto muestra el historial de un proyecto seleccionado, incluyendo todos sus eventos significativos, como la eliminación de archivos o subproyectos, la adición de archivos o subproyectos, el etiquetado y cambio de nombre de elementos, y las protecciones. Para cada evento significativo, el cuadro de diálogo muestra el archivo o subproyecto afectado, el usuario que realizó la acción, la fecha y hora del evento, y la descripción del mismo. Los eventos se muestran con el más reciente en la parte superior de la pantalla.

Desde este cuadro de diálogo están disponibles varios comandos. Puede realizar un comando sobre un archivo o un subproyecto si selecciona primero un evento y después hace clic en un botón de comando.

Opciones del cuadro de diálogo

Cerrar

Cierra el cuadro de diálogo y vuelve al Explorador de VSS.

Ver

Muestra un cuadro de diálogo que contiene una lista de todos los archivos (con sus números de versión), así como el proyecto que existía en el punto seleccionado del historial del proyecto.

Detalles

Muestra los comentarios asociados con un evento, junto con información de eventos más detallada, como información de etiqueta, información de versión, etc.

Obtener

Realiza el comando Obtener sobre la versión del archivo o el subproyecto seleccionado. Si selecciona un archivo, VSS mostrará un cuadro de diálogo para pedirle que aclare si desea obtener sólo el archivo seleccionado u obtener (es decir, volver a crear) el proyecto completo tal y como existía en el momento en que existía la versión del archivo seleccionado.

Desproteger

Ejecuta el comando Desproteger sobre la versión del archivo o del proyecto secundario seleccionado. Si selecciona un archivo, VSS muestra un cuadro de diálogo dónde le pregunta que aclare si desea desproteger tan sólo el archivo seleccionado o desproteger (es decir: volver a crear) el proyecto completo tal y como existía en el mismo punto de versión que el archivo seleccionado. Puede aparecer un mensaje de error si el archivo ha sido destruido en el punto de historial en el que intenta desprotegerlo.

Compartir

Realiza el comando Compartir sobre el archivo o el proyecto seleccionado. Con este comando podrá compartir la versión actual u otra anterior de archivos del proyecto con otro proyecto. Esto le permite crear una bifurcación de una versión anterior del proyecto. Puede que desee hacerlo si necesita reparar algunos errores para un cliente mientras sigue desarrollando la próxima versión del producto.

Informe

Envía un informe al Portapapeles, a un archivo o a una impresora.


Informe de historial (Cuadro de diálogo)

Vea también

Envía un informe con la información del historial de un archivo o de un proyecto a una impresora, a un archivo o al Portapapeles.

Para mostrar el cuadro de diálogo Informe de historial:

  1. Seleccione un archivo o un proyecto en el Explorador de VSS y, en el menú Herramientas, haga clic en Mostrar historial.

  2. Si está habilitado, haga selecciones en el cuadro de diálogo Opciones del historial de archivo u Opciones del historial del proyecto y haga clic en Aceptar.

    Nota Active la presentación del cuadro de diálogo Opciones de historial en la ficha Diálogos de comandos del cuadro de diálogo Opciones de SourceSafe (menú Herramientas).

  3. En el cuadro de diálogo Historial de archivo o Historial de proyecto, haga clic en Informe.

Opciones del cuadro de diálogo

Incluir detalles

Incluye todos los detalles del historial de los archivos seleccionados en el informe. Los detalles incluyen la fecha de creación, el usuario que modificó el archivo en cada protección, los comentarios adjuntos al archivo y la información de hora y fecha de cada evento.

Incluir diferencias

Utilice esta opción cuando compara dos versiones diferentes de un archivo o de un proyecto. El informe incluye las diferencias entre los archivos o los proyectos seleccionados.

Imprimir en

Envía el informe de historial a una impresora, a un archivo o al Portapapeles.

Aceptar

Prepara el informe especificado.

Cancelar

Cancela el informe.

Vista previa

Muestra una vista previa del informe especificado, de forma que pueda determinar si es lo que deseaba antes de realizarlo y enviarlo a la cola de impresión o a un archivo.


Resultados de comprobar hipervínculos (Cuadro de diálogo)

Vea también

Le permite ver los vínculos HTML identificados como errores y, opcionalmente, marcarlos como correctos.

Opciones del cuadro de diálogo

Archivo

Muestra una lista de los archivos en los que VSS ha encontrado errores de vínculos HTML. También muestra el número de errores encontrado en cada archivo.

Hipervínculos que parecen no válidos:

<archivo> Muestra una lista de los errores encontrados en el archivo seleccionado en el cuadro de lista Archivo.

Hipervínculos no comprobados:

<archivo>) Muestra el código HTML reconocido como un vínculo externo. Los vínculos externos no se comprueban.

Cerrar

Cierra este cuadro de diálogo.


Opciones de integración (Ficha)

Muestra información acerca de la integración entre su proyecto de Visual Basic y el proyecto de VSS correspondiente.

Para mostrar la ficha Opciones de Integración:

  • En el menú Complementos haga clic en SourceSafe, después en Opciones y a continuación en el botón Avanzadas. En este cuadro de diálogo, seleccione la ficha Integración.

Derechos de acceso

Debe disponer del derecho de acceso de Leer para poder utilizar este cuadro de diálogo.

Comentarios

La principal utilidad de la ficha Opciones de Integración es mostrar cómo están conectados sus proyectos de VSS y de Visual Basic. Sin embargo, puede establecer también un par de opciones en esta ficha: una que especifica si deben mostrarse los cuadros de diálogo intermedios para los comandos Historial y Mostrar diferencias, y otra que especifica si VSS debe preguntar por la base de datos que usará al abrir un proyecto nuevo.

Opciones de la ficha

Proyecto de SourceSafe

Muestra el nombre completo del proyecto de VSS asociado con este proyecto de Visual Basic.

Nombre de la base de datos

Muestra el nombre (en su caso) de la base de datos de VSS en la que está almacenado el proyecto.

Ruta de la base de datos

Muestra la ruta de la base de datos de VSS en la que está almacenado el proyecto.

Especificador de datos

Muestra el directorio de datos correspondiente a un proyecto específico. (Su administrador de VSS puede establecer directorios de datos diferentes para proyectos diferentes mediante la variable Data_Path.)

Mostrar cuadro de diálogo

Active la casilla correspondiente al comando si desea mostrar un cuadro de diálogo de opciones cuando lo selecciona.

Elegir base de datos de SourceSafe

Establezca su valor a Utilizar predeterminada para buscar siempre la información de su proyecto en la base de datos predeterminada de VSS. Establezca la opción Preguntar para mostrar un cuadro de diálogo donde puede especificar el nombre de la base de datos, su ruta y su especificador de datos cada vez que abre un proyecto.

Aceptar

Establece las opciones tal y como se especifican en la ficha.

Cancelar

Cierra la ficha Opciones de Integración.


Vínculos (Ficha, cuadro de diálogo Propiedades)

Vea también

Muestra todos los proyectos que comparten un archivo especificado.

Para ver la ficha Vínculos:

  1. Haga clic en un archivo del panel de archivos del Explorador de VSS.

  2. En el menú Archivo, haga clic en Propiedades y después haga clic en la ficha Vínculos.

    Nota Para ver esta ficha desde dentro de Visual Basic, después de agregar un proyecto de Visual Basic a VSS, en el menú Complementos de Visual Basic haga clic en SourceSafe y después haga clic en Propiedades de SourceSafe.

Derechos de acceso

Debe disponer del derecho de acceso Leer para utilizar esta ficha.

Comentarios

Utilice el comando Compartir para crear un vínculo compartido entre archivos. Un archivo que está compartido por múltiples proyectos es el mismo en todos los proyectos que lo comparten.

Opciones de la ficha

Proyectos que comparten <archivo>

La lista de proyectos que comparten el archivo seleccionado. Cuando protege un archivo, todos los proyectos mostrados en esta lista reciben automáticamente la versión protegida del archivo. Si un archivo se elimina de un proyecto o si un proyecto está fijado a una versión específica del archivo (en lugar de a la última versión), también se indica en la ventana de lista. Los elementos eliminados se anotan con una cadena de texto y los elementos protegidos se anotan con el número de versión a continuación del nombre de archivo, por ejemplo, $/CODE/HEADER.H; 4.

Cerrar

Cierra el cuadro de diálogo Propiedades y vuelve al Explorador de VSS.

Informe

Muestra el cuadro de diálogo Informe de vínculos, en el que puede ver la vista previa de un informe y enviarla al Portapapeles, a un archivo de texto o a una impresora.


Archivos locales (Ficha, cuadro de diálogo Opciones)

Vea también

Establece o cambia las opciones de la carpeta de trabajo.

Para ver la ficha Archivos locales:

  • En el menú Herramientas, haga clic en Opciones y después haga clic en la ficha Archivos locales.

Derechos de acceso

Cualquier usuario de VSS puede utilizar esta ficha.

Opciones de la ficha

Quitar copia local después de Agregar o Proteger

Elimina automáticamente la copia de los archivos agregados o protegidos de la carpeta de trabajo. Así puede mantener al mínimo el espacio utilizado en disco y se asegura que siempre tiene la versión más reciente cuando empieza a trabajar con un archivo.

Quitar copia local después de Eliminar

Elimina automáticamente de la carpeta de trabajo la copia de un archivo que elimina con el comando Eliminar. Esto ayuda a mantener la saturación del disco al mínimo. Además, siempre que no haya destruido o purgado el archivo de la base de datos de VSS, puede recuperarlo más tarde.

Utilizar indicador de sólo lectura para archivos no desprotegidos

Establece el indicador de sólo lectura sobre los archivos de su carpeta de trabajo. VSS asume que los archivos de la carpeta de trabajo que no ha desprotegido son de sólo lectura. VSS establece el indicador de sólo lectura cuando realiza un comando Obtener la última versión, Agregar, Proteger o Deshacer desprotección sobre un archivo y lo utiliza como una señal de que no ha modificado el archivo (por lo que VSS puede reemplazarlo).

Copiar los archivos de claves expandidas a la carpeta de trabajo

Copia directamente a la carpeta de trabajo los archivos modificados. Cuando protege un archivo y tiene activada la expansión de palabras clave, VSS puede reemplazar ciertas palabras clave del archivo con información acerca de la versión. El archivo modificado se reemplaza directamente en VSS. Si no establece esta opción, el archivo no se copiará automáticamente; esto aumenta el rendimiento, pero la copia de la carpeta de trabajo puede que no esté completamente actualizada.

Agregar fin de línea a todos los archivos de texto

Agrega un carácter de fin de línea siempre que VSS recupera un archivo de texto que no termine con uno. Algunos compiladores requieren que todos los archivos que compilan terminen con un carácter de fin de línea. Si está trabajando en un entorno como éstos, puede que necesite establecer esta opción.

Comparar archivos por

Establece la forma en que VSS determina si su copia local está actualizada. Las siguientes opciones están en el orden apropiado para incrementar la velocidad:

  • Contenido: compara el contenido completo del archivo local con la copia de VSS. Es el método más lento, pero es el más frecuente de trabajar.

  • Suma de comprobación: compara mediante una suma de comprobación almacenada por VSS.

  • Hora: compara los indicadores de fecha y hora. El método exacto de comparación de fecha depende de la configuración de la opción Establecer fecha y hora en archivos locales: si está configurada como Protección, VSS reemplaza la copia local si la hora de la última protección (o adición) es más reciente que la fecha de modificación de la copia local. Si está configurada como Actual (el valor predeterminado) o Modificación, VSS reemplaza el archivo local si la hora de modificación del archivo de VSS es diferente de la hora de modificación del archivo local.

Reemplazar archivos modificables

Cuando obtiene o desprotege un archivo, VSS copia el archivo a su carpeta de trabajo. Si ya hay una copia editable del archivo en la carpeta de trabajo, reemplazar el archivo puede borrar su trabajo.

  • Preguntar: le ofrece una opción cada vez.

  • Reemplazar: reemplaza (sobrescribe) el archivo.

  • Saltar: no reemplaza el archivo y genera un error en el panel de resultados si lo está viendo.

  • Combinar: combina los cambios entre el archivo desprotegido y el que está obteniendo o desprotegiendo. Si el archivo no puede combinarse (es un archivo binario), se mostrará un error en el panel de resultados si lo está viendo. Para que esto funcione, el administrador de VSS debe permitir múltiples desprotecciones en los archivos implicados.

Establecer fecha y hora en archivos locales

Esta opción controla la fecha y la hora a la que SourceSafe coloca archivos en su carpeta de trabajo. La opción elegida aquí es la hora que aparecerá cuando vea archivos en el Explorador de Windows:

  • Actual: establece la fecha y la hora del archivo a la fecha y la hora actuales de forma predeterminada, siempre que VSS obtiene un archivo. Esto indica al compilador que el archivo acaba de cambiar y hay que volver a compilarlo de nuevo.

  • Modificación: establece la copia local a la fecha y la hora en que se modificó el archivo por última vez.

  • Protección: establece la copia local a la fecha y la hora en que se protegió el archivo por última vez.


Inicio de sesión (Cuadro de diálogo)

Le permite iniciar la sesión en VSS. El cuadro de diálogo Inicio de sesión aparece cuando inicia VSS.

Para iniciar la sesión en VSS:

  1. En el cuadro Nombre de usuario escriba su nombre de usuario.

  2. Escriba su contraseña de VSS (si tiene una).

  3. Seleccione la base de datos de VSS con la que conectar y presione INTRO para iniciar la sesión en VSS. (Puede Examinar una base de datos diferente.)

Derechos de acceso

Cualquier usuario de VSS puede usar este cuadro de diálogo.

Comentarios

Si no está seguro de su nombre de usuario o de su contraseña de VSS, consulte con su administrador de VSS.


Microsoft VSS Versión de prueba

Su versión gratuita de prueba de VSS ha caducado hace más de 30 días.

Se ha deshabilitado parte de la funcionalidad de VSS.

Para cumplir con su contrato de licencia y restaurar la funcionalidad completa de VSS, es necesario solicitar una licencia.

Para realizar un pedido de Microsoft VSS o recibir una relación de distribuidores, llame al (800) 621-7930 en los Estados Unidos o Canadá. Fuera de los Estados Unidos o Canadá, póngase en contacto con su distribuidor local de Microsoft.

En caso contrario, debe desinstalar completamente VSS.


Rutas de acceso (Ficha, cuadro de diálogo Propiedades)

Vea también

Muestra todas las bifurcaciones del archivo especificado.

Para ver la ficha Rutas de acceso:

  1. Haga clic en un archivo del panel de archivos del Explorador de VSS.

  2. En el menú Archivo, haga clic en Propiedades y después haga clic en la ficha Rutas de acceso.

    Nota Para ver esta ficha desde dentro de Visual Basic, después de agregar un proyecto de Visual Basic a VSS, en el menú Complementos de Visual Basic haga clic en SourceSafe y después haga clic en Propiedades de SourceSafe.

Derechos de acceso

Debe disponer del derecho de acceso Leer para utilizar esta ficha.

Comentarios

Cuando utilice el comando Bifurcar para bifurcar un archivo, el vínculo compartido se rompe y se crea una bifurcación de archivo independiente. Una vez bifurcado un archivo, las modificaciones realizadas a dicho archivo en un proyecto no se reflejan en los demás proyectos. Sin embargo, algunas veces es valioso para hacer un seguimiento de estas relaciones.

Por ejemplo, suponga que encuentra un error en un archivo y lo corrige. Todos los proyectos que comparten el archivo se actualizan inmediatamente con la nueva versión. Sin embargo, los proyectos que compartían ese archivo y después se bifurcaron de él, no se actualizan; utilice la ficha Rutas de acceso para encontrar esos proyectos y después actualícelos manualmente.

Cuando examina las rutas de acceso, ve el historial de bifurcaciones completo de un archivo, incluyendo todas las veces que se utilizó el comando Bifurcar para moverlo a diferentes proyectos de distintas rutas de desarrollo. Sin embargo, no se muestran los cambios realizados al archivo; utilice el comando Mostrar historial para verlos.

Utilizar el comando Rutas de acceso podría dar lugar a algo parecido a lo siguiente.

Proyectos con ramificaciones independientes
$/A         1->5
--$/B         6->7
--$/D         4->4

Esta pantalla quiere decir que hay 3 bifurcaciones de este archivo (porque hay 3 líneas); la primera procede de la versión 1 del archivo y se ha trasladado a la versión 5, la segunda bifurcación considera la primera como su primaria (lo que significa que las versiones 1 a 5 del archivo son la misma en esta bifurcación), comenzó su vida en la versión 6 y se protegió una vez a partir de entonces, trasladándose a la versión 7, que es su estado actual. La tercera bifurcación comenzó en la versión 4 y, desde ese momento, ha permanecido inalterada.

Puede seleccionar cada bifurcación y hacer clic en el botón Vínculos para ver dónde está compartido ese archivo en concreto. ¿Cómo utilizará dicha información? Suponga que se introdujo un error en este archivo en la versión 5 de la primera ramificación. Gracias a la información que aparece en pantalla, sabe que la tercera bifurcación no se ha visto afectada por dicho error (porque todavía se encuentra en la versión 4) pero que, en la segunda bifurcación, es necesario insertar la solución manualmente, ya que esta bifurcación procede de la primera (su primaria), pero comenzó en la versión 6. Por supuesto, en cuanto haya arreglado el archivo en cada una de estas bifurcaciones, cualquier otro proyecto que comparta el archivo incluirá la solución al error automáticamente.

Opciones de la ficha

Proyectos con ramas independientes

Enumera los proyectos en los que se ha compartido el archivo seleccionado.

Versiones

Muestra el número de versión del archivo que se bifurcó en el correspondiente proyecto.

Vínculos

Muestra la ficha Vínculos del cuadro de diálogo Propiedades de archivos.

Cerrar

Cierra el cuadro de diálogo Propiedades y vuelve al Explorador de VSS.

Informe

Envía un informe al Portapapeles, a un archivo de texto o a una impresora.


Vista previa (Cuadro de diálogo)

Muestra una vista previa del informe especificado, de forma que pueda determinar si es lo que deseaba antes de realizarlo y enviarlo a la cola de impresión o a un archivo. Puede utilizar las teclas aceleradoras del visor en este cuadro de diálogo para desplazarse por el archivo.

Opciones del cuadro de diálogo

Cerrar

Cierra la vista previa del informe.


Imprimir (Cuadro de diálogo)

Vea también

Establece las opciones de impresión.

Para ver el cuadro de diálogo Imprimir:

  1. Seleccione un archivo o un proyecto en el Explorador de VSS y, en el menú Herramientas, haga clic en Mostrar historial.

  2. Realice las selecciones deseadas en el cuadro de diálogo Opciones de historial u Opciones de historial de proyectos, si está activado, y haga clic en Aceptar.

    Nota Active la presentación de los cuadros de diálogo Opciones de historial en la ficha Diálogos de comandos del cuadro de diálogo Opciones de SourceSafe (menú Herramientas).

  3. En el cuadro de diálogo Historial de archivo o Historial de proyecto, haga clic en Informe.

  4. Bajo Imprimir en, haga clic en Impresora y después haga clic en Aceptar.

Opciones del cuadro de diálogo

Impresora

Impresora seleccionada en el cuadro de diálogo Configurar impresión. Para ver el cuadro de diálogo Propiedades de impresora, haga clic en Propiedades.

Copias

Escriba el número de copias del informe que desea imprimir.

Imprimir en archivo

Envía el informe a un archivo PostScript e imprime el informe.

Propiedades

Muestra el cuadro de diálogo Propiedades de impresora de Windows.


Purgar (Comando)

Vea también

Quita de forma permanente los archivos y proyectos eliminados previamente de la base de datos de VSS.

Para utilizar el comando Purgar:

  1. Haga clic en un proyecto del panel de proyectos del Explorador de VSS.

  2. En el menú Archivo, haga clic en Propiedades y después haga clic en la ficha Elementos eliminados.

  3. Haga clic en Purgar. Recibirá un mensaje de advertencia puesto que no puede deshacer el comando Purgar.

Derechos de acceso

Debe disponer del derecho de acceso Destruir para utilizar este comando.

Comentarios

Cuando utiliza el comando Eliminar para eliminar archivos o proyectos de VSS, los elementos eliminados se quitan del Explorador de VSS. Sin embargo, VSS sigue almacenando los elementos de forma que puede recuperarlos y, por ejemplo, volver a generar versiones anteriores del proyecto que las requiera.

Para eliminar de forma permanente estos archivos de la base de datos de VSS y liberar el espacio en disco que están utilizando, utilice el comando Purgar.

Cuando purga un archivo eliminado previamente de un proyecto, el archivo se quita de forma permanente del proyecto y no puede recuperarse. Por tanto, si utiliza el comando Obtener la última versión para obtener cualquier versión del proyecto que contuviera ese archivo, el archivo no podrá encontrarse. Por esta razón, el comando Purgar debe utilizarse con sumo cuidado: debe tener la seguridad de que jamás va a necesitar el archivo o el proyecto, ni ninguna de sus versiones anteriores, por ninguna razón.

Nota El propósito de purgar es deshacerse de los archivos obsoletos y con ello liberar espacio en disco. Sin embargo, puede que el comando Purgar no tenga siempre ese efecto. Si un archivo se está compartiendo en más de un proyecto y lo purga en uno de ellos, no se liberará espacio en disco, puesto que el archivo todavía se está utilizando. Sólo si purga el archivo en todos los proyectos que lo están utilizando se eliminará el archivo de forma permanente de la base de datos de VSS


Sincronizar todo (Cuadro de diálogo)

Vea también

Puede encontrar el botón Sincronizar todo en el cuadro de diálogo Mostrar diferencias de la barra de herramientas. El botón Sincronizar todo muestra un cuadro de diálogo con las siguientes opciones. Estas opciones especifican lo que desea que haga VSS cuando se encuentre en unas situaciones determinadas.

Sincronizar los archivos que sólo aparecen en una lista...

Archivos que no están en su carpeta de trabajo. Esta opción especifica lo que desea que ocurra cuando VSS encuentre archivos que no estén en su carpeta de trabajo, pero que sí estén en el proyecto. Elija Obtener (la opción predeterminada) para obtener los archivos que faltan en su carpeta de trabajo. Elija Ignorar para que no se lleve a cabo ninguna acción con estos archivos.

Archivos que se han eliminado del proyecto. En esta opción se especifica lo que desea que ocurra cuando VSS encuentre archivos que están en su carpeta de trabajo, pero que se han eliminado del proyecto. Elija Eliminar de la carpeta (la opción predeterminada) para eliminar dichos archivos de la carpeta de trabajo. Elija Recuperar archivo eliminado para recuperar el archivo eliminado y colocar una copia en su carpeta de trabajo. Elija Agregar al proyecto para agregar dichos archivos otra vez a su proyecto. Elija Ignorar para que no se lleve a cabo ninguna acción con estos archivos.

Archivos que no están en el proyecto. En esta opción podrá especificar qué pasará cuando VSS encuentre archivos que no estén en su proyecto, pero que sí estén en su carpeta de trabajo. Elija Agregar al proyecto (la opción predeterminada) para agregar estos archivos a su proyecto de VSS. Elija Ignorar para que no se lleve a cabo ninguna acción con estos archivos.

Sincronizar los archivos que aparecen en las dos listas …

Archivos que ha desprotegido. En esta opción podrá especificar lo que ocurrirá cuando VSS encuentre archivos desprotegidos para usted y que son distintos en su carpeta de trabajo. Elija Proteger (la opción predeterminada) para proteger estos archivos en su proyecto de VSS. Elija Deshacer desproteger para deshacer la desprotección en dichos archivos. Elija Obtener para sobrescribir su archivo desprotegido con una copia de sólo lectura (perdiendo todos los cambios que haya podido hacer). Elija Ignorar para que no se lleve a cabo ninguna acción con estos archivos.

Archivos que no ha desprotegido. En esta opción podrá especificar lo que ocurrirá cuando VSS encuentre archivos que no estén desprotegidos para usted, pero que son distintos en su carpeta de trabajo. Elija Obtener (la opción predeterminada) para obtener la versión más reciente de dichos archivos. Elija Ignorar para que no se lleve a cabo ninguna acción con estos archivos.

Aceptar

Ejecuta el comando Sincronizar todas con las opciones elegidas.

Cancelar

Cancela la sincronización.


Recuperar (Comando)

Vea también

Reemplaza un archivo o un proyecto que se ha eliminado.

Para utilizar el comando Recuperar:

  1. Haga clic en un proyecto del panel de proyectos del Explorador de VSS.

  2. En el menú Archivo, haga clic en Propiedades y después haga clic en la ficha Elementos eliminados.

  3. Haga clic en Recuperar.

Derechos de acceso

Debe disponer del derecho de acceso Agregar para utilizar este comando.

Comentarios

Cuando utiliza el comando Eliminar para eliminar un archivo o un proyecto de VSS, los elementos eliminados se quitan del Explorador de VSS. Sin embargo, VSS sigue almacenándolos, de forma que se puedan volver a generar las versiones anteriores del proyecto que se requieran.

El comando Recuperar invierte el comando Eliminar y restaura el archivo. Tras haberse recuperado el archivo, éste forma parte de nuevo de su proyecto primario.

Si el archivo que se está recuperando se comparte con otros proyectos, puede que se haya modificado en esos proyectos. De esta forma, el archivo que se recupera puede que no sea exactamente el archivo que eliminó.

Cuando elimina un proyecto, todos los subproyectos y archivos que hay bajo él se vuelven no disponibles. Sin embargo, cuando recupera el proyecto, también se recuperan sus subproyectos.


Informe (Cuadro de diálogo)

Crea un informe con formato con la información seleccionada que puede enviar al Portapapeles, a un archivo o a una impresora.

Opciones del cuadro de diálogo

Imprimir en

  • Impresora: Envía el informe a una impresora.

  • Archivo: Envía el informe al cuadro de diálogo Archivo.

  • Portapapeles: Coloca el informe en el Portapapeles.

Aceptar

Confirma la selección del informe.

Cancelar

Cancela el informe.

Vista previa

Muestra una vista previa del informe especificado, de forma que pueda determinar si es lo que deseaba antes de realizarlo y enviarlo a la cola de impresión o a un archivo.


Deshacer (Comando)

Vea también

Elimina todos los cambios realizados desde una versión anterior de un archivo.

Para utilizar el comando Deshacer:

  1. Haga clic en un archivo del panel de archivos del Explorador de VSS.

  2. En el menú Herramientas, haga clic en Mostrar historial.

  3. Realice las selecciones deseadas en el cuadro de diálogo Opciones de historial, si está activado.

    Nota Active la presentación del cuadro de diálogo Opciones de historial en la ficha Diálogos de comandos del cuadro de diálogo Opciones de SourceSafe (menú Herramientas).

  4. Haga clic en una versión anterior del archivo y después haga clic en Deshacer. Al deshacer un archivo se pierden los cambios realizados en dicho archivo después de la versión que ha deshecho. Por ejemplo, si hace clic en la versión 5 y después elige Deshacer, se perderán todos los cambios realizados a partir de la versión 5.

Derechos de acceso

Debe disponer del derecho de acceso Destruir para utilizar este comando.

Comentarios

Deshacer devuelve un archivo a una versión anterior, borrando todas las versiones y cambios realizados desde entonces; todos los cambios realizados tras la versión deshecha se pierden. El comando Deshacer no puede deshacerse.

Si el archivo que deshace está compartido por más de un proyecto, la operación de deshacer sólo afecta al proyecto que especifique (el proyecto actual, de forma predeterminada). Para conseguirlo, Deshacer realiza una bifurcación implícita, es decir, bifurca el archivo en el proyecto especificado desde el mismo archivo en todos los demás proyectos y crea una nueva ruta de desarrollo. Para volver a unir las distintas rutas de desarrollo, si hace cambios en el proyecto especificado tiene que combinar los archivos.

Hay otras formas para volver atrás en una operación deshacer. En el caso de un archivo compartido, puede eliminar el archivo resultante y volver a compartirlo desde otro proyecto. Para un archivo no compartido, si no desea perder todos los pasos implicados, un método es desproteger el archivo, obtener una versión anterior y después proteger el archivo. La versión anterior que obtiene se convierte en la versión más reciente, pero no se pierde información.


Guardar informe en archivo (Cuadro de diálogo)

Vea también

Especifica un archivo en el que guardar un informe.

Para mostrar el cuadro de diálogo Guardar informe en archivo:

  1. En el menú Herramientas haga clic en Informe de archivos.

  2. Bajo Imprimir en haga clic en Archivo y a continuación en Aceptar.

Opciones del cuadro de diálogo

Nombre del archivo

Nombre y ruta del archivo donde escribir el informe.

Carpetas

Especifica una ruta para el archivo.

Unidades

Permite seleccionar una unidad entre las disponibles.

Mostrar archivos de tipo

Aplica un filtro a la lista de archivos con el fin de fin de mostrar únicamente los archivos del tipo especificado.

Agregar

Agrega el informe al final de un archivo existente.

Aceptar

Confirma la selección.

Cancelar

Cancela las selecciones, cierra el cuadro de diálogo y vuelve al explorador de VSS.

Red

Muestra el cuadro de diálogo Conectar a unidad de red de Windows.


Seleccionar (Cuadro de diálogo)

Muchos de los comandos más comunes de VSS (como Obtener la última versión, Desproteger y Proteger) pueden actuar sobre más de un archivo a la vez. Para que funcionen, debe seleccionar varios elementos antes de elegir el comando de menú que desee ejecutar.

Para seleccionar varios elementos con el cuadro de diálogo Seleccionar

  1. Haga clic en el panel de archivos del Explorador de VSS y después, en el menú Edición, elija Seleccionar.

    VSS mostrará el cuadro de diálogo Seleccionar.

  2. En el cuadro Elemento, escriba un nombre de archivo utilizando caracteres comodín. Por ejemplo, escriba *.* para seleccionar todos los elementos.

    Elija Seleccionar o presione Alt-S.

  3. Para agregar elementos adicionales a la lista de selección, sepárelos con un signo de punto y coma en la lista.

  4. Elija Cerrar para confirmar la selección y cerrar el cuadro de diálogo.

Para seleccionar elementos con el mouse:

  • Elija un elemento en el Explorador de VSS.

    O bien

    Mantenga presionada la tecla CTRL mientras elige cada elemento que desee; para seleccionar un bloque de elementos, elija el primer elemento, mantenga presionada la tecla MAYÚSCULAS y elija el último elemento.

Para seleccionar elementos con el teclado:

  • Presione Mayúsculas-Barra espaciadora para seleccionar cada elemento que desee. Utilice las teclas de dirección para moverse a cada uno de ellos.

Para anular la selección de elementos con el comando Invertir selección:

  • En el menú Edición, elija Invertir selección para cambiar los elementos seleccionados a elementos no seleccionados y viceversa.


Compartir (Cuadro de diálogo)

Vea también

Permite especificar un proyecto para compartir con el proyecto actual.

Para ver el cuadro de diálogo Compartir:

  1. En el panel de proyectos del Explorador de VSS, haga clic en un proyecto en el cual desee compartir otro proyecto.

  2. En el menú SourceSafe, haga clic en Compartir.

  3. En el cuadro de diálogo Compartir con proyecto, seleccione un proyecto para compartir y haga clic en Compartir.

Opciones del cuadro de diálogo

Nuevo nombre

Escriba el nombre del proyecto que desea compartir con el proyecto actual.

Recursivo

Active esta casilla de verificación para que la operación de compartir sea recursiva (que incluya todos los subproyectos y sus archivos).

Comentario

Escriba un comentario para esta operación.

Aceptar

Vuelve al cuadro de diálogo Compartir con proyecto, que muestra el proyecto seleccionado para compartir con los archivos elegidos.

Cancelar

Cancela el comando Compartir.


Compartir desde el proyecto (Cuadro de diálogo)

Vea también

Comparte un proyecto con el proyecto actual y lo fija respecto a una versión.

Para ver el cuadro de diálogo Compartir desde el proyecto:

  1. En el panel de proyectos del Explorador de VSS, haga clic en un proyecto en el cual desee compartir otro proyecto.

  2. En el menú Herramientas, haga clic en Mostrar historial. Realice las selecciones deseadas en el cuadro de diálogo Opciones de historial de proyectos si está activado y haga clic en Aceptar.

    Nota Active la presentación del cuadro de diálogo Opciones de historial de proyectos en la ficha Diálogos de comandos del cuadro de diálogo Opciones de SourceSafe (menú Herramientas).

  3. En el cuadro de diálogo Historial de proyecto, haga clic en Compartir.

Cuando utilice este cuadro de diálogo, lo que va a hacer es crear un proyecto completamente nuevo, idéntico a una versión anterior de este proyecto. Por ejemplo, suponga que puede crear un proyecto exactamente igual al $/A/B que existía el lunes pasado a medianoche. Su nuevo proyecto se llama, por ejemplo, $/A/C. C es idéntico a B (tiene los mismos subproyectos y archivos) pero los archivos que se encuentran en C representan antiguas versiones de los archivos que están en B. Esto puede ocurrir por dos razones. Puede que los archivos estén fijados a las antiguas versiones (aunque todavía se compartan con sus equivalentes en B) o bien pueden recuperarse a dichas versiones (y ya no se compartirán con B). Tiene que elegir entre estos dos métodos basándose en si activó la casilla de verificación Bifurcar después de compartir.

Para llevar esto a cabo, debería hacer clic en B (el lugar a partir del cual desea compartir; observe que ésta es la dirección contraria a la dirección normal utilizada para compartir) y hacer clic en el botón Compartir del cuadro de diálogo Historial. Después, especifique la ubicación y el nombre del nuevo proyecto, si desea o no bifurcar, si desea hacerlo recursivamente, etc.

Opciones del cuadro de diálogo

Proyectos

Muestra la lista de proyectos de forma que pueda examinar el proyecto que desea compartir con el proyecto actual.

Bifurcar después de compartir

Bifurca inmediatamente después de compartir, deshaciendo el proyecto que acaba de crear a la versión especificada. Con esta opción puede crear fácilmente una versión distinta de un proyecto como era en una versión anterior.

Aceptar

Comparte el proyecto seleccionado en el proyecto actual y lo fija a la versión seleccionada. Si el proyecto seleccionado es la versión actual, el proyecto compartido se fija a esa versión.

Cancelar

Cancela el comando Compartir desde el proyecto.


Opciones de control de código fuente (Cuadro de diálogo)

Personaliza el entorno de su proveedor de control de código fuente.

Para utilizar el comando Opciones:

  • Tras agregar un proyecto de entorno de desarrollo a su proveedor de control de código fuente, en el menú Complementos haga clic en el nombre de su proveedor de control de código fuente y a continuación en Opciones.

Comentarios

El comando Opciones muestra el cuadro de diálogo Opciones de control de código fuente.

Opciones del cuadro de diálogo

  • ¿Desea obtener las últimas versiones de los archivos al abrir un proyecto de VB?

  • ¿Desea proteger archivos al cerrar el proyecto de VB?

  • ¿Desea agregar archivos al control de código fuente al agregarlos a un proyecto de Visual Basic?

  • ¿Desea quitar los archivos del control de código fuente al eliminarlos del proyecto de Visual Basic?

En cada opción, puede especificar Sí, No o Preguntar. Preguntar es la opción predeterminada.

Avanzadas

Muestra opciones avanzadas.

Aceptar

Confirma las selecciones.

Cancelar

Cancela las selecciones.


Resultados de control de código fuente (Cuadro de diálogo)

Coloca los resultados de un comando en una ventana.

Para mostrar el cuadro de diálogo Resultados de comando:

  1. Establezca la variable Results_Window con el valor Sí en el archivo SRCSAFE.INI.

  2. Obtenga o desproteja un archivo.

Cuando lleva a cabo un comando que genera un mensaje de estado o de error, VSS muestra el resultado del comando en la ventana Resultados. Esta ventana permanece en pantalla hasta que presiona la tecla INTRO, hace clic en Cancelar (o en Cerrar) o bien hace clic en la ventana del explorador de VSS.

Si lo prefiere, puede indicar a VSS que no muestre la ventana Resultados. Desactive la casilla Mostrar panel de resultados en la ficha Ver del cuadro de diálogo Opciones de SourceSafe (en el menú Herramientas). Así se establece automáticamente la variable de inicialización Results_Windows con el valor No en su archivo SS.INI. Sin embargo, los mensajes de error siguen apareciendo


Estado de comandos de SourceSafe (Cuadro de diálogo)

Este cuadro de diálogo aparece brevemente mientras obtiene o desprotege un archivo.

Opciones del cuadro de diálogo

Cancelar

Este botón cancelará la operación de obtención del archivo.


Deshacer desprotección para <Nombre de proyecto o de archivo>

Vea también

Cancela una operación Desproteger, y deshace todos los cambios. Debe tener establecida una carpeta de trabajo para que este comando funcione correctamente.

Derechos de acceso

Debe disponer de los derechos de acceso de Desproteger para poder utilizar este comando.

Comentarios

El comando Deshacer desprotección deshace todos sus cambios. Aunque el archivo ya no está desprotegido a su nombre, VSS conserva en su lugar la versión de que disponía antes y sustituye el archivo en su carpeta de trabajo.

Puede utilizar el comando Deshacer desprotección únicamente en los archivos que tiene desprotegidos actualmente, pero no en archivos desprotegidos por otros usuarios.

Nota Su administrador de VSS puede deshacer la desprotección de otro usuario.

Opciones del cuadro de diálogo

Nota Habilite la presentación del cuadro de diálogo en la ficha Diálogos de comandos, mediante el comando Herramientas, Opciones.

Copia local

  • Reemplazar: Reemplaza el archivo en su carpeta de trabajo. VSS ejecuta el comando Obtener la última versión sobre el archivo. Esto mantiene la sincronización de su carpeta de trabajo con el contenido del proyecto, al pasar por alto todas sus modificaciones.

  • Eliminar: Elimina el archivo en su carpeta de trabajo.

  • Dejar: No toca el archivo aislado.

  • Predeterminado: Utiliza los valores predeterminados establecidos en la ficha Archivos locales o heredados de un proyecto primario. No es posible establecer esta opción; se utiliza automáticamente cuando selecciona múltiples archivos explícitamente (en la lista de archivos) o implícitamente (al seleccionar Recursivo).

Mostrar sólo cuando se presiona Mayús

Salta este cuadro de diálogo en las operaciones Deshacer desprotección futuras y utiliza los valores que estableció como predeterminados. Para presentar obligatoriamente este diálogo sin tener que presionar la tecla MAYÚSCULAS, mantenga activada esta opción. O bien, para hacer que el comportamiento del cuadro de diálogo sea permanente, haga clic en la casilla de verificación apropiada de la ficha Diálogos de comandos del cuadro de diálogo Opciones de SourceSafe.

Recursivo (sólo para deshacer desprotecciones en el ámbito de proyecto)

Deshace la desprotección de todos los archivos en el proyecto seleccionado, con todos los archivos de todos sus proyectos secundarios.

Modificar (sólo para deshacer desprotecciones a nivel de proyecto)

Modifica el conjunto de carpetas de trabajo a las que se aplica una operación recursiva. Esto es útil si tiene archivos desprotegidos en más de un proyecto y desea deshacer la desprotección de todos ellos al mismo tiempo. Sólo está disponible cuando hace clic en la casilla de verificación Recursivo.


Deshacer desprotección <Nombre de proyecto> (Cuadro de diálogo)

Sobrescribe sus cambios en un archivo y copia la última versión desprotegida en el directorio de trabajo de su entorno de desarrollo.

Para utilizar el comando Deshacer desproteger:

  • En el menú Herramientas de Visual Basic, haga clic en Deshacer desproteger.

Opciones del cuadro de diálogo

Archivos para desproteger

Enumera los archivos desprotegidos actualmente. Haga clic en los archivos cuya desprotección desee deshacer, o haga clic en Seleccionar todos para seleccionar todos los archivos que se enumeran.

Avanzadas

Muestra las Opciones avanzadas de deshacer desproteger.

Aceptar

Confirma la selección.

Cancelar

Cancela la selección.

Seleccionar todos

Selecciona todos los archivos que se enumeran.


Ver o modificar (Cuadro de diálogo)

Este cuadro de diálogo le permite especificar si desea ver la versión de la base de datos de VSS del archivo en el que hizo doble clic o bien si prefiere desproteger y modificar dicho archivo en su carpeta de trabajo.

Tan sólo verá este cuadro de diálogo si especificó que debe presentarse cuando hace doble clic en un archivo en el explorador de VSS. Puede modificar esta especificación en la ficha Opciones de Herramientas, General. O bien, si presiona la MAYÚSCULAS mientras hace doble clic en un archivo en el explorador, se mostrará siempre este diálogo sin tener en cuenta la configuración de la ficha Opciones de Herramientas, General.

Seleccione en este cuadro de diálogo sus opciones (o haga clic en Cancelar para cancelar la operación) y haga clic en Aceptar.


Ver (Ficha, cuadro de diálogo Opciones)

Establece las opciones de presentación del Explorador de VSS.

Para mostrar la ficha Ver:

  • En el menú Herramientas, haga clic en Opciones y después haga clic en Ver.

Derechos de acceso

Cualquier usuario de VSS puede utilizar esta ficha.

Opciones de la ficha

Mostrar panel de resultados

Muestra u oculta el panel de resultados del Explorador de VSS. El panel de resultados, en la parte inferior del Explorador de VSS, muestra el resultado de sus comandos de VSS.

Mostrar barra de herramientas

Muestra u oculta la barra de herramientas del Explorador de VSS. La barra de herramientas contiene una serie de botones en los que puede hacer clic para ejecutar comandos utilizados con frecuencia.

Mostrar barra de estado

Muestra u oculta la barra de estado del Explorador de VSS. La barra de estado muestra información de estado acerca de VSS, como es la ordenación actual de los archivos en el panel de archivos, el nombre de usuario actual y el número de elementos de la lista de archivos.

Usar siempre los nombres de archivos en formato MS-DOS

Trunca los nombres de archivo largos aceptados por plataformas de 32 bits. Esta opción mantiene la presentación estrecha de la columna del nombre de archivo y también es útil si tiene equipos con diferentes sistemas operativos que utilicen la base de datos de VSS.

Convertir el proyecto seleccionado en el proyecto actual

Esta opción está seleccionada normalmente. Sin embargo, si su red tiene un rendimiento pobre, puede que desee poder desplazarse por la lista de proyectos sin que VSS actualice el proyecto actual. En este caso, desactive esta opción. Si está desactivada, puede presionar la tecla ENTRAR en un proyecto (o hacer doble clic en él con el mouse) para convertirlo en el proyecto actual.

Actualizar automáticamente la lista de archivos

Controla si VSS actualiza automáticamente la lista de archivos. La actualización mantiene actualizado el Explorador de VSS, pero también provoca un retraso momentáneo (y una carga de la red). Si selecciona esta opción, especifique el intervalo de actualización en el cuadro de abajo. Si no selecciona esta opción, puede actualizar manualmente la lista de archivos mediante el comando Actualizar lista de archivos del menú Ver de VSS.


Visor de VSS (Cuadro de diálogo)

Permite modificar o mostrar un archivo que no está asociado con ningún programa.

Opciones del cuadro de diálogo

Este cuadro de diálogo incluye una de herramientas con los botones siguientes:

Guardar

Guarda su archivo modificado a disco.

Cortar

Corta la selección en el archivo y la coloca en el Portapapeles. La tecla de método abreviado es Ctrl-X.

Copiar

Copia la selección en el Portapapeles. La tecla de método abreviado es Ctrl-C.

Pegar

Pega el contenido del Portapapeles en la posición del cursor. La tecla de método abreviado es Ctrl-V.

Deshacer

Deshace su última acción de edición. La tecla de método abreviado es Ctrl-Z.

Rehacer

Vuelve a realizar la última acción de edición deshecha. La tecla de método abreviado es Ctrl-A.

Buscar

Permite buscar una cadena en el archivo. La tecla de método abreviado es Alt-F3.

Buscar siguiente

Permite buscar la aparición siguiente de una cadena en el archivo. La tecla de método abreviado es F3.

Buscar anterior

Permite buscar la aparición anterior de una cadena en el archivo. La tecla de método abreviado es Mayús-F3.

Alternar marcador

Permite activar o desactivar un marcador en un archivo. La tecla de método abreviado es Ctrl-F2.

Marcador siguiente

Permite ir al marcador siguiente en el archivo. La tecla de método abreviado es F2.

Marcador anterior

Permite ir al marcador anterior en el archivo. La tecla de método abreviado es Mayús-F2.

Borrar todos los marcadores

Permite borrar todos los marcadores en el archivo.


Advertencias (Ficha, cuadro de diálogo Opciones)

Especifica si se muestran advertencias antes de las acciones que podrían dar lugar a una pérdida accidental o eliminación de datos.

Para ver la ficha Advertencias:

  • En el menú Herramientas, haga clic en Opciones y después haga clic en Advertencias.

Derechos de acceso

Cualquier usuario de VSS puede utilizar esta ficha.

Comentarios

Cuando elimina un archivo de la base de datos de VSS, VSS le pregunta "¿Realmente desea eliminar?". Algunos usuarios encontrarán útil la advertencia, puesto que impide la eliminación accidental de datos. Otros la encontrarán molesta, puesto que requiere presionar una tecla más. Ésta y otras advertencias de VSS son completamente configurables.

Puede elegir si desea recibir advertencias antes de que VSS ejecute lo siguiente:

  • Deshacer desprotección de un archivo modificado

  • Eliminar un archivo o proyecto

  • Destruir un archivo o proyecto

  • Purgar un archivo o proyecto

  • Deshacer un archivo

  • Desproteger un archivo ya desprotegido

  • Salir de VSS


Ya existe en este proyecto una copia eliminada de este archivo <archivo>. ¿Desea recuperar el archivo existente?

Vea también

Esta advertencia tiene la siguiente causa y solución:

  • Cuando se elimina un archivo de un proyecto, el archivo ya no aparece, pero aún existe. Así, cuando decide agregar un archivo con el mismo nombre, VSS le pide que decida si desea recuperar el archivo eliminado o agregar el que ha indicado.

    Haga clic en Sí si desea recuperar en el proyecto el archivo que había sido eliminado y no quiere agregar un nuevo archivo.

    Haga clic en No si no desea recuperar el archivo eliminado y quiere agregar el nuevo archivo.

    Haga clic en Cancelar si desea abandonar la operación.


Un archivo eliminado con el mismo nombre ya existe en este proyecto de SourceSafe. ¿Desea recuperar el archivo eliminado en lugar de agregar el <nombre de archivo> local?

Anteriormente fue eliminado un archivo con el mismo nombre que el que está agregando a VSS, pero no ha sido purgado de la base de datos. El archivo eliminado aún forma parte del proyecto, pero se encuentra en la lista de archivos eliminados. Puesto que en un proyecto no pueden existir dos archivos con el mismo nombre, VSS le da la opción de recuperar el archivo eliminado o la de utilizar el nuevo archivo qe está intentando agregar. En cualquier caso, el otro archivo quedará sustituido en el proyecto de forma permanente.


Ya existe un vínculo del archivo <archivo> en el proyecto de destino

¿Desea recuperar el archivo enlazado?


Se ignoró un hipervínculo en <archivo> porque era demasiado largo

Este mensaje tiene la siguiente causa y solución:

  • La dirección URL es muy larga para el búfer interno.

    Utilice una dirección URL más corta.


Una combinación de <archivo> ha producido un archivo de 0 bytes. Puede que se hayan perdido datos. ¿Desea deshacer la combinación? (se recomienda)

Este mensaje tiene la siguiente causa y solución:

  • Un archivo de longitud cero indica un posible error interno de VSS que ha dado como resultado la pérdida de los datos durante la operación de combinación.

    Recomendado: deshacer la combinación haciendo clic en Sí. Sin embargo, si está seguro de que ha realizado alguna operación en la que se ha obtenido como resultado un archivo válido de longitud cero, puede hacer clic en No para guardar el archivo combinado de longitud cero.


Hay una versión más reciente desprotegida

En cualquier momento pueden estar desprotegidas múltiples versiones de un archivo. Sin embargo, cuando exista una versión más reciente del archivo, VSS le advertirá de que podría sobrescribir una versión más reciente del archivo.


No se puede compartir un proyecto por debajo de un descendiente

Este mensaje tiene la siguiente causa y solución:

  • Está intentando compartir este proyecto de forma recursiva, con un subroyecto perteneciente a este proyecto. Esta acción produciría una recursión infinita y, por tanto, no está permitida.


Ya existe una copia modificable de <archivo>

Al obtener un archivo VSS, el archivo es marcado como sólo lectura. No puede modificar el archivo. Cuando desprotege el archivo para modificarlo, se elimina el indicador de sólo lectura. Al protegerlo, el archivo se vuelve a marcar como de sólo lectura. Este mensaje tiene la siguiente causa y solución:

  • Intentó utilizar el comando Obtener la última versión sobre un archivo que ya existía en el disco duro en formato lectura/escritura. Si la copia local es de lectura/escritura, probablemente estará desprotegida, VSS no sustituye el archivo y muestra este mensaje de error.

    Haga clic en Sí o en Sí a todos para sustituir el archivo o archivos por la versión actual de la base de datos VSS.

    Haga clic en No o en No a todos para no reemplazar el(los) archivo(s).

    Haga clic en Cancelar para cancelar el comando Obtener la última versión.


Se ha denegado el acceso al archivo <archivo>

Bajo determinadas condiciones, VSS deniega el acceso a un archivo a un usuario. Este error tiene las causas y soluciones siguientes:

  • Se le denegó el acceso (privilegios de lectura o escritura) a un archivo que VSS intentaba abrir.

    Es posible que otro usuario tenga el archivo bloqueado momentáneamente; vuélvalo a intentar.

  • Puede que no tenga suficientes privilegios de red para llevar a cabo la acción que intenta realizar.

    Consulte su administrador de VSS para obtener más información acerca de sus derechos de acceso VSS.


Si agrega el nombre <nombre de grupo> sobrepasaría la longitud máxima de File_Types. Reduzca el tamaño del nombre o elimine otros nombres

Este mensaje tiene la siguiente causa y solución:

  • La longitud combinada de los valores de los filtros de la ficha Tipos de archivo del cuadro de diálogo Opciones de SourceSafe en el menú Herramientas es demasiado grande. VSS utiliza el campo Tipos de archivo incluidos en grupo de archivos para crear un filtro para los cuadros de diálogo Compartir y Agregar. Este error se produce cuando la longitud combinada de los grupos es demasiado grande. La longitud total del búfer es de 511 caracteres.

    Para remediar y evitar este error, reduzca el tamaño del nombre de Grupo de archivos o elimine de la lista otros nombres de Grupo de archivos.


Se han resuelto todos los conflictos. ¿Desea guardar el archivo?

Este mensaje tiene la siguiente causa y solución:

  • Resolvió correctamente todos los conflictos de combinación.

    Haga clic en Sí para guardar el archivo o en No para descartar los cambios.


¿Desea compartir siempre la versión más reciente de <archivo>?

Vea también

Generalmente, todo proyecto que comparte un archivo siempre tiene la versión más reciente del archivo. Cuando protege el archivo en cualquier proyecto se actualizan automáticamente todos los proyectos. Sin embargo, puede utilizar el botón Fijar del cuadro de diálogo Historial del archivo para compartir una determinada versión de un archivo. Este mensaje tiene la siguiente causa y solución:

  • Si hace clic en el botón Fijar del cuadro de diálogo Historial del archivo, el proyecto compartirá explícitamente la versión fijada y no recibirá los cambios protegidos realizados en otros proyectos.

  • Si hace clic en Liberar el proyecto volverá al estado compartido en el que se utiliza siempre la versión más reciente del archivo.


Ha ocurrido una combinación automática y hay conflictos. Modifique <archivo> para resolverlos

Vea también

Los cambios que realizó en el archivo desde que lo desprotegió entran en conflicto con los cambios realizados (y protegidos) en el archivo de origen por otro usuario. Este mensaje tiene la siguiente causa y solución:

  • Debe resolver los conflictos entre sus cambios y los realizados por otro usuario antes de poder proteger el archivo.

    Abra el archivo en su carpeta de trabajo y busque seis signos igual consecutivos (======). VSS los utiliza para señalar la ubicación de un conflicto.

Es posible que prefiera utilizar la característica Combinación Visual para facilitar la resolución del conflicto. Para evitar esta situación, su administrador VSS puede desactivar desprotecciones múltiples en su proyecto.


Error al comprobar los hipervínculos de <archivo>

Este mensaje tiene la siguiente causa y solución:

  • La ruta del directorio de trabajo, la especificación de VSS o la URL son muy grandes.

    Compruebe que no está sobrepasando los límites de ruta de la carpeta, de la especificación o de la dirección URL. Compruebe que Htmlfilt.dll está todavía presente en su sistema y se ha registrado correctamente (vuelva a ejecutar la instalación del cliente para solucionar este problema).


Ya se ha eliminado de este proyecto un elemento llamado <elemento>

Vea también

En VSS sólo puede eliminar una instancia de un archivo o un proyecto con un determinado nombre en un proyecto dado. Este mensaje tiene la siguiente causa y solución:

  • Eliminó un archivo y creó uno con el mismo nombre, para después intentar eliminar de nuevo el archivo.

    Puede hacer clic en Sí para purgar el archivo anterior o en No para cancelar la operación de eliminación. Si purga el archivo original, perderá toda la información histórica, pero podrá continuar con la operación de eliminación. Si quiere guardar el historial del archivo antiguo, puede hacer clic en No y asignar un nombre diferente al nuevo archivo antes de eliminarlo.


Ya existe un elemento con el nombre <nombre>

Vea también

Cada elemento de un proyecto de VSS debe tener un nombre único. Este mensaje tiene la siguiente causa y solución:

  • Intentó asignar nombre a un archivo o a un subproyecto inmediato con el mismo nombre que el proyecto. (Puede existir un elemento con este nombre en otros proyectos de la base de datos, incluidos subproyectos.)

    Para resolver este error, asigne un nombre diferente y único al nuevo elemento. O bien, puede eliminar o cambiar el nombre del elemento existente.

Nota En VSS, los nombres de los proyectos y de los archivos no distinguen entre mayúsculas y minúsculas. Por ejemplo, si tiene un archivo llamado Test.C, no podrá crear un subproyecto o un archivo llamado "Test.c" o "test.c" dentro del mismo proyecto.


No se puede compartir una versión antigua del archivo <archivo> porque sólo está almacenada la versión más reciente

Este mensaje tiene la siguiente causa y solución:

  • Ha intentado compartir una versión antigua de un archivo. VSS sólo guarda la última versión de un archivo.

    Sólo puede compartir la versión más reciente de un archivo.


¿Realmente desea eliminar?

Esta advertencia tiene la siguiente causa y solución:

  • Es el mensaje estándar de advertencia mostrado por VSS.

    Si hace clic en Sí, VSS eliminará el elemento o los elementos.

    Si hace clic en No, VSS cancelará el comando Eliminar.


¿Realmente desea quitar todos los archivos de <proyecto>?

Esta advertencia tiene la siguiente causa y solución:

  • Esta acción eliminará todos los archivos especificados en su directorio temporal.

    Puede cancelar la operación o continuar con la eliminación de todos los archivos temporales.


La sintaxis del nombre de usuario no es correcta: <sintaxis>

Este mensaje tiene la siguiente causa y solución:

  • Ha introducido un nombre de usuario con una sintaxis de usuario de VSS no válida.

    Pregúntele a su administrador VSS cuál es su nombre de usuario VSS correcto.


Los archivos binarios son diferentes

Este mensaje tiene la siguiente causa y solución:

  • Los archivos binarios que ha seleccionado son diferentes.

    El comando Mostrar diferencias no muestra línea por línea las diferencias entre archivos binarios. Por tanto, VSS sólo puede decirle si la copia maestra de VSS es diferente de su copia local.


No se puede cambiar el proyecto a <proyecto>

Este mensaje tiene la siguiente causa y solución:

  • VSS no ha podido cambiar el proyecto al proyecto especificado.

    Por favor, asegúrese de que el proyecto existe y es válido.


No se puede desproteger <archivo>. Es de tipo binario y ya está desprotegido

Este mensaje tiene las siguientes causas y solución:

  • El archivo especificado es binario y ya está desprotegido. VSS no permite múltiples desprotecciones en archivos binarios, ya que sus cambios no se pueden combinar.

    Espere para desproteger el archivo a que el otro usuario lo haya protegido.


No se puede desproteger una versión antigua de <nombre de archivo> porque se ha eliminado el archivo

Vea también

Esta advertencia tiene la siguiente causa y solución:

  • Está intentando desproteger una versión antigua del archivo. Sin embargo, esa versión del archivo ha sido eliminada y no puede ser desprotegida.

    Recupere el archivo del proyecto antes de intentar desprotegerlo. Puede recuperar archivos desde la ficha Elementos eliminados del cuadro de diálogo Propiedades del proyecto.


No se puede desproteger una versión antigua de un archivo

Vea también

El comando Desproteger siempre utiliza la versión más reciente de un archivo. Este mensaje tiene la siguiente causa y solución:

  • Está intentando desproteger una versión antigua de un archivo.

Para utilizar y modificar una versión anterior

  1. Desproteja la versión más reciente del archivo.

  2. Elimínelo de la carpeta de trabajo (no de la base de datos VSS).

  3. Obtenga la versión antigua que desea modificar.

  4. Realice los cambios en la versión antigua. (Puede que necesite quitar manualmente el indicador de sólo lectura.)

  5. Proteja el archivo modificado en VSS.

Nota También puede utilizar el botón Deshacer del cuadro de diálogo Historial del archivo (en el menú Herramientas, haga clic en Mostrar historial). Si vuelve a una determinada versión, todas las versiones posteriores a ella son eliminadas. Entonces podrá desproteger el archivo y comenzar a modificarlo. La desventaja de este método, sin embargo, es que perderá todas las versiones posteriores y no podrá recuperarlas.


No se puede cambiar el nombre del proyecto raíz

Este mensaje tiene la siguiente causa:

  • No se puede aplicar los comandos Eliminar, Cambiar nombre y Mover proyecto al proyecto raíz ($/),que es análogo a la carpeta raíz del disco duro (C:\).


No se puede eliminar, cambiar de nombre o mover el proyecto raíz

Este mensaje tiene la siguiente causa y solución:

  • No se puede aplicar los comandos Eliminar, Cambiar nombre y Mover proyecto al proyecto raíz ($/),que es análogo a la carpeta raíz del disco duro (C:\).

    Como no hay ninguna forma de modificar el proyecto raíz, considere la posibilidad de reestructurar su proyecto.


No se puede eliminar/cambiar de nombre/modificar el usuario Admin

Este mensaje tiene la siguiente causa y solución:

  • Intentó cambiar eliminar, cambiar el nombre o cambiar el usuario Admin. El administrador VSS siempre debe existir en la lista de usuarios del Administrador de VSS, aunque no debe utilizar Admin como un usuario real.

    Sin embargo, puede cambiar la contraseña del usuario Admin utilizada para iniciar la sesión en el Administrador de VSS.


No se puede distinguir el elemento <elemento> especificado

Al menos uno de los elementos que ha seleccionado para comparar con otro elemento no se puede distinguir en VSS.


No se puede modificar el usuario Admin

Este mensaje tiene la siguiente causa y solución:

  • Intentó modificar los derechos de acceso del usuario Admin.

    No se puede cambiar el nombre del usuario Admin ni sus derechos de acceso. Seleccione otro usuario sobre el que utilizar este comando.


No se puede encontrar el archivo de Ayuda <archivo>

Este mensaje tiene la siguiente causa y solución:

  • El archivo de Ayuda no está disponible.

    Pruebe a reinstalar VSS para obtener una copia del archivo de ayuda. Si, aún así, no encuentra el archivo, llame al Servicio de soporte técnico.


No se puede encontrar la variable de inicialización <variable>

VSS no puede encontrar una variable de inicialización que necesita para realizar una operación. Este mensaje tiene la siguiente causa y solución:

  • No se encuentra la variable de inicialización necesaria para completar la operación.

    Busque en la Ayuda o en Manual del usuario de Microsoft Visual SourceSafe información acerca de la variable, asigne un valor adecuado y agregue la variable a su archivo de inicialización.


No se puede encontrar el archivo SS.INI

VSS no puede encontrar su archivo SS.INI. Este mensaje tiene las siguientes causas y solución:

  • El archivo SS.INI no está donde VSS esperaba encontrarlo. (Pregunte al Administrador de VSS si movió el archivo.)

  • Eliminó sin querer el archivo SS.INI.

    Puede copiar un archivo SS.INI de otro usuario a su carpeta de VSS y después modificarlo para personalizar VSS. Su administrador deberá configurar VSS para que busque el archivo en el lugar correcto.


No se puede encontrar el archivo SS.INI para el usuario <nombre de usuario>

VSS no puede encontrar el archivo SS.INI para este usuario. La ubicación predeterminada es vss\users\<username>.

Este mensaje tiene las siguientes causas y solución:

  • El archivo SS.INI no está donde VSS esperaba encontrarlo. (Pregunte al Administrador de VS si ha movido este archivo.)

  • El archivo SS.INI del usuario ha sido movido o cambiado de nombre.

    Puede copiar un archivo SS.INI de otro usuario en la carpeta de este usuario y después modificarlo para personalizar VSS. Su administrador deberá configurar VSS para que busque el archivo en el lugar correcto.


No se puede mover un proyecto bajo él mismo

Vea también

Un proyecto no puede ser un proyecto de él mismo. Este mensaje tiene la siguiente causa y solución:

  • Ha intentado crear en la jerarquía de su proyecto un bucle no válido, por ejemplo, moviendo el proyecto $/Word bajo el proyecto $/Word, o moviendo $/Word under $/Word/Apps. Esto crea un bucle recursivo sin fin, lo que produce este error.

    Reestructure la jerarquía del proyecto para que no se produzca un bucle no válido.


No se puede mover el proyecto raíz

Este mensaje tiene la siguiente causa y solución:

  • No se puede aplicar los comandos Eliminar, Cambiar nombre y Mover proyecto al proyecto raíz ($/),que es análogo a la carpeta raíz del disco duro (C:\).

    Como no hay ninguna forma de modificar el proyecto raíz, considere la posibilidad de reestructurar su proyecto.


No se puede cambiar el nombre del usuario Admin

Ha intentado cambiar el nombre del usuario Admin. El administrador VSS siempre debe existir en la lista de usuarios del Administrador de VSS, aunque no debe utilizar Admin como un usuario real.

Puede, sin embargo, cambiar la contraseña del usuario Admin utilizada para iniciar la sesión en el Administrador de VSS.


No se puede cambiar el nombre con otro volumen

No hay elementos eliminados para este proyecto.


No se puede cambiar el nombre por <archivo>; este nombre ya existe

Vea también

El nombre de archivo especificado ya existe en el proyecto. Este mensaje tiene la siguiente causa y solución:

  • Cuando cambia el nombre de un archivo compartido por diferentes proyectos, el nombre del archivo cambia en todos los proyectos que lo comparten. Si cualquier otro de estos proyectos ya tiene un archivo con el mismo nombre, creará una situación antigua que no es válida: dos archivos del mismo proyecto con el mismo nombre. La operación de cambio de nombre falla.

    Para corregirlo, elija otro nombre para el archivo.


No se pueden deshacer los cambios hasta la versión más reciente de <archivo>

Vea también

El comando Deshacer devuelve un archivo a su versión anterior. Este mensaje tiene la siguiente causa y solución:

  • Intentó deshacer los cambios a un archivo hasta su versión más reciente o no especificó la versión a la que desea volver.

    No se puede deshacer los cambios a un archivo hasta su versión más reciente en VSS. Si quiso especificar una versión anterior, vuelva a intentar ejecutar el comando con la versión anterior especificada.


No se pueden deshacer los cambios hasta la versión más reciente de <archivo>

Este mensaje tiene la siguiente causa y solución:

  • Deshacer es una función que le permite destruir de forma permanente todas las versiones de los archivos, desde la más reciente hasta la versión indicada con el modificador –V. Sin embargo, la versión que ha indicado en el modificador –V es la versión más reciente por tanto no se han deshecho los cambios.

    Utilice el comando ss history <Archivo> para ver si existen versiones anteriores del archivo. Utilice después una de las versiones antiguas del archivo con el comando ss rollback <Archivo> -V.


No se puede compartir un archivo o proyecto consigo mismo

Este mensaje tiene la siguiente causa y solución:

  • VSS no permitirá que exista más de un archivo o subproyecto con el mismo nombre en un único proyecto. En la línea de comandos, está intentando compartir un archivo o subproyecto con un proyecto que ya contiene un archivo o subproyecto con el mismo nombre.

    Utilice el comando ss cp para cambiar el proyecto actual a un proyecto que no contenga un archivo/proyecto con el mismo nombre. También puede seleccionar un archivo o proyecto diferente para compartirlo.


¿Desea desproteger todo el proyecto en esta etiqueta?

Esta advertencia tiene la siguiente causa y solución:

  • Está intentando desproteger una versión antigua de un proyecto etiquetado desde la ventana del historial del proyecto.

    Haga clic en Sí para desproteger todos los archivos del proyecto en la versión etiquetada que ha seleccionado.

    Haga clic en No para cancelar la operación.


¿Desea desproteger todo el proyecto que contiene esta versión del archivo?

Esta advertencia tiene la siguiente causa y solución:

  • Está intentando desproteger una versión antigua de un archivo desde la ventana del historial del proyecto.

    Haga clic en Sí para desproteger todos los archivos del proyecto en la versión que ha seleccionado.

    Haga clic en No para desproteger tan sólo la versión del archivo que ha seleccionado.

Nota Si etá viendo la historia recursiva de un proyecto de mayor nivel e intenta desproteger una versión antigua de un archivo en un subproyecto, debe seleccionar la casilla de verificación Recursivo en el cuadro de diálogo Desproteger <nombre de archivo>. De otro modo, el archivo no será desprotegido.


Eliminadas las desprotecciones de <ruta de acceso> (<usuario>)

Este es un mensaje de información que indica que han sido eliminadas algunas desprotecciones. En cualquier momento puede volver a desproteger cualquier archivo.


Se ha producido una colisión al tener acceso a la base de datos; vuelva a intentarlo

No hay elementos eliminados para este proyecto.


¿Desea continuar con otros elementos?

¿Desea continuar procesando los restantes elementos?


Se ha dañado el historial para el archivo <archivo> después de la revisión <número>

Este mensaje tiene la siguiente causa y solución:

  • La base de datos VSS ha sido dañada.

    Ddconv.EXE guarda todo lo posible de la base de datos, pero perderá irremediablemente alguna información (a menos que haya hecho copia de seguridad de la base de datos y pueda recuperar la información de dicha copia)


No se pudo distribuir <proyecto> en <host>

Este mensaje tiene la siguiente causa y solución:

  • VSS no pudo abrir una conexión con el host ftp especificado y desplegar su proyecto.

    Compruebe sus conexiones de red y verifique que ha utilizado la sintaxis correcta para el host ftp. Este error también se puede producir si su host ftp no está disponible en este momento.

    Este mensaje puede querer decir también que no queda espacio en el disco. También puede significar que no tiene permiso para escribir en la ubicación aunque pueda tener permiso de lectura.


No se puede mostrar esta dirección URL

Este mensaje tiene la siguiente causa y solución:

  • Ha intentado comprobar un enlace Web externo, pero en el registro no existe ningún explorador Web que permita tratar una ruta http; o, la sintaxis del enlace era incorrecta para ShellExecute (podría suceder si se intenta comprobar una raíz virtual haciendo doble clic en ella en lugar de configurando la raíz virtual).

    Instale Internet Explorer versión 3.0 (o posterior).


No se pudo encontrar el archivo al que hace referencia el acceso directo <archivo>

Este mensaje tiene la siguiente causa y solución:

  • Imposible encontrar el archivo al que hace referencia el archivo .lnk.

    Compruebe que el archivo no se ha movido o eliminado. Haga clic en Aceptar para aceptar y volver a intentar.


No se pudo iniciar la sesión en <sitio ftp>

Este mensaje tiene la siguiente causa y solución:

  • No puede iniciar la sesión en el sitio ftp especificado.

    Puede que esté usando una dirección, un nombre de usuario o una contraseña no válidos, o quizá el sitio no responde. Asegúrese de que tiene la dirección ftp apropiada.


La base de datos actual no coincide con la solicitada

Este mensaje tiene la siguiente causa y solución:

  • Se ha producido un error interno de VSS. VSS asume que la base de datos en la que ha iniciado la sesión debe estar en un formato nuevo.

    Llame al Administrador VSS para ejecutar DDUPD –redo, o para ponerse en contacto con el soporte técnico.


Falta la configuración del proyecto actual en el archivo SS.INI o no es válida

Esta advertencia tiene la siguiente causa y solución:

  • Cuando un usuario sale de VSS, el programa guarda el último proyecto en el que trabajaba el usuario en el archivo de configuración de usuarios. Si se elimina ese proyecto, cuando el usuario intenta realizar una acción desde la línea de órdenes aparecerá este mensaje.

    Utilice el comando ss cp <proyecto> para cambiar a un proyecto existe.


<base de datos> ya está en la lista de la base de datos

Este mensaje tiene la siguiente causa y solución:

  • La base de datos ya existe en la lista de Bases de datos disponibles.

    Seleccione la entrada correspondiente en la base de datos, tal y como aparece en la lista de Bases de datos disponibles.


<base de datos> ya está en la lista de la base de datos. ¿Desea cambiar el nombre?

Este mensaje tiene la siguiente causa y solución:

  • Está cambiando el nombre de una entrada de base de datos VSS en la lista de Bases de datos abiertas de SourceSafe.

    Haga clic en Sí para cambiar el nombre de la entrada seleccionada o en No para dejar la entrada de la base de datos tal y como aparece en la lista.


¿Desea eliminar todos los elementos especificados?

Vea también

Esta advertencia tiene la siguiente causa y solución:

  • Está a punto de eliminar un archivo o un proyecto.

    Haga clic en Sí, para que VSS elimine el archivo o proyecto.

    Haga clic en No, y VSS no lo hará.

    Utilice el comando Recuperar para deshacer Eliminar.

Nota Su no quiere recibir este mensaje cada vez que elimine un archivo o proyecto, puede deshabilitarlo en la ficha Advertencias del cuadro de diálogo Opciones de SourceSafe del menú Herramientas.


¿Desea eliminar el archivo local: <archivo local>?

Esta advertencia tiene la siguiente causa y solución:

  • Tiene activado el Modo Inteligente y está intentando eliminar un archivo de un proyecto. VSS también le ofrece eliminar la copia local.

    Haga clic en Sí para eliminar la copia local.

    Haga clic en No para dejar la copia local. La copia de VSS será eliminada.

    Para desactivar el Modo inteligente, vaya a la ficha Archivos Locales de la opción Opciones del menú Herramientas y quite la selección de Quitar copia local después de Eliminar.


¿Desea eliminar los derechos de usuario para <nombre de usuario>?

Elimina los derechos de usuario de un usuario específico para un proyecto VSS seleccionado. Estos cambios tendrán efecto sobre el usuario la próxima vez que acceda a VSS.


¿Desea eliminar los derechos de usuario para <nombre de proyecto>?

Elimina los derechos de usuario asignados con anterioridad a un proyecto VSS para un usuario especificado. Este cambio tendrá efecto sobre el usuario especificado la próxima vez que acceda a VSS.


No se puede deshacer la destrucción. Perderá la información definitivamente.

Vea también

Esta advertencia tiene la siguiente causa y solución:

  • Cuando utiliza el comando Destruir en un archivo o en un proyecto, la acción es irreversible.

    Haga clic en Sí para continuar con la operación de destrucción. Haga clic en No para cancelar la operación.

Nota Su no quiere recibir este mensaje cada vez que destruya un archivo o proyecto, puede deshabilitarlo en la ficha Advertencias del cuadro de diálogo Opciones de SourceSafe del menú Herramientas.


El disco está lleno

Este mensaje tiene la siguiente causa y solución:

  • Intentó guardar datos en un disco lleno.

    Libere espacio en disco; para ello, elimine o mueva archivos innecesarios.


La ruta del editor es un campo necesario cuando se selecciona la petición de editor

Este mensaje tiene la siguiente causa y solución:

  • Cuando active la casilla de verificación Utilizar editor para pedir comentarios debe especificar el editor adecuado.

    Establezca .la ruta en el campo Editor de la ficha Opciones de línea de comandos del cuadro de diálogo Opciones de SourceSafe del menú Herramientas.


Error al crear <archivo> mientras se intentaba bloquear la base de datos. La base de datos no está bloqueada.

Este mensaje tiene la siguiente causa y solución:

  • Es necesario crear un archivo en el siguiente directorio, sin embargo, el proceso de creación ha fallado: <directorio de instalación de vss>\data\loggedin

    Es posible que se haya quedado sin espacio en disco, o que no tenga derecho de escritura en esa carpeta.

    Asegúrese de que tiene acceso de escritura a la carpeta de VSS.


Error al eliminar <archivo> mientras se intentaba desbloquear la base de datos. La base de datos no está desbloqueada

Este mensaje tiene la siguiente causa y solución:

  • Es necesario eliminar un archivo en el siguiente directorio, sin embargo, el proceso de eliminación ha fallado: <directorio de instalación de vss>\data\loggedin

    No tiene permisos de eliminación en la carpeta.

    Asegúrese de que tiene permisos de eliminación en la carpeta VSS.


Error al cargar el complemento de SourceSafe: <nombre de complemento>

No hay elementos eliminados para este proyecto.


Error al intentar localizar el directorio de archivos temporales

Este mensaje tiene la siguiente causa y solución:

  • Falta la entrada de Temp_Path en el archivo SRCSAFE.INI.

    Pida a su Administrador VSS que arregle la entrada Temp_Path en el archivo SRCSAFE.INI


Error al leer el archivo

VSS no puede leer uno de los archivos que ha abierto. Este mensaje tiene la siguiente causa y solución:

  • Puede que haya perdido la conexión con la red.

    Salga de VSS y compruebe todas las conexiones de red antes de reiniciar.


Error al escribir en el archivo

VSS no puede escribir datos en uno de los archivos que ha abierto. Este mensaje tiene la siguiente causa y solución:

  • Puede que el disco esté lleno.

    Salga de VSS y libere espacio en el disco eliminando los archivos que no sean necesarios.


Error al escribir el archivo de combinación para <archivo>

Se ha producido un error interno y la operación de combinación ha sido deshecha.


No se puede encontrar el archivo <nombre de archivo> (archivo <nombre de archivo> en SourceSafe)

Este mensaje tiene la siguiente causa y solución:

  • VSS no ha podido localizar el archivo especificado.

    Ejecute la utilidad Analyze para asegurarse de que no hay errores en su base de datos VSS. Si el problema no se arregla ejecutando Analyze con el argumento–F, póngase en contacto con el Soporte de productos.

Nota Cuando use la utilidad Analyze, hágalo primero sin argumentos para localizar cualquier error en la base de datos y luego con el argumento –F para que se ejecute en modo de reparación automática.


El archivo <nombre de archivo> no ha cambiado. ¿Desea crear una versión nueva del archivo en SourceSafe?

Este mensaje tiene la siguiente causa y solución:

  • Está intentando proteger un archivo desprotegido que no ha modificado.

    Haga clic en Sí, y VSS protegerá el archivo. (Si hace clic en Sí a todo protegerá todos los archivos seleccionados.) Una protección crea una nueva versión del archivo, con un comentario opcional.

    Haga clic en No, y VSS deshará la desprotección del archivo. (Haga clic en No, y VSS deshará la desprotección del archivo.) En este caso no se creará una versión nueva del archivo.

Nota Para omitir este mensaje en el futuro, deshabilite esta notificación en la ficha General a la que se accede seleccionando Opciones en el menú Herramientas.


El archivo <nombre de archivo> está desprotegido por <nombre de usuario>. ¿Desea eliminarlo?

Esta advertencia tiene la siguiente causa y solución:

  • Está intentando realizar una operación que eliminaría un archivo desprotegido por otro usuario en estos momentos.

    Si elimina este archivo, la información de desprotección se perderá, incluso aunque el archivo no se elimine de forma permanente. En esta situación, VSS le da varias opciones:

    • Haga clic en Sí para eliminar el archivo.

    • Haga clic en Sí a todo para que las opciones que elija en este cuadro de diálogo se apliquen a todos los archivos desprotegidos para otros usuarios.

    • Haga clic en No para omitir la operación para este archivo.

    • Haga clic en No a todo para omitir la operación para todos los archivos desprotegidos para otros usuarios.

    • Haga clic en Cancelar para cancelar la operación.


El archivo <nombre de archivo> está desprotegido por <nombre de usuario>. ¿Desea hacerlo?

Esta advertencia tiene la siguiente causa y solución:

  • Está intentando realizar una operación en un archivo desprotegido para otro usuario, lo que eliminaría la información de desprotección. Por ejemplo, el usuario Admin puede deshacer la desprotección de un archivo desprotegido por cualquier otro usuario.

    Haga clic en Sí para continuar con la operación, perdiendo la información de desprotección.

    Haga clic en Sí a todo para que las opciones que elija en este cuadro de diálogo se apliquen a todos los archivos desprotegidos para otros usuarios.

    Haga clic en No para omitir la operación para este archivo.

    Haga clic en No a todo para omitir la operación para todos los archivos desprotegidos para otros usuarios.

    Haga clic en Cancelar para cancelar la operación.


El archivo <nombre de archivo> no es válido. Los archivos no pueden comenzar con $

Esta advertencia tiene la siguiente causa y solución:

  • Está intentando agregar un archivo a VSS cuyo nombre comienza con el signo de dólar. No es un nombre de archivo válido en VSS.

    Elimine el signo de dólar e intente agregar el archivo de nuevo.


El archivo <nombre de archivo> no está bifurcado; por lo tanto, no puede combinarlo

Esta advertencia tiene la siguiente causa y solución:

  • Para poder combinar un archivo debe haber estado ramificado en algún momento de su historial. El archivo seleccionado nunca ha estado ramificado.

    Seleccione un archivo que haya estado ramificado.


No se encontró el archivo <nombre de archivo>

VSS no ha podido encontrar el archivo que estaba buscando.

Este mensaje tiene las siguientes causas y solución:

  • Es posible que haya tecleado mal un nombre de archivo en el explorador de VSS o en una variable del archivo de inicialización.

  • Puede que el archivo no exista.

    Asegúrese de que ha escrito correctamente el nombre del archivo.


El archivo <archivo> ya existe

Este mensaje tiene la siguiente causa y solución:

  • Intentó crear un archivo o una carpeta con un nombre ya existente.

    Puede dar el mismo nombre a varios archivos VSS siempre que estén en diferentes directorios, pero sólo puede aparecer una vez en un único directorio. Seleccione un nombre diferente o cambie el nombre del archivo o el proyecto que está provocando el problema.


El archivo <archivo> ya existe. ¿Desea sobrescribirlo?

Esta advertencia tiene la siguiente causa y solución:

  • Está intentado copiar un archivo, como parte de un comando Desproteger u Obtener, sobre un archivo existente con permisos de escritura. Esta caso suele producirse en la integración.

    Haga clic en Sí si desea que la copia de la carpeta local sea sobrescrita por el archivo en el que está ejecutando el comando Obtener o Desproteger.

    Haga clic en No si desea mantener la copia de la carpeta local.


El archivo <archivo> no mantiene las versiones anteriores de sí mismo

Vea también

Este mensaje tiene la siguiente causa y solución:

  • Cuando protege un archivo, VSS conserva la versión actual del archivo y la información necesaria para reconstruir versiones anteriores. Ha desactivado el almacenamiento de versiones históricas para este archivo.

    Si de forma explícita desactivó esta información de modificaciones en el cuadro de diálogo Propiedades o, cuando utilizaba el comando Agregar archivos, VSS le puede dar la versión más reciente, pero no puede reconstruir versiones anteriores.


Se ha destruido el archivo <archivo> y no puede volver a generarse

Vea también

Es posible que VSS no pueda reproducir el archivo que ha solicitado. Este mensaje tiene la siguiente causa y solución:

  • Destruyó de forma permanente un archivo o lo cambió de lugar. Por ejemplo, debía haber un archivo en un proyecto que ha eliminado o purgado. Después intentó volver a una versión anterior del proyecto. VSS intenta reconstruir el proyecto exactamente como era anteriormente, pero no puede porque no puede recuperar el archivo.

    Haga clic en Sí, y VSS intentará recuperar el archivo antiguo, aunque la recuperación no está garantizada.

    Haga clic en No y se detendrá el intento de restaurar el archivo antiguo.

    Haga clic en Sí a todo y VSS no le avisará de la posible existencia de otros archivos irrecuperables; continuará llevando a cabo la reconstrucción de la mejor forma posible.


El archivo <archivo> no ha cambiado

Este mensaje tiene la siguiente causa y solución:

  • Está intentando proteger un archivo desprotegido que no ha cambiado.

    Haga clic en Sí, y VSS protegerá el archivo. (Si hace clic en Sí a todo protegerá todos los archivos seleccionados.) Una protección crea una nueva versión del archivo, con un comentario opcional.

    Haga clic en No, y VSS deshará la desprotección del archivo. (Haga clic en No, y VSS deshará la desprotección del archivo.) En este caso no se creará una versión nueva del archivo.

Nota Para omitir este mensaje en próximas ocasiones, deshabilite esta notificación en la ficha General a la que se accede seleccionando Opciones en el menú Herramientas.


El archivo <archivo> ya está desprotegido por otro usuario. ¿Desea continuar?

Esta advertencia tiene la siguiente causa y solución:

  • El archivo que ha seleccionado para desproteger ya está desprotegido por otro usuario.

    Cancele la desprotección o siga adelante.


El archivo <archivo> ya está abierto

Esta advertencia tiene la siguiente causa y solución:

  • VSS u otro usuario han bloqueado el archivo.

    Si VSS ha bloqueado el archivo, puede intentar eliminar el bloqueo realizando una comprobación de estado en el archivo o en toda la base de datos.

    En un símbolo del sistema, escriba:

    SS Status $/ -R

    Si el archivo aún está bloqueado, póngase en contacto con el administrador de su red.

    Si se siguen produciendo problemas como éste, es posible que necesite habilitar el bloqueo VSS.


El archivo <archivo> ya está compartido con este proyecto

Vea también

Este mensaje tiene la siguiente causa y solución:

  • Está intentando compartir un archivo con el proyecto actual, pero ese archivo ya existe en el proyecto actual.

    Si desea compartir una versión diferente del archivo, especifique una versión en el cuadro de diálogo Historial del archivo y haga clic en Fijar. Si desea compartir este archivo con otro proyecto, seleccione ese proyecto en el explorador de VSS y haga clic en Compartir en el menú SourceSafe. Después, seleccione el archivo que desea compartir en el cuadro de diálogo Compartir.


El archivo <archivo> ya está desprotegido por <usuario>

Esta advertencia tiene la siguiente causa y solución:

  • Ha intentado realizar una operación en un archivo VSS que está desprotegido pro otro usuario.

    VSS muestra esta advertencia antes de permitir o negar el acceso a la realización de acciones sobre un archivo.


El archivo <archivo> está desprotegido en el proyecto <proyecto> y usted está en <proyecto>

Cuando un archivo se comparte entre varios proyectos, un archivo de un proyecto está vinculado a todos los demás proyectos que lo comparten. Por tanto, cuando desprotege el archivo de un proyecto, también se desprotege de todos los proyectos que lo comparten. Esta advertencia tiene la siguiente causa y solución:

  • Desprotegió un archivo de un proyecto y está intentando proteger o deshacer la desprotección del archivo en otro proyecto que comparte el mismo archivo.

    Es una acción válida. VSS sólo le avisa por si no pretendía realizar esta acción. Para continuar, haga clic en Sí; para cancelar la operación, haga clic en No.

Nota Puede proteger un archivo o deshacer la desprotección en cualquier proyecto que comparta un archivo.


El archivo <archivo> está desprotegido actualmente por <usuario>

Vea también

Esta advertencia tiene la siguiente causa y soluciones:

  • Cuando otro usuario tiene un archivo desprotegido, hay algunas cosas que usted no puede hacer con el archivo. Por ejemplo, no puede eliminar o cambiar el nombre de un archivo desprotegido.

    Haga clic en Sí para desproteger el archivo de todas formas. (Sí a todo desprotege todos los archivos seleccionados aunque ya estén desprotegidos por otro usuario.) Si elije Sí, puede haber conflictos entre sus cambios y los realizados por otro usuario, y después habrá que resolverlos y combinarlos.

    Haga clic en No para cancelar el comando Desproteger. (No a todo cancela el comando para todos los archivos seleccionados.)

Si desea trabajar con un archivo desprotegido, lo mejor es comprobar en la columna Usuario del explorador de VSS el nombre del usuario que ha desprotegido el archivo y pedirle que lo protega lo antes posible. Si no puede contactar con el usuario, el Administrador VSS puede desprotegerlo por usted.


Se ha desprotegido el archivo <archivo> de forma exclusiva

Esta advertencia tiene la siguiente causa y solución:

  • Si la opción Desprotecciones múltiples está activada, los usuarios de VSS pueden desproteger los archivos de dos formas diferentes. Primero, pueden permitir que otros archivos desprotejan el archivo o pueden desprotegerlo de forma que ningún otro usuario pueda desproteger ese archivo, de forma exclusiva. Este es el mensaje que aparece cuando un usuario intenta desproteger un archivo que ya está desprotegido de forma exclusiva por algún otro usuario. Frecuentemente aparece con el mensaje "<Archivo> ya está desprotegido, ¿Desea continuar?".

    No podrá desproteger este archivo hasta que el usuario que lo tiene lo proteja o realice una operación deshacer desprotección. Para averiguar quién tiene desprotegido el archivo, puede utilizar el comando ss status o mirar la ficha Estado de desprotección del cuadro de diálogo Propiedades. El administrador VSS también puede deshacer la desprotección de archivos desprotegidos por otros usuarios.


El archivo <archivo> está bloqueado

Este mensaje tiene la siguiente causa y solución:

  • El archivo al que está intentando tener acceso está en uso.

    Espere y vuelva intentar la operación más tarde.


El archivo <archivo> no está compartido con ningún otro proyecto

El comando Bifurcar se utilizar para romper un vínculo compartido. Este mensaje tiene la siguiente causa y solución:

  • El archivo que ha elegido para aplicar el comando Bifurcar no tiene vínculo con otros proyectos.

    Seleccione otro comando o seleccione un archivo compartido para aplicar en él el comando Bifurcar.


Puede que el archivo <archivo> esté dañado

Este mensaje tiene la siguiente causa y solución:

  • El archivo especificado puede estar dañado.

    Ejecute la utilidad Analyze para asegurarse de que no hay errores en su base de datos VSS. Si el problema no se arregla ejecutando Analyze con el argumento–F, póngase en contacto con el Soporte de productos.

Nota Cuando use la utilidad Analyze, hágalo primero sin argumentos para localizar cualquier error en la base de datos y luego con el argumento –F para que se ejecute en modo de reparación automática.


No se ha encontrado el archivo <archivo>

VSS no ha podido encontrar el archivo que estaba buscando. Este mensaje tiene las siguientes causas y solución:

  • Es posible que haya tecleado mal un nombre de archivo en el explorador de VSS o en una variable del archivo de inicialización.

  • Puede que el archivo no exista.

    Asegúrese de que ha escrito correctamente el nombre del archivo.


El archivo <archivo> se ha desprotegido en <carpeta>, no en <carpeta>

Esta advertencia tiene la siguiente causa y solución:

  • El archivo que está protegiendo estaba desprotegido en otra carpeta diferente.

    Al arrastrar un archivo, debe protegerlo desde la misma carpeta donde estaba desprotegido. El archivo que ha arrastrado no será protegido. Si quiere proteger el archivo desde esta carpeta, utilice el comando Proteger de VSS desde el menú SourceSafe.


El archivo <archivo> se ha desprotegido en la carpeta <ruta de acceso>

Cuando desprotege un archivo, VSS hace un seguimiento de la carpeta de trabajo en la que lo desprotegió. En general, las modificaciones se hacen en esa carpeta y luego se protege el archivo o se deshace la desprotección desde la misma carpeta cuando se ha terminado. Esta advertencia tiene la siguiente causa y solución:

  • Está intentando proteger o deshacer la desprotección del archivo en una carpeta que no es la misma en la que lo desprotegió.

    La carpeta de trabajo de un proyecto aparece justo encima del panel de archivos en el Explorador de VSS, y puede modificarse con el comando Establecer carpeta de trabajo del menú Archivo (Ctrl-D). La carpeta de desprotección de un archivo se muestra en la lista de archivos. (La carpeta de desprotección puede ser diferente de la carpeta de trabajo asignada al proyecto, por ejemplo si otro usuario tiene desprotegido el archivo.) Aunque puede proteger un archivo desde otra carpeta que la carpeta en la que lo desprotegió, asegúrese de que eso es lo que desea.


<archivo> ya existe en el proyecto <nombre de proyecto> y no es el mismo que el archivo almacenado. No se puede restaurar

Este mensaje tiene la siguiente causa y solución:

  • Está intentando recuperar un archivo en una base de datos diferente a la base de datos desde la cual lo archivó y ya existe un archivo con el mismo nombre.

    Mantenga el archivo existente, elimínelo o cambie su nombre y ejecute después SSRESTOR.


Se ha combinado <archivo> sin conflictos

El archivo actual se ha combinado. No se han encontrado conflictos entre las versiones combinadas.


Se ha combinado <archivo> sin conflictos. ¿Desea protegerlo ahora?

Esta advertencia tiene la siguiente causa y solución:

  • Es el mensaje estándar de advertencia de Combinación mostrado por VSS.

    Haga clic en Sí para registrar los archivos combinados en VSS.

    Haga clic en No para no registrar el archivo combinado en VSS.


<archivo> ha cambiado. ¿Desea deshacer la desprotección y perder los cambios?

Vea también

Esta advertencia tiene la siguiente causa y solución:

  • Está a punto de deshacer la desprotección de un archivo. Si lo hace, descartará todos los cambios realizados desde que desprotegió el archivo.

    Si quiere guardar los cambios en VSS en lugar de perderlos, utilice el comando Proteger en su lugar.

Nota Su no quiere recibir este mensaje cada vez que desproteja un archivo o proyecto, puede deshabilitarlo en la ficha Advertencias del cuadro de diálogo Opciones de SourceSafe del menú Herramientas.


<archivo> es un archivo de configuración de SourceSafe y no se puede agregar

El archivo especificado es un archivo de configuración de VSS y no puede ser agregado a la base de datos VSS.


<archivo> es un archivo de almacenamiento local de SourceSafe y no se puede agregar

Este mensaje tiene la siguiente causa y solución:

  • Ha intentado agregar en VSS un archivo existente de VSS.

    Detener la operación.


El archivo <archivo> ya está desprotegido por <usuario>. ¿Desea continuar?

Esta advertencia tiene la siguiente causa y solución:

  • Ha intentado realizar una operación en un archivo VSS que está desprotegido pro otro usuario.

    VSS le ofrece la posibilidad de continuar, lo que implica que cualquier diferencia entre los cambios que realice y los cambios que realicen otros usuarios necesitarán combinarse en el futuro. Haga clic en Sí para continuar con la operación y crear una situación de desprotección múltiple; responda No para cancelar desprotección.


<archivo> ya está en este proyecto; no necesita compartirlo

Esta advertencia tiene la siguiente causa y solución:

  • No puede tener dos elementos en un proyecto que tengan el mismo nombre. Está intentando compartir un archivo en un proyecto que ya contiene un archivo o subproyecto con el mismo nombre.

    Si quiere que el archivo esté en el proyecto, tendrá que::

    • Cambiar el nombre del proyecto/archivo existente antes de compartir el archivo en el proyecto, o

    • Eliminar o destruir el elemento existente en el proyecto


<archivo> es un archivo de vínculo de Explorer

Este mensaje tiene la siguiente causa y solución:

  • Ha arrastrado un archivo .lnk en VSS.

    Cuando se arrastra un archivo .lnk a VSS, es necesario indicar al programa si se quiere agregar el archivo .lnk a la base de datos o si se quiere agregar el archivo al que apunta el archivo .lnk. Si desea agregar el archivo al que hacer referencia el archivo .lnk, haga clic en Sí. De lo contrario, haga clic en No.


<archivo> no es un nombre válido de <archivo>

Vea también

El nombre del archivo no es válido. Por favor, consulte las convenxiones de nomenclatura de VSS para conocer la sintaxis correcta.


<archivo> no es un archivo de registro válido o está dañado

Este mensaje tiene la siguiente causa y solución:

  • VSS no puede encontrar o leer su archivo de registro.

    Ejecute Analyze.exe con la opción -F. Si es necesario, póngase en contacto con el soporte técnico para obtener más ayuda.


<Archivo> está desprotegido por <usuario>; si lo elimina cancelará la desprotección. ¿Desea continuar?

Esta advertencia tiene la siguiente causa y solución:

  • Está intentando eliminar un archivo desprotegido.

    Este mensaje de advertencia le da la oportunidad de no eliminar un archivo equivocado. Si el nombre del archivo es correcto, haga clic en Sí para continuar. Haga clic en No para cancelar la operación de eliminar.


<archivo> no es un archivo de texto

Aunque la mayoría de los comandos VSS funcionan con archivos de texto o binarios, este comando no lo hace. Este mensaje tiene la siguiente causa y solución:

  • Ha intentado ejecutar un comando que sólo funciona con archivos de texto, como Ver archivo del menú Editar o Buscar en archivos en el menú Herramientas.

    Los archivos binarios son configurados automáticamente por VSS utilizando la ficha Tipos de archivos del cuadro de diálogo Opciones de SourceSafe del menú Herramientas.


<archivo o carpeta> no es un archivo o ruta válida y se ignorará. ¿Desea agregar otros archivos?

Este mensaje tiene la siguiente causa y solución:

  • El comando de línea de comandos ss add puede aceptar como parámetros múltiples archivos o carpetas. En este caso, uno de los parámetros no existe.

    Escriba Y si quiere seguir agregando los demás archivos que aparecen en el comando ss add.

    Escriba N si desea abortar el proceso de agregación y dejar de agregar los demás archivos del comando ss add.


<archivo> se desprotegió desde <carpeta local>, no desde la carpeta actual. ¿Desea continuar de todas maneras?

Esta advertencia tiene la siguiente causa y solución:

  • Cuando se desproteje un archivo, VSS registra el lugar en el que se ha copiado. Cuando se protege un archivo desde la línea de comandos, VSS, por defecto, busca el archivo en el directorio actual. Si ya existe una copia del archivo en la carpeta actual, pero ese no es el lugar en el que se desprotegíó el archivo, aparecerá el siguiente mensaje.

    Escriba Y si quiere proteger el archivo que existe en la carpeta actual.

    Escriba N si quiere detener la operación y no quiere proteger el archivo de la carpeta local. Si quiere proteger un archivo que no existe en la carpeta actual, utilice el argumento–GL del comando de desprotección para indicar a VSS la carpeta desde la que debe desproteger el archivo.


Se ha cambiado automáticamente el nombre de <nombre de archivo> a <nombre de archivo> en el proyecto <proyecto> para que coincida con el archivo actual de la base de datos

Este mensaje sólo es informativo. Ha sido generando por un comando de archivo.


<nombre de archivo>está desprotegido, ¿desea reemplazarlo?

Esta advertencia tiene la siguiente causa y solución:

  • Eligió obtener un archivo que ya estaba desprotegido.

    Cuando obtiene un archivo, se escribe una nueva copia del mismo a su carpeta de trabajo. Si ya tiene el archivo desprotegido, puede que se sobrescriban algunos cambios. En esta situación, VSS le da varias opciones:

    • Haga clic en Reemplazar para sobrescribir el archivo de la carpeta de trabajo.

    • Haga clic en Combinar para combinar los cambios del archivo de la carpeta de trabajo en el archivo de base de datos VSS.

    • Haga clic en Mantener para dejar el archivo de la carpeta de trabajo (se pasará por alto el comando Obtener para dicho archivo).

    • Haga clic en Cancelar para cancelar la operación Obtener.

    • Active la opción Aplicar a todos los elementos para que las decisiones que ha tomado en este cuadro de diálogo se apliquen a todos los demás archivos que tiene desprotegidos.


<nombre de archivo> está fijado a una versión específica

Esta advertencia tiene la siguiente causa:

  • Está intentando realizar una operación en un archivo fijado. Libere este archivo para realizar cambios en él.


<nombre de archivo> sólo almacena la última versión y ya está desprotegido

Esta advertencia tiene la siguiente causa y solución:

  • VSS sólo permite que un usuario desproteja un archivo que está configurado para almacenar tan sólo la última versión. Esto se debe a que VSS no puede combinar los cambios de un segundo usuario, ya que el archivo anterior ha sido sustituido por la protección del primer usario.

    Identifique al usuario que ha desprotegido el archivo y pídale que ejecute el comando Proteger o el comando Deshacer desprotección. Si no puede encontrar al usuario, el usuario Admin puede proteger los archivos desprotegidos por otros usuarios.

    Para identificar al usuario que ha desprotegido un archivo, vea la ficha Estado de desprotección del cuadro de diálogo propiedades del archivo o utilice el comando ss status.


<nombre de archivo> se desprotegió desde el proyecto <ruta de proyecto>, no desde <ruta de proyecto>. ¿Desea deshacer la desprotección?"

Cuando un archivo se comparte entre varios proyectos, un archivo de un proyecto está vinculado a todos los demás proyectos que lo comparten. Por tanto, cuando desprotege el archivo de un proyecto, también se desprotege de todos los proyectos que lo comparten.

Esta advertencia tiene la siguiente causa y solución:

  • Ha desprotegido un archivo de un proyecto y está intentando protegerlo o deshacer la desprotección desde otro proyecto que comparte el mismo archivo.

    Es una acción válida. VSS sólo le avisa por si no pretendía realizar esta acción.

    Para seguir adelante, haga clic en Sí.

    Para cancelar la operación, haga clic en No.

Nota Puede proteger un archivo o deshacer la desprotección en cualquier proyecto que comparta un archivo.


<nombre de archivo> se desprotegió desde el proyecto <ruta de proyecto>, no desde <ruta de proyecto>. ¿Desea protegerlo en cualquier caso?

Cuando un archivo se comparte entre varios proyectos, un archivo de un proyecto está vinculado a todos los demás proyectos que lo comparten. Por tanto, cuando desprotege el archivo de un proyecto, también se desprotege de todos los proyectos que lo comparten.

Esta advertencia tiene la siguiente causa y solución:

  • Ha desprotegido un archivo desde un proyecto y está intentando protegerlo desde otro proyecto que comparte el mismo archivo.

    Es una acción válida. VSS sólo le avisa por si no pretendía realizar esta acción.

    Para seguir adelante, haga clic en Sí.

    Para cancelar la operación, haga clic en No.

Nota Puede proteger un archivo o deshacer la desprotección en cualquier proyecto que comparta un archivo.


El archivo no ha sido desprotegido por usted

Vea también

Algunas operaciones de VSS sólo se pueden realizar sobre archivos que estén desprotegidos. Este error tiene las causas y soluciones siguientes:

  • Intentó proteger o deshacer la desprotección de un archivo que no está desprotegido.

    Desproteja el archivo antes de protegerlo. Si ha realizado cambios en un archivo, vea las opciones Avanzadas del cuadro de diálogo Desproteger y luego, en Reemplazar modificable, seleccione Saltar para desproteger el archivo sin sustituir los cambios en su carpeta de trabajo.

  • Intentó realizar una operación que sólo se puede efectuar sobre un archivo desprotegido.

    Desproteja el archivo.


No se ha encontrado el archivo o el proyecto

Vea también

VSS está buscando un archivo o proyecto que no existe. Este mensaje tiene las siguientes causas y solución:

  • Se equivocó al escribir el nombre del archivo o el proyecto, o el archivo o el proyecto especificado no existe.

  • La base de datos VSS está dañada.

    Pruebe a escribir de nuevo el nombre o seleccione el nombre en la lista del explorador de VSS. Si sospecha que la base de datos está dañada, ejecute la utilidad Analyze.exe.


El tipo de archivo <grupo> ya está en la lista

Esta advertencia tiene la siguiente causa y solución:

  • El archivo de grupo que está agregando ya existe en la lista de archivos de grupo.

    Especifique un nombre diferente para el archivo de grupo que está agregando o elimine el archivo de grupo existente en la lista con el mismo nombre.


No se encuentra esta versión del archivo en el archivo de almacenamiento local

No hay elementos eliminados para este proyecto.


Los archivos no están bifurcados

Este mensaje tiene la siguiente causa y solución:

  • Ha intentado Combinar bifurcaciones en dos archivos que no tienen bifurcaciones.

    No se puede Combinar bifurcaciones en estos dos archivos.


Los archivos no tienen ningún ancestro común

No hay elementos eliminados para este proyecto.


La cadena de filtro sobrepasa la longitud máxima de <número>

Este mensaje tiene la siguiente causa y solución:

  • La longitud combinada de los valores de los filtros de la ficha Tipos de archivo del cuadro de diálogo Opciones de SourceSafe del menú Herramientas es demasiado grande.

    VSS utiliza el tipo de archivo incluido en el campo Grupo de archivo para crear una cadena de filtro para los cuadros de diálogo Compartir y Agregar archivos. Este error se produce cuando la longitud combinada de los grupos es demasiado grande. La longitud total del búfer es de 511 caracteres. Para corregir este error, reduzca el tamaño de las listas de tipos de archivos.


La carpeta <carpeta> ya existe

Esta advertencia tiene la siguiente causa y solución:

  • Está intentando crear una carpeta local que ya existe en la unidad de disco. Puede producirse al crear una carpeta desde el cuadro de diálogo Establecer carpeta de trabajo.

    Utilice un nombre diferente para la carpeta al crear la carpeta local. O establezca la carpeta existente como carpeta de trabajo.


No se encontró la carpeta <ruta de acceso>. ¿Desea crearla?

La carpeta de trabajo especificada no existe. Este mensaje tiene la siguiente causa y solución:

  • Puede que se haya eliminado la carpeta o que haya escrito su especificación incorrectamente. Puede que se haya interrumpido la conexión con una ubicación de red.

    Restablezca la carpeta de trabajo de este proyecto (con el comando Establecer carpeta de trabajo del menú Archivo) o haga clic en Sí para crear la carpeta. Así indicará a VSS que esta es la carpeta de trabajo local. Cuando vuelva a abrir el proyecto, VSS irá automáticamente a esta carpeta de trabajo.

    Si la carpeta de trabajo parece estar bien, compruebe si este proyecto está centralizado en otra ubicación y que la conexión con dicha ubicación sigue siendo correcta.


No se encontró la carpeta

Este mensaje tiene la siguiente causa y solución:

  • Ha especificado una carpeta del sistema operativo que no se ha podido encontrar.

    Asegúrese de que la carpeta que ha indicado es correcta. Compruebe las mayúsculas y minúsculas en aquellos sistemas operativos en los que se establezcan diferencias entre ellas.


Función no implementada

No hay elementos eliminados para este proyecto.


¿Desea obtener todo el proyecto en esta etiqueta?

Este mensaje tiene la siguiente causa y solución:

  • Ha elegido realizar una obtención desde el cuadro de diálogo historial de un archivo etiquetado. Todo el proyecto tiene la misma etiqueta.

    Haga clic en Sí si quiere obtener todo el proyecto en esa etiqueta. Haga clic en no para obtener tan sólo el archivo en esa etiqueta.


Obtener en el diálogo del archivo desprotegido

Este mensaje tiene la siguiente causa y solución:

  • Eligió obtener un archivo que ya estaba desprotegido.

    Cuando obtiene un archivo, se escribe una nueva copia del mismo a su carpeta de trabajo. Si ya tiene el archivo desprotegido, puede que se sobrescriban algunos cambios. En esta situación, VSS le da varias opciones:

    • Haga clic en Reemplazar para sobrescribir el archivo de la carpeta de trabajo.

    • Haga clic en Combinar para combinar los cambios del archivo de la carpeta de trabajo en el archivo de base de datos VSS.

    • Haga clic en Mantener para dejar el archivo de la carpeta de trabajo (se pasará por alto el comando Obtener para dicho archivo).

    • Haga clic en Cancelar para cancelar la operación Obtener.

    • Haga clic en Aplicar a todos los elementos para que las decisiones que ha tomado en este cuadro de diálogo se apliquen a todos los demás archivos que tiene desprotegidos.


¿Desea obtener todo el proyecto en esta etiqueta?

Este mensaje tiene la siguiente causa y solución:

  • Ha obtenido el archivo de una etiqueta desde el cuadro de diálogo Historial del proyecto.

    Haga clic en Sí para obtener el proyecto completo en esa etiqueta. Haga clic en no para obtener tan sólo el archivo en esa etiqueta.


¿Desea obtener todo el proyecto que contiene esta versión de archivo?

Vea también

Este mensaje tiene la siguiente causa y solución:

  • Seleccionó un archivo en la lista del cuadro de diálogo Historial del archivo e hizo clic en Obtener.

    Haga clic en Sí, y VSS obtendrá todo el proyecto tal y como existía inmediatamente antes de que se activase la protección seleccionada.

    Haga clic en No, y VSS obtendrá tan sólo la el archivo de la versión que ha seleccionado, sin obtener ningún otro archivo del proyecto.


¿Se ha combinado correctamente <nombre de archivo>?

Esta advertencia tiene la siguiente causa y solución:

  • Ha intentado proteger un archivo de la versión almacenada actualmente en VSS.

    Este mensaje de advertencia aparece a menudo cuando varios usuarios han desprotegido el mismo archivo para más de un usuario o equipo. Se muestra para que sepa que hay conflictos de combinación que se deben resolver. En algunos casos, esta advertencia se puede mostrar incluso si no hay conflictos de combinación y puede resultar confuso. En este caso, basta con hacer clic en Sí y continuar su trabajo.

    Si había conflictos y no abrió el archivo de origen para resolverlos, haga clic en No y hágalo ahora. Cuando termine, vuelva a ejecutar la operación de Protección.


¿Se han resuelto correctamente los conflictos en <archivo>?

Este mensaje tiene la siguiente causa y solución:

  • Ha intentado proteger un archivo de la versión almacenada actualmente en VSS.

    Este mensaje de advertencia aparece a menudo cuando varios usuarios han desprotegido el mismo archivo para más de un usuario o equipo. Se muestra para que sepa que hay conflictos de combinación que se deben resolver. En algunos casos, esta advertencia puede aparecer incluso si no se producen conflictos en la combinación. Si esto sucede, haga clic en Sí y siga trabajando.

    Si hubiera conflictos y no abrió el archivo original para solucionarlos, haga clic en No. Cuando haya terminado, vuelva a intentar la operación Proteger.


Nombre de archivo o de proyecto no válido: <archivo>

Vea también

Este mensaje tiene la siguiente causa y solución:

  • Especificó un nombre de archivo o de proyecto no válido.

    Asegúrese de que el nombre se escribió correctamente. Si no está seguro de qué caracteres puede utilizar en un nombre VSS, compruebe los temas relacionados con la Sintaxis y convenciones de nomenclatura.


El número de la versión no es válido

Este mensaje tiene la siguiente causa y solución:

  • Se ha encontrado un número de versión ilegal en el archivo VSS.

    Ejecute la utilidad Analyze para asegurarse de que no hay errores en su base de datos VSS. Si el problema no se arregla ejecutando Analyze con el argumento–F, póngase en contacto con el Soporte de productos.

Nota Cuando ejecute la utilidad Analyze, hágalo primero sin argumentos para encontrar cualquier error en la base de datos. Luego, ejecute Analyze con el argumento –F para activar el modo de reparación automática.


La sintaxis de la versión no es válida: <número>

Este mensaje tiene la siguiente causa y solución:

  • El número de versión especificado utiliza una sintaxis no válida.

    Asegúrese de que escribió la información correctamente.


La versión de la base de datos no es compatible

La base de datos especificada no está en un formato que pueda ser leído por esta versión de VSS. Por ejemplo, puede que esté intentando abrir una base de datos de la versión 2.0 de VSS desde la versión 6.0 del programa. Actualice la base de datos o el software.


La variable de inicialización <variable> debe estar entre <número> y <número>

Un número de inicialización está fuera del intervalo permitido. Este mensaje tiene la siguiente causa y solución:

  • Se ha establecido una variable de inicialización como un número no válido.

    Busque en la Ayuda información acerca de la configuración válida.

Nota Puede utilizar cualquier editor de textos para modificar o eliminar el número erróneo.


La variable de inicialización <variable> debe establecerse como "Sí" o "No"

Este mensaje tiene la siguiente causa y solución:

  • La variable de inicialización debería estar establecida a Yes o No, pero no es así.

    Cambie la variable para que quede establecida a Yes (o True) o No (False).

Nota Puede utilizar cualquier editor de textos para modificar o eliminar el valor no válido.


La variable de inicialización <variable> contiene una ruta no válida

Una variable de inicialización que debería contener una ruta de carpeta válida contiene una ruta no válida. Este mensaje tiene la siguiente causa y solución:

  • Puede que la sintaxis de la ruta sea incorrecta o que la ruta no exista.

    Compruebe que la ruta existe o que la sintaxis es correcta y cámbiela si es necesario.

Nota Puede utilizar cualquier editor de textos para cambiar o eliminar la ruta errónea.


La variable de inicialización <variable> contiene un número no válido

Se asignó de forma incorrecta la variable de inicialización especificada. Este mensaje tiene la siguiente causa y solución:

  • La variable de inicialización debería estar establecida como un número arábigo, pero no es así. Por ejemplo, puede estar establecida a "dos" cuando debería haberse establecido a "2".

    Busque en la Ayuda información acerca de la sintaxis adecuada de los archivos de inicialización.

Nota Puede utilizar cualquier editor de textos para modificar o eliminar el número erróneo.


La variable de inicialización <variable> contiene un valor no válido

Este mensaje tiene la siguiente causa y solución:

  • Se ha asignado a la variable de inicialización un valor no válido.

    Busque en la Ayuda información acerca de la sintaxis adecuada.

Nota Puede utilizar cualquier editor de textos para modificar o eliminar el valor no válido.


El código de acceso no es válido (parámetro incorrecto)

No hay elementos eliminados para este proyecto.


Hay caracteres no válidos en la variable Dir_Umask.ini. Se ignorarán

No hay elementos eliminados para este proyecto.


La cadena de fecha no es válida

VSS no puede utilizar la sintaxis que ha usado para la fecha. Este mensaje tiene la siguiente causa y solución:

  • La fecha que ha introducido no es válida.

    La sintaxis correcta para la fecha es Mes/Día/Año, separando cada número con una barra inclinada: por ejemplo, 2/29/64 ó 11/5/1992.


La ruta de DOS no es válida: <ruta de archivo>

Este mensaje tiene la siguiente causa y solución:

  • El cliente de VSS no encuentra la base de datos especificada en la línea #include del archivo local SRCSAFE.INI.

    Para resolver el problema, asegúrese de que tiene acceso a la carpeta especificada en la línea #include del SRCSAFE.INI local.


La unidad no es válida: <unidad>

Este mensaje tiene la siguiente causa y solución:

  • La unidad a la que está intentando tener acceso no es válida. Puede que se haya equivocado al especificar la unidad, ya sea en el Explorador de VSS o en un archivo de inicialización.

    Compruebe si ha escrito correctamente la especificación de unidad.


El nombre de archivo no es válido: <archivo>

Este mensaje tiene la siguiente causa y solución:

  • Escribió el nombre de un archivo con una sintaxis no válida.

    Compruebe lo que ha escrito o seleccione otro nombre diferente con caracteres válidos. También puede obtener este error si tiene múltiples archivos seleccionados e intenta usar un comando para un único archivo, como Ver.


El controlador no es válido

  • VSS está intentando abrir un archivo que no existe, o un archivo cuya ruta de acceso no es correcta. VSS intenta resolver las rutas de acceso relativas con la ubicación del archivo SRCSAFE.INI local de la carpeta de instalación del servidor.

Este mensaje tiene las siguientes posibles causas y solución:

  • La variable Journal_File del archivo SRCSAFE.INI está configurada con una ubicación que no está disponible, como por ejemplo una conexión de red de la cual se ha desconectado.

  • Está intentando mostrar diferencias sobre un archivo cuya carpeta de trabajo está en una unidad de disco flexible, y no hay disco en la unidad.

    En ese caso VSS de ser capaz de localizar el archivo si necesita completar la operación.


La contraseña no es válida

Este mensaje tiene la siguiente causa y solución:

  • Su combinación nombre de usuario/contraseña no es válida.

    Vuelva a escribir la contraseña. Vuelva a especificar la contraseña. Como no aparece en la pantalla, es muy fácil escribirla de forma incorrecta. Observe que la contraseña de VSS distingue entre mayúsculas y minúsculas. Si cree que ha escrito la contraseña correctamente y VSS no la reconoce, pida a su administrador de VSS que cambie su nombre de usuario y su contraseña. Si ha olvidado la contraseña, el administrador de VSS puede utilizar el programa Administrador para asignarle una nueva.


La sintaxis no es válida en la línea <línea> del archivo <archivo>

Este mensaje tiene la siguiente causa y solución:

  • La sintaxis de una o más líneas del archivo de inicialización no es válida.

    Busque en la Ayuda información acerca de la sintaxis adecuada de la variable de inicialización.

Nota Puede utilizar cualquier editor de textos para modificar o eliminar la línea errónea.


La cadena de hora o fecha no es válida

VSS no puede utilizar la sintaxis que ha usado para la fecha o la hora. Este error tiene las causas y soluciones siguientes:

  • La fecha que ha introducido no es válida.

    La sintaxis correcta para la fecha es Mes/Día/Año, separando cada número con una barra inclinada: por ejemplo, 2/29/64 ó 11/5/1992.

  • La hora que ha introducido no es válida.

    La sintaxis de hora adecuada es Hora:Minuto, seguida de un indicador A.M. o P.M. de una letra: por ejemplo, 9:30A o 5:00p. (El indicador no distingue entre mayúsculas y minúsculas.) O puede usar el formato de 24-horas como 13:45.


El valor <valor> en la ficha Tipos de archivo no es válido

Este mensaje tiene la siguiente causa y solución:

  • Intentó crear un tipo de archivo utilizando caracteres que no son válidos.

    Los nombres de tipos de archivo no pueden contener los siguientes caracteres: [ ] ( ) , ;. El valor de un tipo de archivos es un modelo de búsqueda y no puede contener caracteres que no sean válidos. Además, no puede dejar en blanco el cuadro de texto Tipos de archivos incluidos en grupo de archivos. Consecuentemente, se debe escribir algún tipo de archivos.


La ruta <ruta de acceso> de SourceSafe no es válida

Vea también

Este mensaje tiene la siguiente causa y solución:

  • Especificó un nombre de archivo o de proyecto de VSS no válido.

    Asegúrese de que escribió la ruta correctamente o utilice el Explorador de VSS para elegir el elemento en la lista de proyectos o en la lista de archivos.

    Si eligió el elemento en el Explorador de VSS, es posible que otro usuario haya eliminado o cambiado el nombre del elemento desde que utilizó por última vez VSS. Contraiga el proyecto raíz y vuélvalo a expandir para actualizar el panel de proyectos.


La sintaxis de SourceSafe no es válida: <sintaxis>

Vea también

La sintaxis utilizada no es válida en VSS. Este mensaje tiene la siguiente causa y solución:

  • Especificó una ruta de archivo o de proyecto de VSS con una sintaxis no válida.

    En la sintaxis de VSS, todos las rutas empiezan con un signo de dólar seguido de una serie de nombres de proyecto, separados por barras y, opcionalmente, seguidos por un nombre de archivo. Por ejemplo:

    • $/ es el proyecto raíz.

    • $/Code es un subproyecto de $/.

    • $/Code/Win/Test.C es un archivo del proyecto $/Code/Win.

    Muchas partes de la sintaxis son opcionales. Puede omitir el signo de dólar en la mayoría de las circunstancias. También puede abreviar la ruta basándola en el proyecto actual; por ejemplo, si está en $/Code, puede escribir WIN como abreviatura de $/Code/Win, Test.C para $/Code/Test.C y ".." para el raíz.

  • Los nombres de archivo pueden ser nombres de archivo válidos en cualquier sistema operativo, excepto para la siguiente restricción que es específica de VSS. Los nombres de archivo en VSS no deben comenzar con un signo dólar ($), un punto y coma (;), o un punto (.), independientemente de si el sistema operativo permite uno o más de estos caracteres.

  • Los nombres de proyecto pueden incluir espacios y pueden tener hasta 256 caracteres de largo. Los nombres de proyecto no distinguen mayúsculas de minúsculas (por ejemplo, para VSS, Code y CODE son el mismo proyecto).


Se ha eliminado <elemento>

Vea también

Este mensaje tiene la siguiente causa y solución:

  • Está intentando actuar sobre un archivo o un proyecto que no se ha eliminado del proyecto actual.

    Antes de poder hacer algo con el archivo debe recuperarlo mediante el comando Recuperar.

    Si desea eliminar el archivo de forma permanente de la base de datos de VSS, en el menú Archivo haga clic en Propiedades y, en la ficha Elementos eliminados, haga clic en Purgar.


<elemento> no es un archivo o proyecto eliminado

Vea también

Los comandos Recuperar y Purgar sólo funcionan con elementos eliminados. Este mensaje tiene la siguiente causa y solución:

  • Intentó utilizar los comandos Recuperar o Purgar sobre un elemento que no se ha eliminado.

    Si está intentando recuperar un archivo o proyecto, el archivo o proyecto ya existe en VSS. Para ver el archivo, utilice el comando Ver archivo.


<elemento> no es un archivo o proyecto ya existente

Este mensaje tiene la siguiente causa y solución:

  • El elemento especificación no tiene un nombre válido de archivo o proyecto.

    Ejecute la utilidad Analyze para asegurarse de que no hay errores en su base de datos VSS. Si el problema no se arregla ejecutando Analyze con el argumento–F, póngase en contacto con el Soporte de productos.

Nota Cuando use la utilidad Analyze, hágalo primero sin argumentos para localizar cualquier error en la base de datos y luego con el argumento –F para que se ejecute en modo de reparación automática.


<elemento> especifica un número de versión, lo cual no es válido para este comando

Este comando sólo funciona sobre la versión más reciente de un archivo. Este mensaje tiene la siguiente causa y solución:

  • Intentó ejecutar el comando sobre una versión más antigua del archivo.

    Seleccione otro comando o aplique el comando elegido a la versión más reciente del archivo.


El comentario de etiqueta no es válido cuando no se ha especificado ninguna etiqueta

Este mensaje tiene la siguiente causa y solución:

  • Especificó un comentario para una etiqueta pero no ha proporcionado ninguna.

    Si desea etiquetar un archivo o un proyecto y quiere incluir un comentario, debe especificar la etiqueta y el comentario.


<archivo local> es modificable. ¿Desea reemplazarlo?

Esta advertencia tiene la siguiente causa y solución:

  • Hay un archivo modificable en su carpeta de trabajo con el mismo nombre que el que está intentado obtener o desproteger.

    Cuando obtiene o desprotege un archivo, se escribe una nueva copia del mismo a su carpeta de trabajo. Si ya tiene una copia modificable del archivo, puede que se sobrescriban algunos cambios. En esta situación, VSS le da varias opciones:

    • Haga clic en Sí para sobrescribir el archivo de la carpeta de trabajo.

    • Haga clic en Sí a todo para que las opciones que elija en este cuadro de diálogo se apliquen a todos los archivos desprotegidos de los cuales tenga actualmente copias modificables.

    • Haga clic en No para omitir la operación para este archivo.

    • Haga clic en No a todo para saltar la operación para todos los archivos de los cuales tenga copias modificables.

    • Haga clic en Cancelar para cancelar la operación.


Se ha borrado el directorio local de archivos temporales

Se ha borrado el directorio local de archivos temporales.


No se encuentra el directorio local de archivos temporales en la ubicación <ruta de acceso>

Este mensaje tiene la siguiente causa y solución:

  • El directorio local de archivos temporales se ha perdido o se ha eliminado accidentalmente.

    Cree el directorio local de archivos temporales tal y como se especifica, o pida al administrador de VSS que resuelva el problema.


La variable Lock_Mode del archivo INI tiene un valor que no es válido. Se utilizará Native

Esta advertencia tiene la siguiente causa y solución:

  • VSS puede configurarse para utilizar su propia forma de bloqueo de archivos. Esto se hace cuando el administrador de VSS agrega un valor Lock_Mode = archivo INI al archivo SRCSAFE.INI. En el momento presente, el valor no es correcto.

    Modifique SRCSAFE.INI para corregir el valor de archivo INI de Lock_Mode por el valor Native o Lockfile.


Falló el inicio de sesión. La información de inicio de sesión suministrada no es válida y debe modificarse para validar la información de inicio de sesión para esta base de datos

Este mensaje tiene la siguiente causa y solución:

  • No ha podido iniciar una sesión en VSS.

    Intente iniciar de nuevo la sesión en la base de datos correcta, con la información de usuario apropiada. Asegúrese de que BLOQ MAYÚS está desactivado.


'Mover' no cambia el nombre de un proyecto

Mover un proyecto no cambia el nombre de un proyecto Si desea cambiar el nombre del proyecto, hágalo desde el Explorador de VSS Explorer o desde la línea de comandos.


No se ha encontrado la información del nombre para el desplazamiento <número> en el archivo de almacenamiento. El nombre se truncará a <nombre>

Este mensaje tiene la siguiente causa y solución:

  • Por razones de mantenimiento, VSS recorta los nombres de archivo largos a nombres de archivo más cortos. La información de un nombre de archivo largo se ha perdido para este archivo o proyecto particular, por tanto VSS ahora hará referencia a él mediante su nombre corto.

    Para remediarlo, cambie el nombre del archivo o proyecto a su nombre largo original.


No se ha encontrado la red

Este mensaje tiene la siguiente causa y solución:

  • No hay ninguna red instalada o VSS no puede encontrar una red válida.

    Puede que no haya instalada ninguna red o que una o más conexiones de red han fallado. Compruebe el hardware de la red y asegúrese de que todos los controladores de red necesarios estén en ejecución. Indique su administrador de VSS que haga comprobaciones adicionales.


No hay ninguna Ayuda adicional disponible sobre este elemento

  • No hay más información disponible acerca de este cuadro de diálogo. Si la causa del problema no está clara en el mensaje, llame al Servicio de soporte técnico para obtener asistencia.


No hay ninguna aplicación asociada con este tipo de archivo

Este mensaje tiene la siguiente causa y solución:

  • Intentó ver un archivo para el que no existe ninguna asociación de archivo.

    Este error se produce normalmente al intentar ver un archivo binario. Compruebe que ha seleccionado el archivo correcto y, entonces, asocie un programa de edición con la extensión del archivo mediante el Explorador de Windows o el Administrador de archivos.


No se ha establecido una ruta de distribución para <nombre de archivo o de proyecto>

Este mensaje tiene la siguiente causa y solución:

  • Intentó desplegar un proyecto sin especificar una ruta de despliegue para el proyecto en el programa Administrador.

    Pida al administrador de VSS que establezca una ruta de despliegue para el proyecto Web.


No se encontraron diferencias en el proyecto <proyecto>

Este mensaje tiene la siguiente causa y solución:

  • Ha comparado dos elementos sin diferencias.

    Es un mensaje informativo para indicarle que no se encontraron diferencias al comparar los elementos.


No hay archivos HTML disponibles en este proyecto para comprobar los hipervínculos

Este mensaje tiene la siguiente causa y solución:

  • Este mensaje informativo indica que no hay archivos desprotegidos para hipervínculos Web porque no se encontraron archivos HTML.

    Si esperaba archivos HTML en este proyecto, compruebe que se han agregado correctamente y que ha escrito correctamente el nombre del proyecto.


No hay elementos sobre los que actuar

Este mensaje tiene la siguiente causa y solución:

  • Está intentando realizar una acción sin seleccionar antes un elemento sobre el que actuar.

    Haga clic en un elemento para seleccionarlo e intente la acción de nuevo.


No hay ningún elemento para agregar

Vea también

Este mensaje tiene la siguiente causa y solución:

  • En el cuadro de diálogo Agregar archivo, ha intentado realizar una operación de agregar sin seleccionar antes el elemento a agregar.

    Para agregar un archivo, escriba primero el nombre de archivo o seleccione el archivo en la lista y después haga clic en el botón Agregar. Para agregar una carpeta, seleccione la carpeta en la lista de carpetas y después haga clic en el botón Agregar.


No se encontraron coincidencias

Este mensaje tiene la siguiente causa y solución:

  • VSS ha buscado en todos los archivos seleccionados y no ha encontrado la cadena que estaba buscando.

    Asegúrese de que ha escrito la cadena correctamente.


No hay más archivos

Esta advertencia tiene la siguiente causa y solución:

  • VSS no ha podido encontrar más archivos para procesar.

    Ejecute la utilidad Analyze para asegurarse de que no hay errores en su base de datos VSS. Si el problema no se arregla ejecutando Analyze con el argumento–F, póngase en contacto con el Soporte de productos.

Nota Cuando use la utilidad Analyze, hágalo primero sin argumentos para localizar cualquier error en la base de datos y luego con el argumento –F para que se ejecute en modo de reparación automática.


No se encontraron más entradas de carpeta

Esta advertencia tiene la siguiente causa y solución:

  • No se han encontrado más entradas de carpeta Podría indicar que la base de datos está corrupta.

    Ejecute la utilidad Analyze para asegurarse de que no hay errores en su base de datos VSS. Si el problema no se arregla ejecutando Analyze con el argumento–F, póngase en contacto con el Soporte de productos.

Nota Cuando use la utilidad Analyze, hágalo primero sin argumentos para localizar cualquier error en la base de datos y luego con el argumento –F para que se ejecute en modo de reparación automática.


No hay ningún otro usuario disponible desde el que copiar los derechos de autor

El administrador de VSS puede copiar los derechos de un usuario a otro. Este mensaje tiene la siguiente causa y solución:

  • Ha intentado copiar derechos en el usuario seleccionado. Sin embargo, no hay ningún otro usuario existente desde el cual se puedan copiar sus derechos. (Tenga en cuenta que no puede copiar los derechos del usuario Admin.)

    Sólo puede copiar derechos de usuario cuando tenga dos o más usuarios distintos de Admin. Si actualmente tiene sólo un usuario, necesita asignar los derechos a este usuario usando el comando Derechos por proyecto o el comando Asignaciones de derechos para usuario del menú Herramientas.


No se ha suministrado ningún modelo de búsqueda

Este mensaje tiene la siguiente causa y solución:

  • No ha especificado ninguna cadena o modelo que VSS pueda utilizar para buscar en los archivos.

    Escriba una cadena en el cuadro de diálogo Buscar en archivos y haga clic en Aceptar o bien haga clic en Cancelar para salir del cuadro de diálogo y volver al Explorador de VSS.


No se ha encontrado ninguna base de datos de SourceSafe (SRCSAFE.INI). Utilice la variable de entorno SSDIR o ejecute NETSETUP

Vea también

Este mensaje tiene la siguiente causa y solución:

  • No se ha encontrado el archivo SRCSAFE.INI. Esto puede ser el resultado de una instalación del cliente, en lugar de realizarla mediante NETSETUP.

    Haga la instalación mediante NETSETUP o establezca la variable de entorno SSDIR.

Configurando la variable de entorno SSDIR se indica a VSS dónde ha de buscar el archivo SRCSAFE.INI para la instalación de servidor de VSS a la que se desea conectar. Hágalo escribiendo lo siguiente en la línea de comandos de MS-DOS:

set ssdir=\\server\share\vss

Donde \\server\share\vss es la carpeta donde se encuentra el archivo srcsafe.ini.

Nota No ponga espacios entre el signo igual y la ubicación de la instalación de servidor de VSS. La cadena siguiente no funciona: set ssdir= \\server\share\vss.


Sólo se permite una conexión a la vez a una base de datos

Esta advertencia tiene la siguiente causa y solución:

  • Al abrir un proyecto de Visual C++ o Visual Basic con código fuente controlado, aparece esta advertencia.

    Para remediarlo, desconecte el proyecto Visual C++ o Visual Basic de VSS y vuelva a conectarlo abriendo el proyecto mediante la integración de proyecto de Visual C++ o Visual Basic.


No hay suficiente memoria

No tiene suficiente memoria en su PC para realizar esta operación. Este mensaje tiene la siguiente causa y solución:

  • Tiene abiertas demasiadas aplicaciones, documentos o archivos de origen.

    Cierre las aplicaciones, documentos o archivos de origen abiertos que no sean necesarios.

  • Tiene cargados demasiados controladores de dispositivos.

    Elimine los controladores de dispositivos innecesarios.


Memoria insuficiente: no se han podido guardar los cambios de derechos

No tiene suficiente memoria en su PC para realizar esta operación. Los cambios que ha realizado en los derechos del usuario no se han guardado.

Este error tiene las causas y soluciones siguientes:

  • Tiene abiertas demasiadas aplicaciones, documentos o archivos de origen.

    Cierre las aplicaciones, documentos o archivos de origen que no sean necesarios.

  • Tiene cargados demasiados controladores de dispositivos.

    Elimine los controladores de dispositivos innecesarios.


El archivo primario <proyecto> del archivo <archivo> (<archivo de base de datos de SourceSafe) no existe. Puede que el archivo esté dañado. Se pasará por alto este archivo primario

Este mensaje tiene la siguiente causa y solución:

  • Mientras la utilidad Analyze estaba procesando este archivo, un registro de uno de los proyectos estaba compartido, o estaba bifurcado desde los archivos, o no se ha encontrado.

    Este mensaje sólo es informativo. No es necesaria ninguna acción.


No se ha encontrado el primario

Este mensaje tiene la siguiente causa y solución:

  • Avisa que la base de datos está dañada.

    Pida a su administrador de VSS que ejecute Analyze.exe para encontrar y corregir el problema. Si esto no funciona, llame al Soporte técnico de Microsoft y pida ayuda para recuperar la base de datos.


<ruta de acceso> no es una especificación completa de VSS ni una ruta válida

Este mensaje aparece en el cuadro de diálogo Diferencias de proyecto cuando se ha especificado un nombre de archivo o un nombre de proyecto de VSS no válido.


La ruta de acceso <ruta de acceso> no existe

Este mensaje tiene la siguiente causa y solución:

  • Intentó abrir un archivo para el que no existe la ruta especificada.

    Compruebe la ruta y escríbala de nuevo. Asegúrese de que está en el equipo en el que se aplica la ruta.


Ruta <ruta de acceso> demasiado larga

Vea también

La ruta especificada es demasiado larga. Este error tiene la siguiente causa y solución:

  • Escribió una ruta de VSS demasiado larga.

    Los nombres de proyecto de VSS tienen un límite de 64 caracteres. Los nombres completos de ruta de proyecto no pueden tener más de 255 caracteres.


Permiso denegado

Este mensaje tiene la siguiente causa y solución:

  • Está intentando llevar a cabo una acción y no tiene los privilegios adecuados para ejecutarla.

    Hable con su administrador de VSS. Si usted es el Administrador de VSS, ejecute el Administrador de VSS para comprobar o cambiar su nombre de usuario, su contraseña y sus derechos de acceso.


Escriba un número entre 0 y 32767

Este mensaje tiene la siguiente causa y solución:

  • No especificó un número de líneas de contexto entre 0 y 32767.

    Las líneas de contexto son las líneas que hay inmediatamente delante y después de una diferencia. Mostrar estas líneas en la presentación de diferencias le ayuda a entender el contexto del cambio o la diferencia. Si ha activado la casilla de verificación Mostrar contexto en el cuadro de diálogo de opciones avanzadas del comando Mostrar diferencias, necesita especificar el número de líneas que preceden y que siguen que desea mostrar.


El proyecto <proyecto> no existe

Este mensaje tiene la siguiente causa y solución:

  • Está intentando mover un proyecto a un proyecto primario que no existe.

    Compruebe la ruta del proyecto primario y vuélvalo a intentar. Si no sabe con seguridad la sintaxis de proyecto de VSS, pruebe a seleccionar el proyecto primario de la lista de proyectos en el Explorador de VSS y anote la ruta del proyecto mostrada en la parte superior de la lista de archivos.

Nota Para mover un archivo o un subproyecto a un primario nuevo, debe haber creado el nuevo proyecto primario. Utilice el comando Crear proyecto para crear un proyecto nuevo.


El proyecto <proyecto> no existe. ¿Desea crearlo?

Esta advertencia tiene la siguiente causa y solución:

  • El proyecto especificado no existe. ¿Desea crearlo?

    Si el proyecto con el que está intentando trabajar existe, haga clic en No y a continuación seleccione el proyecto.


Se ha eliminado el proyecto <proyecto> y antes de abrirlo debe recuperarlo

Vea también

Este mensaje tiene la siguiente causa y solución:

  • Está intentado actuar sobre un proyecto que ha sido eliminado. Este error ocurrirá en la integración debido a que no puede conectar con el proyecto de VSS (el proyecto se ha eliminado desde VSS).

    Antes de poder hacer algo con el proyecto debe recuperarlo mediante el comando Recuperar de VSS.

    Utilice los siguientes pasos en el Explorador de VSS:

    • Seleccione el proyecto primario que contenía el proyecto eliminado.

    • En el menú Archivo, haga clic en Propiedades.

    • Haga clic en la ficha Elementos eliminados.

    • Seleccione el proyecto eliminado, después haga clic en Recuperar.


Se ha destruido el proyecto <proyecto> y no puede volver a generarse

Vea también

Es posible que VSS no pueda reproducir la versión de proyecto que ha solicitado. Este mensaje tiene la siguiente causa y solución:

  • Destruyó de forma permanente un subproyecto o cambió de lugar el subproyecto. Por ejemplo, debía haber un subproyecto que ha eliminado o purgado. Después intentó volver a una versión anterior del proyecto. VSS intenta reconstruir el proyecto exactamente como era anteriormente, pero no puede porque no puede recuperar el subproyecto.

    Haga clic en Sí, y VSS intentará recuperar el proyecto antiguo, aunque la recuperación no está garantizada.

    Haga clic en No y se detendrá el intento de restaurar la versión anterior del proyecto.

    Haga clic en Sí a todo y VSS no le avisará de la posible existencia de otros subproyectos irrecuperables; continuará llevando a cabo la reconstrucción de la mejor forma posible.


<proyecto o archivo> creará un nombre de archivo o de proyecto demasiado largo

Esta advertencia tiene la siguiente causa y solución:

  • VSS tiene una restricción de 259 caracteres para nombres de ruta de acceso del proyecto y de 255 caracteres para los archivos. El proyecto que está intentado crear o el archivo que está intentando agregar tiene una longitud mayor que supera la restricción.

    Use un nombre de archivo más corto o cambie el nombre de un proyecto primario a un nombre más corto.


No se puede deshacer el purgado; perderá la información definitivamente

Vea también

Esta advertencia tiene la siguiente causa y solución:

  • Cuando purga un archivo o un proyecto, la acción es irreversible.

    Haga clic en Sí para continuar con la operación de purgado. Haga clic en No para cancelar la operación.

    Si no desea perder permanentemente el archivo o el proyecto, utilice en su lugar el comando Eliminar.

Nota Su no quiere recibir este mensaje cada vez que elimine un archivo o proyecto, puede deshabilitarlo en la ficha Advertencias del cuadro de diálogo Opciones de SourceSafe del menú Herramientas.


¿Desea rehacer la combinación automática?

No hay elementos eliminados para este proyecto.


¿Desea quitar <base de datos> de la lista de la base de datos?

Esta advertencia tiene la siguiente causa y solución:

  • Está eliminando una entrada de base de datos VSS de la lista de Bases de datos abiertas de SourceSafe.

    Haga clic en Sí para eliminar la entrada especificada o en No para dejar la entrada de la base de datos en la lista.


Cambiar nombre no mueve un elemento a otro proyecto

Vea también

No se pueden implementar al mismo tiempo los comandos Cambiar nombre y Mover proyecto. Este mensaje tiene la siguiente causa y solución:

  • Los comandos Cambiar nombre y Mover de VSS son operaciones distintas, por lo que no puede realizar ambas a la vez.

    Realice primero una acción y luego la otra.


No se puede deshacer. Se perderán algunas versiones definitivamente

Vea también

Esta advertencia tiene la siguiente causa y solución:

  • Está a punto de deshacer los cambios de un archivo o proyecto a una versión anterior. El comando Deshacer es irreversible.

Para convertir la versión antigua a la más reciente sin perder todas las versiones intermedias

  1. Desproteja el archivo.

  2. Elimine la copia local.

  3. Obtenga la versión hasta la que desea deshacer.

  4. Proteja esa versión en VSS.

Nota Su no quiere recibir este mensaje cada vez que deshaga un archivo, puede deshabilitarlo en la ficha Advertencias del cuadro de diálogo Opciones de SourceSafe del menú Herramientas.


No se pueden deshacer los cambios antes de fijar una versión

Esta advertencia tiene la siguiente causa y solución:

  • Intentó deshacer los cambios de un archivo a una versión anterior a la que se fijó.

    No se pueden deshacerse los cambios del archivo a una versión anterior a la versión en la que se fijó. Para deshacer los cambios del archivo, libere el archivo y entonces deshaga los cambios.


No se puede ejecutar más de una instancia del Explorador de VSS bajo Windows de 16 bit

Este mensaje tiene la siguiente causa y solución:

  • Sólo puede ejecutar a la vez una versión de VSS en una plataforma de 16 bits.

    No intente ejecutar una segunda instancia de VSS. Se admite la ejecución de varias instancias de VSS con plataformas Microsoft Windows de 32 bits.


¿Desea guardar los cambios?

¿Desea guardar los cambios que ha realizado en el cuadro de diálogo Detalles de historial? Haga clic en Sí o en No.

Nota Puede realizar cambios en la etiqueta o comentario de un archivo/proyecto desde el cuadro de diálogo Detalles de historial, así como explorar las versiones siguientes o previas del proyecto/archivo.


¿Desea establecer <carpeta> como carpeta predeterminada para el proyecto <proyecto>?

Esta advertencia tiene la siguiente causa y solución:

  • ¿Desea establecer la carpeta especificada como carpeta de trabajo para este proyecto?

    Haga clic en Sí o en No.

    De manera predeterminada, todas las operaciones futuras de VSS para este proyecto utilizarán la carpeta de trabajo que especifique.


¿Desea establecer <carpeta> como su carpeta de trabajo personal para el proyecto <proyecto>?

Este mensaje tiene la siguiente causa y solución:

  • Necesita establecer una carpeta de trabajo para todos sus proyectos. Este mensaje le ofrece la opción de crear la carpeta de trabajo inmediatamente, en vez de tener que crearla más tarde mediante el comando Establecer carpeta de trabajo del menú Archivo.

    Haga clic en Sí para establecer la carpeta de trabajo del proyecto. Haga clic en No para saltarse este paso de momento.


Algunos conflictos no se han resuelto. ¿Desea guardar el archivo?

Esta advertencia tiene la siguiente causa y solución:

  • No se han resuelto todos los conflictos en el archivo combinado.

    Haga clic en Sí para guardar el archivo no resuelto o en No para descartar los cambios y salir.


Se ha desactivado el control de código fuente en esta aplicación. Reinicie la aplicación para usar el control de código fuente

Este mensaje tiene la siguiente causa y solución:

  • Se ha perdido la conexión al servidor, por lo que se ha desactivado el control de código fuente.

    Una vez que se restablezca la conexión a la base de datos de VSS, reinicie el programa con el que lo esté usando (por ejemplo, Visual C, Visual Basic o Visual J) para usar el control de código fuente.


La dirección <dirección> no es una dirección FTP válida

Este mensaje tiene la siguiente causa y solución:

  • Especificó una dirección ftp no válida.

    Escriba de nuevo la dirección; revise la ortografía y si la dirección está legitimada.


El usuario Admin no tiene actualmente contraseña de SourceSafe

Este mensaje tiene la siguiente causa y solución:

  • No ha asignado ninguna contraseña para el usuario Admin del programa Administrador.

    Asigne una contraseña al usuario Admin; para ello, elija el comando Los usuarios cambian la contraseña. Si no lo hace, cualquier usuario puede iniciar una sesión como administrador y realizar cambios en la base de datos de VSS.


La dirección URL base de este proyecto Web, <proyecto>, tiene una sintaxis de URL errónea

Este mensaje tiene la siguiente causa y solución:

  • La dirección URL que ha especificado para la dirección URL base de un proyecto Web de VSS tiene una sintaxis errónea.

    La sintaxis válida para la dirección URL se muestra en estos ejemplos:

    http://www.microsoft.com/spanish/default.htm
http://www.microsoft.com/spanish

    Puede cambiar la dirección URL en la ficha Proyectos Web a la está teniendo acceso seleccionando Opciones desde el menú Herramientas, o bien puede modificar la dirección URL en el archivo SRCSAFE.INI.


La base de datos <base de datos> no existe. Seleccione otra

Este mensaje tiene la siguiente causa y solución:

  • Está intentando buscar una base de datos que no existe.

    Haga clic en el botón Examinar para buscar la base de datos de VSS correcta o en No para cancelar la operación.


La base de datos <base de datos> no existe. ¿Desea buscarla?

Este mensaje tiene la siguiente causa y solución:

  • Está intentando buscar una base de datos que no existe.

    Haga clic en Sí para buscar la base de datos de VSS correcta o en No para cancelar la operación.


La base de datos no está disponible. ¿Desea desactivar la integración del control de código fuente?

Este mensaje tiene la siguiente causa y solución:

  • La base de datos VSS no está disponible. Haga lcic en Sí para desactivar la integración de control de código fuente.

    Una vez que se restablezca la conexión a la base de datos de VSS, reinicie el programa con el que lo esté usando (por ejemplo, Visual C, Visual Basic o Visual J) para usar el control de código fuente.


No se puede utilizar la carpeta de trabajo predeterminada del proyecto actual, heredada de la carpeta primaria, porque la ruta es demasiado larga

Este mensaje tiene la siguiente causa y solución:

  • VSS crea directorios de trabajo para los proyectos heredándolos de los proyectos primarios, y agregando después los nombres de los proyectos VSS que le sigan. Sin embargo, si el nombre del que se hereda es un nombre largo, no se puede exceder el límite de 260 caracteres.

    Establezca un nuevo directorio de trabajo para el proyecto en uso, o modifique y recorte el directorio de trabajo del proyecto desde el que se hereda.


La ruta de distribución <ruta de acceso> no es un archivo de sistema válido o una ruta de distribución FTP

Este mensaje tiene la siguiente causa y solución:

  • Una de las rutas de acceso especificadas para desplegar el proyecto no es una ruta válida del sistema de archivos del sistema operativo o no es una dirección URL válida para FTP.

    Las rutas de acceso ftp tienen la siguiente apariencia.

    ftp://usuario:usuario@www.microsoft.com/spain/ssafe
ftp://usuario@www.microsoft.com/spain/ssafe
ftp://www.microsoft.com/spain/ssafe

    Siempre empiezan con "ftp://". Siempre terminan con la dirección ftp (nombre de servidor y, opcionalmente, ruta de acceso del directorio). En el medio puede no haber nada (como en el último ejemplo anterior). O bien, puede haber un nombre de usuario (como en el ejemplo central) o un nombre de usuario y una contraseña (como en el primer ejemplo).


No se encontró editor <editor>

Este mensaje tiene la siguiente causa y solución:

  • Intentó ver o modificar un archivo para el que no se pudo encontrar el editor especificado. (Las asociaciones de editor a las extensiones de archivo se establecen en la ficha General a la que se tiene acceso haciendo clic en Opciones del menú Herramientas.)

    Haga clic en Sí si desea especificar otro editor diferente. Haga clic en No para cancelar la operación de edición.


No se pudo encontrar el archivo <archivo>. Pida al administrador de SourceSafe que ejecute la utilidad Analyze para volver a generarlo

Este mensaje tiene la siguiente causa y solución:

  • El archivo labels.ini no se ha encontrado en la base de datos de VSS.

    Pida a su administrador de VSS que ejecute la utilidad Analyze o ddupd -redo.


No se puede asignar el archivo <nombre de archivo> al proyecto <nombre de proyecto> de SourceSafe. Copie el archivo en <nombre de proyecto>

Este mensaje tiene la siguiente causa y solución:

  • Ha agregado un archivo de una carpeta distinta a su carpeta de proyecto (o uno de sus subdirectorios) y VSS no puede determinar qué proyecto corresponde a la carpeta de inicio del archivo nuevo.

    VSS debe asignar la copia local a una ruta de acceso de un proyecto VSS para que funcione esta operación. Copie el archivo a una subcarpeta de o debajo de su proyecto IDE. Si el archivo ya está en VSS en un proyecto diferente, comparta el archivo en su proyecto actual e intente de nuevo la operación.

    Continuará para obtener este mensaje conforme el archivo tenga un nombre tan largo que no se pueda asignar. Si ocurre esto, deberá quitar el archivo de su archivo de proyecto, copiarlo o compartirlo, y después volver a agregarlo.


No se ha podido asignar el archivo <nombre de archivo> al proyecto <nombre de proyecto> de SourceSafe

Este mensaje tiene la siguiente causa y solución:

  • Debe tener el archivo en VSS antes de continuar la operación.

    Haga clic en Sí para copiar el archivo al proyecto especificado y continuar.

    Haga clic en No para cancelar la operación.


El archivo <nombre de archivo> sobrepasa el tamaño de nombre de archivo máximo de SourceSafe

Este mensaje tiene la siguiente causa y solución:

  • Ha excedido el número máximo de nombre de archivo de la base de datos de VSS.

    Póngase en contacto con el Soporte de productos.


El archivo <nombre de archivo> ya está desprotegido

No hay elementos eliminados para este proyecto.


El archivo <nombre de archivo> no está bifurcado en <nombre de proyecto>

Este mensaje tiene la siguiente causa y solución:

  • El archivo que está intentando combinar no está bifurcado.

    Cuando un archivo está bifurcado y desea combinar las diferentes versiones del archivo en un archivo combinado, puede utilizar el comando Combinar bifurcaciones. En este caso, el archivo no está bifurcado, por lo que Combinar bifurcaciones no tiene ningún efecto.


El archivo <nombre de archivo> no está desprotegido

Esta advertencia tiene la siguiente causa y solución:

  • Ha intentado Proteger o Deshacer la desprotección de un archivo que actualmente no está desprotegido.

    Haga clic en la opción apropiada del mensaje de advertencia.


El archivo <nombre de archivo> se ha sacado del proyecto y no se puede volver a generar. ¿Desea continuar?

Vea también

Es posible que VSS no pueda reproducir la versión de proyecto que ha solicitado. Este mensaje tiene la siguiente causa y solución:

  • Un subproyecto de este proyecto se ha movido a otra ubicación. Después intentó volver a una versión anterior del proyecto. VSS intenta reconstruir el proyecto exactamente como era anteriormente, pero no puede porque no puede recuperar el subproyecto.

    Haga clic en Sí y VSS hará todo lo posible para restaurar la versión anterior del proyecto, pero no se garantiza la restauración.

    Haga clic en No y se detendrá el intento de restaurar la versión anterior del proyecto.

    Haga clic en Sí a todo y VSS no le avisará de la posible existencia de otros archivos irrecuperables; continuará llevando a cabo la reconstrucción de la mejor forma posible.


La cadena Tipos de archivo tiene una longitud máxima de <número> caracteres. Actualmente tiene <número> caracteres y debe acortarse

Este mensaje tiene la siguiente causa y solución:

  • Está agregando tipos de archivos en Tipos de archivo incluidos en grupo de archivos en la ficha Tipos de archivo del cuadro de diálogo Opciones del menú Herramientas. VSS tiene un límite de 511 caracteres para cualquier valor del archivo SS.INI y se ha excedido este límite.

    Reduzca el número de Grupos de archivos o el número de máscaras de archivo (si se está usando alguna en los Grupos de archivos) a 511 caracteres o menos.


El nombre de archivo <archivo> contiene caracteres no válidos. Se pasará por alto el archivo

Este mensaje tiene la siguiente causa y solución:

  • El nombre de archivo especificado contiene uno o más caracteres no válidos.

    Al agregar archivos a VSS, deben cumplir los requisitos siguientes.

    • Longitud de 255 caracteres o menos.

    • La ruta de acceso completa no puede pasar de 259 caracteres, incluyendo los separadores.

    • No pueden comenzar o acabar con un espacio.

    • No pueden comenzar con un $.

    • Pueden contener una o más extensiones de archivo (p.e., MiArchivo.Ext1.Ext2.Ext3.Txt).

    • Son caracteres válidos los caracteres del 32 al 255 en ASCII, pero no: ?”/\<>*|:


Los archivos son idénticos

Este mensaje tiene la siguiente causa y solución:

  • Los archivos que ha seleccionado, la copia maestra de VSS y la copia local, son idénticos. Puede que haya seleccionado un archivo en la lista de archivos e intentado ejecutar el comando Mostrar diferencias sólo en este archivo, en cuyo caso se está comparando el archivo consigo mismo y, por definición, es idéntico.

    En este caso, antes de volver a aplicar el comando Mostrar diferencias, especifique dos archivos diferentes.


La carpeta <nombre de carpeta> ya está en uso

No hay elementos eliminados para este proyecto.


La carpeta <carpeta> ya existe

Cada elemento de un proyecto de VSS debe tener un nombre único. Este mensaje tiene las siguientes causas y solución:

  • Intentó asignar nombre a un archivo o a un subproyecto inmediato con el mismo nombre que el proyecto. (Puede existir un elemento con este nombre en otros proyectos de la base de datos, incluidos subproyectos.)

  • Está utilizando una versión de 16 bits y una versión de 32 bits de VSS para el mismo proyecto y no ha asignado los nombres de archivo correctamente.

    Para resolver este error, asigne un nombre diferente y único al nuevo elemento. O bien, puede eliminar o cambiar el nombre del elemento existente.

Nota En VSS, los nombres de los proyectos y de los archivos no distinguen entre mayúsculas y minúsculas. Por ejemplo, si tiene un archivo llamado Test.C, no podrá crear un subproyecto o un archivo llamado "Test.c" o "test.c" dentro del mismo proyecto.


El archivo INI <nombre de archivo> sigue teniendo el formato 2,2. Ejecute UPDINI.EXE en este archivo INI

No hay elementos eliminados para este proyecto.


No se pudo encontrar el archivo de almacenamiento local de etiquetas <archivo>. Pida al Administrador de VSS que ejecute el utilidad Analyze para volver a generarlo

Este mensaje tiene la siguiente causa y solución:

  • Alguien ha eliminado este archivo de manera intencionada o un equipo se ha quedado bloqueado al intentar escribir en él.

    Ejecute Analyze sobre la base de datos tan pronto como sea posible. No etiquete más archivos o proyectos, ni intente obtener una etiqueta hasta que se complete el análisis.


No se ha actualizado el archivo <archivo> de manera apropiada. Pida al administrador de SourceSafe que ejecute la utilidad Analyze para volver a generarlo

Este mensaje tiene la siguiente causa y solución:

  • Mientras intentaba mantener el archivo labels.ini actualizado, VSS no ha podido escribir en el mismo. Cualquier intento de realizar una obtención por etiqueta no verá la etiqueta hasta que el administrador de VSS ejecute Analyze.

    Pida al administrador de VSS que ejecute la utilidad Analyze.


El archivo de almacenamiento local (vss.ver) no existe

Este mensaje tiene la siguiente causa y solución:

  • Algunas características como la desprotección de versión local no pueden funcionar si no hay un archivo vssver.scc.

    La siguiente obtención de cualquier archivo creará un archivo vssver.scc.


El nombre del archivo de salida comienza con un carácter no alfabético. Use '@' para crear el archivo de salida <nombre de archivo>

Esta advertencia tiene la siguiente causa y solución:

  • VSS tiene la capacidad de enviar la salida de los comandos de la línea de comandos a un archivo con la utilización de la opción –O. En este caso, el archivo de salida comienza con un carácter no permitido.

    Vuelva a ejecutar el comando usando un nombre de archivo válido para el archivo de salida.


Las contraseñas no coinciden

Este mensaje tiene la siguiente causa y solución:

  • La contraseña que ha especificado para el usuario no coincide.

    Cuando cambie la contraseña de un usuario, debe escribir la nueva contraseña dos veces para evitar errores de escritura. En este caso, las contraseñas que ha escrito no coinciden. Vuelva a escribirlas.


Las contraseñas no coinciden

Este mensaje tiene la siguiente causa y solución:

  • La contraseña que ha escrito en el cuadro Contraseña nueva no coincide con la escrita en el cuadro Comprobar.

    Si las contraseñas especificadas son idénticas, VSS supondrá que las ha escrito correctamente y cambiará su contraseña. Si escribe dos contraseñas diferentes, VSS asume que ha escrito una contraseña incorrecta.


No se encontró el proyecto <nombre de proyecto>. ¿Desea buscar el proyecto?

VSS ha intentado abrir un proyecto que no se ha podido encontrar en la base de datos de VSS. Este mensaje tiene la siguiente causa y solución:

  • Se ha movido o cambiado de nombre el proyecto VSS en el Explorador de VSS, y después se ha abierto el proyecto en Visual Basic o Visual C++ que hace referencia al nombre de proyecto antiguo de VSS.

    Haga clic en Sí para explorar el proyecto si sabe el nombre del proyecto nuevo.

    Haga clic en No si no quiere que el proyecto esté bajo el control de código fuente. Si hace clic en No, debe volver a agregar manualmente el proyecto a VSS para poder usar las características de control de código fuente en el futuro.


La revisión <número de revisión> no tiene cambios. ¿Desea incluirla?

No hay elementos eliminados para este proyecto.


El complemento de control de código fuente no se puede conectar con Visual Basic

Este mensaje tiene la siguiente causa y solución:

  • El complemento de control de código fuente no se puede conectar con Visual Basic.

    Póngase en contacto con el Soporte de productos.


La dirección URL <URL> no tiene una sintaxis URL de HTTP apropiada

Este mensaje tiene la siguiente causa y solución:

  • La dirección URL que especificó tiene una sintaxis no válida.

    La sintaxis válida para la dirección URL se muestra en estos ejemplos:

    http://www.microsoft.com/spanish/default.htm
http://www.microsoft.com/spanish


La dirección URL para el proyecto <proyecto> no se ha establecido apropiadamente

Este mensaje tiene la siguiente causa y solución:

  • Estableció una dirección URL incorrecta para un proyecto Web o la dirección URL usa una sintaxis que VSS no entiende (por ejemplo, puede que use www.microsoft.com/spanish/... en lugar de http://www.microsoft.com/spanish/...)

    Use el programa Administrador para establecer una dirección URL correcta.


Se ha modificado la contraseña del usuario

Ha cambiado correctamente la contraseña de este usuario.


La versión especificada en 'Desde' debe ser anterior a la especificada en 'En'

Las fechas especificadas en los campos Desde: y En: del cuadro de diálogo Opciones de historial de proyectos no son válidas. La fecha del campo Desde: ha de ser cronológicamente anterior a la del campo En: .


El administrador ha bloqueado la base de datos de SourceSafe

Este mensaje tiene la siguiente causa y solución:

  • Está intentado tener acceso a una base de datos que ha sido bloqueada por el administrador.

    Puede que el administrador esté ejecutando Analyze para reparar la base de datos, o podría estar archivando datos. Recuerde a su administrador que desbloquee la base de datos cuando complete sus tareas.


La ruta de la base de datos de VSS <ruta de acceso> no existe. Seleccione otra base de datos

Este mensaje tiene la siguiente causa y solución:

  • La ruta de acceso de la base de datos de VSS no existe. La entrada de Data_Path en el archivo SRCSAFE.INI no es válida.

    Pida a su administrador de VSS que compruebe la ruta de acceso a la base de datos de VSS en el archivo SRCSAFE.INI.


No se puede ejecutar el Explorador de VSS

No se puede ejecutar el Explorador de VSS.

Es posible que haya un apuntador incorrecto a la ubicación del programa de VSS. Póngase en contacto con el Soporte de productos.


En este comando no se permite la máscara de caracteres comodín <máscara>

No hay elementos eliminados para este proyecto.


No hay elementos eliminados en este proyecto

Este mensaje tiene la siguiente causa y solución:

  • No hay elementos en este proyecto que se hayan eliminado.

    Como no se ha eliminado ningún archivo de este proyecto, no hay archivos que pueda recuperar o purgar.


No hay elementos en la lista

Este mensaje tiene la siguiente causa y solución:

  • Especificó una operación de historial donde no hay elementos que cumplan el criterio especificado.

    Examine las casillas de verificación del cuadro de diálogo Opciones de historial y asegúrese de que estén correctamente establecidas.


Este comando no se puede completar si no hay especificada una carpeta de trabajo

Este mensaje tiene la siguiente causa y solución:

  • Eligió un comando que requiere una carpeta de trabajo, sin que se haya establecido aún ninguna.

    Haga clic en Aceptar para establecer una carpeta de trabajo para el proyecto actual o Cancelar para cancelar el comando. También puede establecer una carpeta de trabajo en cualquier momento si selecciona el proyecto y después el comando Establecer carpeta de trabajo del menú Archivo.


Este comando sólo funciona sobre archivos

Este comando sólo puede operar sobre archivos. Este mensaje tiene la siguiente causa y solución:

  • Está intentando realizar una operación (como utilizar el comando Ver) sobre un proyecto.

    Seleccione el comando adecuado o seleccione un archivo que funcione con el comando elegido.


Este comando sólo funciona sobre proyectos

Este comando sólo puede operar sobre proyectos. Este mensaje tiene la siguiente causa y solución:

  • Está intentando realizar una operación de proyecto (como el comando Mover proyecto) sobre un archivo.

    Seleccione el comando adecuado o seleccione un proyecto que funcione con el comando que ha elegido.


Este comando actúa sobre un único elemento

En muchas listas de los cuadros de diálogo de VSS, puede seleccionar más de un elemento a la vez, y después actuar sobre todos los elementos de una sola vez. Sin embargo, algunas acciones no pueden actuar sobre más de un elemento a la vez. Este mensaje tiene la siguiente causa y solución:

  • Seleccionó más de un elemento y aplicó un comando que sólo actúa sobre un elemento a la vez. Por ejemplo, puede que intentara utilizar el comando Ver, que sólo funciona con un archivo a la vez.

    Presione la barra espaciadora sobre un elemento para convertirlo en el único elemento seleccionado de la lista.


Este comando sólo funciona en archivos, no en proyectos (como <proyecto>)

Este comando sólo funciona sobre archivos. Este mensaje tiene la siguiente causa y solución:

  • Intentó ejecutar el programa sobre un proyecto.

    En el Explorador de VSS, seleccione un archivo en la lista de archivos y vuelva a intentar ejecutar el comando.


Este comando sólo funciona en proyectos, no en archivos (como <archivo>)

Este comando sólo funciona sobre proyectos. Este mensaje tiene la siguiente causa y solución:

  • Intentó ejecutar el comando sobre un archivo.

    En el Explorador de VSS, seleccione un proyecto en la lista de proyectos y vuelva a intentar ejecutar el comando.


Este comando requiere componentes de Internet que no están instalados en su equipo

Este mensaje tiene las siguientes causas y solución:

  • Intentó utilizar el comando Comprobar vínculos de Web en una plataforma RISC pero no había ningún archivo WinINET.DLL para distribuir cuando salió al mercado VSS. Puede obtener este archivo DLL necesario cuando exista una versión RISC del explorador.

  • Falta la versión correcta del archivo WinINET.DLL en su equipo Intel o Alpha. Compruebe si el archivo se ha movido o cambiado de nombre.

    Para asegurarse de que tiene los componentes de Internet más actualizados, vaya a http://www.microsoft.com/spain/ie/ y descargue Microsoft Internet Explorer 3.0 ó posterior. Después, reinicie VSS para activar este comando.


Esta base de datos no tiene nombre. Solicite a su administrador que le proporcione primero un nombre

Este mensaje tiene la siguiente causa y solución:

  • La base de datos no tiene nombre. Falta la entrada de Database_Name en el archivo SRCSAFE.INI.

    Pida a su administrador de VSS que de un nombre a la base de datos.


Esta etiqueta es heredada. Los cambios realizados en ella afectarán a todos los proyectos y archivos que están por debajo de <nombre de proyecto>. ¿Desea guardar los cambios?

Cambiar una etiqueta heredada de un proyecto aplicará de manera recursiva el cambio en todos los subproyectos o archivos secundarios del proyecto. Puesto que afecta a los proyectos y sus secundarios de manera recursiva, VSS le pregunta si desea guardar los cambios antes de completar la acción. Haga clic en Sí o en No.


Esto es un proyecto de integración. No está permitido proteger archivos desde el explorador de VSS

Este mensaje tiene la siguiente causa y solución:

  • Está intentando Proteger un objeto de Microsoft Access en el explorador de Microsoft VSS, o se ha agregado manualmente la entrada Disable_UI al archivo SRCSAFE.INI.

    El Componente de integración de Microsoft Access de VSS agrega un valor al archivo SRCSAFE.INI cuando agrega una base de datos de Microsoft Access a la base de datos del servidor de VSS. Esta entrada marca los archivos de la base de datos de VSS conforme van perteneciendo a un proyecto de integración de base de datos de Microsoft Access, y tiene un aspecto similar a éste:

       [$/Northwind]
      Disable_UI = Yes

Esta entrada del archivo .ini impide que se use el Explorador de VSS para desproteger los archivos de base de datos de Microsoft Access. Ocurre así por diseño debido a que los archivos son representaciones de tipo texto de los objetos de Microsoft Access que sólo se debería manipular en el contexto de un proyecto de Microsoft Access.

En algunos casos, puede que sea necesario realizar operaciones sobre objetos de Microsoft Access u otros archivos dentro del Explorador de VSS. Si es así, cierre el Explorador de VSS, quite o marque como comentario la línea Disable_UI del archivo SRCSAFE.INI, y después vuelva a abrir el Explorador de VSS. Después podrá realizar la operación deseada desde el Explorador de VSS.

Tenga en cuenta que cuando vuelva a abrir la base de datos de Microsoft Access, el Componente de integración de VSS (ACCSCC) vuelve a agregar la línea Disable_UI = Yes al archivo SRCSAFE.INI. También puede volver a agregar la línea al archivo por su propia cuenta.


Esto es un proyecto de integración. No está permitido desproteger archivos desde el explorador de VSS

Este mensaje tiene la siguiente causa y solución:

  • Está intentando Desproteger un objeto de Microsoft Access en el explorador de Microsoft VSS, o se ha agregado manualmente la entrada Disable_UI al archivo SRCSAFE.INI.

    El Componente de integración de Microsoft Access de VSS agrega un valor al archivo SRCSAFE.INI cuando agrega una base de datos de Microsoft Access a la base de datos del servidor de VSS. Esta entrada marca los archivos de la base de datos de VSS conforme van perteneciendo a un proyecto de integración de base de datos de Microsoft Access, y tiene un aspecto similar a éste:

      [$/Northwind]
      Disable_UI = Yes

Esta entrada del archivo .INI impide que se use el Explorador de VSS para desproteger los archivos de base de datos de Microsoft Access. Ocurre así por diseño debido a que los archivos son representaciones de tipo texto de los objetos de Microsoft Access que sólo se debería manipular en el contexto de un proyecto de Microsoft Access.

En algunos casos, puede que sea necesario realizar operaciones sobre objetos de Microsoft Access u otros archivos dentro del Explorador de VSS. Si es así, cierre el Explorador de VSS, quite o marque como comentario la línea Disable_UI del archivo SRCSAFE.INI, y después vuelva a abrir el Explorador de VSS. Después podrá realizar la operación deseada desde el Explorador de VSS.

Tenga en cuenta que cuando vuelva a abrir la base de datos de Microsoft Access, el Componente de integración de VSS (ACCSCC) vuelve a agregar la línea Disable_UI = Yes al archivo SRCSAFE.INI. También puede volver a agregar la línea al archivo por su propia cuenta.


Esto es un proyecto de integración. No está permitido obtener archivos desde el explorador de VSS

Este mensaje tiene la siguiente causa y solución:

  • Está intentando Obtener un objeto de Microsoft Access en el explorador de Microsoft VSS, o se ha agregado manualmente la entrada Disable_UI al archivo SRCSAFE.INI.

    El Componente de integración de Microsoft Access de VSS agrega un valor al archivo SRCSAFE.INI cuando agrega una base de datos de Microsoft Access a la base de datos del servidor de VSS. Esta entrada marca los archivos de la base de datos de VSS conforme van perteneciendo a un proyecto de integración de base de datos de Microsoft Access, y tiene un aspecto similar a éste:

       [$/Northwind]
      Disable_UI = Yes
  • Esta entrada del archivo .INI impide que se use el Explorador de VSS para desproteger los archivos de base de datos de Microsoft Access. Ocurre así por diseño debido a que los archivos son representaciones de tipo texto de los objetos de Microsoft Access que sólo se debería manipular en el contexto de un proyecto de Microsoft Access.

    En algunos casos, puede que sea necesario realizar operaciones sobre objetos de Microsoft Access u otros archivos dentro del Explorador de VSS. Si es así, cierre el Explorador de VSS, quite o marque como comentario la línea Disable_UI del archivo SRCSAFE.INI, y después vuelva a abrir el Explorador de VSS. Después podrá realizar la operación deseada desde el Explorador de VSS.

    Tenga en cuenta que cuando vuelva a abrir la base de datos de Microsoft Access, el Componente de integración de VSS (ACCSCC) vuelve a agregar la línea Disable_UI = Yes al archivo SRCSAFE.INI. También puede volver a agregar la línea al archivo por su propia cuenta.


Esto es un proyecto de integración; esta operación no está permitida desde el explorador de VSS

Este mensaje tiene la siguiente causa y solución:

  • Está intentando una operación sobre un objeto de Microsoft Access en el Explorador de Microsoft VSS.

    El Componente de integración de Microsoft Access de VSS agrega un valor al archivo SRCSAFE.INI cuando agrega una base de datos de Microsoft Access database a la base de datos del servidor de VSS. Esta entrada marca los archivos de la base de datos de VSS conforme van perteneciendo a un proyecto de integración de base de datos de Microsoft Access, y tiene un aspecto similar a éste:

      [$/Northwind]
      Disable_UI = Yes

Esta entrada del archivo .INI impide que se use el Explorador de VSS para desproteger los archivos de base de datos de Microsoft Access. Ocurre así por diseño debido a que los archivos son representaciones de tipo texto de los objetos de Microsoft Access que sólo se debería manipular en el contexto de un proyecto de Microsoft Access.

En algunos casos, puede que sea necesario realizar operaciones sobre objetos de Microsoft Access dentro del Explorador de VSS. Si es así, cierre el Explorador de VSS, quite o marque como comentario la línea Disable_UI del archivo SRCSAFE.INI, y después vuelva a abrir el Explorador de VSS. Después podrá realizar la operación deseada desde el Explorador de VSS.

Tenga en cuenta que cuando vuelva a abrir la base de datos de Microsoft Access, el Componente de integración de VSS (ACCSCC) vuelve a agregar la línea Disable_UI = Yes al archivo SRCSAFE.INI. También puede volver a agregar la línea al archivo por su propia cuenta.


Esto es un proyecto de integración. No está permitido deshacer la desprotección de archivos desde el explorador de VSS

  • Está intentando Deshacer la desprotección de un objeto de Microsoft Access en el explorador de Microsoft VSS, o se ha agregado manualmente la entrada Disable_UI al archivo SRCSAFE.INI.

    El Componente de integración de Microsoft Access de VSS agrega un valor al archivo SRCSAFE.INI cuando agrega una base de datos de Microsoft Access database a la base de datos del servidor de VSS. Esta entrada marca los archivos de la base de datos de VSS conforme van perteneciendo a un proyecto de integración de base de datos de Microsoft Access, y tiene un aspecto similar a éste:

       [$/Northwind]
      Disable_UI = Yes

Esta entrada del archivo .INI impide que se use el Explorador de VSS para desproteger los archivos de base de datos de Microsoft Access. Ocurre así por diseño debido a que los archivos son representaciones de tipo texto de los objetos de Microsoft Access que sólo se debería manipular en el contexto de un proyecto de Microsoft Access.

En algunos casos, puede que sea necesario realizar operaciones sobre objetos de Microsoft Access u otros archivos dentro del Explorador de VSS. Si es así, cierre el Explorador de VSS, quite o marque como comentario la línea Disable_UI del archivo SRCSAFE.INI, y después vuelva a abrir el Explorador de VSS. Después podrá realizar la operación deseada desde el Explorador de VSS.

Tenga en cuenta que cuando vuelva a abrir la base de datos de Microsoft Access, el Componente de integración de VSS (ACCSCC) vuelve a agregar la línea Disable_UI = Yes al archivo SRCSAFE.INI. También puede volver a agregar la línea al archivo por su propia cuenta.


Esta etiqueta <etiqueta> ya está en uso. ¿Desea quitar la etiqueta antigua?

Una etiqueta de VSS se utiliza para identificar un determinado número de versión de un archivo o un proyecto. Este mensaje tiene la siguiente causa y solución:

  • Está intentando asignar una etiqueta a un archivo o un proyecto, pero hay otra versión de este archivo o proyecto que tiene la misma etiqueta.

    Haga clic en Sí para aplicar la nueva etiqueta y eliminar la antigua. Haga clic en No para dejar la antigua etiqueta sin cambiar. Haga clic en Cancelar para cancelar la operación de etiquetado.


La etiqueta <etiqueta> ya está en uso en una versión anterior de <archivo o proyecto>. ¿Desea quitar la etiqueta antigua?

Una etiqueta de VSS se utiliza para identificar una versión particular de un archivo o proyecto.

Este mensaje tiene la siguiente causa y solución:

  • Está intentando asignar una etiqueta a un archivo o un proyecto, pero hay otra versión de este archivo o proyecto que tiene la misma etiqueta.

    Haga clic en Sí para aplicar la nueva etiqueta y reemplazar la antigua.

    Haga clic en No para cancelar la acción; se mantendrá la etiqueta antigua.

    Haga clic en Cancelar para cancelar la operación de etiquetado.


Esta versión de <archivo o proyecto> ya tiene una etiqueta. ¿Desea sobrescribirla con la etiqueta nueva?

Cualquier versión de un archivo o proyecto de VSS puede tener una etiqueta, que se utiliza para identificar dicha versión.

Este mensaje tiene la siguiente causa y solución:

  • Una versión de un archivo o un proyecto no puede tener más de una etiqueta. Por tanto, cuando intente etiquetar una versión que ya tiene una etiqueta, VSS mostrará este mensaje.

    Haga clic en Sí para aplicar la nueva etiqueta y reemplazar la antigua.

    Haga clic en No para cancelar la acción; se mantendrá la etiqueta antigua.


Esta versión de <nombre> ya tiene una etiqueta. ¿Desea sobrescribirla?

Cualquier versión de un archivo o proyecto de VSS puede tener una etiqueta, que se utiliza para identificar ese número de versión. Este mensaje tiene la siguiente causa y solución:

  • Una versión de un archivo o un proyecto no puede tener más de una etiqueta. Por tanto, cuando intente etiquetar una versión que ya tiene una etiqueta, VSS mostrará este mensaje.

    Haga clic en Sí para aplicar la nueva etiqueta y reemplazar la antigua. Haga clic en No para cancelar la acción y dejar la antigua etiqueta en su lugar.


Esta base de datos de VSS no tiene UUID

No hay elementos eliminados para este proyecto.


Esto finalizará la sesión de VSS

Este mensaje tiene la siguiente causa y solución:

  • Va a salir de VSS.

    Haga clic en Aceptar para salir de VSS, o haga clic en Cancelar para volver a VSS.

Nota Su no quiere recibir este mensaje cada vez que salga, puede deshabilitarlo en la ficha Advertencias del cuadro de diálogo Opciones de SourceSafe del menú Herramientas.


Se ha terminado el tiempo de espera para bloquear el archivo: <nombre de archivo>

Esta advertencia tiene las siguientes causas y solución:

  • VSS puede configurarse para utilizar su propia forma de bloqueo de archivos. Esta opción la debe establecer el administrador de VSS en el archivo SRCSAFE.INI. Este error indica que existe un bloqueo de archivo (extensión .LCK) en la carpeta \DATA\LOCKS. Esta situación ocurre bajo cualquiera de las circunstancias siguientes:
    • Un usuario tiene un archivo bloqueado. Por ejemplo, un archivo está bloqueado mientras se actualiza.

    • Un bloqueo de archivo de VSS no se ha eliminado de la carpeta \DATA\LOCKS.

    • No existe una carpeta \DATA\LOCKS.

    Si un usuario tiene un bloqueo sobre un archivo, entonces vuelva a intentar el comando pasados unos minutos.

    Si el bloqueo no se ha eliminado de la carpeta \DATA\LOCKS, vaya a la misma y elimine el archivo .LCK, pero asegúrese de que todos han salido de VSS antes de eliminar los archivos .LCK o podría afectar al proceso de otros usuarios.

    Si aparece esta advertencia cuando se inicia la sesión en VSS, compruebe si existe una carpeta \DATA\LOCKS. Si no existe, cree una e intente iniciar de nuevo la sesión.


Hay demasiados controladores de archivo abiertos

Este mensaje tiene la siguiente causa y solución:

  • Hay demasiados archivos abiertos en el sistema.

    Compruebe si se puede cerrar alguno de los archivos o bien, puede que desee aumentar el contador de archivos en el archivo de inicialización del sistema operativo.


Hay demasiadas cadenas de entorno de SS.INI

Esta advertencia tiene la siguiente causa y solución:

  • VSS almacena demasiadas configuraciones en un archivo SS.INI que es individual para cada usuario. Para cada valor del archivo INI, VSS almacenará una cadena de entorno. Normalmente será el nombre del equipo sonde se ha establecido el valor. Normalmente ocurre por culpa del valor 'Dir (<cadena de entorno>) = <Alguna carpeta local>' del archivo INI. VSS permite unas 25 cadenas de entorno únicas.

    Modifique manualmente el archivo \USERS\<NombreUsuario>\SS.INI del usuario que obtenga este mensaje. Elimine cualquier valor del archivo INI que no utilice que tenga varias cadenas de entorno.

    Si cuenta el número de veces que recibe este mensaje, indica el número de cadenas de entorno que necesita eliminar. Si obtiene el error durante el inicio, indicará qué líneas contienen las cadenas de entornos en exceso.


<Tipo> no es una máscara válida

Este mensaje tiene la siguiente causa y solución:

  • Ha especificado una máscara no válida en la ficha Tipos de archivo del cuadro de diálogo Opciones del menú Herramientas.

    Debe especificar un carácter * o ? en su máscara de archivo y no puede tener en la máscara caracteres no válidos como (, ), [ o ].

    Vuelva a escribir la máscara de archivo usando caracteres válidos.


No se puede distribuir <proyecto> al host FTP <host>

Este mensaje tiene la siguiente causa y solución:

  • VSS no pudo abrir una conexión con el host ftp especificado y desplegar su proyecto.

    Compruebe sus conexiones de red y asegúrese de que ha escrito la sintaxis correcta para el host FTP. Este error también se puede producir si su host ftp no está disponible en este momento.


No se puede iniciar el explorador de Web en la página <archivo>

Este mensaje tiene la siguiente causa y solución:

  • VSS no ha podido iniciar su explorador del Web.

    Compruebe que su explorador del Web está funcionando normalmente. Puede que necesite volver a instalar el explorador para comprobar los valores del Registro.


No se puede cargar el analizador de HTML

Este mensaje tiene la siguiente causa y solución:

  • Tiene una instalación de VSS corrupta. El archivo DLL ha desaparecido o en el registro no se ha especificado el archivo DLL correcto.

    Vuelva a instalar VSS de nuevo.


No se puede abrir una conexión para el host FTP <host>

Este mensaje tiene la siguiente causa y solución:

  • VSS no pudo abrir una conexión con el host FTP especificado.

    Compruebe sus conexiones de red y si ha utilizado la sintaxis correcta al escribir el host ftp. Este error se podría producir si su host ftp no está disponible en este momento.


No se puede abrir el archivo de registro de usuario <ruta de acceso del archivo de registro de usuario>

Esta advertencia tiene la siguiente causa y solución:

  • El usuario no tiene derecho de acceso Escribir a la base de datos de VSS.

    Garantice al usuario derechos plenos sobre el directorio de VSS y sobre todos sus subdirectorios.

    Todos los usuarios de VSS deben tener la capacidad de leer, escribir, crear y eliminar archivos en el directorio de VSS y todos sus subdirectorios.


No se puede cambiar el nombre del <elemento> por <elemento>

Vea también

VSS no pudo cambiar el nombre del elemento. Compruebe si el nombre especificado es un nombre válido.


No se puede cambiar el nombre del archivo seleccionado

El archivo que ha seleccionado está en un estado en el que no se puede cambiar de nombre. Por ejemplo, si un archivo está desprotegido, no se puede cambiar de nombre.


Error de automatización desconocido

No hay elementos eliminados para este proyecto.


Error desconocido: 20038

Si está en medio de una sesión de VSS y pierde su conexión al servidor a través de la red, el único mensaje que verá será un mensaje numérico que le informa de un error desconocido. Cuando vea, "error desconocido: 20038," o algo similar, será porque ha perdido su conexión de red. Reinicie VSS y continúe su trabajo.


¿Desea usar el archivo <archivo> desprotegido originalmente en <carpeta local>?

Esta advertencia tiene la siguiente causa y solución:

  • Desde la línea de comandos, está intentando proteger un archivo que está desprotegido varias veces. VSS le está pidiendo que confirme si desea desproteger o proteger.

    Escriba S si la carpeta local indicada es correcta. Se realizará la protección.

    Escriba N si la carpeta local que se indica no es correcta. VSS repetirá este mensaje por cada desprotección guardada para el archivo.


El usuario <usuario> ya existe

Este mensaje tiene la siguiente causa y solución:

  • Intentó agregar un usuario con un nombre de usuario que ya existe. Puede elegir otro nombre; por ejemplo, si ya existe Juan, agregue JuanG.

Nota Los nombres no distinguen entre mayúsculas y minúsculas, por lo que si ya existe Juan, agregar JUAN genera este error.


No se ha encontrado el usuario <usuario>

Este mensaje tiene la siguiente causa y solución:

  • No se encontró su nombre de usuario.

    Indíquelo a su administrador de VSS. Si es usted el administrador de VSS, ejecute Administrador de VSS para agregar su nombre de usuario.


El nombre de usuario es demasiado largo

Los nombres de usuario no pueden tener más de 31 caracteres de longitud.


En Windows 95 no puede agregar múltiples archivos desde una ruta de red que no está asignada a una letra de unidad

Al intentar agregar varios archivos a VSS debe asignar una letra de unidad a la ubicación remota que desee usar.


No se ha encontrado esta versión

Vea también

No se puede encontrar la versión especificada. Este error tiene las causas y soluciones siguientes:

  • Especificó una versión que no existe.

    En VSS, haga clic en el comando Mostrar historial del menú Herramientas y seleccione una versión de las mostradas en el cuadro de diálogo Historial del archivo.

  • Si está utilizando VSS desde la línea de comandos, puede que no esté utilizando correctamente el parámetro -V.

    Busque en la Ayuda en pantalla más información acerca de la correcta utilización del parámetro (haga clic en el botón Contenido).


El número <número> de versión es idéntico al número <número> de versión de <archivo>

Este mensaje tiene la siguiente causa y solución:

  • Las dos versiones que está comparando son idénticas.

    Asegúrese de que las dos versiones son las que desea comparar.


Las versiones <número> a <número> están en <archivo>. No se realizará ninguna acción.

Este mensaje tiene la siguiente causa y solución:

  • Está intentando eliminar un rango de versiones que VSS no puede localizar (quizá ya se ha archivado).

    Determina el rango de versiones válido y después archívelo.


VSS no puede encontrar una base de datos predeterminada. ¿Desea seleccionar una?

Este mensaje tiene la siguiente causa y solución:

  • VSS está intentando buscar una base de datos predeterminada que no existe.

    Haga clic en Sí para buscar la base de datos de VSS correcta o en No para cancelar la operación.


<archivo VSS> (<archivo de base de datos>) es una bifurcación primaria de un archivo que no se va a archivar. No se ha eliminado ninguna versión

Este mensaje tiene la siguiente causa y solución:

  • Este mensaje sólo tiene carácter informativo, y se genera al realizar una operación de Archivar. Archivar no elimina el archivo por el que se pregunta, puesto que contiene una porción del historial del archivo que se bifurca en cualquier parte y permanece activa.

    Si necesita eliminar el archivo, necesitará eliminar el registro de todas las bifurcaciones del archivo (mediante la ficha Rutas de acceso del cuadro de diálogo Propiedades), y después indicar también a Archivar que elimine todas las bifurcaciones del archivo.


Advertencia: Si no usa una contraseña, otros podrán iniciar una sesión en su cuenta de VSS. ¿Desea continuar sin contraseña?

Esta advertencia tiene la siguiente causa y solución:

  • Intentó iniciar una sesión sin especificar una contraseña.

    Es una advertencia informativa para asegurarse de que desea continuar sin establecer una contraseña en su cuenta. Haga clic en Sí para iniciar la sesión o en No para cancelar.


Advertencia: el comando Deshacer bifurcará este archivo, rompiendo los vínculos con otros proyectos que lo compartan

Esta advertencia tiene la siguiente causa y solución:

  • Esta advertencia puede producirse cuando deshaga un archivo que se ha bifurcado o que está fijado a otro proyecto.

    Haga clic en Sí para continuar o en No para cancelar.


Ya ha desprotegido el archivo <archivo> en otra ubicación. ¿Desea continuar?

Esta advertencia tiene la siguiente causa y solución:

  • El archivo que ha seleccionado para desproteger ya está desprotegido por usted en una ubicación diferente.

    Cancele la desprotección, o desproteja el archivo en una nueva ubicación.


Va a quitar la contraseña del usuario Admin de VSS, que permite a cualquier usuario ejecutar el programa del administrador

Esta advertencia tiene la siguiente causa y solución:

  • Va a eliminar la contraseña del usuario Admin.

    Dejar al usuario Admin sin contraseña es un gran riesgo para la seguridad, ya que cualquier usuario puede iniciar una sesión en el programa Administrador y realizar cambios en la base de datos de VSS. Haga clic en Sí para continuar o en No para cancelar la operación.


Sólo se permite una carpeta para este comando. <carpeta> no está permitido

Esta advertencia tiene la siguiente causa y solución:

  • Ciertos comandos de VSS sólo pueden aceptar una carpeta cada vez. Un ejemplo es el comando ss workfold.

    Use sólo una carpeta al usar este comando.


Sólo se permite un proyecto para este comando. <proyecto> no está permitido

Esta advertencia tiene la siguiente causa y solución:

  • Ciertos comandos de VSS sólo pueden ocurrir en un proyecto cada vez. Algunos de los comandos que lo requieren son ss share y ss project.

    Ejecute varias veces el comando, indicando un solo proyecto cada vez.


Sólo se permite una ruta de acceso relativa para este comando. <carpeta> debe ser una ruta de acceso completa

Esta advertencia tiene la siguiente causa y solución:

  • Ciertos comandos de VSS sólo pueden aceptar una carpeta relativa cada vez. Un ejemplo es el comando ss workfold.

    Use sólo una carpeta cuando use este comando e identifique una ruta de acceso completa.


Se está usando una versión anterior de <archivo> y no se puede cambiar. Deshaga para hacer que esa versión sea la más reciente si necesita cambiarla

Vea también

Este mensaje tiene la siguiente causa y solución:

  • Intentó modificar una versión antigua de archivo.

    Si desea que un proyecto utilice siempre una versión específica y no reciba los cambios protegidos realizados en otros proyectos, puede compartir una determinada versión del archivo mediante el comando Fijar del cuadro de diálogo Historial del archivo.

    Si desea empezar por modificar el archivo desde una versión antigua, puede deshacer los cambios realizados en el archivo. El comando Deshacer sólo afecta al proyecto actual; realiza implícitamente una operación distinta. Bifurcar y Deshacer están disponibles desde el cuadro de diálogo Historial del archivo.


Sólo puede compartir un proyecto a la vez

Este mensaje tiene la siguiente causa y solución:

  • El comando share de la línea de comandos de VSS sólo puede usar un proyecto como parámetro. Ha indicado más de un proyecto en el comando ss share.

    Ejecute el proyecto ss share <Proyecto> una vez por cada proyecto que desee compartir. Puede que desee considerar la utilización del modificador –R del comando para compartir proyectos de manera recursiva.


No puede agregar la carpeta raíz <carpeta>

Este mensaje tiene la siguiente causa y solución:

  • En el diálogo Agregar archivo, ha intentado agregar a una carpeta raíz (p.e., “d:\”). VSS no permite agregar carpetas raíz.

    Seleccione y agregue un archivo a una carpeta que no sea carpeta raíz.


No puede cambiar el nombre o los privilegios de acceso de Admin

Este mensaje tiene la siguiente causa y solución:

  • Intentó cambiar el nombre del usuario Admin o sus privilegios de acceso.

    No se puede cambiar el nombre del usuario Admin ni sus derechos de acceso. Seleccione otro usuario sobre el que utilizar este comando.


No puede combinar una bifurcación consigo misma

Esta advertencia tiene la siguiente causa y solución:

  • VSS puede combinar los cambios de dos archivos que vienen de un archivo ancestro común. Sin embargo, no se puede combinar un archivo consigo mismo.

    Seleccione uno de los otros proyectos en los que el archivos está bifurcado. Para ver las bifurcaciones, consulte el menú Archivo, Propiedades, ficha Rutas de acceso.


No puede modificar las propiedades de un archivo desprotegido

Vea también

Esta advertencia tiene la siguiente causa y solución:

  • Está intentando cambiar una de las propiedades de un archivo que está desprotegido desde la línea de comandos. Este mensaje se acompaña normalmente de un mensaje adicional que le informa de quién tiene el archivo desprotegido.

    Identifique a quien tiene el archivo desprotegido con el comando ss status <nombrearchivo>, y después haga que lo proteja. Ahora podrá volver a ejecutar el comando ss properties.


No puede realizar una combinación sobre un archivo binario o un archivo que sólo almacena la última versión

Este mensaje tiene la siguiente causa y solución:

  • VSS sólo puede combinar archivos de texto que vengan de una versión de ancestro común. El archivo seleccionado es un archivo binario o está configurado para que almacene sólo la versión más reciente. Si está configurado para almacenar sólo la versión más reciente entonces VSS no puede determinar a qué archivo ancestro se parece y por tanto no puede combinar los archivos.

    Elija un archivo de texto que almacene más de una versión.


No puede establecer el indicador Almacenar la versión más reciente para el archivo <nombre de archivo> porque está fijado a una versión específica

Esta advertencia tiene la siguiente causa y solución:

  • Intentó cambiar la propiedad Guardar sólo la última versión de un archivo que está fijado.

    Averigüe a qué versión del archivo está fijado mediante el comando ss dir <Nombre de archivo>. Después use el comando ss unpin <Nombre de archivo> para liberar el archivo. En este punto podrá usar el comando ss properties –L <Nombre de archivo> para cambiar la propiedad Guardar sólo la última versión. Después fije el archivo a la versión a la que estaba fijado originalmente.


No puede compartir un proyecto consigo mismo

Este mensaje tiene la siguiente causa y solución:

  • Para evitar confusiones, VSS no permitirá que un proyecto se comparta de manera recursiva a sí mismo. Está intentando compartir un proyecto en la línea de comando y ya está actualmente en ese proyecto.

    Use el comando ss cp para cambiar su proyecto actual a un proyecto distinto del que está intentando compartir. O seleccione un proyecto diferente para compartir.


No se pueden utilizar comodines con este comando

Muchos comandos de VSS aceptan caracteres comodín, como * y ?. Sin embargo, algunos comandos, como el comando Ver, sólo pueden actuar sobre un elemento a la vez. Este mensaje tiene la siguiente causa y solución:

  • El comando que ha elegido no acepta caracteres comodín.

    Utilice un nombre de archivo explícito, sin caracteres comodín.


Tiene el archivo <archivo> desprotegido actualmente

Vea también

Esta advertencia tiene la siguiente causa y solución:

  • Desde la línea de comandos, está intentando desproteger un archivo que ya ha desprotegido. Este mensaje sólo aparecerá si está desactivada la opción de Permitir varias desprotecciones.

    Si desea desproteger el archivo una segunda vez, tendrá que hacer que el administrador de VSS active la opción Permitir varias desprotecciones. En otro caso, proteja el archivo antes de intentar desprotegerlo de nuevo.


Tiene el archivo <archivo> desprotegido actualmente

Sólo puede desproteger un archivo una vez por usuario y por equipo. Debe iniciar una sesión como otro usuario o desproteger el archivo desde otra máquina.


Tiene el archivo <archivo> desprotegido actualmente. ¿Desea eliminarlo?

Esta advertencia tiene la siguiente solución:

Cuando tenga desprotegido un archivo, hay algunas cosas que no debería hacer. Por ejemplo, no debería eliminar o cambiar el nombre del archivo que está desprotegido.

  • Haga clic en Sí para eliminar el archivo en cualquier caso. (Sí a todo elimina todos los archivos desprotegidos aunque ya estén desprotegidos por otro usuario.)

  • Haga clic en No para cancelar el comando Eliminar. (No a todo cancela el comando para todos los archivos seleccionados.)

  • Haga clic en Cancelar para cancelar la operación de eliminación.

    Si desea eliminar el archivo, es mejor practicar antes para proteger sus cambios o para poder deshacer la desprotección en el archivo.


No tiene derechos de acceso a <nombre de comando>

Este mensaje tiene la siguiente causa y solución:

  • Sus derechos de acceso en VSS son insuficientes para ejecutar el comando seleccionado. Por ejemplo, si es un usuario de sólo lectura, puede utilizar el comando Obtener la última versión para ver archivos, pero no puede utilizar el comando Desproteger para modificarlos.

    Si cree que ha recibido este mensaje por error, póngase en contacto con el Administrador de VSS.


No tiene permiso de destrucción para <elemento>

Este mensaje tiene la siguiente causa y solución:

  • Ha intentado destruir algo sin los permisos apropiados (derechos de destruir).

    Pida a su administrador de VSS que configure sus derechos de destruir, o abandone el intento de destrucción.


Actualmente no tiene el archivo <nombre de archivo> desprotegido

Esta advertencia tiene la siguiente causa y solución:

  • Está intentando proteger o deshacer la desprotección sobre un archivo que usted no ha desprotegido. El archivo puede haber sido desprotegido por otro usuario.

    Identifique al usuario que ha desprotegido el archivo y pídale que ejecute el comando Proteger o el comando Deshacer desprotección. Si no puede encontrar al usuario, el usuario Admin puede proteger los archivos desprotegidos por otros usuarios.

    Para identificar al usuario que ha desprotegido un archivo, vea la ficha Estado de desprotección del cuadro de diálogo propiedades del archivo o utilice el comando ss status.


Tiene desprotegido <archivo>; si lo elimina cancelará la desprotección

Esta advertencia tiene la siguiente causa y solución:

  • Está intentando eliminar un archivo desprotegido.

    Si el nombre del archivo es correcto, haga clic en Sí para continuar. Para cancelar la operación de eliminación, haga clic en No.


Le quedan <número> días para probar la versión gratuita de VSS de prueba

Para realizar un pedido de Microsoft VSS u obtener una relación de distribuidores, llame al 1-800-621-7930. Fuera de los Estados Unidos o Canadá, póngase en contacto con su distribuidor local de Microsoft.


Debe introducir un nombre de archivo sin ruta de acceso para el mapa de sitios

Este mensaje tiene la siguiente causa y solución:

  • Ha especificado una ruta de archivo para el archivo del mapa del Sitio que no está permitida. La especificación del archivo de mapa del Sitio no admite una ruta.

    Escriba sólo el nombre del archivo, como por ejemplo Sitemap.htm.


Debe especificar un nombre nuevo

Este mensaje tiene la siguiente causa y solución:

  • Está intentando cambiar el nombre de un archivo o un proyecto sin especificar un nombre nuevo para él.

    Escriba un nombre nuevo y después haga clic en Aceptar, o presione ESC para cancelar la operación de cambio de nombre.


Debe escribir más de <las que ya ha escrito> letras para identificar un comando de forma exclusiva

Vea también

Este mensaje tiene la siguiente causa y solución:

  • La línea de comandos de VSS acepta versiones abreviadas de sus comandos. Sin embargo, la línea de comandos ha de ser capaz de distinguir lo que está intentando usar. Ha utilizado muy pocas letras.

    Use más letras en el comando para distinguirlo unívocamente de los demás comandos. Tres letras deberían ser suficientes para identificar de manera unívoca un comando. Sin embargo, 'check' se interpretará como checkout y no como checkin.


Su versión gratuita de prueba de VSS caducó hace más de 30 días

Se ha deshabilitado parte de la funcionalidad de VSS.

Para cumplir con su contrato de licencia y restaurar la funcionalidad completa de VSS, es necesario solicitar una licencia.

Para realizar un pedido de Microsoft VSS o recibir una relación de distribuidores, llame al 1-800-621-7930. Fuera de los Estados Unidos o Canadá, póngase en contacto con su distribuidor local de Microsoft.

Se elige que no desea solicitar una versión con licencia de VSS, debe desinstalar completamente VSS puesto que está produciendo una violación de su acuerdo de licencia.


Su versión gratuita de prueba de VSS ha caducado

Para continuar usando Microsoft VSS, debe solicitar una copia con licencia. Para realizar un pedido de VSS o recibir una relación de distribuidores, llame al 1-800-621-7930. Fuera de los Estados Unidos o Canadá, póngase en contacto con su distribuidor local de Microsoft.

Se elige que no desea solicitar una versión con licencia de VSS, debe desinstalar completamente VSS puesto que está produciendo una violación de su acuerdo de licencia.


Se ha cambiado la contraseña correctamente

Se ha cambiado su contraseña. Al iniciar una nueva sesión de VSS o al usar la línea de comandos, necesitará usar la contraseña nueva.


Su carpeta de trabajo contiene una copia modificable de <archivo>

Este mensaje tiene la siguiente causa y solución:

  • Tiene un archivo modificable en su disco no desprotegido por usted, y no ha realizado un comando Get.

    Seleccione una de las opciones que se presentan. Abandone el archivo, reemplácelo, desprotéjalo manteniendo los cambios o cancel la obtención.


Su carpeta de trabajo contiene una copia modificable de una versión antigua de <archivo>

Este mensaje tiene la siguiente causa y solución:

  • Tiene un archivo modificable en su disco no desprotegido por usted, y no ha realizado un comando Get.

    Seleccione una de las opciones que se presentan. Abandone el archivo, reemplácelo, desproteja la versión antigua al mantener los cambios, desproteja la versión antigua al combinar los cambios o cancele la obtención.


Error al ejecutar: <programa>

No hay Ayuda para este tema.


Agregar archivos (Comando, menú Archivo)

Vea también

Copia un archivo o un grupo de archivos al proyecto actual de VSS. En el cuadro de diálogo Agregar archivo puede especificar un archivo de cualquier unidad y carpeta, y que ese archivo se copie al proyecto actual de VSS.

Derechos de acceso

Debe disponer del derecho de acceso Agregar para utilizar este comando.

Comentarios

Puede utilizar el comando Purgar para deshacer una operación Agregar archivos, pero no es recomendable puesto que no conserva una copia recuperable del archivo en la base de datos de VSS. En su lugar, considere la utilización del comando Eliminar, puesto que conserva una copia recuperable del archivo.

Opciones del cuadro de diálogo

Nombre de archivo

Seleccione o escriba el nombre del archivo que desee abrir. Este cuadro muestra los elementos que tienen la extensión de archivo seleccionada en el cuadro Mostrar archivos de tipo.

Mostrar archivos de tipo

Muestra el tipo de archivo o indica a VSS cómo clasificar un archivo.

La lista de tipos de archivo disponibles se determina en el filtro Tipos de archivo incluidos en grupo de archivos y en el filtro Grupos de archivo establecidos en la ficha Tipos de archivo del cuadro de diálogo Opciones de SourceSafe. Todos los archivos (*.*) muestra una lista de todos los archivos de la carpeta actual.

Carpetas

Especifica la carpeta que contiene el archivo que desea agregar.

Unidades

Selecciona la unidad que contiene el archivo que desea agregar.

Cerrar

Cierra el cuadro de diálogo sin agregar el archivo al proyecto.

Agregar

Abre el cuadro de diálogo Comentario avanzado, permitiéndole agregar los archivos seleccionados al proyecto seleccionado. El cuadro de diálogo Comentarios avanzados muestra un cuadro de comentarios en el que puede introducir comentarios (opcional). Seleccione la casilla Aplicar el mismo comentario a todos para utilizar el mismo comentario para todos los archivos que está agregando. Haga clic en elk botón Avanzados del cuadro de diálogo Comentarios avanzados para acceder a más opciones.

Ver

Muestra el archivo seleccionado con el comando Ver archivo.

Aplicar el mismo comentario para todos

Utiliza el mismo comentario a todos los archivos implicados en la operación Agregar archivos. Si esta casilla de verificación está desactivada, puede especificar un comentario diferente para cada archivo. El valor predeterminado es que esté activada (su comentario se aplicará a todos los archivos seleccionados para esta operación).

Recursiva

Indica que quiere agregar todos los archivos de las subcarpetas cuando selecciona toda una carpeta para agregar. Sólo está disponible cuando selecciona una carpeta y hace clic en Agregar.

Opciones avanzadas

Guardar sólo la última versión

Indica que no desea guardar versiones antiguas del archivo o los archivos que se agregan a la base de datos de VSS. VSS conserva un historial de archivo con los registros de cambios con comentarios. De todas formas, la versiones antiguas del archivo no se almacenan y, por tanto, no se pueden recuperar.

Nota Para incrementar el rendimiento y ahorrar espacio del disco, use esta opción cuando almacene programas ejecutables en VSS.

Desproteger inmediatamente

Desprotege el archivo justo después de agregarlo a VSS.

Quitar copia local

Elimina el archivo de la carpeta de trabajo después de agregarlo a VSS.

Tipo de archivo

Seleccione una opción del cuadro de lista.

  • Detección automática: VSS determina el tipo de archivo.

  • Binario: VSS trata al archivo como un archivo binario.

  • Texto: VSS trata al archivo como un archivo de texto.

Nota Al agregar una carpeta, el campo Tipos de archivo se pasa por alto. Sin embargo, los archivos agregados durante una operación de carpeta Agregar archivos se filtran mediante el valor de Máscaras relevantes de la ficha Tipos de archivo del cuadro de diálogo Opciones de SourceSafe.


Bifurcar (Comando, menú SourceSafe)

Vea también

Rompe un vínculo compartido mientras conserva una copia del archivo.

Nota En versiones anteriores de VSS, este comando se llamaba Separar.

Derechos de acceso

Debe disponer del derecho de acceso Agregar para utilizar este comando.

Comentarios

Un único archivo puede estar compartido por múltiples proyectos. Cualquier cambio realizado en ese archivo se refleja en todos los proyectos que lo comparte de forma que, por ejemplo, la propagación de solución de errores la controla VSS.

Tras aplicar el comando Bifurcar al archivo, existen dos bifurcaciones distintas del archivo en diferentes proyectos. Puede hacer un seguimiento de las diferentes bifurcaciones en la ficha Rutas de acceso del cuadro de diálogo Propiedades y agruparlas de nuevo con el comando Combinar bifurcaciones.

Opciones del cuadro de diálogo

Comentario

Escriba un comentario que describa la bifurcación.

Aceptar

Confirma el comando Bifurcar.

Cancelar

Cancela el comando Bifurcar.


Cancelar búsqueda (Comando, menú Ver)

Vea también

Restaura toda la lista de archivos en el Explorador de VSS para el proyecto actual. Este comando se utiliza tras una operación de búsqueda, que normalmente filtra la lista de archivos a un subconjunto más pequeño.

Derechos de acceso

Cualquier usuario de VSS puede utilizar este comando.

Comentarios

Cuando ejecuta el comando Buscar, VSS muestra la palabra Búsqueda en la barra de estado. Haga clic en el comando Cancelar búsqueda para volver a ver la presentación completa de archivos del Explorador de VSS. La palabra Búsqueda desaparece de la barra de estado.


Cambiar contraseña (Comando, menú Herramientas)

Vea también

Establece la contraseña del usuario actual.

Derechos de acceso

Cualquier usuario de VSS puede utilizar este comando.

Comentarios

Utilice el comando Cambiar contraseña para establecer su contraseña. Tras cambiarla, la contraseña anterior dejará de funcionar y deberá escribir la nueva cada vez que inicie una sesión de VSS.

Para cambiar su contraseña, primero debe saber cuál es. Si olvida su contraseña, pida al administrador de VSS que la cambie.

Nota Tenga en cuenta que la contraseña de VSS no implica que reemplace o aumente la contraseña del sistema operativo o de la red. Sólo cuando el sistema operativo no permite a VSS determinar la identificación del usuario, SourceSafe pide la contraseña de SourceSafe al iniciar la sesión. Su contraseña de VSS puede ser la misma o bien otra diferente de la del sistema operativo.

Opciones del cuadro de diálogo

Contraseña anterior

Escriba la contraseña actual o deje este cuadro en blanco si la contraseña está en blanco (una cadena de longitud cero).

Contraseña nueva

Escriba la contraseña nueva.

Una contraseña puede consistir en cualquier combinación de 1 a 15 caracteres válidos. A medida que los escribe, los caracteres se muestran como asteriscos. Las contraseñas de Microsoft VSS no distinguen entre mayúsculas y minúsculas.

Comprobar

Vuelva a escribir la nueva contraseña para comprobarla.


Proteger (Comando, menú SourceSafe)

Vea también

Actualiza VSS con los cambios realizados a un archivo desprotegido y desbloquea la copia maestra de VSS.

Nota En versiones anteriores de VSS, este comando se llamaba Actualizar.

Derechos de acceso

Debe disponer del derecho de acceso Desproteger para utilizar este comando.

Comentarios

Hay dos comandos que puede utilizar para terminar la desprotección de un archivo:

  • El comando Proteger copia los cambios a la base de datos de VSS, creando una versión nueva del archivo. Cuando otros usuarios utilicen el comando Obtener la última versión o desprotejan el archivo, recibirán todas las modificaciones que haya realizado.

  • El comando Deshacer desprotección permite anular todos los cambios y deshace la desprotección del archivo.

Al proteger un archivo, VSS proporciona un cuadro en el cual puede especificar un comentario.

Nota Para actualizar la copia maestra de un archivo mientras se conserva el archivo desprotegido, haga clic en la casilla de verificación Mantener desprotegido. Puede convertirlo en el comportamiento predeterminado si activa la casilla de verificación Mantener los archivos desprotegidos siempre de la ficha General en el cuadro de diálogo Opciones de SourceSafe.

Puede proteger un archivo que no haya cambiado, pero aún así agrega el archivo no cambiado como una nueva versión al historial de archivo. VSS le pregunta en este caso si desea realizar una operación de protección. Si hace clic en No, VSS ejecutará el comando Deshacer desprotección y no se agregará ninguna versión nueva a la lista de archivos.

Nota Para evitar este mensaje en futuras ocasiones, puede desactivar esta notificación en la ficha General del cuadro de diálogo Opciones de SourceSafe en el menú Herramientas.

Proteger desde múltiples desprotecciones

En una situación de desprotección múltiple, cuando es el primer usuario que protege el archivo en VSS, su versión del archivo se convierte en la versión más reciente. Sin embargo, si usted es el siguiente usuario que protege el archivo, VSS realizará una combinación automática, creando un nuevo archivo como versión más reciente en VSS.

VSS le informa que tuvo lugar una combinación. Puede proteger inmediatamente el archivo o conservar el archivo combinado en su carpeta de trabajo y revisarlo antes de devolverlo a VSS. Si hay conflictos de combinación no puede proteger el archivo hasta que resuelva los conflictos.

Opciones del cuadro de diálogo

Comentario

Escriba un comentario opcional. Los comentarios están limitados a 4095 caracteres.

Mantener desprotegido

Actualiza la copia maestra con sus cambios pero deja el archivo desprotegido.

Quitar copia local

Quita la copia local de su carpeta de trabajo.

Aceptar

Confirma la selección.

Cancelar

Cancela la selección.

Diferencias

Compara el archivo que desea proteger con la copia maestra de VSS y muestra las diferencias. Esta característica es útil si desea especificar un comentario adecuado al proteger el archivo.

Recursivo (sólo al proteger a nivel de proyecto)

Indica que desea proteger los archivos de todas las subcarpetas agregadas cuando seleccione proteger un proyecto completo.

Ignorar carpetas de trabajo (sólo al proteger a nivel de proyecto)

Modifica el conjunto de carpetas de trabajo a las que se aplica una operación recursiva. Esto es útil si tiene algunos archivos compartidos desprotegidos en más de un proyecto y desea protegerlos todos a la vez. Está disponible sólo cuando hace clic en la casilla de verificación Recursivo.


Desproteger (Comando, menú SourceSafe)

Vea también

Copia la versión más reciente de uno o más archivos seleccionados del proyecto actual a su carpeta de trabajo.

Derechos de acceso

Debe disponer del derecho de acceso Desproteger para utilizar este comando. Debe tener una carpeta de trabajo establecida antes de utilizar este comando.

Comentarios

El comando Desproteger recupera archivos editables de VSS y los coloca en su carpeta de trabajo, de forma que pueda modificarlos. VSS muestra el archivo como desprotegido en el Explorador de VSS.

Nota Hay una diferencia importante entre los comandos Desproteger y Obtener la última versión. El comando Obtener última versión coloca una copia de sólo lectura de un archivo en su carpeta e trabajo. Desproteger coloca en el directorio de trabajo una copia del archivo en la que se puede escribir.

Para devolver el archivo a VSS, puede utilizar el comando Proteger para confirmar los cambios y copiar el archivo local modificado a la base de datos de VSS.

Nota También puede utilizar el comando Deshacer desproteger. Deshacer desproteger no actualiza VSS. En su lugar, copia la versión más reciente del archivo en VSS sobre su copia local, de forma que todos los cambios realizados en la copia local desde la última vez que la desprotegió se pierden. Además, el comando Deshacer desprotección cancela la desprotección y quita la versión editable del archivo de la carpeta de trabajo. Para mostrar un cuadro de diálogo cuando utilice el comando Deshacer desprotección, utilice la ficha Cuadros de diálogo de comandos del cuadro de diálogo Opciones de SourceSafe en el menú Herramientas.

Generalmente, sólo un usuario puede tener un archivo desprotegido para modificación en un momento dado. Sin embargo, si el administrador de VSS permite desprotecciones múltiples, varios usuarios podrán desproteger el mismo archivo a la vez. Cuando el primer usuario proteja el archivo en VSS, ese archivo se convertirá en la versión actual. Cuando los siguientes usuarios protejan sus copias locales, sus cambios se combinarán en el archivo y se creará una nueva versión en VSS. Los archivos en formato binario sólo los puede desproteger una persona cada vez.

También puede desproteger elementos de forma exclusiva; es decir, desprotegerlos de forma que nadie más pueda desprotegerlos mientras usted tenga el archivo o el proyecto desprotegido. El administrador de VSS puede establecer una opción administrativa para desactivar desprotecciones múltiples en todo un proyecto todo el tiempo o usted puede desactivar la casilla de verificación de opción avanzada Permitir varias desprotecciones del diálogo del comando Desproteger para que sólo se pueda desproteger un archivo por sesión.

Opciones del cuadro de diálogo

Si tiene activada la casilla de verificación Desproteger a nivel de archivo en la ficha Cuadros de diálogo de comandos del cuadro de diálogo Opciones (menú Herramientas), el comando Desproteger muestra el cuadro de diálogo Desproteger, que tiene las siguientes opciones. Hay una opción Recursivo adicional si se activa también la casilla de verificación Desproteger a nivel de proyecto:

Comentario

Describa brevemente la razón por la que desprotege el archivo. Mientras el archivo esté desprotegido, la ficha Estado de desprotección muestra este comentario. El límite para los comentarios de desprotección es 63 caracteres.

En

Muestra la carpeta de trabajo a la cual VSS copia el archivo. De forma predeterminada, VSS copia el archivo con su propio nombre de archivo en su carpeta de trabajo. Sin embargo, puede especificar una carpeta y un nombre de archivo diferentes o hacer clic en Examinar para seleccionar una ubicación diferente en su árbol de carpetas.

Recursivo (sólo al desproteger a nivel de proyecto)

Desprotege el proyecto y todos sus subproyectos.

Generar árbol: ignora carpetas de trabajo (sólo al desproteger a nivel de proyecto)

Ignora la carpeta de trabajo establecida en los subproyectos implicados en una operación recursiva y genera el árbol de proyecto que refleja la organización del proyecto en su equipo local. Se pasa por alto la configuración de carpeta de trabajo para los subproyectos individuales. Está disponible sólo cuando hace clic en la casilla de verificación Recursivo.

No obtener copia local

Indica a VSS que no copie el archivo a su carpeta de trabajo. VSS registra que el archivo se ha desprotegido, pero no escribe una nueva copia en la carpeta de trabajo.

Opciones avanzadas

También puede establecer los valores predeterminados para las tres primeras opciones de la ficha Archivos locales del cuadro de diálogo Opciones de SourceSafe (menú Herramientas).

Permitir varias desprotecciones

Permite que varios usuarios desprotejan simultáneamente este archivo o proyecto. Si hay otro usuario que ya tiene este archivo desprotegido, la casilla de verificación estará activada pero sin marca de verificación. Si se han desactivado las desprotecciones múltiples para este proyecto, la casilla de verificación estará desactivada y sin marca de verificación. Cuando se ha desprotegido en modo exclusivo un archivo o un proyecto, el icono del Explorador de VSS para dicho elemento está rodeado por un recuadro rojo.

Reemplazar modificable

Determina cómo se comporta VSS cuando intenta desproteger un archivo que ya está marcado como editable en la carpeta de trabajo. Seleccione una de las posibilidades siguientes en el cuadro de lista:

  • Preguntar. Le pregunta qué hacer cuando se encuentre una versión editable de un archivo.

  • Reemplazar. Reemplaza el archivo editable con una versión de sólo lectura.

  • Saltar. No realiza la operación de desprotección para el archivo editable. Se muestra un error en la ventana Resultados, si está abierta.

  • Combinar. Combina los cambios entre el archivo editable y el que está desprotegiendo ahora. Si el archivo no puede combinarse (por ejemplo, es un archivo binario), se salta la operación de desprotección para ese archivo y se muestra un error en la ventana Resultados, si está abierta.

  • Predeterminado. Utiliza los valores predeterminados de la ficha Archivos locales o los heredados de un proyecto primario. No puede establecer esta opción; se utiliza automáticamente cuando se seleccionan explícitamente (en la lista de archivos) o implícitamente (activando Recursivo) múltiples archivos.

Establecer hora de archivo

Cambia la fecha asociada a la operación de desprotección. Seleccione una de las posibilidades siguientes en el cuadro de lista: hora actual, hora de la última modificación del archivo, hora de la última protección del archivo o la hora predeterminada (establecida en la ficha Archivos locales).

Mostrar sólo cuando se presiona Máyus

Salta este cuadro de diálogo durante operaciones de desprotección futuras y, de forma predeterminada. utiliza la configuración que ha especificado. Para restaurar el cuadro de diálogo, desactive la casilla de verificación correspondiente en la ficha Diálogos de comandos del cuadro de diálogo Opciones de SourceSafe. Si presiona la tecla MAYÚSCULAS al hacer clic en el comando Desproteger se muestra este cuadro de diálogo, sin tener en cuenta la configuración de la ficha Cuadros de diálogo de comandos.


Comprobar hipervínculos (Comando, menú Web)

Vea también

Le permite comprobar los vínculos Web en los archivos HTML.

Derechos de acceso

Debe tener el derecho de acceso Escribir para utilizar este comando.

Comentarios

Puede utilizar este comando para comprobar los vínculos del Web en los archivos HTML, tanto los archivos que se encuentren en la carpeta de trabajo como los que estén en un proyecto de VSS. VSS sólo comprueba los vínculos que saltan a otros archivos del proyecto; los vínculos con páginas externas no se comprueban.

Se comprueban los vínculos identificados con las etiquetas <A HREF>, <IMG SRC> y <OPTION VALUE> de HTML, así como dentro de los archivos .MAP (para las zonas activas de una imagen). No se comprueban los vínculos con otras direcciones del Web creados mediante código como VBScript o Java.

Cuando ha terminado la comprobación de vínculos, VSS presenta un cuadro de diálogo con tres cuadros de lista. El cuadro superior presenta una lista con todos los archivos en los que se encontraron errores. El cuadro del centro muestra los vínculos internos (saltos a otros archivos dentro del mismo proyecto Web) que parecen no ser válidos en el archivo seleccionado en el cuadro superior y el cuadro inferior muestra los vínculos externos que se han encontrado pero no han sido comprobados.


Crear proyecto (Comando, menú Archivo)

Vea también

Crea un nuevo subproyecto bajo el proyecto seleccionado actualmente.

Derechos de acceso

Debe disponer del derecho de acceso Agregar en el proyecto primario para utilizar este comando.

Comentarios

Utilice el comando Crear proyecto para crear un subproyecto bajo el proyecto actual de VSS. El subproyecto está vacío hasta que coloque archivos u otros subproyectos en él. Todos los derechos de usuario que tenga en el proyecto primario se propagan al proyecto recién creado.

Opciones del cuadro de diálogo

Proyecto

Escriba un nombre para el nuevo proyecto.

Comentario

Escriba una breve descripción del proyecto.


Crear mapa de sitios (menú Web)

Vea también

Le permite crear automáticamente un mapa de los archivos HTML que se encuentran en un proyecto Web.

Derechos de acceso

Debe tener el derecho de acceso Escribir para utilizar este comando.

Comentarios

Los mapas de sitios cada vez son más populares como métodos de exploración a través de un sitio Web. Este comando le permite generar fácilmente una lista de los archivos HTML que hay en su proyecto Web y crea la lista como un archivo HTML que se vincula a cada archivo. Con una mínima personalización, podrá agregar el archivo resultante a su sitio Web y proporcionar a sus usuarios un método de exploración clásico.

Cada vez que ejecute este comando se creará un archivo totalmente nuevo. Es decir, este comando no compara el material nuevo con el antiguo y únicamente realiza cambios. Por tanto, si ha agregado alguna personalización al archivo de mapa de sitios resultante, debe estar preparado para agregarlo de nuevo cada vez que ejecute este comando o para utilizar tecnología como archivos de inclusión en el lado del servidor para almacenarlo en un lugar aparte. Además, el código HTML generado por este comando es bastante rudimentario (etiquetas de HTML 2.0). Si desea una página más personalizada, puede cortar y pegar a partir del código HTML proporcionado por este comando o agregar etiquetas HTML al archivo para que quede mejor en su sitio Web.

El comando Crear mapa de sitios funciona obteniendo los títulos de los archivos HTML a partir de su etiqueta <TITLE>. Si tiene un archivo HTML sin una etiqueta <TITLE>, VSS utilizará su nombre de archivo. Para generar un buen mapa de sitios, debe utilizar cadenas únicas y descriptivas en las etiquetas <TITLE> de sus archivos. Los nombres de categorías del mapa de sitios proceden del nombre del proyecto de VSS. Por tanto, es importante utilizar nombres de proyectos buenos y descriptivos en los proyecto de sitios Web.

Una vez creado el archivo de mapa de sitios HTML, puede agregarlo a su proyecto mediante el comando Agregar archivos. Si agrega el archivo a su proyecto de sitio Web, no olvide desprotegerlo antes de ejecutar el comando Crear mapa de sitios.

A modo de ejemplo, considere un proyecto Web externo como el siguiente:

Si ejecuta Crear mapa de sitios en el proyecto Web externo se creará un archivo HTML cuya apariencia será igual a la de éste en un explorador Web:

Usando este HTML:

Por supuesto, en este momento puede personalizar el código HTML para lograr una apariencia del mapa de sitios que le satisfaga; utilice un color o un diseño de fondo diferente, cambie los niveles de sangría, elimine o agregue elementos, etc. Una forma de personalizar el mapa de sitios consiste en cambiar los archivos gráficos utilizados para los iconos de la carpeta y del archivo. Para obtener más información acerca de cómo hacerlo, vea las variables de inicialización IMG_Folder e IMG_File.


Personalizar barra de herramientas (Comando, menú Herramientas)

Vea también

Agrega o elimina botones en la barra de herramientas de VSS.

Derechos

Cualquier usuario de VSS puede utilizar este comando.

Comentarios

Para agregar un botón a la barra de herramientas, en el menú Herramientas, elija Personalizar la barra de herramientas. En el cuadro de diálogo Personalizar la barra de herramientas, seleccione el botón de la barra de herramientas que desee en el área de Botones disponibles y después haga clic en Agregar para moverlo al área Botones de la barra de herramientas. Para eliminar un botón, seleccione el botón de la barra de herramientas que desee dentro del área Botones de la barra de herramientas y después haga clic en Quitar para desplazarlo al área de Botones disponibles.

Después de que un botón esté en la barra de herramientas, puede arrastrarlo a una nueva ubicación del cuadro de diálogo para moverlo a una nueva posición en la barra de herramientas.

Opciones del cuadro de diálogo

Agregar

Mueve un botón seleccionado desde la lista Botones disponibles a la lista Botones de la barra de herramientas (es decir, lo agrega a la barra de herramientas).

Quitar

Mueve un botón seleccionado desde la lista Botones de la barra de herramientas a la lista Botones disponibles (es decir, lo quita de la barra de herramientas).

Restablecer

Restablece la barra de herramientas a su configuración predeterminada.

Cerrar

Cierra el cuadro de diálogo Personalizar barra de herramientas.

Subir

Mueve un botón hacia arriba dentro de la lista Botones de la barra de herramientas y lo desplaza hacia la izquierda dentro de la barra de herramientas del Explorador de VSS.

Bajar

Mueve un botón hacia abajo dentro de la lista Botones de la barra de herramientas y lo desplaza hacia la derecha en la barra de herramientas del Explorador de VSS.


Eliminar (Comando, menú Archivo)

Vea también

Elimina un archivo o un proyecto.

Nota En versiones anteriores de VSS, este comando se llamaba Quitar.

Derechos de acceso

Debe disponer del derecho de acceso Agregar para utilizar este comando.

Comentarios

Si no activa la casilla de verificación Destruir definitivamente del cuadro de diálogo Eliminar, el comando Eliminar es reversible; para hacer posible la recuperación, VSS almacena todo archivo o subproyecto eliminado.

Para recuperar el archivo, utilice el comando Recuperar. Otra forma de recuperar el archivo (si no se ha purgado o destruido) es volver a una versión anterior del proyecto que contiene el archivo.

Nota Al eliminar un proyecto, todos sus subproyectos y los archivos contenidos en ellos se eliminan también. Al recuperar el proyecto, se recuperan sus subproyectos (y los archivos que contienen).

Un archivo o un subproyecto eliminado se puede purgar o destruir, lo cual lo quita de forma permanente.

Opciones del cuadro de diálogo

Elemento

Nombre del archivo o subproyecto que desea eliminar.

Destruir definitivamente

Si hace clic en esta casilla de verificación se quita el archivo o el subproyecto de forma que no pueda recuperarse posteriormente. Es lo mismo que ejecutar el comando Purgar sobre los elementos. Debe disponer del derecho de acceso Destruir para activar esta casilla de verificación.

Precaución El comando Destruir debe utilizarse con extrema precaución. Antes de utilizarlo, debe asegurarse de que jamás necesitará el archivo o el proyecto, o ninguna de sus versiones anteriores, por ninguna razón.

Si hay alguna razón por la cual podría desear recuperar versiones anteriores del proyecto que contenía el archivo, elimine el archivo sin destruirlo; en este caso puede recuperar el archivo más tarde con el comando Recuperar.


Distribuir (Comando, menú Web)

Vea también

Le permite distribuir un conjunto de archivos Web en un servidor Web o en varios servidores Web. Este comando sólo funciona con proyectos, no con archivos.

Derechos de acceso

Debe disponer del derecho de acceso Destruir para utilizar este comando.

Comentarios

Una vez terminado el desarrollo y la comprobación de sus páginas Web, el comando Distribuir se utiliza para copiar los archivos al servidor Web activo. La ubicación de dicho servidor es una carpeta o un sitio FTP especificado por el administrador de VSS. Cuando elija el comando Distribuir, se copiará el contenido del proyecto actual a dicha ubicación.

En muchos aspectos, el comando Distribuir se comporta igual que el comando Obtener: copia archivos de un proyecto de VSS a una carpeta local. Sin embargo, Obtener realiza una copia para su uso personal, mientras que Distribuir hace el proyecto público, potencialmente para todo el mundo. Por este motivo, el comando Distribuir requiere privilegios del nivel de Destruir en el proyecto seleccionado.

El administrador de VSS tiene que establecer una ruta de acceso para la distribución en la ficha Sitios Web del cuadro de diálogo Opciones (menú Herramientas del Administrador) para activar este comando. Sólo puede distribuir un proyecto completo marcado como un proyecto de sitio Web, pero no archivos individuales. La carpeta de distribución puede ser un conjunto de lugares delimitados por una coma a donde desea que se copien sus archivos.

Al utilizar el comando Distribuir sobreescribirá los archivos ya existentes con el mismo nombre en la carpeta de distribución, incluso si la casilla de verificación Reemplazar archivos modificables de la ficha Archivos locales (cuadro de diálogo Opciones del menú Herramientas) está establecida a Saltar.

Observe que este comando es útil en varias situaciones no necesariamente relacionadas con la distribución de sitios Web. Por ejemplo, si ha seleccionado un conjunto de archivos .DOC de especificación del producto que desee publicar en un servidor público.


Editar archivo (Comando, menú Edición)

Vea también

Le permite modificar un archivo controlado de origen asegurándose de que está desprotegido para después abrir el archivo en el editor asociado.

Derechos de acceso

Debe tener el permiso Escribir para utilizar este comando.

Comentarios

Cuando selecciona Editar archivo, lo primero que hace VSS es comprobar que lo ha desprotegido. Si no lo ha hecho, le desprotegerá el archivo, a no ser que algo lo impida, como que el archivo ya esté desprotegido por otro usuario (cuando el administrador de VSS no haya activado varias desprotecciones para ese proyecto).

Tras desprotegerle el archivo, VSS abre el archivo. Es posible seleccionar un editor al hacer clic en el botón Avanzadas del cuadro diálogo Archivo.

La selección del editor predeterminado se establece de una de las formas siguientes, en el orden siguiente:

  1. VSS busca en sus archivos de inicialización una línea con la extensión del archivo que se está viendo.

  2. VSS utiliza el Explorador de Microsoft Windows (la base de datos de registro y WIN.INI) para asociar una aplicación con la extensión de archivo.

  3. VSS busca su entrada en Editor para ver archivos de la ficha General del cuadro de diálogo Opciones de SourceSafe.

  4. Si VSS no puede determinar una asociación para el archivo después de haber utilizado estos métodos, mostrará el archivo con su propio editor.

Nota Si no se puede encontrar ningún editor para un tipo determinado de archivo, el archivo permanecerá desprotegido para usted en su carpeta de trabajo, por lo que podrá abrirlo con normalidad en el editor que desee.

También puede establecer el comportamiento de doble clic de VSS en la ficha General del cuadro de diálogo Opciones del menú Herramientas. Si establece la opción Doble clic en un archivo a Modificar archivo, podrá hacer doble clic en un archivo en VSS para modificarlo. De todas formas, se recomienda la opción Preguntar (para evitar que escriba accidentalmente sobre un archivo local durante la operación de desprotección).


Informe de archivos (Comando, menú Herramientas)

Crea un informe con formato del proyecto actual e información de archivo que puede enviar al Portapapeles, a un archivo o a una impresora.

Derechos de acceso

Debe disponer del derecho de acceso Leer para utilizar este comando.

Comentarios

Puede preparar un informe que contenga una relación de todos los archivos del proyecto actual. (El informe incluye sólo los archivos y subproyectos que están actualmente en el proyecto, no los archivos o subproyectos eliminados.) El comando Informe de archivos es útil para proyectos grandes para los cuales el Explorador de VSS puede que no sea capaz de mostrar todos los nombres de archivo en la pantalla de una vez.

Nota Las opciones del cuadro de diálogo varían dependiendo de si tiene un archivo o un proyecto seleccionado en el Explorador de VSS.

Opciones del cuadro de diálogo

Todos los archivos mostrados (sólo disponible cuando hay un archivo seleccionado)

Incluye todos los archivos mostrados en el panel de archivos del Explorador de VSS.

Archivos seleccionados (sólo disponible cuando hay un archivo seleccionado)

Crea un informe sólo con los archivos seleccionados.

Recursivo (sólo disponible cuando hay un proyecto seleccionado)

Crea un informe que incluye información de los subproyectos del proyecto actual.

Incluir archivos (sólo disponible cuando hay un proyecto seleccionado)

Crea un informe que incluye los nombre de los archivos que forman parte del proyecto.

Sólo nombres de archivos

Crea un informe que incluye sólo los nombres de archivo. Si este cuadro no está activado, el informe de archivo incluirá cuatro columnas en lugar de mostrar sólo una para el nombre de archivo. Las cuatro columnas son Nombre de archivo, Nombre de usuario, Fecha y hora y Carpeta de desprotección (como en el Explorador de SourceSafe). La columna Nombre de archivo acepta nombres de archivo largos, los cuales pueden ajustarse a la columna como sea necesario.

Imprimir en

  • Impresora: Envía el informe a una impresora.

  • Archivo: Envía el informe al cuadro de diálogo Archivo.

  • Portapapeles: Coloca el informe en el Portapapeles.

Aceptar

Confirma la selección.

Cancelar

Cancela el informe.

Vista previa

Muestra una presentación previa del informe.


Buscar en archivos (Comando, menú Herramientas)

Vea también

Busca todas las instancias de una cadena de caracteres especificada dentro de uno o más archivos.

Derechos de acceso

Debe disponer del derecho de acceso Leer para utilizar este comando.

Comentarios

Utilice el comando Buscar en archivos para mostrar una lista de todas las ocurrencias de una cadena de caracteres en los archivos de VSS que especifique. Puede utilizar el comando en un único archivo o en un proyecto completo.

Hay tres caracteres comodín que puede utilizar en una cadena de búsqueda, a menos que se active Coincidencias exactas:

  • Un signo de interrogación coincide con cualquier carácter.

  • Un asterisco coincide con cualquier cadena.

  • Una barra inversa hace literal el carácter que hay a continuación de ella: y \\. Esto es necesario si desea buscar asteriscos, signos de interrogación o barras inversas.

Normalmente, VSS distingue entre mayúsculas y minúsculas; es decir, "A" no es igual que "a". Para hacer que el comando Buscar en archivos distinga entre mayúsculas y minúsculas, haga clic en Coincidir mayúsculas y minúsculas.

El resultado de la búsqueda se muestra en una ventana Resultados. En la parte superior de esta ventana, VSS muestra una lista de todos los archivos que contienen coincidencias. En la parte inferior, VSS muestra las cadenas que coincide en archivo seleccionado actualmente. A medida que se desplaza por la lista de la parte superior, la parte inferior muestra los cambios para reflejar el cambio de selección de archivo.

Opciones del cuadro de diálogo

Elemento

Escriba el nombre del archivo o archivos en los que desea que VSS busque.

Cadena

Escriba la cadena de caracteres que desea que encuentre VSS.

Coincidir mayúsculas y minúsculas

Buscar sólo coincidencias exactas. La cadena que introduzca no puede contener caracteres comodín.

Usar expresiones normales

Active la casilla si utiliza un signo asterisco como parte de una búsqueda por comodines dentro del texto. Desactívela si utiliza el signo asterisco como un carácter de texto normal.

Recursivo (sólo a nivel de proyecto)

Busca en todos los archivos del proyecto y los de sus subproyectos.

Mostrar por separado todos los archivos compartidos (sólo a nivel de proyecto)

En búsquedas de proyecto, anota cada coincidencia encontrada en un archivo compartido como un elemento separado. (De forma predeterminada, una coincidencia en un archivo compartido se cita sólo para uno de los proyectos en los que existe el archivo.)


Obtener la última versión (Comando, menú SourceSafe)

Vea también

Recupera una copia de sólo lectura de los elementos seleccionados de VSS. Para obtener la versión más reciente, haga clic en Obtener la última versión en el menú SourceSafe. Para obtener una versión más antigua, haga clic en Obtener en el cuadro de diálogo Historial de archivo o Historial de proyecto.

Derechos de acceso

Debe disponer del derecho de acceso Leer para utilizar este comando. Debe tener una carpeta de trabajo establecida antes de utilizar este comando.

Comentarios

El comando Obtener la última versión recupera la versión más reciente de un archivo, un grupo de archivos o un proyecto completo de VSS y crea copias de sólo lectura para ver o compilar en su carpeta de trabajo.

Nota Puede elegir una carpeta de trabajo diferente para la operación Obtener actual si escribe una nueva ruta de acceso en el cuadro de diálogo Obtener la última versión. Haga clic en Examinar para desplazarse y elegir su carpeta.

La obtención de un archivo no reemplaza el archivo que ha desprotegido actualmente en su carpeta de trabajo, a menos que establezca la opción avanzada Reemplazar.

Resultado de una operación Obtener

Utilizar el comando Obtener la última versión tiene cuatro resultados posibles:

  • Si el archivo que está recuperando no se encuentra ya en su carpeta de trabajo, VSS simplemente obtiene el archivo.

  • Cuando el archivo de la carpeta de trabajo es idéntico al archivo que está recuperando, VSS no lo recupera o modifica de ninguna forma.

  • Cuando el archivo de la carpeta de trabajo es diferente de la copia maestra de VSS y su copia local es de sólo lectura, VSS reemplaza su copia local.

  • Cuando el archivo de la carpeta de trabajo no es de sólo lectura, VSS asume que tiene el archivo desprotegido y no lo reemplaza. Puede cambiar el comportamiento de VSS en este caso con la opción Reemplazar archivos modificables de la ficha Archivos locales del cuadro de diálogo Opciones.

Combinar con el comando Obtener la última versión

En una situación de desprotección múltiple, puede utilizar el comando Obtener la última versión para recuperar los cambios de otros usuarios antes de proteger su versión del archivo. Puede indicar a VSS que combine los cambios en la copia local del archivo o puede especificar que desea comprobar cada cambio antes de permitir la combinación. Para ello, establezca la opción Reemplazar archivos modificables a Combinar en la ficha Archivos locales del cuadro de diálogo Opciones de SourceSafe.

Opciones del cuadro de diálogo

Si activa el cuadro de diálogo del comando Obtener la última versión en la ficha Cuadros de diálogo de comandos del cuadro de diálogo Opciones de SourceSafe (menú Herramientas) o presiona la tecla MAYÚSCULAS al hacer clic en el comando Obtener la última versión, tiene las siguientes opciones:

En

Escriba la ruta de acceso en la que desea que VSS coloque los archivos.

Recursivo (sólo al Obtener a nivel de proyecto)

Obtiene un proyecto, todos los archivos del proyecto y sus subproyectos. Se copia cada archivo de un subproyecto a su propia carpeta de trabajo, que puede ser una carpeta situada en cualquier lugar de su equipo o de un equipo accesible remoto. Para invalidar la configuración de la carpeta de trabajo y crear una estructura de archivos idéntica a la estructura del proyecto de SourceSafe, utilice la opción Generar árbol.

Generar árbol: ignora carpetas de trabajo (sólo al Obtener a nivel de proyecto)

Invalida la carpeta de trabajo establecida para los subproyectos implicados en una operación recursiva y genera en su equipo local un árbol de proyecto que refleja la organización del proyecto. Se pasa por alto la configuración de carpeta de trabajo para los subproyectos individuales. Está disponible sólo cuando hace clic en la casilla de verificación Recursivo.

Crear modificable

Establece el indicador de lectura-escritura de forma que el archivo sea editable. No es el comportamiento predeterminado, pero puede resultar útil si desea probar un cambio temporal en el archivo o desea cambiar el nombre del archivo después de obtenerlo.

Opciones avanzadas

También puede establecer los valores predeterminados para las tres primeras opciones avanzadas de la ficha Archivos locales del cuadro de diálogo Opciones de SourceSafe (menú Herramientas).

Establecer hora de archivo

Cambia la hora asignada a la operación de obtención. Seleccione una de las posibilidades siguientes en el cuadro de lista: hora actual, hora de la última modificación del archivo, hora de la última protección del archivo o la hora predeterminada (establecida en la ficha Archivos locales).

Reemplazar modificable

Determina cómo se comporta VSS cuando intenta obtener un archivo que ya está marcado como editable en su carpeta de trabajo. Seleccione una de las posibilidades siguientes en el cuadro de lista:

  • Preguntar. Le pregunta qué hacer cuando se encuentre una versión editable de un archivo.

  • Reemplazar. Reemplaza el archivo editable con una versión de sólo lectura.

  • Saltar. Salta la operación de obtención para el archivo editable. Se muestra un error en la ventana Resultados, si está abierta.

  • Combinar. Combina los cambios entre el archivo desprotegido y el que está obteniendo. Si el archivo no puede combinarse (por ejemplo, si es un archivo binario), la operación de obtención se salta para ese archivo y se muestra un error en la ventana Resultados, si está abierta.

  • Predeterminado. Utiliza los valores predeterminados de la ficha Archivos locales o los heredados de un proyecto primario.

Mostrar sólo cuando se presiona Máyus

Salta este cuadro de diálogo durante futuras operaciones de obtención y utiliza la configuración que ha introducido como predeterminada. Para restaurar el cuadro de diálogo, desactive la casilla de verificación correspondiente en la ficha Diálogos de comandos del cuadro de diálogo Opciones de SourceSafe. Si presiona la tecla MAYÚSCULAS al hacer clic en el comando Obtener la última versión se muestra este cuadro de diálogo, sin tener en cuenta la configuración de la ficha Cuadros de diálogo de comandos.


Invertir selección (Comando, menú Edición)

Selecciona todos los archivos no seleccionados actualmente y anula la selección de los seleccionados actualmente.

Derechos de acceso

Cualquier usuario de VSS puede utilizar este comando.

Comentarios

El comando Invertir selección invierte el estado de selección de cada archivo mostrado actualmente en la lista de archivos del Explorador de VSS. El comando puede ser muy útil cuando ha realizado una operación sobre todos los archivos seleccionados y desea realizar otras sobre los archivos restantes.


Etiqueta (Comando, menú Archivo)

Vea también

Asigna una etiqueta a la versión especificada o a la versión actual de un archivo o un proyecto.

Derechos de acceso

Debe disponer del derecho de acceso Agregar para utilizar este comando.

Comentarios

Cada versión de un archivo tiene un número de versión y una fecha y hora, y puede recuperarse por referencia a cualquiera de ellas. Para facilitar la identificación de una versión, puede asignarle una etiqueta (cualquier cadena de hasta 31 caracteres de longitud) y referirse a la versión por su etiqueta.

Con el comando Etiqueta se crea la nueva versión del archivo o proyecto seleccionado y la etiqueta se asocia a esa versión.

Nota Para cambiar la etiqueta de una versión anterior, cuando un archivo se selecciona en el panel de archivos del Explorador de VSS, en el menú Herramientas, haga clic en Mostrar historial y después haga clic en Detalles.

Al modificar una etiqueta en el cuadro de diálogo Detalles de historial, está asignando una etiqueta a una versión ya existente del elemento especificado.

Si desea identificar una determinada versión de un proyecto de forma que pueda volver a ella, no asigne una etiqueta a cada archivo del proyecto; mejor asigne la etiqueta al propio proyecto. Incluso si agrega, elimina y cambia el nombre de los archivos en el futuro, VSS puede restaurar exactamente esa versión del proyecto basándose en la etiqueta del proyecto.

Opciones del cuadro de diálogo

Elemento

Nombre del archivo o el proyecto.

Etiqueta

Escriba una etiqueta de hasta 31 caracteres de longitud.

Comentario

Escriba un comentario opcional.


Combinar bifurcaciones (Comando, menú SourceSafe)

Vea también

Copia todos los cambios realizados en una bifurcación de un archivo a otra bifurcación. Sólo funciona con archivos, no con proyectos.

Derechos de acceso

Debe disponer del derecho de acceso Desproteger en el proyecto en el que está combinando y el derecho de acceso Leer en el proyecto desde el que está combinado para utilizar este comando. Debe tener una carpeta de trabajo establecida antes de utilizar este comando.

Comentarios

La combinación copia los cambios realizados en un archivo a otro archivo diferente (en otra ruta de desarrollo distinta) en VSS. Si la combinación genera conflictos, VSS desprotege el archivo en su carpeta de trabajo si no está ya desprotegido. Entonces puede modificar el archivo y resolver cualquier conflicto antes de volver a proteger el archivo en VSS.

Por ejemplo, el proyecto $/Newapp actualmente está funcionando con la versión 5. El equipo de desarrollo ha empezado a trabajar con la versión 6, cuando de repente un cliente muy importante informa de un error muy grave en la versión 5. El proyecto Newapp se bifurcará a partir de ese punto para que el equipo de desarrollo pueda continuar trabajando en la versión 6 mientras un equipo de emergencia trabaja en la reparación del error de la versión 5 (quizás su proyecto se llame $/Solucerror). Antes del punto de bifurcación, los proyectos son idénticos, pero a partir del punto de bifurcación, el código de cada proyecto es distinto.

Justo antes de que se publique la versión 6, el equipo que está resolviendo el error anuncia que ya lo ha arreglado. Usted decide combinar su código en el proyecto Newapp, con lo que la versión 6 de su producto tendrá el fallo resuelto. Para ello, seleccione un archivo cada vez en el proyecto Newapp y elija el comando Combinar bifurcaciones.

Después de la operación de combinación, todavía tiene dos rutas de desarrollo independientes, pero los cambios realizados en $/Solucerror se han copiado a $/Newapp. Antes de elegir el comando Combinar bifurcaciones, compruebe que ha seleccionado el archivo al cual desea combinar los cambios. (El archivo a partir del cual está combinando los cambios permanecerá inalterado.)

Nota No puede combinar archivos binarios.

Opciones del cuadro de diálogo

Proyectos

Seleccione el proyecto en el cual desee combinar su archivo. La columna Versiones muestra los números de las versiones que va a combinar.

Combinar

Combina la bifurcaciones.

Cancelar

Cancela la combinación de bifurcaciones.

Vínculos

Muestra todos los proyectos con los cuales el archivo posee vínculos compartidos.


Microsoft en el Web (Comando, menú Ayuda)

Abre Microsoft Internet Explorer (o su explorador de Web configurado) en uno de los diversos sitios Web de Microsoft.

Visite el sitio Web de VSS en la dirección http://www.microsoft.com/spain/ssafe.

Derechos de acceso

Cualquier usuario de VSS puede utilizar este comando.


Mover proyecto (Comando, menú Archivo)

Vea también

Coloca un subproyecto de un proyecto primario en otro.

Derechos de acceso

Debe disponer del derecho de acceso Agregar en el proyecto primario al cual se va a mover y el derecho de acceso Destruir en el proyecto primario desde el que se va a mover para utilizar este comando.

Comentarios

El comando Mover proyecto vuelve a definir la ruta de un subproyecto. Por ejemplo, si el proyecto toolmanager existe bajo $/Joe y lo mueve a $/apps, su nuevo nombre completo será $/apps/toolmanager.

Este comando no cambia el nombre de un proyecto y no cambia su contenido ni su historial. Afecta a los historiales de los proyectos primarios antiguos y nuevos.

Tras mover un proyecto, no puede reconstruir una versión anterior de su proyecto primario original. En el ejemplo anterior, cualquier intento de utilizar el comando Obtener la última versión de forma recursiva para recuperar una versión de $/Joe que existía antes de que moviera el proyecto Toolmanager genera una advertencia de que Toolmanager se ha movido y no está disponible.

Nota No puede mover archivos individuales con el comando Mover proyecto. En cambio, para mover un archivo, comparta el archivo con el nuevo proyecto primario y después elimine o destruya el archivo en el proyecto original. El historial del archivo se conserva.

Opciones del cuadro de diálogo

Para mover un proyecto, seleccione primero dicho proyecto en el Explorador de VSS. Después, seleccione la nueva ubicación del proyecto desde este cuadro de diálogo y haga clic en Aceptar.

A

Seleccione la ruta de acceso de un proyecto al que va a mover el subproyecto.

Aceptar

Mueve el proyecto seleccionado a la nueva ubicación.

Cancelar

Cancela la operación de traslado.


Opciones (Comando, menú Herramientas)

Vea también

Le permite personalizar su entorno VSS.

Derechos de acceso

Cualquier usuario de VSS puede utilizar este comando.

Comentarios

Haga clic en la ficha que contiene la información que desea. Cada ficha contiene grupos de opciones que puede establecer para personalizar VSS.

Fichas del cuadro de diálogo

General

Le permite establecer opciones generales aplicables a una serie de comandos de VSS.

Archivos locales

Configura los archivos de la carpeta de trabajo y cómo se tratan durante el funcionamiento de diferentes comandos.

Ver

Establece opciones de presentación, como mostrar o no la barra de herramientas o la barra de estado, y opciones de la lista de archivo.

Diferencias

Le permite especificar opciones para ver diferencias entre archivos y proyectos. Estas opciones se utilizan en otros cuadros de diálogo de VSS como el cuadro de diálogo Diferencias de proyecto y Combinación visual.

Cuadros de diálogo de comandos

Configura la presentación de cuadros de diálogo intermedios relacionados con varios comandos de VSS. Estos cuadros de diálogo intermedios suelen presentar opciones adicionales.

Advertencias

Determina cuándo se muestran los mensajes de advertencia.

Tipos de archivo

Establece cómo se determina la información sobre el tipo de archivo.

Opciones de línea de comandos

Personaliza el funcionamiento de los comandos de la línea de comandos.


Propiedades (Comando, menú Archivo)

Vea también

Muestra el cuadro de diálogo Propiedades, que contiene información básica acerca de un archivo o un proyecto de VSS, incluyendo el tamaño, nombre y tipo.

Derechos de acceso

Debe disponer del derecho de acceso Leer para ver el cuadro de diálogo Propiedades.

Debe disponer del derecho de acceso Agregar para cambiar el tipo de un archivo.

Debe disponer del derecho de acceso Destruir para cambiar el estado de Almacenar sólo la última versión de un archivo.

Comentarios

Haga clic en la ficha que contiene la información que desea. El contenido de la ficha varía dependiendo si un archivo o un proyecto está seleccionado actualmente en el Explorador de VSS.

Nota Haga clic en el botón Informe de cualquiera de las fichas para crear un informe para enviarlo al Portapapeles, a un archivo de texto o a una impresora.

Fichas del cuadro de diálogo Propiedades de archivo

General

Muestra el nombre de archivo, su tipo, tamaño el número de la versión más reciente, la fecha de la última modificación, el comentario, además de indicar si todo el historial del archivo (o sólo la última versión) está almacenado en la base de datos de SourceSafe. Puede cambiar el comentario y establecer que se almacene sólo la última versión del archivo para ahorrar espacio de disco. Aquí también puede modificar el tipo de archivo.

Estado de desprotección

Muestra el nombre del archivo, quién lo ha desprotegido (si lo ha desprotegido alguien), si está desprotegido de forma exclusiva, cuando fue desprotegido, la versión que está desprotegida, el ordenador para el que está desprotegido la ruta de desprotección, el proyecto en el que está el archivo y el comentario de desprotección. Puede modificar el comentario de desprotección.

Vínculos

Muestra los vínculos compartidos actuales que tiene un archivo con otros proyectos.

Rutas de acceso

Muestra los proyectos que han bifurcado versiones de este archivo anteriormente.

Fichas del cuadro de diálogo Propiedades del proyecto

General

Muestra el nombre del proyecto actual, el número de archivos y subproyectos que contiene, el número de versión más reciente, cuándo se cambió por última vez, si el proyecto está escondido y el comentario del proyecto. Puede cambiar el comentario.

Elementos eliminados

Muestra los archivos que se han eliminado del proyecto desde la última vez que se agregó a VSS. Utilice este cuadro de diálogo para recuperar o purgar un archivo eliminado.


Actualizar la lista de archivos (Comando, menú Ver)

Vea también

Actualiza la lista de archivos del Explorador de VSS.

Derechos de acceso

Cualquier usuario de VSS puede utilizar este comando.

Comentarios

Actualiza sólo la lista de archivos, no la lista de proyectos. Para actualizar ambas listas, contraiga la lista de proyectos a un proyecto primario y después haga doble clic en ese proyecto para expandir la lista de proyectos.

También puede actualizar la lista de archivos automáticamente. Configure el periodo de actualización con la opción Actualizar automáticamente la lista de archivos en la ficha Ver del cuadro de diálogo Opciones de SourceSafe (menú Herramientas).


Cambiar nombre (Comando, menú Archivo)

Vea también

Cambia el nombre de un archivo o un proyecto.

Derechos de acceso

Debe disponer del derecho de acceso Agregar para utilizar este comando.

Comentarios

Para utilizar el comando Cambiar nombre, seleccione el archivo o el proyecto cuyo nombre desee modificar y después elija el comando. Posteriormente, tendrá la posibilidad de modificar el nombre del elemento directamente en la ventana del Explorador de VSS.

Al utilizar el comando Cambiar nombre sobre un archivo o un proyecto, el historial de archivo del elemento se mantiene. Si múltiples proyectos comparten un archivo y el archivo se cambia de nombre, se cambiará de nombre en todos los proyectos que lo comparten. Sin embargo, si se han roto algunos vínculos compartidos mediante el comando Bifurcar, los archivos bifurcados no se cambiarán de nombre. La ficha Rutas de acceso del cuadro de diálogo Propiedades muestra cómo ha cambiado el nombre en diferentes bifurcaciones del archivo.


Buscar (Comando, menú Ver)

Vea también

Filtra la lista de archivos del Explorador de VSS para buscar los archivos desprotegidos cuyos nombres coinciden con un patrón o cadena especificado. Busca uno o más archivos especificados en la lista de proyectos y limita la presentación de la lista de archivos a esos archivos.

Derechos de acceso

Debe disponer del derecho de acceso Leer para utilizar este comando.

Comentarios

La búsqueda por estado puede utilizarse para buscar únicamente los archivos desprotegidos por un determinado usuario. Cuando un archivo se comparte en múltiples proyectos, el comando Buscar muestra para qué proyectos está desprotegido el archivo.

Sugerencia Presione Mayúsculas-Ctrl-S para buscar todos los archivos desprotegidos del proyecto actual. No se muestra el cuadro de diálogo Buscar.

Opciones del cuadro de diálogo Buscar por estado

Mostrar todos los archivos desprotegidos

Muestra todos los archivos desprotegidos, sin tener en cuenta quién los desprotegió.

Mostrar archivos desprotegidos por

Haga clic en este botón y escriba un nombre de usuario si sólo desea ver los archivos que ha desprotegido dicho usuario, en lugar de ver todos los archivos desprotegidos. También puede seleccionar nombres de usuario de la lista desplegable. También puede seleccionar nombres de usuario de la lista desplegable.

Área de búsqueda

Especifique qué proyectos o subproyectos desea incluir en la búsqueda. Puede buscar sólo en el proyecto actual, en el proyecto actual y en todos sus subproyectos, o bien en todos los proyectos de la base de datos.

Opciones del cuadro de diálogo Buscar con comodín

Comodín

Escriba un nombre de archivo o una cadena con caracteres comodín. Por ejemplo, archivo.*.

Área de búsqueda

Especifique qué proyectos o subproyectos desea incluir en la búsqueda. Puede buscar sólo en el proyecto actual, en el proyecto actual y en todos sus subproyectos, o bien en todos los proyectos de la base de datos.

Nota Si desactiva simultáneamente las casillas de verificación Comodín, se cancelará la búsqueda. Además, si escribe * o *.* en el cuadro Comodín y la casilla de verificación Buscar en todos los proyectos está desactivada, también se cancelará la búsqueda.

Recuerde que, en realidad, la búsqueda con comodines de SourceSafe es una operación de filtrado. Está buscando aquellos archivos del proyecto actual que coinciden con un criterio especificado. Si escribe *.* en el cuadro Comodín, suprimirá cualquier criterio de filtrado, por lo que se cancelará la búsqueda.


Seleccionar todo (Comando, menú Edición)

Vea también

Selecciona todos los archivos mostrados actualmente en el panel de archivos del Explorador de VSS de forma que pueda realizar una operación de grupo sobre todos los archivos.

Derechos de acceso

Cualquier usuario de VSS puede utilizar este comando.


Seleccionar (Comando, menú Edición)

Vea también

Selecciona uno o más archivos sobre los cuales realizar operaciones. El panel de archivos del Explorador de VSS debe estar activo para que este comando esté disponible.

Derechos de acceso

Cualquier usuario de VSS puede utilizar este comando.

Comentarios

El comando Seleccionar abre un cuadro de diálogo dentro del cual puede escribir el nombre de un único archivo, varios nombres de archivo separados por signos de punto y coma (;) o los nombres de varios archivos mediante caracteres comodín.

Opciones del cuadro de diálogo

Elemento

Escriba el nombre de un único archivo o de múltiples archivos. Para seleccionar todos los archivos de la lista de archivos, escriba *.*; para seleccionar todos los archivos que tienen la extensión .RTF, escriba *.RTF y así sucesivamente. Utilice el punto y coma (;) como delimitador entre tipos de archivo que desee incluir en la selección, por ejemplo "*.RTF; *.EXE".

Seleccionar

Selecciona el archivo.

Anular selección

Anula la selección de un archivo.

Aceptar

Confirma la selección.

Cancelar

Cancela la operación, cierra el cuadro de diálogo y vuelve al Explorador de VSS.


Establecer carpeta de trabajo (Comando, menú Archivo)

Vea también

Establece la carpeta de trabajo.

Derechos

Cualquier usuario de VSS puede utilizar este comando.

Comentarios

Es importante designar, tras crear un nuevo proyecto, una carpeta de trabajo en la cual trabajar con los archivos del proyecto. Si no lo hace, SourceSafe le solicitará una carpeta de trabajo siempre que utilice un comando que requiera que haya una establecida.

Puede utilizar como carpeta de trabajo una carpeta ya existente en el disco duro del equipo. También puede crear una nueva carpeta desde VSS o desde Windows.

Si sólo hace clic en Aceptar, este comando establece temporalmente la carpeta de trabajo para el proyecto. La configuración no se guarda al cerrar VSS. Si hace clic en la casilla de verificación Guardar como predeterminada, la carpeta se guardará como carpeta de trabajo predeterminada para el proyecto actual.

Opciones del cuadro de diálogo

Nombre

Nombre y ruta de acceso de la carpeta de trabajo.

Carpeta

Tu actual carpeta de trabajo.

Carpetas

Su carpeta de trabajo actual.

Unidades

Selecciona la unidad que contiene la carpeta de trabajo.

Aceptar

Confirma la selección.

Cancelar

Cancela la selección, cierra el cuadro de diálogo y vuelve al Explorador de VSS.

Crear carpeta

Crea una nueva carpeta para la carpeta de trabajo. Escriba un nuevo nombre de carpeta en el cuadro Nombre y después haga clic en Crear carpeta para crearla.

Guardar como predeterminada

Guarda la carpeta que especifique como su carpeta de trabajo predeterminada para el proyecto.


Compartir (Comando, menú SourceSafe)

Vea también

Convierte un archivo en miembro del proyecto actual o crea un nuevo proyecto bifurcado.

Para compartir una versión específica de un archivo en su proyecto actual, utilice el cuadro de diálogo Mostrar historial (menú Herramientas) y haga clic en Compartir. En el cuadro de diálogo Compartir desde el proyecto, seleccione el archivo que desea compartir en el proyecto actual.

Derechos de acceso

Debe disponer del derecho de acceso Desproteger en el proyecto desde el que está compartiendo y el derecho de acceso Agregar en el proyecto al cual está compartiendo para utilizar este comando.

Comentarios

Para compartir un archivo, cree un vínculo compartido entre dos proyectos. El archivo está entonces en dos (o más) proyectos al mismo tiempo. Al proteger el archivo en cualquiera de los proyectos, sus cambios se protegen automáticamente en todos ellos. Para mostrar una lista de todos los proyectos que comparten un determinado archivo, utilice la ficha Vínculos del cuadro de diálogo Propiedades.

Si crea una bifurcación, los cambios realizados en el archivo bifurcado no se propagarán más allá del proyecto original y viceversa. El comando Vínculos ya no muestra una relación, pero puede utilizar la ficha Rutas de acceso del cuadro de diálogo Propiedades para ver la ruta de la bifurcación de archivo que creó.

Al compartir un proyecto, crea un proyecto completamente nuevo bajo el proyecto actual que es un duplicado exacto del proyecto que especificó. Todos los archivos del nuevo proyecto se comparten con los archivos correspondientes del proyecto original y los cambios de unos se reflejan en los otros durante la protección.

Opciones del cuadro de diálogo

Compartir archivo

Escriba el nombre del archivo o archivos que desea compartir o haga clic en un nombre de archivo ya mostrado. Los archivos mostrados son aquellos que pueden compartirse con su proyecto actual: algunos archivos no se pueden compartir, como los archivos que tienen el mismo nombre que archivos que ya existen en su proyecto.

Proyectos

El nombre del proyecto desde el cual se está compartiendo.

Mostrar archivos de tipo

Muestra el tipo de archivo o indica a VSS cómo clasificar un archivo.

La lista de tipos de archivo disponibles se determina en el filtro Tipos de archivo incluidos en grupo de archivos y en el filtro Grupos de archivo establecidos en la ficha Tipos de archivo del cuadro de diálogo Opciones de SourceSafe. Todos los archivos (*.*) muestra una lista de todos los archivos de la carpeta actual.

Cerrar

Cierra el cuadro de diálogo.

Compartir

Comparte el archivo o el proyecto seleccionado.

Ver

Muestra el archivo con el editor de textos asociado a la extensión del archivo. El editor se configura con la opción Visor de archivos de la ficha General del cuadro de diálogo Opciones de SourceSafe.

Bifurcar después de compartir

Comparte el archivo y después lo bifurca inmediatamente para crear copias distintas del archivo.


Mostrar diferencias (Comando Archivo, menu Herramientas)

Vea también

Compara dos archivos y muestra las diferencias, si las hay.

Nota Si desea ver las diferencias entre proyectos, seleccione un proyecto en el panel de proyectos del Explorador de VSS y haga clic en Mostrar diferencias.

Derechos de acceso

Debe disponer del derecho de acceso Leer para utilizar este comando. Debe tener una carpeta de trabajo establecida antes de utilizar este comando.

Comentarios

La mayoría de las veces, utilizará el comando Mostrar diferencias inmediatamente antes de proteger un archivo para comparar su copia del archivo con la copia maestra de VSS. Esto le da una lista de los cambios que ha realizado, lo cual puede ayudarle a generar un comentario.

Al utilizar el comando Mostrar diferencias sobre un archivo de texto ASCII, VSS muestra una lista coloreada de las diferencias entre los archivos.

En el caso de archivos binarios, VSS puede decirle si la copia local del archivo es diferente de la copia maestra, pero no puede mostrar las diferencias.

Nota También es posible comparar dos versiones anteriores de un archivo entre sí o comparar una versión anterior con la versión actual. Cuando selecciona un elemento en el cuadro de diálogo Historial de archivo y después hace clic en Diferencias.

Opciones del cuadro de diálogo

Nota Active la presentación de este cuadro de diálogo en la ficha Cuadros de diálogo de comandos del cuadro de diálogo Opciones de SourceSafe (menú Herramientas).

De forma predeterminada, VSS utiliza el cuadro de diálogo Diferencia visual. Si especifica una presentación UNIX, VSS utiliza la opciones de presentación de VSS correspondientes a las casillas Pasar por alto MAY e Ignorar diferencias en espacios en blanco. La opción de presentación de VSS utiliza anchos de línea calculados para que éstas quepan dentro de su pantalla y no muestra líneas de contexto.

Comparar / Con

Cuando realiza una comparación de archivo rutinaria, el campo Comparar contendrá de forma predeterminada el archivo de VSS y el campo Con el archivo correspondiente en la carpeta de trabajo. Puede escribir en el campo Comparar o hacer clic en el botón Examinar con el fin de especificar su selección. Puede también utilizar los botones Examinar para comparar dos archivos de VSS (en el mismo proyecto o en otros proyectos), dos archivos locales (en la misma carpeta o en otras carpetas) o bien un archivo de VSS con otro archivo local.

Visual

Muestra el archivo completo, con anotaciones para los cambios.

SourceSafe

Muestra una lista de las líneas que se agregaron, eliminaron y cambiaron, optimizada para su legibilidad.

UNIX

Muestra las diferencias de formato utilizadas por el programa Diff de UNIX.

Ignorar espacios en blanco

Muestra las diferencias sin tener en cuenta los caracteres espaciadores tales como los tabuladores.

Pasar por alto MAY/min

Muestra las diferencias sin distinguir entre mayúsculas y minúsculas.

Mostrar sólo cuando se presiona Máyus

Si activa esta casilla, el cuadro de diálogo Mostrar diferencias se mostrará sólo si mantiene presionada la tecla MAYÚSCULAS mientras ejecuta el comando Mostrar diferencias.

Aceptar

Muestra el cuadro de diálogo Diferencias de proyecto.

Cancelar

Cancela el comando Mostrar diferencias.

Informe

Envía un informe al Portapapeles, a un archivo de texto a la impresora.

Opciones avanzadas

Ignorar diferencias del SO

Especifica que VSS pase por alto las diferencias entre los caracteres de salto de línea entre sistemas operativos. Esta opción es útil si está comparando archivos en una red en la que hay un equipo Macintosh, por ejemplo, y el otro equipo funciona con Microsoft Windows NT.

Mostrar contexto

Incluye el número especificado de líneas de contexto en la pantalla de diferencias. Las líneas de contexto son las líneas del archivo que rodean la línea identificada como diferente por VSS. Por ejemplo, establecer Mostrar contexto a tres significa que verá tres líneas de contexto por encima y tres por debajo de la línea de diferencia.

Nota Si utiliza Diferencia visual, esta opción se pasará por alto.

Guardar configuración

Guarda la configuración seleccionada para utilizaciones futuras.


Mostrar diferencias (Comando, Proyecto, menú Herramientas)

Vea también

Compara un proyecto de VSS y el correspondiente proyecto de su carpeta de trabajo y muestra las diferencias, si las hay. También puede ver las diferencias de líneas individuales en los archivos con diferentes y reconciliar las diferencias entre la carpeta de trabajo y el proyecto.

Nota Si desea mostrar diferencias entre un archivo del proyecto y ese archivo en la carpeta de trabajo. seleccione un archivo en el panel de archivos del Explorador de VSS y después haga clic en Mostrar diferencias.

Derechos de acceso

Debe disponer del derecho de acceso Leer para utilizar este comando.

Comentarios

El comando Mostrar diferencias de un proyecto genera un cuadro de diálogo con dos paneles en el que se muestran las diferencias entre un proyecto VSS y otro proyecto VSS, un proyecto VSS y una carpeta de Windows o dos carpetas de Windows. Antes de que se muestren las listas de proyectos, aparecerá un cuadro de diálogo de comando que le permite filtrar la lista de archivos, si lo desea, de forma que podrá limitar la información a los archivos que le interesen.

Una utilización común de este comando es buscar los archivos que otro usuario ha eliminado del proyecto, de forma que pueda eliminarlos de su carpeta de trabajo. También puede ser útil si toma un proyecto durante un momento para ver dónde ha realizado sus cambios a nivel de proyecto.

Después de examinar los archivos en ambos paneles, puede reconciliar las diferencias entre la carpeta de trabajo y el proyecto de SourceSafe de varias formas. Por ejemplo, puede obtener o proteger todos los archivos que son diferentes en su carpeta de trabajo, o agregar a su proyecto todos los archivos que todavía no se encuentren en él.

Opciones del cuadro de diálogo Diferencias de proyecto

Nota Active la presentación de este cuadro de diálogo en la ficha Cuadros de diálogo de comandos del cuadro de diálogo Opciones de SourceSafe (menú Herramientas).

Las opciones que aparecen en este cuadro de diálogo no son mutuamente excluyentes, sino que puede combinarlas para filtrar las listas de archivos de cada panel. Cada casilla de verificación puede agregar más archivos a las listas de los paneles.

Comparar / En

Cuando realiza una comparación de archivo rutinaria, el campo Comparar contendrá de forma predeterminada el archivo de VSS y el campo En el archivo correspondiente en la carpeta de trabajo. Puede escribir en el campo Comparar o hacer clic en el botón Examinar con el fin de especificar su selección. Puede también utilizar los botones Examinar para comparar dos archivos de VSS (en el mismo proyecto o en otros proyectos), dos archivos locales (en la misma carpeta o en otras carpetas) o bien un archivo de VSS con otro archivo local.

Mostrar los archivos que están sólo en el proyecto

Incluye, en el panel izquierdo, archivos de proyecto que no están en la carpeta de trabajo en ese momento. Esta opción aparecerá activada de forma predeterminada.

Mostrar los archivos que están sólo en la carpeta de trabajo

Incluye, en el panel derecho, los archivos de la carpeta de trabajo que no se encuentran en el proyecto de VSS en ese momento. Esta opción aparecerá activada de forma predeterminada.

Mostrar los archivos que son diferentes en los dos sitios

Incluye todos los archivos que se encuentran tanto en la carpeta de trabajo como en el proyecto de VSS, pero que son distintos entre sí. En el caso de estos archivos, lo más frecuente es que tenga que obtener el archivo para actualizar la versión en su carpeta de trabajo. Esta opción aparecerá activada de forma predeterminada.

Mostrar los archivos que son iguales en los dos sitios

Incluye archivos en los proyectos que son iguales en ambos lugares. Esta opción aparecerá activada de forma predeterminada.

Recursivo

Busca el contenido del proyecto actual; también busca en los subproyectos bajo el proyecto actual y muestra las diferencias entre la lista de proyectos completa y su lista de carpeta local.

Mostrar sólo cuando se presiona Máyus

Si activa esta casilla, el cuadro de diálogo Mostrar diferencias se mostrará sólo si mantiene presionada la tecla MAYÚSCULAS mientras ejecuta el comando Mostrar diferencias.

Aceptar

Muestra el cuadro de diálogo Diferencias de proyecto.

Cancelar

Cancela el comando Mostrar diferencias.


Mostrar historial (Comando, menú Herramientas)

Vea también

Muestra el historial de un archivo o un proyecto de VSS.

Derechos de acceso

Debe disponer del derecho de acceso Leer para utilizar este comando.

Comentarios

Cada vez que proteja un archivo o un proyecto en VSS, el archivo o el proyecto se considera una nueva versión. Utilice el comando Mostrar historial para ver una lista de las versiones anteriores de un archivo o un proyecto.

Las versiones se muestran comenzando con la más reciente y hacia atrás hasta la creación del archivo o el proyecto. VSS proporciona información acerca del número de versión, que puede utilizarse con otros comandos (como Obtener la última versión) para indicar una versión específica.

De forma predeterminada, el historial de un proyecto incluye los historiales de todos sus archivos, pero no incluye los subproyectos.

Puede comparar una versión de un archivo con otra si selecciona las dos versiones simultáneamente (mantiene presionada la tecla CTRL y hace clic en cada versión) y después hace clic en el botón Diferencias.

Opciones del cuadro de diálogo

Nota Active la presentación de este cuadro de diálogo en la ficha Cuadros de diálogo de comandos del cuadro de diálogo Opciones de SourceSafe (menú Herramientas).

Incluir historiales de archivos (sólo en historial de proyecto)

Incluye archivos en el historial del proyecto.

Recursivo (sólo para historiales de proyectos)

Incluye subproyectos y todos los archivos que contienen.

Sólo etiquetas

Incluye sólo las etiquetas en el historial del proyecto.

Desde

Escriba una hora, fecha, versión o etiqueta. Utilice el prefijo D para indicar una fecha o fecha y hora, y el prefijo L para indicar una etiqueta. Por ejemplo "D02/29/95;12:15" o "Lbeta1". Es posible escribir la fecha en el formato 08.15.97, 08-15-97 ó 08/15/97, pero no como 15 de agosto, 1997. Observe que, si tiene un proyecto seleccionado para ver su historial, no podrá examinarlo en busca de etiquetas; para ello deberá seleccionar el archivo y utilizar el comando Mostrar historial para encontrar una etiqueta en concreto.

En

Escriba la hora, la fecha, la versión o la etiqueta. Utilice el prefijo D para indicar una fecha o fecha y hora, y el prefijo L para indicar una etiqueta. Por ejemplo "D02/29/95;12:15" o "Lbeta1". Las fechas pueden especificarse en el formato 08.15.95, 08-15-95 u 08/15/95, pero no como 15 de agosto de 1995.

Usuario

Muestra un historial de los archivos en los que ha trabajado el usuario especificado.

Aceptar

Muestra el cuadro de diálogo Historial de proyecto o Historial de archivo, dependiendo de si se seleccionó un archivo o un proyecto en el Explorador de VSS. En estos cuadros de diálogo, haga clic en cualquiera de los elementos de la lista y después haga clic en Detalles para mostrar el cuadro de diálogo Detalles del historial. Desde dentro del cuadro de diálogo Detalles del historial puede hacer clic en los botones Siguiente y Anterior para moverse hacia arriba y hacia abajo por el historial. También puede modificar el comentario y la etiqueta asociados con la versión que está viendo.

Mostrar sólo cuando se presiona Máyus

Salta este cuadro de diálogo en las futuras operaciones de Mostrar historial y utiliza los valores especificados como predeterminados. Para restaurar el cuadro de diálogo, haga clic en la casilla de verificación apropiada de la ficha Cuadros de diálogo de comandos en el cuadro de diálogo Opciones de SourceSafe.


Ordenar (Comando, menú Ver)

Ordena la lista de archivos del Explorador de VSS. Las opciones de orden permiten ordenar por nombre de archivo, tipo, usuario, fecha o carpeta de desprotección.

Derechos de acceso

Cualquier usuario de VSS puede utilizar este comando.

Comentarios

La lista de archivos del Explorador de VSS suele estar ordesnada por nombre de archivo. Puede cambiar el criterio de ordenación:

  • Nombre (nombre de archivo)

  • Tipo (extensión del tipo de archivo)

  • Usuario (los nombres de usuario que tienen archivos desprotegidos)

  • Fecha: hora

  • Carpeta de desprotección

Tipo, Nombre, Usuario y Carpeta de desprotección se ordenan en sentido ascendente; Fecha y hora se ordena en sentido descendente, de forma que los archivos más recientes están en la parte superior. El criterio de ordenación actual se muestra siempre en la barra de estado.


Deshacer desprotección (Comando, menú SourceSafe)

Vea también

Cancela una operación Desproteger, y deshace todos los cambios. Debe tener establecida una carpeta de trabajo para que este comando funcione correctamente.

Derechos de acceso

Debe disponer del derecho de acceso Desproteger para utilizar este comando.

Comentarios

El comando Deshacer desprotección deshace todos los cambios; el archivo ya no está desprotegido por usted, pero en lugar de actualizar VSS con la copia modificada, Deshacer desprotección conserva la versión que VSS tenía previamente y la copia sobre el archivo en su carpeta de trabajo.

Puede utilizar el comando Deshacer Desproteger únicamente en los archivos que tiene desprotegidos actualmente, pero no en archivos desprotegidos por otros usuarios.

Nota Su administrador de VSS puede deshacer la desprotección de otro usuario. Consulte el capítulo 8, "Administración", del Manual del usuario de Visual SourceSafe si desea más información al respecto.

Opciones del cuadro de diálogo

Importante Las siguientes opciones son exclusivas de VSS. Access u otros productos integrados pueden tener opciones diferentes.

Nota Active la presentación de este cuadro de diálogo en la ficha Cuadros de diálogo de comandos del cuadro de diálogo Opciones de SourceSafe (menú Herramientas).

Copia local

  • Reemplazar: reemplaza el archivo de la carpeta de trabajo. VSS ejecuta el comando Obtener la última versión sobre el archivo. Esto mantiene la sincronización de su carpeta de trabajo con el contenido del proyecto, al pasar por alto todas sus modificaciones.

  • Eliminar: Elimina el archivo en su carpeta de trabajo.

  • Dejar: No toca el archivo aislado.

    Predeterminado utiliza el valor predeterminado establecido en la ficha Archivos locales o el heredado de un proyecto primario. Esta opción no puede configurarse; se utiliza automáticamente cuando de forma explícita (en la lista de archivos) o implícita (activando Recursivo) selecciona múltiples archivos.

Mostrar sólo cuando se presiona Máyus

Salta este cuadro de diálogo en las operaciones Deshacer Desproteger futuras y utiliza los valores que estableció como predeterminados. Para restaurar el cuadro de diálogo, haga clic en la casilla de verificación apropiada de la ficha Cuadros de diálogo de comandos en el cuadro de diálogo Opciones de SourceSafe.

Recursivo (sólo para deshacer desprotecciones a nivel de proyecto)

Deshace la desprotección de todos los archivos en el proyecto seleccionado, con todos los archivos de todos sus proyectos secundarios.

Modificar (sólo para deshacer desprotecciones a nivel de proyecto)

Modifica el conjunto de carpetas de trabajo a las que se aplica una operación recursiva. Esto es útil si tiene archivos desprotegidos en más de un proyecto y desea deshacer la desprotección de todos ellos al mismo tiempo. Está disponible sólo cuando hace clic en la casilla de verificación Recursivo.


Ver archivo (Comando, menú Edición)

Vea también

Muestra el texto de la copia maestra del archivo de VSS. Para ver una versión anterior del archivo, utilice el botón Ver del cuadro de diálogo Historial de archivo (menú Herramientas). Para ver un archivo antes de compartirlo en el proyecto actual, utilice el botón Ver del cuadro de diálogo Compartir.

Derechos de acceso

Debe disponer del derecho de acceso Leer para utilizar este comando.

Comentarios

El comando Ver archivo abre y muestra una copia maestra de VSS del archivo utilizando el editor asociado a ese archivo. También puede seleccionar un editor haciendo clic en el botón Avanzado del cuadro de diálogo Archivo. No cambia nada en la base de datos de VSS ni en la carpeta de trabajo.

El editor asociado se selecciona de una de las siguientes maneras, en el orden siguiente:

  1. VSS busca en sus archivos de inicialización una línea con la extensión del archivo que se está viendo.

  2. VSS utiliza el Explorador de Microsoft Windows (la base de datos de registro y WIN.INI) para asociar una aplicación con la extensión de archivo.

  3. VSS busca su entrada en Editor para ver archivos de la ficha General del cuadro de diálogo Opciones de SourceSafe.

  4. Si VSS no puede determinar una asociación de archivo tras utilizar estos métodos, muestra el archivo en su propio editor.


Glosario

A

Administrador de VSS

Responsable de la base de datos de VSS. El administrador utiliza el programa Administrador de VSS para controlar la ubicación de la base de datos, la lista de usuarios y los derechos de acceso de cada usuario, y realiza la configuración y las tareas de copia de seguridad en la base de datos. El nombre de usuario del administrador siempre es Admin.

archivo bifurcado

Archivo cuyo vínculo compartido se rompió al utilizar el comando Bifurcar.

archivo compartido

Archivo utilizado simultáneamente, en su totalidad o en parte, por más de un proyecto.

archivo de palabras clave

Archivo que contiene información de las palabras claves de VSS.

archivo de sólo lectura

Archivo marcado como de sólo lectura en sus atributos de archivo. Un archivo de este tipo se puede ver en un editor de texto apropiado, pero no se puede modificar. VSS marca el archivo como de sólo lectura cuando utiliza los comandos Proteger y Obtener la última versión.

archivo desprotegido

Archivo reservado por un usuario para trabajar con él. Los usuarios desprotegen los archivos para realizar cambios con ellos. En la configuración predeterminada, VSS sólo permite desproteger un archivo a un usuario a la vez. Al desproteger un archivo se copia su última versión en la carpeta de trabajo del usuario.

archivo diario

Archivo de texto que el administrador configura para que registre cualquier acción de VSS que genere una entrada en el historial de un archivo o proyecto. Este archivo se utiliza frecuentemente con propósitos de auditoría.

archivo protegido

Archivos almacenados en la base de datos de VSS y que no están disponibles para su modificación.

arrastrar y colocar

Combinación de características que permite al usuario arrastrar un elemento y colocarlo sobre otro mediante el mouse (ratón). Un elemento puede ser el origen (el elemento que arrastra el usuario) o el destino (el elemento sobre el que el usuario coloca un origen).

Para arrastrar un objeto, haga clic en el objeto y después, manteniendo presionado el botón del mouse, llévelo a su nueva ubicación. Suelte el botón del mouse para colocar el objeto.

B

barra de estado

Barra que aparece en la parte inferior de la ventana del Explorador de VSS y se utiliza para mostrar información del estado de archivos y proyectos, así como información del comando actual.

base de datos de VSS

Base de datos central donde se almacenan todas la copias maestras, historiales, estructuras de proyecto e información del usuario. Un proyecto siempre está en una base de datos; es posible almacenar varios proyectos en una base de datos y puede haber varias base de datos de VSS para almacenar múltiples proyectos.

bifurcar

Proceso de compartir un archivo con otro proyecto y separarlo después en dos o más bifurcaciones. Tras haberse creado una bifurcación, dos archivos (el archivo del proyecto y su contrapartida en otros proyectos) tienen un historial compartido hasta un cierto punto e historiales divergentes después de ese momento.

bloqueo

Sistema de seguridad que sirve para que dos procesos no afecten al mismo registro de una base de datos a la vez. Para coordinar el acceso a registros, VSS aplica el bloqueo nativo, que utiliza funciones del sistema operativo nativo. También se puede configurar VSS para que utilice archivos de bloqueo que crean archivos temporales en la carpeta LOCKS.

C

caracteres comodín

El asterisco (*) y el signo de interrogación de cierre (?) son caracteres comodín. Puede utilizar estos caracteres para hacer coincidir modelos. También puede utilizar los caracteres comodín y los caracteres coincidentes para refinar una búsqueda.

Símbolo | Ejemplo | Utilización
* | qu* encuentra que, quién y queso; *al encuentra tal, cual y mal | Igual que el carácter comodín de MS-DOS asterisco (*), este asterisco coincide con cualquier número de caracteres.
? | s?n encuentra sin, san y son | Igual que el carácter comodín de MS-DOS (?), este símbolo coincide con cualquier carácter único.

Una barra inversa delante de un asterisco o un signo de interrogación de cierre indica un asterisco o interrogación de cierre literales: \* o \? (Esto es necesario si desea buscar asteriscos, signos de interrogación de cierre o barras inversas.) Una barra inversa doble (\\) indica una barra inversa. Se pasará por alto cualquier otra utilización de la barra inversa.

carpeta central

Carpeta central y opcional que contiene las versiones actuales de todos los archivos de un proyecto. La carpeta central no contiene la copia maestra ni la copia local de un archivo. En su lugar, proporciona una ubicación central desde la que se puede ver la estructura global del proyecto y sirve como lugar apropiado para generar o compilar el proyecto.

carpeta de desprotección

Carpeta en la que se desprotege un archivo en VSS. No es la carpeta de trabajo. Si desprotege un archivo, éste se desprotege en su carpeta de trabajo. Para otro usuario, el arhivo está en la carpeta de desprotección. La carpeta de desprotección se muestra en la columna Carpeta de desprotección del panel de archivos; la carpeta de trabajo se muestra bajo la barra de herramientas.

carpeta de trabajo

Carpeta específica del equipo local del usuario utilizada para almacenar archivos cuando se desprotegen de la base de datos de VSS. El usuario lleva a cabo los cambios en los archivos en la carpeta de trabajo y después protege los archivos modificados en la base de datos de VSS para el seguimiento de versiones.

comando Destruir

Quita de forma permanente los archivos y proyectos eliminados de la base de datos de VSS. Una vez destruidos, los elementos no se pueden recuperar.

comando Eliminar

Quita archivos y proyectos de un proyecto de VSS y los marca como eliminados; sin embargo, los elementos aún existen y se pueden recuperar mediante el comando Recuperar.

comando Purgar

Quita de forma permanente los archivos y proyectos previamente eliminados de la base de VSS. Los elementos no se pueden recuperar una vez purgados.

combinación automática

Cuando varios usuarios tienen el mismo archivo desprotegido, VSS combina sus cambios en el archivo al protegerlos.

combinación visual

Operación de combinación en la que se resuelven visualmente los conflictos en una interfaz gráfica fácil de usar.

combinar

Proceso de combinar diferencias en dos o más copias modificadas de un archivo a una nueva versión del mismo. Una combinación implica al menos dos archivos diferentes (que pueden ser versiones diferentes del mismo archivo o cambios realizados a la misma versión del archivo) y crea un archivo nuevo a partir de los resultados de la combinación. La combinación puede ocurrir cuando el usuario combina dos bifurcaciones o cuando se utiliza el comando Proteger u Obtener la última versión.

conflicto

Dos o más cambios diferentes en la misma línea de código en una situación de desprotección múltiple. VSS reconoce los conflictos durante una operación de combinación, y los marca de alguna manera.

contraseña

Cadena de texto utilizada como medio de seguridad para comprobar la identidad de un usuario. Para utilizar la base de datos de VSS se requiere a menudo la contraseña del usuario.

control de código fuente

Administración del historial de cambios de un archivo y relación del archivo con un grupo mayor de archivos relacionados conocido como proyecto. El control de código de origen es una parte vital del desarrollo eficiente de aplicaciones de software. VSS es un control de código fuente orientado a proyecto.

control de versiones

VSS mantiene varias versiones de un archivo, incluyendo un registro de los cambios en el archivo de versión a versión.

copia local

Copia de un archivo almacenado en la carpeta de trabajo del equipo local. La copia local puede ser diferente del la copia maestra de VSS si se modificó desde la última desprotección o si otro usuario modificó la copia maestra mientras trabajaba con la copia local.

copia maestra

Última versión protegida de un archivo almacenada en la base de datos de VSS, como contraposición a la copia local de un archivo en la carpeta de trabajo.

cuadro de diálogo Avanzadas

Cuadro de diálogo que contiene configuraciones opcionales o adicionales. Muchos cuadros de diálogo de VSS tienen un botón Avanzadas que muestra estas configuraciones adicionales.

D

delta inverso

Tecnología de almacenamiento de cambios utilizada por VSS en la que se almacenan los cambios incrementales con respecto a un archivo de referencia, en lugar de almacenar cada versión sucesiva del archivo en su totalidad. En VSS, la versión actual de un archivo se utiliza como referencia y se guardan los cambios con respecto a las versiones previas. Así se requiere menos requisitos de almacenamiento en disco y menor tiempo de acceso, ya que sólo se almacena en su totalidad en la base de datos la versión actual.

delta

En VSS, delta es la diferencia entre la versión X de un archivo y la versión X [image] 1 del mismo archivo. VSS utiliza la tecnología de delta inverso para almacenar los cambios.

derechos de acceso

Niveles de permisos de los usuarios que concede el administrador de VSS para usar la base de datos de VSS Los niveles de derechos de acceso son Leer, Desproteger, Agregar y Destruir.

desarrollo multiplataforma

VSS admite compatibilidad transparente de archivos entre varios procesadores y sistemas operativos.

desprotección múltiple

Desprotecciones simultáneas por parte de dos o más usuarios. El administrador de VSS debe habilitar la desprotección múltiple.

E

encabezado de archivo

Texto que aparece al principio de un archivo y que contiene información, como el número de revisión del archivo, el autor, la fecha y hora de la última modificación, etc. Esta información aparece normalmente como comentarios en los archivos de lenguaje de programación, por lo que no interfiere con la misma.

entorno de desarrollo

Conjunto de herramientas de desarrollo de software, que se presenta como un entorno unificado en el que puede trabajar más eficientemente el programador de software. Microsoft Visual Basic y Microsoft Visual C++ son ejemplos de esos entornos.

esconder

Impedir que un proyecto se vea afectado por determinados comandos, por ejemplo Obtener, Desproteger, Proteger, Deshacer desprotección y Mostrar diferencias de proyectos.

etiqueta

Nombre definido por el usuario que puede adjuntar a un número específico de versión de un archivo o proyecto.

expansión de palabras clave

Proceso que utiliza VSS para reemplazar palabras clave de VSS con información significativa de encabezado cuando utiliza los comandos Proteger y Agregar archivos. Por ejemplo, la cadena "$Revision:   $" indica a VSS que expanda automáticamente la palabra clave Revision con el número de versión del archivo actual.

Explorador de VSS

Interfaz gráfica de usuario de VSS. De manera predeterminada, contiene tres paneles: El panel izquierdo de proyecto y el panel derecho de archivo, así como la barra de herramientas, la barra de estado, los menús y así sucesivamente. El Explorador de VSS se muestra cuando se hace clic en el icono de VSS.

F

formato de columna

Opción de formato utilizada con expansión de palabras clave en un archivo. Esta opción (utilizando dos signos de dos puntos en vez de uno en las instrucciones de palabra clave) le dice a VSS que alinee las columnas de información de palabras clave para obtener una presentación más legible.

H

herencia

Efecto heredado de variables en los archivos de inicialización de VSS que reciben los subproyectos de sus proyectos primarios. Las variables de estos archivos se pueden agrupar bajo encabezados para especificar su comportamiento. Si se establece una variable en el archivo de inicialización antes de los encabezados de grupo, la variable afectará a todos los proyectos; las variables de los subproyectos heredan el efecto.

historial

Registra los cambios de un archivo desde que se agregó inicialmente a VSS. Con el historial del archivo, puede volver a cualquier punto de la historia del archivo y recuperarlo tal y como era en ese momento. El cuadro de diálogo Historial del proyecto muestra el registro de los eventos significativos del proyecto actual, como etiquetado y eliminación o agregación de archivos y subproyectos.

I

inicio de sesión

Proceso de introducción y comprobación del nombre y la contraseña de un usuario para tener acceso a la base de datos de VSS.

L

lista de archivos

Lista de archivos del proyecto actual, que se pueden encontrar en el panel de archivos de la ventana del Explorador de VSS.

lista de proyectos

Lista de todos los proyectos disponibles en la base de datos de VSS; la lista de proyectos se encuentra en el panel izquierdo de la ventana del Explorador de VSS.

lista de usuarios

Lista de usuarios que pueden usar la base de datos de VSS. La lista la mantiene el administrador de VSS y se muestra en la ventana principal del Administrador de VSS.

M

marcador de conflicto

Símbolo utilizado para designar cambios conflictivos en un archivo. Estos símbolos son:

Símbolo | Descripción
<<<<<< | versión de SourceSafe
====== | separador de conflicto
>>>>>> | versión local

VSS coloca esas marcas en el archivo tras un conflicto de protección o una operación de combinación, de forma que se pueda encontrar y resolver fácilmente.

N

nombre usuario

Cadena única que identifica a un usuario dado. Se utiliza para iniciar sesión.

número de versión

Número que indica el número de revisiones que ha sufrido un archivo desde que se agregó a VSS. Dicho nombre aparece en el cuadro de diálogo Historial. Los números de versión son siempre números enteros.

O

operación recursiva

Operación que se aplica a un proyecto y a todos los archivos y subproyectos de ese proyecto. Por ejemplo, puede utilizar el comando Desproteger de forma recursiva para desproteger simultáneamente todos los archivos de la lista de proyectos y evitar tener que seleccionar cada archivo individualmente.

P

palabra clave

Específico de VSS. Puede utilizar palabras clave en los archivos de texto para crear automáticamente un encabezado de archivo con información específica de la versión. Utilice palabras clave de VSS para colocar información desde VSS directamente en un archivo de texto.

panel de archivos

Lado derecho de la ventana del Explorador de VSS. Este panel contiene la lista de archivos, que es una lista de todos los archivos del proyecto actual.

panel de proyectos

Lado izquierdo de la ventana del Explorador de VSS. El panel de proyectos contiene la lista de proyectos, una lista de todos los proyectos disponibles en la base de datos de VSS.

panel de resultados

Porción de la ventana del Explorador de VSS donde se muestran los resultados de las operaciones de VSS. Por ejemplo, cuando protege un archivo, en este panel aparece el nombre del archivo que está protegiendo.

propagación de derechos

Asignación predeterminada de derechos a un usuario en subproyectos basada en los derechos asignados en el proyecto primario. Esta asignación predeterminada se puede modificar.

proyecto actual

Proyecto seleccionado en el panel de proyectos de la ventana del Explorador de VSS.

Proyecto de sitio Web.

Proyecto marcado como un proyecto de sitio Web en el Administrador de VSS Esta designación permite la utilización de comandos de sitio Web especiales tales como Despliegue, en este proyecto.

proyecto primario

Proyecto en el que existe un archivo o subproyecto. Por ejemplo, el primario del archivo $/Proyecto/Abc.txt es $/Proyecto y el primario del proyecto $/Proyecto es el raíz ($/).

proyecto raíz

Proyecto de máximo nivel con el nombre $/ en la lista de proyectos. Todos los proyectos de una base de datos de VSS son subproyectos del proyecto raíz.

proyecto

Grupo de archivos asociados, normalmente todos los archivos necesarios para desarrollar un componente software. Es posible agrupar los archivos en un proyecto para crear subproyectos. Proyectos que se pueden definir de cualquier forma que tenga sentido para el usuario. Por ejemplo, un proyecto por versión, o un proyecto por lenguaje. Los proyectos tienden a estar organizados de la misma manera que los directorios de archivos.

S

seguimiento de versiones

Proceso de mantenimiento de registros del seguimiento del historial de un archivo desde su versión inicial hasta la versión actual. Se siguen los cambios a un archivo como parte de este proceso.

seguridad

VSS tiene dos niveles de seguridad: seguridad predeterminada y seguridad de proyecto. La seguridad predeterminada proporciona dos derechos de acceso: lectura y escritura, y sólo lectura. Cuando está activada la seguridad de proyecto, hay cuatro derechos de acceso disponibles por usuario y proyecto: Leer, Desproteger, Agregar y Destruir. Cada derecho sucesivo incluye los derechos que le preceden. El derecho de acceso Destruir proporciona acceso ilimitado y es equivalente a los derechos de Leer y escribir bajo la seguridad predeterminada.

Sistema de seguridad del proyecto

El más restrictivo de los dos sistemas de seguridad que proporciona VSS. De manera predeterminada, está deshabilitado. Cuando lo habilite el administrador, esta características permite a un administrador establecer derechos de acceso por usuario y por proyecto. Vea derechos de acceso.

subproyecto

Proyecto dentro de un proyecto primario.

V

versión actual

Versión del archivo utilizado más recientemente en la base de datos de VSS. La versión actual tiene el mayor número de versión de un archivo en VSS.

vínculo compartido

Vínculo entre un archivo compartido entre uno o más proyectos. Este vínculo sirve para actualizar el archivo compartido con cualquier cambio protegido, sin importar desde qué proyecto se desprotegió.


Append_EOL (Variable de inicialización)

Vea también

Indica si todos los archivos de texto deben terminar con un carácter de fin de línea. El valor predeterminado es No.

Sintaxis

Append_EOL = {Yes|No}

Ejemplo

Indica a VSS que no anexe un carácter de fin de línea a los archivos de texto:

Append_EOL = No

Comentarios

Algunos compiladores requieren que todos los archivos que compilan terminen con un carácter de fin de línea. Si está trabajando en uno de estos entornos, puede que desee establecer esta variable a Yes; esto hace que VSS anexe un carácter de fin de línea siempre que recupere un archivo de texto que no termine ya con uno.

También puede establecer esta variable en el archivo SS.INI mediante la casilla de verificación Agregar fin de línea a todos los archivos de texto de la ficha Archivos locales del cuadro de diálogo Opciones de SourceSafe.


Backup_Ext (Variable de inicialización)

Vea también

Especifica la extensión que se utiliza para crear un archivo de copia de seguridad al combinar. El valor predeterminado es .ORG y esta variable sólo puede establecerse si modifica directamente el archivo SS.INI.

Sintaxis

Backup_Ext = extensión de archivo utilizada para copias de seguridad de la combinación

Ejemplo

Establece .ORG como la extensión que se utilizará para los archivos de copia de seguridad:

Backup_Ext = .org

Comentarios

Cuando VSS combina una bifurcación de un archivo y encuentra un conflicto, reemplaza el archivo original con una copia combinada que marca todos los conflictos, de forma que pueda resolverlos. Si especifica una extensión de copia de seguridad, el archivo original (previo a la combinación) se guarda con la extensión especificada en esta variable.

Por ejemplo, al proteger MiArch.cpp, VSS crea MiArch.org, que incluye el contenido de MiArch.cpp antes de que VSS comenzara la operación de protección, combinación u obtención.


Binary_Masks (Variable de inicialización)

Vea también

Establece el almacenamiento de archivo binario para ciertos tipos de archivo.

Sintaxis

Binary_Masks = máscara [, máscaras adicionales]

Ejemplo

Indica a VSS que cualquier archivo que tenga la extensión .OBJ o .XLS es un archivo binario:

Binary_Masks = *.OBJ, *.XLS

Comentarios

Esta variable anula la detección automática de VSS de los archivos de texto y binarios, de forma que pueda indicar que ciertos tipos de archivo sean siempre binarios. También puede establecer esta variable en el archivo SS.INI mediante la opción Archivos binarios de la ficha Tipos de archivo del cuadro de diálogo Opciones de SourceSafe.

Normalmente, VSS comprueba el contenido de un archivo durante una operación de agregar o proteger para ver si contiene datos de texto o binarios; pero esta comprobación puede llevar mucho tiempo para los archivos grandes. Establecer la variable Binary_Masks acelera los comandos Agregar archivos y Proteger para los archivos que sabe que son de un tipo o de otro.


Check_Hyperlink_Masks (Variable de inicialización)

Controla los tipos de archivo en el que se comprueban hipervínculos.

Sintaxis

Check_Hyperlink_Masks = *.HTM, *.HTML, *.ASP

Ejemplo

Especifica que cuando se comprueban los hipervínculos de Web, se comprueban los vínculos de los archivos que tienen las extensiones *.htm, *.html y *.asp:

Check_Hyperlink_Masks = *.HTM, *.HTML, *.ASP


Checkout_Comment (Variable de inicialización)

Vea también

Establece la opción -C de la línea de comandos para el comando Check Out. Se aplica sólo al programa de la línea de comandos de VSS (SS.EXE).

Sintaxis

Checkout_Comment = configuración válida de -C

Ejemplo

Hace que la desprotección no solicite comentarios de forma predeterminada:

Checkout_Comment = -

Comentarios

VSS le ofrece la posibilidad de proporcionar un comentario para cada archivo que desproteja. Es el comportamiento predeterminado. El comentario de desprotección indica a los demás usuarios por qué ha desprotegido el archivo y después se borra cuando protege el archivo con un comentario permanente que describe el cambio realizado.

La variable Checkout_Comment controla la solicitud de comentario de desprotección de VSS. Todas las configuraciones siguientes son válidas.

No solicita un comentario al desproteger:

Checkout_Comment = -

Solicita un comentario para todos los archivos desprotegidos:

Checkout_Comment =

Lee el archivo de texto especificado como comentario:

Checkout_Comment = @archivo

Utiliza el comentario especificado:

Checkout_Comment = comentario

También puede establecer esta variable en el archivo SS.INI bajo Comentarios de desprotección en la ficha Opciones de línea de comandos del cuadro de diálogo Opciones de SourceSafe.


Cloak (Variable de inicialización)

Vea también

Esconde proyectos para los comandos recursivos Obtener, Proteger, Desproteger, Deshacer desprotección y Diferencias de proyecto.

Sintaxis

Cloak = {Yes|No}

Ejemplo

Informa a VSS que esconda un proyecto para que un comando recursivo, como Obtener por ejemplo, no afecte al proyecto:

Cloak = Yes

Comentarios

El valor predeterminado es No. Esta variable también puede establecerse en la ficha General del cuadro de diálogo Propiedades de archivo (cuando está seleccionado un proyecto).


Comment_Editor (Variable de inicialización)

Vea también

Determina qué editor se utiliza para especificar comentarios. Se aplica sólo al programa de la línea de comandos de VSS (SS.EXE).

Sintaxis

Comment_Editor = archivo ejecutable del editor

Ejemplo

Establece B.EXE como el editor para especificar comentarios:

Comment_Editor = C:\Editors\B.exe

Comentarios

El método normal de VSS para recibir comentarios es una petición en la línea de comandos. Esta variable anula eso, indicando a VSS que cargue el editor especificado siempre que tenga que pedir un comentario. Esto le permite especificar comentarios en un editor que ya conoce. Si no se asigna un valor, se recupera el modo de introducción de comentarios mediante preguntas.

Si está establecida la variable de inicialización Editor, puede establecer el Comment_Editor para ignorar esa variable para los comentarios al mismo tiempo que se puede utilizar un editor para verlos. También puede establecer esta variable en el archivo SS.INI bajo las opciones Petición de comentarios de la ficha Opciones de línea de comandos en el cuadro de diálogo Opciones de SourceSafe.


Comment_Editor_Prompt (Variable de inicialización)

Vea también

Controla la petición que se utiliza al especificar un comentario con un editor. Se aplica sólo al programa de la línea de comandos de VSS (SS.exe).

Sintaxis

Comment_Editor_Prompt = {Yes|No}

Ejemplo

Activa la petición de editor:

Comment_Editor_Prompt = Yes

Comentarios

Cuando está escribiendo un comentario de archivo en la línea de comandos de VSS, las variables de inicialización Editor y Comment_Editor invocan un editor o un procesador de textos en el que puede escribir su comentario. Cuando se muestra el editor, proporciona una petición como la siguiente:

Escriba un comentario para TEST.C; guárdelo y salga.

Esta petición no se incluye en su comentario; no tiene que eliminarla (aunque puede hacerlo sin problemas). Puede establecer esta variable a No (la opción predeterminada es Yes), de forma que la petición no aparezca en el editor.

También puede establecer esta variable en el archivo SS.INI bajo las opciones Petición de comentarios de la ficha Opciones de línea de comandos en el cuadro de diálogo Opciones de SourceSafe.


Comment_Template (Variable de inicialización)

Establece un archivo de plantilla para los comentarios del Explorador VSS o el editor de comentarios.

Sintaxis

Comment_Template = archivo de plantilla

Ejemplo

Establece Template.txt como la plantilla que se utilizará al escribir comentarios:

Comment_Template = R:\SS\Template.txt

Comentarios

Esta variable señala a una plantilla: un archivo de texto que usted crea y que contiene un plantilla de comentario. Cuando se pide al usuario un comentario, ya sea en el Explorador de VSS o en el Comment_Editor utilizado por la línea de comandos, se coloca la plantilla en el campo de comentario.


Compare (Variable de inicialización)

Vea también

Indica cómo realiza VSS las comparaciones de archivos, con el propósito de determinar si obtener o no un archivo.

Sintaxis

Compare = {Contents|Checksum|Time}

Ejemplo

Compara el contenido completo del archivo para determinar si ha cambiado:

Compare = Checksum

Comentarios

Cuando obtiene o desprotege un archivo, VSS no vuelve a copiar el archivo a su carpeta de trabajo si ya tiene ahí una copia actualizada. Esta variable establece la forma en que VSS determina si su copia local está actualizada. Las siguientes opciones están en el orden apropiado para incrementar la velocidad:

  • Contents: compara el contenido completo de su copia local con la copia maestra. Es el método más lento, pero es el único que funciona en todos los casos.

  • Checksum: compara mediante una suma de comprobación almacenada por VSS. Si dos archivos tienen los mismos valores de suma de comprobación, pero son diferentes, este método falla (raramente ocurre esto).

  • Time: compara el indicador de fecha y hora. Es el valor más rápido, pero su fiabilidad está influenciado por las configuraciones de fecha y hora de los demás equipos que utilicen el archivo. (Este valor se utiliza normalmente sólo cuando su red puede aceptar la sincronización de todos los equipos de la red.)

Estas opciones, cuanto más rápidas sean, más aumentan el riesgo de que VSS pueda recuperar incorrectamente un archivo. De acuerdo con esto, se recomienda que utilice la opción Contents.

Al utilizar Compare=Time, el método exacto de comparación de fecha depende del valor de la variable de inicialización SetTime. Si SetTime está establecida a Check In, VSS reemplaza la copia local si la hora de la última protección (o adición) es más reciente que la fecha de modificación de su copia local. Si SetTime está establecida a Current (el valor predeterminado) o Modification, VSS reemplaza la copia local si la hora de modificación del archivo de VSS es diferente de la hora de modificación de la copia local.

También puede establecer esta variable en el archivo SS.INI mediante la opción Comparar archivos por de la ficha Archivos locales del cuadro de diálogo Opciones de SourceSafe.


ComputerName (Variable de inicialización)

Establece un nombre de equipo especificado por el usuario para la presentación opcional de archivos desprotegidos del panel de archivos del Explorador de VSS.

Sintaxis

ComputerName = cadena del nombre del equipo

Ejemplo

Establece el nombre de su PC como Contabilidad1:

ComputerName = Contabilidad1

Comentarios

Se permiten espacios en blanco en el nombre del equipo; no son necesarias comillas para delimitar la cadena.

VSS muestra el nombre del equipo en la columna Carpeta de desprotección del Explorador de VSS. Sin embargo, VSS no puede obtener la información sobre el nombre del equipo cuando se ejecuta en MS-DOS o Windows 3.x o Macintosh. En estas plataformas, VSS recupera el nombre del equipo desde la variable ComputerName y lo utiliza en la presentación del Explorador de VSS. Si no se especifica ningún nombre de equipo con esta variable, VSS no podrá mostrar el nombre del equipo.

Puede asignar como valor de la variable ComputerName el valor de una variable de entorno, si lo desea. Por ejemplo (en MS-DOS):

ComputerName = %EQUIPO%

El carácter % indica a VSS que lea la variable de entorno para determinar el nombre del equipo.

Nota La variable ComputerName se pasa por alto en Windows NT y en Windows 95. En estas plataformas el sistema operativo siempre recupera el nombre del equipo del propio sistema operativo.


CP_OnSelection (Variable de inicialización)

Vea también

Indica si al seleccionar un proyecto en el Explorador de VSS se establece automáticamente el proyecto actual.

Sintaxis

CP_OnSelection = {Yes|No}

Ejemplo

Indica que la selección de un proyecto cambia automáticamente a él:

CP_OnSelection = Yes

Comentarios

Si esta variable se establece a Yes, cada vez que seleccione un proyecto en el Explorador de VSS (ya sea con las teclas de dirección o con un clic del mouse) éste se convertirá en su proyecto actual. Si se establece a No, debe presionar ENTRAR (o hacer doble clic con el mouse) para convertirlo en su proyecto actual.

También puede establecer esta variable en el archivo SS.INI mediante la opción Convertir el proyecto seleccionado en el proyecto actual de la ficha Ver del cuadro de diálogo Opciones de SourceSafe.


Data_Path (Variable de inicialización)

Establece la ruta de la carpeta a la carpeta de datos utilizada por VSS para guardar la información de versión. Sólo se utiliza en el archivo SRCSAFE.INI.

Sintaxis

Data_Path = ruta_carpeta

Ejemplo

Establece la carpeta de datos como Data en la carpeta VSS del recurso compartido \\MIS\Developers:

Data_Path = \\MIS\Developers\VSS6\DATA

Comentarios

El administrador de VSS debe utilizar el valor predeterminado o establecer esta variable sólo una vez (antes de crear una base de datos nueva).

De forma predeterminada, VSS crea un variable de ruta de datos relativa como parte de su configuración. Esta variable se establece a Data_Path = DATA. Este valor predeterminado hace que VSS busque la subcarpeta DATA en la ruta donde está el archivo SRCSAFE.INI.


Database_Name (Variable de inicialización)

Establece el nombre de la base de datos de VSS actual como se muestra en la barra de título del Explorador de VSS. Disponible sólo en el archivo SRCSAFE.INI.

Nota Si desea utilizar el nombre de la base de datos antes de que alguien ejecute VSS o contenga usuarios, elimine la lista del su registro HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SourceSafe\Databases y comience entonces una nueva sesión de VSS.

Sintaxis

Database_Name = cadena_caracteres

Ejemplo

Establece el nombre de la base de datos como "Servicios de información":

Database_Name = Servicios de información

Comentarios

El nombre de la base de datos debe ser uno que indique claramente para qué sirve una serie de proyectos. Son apropiados los nombres de producto, nombres del código del proyecto, etc. Si no se define, la barra de título del Explorador de VSS contiene el último punto de la ruta de una instalación. Por ejemplo, la barra de título para una instalación en \\servidor\recurso_compartido\VSS6 contendrá VSS6. Observe que si el nombre de la carpeta es VSS, la barra de título utilizará en su lugar el nombre de recurso compartido.


Delete_Local (Variable de inicialización)

Vea también

Indica si durante los comandos Agregar, Proteger y Deshacer desprotección están manteniendo una copia local de un proyecto completo.

Sintaxis

Delete_Local = {Yes|No}

Ejemplo

Indica a VSS que no elimine las copias locales cuando haya terminado de trabajar con ellas:

Delete_Local = No

Comentarios

De forma predeterminada, cuando está trabajando con un archivo, VSS mantiene una copia del proyecto completo en su carpeta de trabajo. Cuando establece Delete_Local a Yes, VSS sólo mantiene copias de los archivos en los que está trabajando actualmente. Por tanto, cuando agrega, protege o deshace la desprotección de un archivo, en lugar de marcarlo como de sólo lectura, VSS elimina su copia local del archivo.

Cuando esta variable está establecida, no puede compilar el contenido de su carpeta de trabajo, puesto que los archivos cruciales quizá no estén en esa carpeta. Por esta razón, cuando establece Delete_Local a Yes, también establece frecuentemente una carpeta central para ese proyecto.

Incluso si Delete_Local está establecida, todavía puede utilizar el comando Obtener la última versión para recuperar un archivo en su carpeta de trabajo. En este caso, el archivo permanece en su carpeta de trabajo hasta que lo elimine o lo desproteja y después lo proteja.


Deploy_Host_Local (Variable de inicialización)

Enumera los host locales que no requieren un servidor proxy para el despliegue.

Sintaxis

Deploy_Host_Local = ftp.microsoft.com

Ejemplo

Especifica que cuando se despliega un proyecto de sitio Web no se requiere ningún servidor proxy para el sitio ftp.microsoft.com:

Deploy_Host_Local = ftp.microsoft.com

Comentarios

Si se especifica una variable de inicialización Deploy_Proxy , se usa en todos los despliegues ftp, excepto en los servidores especificados en Deploy_Host_Local.


Deploy_Path (Variable de inicialización)

Vea también

Especifica la ubicación a la que se copian los archivos cuando un usuario selecciona el comando Despliegue o el menú Web de VSS.

Sintaxis

Deploy_Path = carpeta

Ejemplo

Indica a VSS que despliegue los archivos en la ubicación \\internet\server1\ssafe cuando se selecciona el comando Despliegue:

Deploy_Path = \\internet\server1\ssafe

Comentarios

Sólo se usa para proyectos marcados como proyectos de sitio Web por la variable de inicialización URL. (También puede marcar un proyecto como proyecto de sitio Web mediante la ficha Proyectos Web del comando Opciones del menú Herramientas del administrador.) Esta variable también puede establecerse en la ficha Proyectos Web en Opciones del menú Herramientas. Puede establecer varias rutas de despliegue separadas por una coma.


Deploy_Proxy (Variable de inicialización)

Especifica el nombre de su servidor proxy.

Sintaxis

Deploy_Proxy = miproxy

Ejemplo

Especifica que la intranet empresarial requiere VSS para usar el servidor proxy miproxy con el fin de tener acceso a sitios ftp externos:

Deploy_Proxy = miproxy

Comentarios

Sólo aquí puede establecer un servidor proxy.


Diff_Format (Variable de inicialización)

Vea también

Controla el formato que se utiliza con el comando Mostrar diferencias (archivo) del menú Herramientas.

Sintaxis

Diff_Format = {SS|UNIX|Visual}

Ejemplo

Indica a VSS que utilice una presentación de diferencias visual (lado a lado):

Diff_Format = Visual

Comentarios

Cuando utiliza el comando Mostrar diferencias (archivo) para mostrar las diferencias existentes entre dos archivos, VSS puede mostrarlas de tres formas.

  • SS: muestra una lista de las líneas agregadas, eliminadas o cambiadas.

  • UNIX: muestra el formato de resultado estándar del programa Diff de UNIX.

  • Visual: muestra dos archivos uno al lado del otro, con las líneas diferentes codificadas con colores.

Si no especifica ningún formato preferido, el Explorador de VSS establece de forma predeterminada el formato Visual y la opción predeterminada en la línea de comandos es la presentación SS. sin embargo, si establece esta variable, tanto el Explorador de VSS como la línea de comandos cambiarán su configuración predeterminada a lo establecido. En cualquier caso, siempre puede evitar el valor predeterminado mediante opciones de la línea de comandos y en el cuadro de diálogo Opciones de SourceSafe del menú Herramientas.


Diff_Ignore (Variable de inicialización)

Controla los factores que se consideran o se pasan por alto al utilizar el comando Mostrar diferencias (archivo) del menú Herramientas.

Sintaxis

Diff_Ignore = lista de opciones

Ejemplo

Pasa por alto las diferencias de fin de línea y muestra todas las demás:

Diff_Ignore = c-es-w-

Comentarios

El comando Mostrar diferencias (archivo) se utiliza para mostrar todos los cambios relevantes de un archivo. Esta variable define lo que es un cambio relevante. Puede controlar cuatro aspectos en esta variable.

  • C: distinción entre mayúsculas y minúsculas.

  • E: caracteres de fin de línea.

  • S: pequeñas diferencias.

  • W: cambios en los espacios en blanco.

El formato de la variable es una lista de estas cuatro letras, con un guión después de cualquier variable que no debe pasarse por alto. En el ejemplo anterior (también el valor predeterminado), E es la única letra que no va seguida de un guión; por tanto, los caracteres de fin de línea son las únicas diferencias que se pasan por alto.


Dir (Variable de inicialización)

Vea también

Asocia una carpeta de trabajo con un proyecto específico. Esta variable se establece automáticamente mediante el comando Establecer carpeta de trabajo. Se recomienda que no establezca esta variable manualmente.

Sintaxis

Dir = ruta de acceso a la carpeta

Ejemplo

Asocia la carpeta C:\Word al proyecto $/Word:

[$/WORD]
Dir (PC) = C:\WORD

Comentarios

Cuando está trabajando en un proyecto, generalmente tiene una carpeta local, en el disco duro o en la red, donde mantiene su código de origen y trabaja con el proyecto.

El comando Dir muestra dónde se almacena su carpeta de trabajo para un determinado proyecto. Cuando cambia a un nuevo proyecto, VSS establece automáticamente su carpeta de trabajo a esta carpeta.

El uso de la variable Dir se puede reforzar si establece a Yes las variables Force_Dir y Force_Prj.


Double_Click (Variable de inicialización)

Determina el comportamiento predeterminado cuando haga doble clic en un archivo en el Explorador de VSS.

Sintaxis

Double_Click= {View|Edit|Ask}

Ejemplo

Informa a VSS que presente un cuadro de diálogo para preguntar si desea modificar o ver el archivo en el que ha hecho doble clic en el Explorador de VSS:

Double_Click = Ask

Comentarios

El valor predeterminado es preguntar (Ask).


Editor (Variable de inicialización)

Vea también

Determina qué editor se utiliza para especificar comentarios y ver archivos.

Sintaxis

Editor = archivo ejecutable del editor

Ejemplo

Establece Me.exe como editor de presentación y comentarios:

Editor = C:\Me\Me.exe

Comentarios

Cuando utiliza el comando Ver, VSS busca la aplicación que debe ejecutar para mostrar el archivo. El último lugar en el que mira es en los archivos de inicialización, en la variable Editor. Puesto que esta variable no es específica de la extensión, no suele ser el mejor lugar para especificar un editor. Sin embargo, puede ser útil establecer un editor predeterminado para todos los archivos cuyas extensiones no se encuentren.

La línea de comandos de VSS también utiliza la variable especificada aquí para los comentarios, a menos que lo anule con la variable de inicialización Comment_Editor.

También puede establecer esta variable en el archivo SS.INI mediante la opción Editor para ver archivos en la ficha General del cuadro de diálogo Opciones de SourceSafe.


EOL (Variable de inicialización)

Vea también

Establece el carácter de fin de línea que se utiliza cuando VSS obtiene archivos de texto.

Sintaxis

EOL = {n|rn}

Ejemplo

Utiliza un par retorno de carro y avance de línea al final de cada línea de texto:

EOL = rn

Comentarios

Otros sistemas operativos utilizan diferentes caracteres de fin de línea en los archivos de texto. UNIX utiliza un avance de línea, mientras que MS-DOS utiliza un par retorno de carro y avance de línea.

Cualquiera que sea el carácter de fin de línea que VSS encuentra en un archivo, lo lee correctamente. Esta variable de inicialización afecta al carácter que muestra VSS cuando obtiene un archivo de texto. De forma predeterminada, VSS utiliza el estándar para su sistema operativo. Si establece esta variable, VSS utilizará el carácter especificado.


Expand_Keywords_Locally (Variable de inicialización)

Vea también

Controla si VSS reemplaza automáticamente los archivos con palabras clave expandidas en su carpeta de trabajo.

Sintaxis

Expand_Keywords_Locally = {Yes|No}

Ejemplo

Realiza automáticamente el comando Obtener la última versión tras cualquier comando Proteger o Agregar que provoque la expansión de palabras clave:

Expand_Keywords_Locally = Yes

Comentarios

Cuando protege un archivo y tiene activada la expansión de palabras clave, VSS puede reemplazar ciertas palabras clave del archivo con información acerca de la versión. El archivo modificado se vuelve a copiar a VSS. Si esta variable se establece a Yes, el archivo modificado se copia después directamente a su carpeta. Si establece esta variable a No, el archivo no se copia; esto aumenta el rendimiento, pero la copia de su carpeta de trabajo puede que no esté completamente actualizada.

También puede establecer esta variable en el archivo SS.INI mediante la opción Copiar los archivos de claves expandidas a la carpeta de trabajo de la ficha Archivos locales del cuadro de diálogo Opciones de SourceSafe.


Extension_Association (Variable de inicialización)

Asocia una extensión de archivo con el editor utilizado al ver un archivo.

Sintaxis

asociación de extensión = nombre del archivo ejecutable del editor

Ejemplo

Establece el editor como WINHELP.EXE al ver archivos con la extensión .hlp:

.hlp = winhelp.exe

Comentarios

Esta variable se utiliza para anular (sólo para VSS) las asociaciones de extensión que existen en el Adminsitrador de archivos o en el Explorador de Windows. Sólo tiene que utilizar esta variable para VSS cuando se ejecuta en MS-DOS.


External_Link_File (Variable de inicialización)

Vea también

Especifica la ubicación del archivo utilizado para mostrar vínculos Web externos considerados válidos por un usuario de VSS.

Sintaxis

External_Link_File = ruta_archivo

Ejemplo

Especifica que los archivos Links.txt y Goodlinks.txt contienen la lista de vínculos Web validados asociada con un proyecto de sitio Web de VSS:

External_Link_File = \\VSSserver\links.txt, c:\webproj\goodlinks.txt

Comentarios

El archivo de vínculos es un archivo de texto con la lista de direcciones URL que se consideran válidas, incluso las que no ha validado VSS. Puede especificar una lista de archivos separados por comas para mantener varias copias de la lista de vínculos. Esta variable también se puede establecer en la ficha Proyectos Web del comando Opciones del menú Herramientas del Administrador de VSS.


File_Types (Variable de inicialización)

Vea también

Llena el cuadro Mostrar archivos de tipo en el cuadro de diálogo Agregar archivos de Windows.

Sintaxis

File_Types = tipos de archivo

Ejemplo

Coloca dos elementos en el cuadro combinado, Archivos C y Archivos por lotes:

File_Types = C Files (*.C; *.H), Batch files (*.BAT)

Comentarios

En el cuadro de diálogo Agregar archivos de VSS, el cuadro Mostrar archivos de tipo se utiliza para filtrar la lista de archivos de manera que muestre únicamente los archivos de ciertos tipos. Mostrar todos los archivos es siempre una opción. Si establece la variable de inicialización Relevant_Masks, este valor es una opción también. Esta variable de inicialización se utiliza para establecer otras opciones que aparecen en el cuadro combinado. En el ejemplo anterior, por ejemplo, Archivos C y Archivos por lotes aparecerían como opciones; si elige Archivos C, la lista de archivos mostrará todos los archivos que tengan la extensión C o H.

También puede establecer esta variable en el archivo SS.INI mediante la opción Grupos de archivos en la ficha Tipos de archivo del cuadro de diálogo Opciones de SourceSafe.


FileType (Variable de inicialización)

Vea también

Indica qué tipo de archivo se utiliza.

Sintaxis

FileType = {Binary|Text|Auto-Detect}

Ejemplo

Detecta automáticamente el tipo de archivo:

FileType = Auto-Detect

Comentarios

Esta variable anula la detección automática de VSS de los archivos de texto y binarios e indica que todos los archivos son de texto o binarios. Generalmente, esta variable se define globalmente para todos los proyectos. Si la utiliza, debe aplicarla sólo a determinados subproyectos cuando sepa que todos los archivos de ese subproyecto son de un tipo específico. Por ejemplo, si tiene un proyecto llamado $/Ejecutables con dos subproyectos $/Ejecutables/DLL y $/Ejecutables/EXE, puede que desee colocar el valor de la variable FileType=Binary bajo el encabezado [$/Ejecutables] para acelerar las operaciones Agregar archivos y Proteger.


Force_Dir (Variable de inicialización)

Vea también

Refuerza la utilización de la variable de inicialización Dir.

Sintaxis

Force_Dir = {Yes|No}

Ejemplo

Indica el uso normal de la variable Dir:

Force_Dir = Yes

Comentarios

La variable de inicialización Dir se utiliza para especificar la carpeta de trabajo para un proyecto. La variable Dir controla dónde recupera los archivos el Explorador de VSS. Si Force_Dir está establecida a No, éste es el único efecto de la variable Dir. Sin embargo, si establece Force_Dir a Yes (el valor predeterminado), la variable Dir se utiliza en otras dos circunstancias.

  1. En la línea de comandos de VSS. Cuando obtiene o desprotege un archivo, el archivo va a la carpeta actual. Pero si Force_Dir está establecida a Yes, el archivo va a la carpeta de trabajo del proyecto, incluso aunque no sea la carpeta actual.

  2. Cuando realiza una obtención recursiva en un proyecto, se crean subdirectorios para cada subproyecto. Por ejemplo, para el subproyecto HOLA se crea una carpeta llamada HOLA, de forma que toda la lista de proyecto se copia a un árbol de carpetas. Pero si Force_Dir está establecida a Yes, los subproyectos van a sus respectivas carpetas de trabajo, en lugar de ir a las subcarpetas bajo la carpeta principal.

También puede configurar esta variable en el archivo SS.INI mediante la opción Carpeta de trabajo basada en el proyecto actual en la ficha Opciones de línea de comandos del cuadro de diálogo Opciones de SourceSafe.


Force_Prj (Variable de inicialización)

Vea también

Establece automáticamente el proyecto actual, basado en la carpeta actual. Se aplica sólo al programa de la línea de comandos de VSS (SS.EXE).

Sintaxis

Force_Prj = {Yes|No|Ask}

Ejemplo

Indica a VSS que no cambie automáticamente el proyecto actual:

Force_Prj = No

Comentarios

  • Yes: primero mira en su carpeta actual siempre que ejecuta cualquier comando de VSS. Si es la carpeta de trabajo para un proyecto de VSS, VSS cambia automáticamente a ese proyecto antes de ejecutar el comando: Puede cambiar de carpeta para moverse por los proyectos sin ejecutar el comando SS CP.

  • No: no cambia a su proyecto actual.

  • Ask: pregunta antes de cambiar el proyecto.

Si establece Force_Prj = Yes, se recomienda encarecidamente que no asigne a dos proyectos la misma carpeta de trabajo, puesto que VSS no sabrá a qué proyecto cambiar.

También puede establecer esta variable en el archivo SS.INI mediante la opción Proyecto basado en la carpeta de trabajo de la ficha Opciones de línea de comandos del cuadro de diálogo Opciones de SourceSafe.


History_Include_Files (Variable de inicialización)

Vea también

Establece si los archivos se incluyen automáticamente en los informes de historial del proyecto.

Sintaxis

History_Include_Files = {Yes|No}

Ejemplo

Establece que VSS incluya automáticamente los archivos en el comando Mostrar historial de proyecto.

History_Include_Files = Yes

Comentarios

También puede establecer esta variable mediante la casilla de verificación Incluir historiales de archivos del cuadro de diálogo Opciones de historial de proyectos.


IMG_File (Variable de inicialización)

Especifica el archivo gráfico que desea utilizar para representar un archivo cuando genere un mapa de sitios de un proyecto de sitio Web.

Sintaxis

IMG_File = HTMLFILE.GIF

Ejemplo

Pide a VSS que utilice el archivo REDDOT.JPG en lugar del archivo predeterminado ARCHHTML.GIF en el mapa de sitios que genere:

IMG_File = REDDOT.JPG


IMG_Folder (Variable de inicialización)

Especifica el archivo gráfico que desea utilizar para representar una carpeta cuando genere un mapa de sitios de un proyecto de sitio Web.

Sintaxis

IMG_Folder = FOLDER.GIF

Ejemplo

Pide a VSS que utilice el archivo BLUEDOT.JPG en lugar del archivo predeterminado CARPETA.GIF en el mapa de sitios que genere:

IMG_Folder = BLUEDOT.JPG


Journal_File (Variable de inicialización)

Establece un nombre de archivo en el que se registran todos los comandos de VSS que cambian datos almacenados. Sólo se utiliza en el archivo SRCSAFE.INI.

Sintaxis

Journal_File = nombre_archivo

Ejemplo

Establece SSLog.TXT como diario de todos los comandos de VSS:

Journal_File = O:\Docs\SSLog.txt

Comentarios

Esta variable suele establecerse en SRCSAFE.INI, no en SS.INI, ya que así se aplica a todos los usuarios. Si se establece esta variable, el archivo se convierte en un diario de las acciones de VSS. El diario es un archivo de texto actualizado automáticamente por VSS para mostrar las distintas acciones que realizan los usuarios. Sólo se registran las acciones que cambian datos almacenados en la base de datos.

Establezca esta variable en el archivo SRCSAFE.INI mediante la opción Registrar todas las acciones en el archivo de diario de la ficha General en el cuadro de diálogo Opciones de SourceSafe del Administrador de VSS.


Keep_Checkedout (Variable de inicialización)

Vea también

Indica si desea mantener los archivos desprotegidos cuando los protege o agrega.

Sintaxis

Keep_Checkedout = {Yes|No}

Ejemplo

Indica a VSS que no vuelva a desproteger los archivos inmediatamente después de actualizarlos o agregarlos:

Keep_Checkedout = No

Comentarios

Tras agregar o proteger un archivo, no puede modificarlo inmediatamente, puesto que ya no está desprotegido. En algunas situaciones, especialmente en proyectos de una única persona, siempre se desea tener todos los archivos desprotegidos. En ese caso, establezca Keep_Checkedout a Yes, lo cual indica a VSS que vuelva a desproteger inmediatamente el archivo siempre que lo proteja o agregue.

En el Explorador de VSS, Keep_Checkedout establece el estado predeterminado de la casilla de verificación Mantener desprotegido del cuadro de diálogo Proteger, que puede activar o desactivar en casos específicos. (En la línea de comandos, puede anular esta variable con la opción -K (o -K-).)

También puede establecer esta variable en el archivo SS.INI mediante la opción Mantener los archivos desprotegidos siempre en la ficha General del cuadro de diálogo Opciones de SourceSafe.


Keyword_Masks (Variable de inicialización)

Vea también

Indica los archivos que van a utilizar, o no utilizar, expansión de palabras clave. Se utiliza en el archivo SRCSAFE.INI.

Sintaxis

Keyword_Masks = máscaras

Ejemplo

Indica que todos los archivos .C y .H, excepto SS.C, deben tener expansión de palabras clave:

Keyword_Masks = *.C, *.H, !SS.C

Comentarios

De forma predeterminada, VSS no explora los archivos en busca de expansión de palabras clave cuando ejecuta un comando Proteger o Agregar archivos. Establezca esta variable para indicar los archivos en que VSS debe expandir palabras clave, teniendo en cuenta que los comandos Agregar archivos y Proteger serán más lentos con dichos archivos.

También puede establecer esta variable en el archivo SRCSAFE.INI mediante la opción Expandir palabras clave en archivos de tipo de la ficha General en el cuadro de diálogo Opciones de SourceSafe del Administrador de VSS.


Lock_Mode (Variable de inicialización)

Establece el tipo de bloqueo de base de datos utilizado por VSS. Disponible sólo en el archivo SRCSAFE.INI.

Sintaxis

Lock_Mode = {Native|Lockfile}

Ejemplo

Indica que VSS utilizará el bloqueo nativo para evitar la colisión de registros de la base de datos:

Lock_Mode = Native

Comentarios

El bloqueo Native utiliza las capacidades inherentes de bloqueo de archivos y registros del sistema operativo (mediante la llamada del sistema fcntl). Este sistema es muy rápido, pero puede que no se acepte si está ejecutando VSS en varias máquinas UNIX.

Lockfile es un mecanismo específico de VSS que implica la creación de archivos especiales en la carpeta Data\Locks de VSS para conseguir el mismo bloqueo de registros de base de datos que la configuración Native. Este método es más lento que el bloqueo Native, pero funciona en situaciones en redes y en situaciones multiplataforma.

Es importante elegir el mecanismo de bloqueo adecuado para su sistema. Si está ejecutando VSS de forma exclusiva en máquinas Microsoft Windows NT, utilice el bloqueo Native (valor predeterminado). Si está ejecutando VSS en un entorno donde no se acepta el bloqueo de bytes en la base de datos, utilice Lockfile. Esto impide las colisiones que podrían causar resultados impredecibles en la base de datos de VSS. Si no sabe con seguridad si su red acepta el bloqueo Native, utilice el programa Testlock.exe.

Nota Si VSS no sale de forma correcta, puede deberse a que haya dejado el archivo UM.LCK en la carpeta Data\Locks. Elimine este archivo manualmente para evitar errores de testlock o resultados extraños con la variable Lock_Mode.


Long_Filenames (Variable de inicialización)

Vea también

Controla cómo VSS trata a los nombres de archivos más largos que el estándar MS-DOS.

Sintaxis

Long_Filenames = {Yes|No}

Ejemplo

Indica a VSS que trabaje con rutas de archivos de hasta 255 caracteres de longitud:

Long_Filenames = Yes

Comentarios

Esta variable permite a VSS conmutar entre el modo de nombres de archivo largos (en el que las rutas completas con el nombre de archivo incluido no debe sobrepasar 255 caracteres) y el modo de nombres de archivos cortos (en el que se aplica el formato de nombres de MS-DOS para todos los archivos). El valor predeterminado es Yes. Esta variable tiene importancia en particular bajo Windows NT que admite tanto el sistema de archivos con nombres largos como el sistema FAT de MS-DOS.

También puede establecer esta variable en su archivo SS.INI mediante la opción Usar siempre los nombres de archivo en formato MS-DOS en la ficha Ver del cuadro de diálogo Opciones de SourceSafe.


Lowercase_Files (Variable de inicialización)

Vea también

Controla cómo se muestran los nombres de archivo en el Explorador de VSS.

Sintaxis

Lowercase_Files = {Yes|No}

Ejemplo

Indica al Explorador de VSS que muestre todos los archivos en mayúsculas:

Lowercase_Files = No

Comentarios

En su modo normal, VSS muestra los archivos con la combinación de letras mayúsculas y minúsculas con que se crearon. Si esta variable se establece a Yes, VSS mostrará los archivos y carpetas en minúsculas.

Tenga en cuenta que esta variable no afecta a la presentación de los nombres de proyecto, que mantienen la combinación de letras con que se crearon.

También puede establecer esta variable en el archivo SS.INI mediante la opción Mostrar nombres de archivo en minúsculas de la ficha Ver del cuadro de diálogo Opciones de SourceSafe.


Mark_Merges (Variable de inicialización)

Vea también

Indica si VSS debe notificar todas las combinaciones, incluyendo aquellas sin conflictos. El valor predeterminado es No.

Sintaxis

Mark_Merges = {Yes|No}

Ejemplo

Indica a VSS que notifique sólo las áreas de conflicto:

Mark_Merges = No

Comentarios

Cuando combina dos archivos y ocurre un conflicto, VSS crea un archivo temporal con marcas para todos los conflictos. Si establece esta variable a Yes, VSS marcará todos los cambios que ha detectado y combinado, incluyendo aquellos que no dan lugar a un conflicto de ningún tipo. También hace más explícita cada marca, mostrando el código original y los dos valores cambiados.

Si establece esta variable a No, VSS marcará únicamente los cambios que entren en conflicto. Utiliza marcadores de conflicto para indicar los cambios de forma que pueda resolver los conflictos.


Menu_Help (Variable de inicialización)

Indica si la barra de estado de VSS muestra ayuda automática acerca de los elementos de menú e iconos seleccionados.

Sintaxis

Menu_Help = {Yes|No}

Ejemplo

Indica a VSS que muestre siempre una línea de ayuda en la barra de estado cuando se seleccione un elemento de menú o un icono:

Menu_Help = Yes

Comentarios

Cuando esta variable se establece a Yes, a medida que se desplaza por un menú o hace clic en un icono, la barra de estado de la parte inferior del Explorador de VSS muestra una breve descripción del comando seleccionado actualmente.


Merge_Ext (Variable de inicialización)

Vea también

Establece la extensión utilizada por VSS para crear un archivo temporal de combinación. El valor predeterminado es .mrg.

Sintaxis

Merge_Ext = extensión del archivo de combinación temporal

Ejemplo

Asigna a todos los archivos combinados temporales la extensión .MRG:

Merge_Ext = .mrg

Comentarios

Cuando VSS realiza una combinación automática, crea un archivo temporal con esta extensión en el que realiza la combinación. Cuando la combinación está completa, VSS cambia el nombre de este archivo o lo elimina; de esta forma, en general, nunca debe ver este archivo. Sin embargo, en caso de fallo durante una combinación, puede buscar la copia .mrg de este archivo.


Merge_Ignore (Variable de inicialización)

Pide a VSS que pase por alto los caracteres en blanco cuando combine archivos.

Sintaxis

Merge_Ignore = w

Ejemplo

Informa a VSS que pase por alto los caracteres en blanco como el tabulador y el espacio mientras realice una operación de combinación:

Merge_Ignore = w

Comentarios

También puede establecer esta variable mediante la ficha Diferencias del cuadro de diálogo Opciones del menú Herramientas en el Explorador de VSS. Active la casilla de comprobación Ignorar diferencias en espacios en blanco al combinar archivos para hacerlo.


Multiple_Checkouts (Variable de inicialización)

Controla si varias personas pueden desproteger un archivo simultáneamente. Sólo se utiliza en el archivo SRCSAFE.INI.

Sintaxis

Multiple_Checkouts = {Yes|No}

Ejemplo

Indica que sólo una persona a la vez puede tener un archivo desprotegido (valor predeterminado):

Multiple_Checkouts = No

Comentarios

En circunstancias normales, en VSS una desprotección es exclusiva; es decir, sólo una persona a la vez puede tener un archivo desprotegido. Sin embargo, si establece esta variable a Yes en el archivo SRCSAFE.INI, VSS permite que varios usuarios desprotejan el mismo archivo. Cuando el primer usuario protege el archivo, VSS actualiza el archivo. Posteriormente, VSS combina todos los cambios que se producen a continuación.

También puede establecer esta variable en el archivo SRCSAFE.INI mediante la opción Permitir varias desprotecciones de la ficha General en el cuadro de diálogo Opciones de SourceSafe del Administrador de VSS.

Nota No se permiten varias desprotecciones en archivos binarios.


Output (Variable de inicialización)

Vea también

Establece el método predeterminado para mostrar el resultado.

Sintaxis

Output = configuración válida de -O

Ejemplo

Pagina todo el resultado de forma predeterminada:

Output =

Envía todo el resultado al archivo Outlog.txt de forma predeterminada:

Output = Outlog.txt

Comentarios

En la línea de comandos de VSS, la variable de inicialización Output establece el valor predeterminado para la opción -O de la línea de comandos para cualquier función. El primer ejemplo anterior es equivalente a -O e indica a VSS que pagine el resultado. El segundo es equivalente a -oOutlog.txt, una instrucción para redirigir todo el resultado a un archivo.


OutputWindow (Variable de inicialización)

Vea también

Controla la forma en que el panel inferior mostrará los resultados de las operaciones de VSS. Observe que el nombre antiguo de esta variable (Results_Window) es obsoleto.

Sintaxis

OutputWindow = {Yes|No}

Ejemplo

Muestra el panel de resultados:

OutputWindow = Yes

Comentarios

Cuando realiza un comando como Obtener la última versión, VSS muestra los resultados del comando en el panel de resultados.

Si establece a No la variable, no se muestra el panel de resultados. Los errores se mostrarán en la ventana de mensajes de error estándar.

También puede establecer esta variable en su archivo SS.INI mediante la opción Mostrar panel de resultados de la ficha Ver en el cuadro de diálogo Opciones de SourceSafe.


Project (Variable de inicialización)

Almacena el proyecto actual de un usuario. Se establece automáticamente al salir de VSS.

Advertencia No establezca esta variable manualmente.

Sintaxis

Project = proyecto actual de Visual SourceSafe

Ejemplo

Indica que el proyecto raíz es su proyecto actual:

Project = $/

Comentarios

Su proyecto actual se almacena en esta variable en su archivo SS.INI.


Reconcile_Project (Variable de inicialización)

Vea también

Determina el comportamiento predeterminado cuando sincronice las diferencias entre proyectos con el comando Mostrar diferencias.

Sintaxis

Reconcile_Project = {Get|Ignore, Delete from folder|Recover deleted file|Add to project|Ignore, Add to project|Ignore, Check In|Undo Check Out|Get|Ignore, Get|Ignore}

Ejemplo

Informa a VSS que debe utilizar el comportamiento normal predeterminado para sincronizar diferencias de proyectos en el cuadro de diálogo Sincronizar todas las diferencias:

Reconcile_Project = Get, Delete, Add, Check In, Get

Comentarios

Cambiar esta variable le permite personalizar las opciones predeterminadas del cuadro de diálogo Sincronizar todas las diferencias. El valor de esta variable se utiliza cuando especifica la opción -F para el comando Project Difference de la línea de comandos.

Los tres primeros valores se utilizan para especificar el comportamiento de la sincronización de los archivos que aparecen sólo en una lista:

Archivos que no están en su carpeta de trabajo. Esta opción especifica lo que desea que ocurra cuando VSS encuentre archivos que no estén en su carpeta de trabajo, pero que sí estén en el proyecto. Especifique Get (el valor predeterminado) para obtener archivos que faltan en su carpeta de trabajo. Especifique Ignore para no realizar ninguna acción con estos archivos.

Archivos que se han eliminado del proyecto. En esta opción se especifica lo que desea que ocurra cuando VSS encuentre archivos que están en su carpeta de trabajo, pero que se han eliminado del proyecto. Especifique Delete from folder (el valor predeterminado) para eliminar esos archivos de su carpeta de trabajo. Especifique Recover deleted file para recuperar el archivo eliminado y situar una copia en su carpeta de trabajo. Especifique Add to project para agregar esos archivos a su proyecto. Especifique Ignore para no realizar ninguna acción con estos archivos.

Archivos que no están en el proyecto. En esta opción podrá especificar qué pasará cuando VSS encuentre archivos que no estén en su proyecto, pero que sí estén en su carpeta de trabajo. Especifique Add to Project (el valor predeterminado) para agregar esos archivos a su proyecto de VSS. Especifique Ignore para no realizar ninguna acción con estos archivos.

Los dos últimos valores especifican el comportamiento de la sincronización de archivos que aparecen en las dos listas:

Archivos que ha desprotegido. En esta opción podrá especificar lo que ocurrirá cuando VSS encuentre archivos desprotegidos para usted y que son distintos en su carpeta de trabajo. Especifique Check In (el valor predeterminado) para proteger estos archivos en su proyecto de VSS. Especifique Undo Check Out para deshacer la desprotección de estos archivos. Especifique Get Latest Version para sobreescribir su archivo desprotegido con una copia de sólo lectura (perdiendo los cambios que haya realizado). Especifique Ignore para no realizar ninguna acción con estos archivos.

Archivos que no ha desprotegido. Especifica qué quiere que suceda cuando VSS encuentre archivos que no están desprotegidos para usted pero son diferentes en su carpeta de trabajo. Especifique Get Latest Version (el valor predeterminado) para obtener la última versión de estos archivos. Especifique Ignore para no realizar ninguna acción con estos archivos.


Recursive (Variable de inicialización)

Vea también

Indica si las operaciones de VSS actúan recursivamente de forma predeterminada.

Sintaxis

Recursive = {Yes|No}

Ejemplo

Indica que los comandos sólo actúen sobre el proyecto, actual o el especificado, sin entrar en todos los subproyectos:

Recursive = No

Comentarios

Muchos comandos de VSS (como Obtener la última versión o Mostrar historial) pueden realizarse sobre un proyecto específico (y todos los archivos que contiene directamente) o bajar de forma recursiva por un árbol de proyectos completo. Siempre puede convertir un determinado comando en recursivo si activa la casilla de verificación apropiada del Explorador de VSS o especifica la opción -R de la línea de comandos. Sin embargo, si establece esta variable a Yes todos los comandos serán recursivos de forma predeterminada.

También puede establecer esta variable en el archivo SS.INI mediante la opción Actuar recursivamente en los proyectos en la ficha General del cuadro de diálogo Opciones de SourceSafe.


Refresh_Display (Variable de inicialización)

Vea también

Controla si VSS actualiza automáticamente su lista de archivos del panel de archivos del Explorador de VSS .

Sintaxis

Refresh_Display = {Yes|No}

Ejemplo

Indica al Explorador de VSS que regenere periódicamente su lista de archivos:

Refresh_Display = Yes

Comentarios

Periódicamente, el Explorador de VSS llena su lista de archivos, de forma que cualquier cambio que los usuarios hayan realizado se refleje en la pantalla. La actualización mantiene la pantalla de VSS actualizada, pero también provoca un retraso momentáneo. Esta variable controla si VSS actualiza automáticamente su lista de archivos; si está establecida a Yes, los controles Refresh_Interval controlan la frecuencia con que se hace. Si esta variable está establecida a No, puede que desee actualizar manualmente la lista de archivos periódicamente, mediante el comando Actualizar lista de archivos del menú Ver.

También puede establecer esta variable en el archivo SS.INI mediante la opción Actualizar automáticamente la lista de archivos en la ficha Ver del cuadro de diálogo Opciones de SourceSafe.


Refresh_Interval (Variable de inicialización)

Vea también

Establece el periodo de tiempo entre actualizaciones automáticas de la lista de archivos.

Sintaxis

Refresh_Interval = número de segundos

Ejemplo

Establece el intervalo de actualización a 300 segundos (5 minutos):

Refresh_Interval = 300

Comentarios

Periódicamente, el Explorador de VSS vuelve a llenar su lista de archivos, de forma que cualquier cambio que los demás usuarios hayan realizado se reflejará en la pantalla. La actualización mantiene la pantalla de VSS actualizada, pero también provoca un retraso momentáneo.

Puede forzar las actualizaciones manualmente mediante el comando Actualizar lista de archivos del menú Ver, pero si está activa la actualización automática (que es la opción predeterminada), esta variable puede utilizarse para cambiar el intervalo de tiempo entre las actualizaciones.

También puede establecer esta variable en el archivo SS.INI mediante la opción Actualizar automáticamente la lista de archivos en la ficha Ver del cuadro de diálogo Opciones de SourceSafe.


Relevant_Masks (Variable de inicialización)

Vea también

Establece las máscaras del comando Agregar de VSS.

Sintaxis

Relevant_Masks = máscaras

Ejemplo

Restringe el comando Agregar a los archivos que tienen las extensiones .C, .H o no tienen extensión:

Relevant_Masks = *.C, *.H, *.

Restringe el comando Agregar a todos los archivos excepto los que tienen la extensión .obj:

Relevant_Masks = !*.OBJ

Comentarios

Una carpeta de trabajo típica de VSS contiene una serie de archivos de código importantes que están en el proyecto de VSS, así como una serie de archivos intermedios no importantes que no están en el proyecto. Por ejemplo, en una carpeta C los archivos .C y .H contienen el código; los archivos .obj no se colocan en el proyecto.

Relevant_Masks indica qué archivos colocaría normalmente en un proyecto. Esto no le impide colocar otros archivos dentro del proyecto; sin embargo tiene efectos potencialmente útiles.

En primer lugar, si agrega una carpeta completa a VSS en un comando (escribiendo ss add * en la línea de comandos de VSS o arrastrando una carpeta del Administrador de archivos a VSS), sólo se agregan los archivos coincidentes con la máscaras relevantes. Es posible agregar otros archivos individualmente.

En segundo lugar, cuando ejecuta el comando Mostrar diferencias de VSS sobre un proyecto para comparar el proyecto actual con su carpeta de trabajo, los archivos que no coincidan con las máscaras relevantes no se mostrarán como diferencias.

Finalmente, las máscaras relevantes se utilizan como opción predeterminada en el cuadro combinado Mostrar archivos de tipo del cuadro de diálogo Agregar archivos; por tanto, de forma predeterminada sólo se muestran esos archivos.

También puede establecer esta variable en el archivo SS.INI mediante la ficha Tipos de archivo del cuadro de diálogo Opciones de SourceSafe.


Replace_Writable (Variable de inicialización)

Vea también

Controla lo que ocurre cuando intenta obtener o desproteger un archivo en la parte superior de un archivo editable. El valor predeterminado es Ask.

Sintaxis

Replace_Writable = {Merge|Replace|Ask|Skip}

Ejemplo

Indica a VSS que no sobrescriba los archivos editables:

Replace_Writable = No

Comentarios

Cuando obtiene o desprotege un archivo, VSS copia el archivo a su carpeta de trabajo. Si ya hay una copia editable (que no es de sólo lectura) del archivo en su carpeta de trabajo (por ejemplo, si tiene el archivo desprotegido), sobrescribirlo puede destruir su trabajo.

VSS proporciona cuatro formas de controlar esta situación.

  • Merge: combina cualquier diferencia entre la copia maestra del archivo y el archivo de su carpeta de trabajo junto con su copia de la carpeta de trabajo. Esto es útil cuando desea asegurarse de que está obteniendo los cambios de otros usuarios y tiene el archivo desprotegido. Si tiene esta opción configurada y no tiene el archivo desprotegido, VSS trata ese archivo automáticamente como si tuviera establecida la opción Skip.

  • Replace: reemplaza el archivo.

  • Ask: le da una opción cada vez que VSS encuentra esta situación.

  • Skip: no reemplaza el archivo y no genera un error.

También puede establecer esta variable en el archivo SS.INI mediante la opción Reemplazar archivos editables de la ficha Archivos locales del cuadro de diálogo Opciones de SourceSafe.

Utilice la variable de inicialización Replace_Checkout para controlar como VSS trata los archivos editables en su directorio de trabajo cuando obtiene o desprotege archivos que previamente ya han sido desprotegidos.


Results_Window (Variable de inicialización)

Vea también

Controla la utilización de una ventana con desplazamiento que muestra el resultado de una operación de VSS.

Sintaxis

Results_Window = {Yes|No}

Ejemplo

Coloca los resultados del comando en una ventana:

Results_Window = Yes

Comentarios

Cuando ejecuta un comando como Obtener, VSS muestra el resultado del comando en la ventana Resultados. Una vez el comando ha terminado, la ventana se cierra.

Si establece esta variable a No, nunca se mostrará la ventana Resultados. Los errores se mostrarán en la ventana de mensajes de error estándar.

También puede establecer esta variable en el archivo SS.INI mediante la opción Mostrar panel de resultados en la ficha Ver del cuadro de diálogo Opciones de SourceSafe.


Reuse_Comment (Variable de inicialización)

Vea también

Indica al Explorador de VSS que llene los comentarios con el último comentario especificado.

Sintaxis

Reuse_Comment = {Yes|No}

Ejemplo

Desactiva la utilización del último comentario:

Reuse_Comment = No

Comentarios

Cuando el Explorador de VSS le pide un comentario, si no tiene establecida la variable Comment_Template, el comentario estará inicialmente en blanco. Sin embargo, si establece esta variable a Yes, el campo de comentario se llenará automáticamente con el comentario que ha escrito más recientemente. Esto facilita el uso repetido del mismo comentario; o bien, puede empezar a escribir para reemplazar el comentario anterior con uno nuevo.

También puede establecer esta variable en el archivo SS.INI mediante la opción Volver a usar el último comentario de la ficha General del cuadro de diálogo Opciones de SourceSafe.


Save_Settings (Variable de inicialización)

Vea también

Establece si se guarda la configuración de un comando Mostrar diferencias a nivel de archivos entre las distintas sesiones de VSS.

Sintaxis

Save_Settings = {Yes|No}

Ejemplo

Indica a VSS que guarde la configuración del comando Mostrar diferencias en el nivel de archivo entre las distintas sesiones:

Save_Settings = Yes

Comentarios

Sólo afecta a la configuración en el nivel de archivos del comando Mostrar diferencias (menú Herramientas).


SetTime (Variable de inicialización)

Vea también

Controla la fecha y la hora asignadas a sus copias locales por un comando Obtener la última versión.

Sintaxis

SetTime = {Current|Mod|Update}

Ejemplo

Da a los archivos una nueva marca de fecha y hora cuando VSS los obtiene:

SetTime = Current

Comentarios

  • Current: establece la fecha y hora del archivo como la actual de forma predeterminada, siempre que VSS obtiene un archivo (con Obtener la última versión, Desproteger, Deshacer desprotección o muchos otros comandos). Esto indica al compilador que el archivo acaba de cambiar y hay que compilarlo de nuevo.

  • Modification: establece la copia local a la fecha y hora del archivo que se modificó por última vez.

  • Update: establece la copia local a la fecha y hora del archivo que se protegió por última vez.

También puede establecer esta variable en el archivo SS.INI mediante la opción Establecer fecha y hora en archivos locales en la ficha Archivos locales del cuadro de diálogo Opciones de SourceSafe.


Shadow_DOSName (Variable de inicialización)

Vea también

Controla si VSS colocará nombres de archivos largos en la carpeta central. Sólo se utiliza en el archivo SRCSAFE.INI.

Sintaxis

Shadow_DOSName = {Yes|No}

Ejemplo

Permite nombres de archivos largos en la carpeta central:

Shadow_DOSName = No

Comentarios

Las versiones de VSS que aceptan nombres de archivos largos (Windows NT y Macintosh) pueden colocar estos nombres de archivos largos en una carpeta central. Sin embargo, en un entorno multiplataforma, quizá no sea deseable, ya que puede crear nombres de archivos que resultarán ilegibles para MS-DOS. Por tanto, se puede utilizar esta variable para obligar a todas las versiones de VSS a truncar los nombres de la carpeta central para que sean nombres estándar de MS-DOS.


Shadow_EOL (Variable de inicialización)

Vea también

Establece el carácter de fin de línea utilizado en la carpeta central. Sólo se utiliza en el archivo SRCSAFE.INI.

Sintaxis

Shadow_EOL = {n|r|rn}

Ejemplo

Termina todas las líneas de la carpeta central con la combinación retorno de carro y avance de línea:

Shadow_EOL = rn

Comentarios

Cuando VSS copia un archivo a la carpeta central, utiliza el carácter de fin de línea utilizado por su propio sistema operativo. Por ejemplo, VSS para MS-DOS utiliza la combinación de retorno de carro y avance de línea. Por tanto, en un entorno multiplataforma, los archivos de la carpeta central son una mezcla de caracteres de fin de línea, basados en el sistema operativo en el que cada archivo se actualizó la última vez.

Esta variable pasa por alto este mecanismo, obligando a todas las versiones de VSS a utilizar el carácter de fin de línea especificado. Establezca la variable a n para avances de línea (predeterminado en UNIX), r para retornos de carro o rn para combinaciones de retorno de carro y avance de línea (predeterminado en PC).

También puede establecer esta variable en el archivo SRCSAFE.INI mediante la opción Carácter de fin de línea para archivos en la ficha Carpetas centrales del cuadro de diálogo Opciones de SourceSafe del Administrador de VSS.


Shadow_Extension (Variable de inicialización)

Vea también

Cambia la extensión de los archivos situados en la carpeta central. Sólo se utiliza en el archivo SRCSAFE.INI.

Sintaxis

Shadow_Extension = extensión

Ejemplo

Establece la extensión central como ??V:

Shadow_Extension = ??V

Comentarios

De forma predeterminada se asigna a todos los archivos el mismo nombre en la carpeta central que el que tienen en VSS. Sin embargo, en algunos casos (especialmente para los programas Make) puede que desee que los archivos de la carpeta central tengan diferentes extensiones que sus correspondientes reales. Por tanto, puede utilizar esta variable para establecer la extensión que tendrán los archivos en la carpeta central.

Por ejemplo, si establece esta variable como .sdw, se dará a todos los archivos de la carpeta central la extensión sdw. Sin embargo, esto no le permite distinguir entre los diferentes tipos de archivos, por lo que se proporciona el signo de interrogación como carácter especial, para indicar a VSS que utilice el carácter real. Por tanto, en el ejemplo anterior ??V, la extensión.pas se convierte en .pav. La extensión .c se convierte en .c_v.


Shadow_ReadOnly (Variable de inicialización)

Vea también

Controla si los archivos de la carpeta central son de sólo lectura. Sólo se utiliza en el archivo SRCSAFE.INI.

Sintaxis

Shadow_ReadOnly = {Yes|No}

Ejemplo

Especifica que todos los archivos de VSS en la carpeta central son de sólo lectura (valor predeterminado):

Shadow_Readonly = Yes

Comentarios

Esta variable activa el indicador de sólo lectura para todos los archivos que VSS coloque en la carpeta central.

También puede establecer esta variable en el archivo SRCSAFE.INI mediante la opción Establecer indicador de sólo lectura para todos los archivos de la ficha Carpetas centrales en el cuadro de diálogo Opciones de SourceSafe del Administrador de VSS.


Shadow_SetTime (Variable de inicialización)

Vea también

Controla la fecha y la hora dada a los archivos en la carpeta central. Sólo se utiliza en el archivo SRCSAFE.INI.

Sintaxis

Shadow_SetTime = {Current|Mod|Update}

Ejemplo

Marca los archivos centrales con la fecha y hora que tienen en la carpeta central (valor predeterminado):

Shadow_SetTime = Current

Comentarios

Esta variable afecta a la marca de fecha y hora dada a los archivos de la carpeta central, de la misma forma que SetTime afecta a los archivos de la carpeta central.

También puede establecer esta variable en el archivo SRCSAFE.INI mediante la opción Fecha y hora del archivo de la ficha Carpetas centrales en el cuadro de diálogo Opciones de SourceSafe del Administrador de VSS.


Shadow (Variable de inicialización)

Vea también

Establece la carpeta central de un proyecto. Sólo se utiliza en el archivo SRCSAFE.INI.

Sintaxis

Shadow = carpeta central

Ejemplo

Establece M:\Masters\Word como carpeta central del proyecto $/WORD:

[$/WORD]
Shadow = M:\MASTERS\WORD

Comentarios

Esta variable hace referencia a la carpeta central que ha creado para su proyecto. Esta carpeta centraliza el proyecto, reflejando cualquier cambio de un archivo en su propio contenido y permaneciendo actualizado. Antes de establecer esta variable, debe crear la carpeta central donde lo desee y llenarla con los archivos que desee mantener ahí (la forma más sencilla es mediante un comando Obtener la última versión de dicha carpeta). Desde ese momento, los archivos que haya colocado en la carpeta central se mantendrán actualizados. Asimismo, cualquier archivo nuevo agregado o eliminado del proyecto en la base de datos de VSS se actualiza en la carpeta central.

La carpeta central no debería ser la carpeta en la que trabaja y en la que modifica el código. Es una carpeta independiente que es mantenida por VSS. Sin embargo, puede dirigirse a esa carpeta para generar su proyecto o ver el código, ya que refleja exactamente el estado actual del proyecto.

También puede establecer esta variable en el archivo SRCSAFE.INI mediante la opción Establecer la carpeta central para el proyecto de la ficha Carpetas centrales en el cuadro de diálogo Opciones de SourceSafe del Administrador de VSS. Si utiliza la ficha Carpetas centrales, no necesitará usar el comando Obtener la última versión para inicializar la carpeta.


SiteMap (Variable de inicialización)

Vea también

Especifica la ubicación del archivo HTML generado cuando el usuario selecciona el comando Crear mapa de sitios del menú Web de VSS.

Sintaxis

SiteMap = ruta_archivo

Ejemplo

Especifica que el archivo Sitemap.html es el mapa de sitios generado automáticamente para el proyecto donde aparece esta variable:

SiteMap = c:\webproj\sitemap.html

Comentarios

Esta variable también se puede establecer en la ficha Proyectos Web del comando Opciones del menú Herramientas del Administrador de VSS.


Skip (Variables de inicialización)

Controla la utilización de cuadros de diálogo de opciones en los comandos del Explorador de VSS.

Sintaxis

Skip_nombre variable = {Yes|No}

Ejemplos

Skip_FCheckout = No
Skip_PCheckout = Yes
Skip_FGet = No
Skip_PGet = Yes
Skip_FUncheckout = No
Skip_Pdeploy = Yes
Skip_Psitemap = Yes
Skip_PUncheckout = Yes
Skip_FDiff = No
Skip_PDiff = Yes
Skip_FHistory = No
Skip_PHistory = No

Comentarios

Cuando ejecuta un comando en el Explorador de VSS, puede elegir si se muestra o no un cuadro de diálogo que le ofrece diversas opciones para establecer. La ventaja de este cuadro de diálogo es que le permite tratar cada ejecución de un comando de forma diferente. La desventaja es que agrega al menos un paso adicional a cada operación común.

De forma predeterminada, VSS no muestra cada cuadro de diálogo cuando ejecuta un comando sobre un archivo; muestra el cuadro de diálogo cuando ejecuta un comando sobre un proyecto. Estas variables pueden utilizarse para modificar estos valores predeterminados; por ejemplo, si establece Skip_PGet = Yes, no se mostrará ningún cuadro de diálogo cuando ejecute un comando Obtener la última versión en el nivel de proyecto. Si establece Skip_FCheckout = No, VSS mostrará el cuadro de diálogo Desproteger cuando utilice el comando Desproteger en el nivel de proyecto.

También puede establecer estas variables en el archivo SS.INI mediante las opciones de la ficha Diálogos de comandos en el cuadro de diálogo Opciones de SourceSafe.


Smart_Mode (Variable de inicialización)

Vea también

Activa y desactiva la característica SmartMode de VSS.

Sintaxis

Smart_Mode = {Yes|No}

Ejemplo

Desactiva la característica SmartMode de VSS:

Smart_Mode = No

Comentarios

Smart_Mode indica a VSS si se van a utilizar o no sus características SmartMode. Las características SmartMode son:

  • Cuando crea o recupera un proyecto, VSS establece el nuevo proyecto como el proyecto actual.

  • Cuando elimina o destruye un archivo, VSS elimina la copia local correspondiente.

  • Cuando cambia el nombre de un archivo, VSS cambia el nombre de la correspondiente copia local.

También puede establecer esta variable en el archivo SS.INI mediante la opción Quitar copa local después de Eliminar en la ficha Archivos locales del cuadro de diálogo Opciones de SourceSafe.


Status_Bar (Variable de inicialización)

Muestra y oculta la barra de estado del Explorador de VSS.

Sintaxis

Status_Bar = {Yes|No}

Ejemplo

Muestra la barra de estado:

Status_Bar = Yes

Comentarios

La barra de estado presenta información acerca de los archivos mostrados en el panel de archivos del Explorador de VSS, así como el orden, el nombre de desprotección, el número de archivos del proyecto, etc. También muestra mensajes de estado y de Ayuda.

También puede establecer esta variable en el archivo SS.INI mediante la opción Mostrar barra de estado en la ficha Ver del cuadro de diálogo Opciones de SourceSafe.


Store_Deltas (Variable de inicialización)

Establece si VSS almacena la información de cambios entre las versiones de un archivo. El valor predeterminado es Yes.

Sintaxis

Store_Deltas = {Yes|No}

Ejemplo

Almacena todos los cambios realizados entre versiones de archivos:

Store_Deltas = Yes

Comentarios

Raramente debería utilizar esta variable. Establecer esta variable a No ahorra espacio en disco en el servidor de VSS, pero no le permite volver a crear las versiones anteriores de los archivos.

Cuando agrega archivos a VSS, el comando Agregar archivos le permite decidir si VSS mantiene su versión anterior de un archivo o sólo la última versión con la casilla de verificación Guardar sólo la última versión en la ficha Opciones avanzadas del cuadro de diálogo Agregar archivos. Establecer la variable Store_Deltas controla el valor predeterminado de esta opción. El valor predeterminado es Yes, pero puede anular manualmente este valor para archivos individuales en el cuadro de diálogo Agregar archivos.


Temp_Path (Variable de inicialización)

Vea también

Establece la carpeta donde VSS almacena los archivos temporales.

Sintaxis

Temp_Path = ruta de la carpeta temporal de Visual SourceSafe

Ejemplo

Indica que la ruta temporal es una carpeta llamada Temp que se encuentra justo debajo de la carpeta en la que se encuentra SRCSAFE.INI:

Temp_Path = Temp

Comentarios

También puede establecer esta variable en el archivo SS.INI mediante la opción Carpeta para archivos temporales en la ficha General del cuadro de diálogo Opciones de SourceSafe.


Toolbar (Variable de inicialización)

Vea también

Muestra u oculta la barra de herramientas de VSS.

Sintaxis

Toolbar = {Yes|No}

Ejemplo

Muestra la barra de herramientas:

Toolbar = Yes

Comentarios

En la parte superior del Explorador de VSS está la barra de herramientas, o barra de iconos, que le da acceso rápido con el mouse a algunas de las características más comunes de VSS.

También puede establecer esta variable en el archivo SS.INI mediante la opción Mostrar barra de herramientas en la ficha Ver del cuadro de diálogo Opciones de SourceSafe.


ToolTips (Variable de inicialización)

Vea también

Establece si se muestra Información sobre herramientas a medida que arrastra el puntero del mouse (ratón) sobre los botones de la barra de herramientas.

Sintaxis

ToolTips = {Yes|No}

Ejemplo

Muestra Información sobre herramientas:

ToolTips = Yes


Update_No_Change (Variable de inicialización)

Vea también

Controla qué ocurre cuando protege un archivo que no ha cambiado.

Sintaxis

Update_No_Change = {Update|Uncheckout|Ask}

Ejemplo

Deshace la desprotección de los archivos que no han cambiado:

Update_No_Change = Uncheckout

Comentarios

Cuando protege un archivo que no ha cambiado desde la última vez que lo desprotegió, VSS tiene tres opciones:

  • Actualizar el archivo

  • Deshacer la desprotección del archivo.

  • Preguntarle cómo tratar el archivo.

Debido a que no se han realizado cambios, la única diferencia entre las dos primeras opciones es que la protección genera una entrada en el archivo de historial con un comentario pero sin cambiar el registro, mientras que deshacer la desprotección no lo hace.

También puede establecer esta variable en el archivo SS.INI mediante la opción Proteger los archivos no modificados en la ficha General del cuadro de diálogo Opciones de SourceSafe.


URL (Variable de inicialización)

Vea también

Marca un proyecto como un proyecto de sitio Web. Cuando se selecciona un proyecto de sitio Web, se activa el menú Web de VSS.

Sintaxis

URL = dirección_url

Ejemplo

Especifica que el proyecto en el que se muestra esta variable corresponde a una dirección URL de un sitio Web:

URL = http://www.microsoft.com/ssafe

Comentarios

Esta variable también se puede establecer en la ficha Proyectos Web del comando Opciones del menú Herramientas.


Use_Network_Name (Variable de inicialización)

Establece si VSS leerá los nombres de inicio de sesión de los usuarios del sistema operativo. Sólo se utiliza en el archivo SRCSAFE.INI.

Sintaxis

Use_Network_Name = {Yes|No}

Ejemplo

Utiliza los nombres de inicio de sesión en red como los nombres de inicio de sesión en VSS:

Use_Network_Name = Yes

Comentarios

Establézcala a No sólo si desea que todos los usuarios de VSS utilicen nombres de inicio de sesión diferentes de sus nombres de inicio de sesión en red. Si la establece a No, VSS mostrará un cuadro de diálogo de inicio de sesión a menos que proporcione el nombre de usuario de otra forma (por ejemplo, mediante una variable de entorno).

Cuando se establece a Yes, VSS utiliza el nombre de inicio de sesión en red de Windows como nombre de usuario de VSS. Si el nombre de red coincide con el nombre de usuario de VSS, se producirá automáticamente la conexión con VSS.

También puede establecer esta variable en el archivo SRCSAFE.INI mediante la opción Usar el nombre de red para iniciar la sesión del usuario automáticamente de la ficha General en el cuadro de diálogo Opciones de SourceSafe del Administrador de VSS.


Use_ReadOnly (Variable de inicialización)

Controla la utilización de VSS del indicador de sólo lectura para los archivos que no están desprotegidos.

Sintaxis

Use_ReadOnly = {Yes|No}

Ejemplo

Marca las copias locales de los archivos no desprotegidos como de sólo lectura:

Use_ReadOnly = Yes

Comentarios

De forma predeterminada, VSS supone que los archivos de la carpeta de trabajo que no haya desprotegido (es decir, los archivos que no debe modificar) son de sólo lectura. VSS establece el indicador de sólo lectura cuando obtiene, agrega, protege o deshace la desprotección de un archivo y lo utiliza como una señal de que no ha estado modificando el archivo (así VSS puede sobrescribirlo). Si establece esta variable a No, VSS no establecerá el indicador de sólo lectura en los archivos de la carpeta de trabajo.

También puede establecer esta variable en el archivo SS.INI mediante la opción Utilizar indicador de sólo lectura para archivos no desprotegidos en la ficha Archivos locales del cuadro de diálogo Opciones de SourceSafe.


Users_Txt (Variable de inicialización)

Establece la ubicación del archivo Users.txt utilizada para almacenar la ubicación de los archivos SS.INI de los usuarios. Disponible sólo en el archivo SRCSAFE.INI.

Sintaxis

Users_Txt = ruta carpeta

Ejemplo

Indica a VSS que utilice el archivo Users.txt situado en la carpeta de SRCSAFE.INI:

Users_Txt = USERS.TXT

Comentarios

Modifíquelo sólo si tiene que mover el archivo Users.txt. Puede especificar un nombre de archivo diferente o una ruta completa hasta el archivo de texto de usuarios, por ejemplo, \\SRCSRVR\VSS6\Users.txt.


Virtual_Root (Variable de inicialización)

Establece la raíz virtual para un determinado proyecto Web.

Sintaxis

Virtual_Root = [nombre_del_proyecto]

Ejemplo

Especifica que cuando se comprueban los hipervínculos de Web, se comprueban los vínculos que incluyen una designación de raíz virtual (compatible con Microsoft Internet Information Server) de /VBASIC:

Virtual_Root = /VBASIC

Comentarios

Si su proyecto Web no incluye hipervínculos a direcciones URL con una raíz virtual, no necesita establecer esta variable.


Visual_Diff_ChangeClr (Variable de inicialización)

Vea también

Establece el color que se utiliza para indicar las líneas cambiadas en el cuadro de diálogo Diferencias del archivo, disponible con el comando Mostrar diferencias (archivo) del menú Herramientas.

Sintaxis

Visual_Diff_ChangeClr = {R,G,B|Color}

Ejemplo

Establece a azul el color de las líneas cambiadas:

Visual_Diff_ChangeClr = <0,0,255>

Establece a azul el color de las líneas cambiadas:

Visual_Diff_ChangeClr = Blue

Comentarios

Si establece esta variable, asegúrese de que establece Visual_Diff_InsertClr y Visual_Diff_DeleteClr a algún otro valor. Puede especificar cualquier color con la sintaxis RGB (3 números entre 1 y 255 separados por comas) o utilizar los siguientes nombres de color: Black, Blue, Red, Green, Cyan, Magenta, Gray, White, Yellow, Light Blue, Light Yellow, Light Green, Light Red, Light Magenta, Light Cyan.


Visual_Diff_DeleteClr (Variable de inicialización)

Vea también

Establece el color utilizado para indicar las líneas eliminadas del cuadro de diálogo Diferencias del archivo, disponible con el comando Mostrar diferencias (archivo) del menú Herramientas.

Sintaxis

Visual_Diff_DeleteClr = {R,G,B|Color}

Ejemplo

Establece a rojo el color de las líneas eliminadas:

Visual_Diff_DeleteClr = <255,0,0>

Establece a rojo el color de las líneas eliminadas:

Visual_Diff_DeleteClr = Red

Comentarios

Si establece esta variable, asegúrese de que establece Visual_Diff_InsertClr y Visual_Diff_ChangeClr a algún otro valor. Puede especificar cualquier color con la sintaxis RGB (3 números entre 1 y 255 separados por comas) o utilizar los siguientes nombres de color: Black, Blue, Red, Green, Cyan, Magenta, Gray, White, Yellow, Light Blue, Light Yellow, Light Green, Light Red, Light Magenta, Light Cyan.


Visual_Diff_InsertClr (Variable de inicialización)

Vea también

Establece el color utilizado para indicar las líneas insertadas en el cuadro de diálogo Diferencias del archivo, disponible con el comando Mostrar diferencias (archivo) del menú Herramientas.

Sintaxis

Visual_Diff_InsertClr = {R,G,B|Color}

Ejemplo

Establece a verde el color de las líneas insertadas:

Visual_Diff_InsertClr = <0,255,0>

Establece a verde el color de las líneas insertadas:

Visual_Diff_InsertClr = Green

Comentarios

Si establece esta variable, asegúrese de que establece Visual_Diff_DeleteClr y Visual_Diff_ChangeClr a algún otro valor. Puede especificar cualquier color con la sintaxis RGB (3 números entre 1 y 255 separados por comas) o utilizar los siguientes nombres de color: Black, Blue, Red, Green, Cyan, Magenta, Gray, White, Yellow, Light Blue, Light Yellow, Light Green, Light Red, Light Magenta, Light Cyan.


Visual_Merge (Variable de inicialización)

Vea también

Establece si se utilizará la característica Combinación visual cuando combine archivos.

Sintaxis

Visual_Merge = {Yes|No|Only if there are conflicts}

Ejemplo

Informa a VSS que debe utilizar la característica Combinación visual sólo cuando existan conflictos en los cambios entre dos archivos combinados; de lo contrario, en utiliza la combinación estándar:

Visual_Merge = Only when there are conflicts

Comentarios

También puede establecer esta variable mediante la casilla de verificación Usar combinación visual de la ficha General del cuadro de diálogo Opciones del menú Herramientas.


Warning (Variables de inicialización)

Controla las advertencias que muestra el Explorador de VSS. No se aplica a la línea de comandos de VSS (es decir, no se generan advertencias en la línea de comandos cualquiera que sea el valor de esta variable.)

Sintaxis

Warn_Destroy = {Yes|No}

Warn_Exit = {Yes|No}

Warn_Multiple_Checkout = {Yes|No}

Warn_Purge = {Yes|No}

Warn_Remove = {Yes|No}

Warn_Rollback = {Yes|No}

Warn_UnCheckout = {Yes|No}

Ejemplo

Muestra una advertencia antes de eliminar archivos o proyectos:

Warn_Remove = Yes

Comentarios

Siempre que realice una acción que podría producir la pérdida o eliminación accidental de datos, VSS muestra una advertencia. Si bien la mayoría de los usuarios encuentran estas advertencias útiles para evitar cambios accidentales, algunos usuarios prefieren eliminar el paso adicional de responder a la advertencia.

Estas variables pueden establecerse (independientemente unas de otras) para desactivar varias advertencias. De forma predeterminada, todas las advertencias se consideran activadas, excepto Warn_Exit. Observe que la variable de inicialización Multiple_Checkouts le avisa cuando va a desproteger un archivo que otro usuario tiene desprotegido; esto es lo único relevante cuando Multiple_Checkouts = Yes.

También puede establecer estas variables en el archivo SS.INI mediante la ficha Advertencias del cuadro de diálogo Opciones de SourceSafe.


Web_Default_Filename (Variable de inicialización)

Vea también

Especifica el nombre de archivo predeterminado para el proyecto Web. El archivo predeterminado es el que utilizan los exploradores Web si alguien especificó una dirección URL de su sitio sin indicar un nombre de archivo. Los nombres de archivo predeterminados comunes son Default.htm e Index.htm.

Sintaxis

Web_Default_Filename = c:\website\default.htm

Ejemplo

Especifica que el archivo Index.html es el predeterminado cuando un usuario escribe la dirección URL de su sitio Web sin una especificación de nombre de archivo:

Web_Default_Filename = c:\website\Index.html


Guía del teclado del Explorador

Las siguientes tablas enumeran las teclas que se pueden utilizar para desplazarse por el Explorador de VSS.

Desplazarse por el Administrador de VSS

Presione | Para
TAB | Moverse entre la lista de archivos y la lista de proyectos.
FLECHA ARRIBA | Moverse hacia arriba en la lista de archivos o en la lista de proyectos.
FLECHA ABAJO | Moverse hacia abajo en la lista de archivos o en la lista de proyectos.
INICIO | Moverse hasta el principio de la lista de archivos o de la lista de proyectos.
FIN | Moverse hasta el final de la lista de archivos o de la lista de proyectos.
F6 | Ir al panel siguiente.
Mayúsculas-F6 | Ir al panel previo.
Mayús-Flecha abajo | Moverse al siguiente archivo o proyecto, extender el intervalo seleccionado.
Mayús-Flecha arriba | Moverse al archivo o proyecto anterior, extender el intervalo seleccionado.

Teclas de navegación en la lista de archivos

Presione | Para
INICIO, después Mayúsculas-Fin | Seleccionar todos los archivos del proyecto actual. (O bien, simplemente seleccionar el proyecto de la lista de proyectos.)
ENTRAR | Ver un archivo

Teclas de navegación en la lista de proyectos

Presione | Para
ENTRAR | Mostrar (u ocultar) subproyectos.
* TECLADO NUMÉRICO | Incluir proyectos y subproyectos.
+ TECLADO NUMÉRICO | Expandir un proyecto.
- TECLADO NUMÉRICO | Contraer un proyecto.


Métodos abreviados de los visores de archivos

Las siguientes tablas enumeran las teclas de método abreviado que se pueden utilizar para desplazarse por el Explorador de VSS y para llevar a cabo ciertos comandos.

Teclas de desplazamiento

Presione | Para
INICIO | Ir al principio de la línea (desplazar pantalla).
Ctrl-Inicio | Ir al principio del archivo (desplazar pantalla).
Ctrl-Fin | Ir al final del archivo (desplazar pantalla).
Ctrl-Flecha izquierda | Ir una palabra a la izquierda.
Ctrl-N | Ir a la siguiente diferencia (aceptado sólo en el Visor de diferencias Visual).
Ctrl-P | Ir a la diferencia anterior (aceptado sólo en el Visor de diferencias Visual).
Ctrl-Flecha derecha | Ir una palabra a la derecha.
FLECHA ABAJO | Bajar una línea.
FIN | Ir al final de la línea (desplazar pantalla).
FLECHA IZQUIERDA | Ir un carácter a la izquierda.
AV PÁG | Bajar una página.
RE PÁG | Desplazar la pantalla hacia arriba una página.
FLECHA DERECHA | Ir un carácter a la derecha.
Mayús-Inicio | Ir al principio de la línea (desplazar pantalla). Si hay una selección activa, la tecla aceleradora mantiene el estado de selección y modifica la selección.
Mayús-Ctrl-Inicio | Ir al principio del archivo (desplazar pantalla). Si hay una selección activa, la tecla aceleradora mantiene el estado de selección y modifica la selección.
Mayús-Ctrl-FIN | Ir al final del archivo (desplazar pantalla). Si hay una selección activa, la tecla aceleradora mantiene el estado de selección y modifica la selección.
Mayús-Ctrl-Flecha izquierda | Ir una palabra a la izquierda. Si hay una selección activa, la tecla aceleradora mantiene el estado de selección y modifica la selección.
Mayús-Ctrl-N | Ir a la siguiente diferencia (aceptado sólo en el Visor de diferencias Visual). Si hay una selección activa, la tecla aceleradora mantiene el estado de selección y modifica la selección.
Mayús-Ctrl-P | Ir a la diferencia anterior (aceptado sólo en el Visor de diferencias Visual). Si hay una selección activa, la tecla aceleradora mantiene el estado de selección y modifica la selección.
Mayús-Ctrl-Flecha derecha | Ir una palabra a la derecha. Si hay una selección activa, la tecla aceleradora mantiene el estado de selección y modifica la selección.
Mayús-Flecha abajo | Desplazar la pantalla una página hacia abajo. Si hay una selección activa, la tecla aceleradora mantiene el estado de selección y modifica la selección.
Mayús-Fin | Ir al final de la línea (desplazar pantalla). Si hay una selección activa, la tecla aceleradora mantiene el estado de selección y modifica la selección.
Mayús-Flecha izquierda | Ir un carácter a la izquierda. Si hay una selección activa, la tecla aceleradora mantiene el estado de selección y modifica la selección.
Mayús-Av pág | Bajar una página. Si hay una selección activa, la tecla aceleradora mantiene el estado de selección y modifica la selección.
Mayús-Re pág | Subir una página. Si hay una selección activa, la tecla aceleradora mantiene el estado de selección y modifica la selección.
Mayús-Flecha derecha | Ir un carácter a la derecha. Si hay una selección activa, la tecla aceleradora mantiene el estado de selección y modifica la selección.
Mayús-Flecha arriba | Subir una página. Si hay una selección activa, la tecla aceleradora mantiene el estado de selección y modifica la selección.
FLECHA ARRIBA | Subir una línea.

Métodos abreviados

Presione | Para
Ctrl-Insertar | Copiar texto.
Ctrl-C | Copiar texto.
ALT-G | Ir al número de línea especificado.
ALT-S | Buscar una cadena en el archivo mostrado.
F1 | Obtener Ayuda en pantalla acerca de un elemento determinado.
F3 | Encontrar la siguiente aparición de la cadena.
Mayús-F3 | Encontrar la aparición anterior de la cadena.
Mayús-Ctrl-O | Seleccionar texto de diferencia (aceptado sólo en el Visor de diferencias Visual).


Teclas de método abreviado para los comandos de menú

Cada comando tiene asociada una combinación de teclas que le permite ejecutar un comando mediante el teclado. Lo más habitual es presionar la tecla CTRL o ALT a la vez que presiona la letra subrayada del comando del menú apropiado.

Teclas de método abreviado para los comandos de menú

Presione | Para
Alt-Entrar | Mostrar propiedades de un archivo o de un proyecto.
Alt-X | Cerrar VSS.
Ctrl-* | Expandir globalmente todos los proyectos.
Ctrl-A | Agregar archivos al proyecto actual.
Ctrl-C | Copiar texto.
Ctrl-Entrar | Establecer el directorio de trabajo para el proyecto actual.
Ctrl-Entrar | Ver un archivo
Ctrl-F | Mostrar las diferencias del archivo o el proyecto seleccionado.
Ctrl-G | Obtener el archivo o el proyecto seleccionado.
Ctrl-H | Mostrar el historial del archivo o proyecto seleccionado.
Ctrl-I | Proteger el archivo o los archivos seleccionados.
Ctrl-Insertar | Copiar el texto seleccionado al Portapapeles.
Ctrl-K | Desproteger el archivo o los archivos seleccionados.
Ctrl-L | Seleccionar archivos.
Ctrl-O | Desproteger un archivo.
Ctrl-Q | Cancelar un estado o presentación de búsqueda. Volver a la presentación normal de archivo.
Ctrl-R | Ver un archivo
Ctrl-S | Buscar un archivo desprotegido para un usuario específico. Utilice Ctrl-Q para volver a la presentación normal del archivo.
Ctrl-U | Proteger el archivo o los archivos seleccionados.
Ctrl-V | Pegar texto desde el portapapeles.
Ctrl-W | Realizar una búsqueda con caracteres comodín.
Ctrl-X | Cortar texto y colocarlo en el Portapapeles.
Ctrl-Z | Deshacer la edición en el cuadro de diálogo.
SUPRIMIR | Eliminar el archivo o el proyecto seleccionado.
ENTRAR | Ver un archivo
F1 | Obtener Ayuda en pantalla sobre un elemento determinado.
F5 | Actualizar la lista de archivos.
INSERTAR | Crear proyecto (si el enfoque está en el panel de proyectos) o Agregar archivos (si el enfoque está en el panel de archivos).
Mayús-Ctrl-L | Seleccionar todos los archivos.
Mayús-Ctrl-S | Buscar todos los archivos desprotegidos actualmente. Utilice Ctrl-Q para volver a la presentación normal del archivo.
Mayús-Supr | Cortar el texto seleccionado y copiarlo al Portapapeles.
Mayús-Ins | Pegar texto del Portapapeles en el cuadro de texto.


Guía del teclado del administrador

La siguiente tabla enumera las teclas que se pueden utilizar para desplazarse por el Administrador de VSS.

Desplazarse por el Administrador de VSS

Presione | Para
FLECHA ARRIBA | Ir hacia arriba en la lista de usuarios.
FLECHA ABAJO | Ir hacia abajo en la lista de usuarios.
INICIO | Ir al principio de la lista de usuarios.
FIN | Ir al final de la lista de usuarios.


Teclas de método abreviado para los comandos de menú

Cada comando tiene asociada una combinación de teclas que le permite ejecutar un comando mediante el teclado. Lo más habitual es presionar la tecla CTRL o ALT a la vez que presiona la letra subrayada del comando del menú apropiado.

Teclas de método abreviado para los comandos de menú

Presione | Para
Ctrl-A | Agregar un usuario a la lista de usuarios.
Ctrl-Entrar | Eliminar un usuario de la lista de usuarios.
Ctrl-E | Modificar un usuario de la lista de usuarios.
F1 | Obtener Ayuda en pantalla sobre un elemento determinado.


Sintaxis de nombres de VSS, convenciones y limitaciones

VSS tiene la siguiente sintaxis, convenciones y limitaciones para los nombres:

  • Los nombres de usuario y los nombres de etiquetas pueden tener hasta 31 caracteres de longitud.

  • Las contraseñas de usuario pueden tener hasta 15 caracteres de longitud.

  • Las cadenas de búsqueda pueden tener hasta 255 caracteres. Los nombres de archivo incluyen espacios sobre sistemas operativos que los admitan.

  • Las rutas de proyecto pueden tener hasta 259 caracteres (incluyendo el nombre de archivo).

  • Las etiquetas de archivos o proyectos pueden tener hasta 31 caracteres.

  • Las cadenas de búsqueda pueden tener hasta 63 caracteres.

  • Los comentarios pueden tener hasta 63 caracteres para el comando Desproteger y 4 KB para los demás comentarios.

  • En los archivos de inicialización de VSS, las líneas pueden tener hasta 511 caracteres de longitud.

  • El resultado de la suma de los archivos y los proyectos (juntos) de la base de datos de VSS no puede ser superior a 4000 millones.

  • El resultado de la suma de los archivos y los proyectos (juntos) de cualquier proyecto de la base de datos de VSS no puede ser superior a 8191.

  • El tamaño máximo permitido para un archivo almacenado en la base de datos de VSS es de 2 gigabytes.

  • El máximo número de versiones de un único archivo que VSS puede almacenar es de 32.767.

La mayoría de los nombres de VSS no pueden empezar ni terminar con espacios en blanco ni tabuladores. Puede utilizarse cualquier carácter para los nombres o etiquetas, excepto los siguientes:

  • Signo de moneda ($)

  • Signo @

  • Corchetes angulares (< >), corchetes ([ ]), llaves ({ }) y paréntesis (( ))

  • Dos puntos (:) y punto y coma (;)

  • Signo igual (=)

  • Circunflejo (^)

  • Símbolo de canalización (|)

  • Asterisco (*)

  • Exclamación (!)

  • Barra oblicua (/) y barra inversa (\)

  • Signo de porcentaje (%)

  • Interrogación de cierre (?)

  • Coma (,)

  • Comillas (sencillas o dobles) (' ")

  • Tabulador

VSS acepta los nombres de archivo UNC (Convención de nomenclatura universal). Si su sistema operativo de red acepta nombres de ruta UNC, puede utilizarlos en cualquier lugar para especificar un nombre de ruta.

VSS no acepta la utilización del carácter @ en redes Banyan Vines. Los usuarios de Banyan pueden tener acceso a toda la funcionalidad de VSS si utilizan letras asignadas de unidades de red.


Utilizar la línea de comandos de VSS

Vea también

Puede utilizar la línea de comandos de VSS para ejecutar archivos de proceso por lotes y macros. Además, puede utilizar la línea de comandos para ejecutar todos los comandos del Explorador de VSS.

Llevar a cabo comandos en la línea de comandos

Puede iniciar una sesión del intérprete de comandos desde Windows 95 o Windows NT y escribir los comandos de SourceSafe desde ahí. Para ello, la carpeta de VSS debe estar en su ruta de acceso (configurada con la variable de entorno PATH).

También puede utilizar el comando Ejecutar (menú Archivo) o el comando Ejecutar (menú Inicio) para ejecutar un comando específico. Por ejemplo, puede escribir ss Get *.* para obtener todos los archivos del proyecto actual.

Sintaxis de la línea de comandos

Los comandos de la línea de comandos tienen la siguiente sintaxis general:

ss comando [uno o más elementos] [una o más opciones]

El significado de un elemento depende del comando. Por ejemplo, para el comando Get, un elemento es un archivo o un proyecto de VSS; para el comando Add, un elemento es un archivo del sistema operativo.

En casi todos los casos en los que puede especificar un elemento sobre el que actuar, puede especificar más de un elemento. Por ejemplo, cualquiera de las siguientes formas de ejecutar el comando Get es válida:

ss Get HOLA.C
ss Get HOLA.C HOLA.H PRUEBA.H makefile
ss Get *.C *.H makefile linkfile
ss Get *.*

La línea de comandos no distingue entre mayúsculas y minúsculas; es decir, el comando ss Get HOLA.C también puede escribirse como ss get Hola.c.

Nota No tiene que escribir el nombre completo del comando para que la línea de comandos de VSS lo reconozca; sólo necesita escribir la parte suficiente del nombre para que VSS pueda distinguirlo de cualquier otro comando. En la mayoría de los casos basta con escribir los dos o tres primeros caracteres.

Opciones de línea de comandos

Además del comando y los elementos, puede especificar opciones o parámetros. Las opciones van precedidas de un guión y modifican el comando. Algunas opciones son específicas de un comando y se describen en el tema de Ayuda relativo a ese comando. También existe un conjunto de opciones que es aplicable a muchos comandos. Están descritas en la siguiente tabla.

Opción | Descripción
-C | Utiliza un comentario (o ninguno) para todos los elementos especificados. (El comando Dir utiliza esta opción de otra forma diferente.)
-O | Redirige o pagina el resultado del comando.
-V | Opera sobre una versión específica de un elemento.
-R | Realiza un comando de forma recursiva.
-S | Activa o desactiva el modo SmartMode para el comando.
-G | Cambia el funcionamiento del comando Get sobre cualquier archivo recuperado en la unidad local.
-W | Indica si las copias locales son de sólo lectura.
-N | Cambia entre los modos de nombre de archivo largo y corto.
-I- | Pasar por alto: no pide entradas bajo ninguna circunstancia.
-Y | Especifica un nombre de usuario y una contraseña.
-?, -H | Solicita Ayuda en pantalla sobre un comando: la opción -H de la línea de comandos obtiene el mismo resultado.

Utilice comillas alrededor de todo el parámetro siempre que un elemento o una opción contenga el carácter de espacio en blanco como parte de una cadena de texto. Por ejemplo, utilice "-CÉste es el comentario" en luegar de -C"Éste es el comentario". De lo contrario, VSS tratará el espacio en blanco como un separador entre los diferentes parámetros y el comando puede fallar o producir resultados inesperados.


Iniciar VSS desde la línea de comandos

Puede utilizar las opciones de la línea de comandos para iniciar el cliente de VSS con una base de datos especificada. Con estas opciones, puede asignar fácilmente diferentes iconos de VSS a las diferentes bases de datos locales o remotas de SourceSafe.

Se aceptan las siguientes opciones de la línea de comandos:

Opción de la línea de comandos | Descripción
-yusuario,contraseña | Identifica el nombre de usuario y la contraseña, evitando el cuadro de diálogo Inicio de sesión.
-s\\servidor\recurso_compartido\ruta | Identifica un determinado archivo Srcsafe.ini, anulando el método normal de búsqueda de VSS del archivo SRCSAFE.INI.
-d variable | Identifica una ruta de datos para su utilización en el archivo SRCSAFE.INI. Si está especificado, este valor especifica una variable DATA_PATH utilizada en el archivo SRCSAFE.INI.
-pproyecto | Identifica el proyecto con el que hay que abrir VSS. Por ejemplo, SSEXP -p$/Word/Code abriría VSS con ese proyecto.

Todas estas opciones son opcionales y ninguna es dependiente de las demás.

Comentarios

Para utilizar estas opciones de forma efectiva, asigne la línea de comandos apropiada a iconos diferentes de SourceSafe en el grupo de programas VSS. Por ejemplo, para utilizar un icono para tener acceso a una base de datos de SourceSafe en \\DEV1\SourceSafe, asigne la siguiente línea a un icono:

SSEXP -s\\DEV1\SourceSafe

La opción -d es una característica poderosa que puede utilizarse para configurar un archivo Srcsafe.ini con múltiples variables de ruta de datos. (Vea el archivo de Ayuda del Administrador de VSS si desea más información acerca de la variable Data_Path.) Por ejemplo:

Data_Path (Word) = \\Office\WORD\SSDB
Data_Path (Excel) = \\Office\EXCEL\SSDB
Data_Path (PowerPoint) = \\Office\PPT\SSDB

Si utiliza un icono para iniciar el Explorador de SourceSafe sobre la base de datos Powerpoint, por ejemplo, podría asignar esta línea de comandos a un icono de SourceSafe:

SSEXP -s\\Office\Source -dPowerpoint

Este comando hace que SourceSafe busque el archivo SRCSAFE.INI en la carpeta raíz del recurso compartido \\Office\Source. En SRCSAFE.INI, SourceSafe buscaría la asignación de la variable Data_path de Powerpoint y se dirigiría a la base de datos de SourceSafe en \\Office\PPT\SSDB.

La opción -p puede utilizarse en software de correo electrónico (que admita iconos) para enviar un puntero a su proyecto de VSS o para crear un icono de Windows que siempre abra VSS en un determinado proyecto.


About (Línea de comandos)

Muestra información acerca de su copia de Microsoft VSS, incluyendo el número de versión y los avisos sobre derechos de autor, licencia y consideraciones legales.

Derechos de acceso

Cualquier usuario de VSS puede utilizar este comando.


Add (Línea de comandos)

Vea también

Agrega nuevos archivos a la base de datos de VSS.

Sintaxis

ss Add archivos locales [-B] [-C] [-D-] [-H] [-I-] [-K] [-N] [-O] [-R] [-W] [-Y] [-?]

Ejemplos

Agrega el archivo HOLA.C al proyecto actual:

ss Add C:\HELLO.C

Agrega al proyecto actual los archivos PRUEBA.C y MI NOMBRE LARGO DE ARCHIVO.H:

ss Add TEST.C "My long filename.H"

Agrega al proyecto actual todos los archivos de la carpeta actual:

ss Add *

Agrega al proyecto actual todos los archivos de la carpeta actual y todas sus subcarpetas:

ss Add -R *

En la siguiente tabla se describen las opciones de línea de comandos disponibles con este comando.

Opción | Descripción
-C | Utiliza el mismo comentario para todos los archivos agregados.
-D | No hace un seguimiento de las versiones anteriores de este archivo.
-R | Agrega recursivamente un árbol de directorios completo, creando una lista de proyectos en VSS.
-K | Desprotege el archivo inmediatamente después de agregarlo.
-B | Supone que el archivo es binario. Utilice -B- para suponer que el archivo es de texto.
-W | Deja la copia local del archivo editable.
-O | Pagina o redirige el resultado del comando.
-I- | Pasar por alto: no pide entradas bajo ninguna circunstancia.
-N | Cambia entre los modos de nombre de archivo largo y corto.
-Y | Especifica un nombre de usuario o una contraseña.
-?, -H | Solicita Ayuda en pantalla sobre un comando.

Derechos de acceso

Debe disponer del derecho de acceso Agregar para utilizar este comando.

Comentarios

Puede especificar un archivo de cualquier unidad y carpeta, y agregar ese archivo al proyecto actual de VSS. Para agregar una carpeta de forma recursiva, es decir, para agregar todas sus subcarpetas y archivos, especifique una carpeta en lugar de un nombre de archivo y utilice la opción -R.

Nota Los nombres de la Universal Naming Convention (UNC) son admitidos: no es necesario especificar una unidad. Puede escribir, por ejemplo, \\COMPUTER\SHARE\FILE.TXT para agregar el fichero FILE.TXT desde \\COMPUTER\SHARE.

Cuando especifique *.* como elemento para agregar o utilice la opción -R, el comando Add comprobará primero la variable Relevant_Masks en los archivos de inicialización de VSS.

La opción -D- indica que no desea almacenar nada excepto la última versión del archivo en la base de datos de VSS. Cuando agrega un archivo con esta opción, VSS conserva un historial del archivo de registro de cambios con comentarios. Sin embargo, el registro de cambios que hace un seguimiento de los cambios reales del archivo no se almacena; por tanto, VSS puede recuperar la última versión, pero no versiones anteriores de este archivo. Esta opción se utiliza con frecuencia con archivos binarios para aumentar la velocidad y ahorrar espacio en disco.

La opción -B indica que todos los archivos que está agregando son archivos binarios en casos donde no desee utilizar la característica de detección automática de VSS; -B- especifica archivos de texto. Ambas anulan el modo predeterminado de detección automática de VSS.


Branch (Línea de comandos)

Vea también

Rompe un vínculo compartido y crea una bifurcación de un archivo en un proyecto.

Sintaxis

ss Branch archivo de SourceSafe [-C] [-H] [-I-] [-N] [-O] [-Y] [-?]

Ejemplos

Bifurca HELP.C del proyecto actual fuera de su contrapartida en otros proyectos:

ss Branch HELP.C

En la siguiente tabla se describen las opciones de línea de comandos disponibles con este comando.

Opción | Descripción
-C | Utiliza el mismo comentario para todos los archivos bifurcados.
-O | Pagina o redirige el resultado del comando.
-I- | Pasar por alto: no pide entradas bajo ninguna circunstancia.
-N | Cambia entre los modos de nombre de archivo largo y corto.
-Y | Especifica un nombre de usuario o una contraseña.
-?, -H | Solicita Ayuda en pantalla sobre un comando.

Derechos de acceso

Debe disponer del derecho de acceso Agregar para utilizar este comando.


Checkin (Línea de comandos)

Vea también

Actualiza VSS con los cambios realizados a un archivo desprotegido y desbloquea la copia maestra de VSS. También puede utilizar el comando Update (por compatibilidad con versiones anteriores).

Sintaxis

ss Checkin archivos de VSS [-C] [-H] [-I-] [-K] [-N] [-O] [-P[proyecto]] [-R] [-W] [-Y] [-?]

Ejemplos

Protege los cambios del archivo TEST.C:

ss Checkin TEST.C

Protege todos los archivos que tiene desprotegidos en el proyecto actual:

ss Checkin * -P

En la siguiente tabla se describen las opciones de línea de comandos disponibles con este comando.

Opción | Descripción
-C | Utiliza el mismo comentario para todos los archivos protegidos.
-K | Mantiene el archivo desprotegido tras protegerlo.
-G | Establece las opciones para el archivo local recuperado.
-W | Convierte la copia local recuperada en editable.
-R | Protege un lista completa de proyectos de forma recursiva.
-P | Protege sólo los archivos desprotegidos del proyecto actual o del especificado.
-O | Pagina o redirige el resultado del comando.
-I- | Pasar por alto: no pide entradas bajo ninguna circunstancia.
-N | Cambia entre los modos de nombre de archivo largo y corto.
-Y | Especifica un nombre de usuario o una contraseña.
-?, -H | Solicita Ayuda en pantalla sobre un comando.

Derechos de acceso

Debe disponer del derecho de acceso Desproteger para utilizar este comando.

Comentarios

Si protege varios archivos a la vez, VSS le pide un comentario para cada archivo individualmente: Si desea que todos tengan el mismo comentario, utilice la opción -C.

Es posible proteger un archivo y crear una nueva versión mientras deja el archivo desprotegido. Para mantener un archivo desprotegido, utilice la opción -K. También puede hacer que este sea el comportamiento predeterminado estableciendo la variable de inicialización Keep_Checkedout en el archivo SS.INI. Utilice la opción –K para indicar que no quiere mantener el archivo desprotefido.

Algunas veces protege un archivo que no ha cambiado y crea una nueva versión. VSS muestra un mensaje preguntándole si realmente desea realizar una protección; si le dice que no, VSS deshará la desprotección, de forma que el archivo se desbloqueará, pero no se creará un nueva versión. Puede impedir esta petición si configura la variable de inicialización Update_No_Change del archivo SS.ini.

La opción -P actúa sólo sobre los elementos que están desprotegidos del proyecto especificado. Si no especifica ningún proyecto en particular a continuación de -P, se asumirá el proyecto actual.


Checkout (Línea de comandos)

Vea también

Copia un archivo del proyecto actual a la carpeta actual con el propósito de modificarlo.

Sintaxis

ss Checkout archivos de VSS [-C] [-F] [-G] [-H] [-I-] [-N] [-O] [-R] [-V] [-Y] [-?]

Ejemplos

Desprotege el archivo TEST.C del proyecto $/TESTDATA:

ss Checkout $/TESTDATA/TEST.C

Desprotege los archivos TEST.C y TEST.H:

ss Checkout TEST.C TEST.H

Desprotege todos los archivos del proyecto TESTDATA y todas las subcarpetas:

ss Checkout -R $/TESTDATA

En la siguiente tabla se describen las opciones de línea de comandos disponibles con este comando.

Opción | Descripción
-C | Utiliza el mismo comentario para todos los archivos desprotegidos.
-G | Establece las opciones para el archivo local recuperado.
-R | Desprotege de forma recursiva el resultado del comando.
-O | Pagina o redirige el resultado del comando.
-V | Especifica qué versión de archivo se desprotege.
-F | Muestra sólo los archivos; no muestra los proyectos.
-I- | Pasar por alto: no pide entradas bajo ninguna circunstancia.
-N | Cambia entre los modos de nombre de archivo largo y corto.
-Y | Especifica un nombre de usuario o una contraseña.
-?, -H | Solicita Ayuda en pantalla sobre un comando.

Derechos de acceso

Debe disponer del derecho de acceso Desproteger para utilizar este comando.

Comentarios

Sólo un usuario puede desproteger archivos binarios al mismo tiempo.

De forma predeterminada, los comentarios de desprotección se requieren para todos los archivos incluidos en la operación. Puede utiliza la opción -C para escribir sólo un comentario, el cual se aplicará a todos los archivos incluidos en la operación.


Cloak (Línea de comandos)

Vea también

Esconde un proyecto de los comandos recursivos Obtener, Desproteger, Proteger, Deshacer desprotección y Diferencias de proyecto.

Sintaxis

ss Cloak ruta de acceso del proyecto de VSS

Ejemplos

Esconde el proyecto $/Word/Code:

ss Cloak $/Word/Code

Derechos de acceso

Cualquier usuario de VSS puede utilizar este comando.


Comment (Línea de comandos)

Vea también

Cambia el comentario introducido previamente para una versión específica de un archivo o un proyecto. Está disponible sólo desde la línea de comandos. (Para cambiar el comentario desde el Explorador, utilice el cuadro de diálogo Propiedades del archivo después de seleccionar el archivo o el proyecto adecuado.)

Sintaxis

ss Comment elementos de VSS [-C] [-H] [-I-] [-N] [-O] [-V] [-Y] [-?]

Ejemplos

Cambia el comentario de la versión 5 de TEST.C:

ss Comment TEST.C -V5

Cambia el comentario de la versión más reciente de TEST.C:

ss Comment TEST.C

Cambia el comentario del proyecto TESTDATA:

ss Comment $/TESTDATA

En la siguiente tabla se describen las opciones de línea de comandos disponibles con este comando.

Opción | Descripción
-C | Utiliza el mismo comentario para todos los archivos que se están cambiando.
-O | Pagina o redirige el resultado del comando.
-V | Especifica la versión de archivo a la cual se va a cambiar el comentario.
-I- | Pasar por alto: no pide entradas bajo ninguna circunstancia.
-N | Cambia entre los modos de nombre de archivo largo y corto.
-Y | Especifica un nombre de usuario o una contraseña.
-?, -H | Solicita Ayuda en pantalla sobre un comando.

Derechos de acceso

Debe disponer del derecho de acceso Agregar para utilizar este comando.

Comentarios

Cada versión de cada archivo o proyecto de VSS se asocia con un comentario definido por el usuario, el cual puede cambiar con el comando Comment. Tras escribir el comando, se le solicitará el nuevo comentario (o puede especificarlo en la línea de comandos mediante la opción -C).

El nuevo comentario reemplaza al antiguo, que no puede recuperarse.


CP (Línea de comandos)

Vea también

Establece la ruta de acceso del proyecto actual.

Sintaxis

ss Cp proyecto [-H] [-I-] [-Y] [-?]

Ejemplos

Convierte a $/WORD en el proyecto actual:

ss Cp $/WORD

Se mueve hacia arriba hacia el proyecto primario del proyecto actual:

ss Cp ..

Se mueve hacia arriba hacia el proyecto raíz:

ss Cp $/

En la siguiente tabla se describen las opciones de línea de comandos disponibles con este comando.

Opción | Descripción
-I- | Pasar por alto: no pide entradas bajo ninguna circunstancia.
-Y | Especifica un nombre de usuario o una contraseña.
-?, -H | Solicita Ayuda en pantalla sobre un comando.

Derechos de acceso

Cualquier usuario de VSS puede utilizar este comando.

Comentarios

El comando CP establece el proyecto actual. Una vez que establece el proyecto actual en la línea de comandos, la mayoría de los comandos suponen el proyecto actual si se especifica simplemente un nombre de archivo. Por ejemplo, si después del comando ss Cp $/WORD se incluye el comando ss Get TEST.C, VSS recupera $/WORD/TEST.C.

Nota Utilice el comando Project para encontrar el proyecto actual desde la línea de comandos.

En la línea de comandos de VSS, cuando obtiene o desprotege un archivo, el archivo va a la carpeta actual. Pero si la variable de inicialización Force_Dir está configurada a Yes, el archivo irá a la carpeta de trabajo para el proyecto, incluso si no es la carpeta actual.


Create (Línea de comandos)

Vea también

Crea un nuevo subproyecto.

Sintaxis

ss Create proyectos [-C] [-H] [-I-] [-O] [-S] [-Y] [-?]

Ejemplos

Crea el subproyecto WORD bajo el proyecto raíz $/:

ss Create $/WORD

Crea el subproyecto WORD bajo el proyecto actual:

ss Create WORD

En la siguiente tabla se describen las opciones de línea de comandos disponibles con este comando.

Opción | Descripción
-C | Utiliza el mismo comentario para todos los proyectos creados.
-S | Activa el modo SmartMode, de forma que VSS cambie al nuevo proyecto inmediatamente después de crearlo.
-O | Pagina o redirige el resultado del comando.
-I- | Pasar por alto: no pide entradas bajo ninguna circunstancia.
-Y | Especifica un nombre de usuario o una contraseña.
-?, -H | Solicita Ayuda en pantalla sobre un comando.

Derechos de acceso

Debe disponer del derecho de acceso Agregar en el proyecto primario para utilizar este comando.


Decloak (Línea de comandos)

Vea también

Quita el atributo de escondido de un proyecto.

Sintaxis

ss Decloak ruta de acceso al proyecto de VSS

Ejemplos

Muestra el proyecto $/Word/Code:

ss Decloak $/Word/Code

Derechos de acceso

Cualquier usuario de VSS puede utilizar este comando.


Delete (Línea de comandos)

Vea también

Quita archivos y proyectos del Explorador de VSS y los marca como eliminados; sin embargo, los elementos aún existen y pueden recuperarse mediante el comando Recover.

Sintaxis

ss Delete elementos de VSS [-H] [-I-] [-N] [-O] [-S] [-Y] [-?]

Ejemplos

Elimina el archivo TEST.C del proyecto $/PRJ:

ss Delete $/PRJ/TEST.C

Elimina el proyecto $/PRJ:

ss Delete $/PRJ

Elimina todos los archivos del proyecto actual:

ss Delete *.*

En la siguiente tabla se describen las opciones de línea de comandos disponibles con este comando.

Opción | Descripción
-S | Activa el modo SmartMode, eliminando la copia local del archivo tras eliminar la copia maestra de VSS.
-O | Pagina o redirige el resultado del comando.
-I- | Pasar por alto: no pide entradas bajo ninguna circunstancia.
-N | Cambia entre los modos de nombre de archivo largo y corto.
-Y | Especifica un nombre de usuario o una contraseña.
-?, -H | Solicita Ayuda en pantalla sobre un comando.

Derechos de acceso

Debe disponer del derecho de acceso Agregar para utilizar este comando.

Comentarios

Una vez eliminado un archivo de un proyecto, no puede eliminar otro archivo con el mismo nombre del mismo proyecto: Si elimina el archivo TRASH.C de un proyecto y después agrega un nuevo archivo llamado TRASH.C al proyecto, está bien. Sin embargo, no se permite intentar eliminar TRASH.C de nuevo.


Deploy (Línea de comandos)

Vea también

Despliega un proyecto en un servidor o en una ubicación ftp especificada por la variable de inicialización Deploy_Path.

Sintaxis

ss Deploy ruta de acceso al proyecto de VSS [-O] [-R] [-V] [-G] [-W]

Ejemplos

Despliega un proyecto Web ($/SSAFE) a la ubicación de despliegue especificada por la variable de inicialización Deploy_Path:

ss Deploy $/SSAFE

En la siguiente tabla se describen las opciones de línea de comandos disponibles con este comando.

Opción | Descripción
-O | Pagina o redirige el resultado del comando.
-R | Despliega de forma recursiva toda una lista de proyectos.
-V | Despliega una versión antigua de un proyecto.
-G | Establece opciones para la copia recuperada.
-W | Convierte la copia local recuperada en editable.
-?, -H | Solicita Ayuda en pantalla sobre un comando.

Derechos de acceso

Debe disponer del derecho de acceso Destruir para utilizar este comando.

Comentarios

El comando Deploy coloca archivos en una ubicación especificada por la variable Deploy_Path. Esta variable puede establecerse directamente en el archivo Srcsafe.ini o mediante el programa Administrador. Deploy es muy parecido al comando Obtener la última versión, excepto en que el usuario no está limitado a poner los archivos en su carpeta de trabajo y no puede impedir que se sobrescriban archivos existentes. Si se utiliza de forma recursiva en un proyecto (la opción -R), VSS desplegará todos los archivos del proyecto y de los subproyectos, y los colocará en subcarpetas del mismo nombre.

De forma predeterminada, Deploy copia la versión más reciente de los proyectos que especifique. Sin embargo, también puede distribuir versiones anteriores si utiliza la opción -V. (Observe que "ss Deploy -V*" no funcionará.)

Nota Cuando se despliega una versión anterior de un proyecto, se obtienen los archivos que estaban en el proyecto en un momento determinado, tal y como estaban en ese momento. Por ejemplo, si utiliza el comando Deploy para recuperar la versión 7 del proyecto $/WORD, es posible que obtenga la versión 3 de TEST.HTML, la versión 10 de HELP.HTM y la versión 5 de TEST.MAP.


Destroy (Línea de comandos)

Vea también

Quita un archivo o un proyecto de forma permanente.

Sintaxis

ss Destroy elemento de VSS [-H] [-I-] [-N] [-O] [-S] [-Y] [-?]

Ejemplos

Destruye el archivo TEST.C del proyecto $/PRJ:

ss Destroy $/PRJ/TEST.C

Destruye el proyecto $/PRJ:

ss Destroy $/PRJ

En la siguiente tabla se describen las opciones de línea de comandos disponibles con este comando.

Opción | Descripción
-S | Activa el modo SmartMode, de forma que VSS elimine sus copias locales de los archivos tras destruir las copias maestras.
-O | Pagina o redirige el resultado del comando.
-I- | Pasar por alto: no pide entradas bajo ninguna circunstancia.
-N | Cambia entre los modos de nombre de archivo largo y corto.
-Y | Especifica un nombre de usuario o una contraseña.
-?, -H | Solicita Ayuda en pantalla sobre un comando.

Derechos de acceso

Debe disponer del derecho de acceso Destruir para utilizar este comando.

Utilice el comando Delete si no quiere quitar el archivo o el proyecto de forma permanente.


Difference (Línea de comandos)

  • Si está realizando una diferencia en un archivo, vea Difference (Archivo, Línea de comandos)

  • Si está realizando una diferencia en un proyecto, vea Difference (Proyecto, Línea de comandos)


Difference (Archivo, Línea de comandos)

Vea también

Muestra las diferencias entre las líneas de una copia maestra de VSS y la correspondiente copia local de su carpeta de trabajo o una versión previa.

Nota En el caso de los archivos binarios, VSS puede decirle si dos archivos son diferentes, pero no en qué se diferencian. VSS almacena los deltas inversos de todos los archivos, pero en el caso de los archivos binarios, el registro binario almacenado no puede mostrarse al usuario. Sólo los archivos de texto ASCII pueden compararse línea a línea.

Sintaxis

ss Diff archivos de VSS [-B] [-D] [-H] [-I] [-I-] [-N] [-O] [-V] [-Y] [-?]

Ejemplos

Compara el archivo de VSS help.c con el archivo local help.c:

ss Diff HELP.C

Compara la versión 2 del archivo de VSS help.c con la copia local de help.c:

ss Diff HELP.C -V2

Compara las versiones 2 y 4 del archivo de VSS help.c:

ss Diff HELP.C -V4~2

Compara el archivo HELP.C de la base de datos de VSS con el archivo BAR.C de su equipo local:

SS Diff $/HELP.C C:\BAR.C

En la siguiente tabla se describen las opciones de línea de comandos disponibles con este comando.

Opción | Descripción
-O | Pagina o redirige el resultado del comando.
-V | Especifica la versión o versiones de archivo antiguas para comparar.
-I [C|E|S|W] | Especifica qué mensajes informativos se pasan por alto. La opción -IS significa que se pasan por alto las coincidencias pequeñas; evita que una gran sección de cambios parezcan coincidencias aunque en realidad no lo sean.
-I- | Pasar por alto: no pide entradas bajo ninguna circunstancia.
-D <S|U|V> [ancho] | Especifica el formato de la presentación de diferencias.
-DX [ - |número de líneas] | Especifica el número de líneas de contexto mostradas.
-B | Crea un breve informe de diferencias.
-N | Cambia entre los modos de nombre de archivo largo y corto.
-Y | Especifica un nombre de usuario o una contraseña.
-?, -H | Solicita Ayuda en pantalla sobre un comando.

Derechos de acceso

Debe disponer del derecho de acceso Leer para utilizar este comando.

Comentarios

La opción -B proporciona un breve informe de diferencias. Comprueba si los archivos especificados son diferentes y es más rápido que calcular las diferencias reales de líneas. Puede ser muy útil en archivos de proceso por lotes y en secuencias de comandos que reaccionen de forma diferente cuando un archivo se haya modificado.

La opción -D controla cómo muestra VSS las diferencias. Una diferencia de archivo puede mostrarse de una de tres formas posibles:

  • V (visual): muestra el archivo completo, con anotaciones sobre los cambios. Esta presentación muestra las diferencias lado a lado.

  • S (SourceSafe): muestra una lista de las líneas que se han agregado, eliminado, cambiado y optimizado por legibilidad; por ejemplo, una línea insertada podría mostrarse como sigue:
    27  Ins: hola, mundo
  • U (unix): muestra información similar en el formato estándar utilizado por el programa diff de UNIX:
    26a27
> hola, mundo

Inmediatamente después de V, S o U en la opción -D, puede especificar un número que indica el ancho de la línea. Si especifica más caracteres de los que permite su pantalla, las líneas largas se ajustarán automáticamente, lo cual puede afectar a la legibilidad de la presentación.

Finalmente, X controla cuántas líneas de contexto muestra VSS sobre cada cambio. Examinar estas líneas puede ayudarle a entender por qué se realizó un cambio. X por sí solo muestra tres líneas de contexto; X- no muestra contexto y X seguido de un número especifica cuántas líneas se muestran.

De forma predeterminada, VSS utiliza la presentación de VSS, con un ancho de línea calculado para que quepa en la pantalla y sin líneas de contexto. Si especifica una presentación UNIX, los demás valores predeterminados serán los mismos; la presentación visual, de forma predeterminada, muestra todas las líneas (contexto infinito).

La tabla siguiente muestra algunos usos de la opción -D.

Ejemplo | Descripción
-DV35 | Presentación visual, 35 caracteres de ancho
-DX | Tres líneas de contexto
-DU70X5 | Presentación estilo UNIX, 70 caracteres de ancho, cinco líneas de contexto

La opción -I indica cuál de los cuatro factores siguientes debe pasar por alto VSS al comparar dos archivos.

  • C (mayúsculas y minúsculas): la letra A se considera la misma que la letra a, etc. y un cambio de una a otra no se informa.

  • W (espacio en blanco): cualquier cambio en el espaciado o la tabulación se pasa por alto; sólo se comunica la inserción o eliminación de caracteres funcionales.

  • E (carácter de fin de línea): cada línea no se comunica como un cambio simplemente porque existan diferencias en un sistema operativo diferente.

  • S (cambios leves): se pasan por alto los cambios menores.

El valor predeterminado, -IE, pasa por alto los caracteres de fin de línea e informa de cualquier otra diferencia como un cambio.


Difference (Proyecto, Línea de comandos)

Vea también

Compara el contenido de un proyecto con la carpeta de trabajo.

Sintaxis

ss Diff proyectos de VSS [-B] [-F] [-H] [-I-] [-N] [-O] [-R] [-V] [-Y] [-?]

Ejemplos

Compara el proyecto WORD de VSS con la carpeta de trabajo:

ss Diff $/WORD

Compara el proyecto actual con la carpeta de trabajo:

ss Diff

En la siguiente tabla se describen las opciones de línea de comandos disponibles con este comando.

Opción | Descripción
-O | Pagina o redirige el resultado del comando.
-V | Compara una versión anterior del archivo o el proyecto.
-R | Compara recursivamente una lista de proyectos completa con un árbol de carpetas local.
-B | Crea un breve informe de diferencias.
-I- | Pasar por alto: no pide entradas bajo ninguna circunstancia.
-N | Cambia entre los modos de nombre de archivo largo y corto.
-Y | Especifica un nombre de usuario o una contraseña.
-F | Sincroniza las diferencias entre proyectos mediante el comportamiento de sincronización especificado por el usuario almacenado en la variable de inicialización Reconcile_Project.
-?, -H | Solicita Ayuda en pantalla sobre un comando.

Derechos de acceso

Es necesario disponer del derecho de acceso Leer para utilizar este comando.

Comentarios

La diferencia a nivel de proyecto compara el contenido de su proyecto actual con el contenido de la carpeta asignada actualmente a dicho proyecto e informa de las diferencias encontradas. Un ejemplo de una de estas diferencias podría ser que un archivo estuviera en un lugar y el otro no, o que un archivo en ambos lugares fuera distinto. La opción -R examina no sólo el contenido del proyecto actual, sino también los subproyectos que hay por debajo del proyecto actual y muestra todas las diferencias entre el proyecto completo y la carpeta de trabajo.

La opción -B crea un breve informe de diferencias: No comprueba el contenido del archivo de ninguna forma, sino que mira simplemente si existe en un lugar y no en el otro. La opción -F sincroniza las diferencias de proyectos mediante las reglas de decisión almacenadas en la variable de inicialización Reconcile_Project. Vea el tema Reconcile_Project (Variable de inicialización) para obtener más información.

La variable de inicialización Relevant_Masks afecta a este comando filtrando la lista de archivos que se comparan entre los proyectos.


Directory (Línea de comandos)

Vea también

Muestra una lista de todos los archivos y proyectos del proyecto especificado o del proyecto actual. Está disponible sólo desde la línea de comandos.

Sintaxis

ss Dir ruta de proyecto[-C] [-D] [-E] [-F-] [-H] [-I-] [-N] [-O] [-R] [-V] [-Y] [-?]

Ejemplos

Muestra un directorio del proyecto $/WORD:

ss Dir $/WORD

Muestra un directorio del proyecto actual:

ss Dir

Equivalente al comando dir del MS-DOS:

ss ls

En la siguiente tabla se describen las opciones de línea de comandos disponibles con este comando.

Opción | Descripción
-D | Muestra los archivos eliminados en lugar de los archivos no eliminados.
-O | Pagina o redirige el resultado del comando.
-R | Muestra recursivamente una lista de proyectos completa.
-E | Muestra la presentación extendida, incluyendo la información de desprotección.
-V | Muestra un directorio de una versión anterior de un proyecto.
-C | Muestra archivos y proyectos en columnas.
-F | Muestra sólo proyectos; no muestra archivos.
-I- | Pasar por alto: no pide entradas bajo ninguna circunstancia.
-N | Cambia entre los modos de nombre de archivo largo y corto.
-Y | Especifica un nombre de usuario o una contraseña.
-?, -H | Solicita Ayuda en pantalla sobre un comando.

Derechos de acceso

Es necesario disponer del derecho de acceso Leer para utilizar este comando.

Comentarios

El comando Directory en las funciones de VSS se parece mucho al comando dir del MS-DOS y muestra todos los archivos y subproyectos de un proyecto. Si un proyecto está compartiendo una versión específica de un archivo (en lugar de la versión más reciente), se muestra el número de versión del archivo. El comando Directory establece el código de salida del sistema operativo para utilizarlo en archivos de proceso por lotes y secuencias de comandos.

La opción -R muestra una carpeta recursiva, es decir, muestra los subproyectos, los archivos y subproyectos que contienen, y así sucesivamente.

La opción -D muestra todos los archivos y subproyectos que se han eliminado. Esto puede ser útil, por ejemplo, para obtener una lista de los archivos que desea recuperar o purgar.

La opción -E muestra información de desprotección para cualquier archivo desprotegido. Dir -E es similar al comando Status de la línea de comandos, con una diferencia notable: Status muestra sólo los archivos desprotegidos; Dir -E muestra todos los archivos, pero notifica el estado de desprotección de los que se han desprotegido.

La opción -F- muestra sólo los proyectos y no muestra los archivos: ss Dir $/ -F -R crea una lista completa de todos los proyectos de la base de datos de VSS sin enumerar ningún archivo.


Filetype (Línea de comandos)

Vea también

Muestra el tipo (de texto o binario) de un archivo. Está disponible sólo desde la línea de comandos. Para buscar esta información en el Explorador, utilice el comando Propiedades del archivo.

Sintaxis

ss Filetype elementos de VSS [-B] [-H] [-I-] [-N] [-O] [-R] [-Y] [-?]

Ejemplos

Dice si HELP.C es de texto o binario:

ss Filetype HELP.C

Cambia HELP.C a un archivo binario:

ss Filetype HELP.C -B

En la siguiente tabla se describen las opciones de línea de comandos disponibles con este comando.

Opción | Descripción
-O | Pagina o redirige el resultado del comando.
-R | Trabaja recursivamente sobre una lista de proyectos completa.
-B | Cambia el tipo de un archivo. -B cambia el tipo de archivo a binario; -B- lo cambia a texto.
-I- | Pasar por alto: no pide entradas bajo ninguna circunstancia.
-N | Cambia entre los modos de nombre de archivo largo y corto.
-Y | Especifica un nombre de usuario o una contraseña.
-?, -H | Solicita Ayuda en pantalla sobre un comando.

Derechos de acceso

Es necesario disponer del derecho de acceso Leer para comprobar el tipo de un archivo y el derecho de acceso Agregar para cambiarlo.

Comentarios

El comando Filetype puede utilizarse para determinar o cambiar el tipo de uno o más archivos. Cada archivo de VSS se clasifica como binario o de texto. Si no especifica una opción -B, VSS simplemente mostrará el tipo de archivo.


FindinFiles (Línea de comandos)

Vea también

Muestra todas las instancias de una cadena especificada en uno o más archivos.

Sintaxis

ss FindinFiles cadena [elementos de VSS] [-H] [-I-] [-IC] [-N] [-O] [-R] [-V] [-Y] [-?]

Ejemplos

Busca la cadena "giGlobal" en todos los archivos .C:

ss FindinFiles giGlobal *.C

Busca la cadena "hola mundo" en el proyecto actual:

ss FindinFiles "Hola mundo"

En la siguiente tabla se describen las opciones de línea de comandos disponibles con este comando.

Opción | Descripción
-O | Pagina o redirige el resultado del comando.
-R | Busca recursivamente en una lista de proyectos completa.
-V | Busca hasta una versión anterior de todos los archivos o proyectos especificados.
-IC | Ignora la distinción entre mayúsculas y minúsculas al buscar.
-I- | Pasar por alto: no pide entradas bajo ninguna circunstancia.
-N | Cambia entre los modos de nombre de archivo largo y corto.
-Y | Especifica un nombre de usuario o una contraseña.
-?, -H | Solicita Ayuda en pantalla sobre un comando.

Derechos de acceso

Debe disponer del derecho de acceso Leer para utilizar este comando.

Comentarios

El comando FindinFiles muestra una lista de todas las apariciones de una cadena de caracteres en los archivos de VSS especificados (de la misma forma que lo hace el comando Grep de los sistemas UNIX). Puede buscar en un archivo o en un proyecto (con lo cual examina todos los archivos de ese proyecto); si no especifica elementos de VSS, se supondrá que está buscando en los archivos del proyecto actual.

El comando FindinFiles de VSS acepta dos caracteres comodín: * y ?

Normalmente, el comando FindinFiles de VSS distingue entre mayúsculas y minúsculas y busca coincidencias exactas: la letra "A" no coincide con la letra "a". La opción -IC hace que no se distinga entre mayúsculas y minúsculas, de forma que "A" coincida con "a".

FindinFiles devuelve un código de salida igual a 1 si había 1 o más coincidencias, 0 si no había ninguna y 100 si ocurrió un error.


Get (Línea de comandos)

Vea también

Recupera una copia de sólo lectura del archivo o archivos de VSS especificados.

Sintaxis

ss Get elementos de VSS [-G] [-H] [-I-] [-N] [-O] [-R] [-V] [-W] [-Y] [-?]

Ejemplos

Recupera una copia de sólo lectura del archivo TEST.C del proyecto actual:

ss Get TEST.C

Recupera copias de sólo lectura de todos los archivos del proyecto actual:

ss Get *

Recupera copias de sólo lectura de todos los archivos del proyecto $/WORD y todos sus subproyectos:

ss Get $/WORD -R

En la siguiente tabla se describen las opciones de línea de comandos disponibles con este comando.

Opción | Descripción
-O | Pagina o redirige el resultado del comando.
-R | Obtiene recursivamente una lista de proyectos completa.
-V | Obtiene una versión antigua del archivo o el proyecto.
-G | Establece las opciones para la copia local recuperada.
-W | Convierte la copia local recuperada en editable.
-I- | Pasar por alto: no pide entradas bajo ninguna circunstancia.
-N | Cambia entre los modos de nombre de archivo largo y corto.
-Y | Especifica un nombre de usuario o una contraseña.
-?, -H | Solicita Ayuda en pantalla sobre un comando.

Derechos de acceso

Debe disponer del derecho de acceso Leer para utilizar este comando.

Comentarios

El comando Get Latest Version coloca archivos en la carpeta de trabajo. Si se utiliza recursivamente en un proyecto (con la opción -R), VSS obtiene todos los archivos del proyecto y subproyectos y los coloca en subcarpetas del mismo nombre. Si establece la variable Force_Dir de SS.ini a Yes, los subproyectos irán a sus correspondientes carpetas de trabajo en lugar de ir a las subcarpetas del mismo nombre.

De forma predeterminada, Get Latest Version recupera la versión más reciente de los archivos o proyectos que especifique. Sin embargo, también puede obtener versiones anteriores si utiliza la opción -V. (Observe que "ss Get -V*" no funcionará.)

Nota Si obtiene una versión anterior de un proyecto se obtienen los archivos que había en el proyecto en un momento determinado, como estaban en ese momento. Por ejemplo, si utiliza el comando Get Latest Version para recuperar la versión 7 del proyecto $/WORD, puede obtener TEST.C versión 3, HELP.C versión 10 y TEST.H versión 5.


Help (Línea de comandos)

Vea también

Muestra Ayuda acerca de la utilización de VSS en general o sobre un comando específico.

Sintaxis

ss Help [Comando] [-H] [-I-] [-Y] [-?]

Ejemplos

Muestra Ayuda general:

ss Help

Muestra Ayuda acerca del comando Share:

ss Help Share

En la siguiente tabla se describen las opciones de línea de comandos disponibles con este comando.

Opción | Descripción
-I- | Pasar por alto: no pide entradas bajo ninguna circunstancia.
-Y | Especifica un nombre de usuario o una contraseña.
-?, -H | Solicita Ayuda en pantalla sobre un comando.

Derechos de acceso

Cualquier usuario de VSS puede utilizar este comando.

Comentarios

La Ayuda para los comandos de la línea de comandos de VSS se muestra en un archivo de Ayuda de Microsoft Windows. Debe estar ejecutando Microsoft Windows para que se muestre la Ayuda; no hay una Ayuda independiente acerca de la línea de comandos.


History (Línea de comandos)

Vea también

Muestra el historial de un archivo o un proyecto de VSS.

Sintaxis

ss History elementos de VSS [-B] [-D] [-F-] [-H] [-I-] [-L] [-N] [-O] [-R] [-U[nombre_usuario] [-V] [-Y] [-#] [-?]

Ejemplos

Muestra el historial del archivo TEST.C:

ss History TEST.C

Muestra el historial del proyecto $/WORD:

ss History $/WORD

Muestra los tres últimos elementos de la lista del historial del proyecto actual o del archivo TEST.C, respectivamente:

ss history . -#3
ss history TEST.C -#3

En la siguiente tabla se describen las opciones de línea de comandos disponibles con este comando.

Opción | Descripción
-O | Pagina o redirige el resultado del comando.
-V | Muestra sólo las versiones que quedan en un intervalo especificado.
-R | Muestra el historial para una lista de proyectos completa.
-L | Muestra sólo las versiones que tienen etiquetas.
-F | No muestra actualizaciones de un archivo individual en el historial del proyecto.
-B | Muestra un breve historial.
-U | Muestra sólo los cambios realizados por un usuario en particular.
-D | Muestra los cambios de un archivo línea a línea.
-#<#> | Muestra el número especificado de entradas del historial para el archivo o el proyecto seleccionado.
-I- | Pasar por alto: no pide entradas bajo ninguna circunstancia.
-N | Cambia entre los modos de nombre de archivo largo y corto.
-Y | Especifica un nombre de usuario o una contraseña.
-?, -H | Solicita Ayuda en pantalla sobre un comando.

Derechos de acceso

Es necesario disponer del derecho de acceso Leer para utilizar este comando.

Comentarios

El comando History tiene una serie de opciones que pueden utilizarse para personalizar su presentación. Por ejemplo, -L sólo muestra las versiones que tienen etiquetas; puesto que estas versiones tienden a ser las etapas más relevantes, la opción -L puede ayudarle a generar una visión general del historial de un elemento.

La opción -B muestra un breve historial; sólo con suficiente información sobre una versión para que quepa en una línea.

La opción -U muestra sólo los cambios que realizó un determinado usuario (el usuario actual si no se especifica ninguno en la línea de comandos).

La opción -D muestra todos los cambios realizados realmente con cada actualización de archivo.

La opción -V especifica un intervalo: -V5 comienza con la versión 5 y va hacia atrás hasta la versión 1. Se utiliza una tilde (~) para especificar ambos lados del intervalo, de forma que -V5~3 da el historial de las versiones 5, 4 y 3. El intervalo debe especificarse comenzando por la versión más reciente, como en el ejemplo.

La opción -R indica que desea ver todos los cambios realizados a cada subproyecto del proyecto y a los archivos y subproyectos de aquellos, etc.

De forma predeterminada, el historial de un proyecto incluye el historial de todos sus archivos, pero no incluye los subproyectos.


Label (Línea de comandos)

Vea también

Asigna una etiqueta a la versión especificada o a la versión actual de un archivo o un proyecto.

Sintaxis

ss Label elementos de VSS [-C] [-H] [-I-] [-L etiqueta] [-N] [-O] [-V] [-Y] [-?]

Ejemplos

Asigna una etiqueta a la versión actual del proyecto actual:

ss Label

Asigna una etiqueta a la versión actual del proyecto $/WORD:

ss Label $/WORD

Asigna una etiqueta a la versión 5 del archivo HELP.C:

ss Label HELP.C -V5

En la siguiente tabla se describen las opciones de línea de comandos disponibles con este comando.

Opción | Descripción
-C | Utiliza el mismo comentario para todas las etiquetas.
-V | Etiqueta una versión de un archivo o un proyecto ya existente.
-L | Especifica la nueva etiqueta en la línea de comandos (en vez de solicitarse).
-O | Pagina o redirige el resultado del comando.
-I- | Pasar por alto: no pide entradas bajo ninguna circunstancia.
-N | Cambia entre los modos de nombre de archivo largo y corto.
-Y | Especifica un nombre de usuario o una contraseña.
-?, -H | Solicita Ayuda en pantalla sobre un comando.

Derechos de acceso

Debe disponer del derecho de acceso Agregar para utilizar este comando.

Comentarios

El comando Label crea una nueva versión del proyecto o el archivo especificado y asigna su etiqueta a esa versión. Sin embargo, si utiliza la opción -V para referirse a una versión específica, la etiqueta se aplica simplemente a esa versión.

Si asigna una etiqueta a una versión que ya tiene una etiqueta, o si asigna una etiqueta a un elemento que ya utiliza esa etiqueta para otra versión diferente, se reemplazará la etiqueta antigua. En ese caso, VSS presentará una advertencia antes de reemplazar la etiqueta antigua.

Si especifica múltiples elementos en la línea de comandos, VSS le solicitará una etiqueta diferente para cada elemento. La opción -C sólo le pide una etiqueta, que VSS aplica a todos los elementos que haya indicado. La opción -L evita completamente la solicitud de la etiqueta si la especifica en la línea de comandos, por ejemplo, -L2.00b.


Links (Línea de comandos)

Vea también

Muestra los proyectos que comparten un archivo especificado.

Sintaxis

ss Links archivos de VSS [-H] [-I-] [-N] [-O] [-Y] [-?]

Ejemplos

Muestra todos los proyectos que comparten el archivo TEST.C:

ss Links TEST.C

En la siguiente tabla se describen las opciones de línea de comandos disponibles con este comando.

Opción | Descripción
-O | Pagina o redirige el resultado del comando.
-I- | Pasar por alto: no pide entradas bajo ninguna circunstancia.
-N | Cambia entre los modos de nombre de archivo largo y corto.
-Y | Especifica un nombre de usuario o una contraseña.
-?, -H | Solicita Ayuda en pantalla sobre un comando.

Derechos de acceso

Debe disponer del derecho de acceso Leer para utilizar este comando.

Comentarios

El comando Links muestra todos los vínculos compartidos actuales de un archivo especificado con todos los demás proyectos que lo comparten. Por el contrario, el comando Paths muestra los vínculos que existían previamente pero se bifurcaron.


Locate (Línea de comandos)

Vea también

Busca en los proyectos de VSS nombres de archivo o de proyecto. Está disponible sólo desde la línea de comandos. En el Explorador, utilice el comando Búsqueda avanzada si desea obtener información equivalente.

Sintaxis

ss Locate nombre_archivo [-H] [-I-] [-N] [-O] [-Y] [-?]

Ejemplos

Busca los archivos llamados TEST.C:

ss Locate TEST.C

Busca los nombres de archivo que coinciden con la máscara de caracteres comodín *.old:

ss Locate *.OLD

En la siguiente tabla se describen las opciones de línea de comandos disponibles con este comando.

Opción | Descripción
-O | Pagina o redirige el resultado del comando.
-I- | Pasar por alto: no pide entradas bajo ninguna circunstancia.
-N | Cambia entre los modos de nombre de archivo largo y corto.
-Y | Especifica un nombre de usuario o una contraseña.
-?, -H | Solicita Ayuda en pantalla sobre un comando.

Derechos de acceso

Este comando sólo encuentra los archivos de los proyectos para los cuales tiene el derecho de acceso Leer.

Comentarios

El comando Locate busca en toda la jerarquía de proyectos de VSS el nombre de archivo que especifique y muestra la ruta de acceso del proyecto para cualquier coincidencia que encuentra. En muchos casos, los resultados son similares a los resultados de la ficha Vínculos. Por ejemplo, si varios proyectos comparten el archivo TEST.C, ambos comandos ofrecerán una lista de todos esos proyectos. Sin embargo, si un proyecto contiene un archivo que no está relacionado con el archivo TEST.C de su proyecto, pero tiene el mismo nombre, Locate encontrará el archivo, mientras que Links lo pasará por alto.

También puede utilizar el comando Locate para buscar un archivo cuando no sabe en qué proyecto se encuentra, mientras que la ficha Vínculos requiere que comience con un archivo específico.


Merge (Línea de comandos)

Vea también

Copia todos los cambios realizados en una bifurcación a otra bifurcación.

Sintaxis

ss Merge archivos de VSS [-C] [-H] [-I-] [-N] [-O] [-Y] [-?]

Ejemplos

Combina el archivo TEST.C del proyecto $/WORD en el archivo TEST.C del proyecto actual:

ss Merge $/WORD/TEST.C

En la siguiente tabla se describen las opciones de línea de comandos disponibles con este comando.

Opción | Descripción
-C | Utiliza el mismo comentario para todos los archivos combinados que están protegidos.
-O | Pagina o redirige el resultado del comando.
-I- | Pasar por alto: no pide entradas bajo ninguna circunstancia.
-N | Cambia entre los modos de nombre de archivo largo y corto.
-Y | Especifica un nombre de usuario o una contraseña.
-?, -H | Solicita Ayuda en pantalla sobre un comando.

Derechos de acceso

Debe disponer del derecho de acceso Desproteger en el proyecto en el que está combinando y el derecho de acceso Leer en el proyecto desde el que está combinado para utilizar este comando.

Comentarios

No puede realizar una combinación sobre un archivo binario.


Move (Línea de comandos)

Vea también

Cambia la ubicación de un subproyecto desde un proyecto primario a otro.

Sintaxis

ss Move <proyecto de origen> <proyecto de destino> [-H] [-I-] [-Y] [-?]

Ejemplos

Mueve el proyecto $/WORD desde $/JOE a $/APPS, creando $/APPS/WORD:

ss Move $/JOE/WORD $/APPS

En la siguiente tabla se describen las opciones de línea de comandos disponibles con este comando.

Opción | Descripción
-I- | Pasar por alto: no pide entradas bajo ninguna circunstancia.
-Y | Especifica un nombre de usuario o una contraseña.
-?, -H | Solicita Ayuda en pantalla sobre un comando.

Derechos de acceso

Es necesario tener el derecho de acceso Agregar en el proyecto primario al que está moviendo y el derecho de acceso Destruir en el proyecto primario desde el que está moviendo, para utilizar este comando.


Password (Línea de comandos)

Vea también

Establece la contraseña para el usuario actual.

Sintaxis

ss Password [-H] [-?]

Ejemplos

Desencadena la petición de la contraseña:

ss Password

En la siguiente tabla se describen las opciones de línea de comandos disponibles con este comando.

Opción | Descripción
-?, -H | Solicita Ayuda en pantalla sobre un comando.

Derechos de acceso

Cualquier usuario de VSS puede utilizar este comando. VSS pedirá el nombre de usuario y la contraseña.


Paths (Línea de comandos)

Vea también

Muestra todos los vínculos compartidos que se han bifurcado.

Sintaxis

ss Paths archivos de VSS [-I] [-N] [-O] [-Y]

Ejemplos

Muestra todos los vínculos de archivo actuales y erróneos del archivo TEST.C:

ss Paths TEST.C

En la siguiente tabla se describen las opciones de línea de comandos disponibles con este comando.

Opción | Descripción
-O | Pagina o redirige el resultado del comando.
-I- | Pasar por alto: no pide entradas bajo ninguna circunstancia.
-N | Cambia entre los modos de nombre de archivo largo y corto.
-Y | Especifica un nombre de usuario o una contraseña.
-?, -H | Solicita Ayuda en pantalla sobre un comando.

Derechos de acceso

Debe disponer del derecho de acceso Leer para utilizar este comando.

Comentarios

La presentación generada por Paths en la línea de comandos de VSS tiene un formato diferente al de la lista generada por la ficha Rutas del cuadro de diálogo Propiedades (menú Archivo). Ambos contienen la misma información, pero los usuarios que alternan entre los dos deben tener especial cuidado para evitar confusiones.

En el programa de la línea de comandos de SourceSafe, el comando Paths podría mostrar algo como lo siguiente.

TEST.C
$/A
 TEST.C (Bifurcado en la versión 5)
 $/B
 $/C
 TEST.C (Bifurcado en la versión 4)
 $/D

La presentación anterior muestra que el archivo comenzaba en el proyecto $/A, se creó una bifurcación en la versión 5 del proyecto $/B, la cual también se compartió en $/C; y se realizó otra bifurcación, también directamente sobre el archivo en $/A, que se creó en la versión 4 de $/D.


Pin (Línea de comandos)

Vea también

Fija una versión específica de un archivo al proyecto actual.

Sintaxis

ss Pin elementos de VSS [-G] [-H] [-N] [-V] [-W] [-Y] [-?]

Ejemplos

Fija el archivo JUSTIFY.CPP de $/WORD/CODE a la versión 2:

SS Pin $/WORD/CODE/JUSTIFY.CPP -V2

Fijar todos los archivos del proyecto $/EXCEL/PIVOTTBL a la etiqueta "beta4". En este ejemplo, se supone que "beta4" es una etiqueta de proyecto:

SS Pin $/EXCEL/PIVOTTBL/*.* -Vbeta4

Fijar todos los archivos de encabezado del proyecto SPECS a la versión 2.

SS Pin *.H -V2

En la siguiente tabla se describen las opciones de línea de comandos disponibles con este comando.

Opción | Descripción
-V | Número de versión que desea fijar al proyecto actual.
-G | Establece las opciones de Get para la copia local recuperada.
-W | Convierte la copia local recuperada en editable.
-N | Cambia entre los modos de nombre de archivo largo y corto.
-Y | Especifica un nombre de usuario o una contraseña.
-?, -H | Solicita Ayuda en pantalla sobre un comando.

Derechos de acceso

Es necesario disponer del derecho de acceso Desproteger en el proyecto desde el que se está fijando un archivo a una versión para utilizar este comando.

Comentarios

El comando Pin es similar al comando Share con la opción -V, pero el comando Pin es el método preferido de bloqueo de un archivo en una versión determinada. Sin embargo, Pin funciona directamente sobre archivos en los proyectos especificados en la línea de comandos. Sin la opción -V, no comparte archivos con el proyecto actual como hace el comando Share. El comando Pin congela un archivo en un número de versión especificado.

Para los elementos de VSS, especifique archivos del proyecto actual o una ruta de proyecto que contenga una especificación de caracteres comodín o un nombre de archivo. El comando Pin sólo actúa sobre los archivos del proyecto actual o del proyecto especificado.

Si el archivo que se va a fijar está actualmente asociado a otra versión, el comando Pin desvincula el archivo de la misma y lo fija a la versión especificada en la línea de comandos. Si el archivo ya está fijado a la versión especificada, no se realiza ninguna acción.

El comando fija una versión del archivo a la carpeta actual o a la carpeta de trabajo, dependiendo del estado de la variable de inicialización Force_Dir. Si utiliza la opción Force_Dir = Yes los archivos quedarán fijados a la carpeta de trabajo. Si utiliza Force_Dir = No los archivos quedarán fijados a la carpeta actual. Esta variable también puede establecerse en la ficha Opciones de línea de comandos del cuadro de diálogo Opciones (menú Herramientas).

Las opciones -G y -W controlan los atributos de archivo del archivo recuperado.


Project (Línea de comandos)

Vea también

Muestra la ruta de acceso del proyecto actual.

Sintaxis

ss Project [-H] [-I-] [-O] [-Y] [-?]

En la siguiente tabla se describen las opciones de línea de comandos disponibles con este comando.

Opción | Descripción
-O | Pagina o redirige el resultado del comando.
-I- | Pasar por alto: no pide entradas bajo ninguna circunstancia.
-Y | Especifica un nombre de usuario o una contraseña.
-?, -H | Solicita Ayuda en pantalla sobre un comando.

Derechos de acceso

Cualquier usuario de VSS puede utilizar este comando.

Comentarios

El comando Project muestra la ruta de acceso del proyecto actual. Le indica en qué proyecto está, por ejemplo, $/WORD; si escribe ss Get TEST.C, VSS busca $/WORD/TEST.C.

Utilice el comando CP para cambiar el proyecto actual.


Properties (Línea de comandos)

Vea también

Muestra información básica acerca de un archivo o un proyecto de VSS.

Sintaxis

ss Properties elementos de VSS [-B] [-F-] [-H] [-I-] [-L] [-N] [-O] [-R] [-Y] [-?]

Ejemplos

Muestra información acerca de la propiedad del archivo TEST.C y cambia su tipo de archivo a binario:

ss Properties -B TEST.C

En la siguiente tabla se describen las opciones de línea de comandos disponibles con este comando.

Opción | Descripción
-B | Cambia el tipo de un archivo. -B cambia el tipo de archivo a binario; -B- lo cambia a texto.
-F | Deshabilita la presentación de propiedades del archivo. Las opciones -B, -B-, -L y -L- sólo actúan sobre los archivos mostrados.
-O | Pagina o redirige el resultado del comando.
-R | Muestra información acerca de una lista de proyectos completa de forma recursiva. Se pasa por alto si se especifica un nombre de archivo o una máscara de archivo en la línea de comandos.
-L | Almacena sólo la versión más reciente (no las versiones anteriores). -L almacena sólo la versión más reciente durante la protección. -L- almacena información delta sobre cada protección.
-I- | Pasar por alto: no pide entradas bajo ninguna circunstancia.
-N | Cambia entre los modos de nombre de archivo largo y corto.
-Y | Especifica un nombre de usuario o una contraseña.
-?, -H | Solicita Ayuda en pantalla sobre un comando.

Derechos de acceso

Es necesario disponer del derecho de acceso Leer para ver las propiedades de un elemento.

Es necesario disponer del derecho de acceso Agregar para cambiar el tipo, de texto o binario, de un archivo.

Es necesario disponer del derecho de acceso Destruir para utilizar la opción -L.

Comentarios

El comando Properties muestra información sobre si un archivo es de texto o binario y además le permite almacenar sólo la última versión o todas las versiones de un archivo.

Si el comando Properties se ejecuta sin la opción -B o -L, muestra información sobre el archivo o proyecto sin cambiar los atributos del archivo. Con alguna de las opciones -B o -L, cambia primero los atributos del archivo y después muestra el resultado del cambio.


Purge (Línea de comandos)

Vea también

Quita de forma permanente los archivos y proyectos eliminados previamente de la base de datos de VSS.

Nota Los archivos purgados no pueden recuperarse.

Sintaxis

ss Purge elementos de VSS [-H] [-I-] [-N] [-O] [-Y] [-?]

Ejemplos

Purga el archivo eliminado TEST.C:

ss Purge TEST.C

Purga el proyecto eliminado $/PRJ:

ss Purge $/PRJ

En la siguiente tabla se describen las opciones de línea de comandos disponibles con este comando.

Opción | Descripción
-I- | Pasar por alto: no pide entradas bajo ninguna circunstancia.
-O | Pagina o redirige el resultado del comando.
-N | Cambia entre los modos de nombre de archivo largo y corto.
-Y | Especifica un nombre de usuario o una contraseña.
-?, -H | Solicita Ayuda en pantalla sobre un comando.

Derechos de acceso

Debe disponer del derecho de acceso Destruir para utilizar este comando.

Comentarios

Cuando utiliza el comando Delete para eliminar un archivo o un proyecto en VSS, el elemento eliminado se quita del Explorador de VSS, pero VSS lo sigue almacenando internamente. Puede utilizar el comando Dir -D en la línea de comandos de VSS para mostrar una lista de los archivos eliminados del proyecto actual. Después, puede purgarlos si desea destruirlos de forma permanente o reconstruir versiones anteriores del proyecto que los requieran con el comando Recover.


PVCS_SS (Línea de comandos)

A continuación se ofrece información acerca de la línea de comandos de PVCS.

Sintaxis

PVCS_SS archivo_registro [más archivos de registro] [proyecto] [-P carpeta_PVCS] [-S carpeta_VisualSourceSafe] [-U contraseña] [-?]

El orden de los parámetros no es importante. Las opciones se reconocen mediante un guión (-) o a una barra oblicua (/), se reconoce al proyecto mediante el signo de moneda ($); cualquier parámetro que no tenga un guión, una barra oblicua o un signo de moneda se interpretará como un archivo de registro de PVCS.

Comentarios

  • Archivos de registro: es posible especificar los archivos de registro de PVCS como nombres de archivos individuales (TEST.C_V) o como máscaras (*.??V). Durante la ejecución de PVCS_SS puede especificar tantos como desee, pero siempre uno como mínimo. Pueden encontrarse en otras carpetas, aunque el valor predeterminado es la unidad y la carpeta actuales. Cualesquiera archivos que pase a PVCS_SS, y sin importar cómo los especifique, debe ser capaz de pasar exactamente los mismos parámetros al programa de PVCS, VLOG.EXE.

  • Proyecto: el proyecto es opcional, ya que PVCS_SS.EXE presupone como valor predeterminado el proyecto actual del usuario Admin. Si especifica un proyecto, utilice la sintaxis de proyecto de VSS. Por ejemplo, $/TEST/SUBPROYECTO. PVCS_SS.EXE intenta crear el proyecto especificado si no existe.

  • Carpeta PVCS – La carpeta PVCS guarda archivos PVCS ejecutables, como GET.EXE y VLOG.EXE. Si tiene la carpeta PVCS en su ruta MS-DOS, no es necesario especificar la opción -P. Si la carpeta PVCS no está en su ruta, utilice la opción -P para permitir que PVCS_SS.EXE localice PVCS. Por ejemplo:
    -pd:\pvcs
  • Carpeta de VSS: en la carpeta de VSS se encuentra el archivo SRCSAFE.INI de VSS. Si SRCSAFE.INI no está en la ruta de acceso, utilice -S para permitir que PVCS_SS.EXE encuentre VSS. Por ejemplo:
    -sh:\ss3
  • Contraseña: se trata de la contraseña del Administrador de VSS. Si ya se ha conectado a VSS como Admin, no tiene que especificar la contraseña. (Utilice Whoami en la línea de comandos para averiguar si está conectado como Admin.) Si no está conectado como Admin, utilice -U para dar la contraseña de Admin. Por ejemplo:
    -uAdmin,R2D2nC3P0

    De forma predeterminada, el usuario Admin no tiene contraseña. Si no le asignó una, puede omitir esta opción.

  • -? (o -H): si utiliza esta opción, PVCS_SS.EXE muestra una descripción de su línea de comandos. No se convierte ningún archivo.


Recover (Línea de comandos)

Vea también

Recupera los archivos y proyectos que se han eliminado.

Sintaxis

ss Recover elementos de VSS [-G] [-H] [-I-] [-N] [-O] [-S] [-W] [-Y] [-?]

Ejemplos

Recupera el archivo eliminado TEST.C:

ss Recover TEST.C

Recupera el proyecto eliminado $/WORD:

ss Recover $/WORD

En la siguiente tabla se describen las opciones de línea de comandos disponibles con este comando.

Opción | Descripción
-S | Activa el modo SmartMode, haciendo de un proyecto recuperado el proyecto actual.
-G | Establece las opciones para la copia local recuperada.
-W | Convierte la copia local recuperada en editable.
-O | Pagina o redirige el resultado del comando.
-I- | Pasar por alto: no pide entradas bajo ninguna circunstancia.
-N | Cambia entre los modos de nombre de archivo largo y corto.
-Y | Especifica un nombre de usuario o una contraseña.
-?, H | Solicita Ayuda en pantalla sobre un comando.

Derechos de acceso

Debe disponer del derecho de acceso Agregar para utilizar este comando.


Rename (Línea de comandos)

Vea también

Cambia el nombre de un archivo o un proyecto.

Sintaxis

ss Rename <elemento de SourceSafe> <nuevo nombre> [-H] [-I-] [-N] [-O] [-S] [-Y] [-?]

Ejemplos

Cambia el archivo de VSS llamado TEST.C a MISC.C:

ss Rename TEST.C MISC.C

Cambia el proyecto de VSS llamado WORD a EDITOR. (El nuevo proyecto es $/APPS/EDITOR):

ss Rename $/APPS/WORD EDITOR

En la siguiente tabla se describen las opciones de línea de comandos disponibles con este comando.

Opción | Descripción
-S | Activa el modo SmartMode, cambiando el nombre de la copia local tras cambiar el nombre de la copia maestra de VSS.
-O | Pagina o redirige el resultado del comando.
-I- | Pasar por alto: no pide entradas bajo ninguna circunstancia.
-N | Cambia entre los modos de nombre de archivo largo y corto.
-Y | Especifica un nombre de usuario o una contraseña.
-?, -H | Solicita Ayuda en pantalla sobre un comando.

Derechos de acceso

Debe disponer del derecho de acceso Agregar para utilizar este comando.


Rollback (Línea de comandos)

Vea también

Deshace todos los cambios realizados desde una versión anterior de un archivo.

Sintaxis

ss Rollback archivo de SourceSafe [-G] [-H] [-I-] [-N] [-O] [-V] [-W] [-Y] [-?]

Ejemplos

Deshace los cambios de TEST.C posteriores a la versión 10:

ss Rollback TEST.C -V10

Deshace los cambios de TEST.C posteriores a la versión 2.01b:

ss Rollback TEST.C -VL2.01b

En la siguiente tabla se describen las opciones de línea de comandos disponibles con este comando.

Opción | Descripción
-V | Especifica hasta qué versión de archivo deshacer los cambios; requiere al menos que esté compartiendo una versión anterior de un archivo.
-G | Establece las opciones de Get para la copia local recuperada.
-W | Convierte la copia local recuperada en editable.
-O | Pagina o redirige el resultado del comando.
-I- | Pasar por alto: no pide entradas bajo ninguna circunstancia.
-N | Cambia entre los modos de nombre de archivo largo y corto.
-Y | Especifica un nombre de usuario o una contraseña.
-?, -H | Solicita Ayuda en pantalla sobre un comando.

Derechos de acceso

Debe disponer del derecho de acceso Destruir para utilizar este comando.

Comentarios

Rollback realiza una operación Get cuando termina, a menos que la variable de inicialización Delete_Local de Ss.ini esté establecida a Yes o utilice la opción -G- en la línea de comandos para impedirlo.


Share (Línea de comandos)

Vea también

Convierte el archivo o el proyecto especificado en un miembro del proyecto actual.

Sintaxis

ss Share archivos de VSS [-C] [-E] [-G] [-H] [-I-] [-N] [-O] [-P] [-R] [-V] [-W] [-Y] [-?]

Ejemplos

Convierte $/WORD/TEST.C en un miembro del proyecto actual:

ss Share $/WORD/TEST.C

Convierte la versión 6 de TEST.C en un miembro del proyecto actual (observe el verbo del comando Pin):

ss Pin TEST.C -V6

Crea una bifurcación desde el proyecto $/WORD:

ss Share $/WORD -R -E

En la siguiente tabla se describen las opciones de línea de comandos disponibles con este comando.

Opción | Descripción
-V | Comparte una versión anterior de un archivo (o proyecto).
-G | Establece las opciones de Get para la copia local recuperada.
-W | Convierte la copia local recuperada en editable.
-R | Comparte una lista de proyectos completa de forma recursiva.
-P | Especifica un nuevo nombre para el proyecto compartido.
-C | Utiliza el mismo comentario para todos los proyectos compartidos (sólo está disponible cuando se comparten proyectos).
-O | Pagina o redirige el resultado del comando.
-E | Bifurca tras compartir.
-I- | Pasar por alto: no pide entradas bajo ninguna circunstancia.
-N | Cambia entre los modos de nombre de archivo largo y corto.
-Y | Especifica un nombre de usuario o una contraseña.
-?, -H | Solicita Ayuda en pantalla sobre un comando.

Derechos de acceso

Debe disponer del derecho de acceso Desproteger en el proyecto desde el que está compartiendo y el derecho de acceso Agregar en el proyecto al cual está compartiendo para utilizar este comando.

Comentarios

Para compartir un archivo, establezca primero la ruta del proyecto actual al proyecto en el que desea compartir el archivo con el comando CP. Después ejecute el comando Share, especificando el archivo o los archivos ya existente que desee llevar a su proyecto actual.

Si utiliza la opción -E, el archivo se convertirá en miembro de su proyecto actual, pero se bifurcará: los cambios realizados en este proyecto no se propagan al proyecto original y viceversa. La ficha Vínculos del cuadro de diálogo Propiedades (menú Archivo) ya no muestran una relación, pero puede utilizar la ficha Rutas de acceso del cuadro de diálogo Propiedades para ver la ruta de acceso de la bifurcación de archivo que ha creado.

Compartir una versión explícita de un archivo o proyecto

Para compartir una versión explícita de un archivo, utilice el comando Pin. Con los archivos, la opción -V de Share se acepta pero no se recomienda. Especifica un archivo (que puede o puede que no esté ya en el proyecto actual) y comparte una versión específica del mismo. Cuando un proyecto está compartiendo una versión específica, siempre utiliza esa versión sin importar los cambios realizados en otros proyectos. (Si está compartiendo una versión específica, el comando ss Dir muestra esta información.) La ventaja de compartir una versión específica de un archivo es que le permite controlar, en su proyecto, el ritmo de los cambios que están realizando otros usuarios en otros proyectos.

Con los proyectos, la opción -V especifica una versión anterior de un proyecto para compartir. Esto crea un nuevo proyecto basado en otro ya existente, pero el nuevo se basa en una versión determinada del proyecto original, en lugar de basarse en la versión actual. Si no bifurca, el nuevo proyecto seguirá compartiendo todos sus archivos con el original, pero compartirá versiones más antiguas de dichos archivos. Si bifurca, ya no se compartirán los nuevos archivos con los antiguos; es como si hubiera deshecho todos los archivos en el nuevo proyecto.

Compartir un proyecto

Cuando especifica un proyecto para compartir, en lugar de compartir un archivo de otro proyecto, se crea un proyecto nuevo y completo bajo el proyecto actual que es un duplicado exacto del proyecto que especificó.

La opción -R comparte de forma recursiva un proyecto y crea una nueva lista de proyectos que comparte todos sus archivos con la lista de proyectos que especifica.

Si utiliza la opción -E con un proyecto, el nuevo proyecto no compartirá sus archivos con el proyecto original; todos los archivos se bifurcan.

La opción -P especifica un nuevo nombre para el proyecto recién creado. De forma predeterminada, el nuevo proyecto tiene el mismo nombre que el proyecto desde el que está compartiendo. Sin embargo, este valor predeterminado no funciona si desea que el nuevo proyecto esté bajo el mismo primario que el antiguo: utilice la opción -P para crear una nueva bifurcación con un nuevo nombre. Por ejemplo, si comparte el proyecto $/TESTDATA dentro de su proyecto $/GIZMO/TESTDATA, sin la opción -P, se crea una situación en la que el subproyecto tiene el mismo nombre que el primario. Con -P puede evitarlo como sigue: SS SHARE -PSHARDATA $/TESTDATA.


Status (Línea de comandos)

Vea también

Muestra información de desprotección sobre archivos.

Sintaxis

ss Status [elementos de VSS] [-H] [-I-] [-N] [-O] [-P[proyecto]] [-R] [-U[nombre_usuario]] [-Y] [-?]

Ejemplos

Enumera todos los archivos desprotegidos del proyecto actual:

ss Status

Indica si TEST.C está desprotegido por el usuario Juan:

ss Status TEST.C -UJoyce

Muestra cada archivo del sistema que está desprotegido por el usuario actual:

ss Status $/ -R -U

Muestra los archivos del proyecto $/TESTDATA que están desprotegidos en $/TESTDATA. No muestra los archivos compartidos en $/TESTDATA, sino los desprotegidos de otros proyectos:

ss Status -P$/TESTDATA $/TESTDATA

En la siguiente tabla se describen las opciones de línea de comandos disponibles con este comando.

Opción | Descripción
-O | Pagina o redirige el resultado del comando.
-R | Muestra recursivamente el estado de una lista de proyectos completa.
-U | Muestra sólo los archivos desprotegidos para un cierto usuario.
-P | Filtra la lista de archivos desprotegidos para incluir sólo los archivos desprotegidos del proyecto actual o el especificado.
-I- | Pasar por alto: no pide entradas bajo ninguna circunstancia.
-N | Cambia entre los modos de nombre de archivo largo y corto.
-Y | Especifica un nombre de usuario o una contraseña.
-?, -H | Solicita Ayuda en pantalla sobre un comando.

Derechos de acceso

Debe disponer del derecho de acceso Leer para utilizar este comando.

Comentarios

Si tiene el mismo archivo desprotegido en múltiples equipos, el comando Status muestra el nombre del equipo, así como la ruta de desprotección. Si desprotegió el archivo con el formato de ruta UNC, el comando Status utilizará este formato en su devolución.

La opción -U muestra una lista de los archivos desprotegidos por el usuario especificado. Si utiliza la opción -U sin nombre de usuario, se asumirá el usuario actual (usted). Si no utiliza la opción -U de ninguna forma, se mostrarán todos los archivos desprotegidos.

Cuando un archivo se comparte entre múltiples proyectos, si está desprotegido de un proyecto, estará desprotegido de todos. Por esta razón, el comando Buscar por estado puede mostrarle los archivos que están desprotegidos para múltiples proyectos, ya que se comparten. La opción -P restringe la presentación a los archivos que se desprotegieron de un determinado proyecto. De forma predeterminada, es el proyecto en el cual está ejecutando el comando Buscar por estado.


Undocheckout (Línea de comandos)

Vea también

Cancela una desprotección, invalidando todos los cambios.

Sintaxis

ss Undocheckout archivos de VSS [-G] [-H] [-I-] [-N] [-O] [-P[proyecto]] [-R] [-W] [-Y] [-?]

Ejemplos

Cancela la desprotección del archivo TEST.C:

ss Undocheckout TEST.C

Cancela todas las desprotecciones realizadas del proyecto actual:

ss Undocheckout * -P

En la siguiente tabla se describen las opciones de línea de comandos disponibles con este comando.

Opción | Descripción
-O | Pagina o redirige el resultado del comando.
-G | Establece las opciones de Get para la copia local recuperada.
-W | Convierte la copia local recuperada en editable.
-R | Deshace la desprotección de una lista completa de proyectos de forma recursiva.
-P | Deshace la desprotección sólo de los archivos desprotegidos del proyecto actual o del especificado.
-I- | Pasar por alto: no pide entradas bajo ninguna circunstancia.
-N | Cambia entre los modos de nombre de archivo largo y corto.
-Y | Especifica un nombre de usuario o una contraseña.
-?, -H | Solicita Ayuda en pantalla sobre un comando.

Derechos de acceso

Debe disponer del derecho de acceso Desproteger para utilizar este comando.

Comentarios

Si especifica la opción -P, el comando sólo actúa sobre los elementos que están desprotegidos en el proyecto especificado. Si no especifica un proyecto en particular después de -P, se supondrá el proyecto actual.

Undocheckout realiza una operación Get cuando termina, a menos que la variable de inicialización Delete_Local del archivo Ss.ini esté establecida a Yes o utilice la opción -G-.

Undocheckout pasa por alto los archivos no desprotegidos.


Unpin (Línea de comandos)

Vea también

Deshace una operación Pin.

Sintaxis

ss Unpin elementos de VSS [-G] [-H] [-N] [-W] [-Y] [-?]

Ejemplos

Cancela el estado fijado con el comando Pin de MIARCH.CPP y MIARCH.H:

ss Unpin MIARCH.CPP MIARCH.H

Cancela el estado fijado con el comando Pin para todos los archivos .DOC del proyecto actual:

ss Unpin *.DOC

Cancela el estado fijado con el comando Pin para todos los archivos del proyecto SPECS:

ss Unpin $/CEDAR/SPECS/*.*

En la siguiente tabla se describen las opciones de línea de comandos disponibles con este comando.

Opción | Descripción
-G | Establece las opciones de Get para la copia local recuperada.
-W | Convierte la copia local recuperada en editable.
-N | Cambia entre los modos de nombre de archivo largo y corto.
-Y | Especifica un nombre de usuario o una contraseña.
-?, -H | Solicita Ayuda en pantalla sobre un comando.

Derechos de acceso

Es necesario disponer del derecho de acceso Desproteger en el proyecto del que está cancelando el fijado de un archivo a una versión para utilizar este comando.

Comentarios

El comando Unpin busca los archivos especificados. Para los archivos fijados a una versión específica, el comando Unpin vuelve a hacer que compartan la última versión del proyecto.

El comando Unpin pasa por alto los archivos que no se han fijado con el comando Pin.


View (Línea de comandos)

Vea también

Muestra el texto de un archivo.

Sintaxis

ss View archivos de VSS [-H] [-I-] [-N] [-O] [-V] [-Y] [-?]

Ejemplos

Muestra el contenido del archivo TEST.C de VSS:

ss View TEST.C

Recupera la versión 5 de TEST.C en un archivo llamado TEST.OLD (sólo para archivos de texto):

ss View TEST.C -V5 -OTEST.OLD

En la siguiente tabla se describen las opciones de línea de comandos disponibles con este comando.

Opción | Descripción
-O | Pagina o redirige el resultado del comando.
-V | Examina una versión anterior de un archivo.
-I- | Pasar por alto: no pide entradas bajo ninguna circunstancia.
-N | Cambia entre los modos de nombre de archivo largo y corto.
-Y | Especifica un nombre de usuario o una contraseña.
-?, -H | Solicita Ayuda en pantalla sobre un comando.

Derechos de acceso

Debe disponer del derecho de acceso Leer para utilizar este comando.

Comentarios

El comando View muestra el texto de un archivo de VSS en la pantalla de una forma muy parecida al comando type de MS-DOS. No realiza una operación Get sobre el archivo ni cambia nada de VSS o de su carpeta de trabajo.

De forma predeterminada, VSS muestra el archivo desplazándolo por la línea de comandos. Si desea que el texto se muestre de forma diferente, configure la variable de inicialización Editor para especificar el editor de textos en el cual desea ver el texto del archivo. También puede utilizar la variable de inicialización Extension_Association para configurar el editor asociado a las diferentes extensiones de archivo.


Whoami (Línea de comandos)

Vea también

Muestra un nombre de usuario actual de VSS. Está disponible sólo desde la línea de comandos. Para ver con qué nombre ha iniciado la sesión en el Explorador, consulte la barra de estado.

Sintaxis

ss Whoami [-H] [-I-] [-Y] [-?]

En la siguiente tabla se describen las opciones de línea de comandos disponibles con este comando.

Opción | Descripción
-I- | Pasar por alto: no pide entradas bajo ninguna circunstancia.
-Y | Especifica un nombre de usuario o una contraseña.
-?, -H | Solicita Ayuda en pantalla sobre un comando.

Derechos de acceso

Cualquier usuario de VSS puede utilizar este comando.


WorkFold

Vea también

Establece la carpeta de trabajo. En el Explorador de VSS, utilice el comando Establecer carpeta de trabajo.

Sintaxis

SS Workfold [Proyecto] [Carpeta]

Ejemplos

Establece la carpeta de trabajo del proyecto $/SitioWeb a c:\Web externo\SitioWeb:

ss Workfold $/SITIOWEB c:\Web externo\SitioWeb

En la siguiente tabla se describen las opciones de línea de comandos disponibles con este comando.

Opción | Descripción
Project | Especifica el proyecto de VSS para el que desea establecer una carpeta de trabajo.
Carpeta | Especifica la carpeta de trabajo para el proyecto especificado.
-?, -H | Solicita Ayuda en pantalla sobre un comando.

Derechos de acceso

Debe disponer del derecho de acceso Leer para utilizar este comando.

Comentarios

Este comando hace que la carpeta especificada sea la carpeta de trabajo para el proyecto especificado.

Observe que tanto el proyecto como la carpeta son opcionales. Si no se especifica ninguno de los dos, se utilizará el proyecto o la carpeta actual. Es decir, si no especifica ninguna carpeta, se utilizará la carpeta actual. Si no especifica ningún proyecto, se utilizará el proyecto actual. Si especifica más de un proyecto o más de una carpeta, se producirá un error.

El resultado del comando es simplemente esta cadena:

%s se ha establecido como la carpeta de trabajo para el proyecto %s.

Este comando pasa por alto las variables de inicialización Force_Dir y Force_Prj.


Utilidades de VSS

Vea también

Se incluyen diversos programas con VSS. La tabla siguiente enumera cada programa y su finalidad.

Programa | Finalidad
Analyze.exe | Explora una base de datos VSS para comprobar su integridad y la existencia de errores.
DDCONV.exe | Actualiza una base de datos de VSS desde un formato anterior al actual.
DDUPD.exe | Actualiza la base de datos de VSS a un nuevo formato. El nuevo formato inicializará la base de datos para aprovechar la promoción de etiquetas y las mejoras de rendimiento que ofrece VSS 6.0. Durante la instalación, es posible que se haya actualizado la base de datos. Si existe la carpeta ..\data\labels, la base de datos está en el nuevo formato. Con esta utilidad también se puede volver a la versión anterior de la base de datos.
Delta_SS.exe | Convierte proyectos o archivos de Microsoft Delta a proyectos de VSS.
MKSS.exe | Crea una base de datos de VSS vacía con un formato anterior. Se ejecuta automáticamente cuando se instala por primera vez VSS.
PVCS_SS.exe | Convierte proyectos o archivos de PVCS en proyectos de VSS.
SS.exe | Permite utilizar en Windows la sintaxis de la línea de comandos de MS-DOS.
SSARC.EXE | Archiva parte o toda la base de datos de VSS en un archivo de almacenamiento comprimido.
SSLogin.exe | Se utiliza en secuencias de comandos y macros de integración para buscar o establecer el nombre de un usuario conectado y, opcionalmente, su archivo SS.INI y su proyecto.
SSRestor.exe | Restaura parte o todo un archivo de base de datos de VSS almacenado en una base de datos de VSS.
Testlock.exe | Comprueba los bloqueos de archivo para ayudarle a detectar el mecanismo de bloqueo de la red.
Unlock.exe | Libera los bloqueos de la base de datos tras un fallo de alimentación u otra pérdida inesperada.
Updini.exe | Convierte al formato actual archivos .ini de VSS de un formato anterior a la versión 3.0.


Programa Analyze

Vea también

Analyze.exe explora una base de datos VSS para comprobar su integridad o si contiene errores, mostrarlos y, si se ha especificado que lo haga, repararlos. Los administradores de VSS deben ejecutar Analyze.exe una vez a la semana para comprobar que no hay ningún problema en la base de datos de VSS.

Los administradores pueden utilizar el programa de la línea de comandos de 32 bits para reparar las bases de datos de VSS versión 4.0 (y posteriores). Por ejemplo, hay un problema en la base de datos cuando selecciona un archivo que sabe que está en la base de datos de VSS, utiliza un comando como GET y recibe el mensaje de error "No existe el archivo".

Los administradores pueden ejecutar manualmente Analyze.exe desde la línea de comandos o como parte de una secuencia de comandos en una operación desatendida para analizar o reparar el problema. El programa Analyze.exe se encuentra en la carpeta WIN32 dentro de la carpeta en la que instaló VSS.

Es conveniente ejecutar Analyze.exe dos veces: primero con la opción -F (para reparar todos los errores encontrados) y una segunda vez para comprobar si queda algún error. Si todavía hay errores después de la primera ejecución, consulte el artículo Q152807 de Microsoft Knowledge Base (en http://www.microsoft.com/kb) para obtener más información (este sitio está en inglés).

Sintaxis

ANALYZE [-B<carpeta>] [-C] [-D] [-F] [-I-] [-V] [-X] [-?] [-H] <Ruta completa de la base de datos | @Archivo de respuestas | Lista de archivos>

Opción | Descripción
-B<carpeta> | Especifica una carpeta de copia de seguridad.
-C | Limpia y comprime la base de datos. Esta opción puede resultar lenta.
-D | Elimina los archivos que no se utilizan.
-F | Intenta reparar cualquier incoherencia o daño detectados.
-I- | Continúa sin detenerse para permitir que el usuario escriba datos (permitiendo una operación desatendida). De forma predeterminada, Analyze.exe deja la ventana de resultados en la pantalla.
-V n | Especifica el detalle con que se mostrarán los datos. -V1 muestra únicamente los errores críticos, -V2 muestra los errores críticos y los significativos, -V3 muestra todos los errores, y -V4 muestra todos los errores y advertencias. La opción -V4 muestra su resultado en el panel inferior de la ventana Resultados de Analyze y contiene información detallada acerca de lo que intentó el programa y lo que consiguió realizar. El valor predeterminado es -V1. -V (sin ningún número) equivale a -V4.
-X | Indica a Analyze.exe que no bloquee los archivos mientras los procesa. Permite realizar el análisis de una base de datos en uso. No puede utilizarse esta opción con las opciones -c, -d o -f ni se recomienda el uso de esta opción a menos que sea absolutamente necesario.
Ruta completa de la base de datos | Ruta de acceso de la carpeta de datos de VSS para analizar. Este parámetro debe ser el primero que no sea modificador. En la línea de comandos debe haber una ruta de acceso a datos, una lista de archivos o un archivo de respuestas.
@Archivo de respuestas | Archivo producido por la ejecución de Analyze.exe, que contiene una lista de los archivos con problemas, y se denomina de manera predeterminada Analyze.bad. Usando este archivo como entrada, se hace que Analyze.exe funciones sobre menos archivos, y de esta manera se mejora el rendimiento.
Lista de archivos | Lista de archivos para analizar. Sólo puede incluir archivos de registro o rutas completas de acceso a datos como C:\VSS\DATA\A\AAAAAAAA.
-?, -H | Muestra un mensaje de utilización que contiene descripciones de las opciones válidas.

El orden de las opciones no es importante, pero la ruta completa de acceso a la base de datos, el archivo de respuestas o la lista de archivos tienen que incluirse en la línea de comandos como el primer elemento que no se una opción.

Ejemplos

ANALYZE -C -D -F -V4 C:\VSS\Data

Analiza y repara toda la base de datos y genera información detallada.

ANALYZE -BC:\Temp C:\VSS\Data

Analiza la base de datos, pero no la repara. Crea una lista de los archivos dañados en C:\Temp.

ANALYZE -F -C -D @C:\Temp\Analyze.bad

Repara todos los problemas de los archivos enumerados en el archivo Analyze.bad generada por el ejemplo anterior.

Comentarios

Los tipos de problemas que el programa Analyze.exe puede corregir son, entre otros, los siguientes:

  • Que el primario y el secundario no coincidan. Entre las situaciones posibles se encuentran aquellas en las que un proyecto "piensa" que tiene un archivo o un subproyecto pero el secundario no está de acuerdo, un secundario cree que tiene un primario pero el primario está en desacuerdo o que el primario y el secundario no se hagan referencia entre sí.

  • Archivos de base de datos dañados. Estos archivos incluyen los siguientes: Names.dat (almacena nombres de archivo largos de más de 34 caracteres), Rights.dat (almacena relaciones entre derechos de proyectos y usuarios), Status.dat (almacena los estados de check out de los archivos), Um.dat (almacena todos los usuarios en una base de datos de VSS) y Version.dat (almacena la versión de VSS).

  • Quitando los elementos no utilizados de la base de datos.

Los administradores deben ejecutar periódicamente este programa para comprobar la inexistencia de problemas en su base de datos de VSS. Todos los resultados de análisis o reparaciones se registran en el archivo Analyze.log, ubicado en la carpeta \VSS\Data\Backup y que se actualizará cada vez que ejecute Analyze.exe. Cuando analiza la base de datos, Analyze.exe crea un archivo con una lista de todos los archivos dañados. Este archivo se llama Analyze.bad y también se encuentra en la carpeta \VSS\Data\Backup. Además, las versiones originales de los archivos reparados se encuentran en la carpeta \VSS\Data\Backup.

En condiciones normales, todos los usuarios deben cerrar una sesión de VSS antes de que los administradores ejecuten Analyze.exe. Los usuarios deben cerrar una sesión para ejecutar Analyze.exe con la opción - F y resolver problemas. Analyze.exe no se ejecuta si hay algún usuario conectado a VSS, a menos que se incluye la opción -X.

Analyze.exe escribe los resultados en una ventana creada por él, Resultados de Analyze. Esta ventana puede constar de dos paneles. Debe cerrar todas las ventanas de resultados abiertas antes de volver a ejecutar Analyze.exe.

El panel superior (o único) contiene información de resumen. Por ejemplo:

Analyze Version 4.00[Build 1110]
Análisis de la base de datos en progreso.
El proyecto primario para el elemento acctapp está dañado y el vínculo con el archivo secundario se ha perdido hasta que se recupere el proyecto.
Análisis completo.

Ésta es la información que aparecerá en la ventana de resultados cuando ejecute Analyze.exe con la opción -V o la opción -V4 para obtener una información exhaustiva. Cuando utilice la opción -V la información aparecerá en el panel inferior de la ventana Resultados de Analyze. A continuación se muestra un ejemplo de unos resultados detallados:

Comenzó el análisis del sistema de administración de usuarios.
Se ha completado correctamente el análisis del sistema de administración de usuarios.
Reconstruyendo el proyecto dañado para el elemento aaaaaaaa.
Generando la lista del proyecto.
Comprobando las relaciones cruzadas de archivos.
Comprobando las relaciones primarias y secundarias.
Validando el sistema de seguridad.
Escribiendo una nueva copia de 'c:\vss\data\a\aaaaaaaa'.
El contador de secundarios del elemento 'aaaaaaaa', como aparece en su encabezado, no coincide con el número de secundarios encontrados en el disco. Se ajustará el contador.
El contador de subproyectos del elemento 'aaaaaaaa', como aparece en su encabezado, no coincide con el número de subproyectos encontrados en el disco. Se ajustará el contador.

Observe que el contenido de la ventana Resultados de Analyze no se ajusta automáticamente, sino que se desplaza dentro del panel.

Cuando el programa Analyze.exe reconstruye el archivo de base de datos Rights.dat, se activa la seguridad del proyecto, incluso aunque se hubiera desactivado la seguridad antes de la reconstrucción. Como resultado, sólo el Administrador puede iniciar una sesión en VSS tras volver a generar Rights.dat. De esta manera, el Administrador tiene que ejecutar después el programa SSAdmin para desactivar la seguridad del proyecto o para volver a asignar todos los derechos de usuario.


Programa DdCONV

Vea también

Ddconv.exe actualiza una base de datos de VSS desde un formato antiguo al formato actual.

Ddconv.exe lo utilizan principalmente secuencias de comandos de instalación para asegurarse de que el formato de una base de datos de VSS instalada es correcto después de una actualización. Ddconv.exe es también uno de los pasos del proceso de creación de una base de datos nueva de VSS con el programa Mkss.exe.

Si durante la instalación VSS no puede encontrar todas las bases de datos instaladas, puede que el administrador de VSS tenga que ejecutar este programa manualmente. Ddconv.exe también puede utilizarse con la opción -S para reconstruir el archivo de estado.

Sintaxis

DDCONV [-S] [-MSSruta]|[ruta de datos]

La tabla siguiente describe las opciones de línea de comandos disponibles con este comando.

Opción | Descripción
-MSSruta | Ruta de acceso de un archivo SRCSAFE.ini desde el que Ddconv.exe puede determinar la carpeta de datos.
Ruta de datos | Ruta de acceso a una carpeta de datos para convertir.
-S | Reconstruir el archivo de índice VSS de estado de desprotección.


Programa DDUPD

Vea también

DDUPD actualiza la base de datos de Visual SourceSafe a un formato nuevo. El nuevo formato inicializará la base de datos para aprovechar la promoción de etiquetas y las mejoras de rendimiento que ofrece VSS 6.0. Durante la instalación, es posible que se haya actualizado la base de datos. Si existe la carpeta ..\data\labels, la base de datos está en el nuevo formato. Con esta utilidad también se puede volver a la versión anterior de la base de datos.

Notas acerca de la actualización:

  • Haga una copia de seguridad de su base de datos VSS antes de actualizar.

  • Asegúrese de que todos los usuarios salen de VSS antes de actualizar a la nueva versión. Sin embargo, los usuarios pueden tener archivos desprotegidos durante la actualización.

  • De forma predeterminada, cuando actualiza a VSS 6.0, el formato de la base de datos es el mismo que el de VSS 5.0 (y 4.0a). Si tiene un sistema Macintosh, UNIX, NT 3.51 o un cliente de 16 bit, debe conservar el formato de la base de datos anterior. (También debe conservar el formato de bases de datos 5.0 hasta que obtenga las sus propias licencias de VSS 6.0 para todos los usuarios.)

  • Si no tiene ningún problema de compatibilidad con lo anterior, puede actualizar la base de datos al nuevo formato, que le permitirá aprovechar de algunas de las mejoras en rendimiento de VSS 6.0. Con el nuevo formato de base de datos, cualquier comando que pida a VSS que copie un archivo a su unidad local (como Get, Check Out, Undo Check Out, Deploy, etc.) será más rápido. La gran mejora en el rendimiento se aprecia en aquellas situaciones en que el archivo ya existe y no es necesaria ninguna copia.

  • Actualizar la base de datos le permite aprovechar la nueva característica de promoción de etiquetas. Para obtener más información, consulte Mantener varias versiones de un proyecto.


Programa Delta_SS

Vea también

Delta_SS.exe extrae archivos de las bibliotecas de Microsoft Delta y los convierte al formato interno de VSS.

Si tiene proyectos guardados en Delta, puede convertirlos a VSS. No se modifican los archivos de Delta. Puede convertir proyectos completos o archivos individuales de Delta. Tras la conversión, todos los archivos residen en un proyecto de VSS del mismo nombre.

Si desea convertir uno o sólo algunos archivos de Delta a VSS, tendrá que ejecutar el programa Delta_SS.exe para cada archivo. También puede utilizar caracteres comodín para incluir varios archivos en un único proyecto.

El archivo que se va a convertir no debe estar bloqueado ni tener el estado de "roto". Para evitar versiones incoherentes de los archivos cuando se convierten varios archivos, asegúrese de que el proyecto no está en uso. Puede utilizar el comando Lock Project de Delta para desactivar el proyecto mientras lo está convirtiendo.

Delta_SS.exe necesita la versión actual de VSS y la instalación de las herramientas de la línea de comandos para la versión 1.0 de Delta. También necesita suficiente espacio libre en disco en la unidad de destino de VSS para colocar los nuevos archivos: se necesita aproximadamente el doble del espacio de disco utilizado por los archivos de registro de Delta para espacio de trabajo y para los archivos nuevos.

Nota Antes de utilizar Delta_SS.exe, no olvide hacer copia de seguridad de los archivos de proyecto de Delta y de la base de datos VSS.

Para convertir un archivo o una carpeta:

  • En la línea de comandos, escriba Delta_SS -V -D [ubicación del proyecto de Delta] -P [nombre del proyecto de Delta] -S [ubicación de VSS] -U [contraseña de VSS] [archivo | carpeta] [nombre del proyecto de VSS].

    Por ejemplo:

    Delta_SS -v -d c:\Delta -p ToolVer1 -s c:\SS -u drowssap Archivo1.txt

    Esto genera un informe detallado de la conversión del archivo Archivo1.txt de Delta a VSS. Como no se ha especificado ningún proyecto de VSS, el archivo convertido se ubica en un proyecto con el mismo nombre que el proyecto de Delta.

Para convertir un proyecto entero:

  • En la línea de comandos, escriba Delta_SS -V -R -D [ubicación del proyecto de Delta] -P [nombre del proyecto de Delta] -S [proyecto de VSS] -U [contraseña de VSS] [archivo | carpeta] [nombre del proyecto de VSS].

    Por ejemplo:

    Delta_SS –v -r -d c:\Delta -p ToolVer1 -s c:\SS -u drowssap

    Esto convierte el proyecto ToolVer1 (y, de forma recursiva, todos sus subproyectos) de Delta a VSS. Esta conversión incluye todo el historial de cada archivo.

Comentarios

Sólo el administrador de VSS puede ejecutar el programa Delta_SS.exe. La opción -U se utiliza para especificar la contraseña del administrador de VSS, si la tiene.

Si no proporciona en la línea de comandos la ubicación de la base de datos de VSS con la opción -S, Delta_SS.exe determinará la ubicación de VSS de la siguiente forma:

  • Si la variable de entorno SSDIR (sistema operativo) está definida, se utiliza la ubicación especificada.

  • Si la carpeta primaria de la carpeta en la que se encuentra Delta_SS.exe contiene SRCSAFE.INI, se utilizará dicha carpeta.

  • Si la carpeta actual contiene el archivo SRCSAFE.INI, se utilizará la carpeta actual.

  • Si no se encuentra ninguno de los anteriores, Delta_SS.EXE terminará con un mensaje de error.

La opción -R convierte de forma recursiva todos los proyectos bajo el proyecto de Delta especificado.

La opción -P especifica que no se requiere el nombre del proyecto de VSS. Si no se especifica, Delta_SS.exe utiliza como valor predeterminado el nombre del proyecto de Delta. (El nombre del proyecto de Delta debe especificarse con la opción -D.)

Se puede utilizar tanto -? como -H (en una línea de comandos de Windows) para obtener una lista de la sintaxis de Delta_SS.exe.

Tras lograr la conversión, los archivos se colocan en el proyecto de VSS especificado. Si el proyecto de destino no existe, se crea durante la conversión. Se crea un archivo de registro (llamado Delta_SS.log) que describe la conversión y se coloca en la carpeta en la que está instalado VSS.

De forma predeterminada, Delta_SS.exe guarda todo el historial de cada archivo seleccionado. Si desea convertir únicamente la versión más reciente, puede recuperarla de Delta y agregarla manualmente a VSS mediante el comando Agregar archivos de VSS.

Nota Debe especificar la ubicación de la carpeta del proyecto maestro de Delta. Delta_SS.exe no funciona con archivos de Delta desprotegidos en la carpeta de trabajo.


Programa MKSS

Vea también

Mkss.exe crea una base de datos de VSS vacía en un formato antiguo. Mkss.exe se instala de forma predeterminada en la subcarpeta ADMIN.

Para crear una nueva base de datos de VSS:

  1. Cree una carpeta.

  2. Ejecute en la carpeta el programa Mkss.exe.

  3. Ejecute en la carpeta el programa Ddconv.exe.

Sintaxis

MKSS [carpeta]


Programa PVCS_SS

Vea también

PVCS_SS.exe convierte un proyecto o un archivo PVCS en un proyecto o en un archivo de VSS.

VSS y PVCS utilizan diferentes métodos internos de almacenamiento de archivos, por lo que los usuarios de PVCS no pueden simplemente cambiar de programa para utilizar VSS; primero deben extraer todos los archivos de registro de PVCS e introducirlos en proyectos de VSS.

Es posible convertir manualmente un proyecto si obtiene un archivo de PVCS y lo agrega a VSS. Sin embargo, tiene algunas desventajas: se tarda bastante tiempo y es fácil que se produzcan errores si no se conservan los historiales de los archivos ni los comentarios, sólo se convierte la última versión de cada archivo.

El programa PVCS_SS.exe proporciona una solución automática. Convierte archivos de registro de PVCS en archivos de VSS, manteniendo intactos sus historiales y comentarios.

Nota Sólo el administrador de VSS puede ejecutar el programa PVCS_SS.exe.

Para preparar la ejecución del programa PVCS_SS.exe:

  1. Haga una copia de seguridad de los archivos de proyecto de PVCS y de la base de datos de VSS.

  2. Asegúrese de que tanto PVCS como VSS están completamente instalados en su sistema. El programa PVCS_SS.exe no reemplaza el proceso de instalación de VSS, sino que se ejecuta tras la instalación de VSS.

  3. Inicie la sesión en VSS como usuario Admin. La mejor forma de hacerlo consiste en establecer variables de entorno (sistema operativo) en el símbolo del sistema. SSUSER y SSPWD son variables de entorno que indican el nombre de usuario y la contraseña, respectivamente. Por ejemplo:
    Set ssuser = admin
Set sspwd = hoof

    De forma predeterminada, el administrador de VSS no tiene asignada ninguna contraseña; especifique una contraseña sólo si se le ha asignado alguna.

  4. Confirme que tanto la carpeta PVCS (en la que se encuentran los archivos ejecutables como Get.exe y VLog.exe) como la carpeta de VSS están en la ruta de acceso a MS-DOS. Aunque no es obligatorio tener dichas carpetas en la ruta, simplifica la ejecución de PVCS_SS.exe.

Ahora ya puede ejecutar el programa PVCS_SS.exe y convertir todos sus archivos.

Para ejecutar PVCS_SS.exe:

  1. Sitúese en la carpeta en la que se encuentran los archivos de registro de PVCS.

    Los archivos de registro de PVCS almacenan todos los datos, comentarios, historiales, etc. En general, se nombran con las extensiones que utilizan sus nombres de archivo, terminadas con una V, por lo que Test.C se convierte en Test.C_V y Test.pas se convierte en Test.pav. Sin embargo, el valor LOGSUFFIX de configuración de PVCS puede cambiar la extensión de nombre del archivo de registro.

  2. Escriba PVCS_SS <archivos de registro de PVCS> <proyecto de VSS>

    El nombre del proyecto de destino de VSS tiene que empezar con un signo de dólar ($). De lo contrario, se supone que esta variable es un archivo de registro de PVCS. A continuación se ofrecen algunos ejemplos.

    PVCS_SS *.??V $/Proyecto
PVCS_SS TEST.C_V TEST.H_V $/Test
PVCS_SS *.PAV TEST.TXV $/
  3. Repita los pasos 1 y 2 para todos los archivos de registro de PVCS que desee convertir.

Comentarios

  • El nombre de archivo en VSS no es el nombre del archivo de registro de PVCS; es el nombre del archivo de trabajo de PVCS, es decir, el nombre real del archivo. Por ejemplo, Test.C_V se convierte en Test.C en VSS.

  • Si el proyecto de VSS especificado ya existe, se le agregarán los archivos convertidos. Si el proyecto no existe, se creará. Si no especifica ningún proyecto, se utilizará el proyecto actual del usuario Admin VSS.

  • Si hay diez revisiones de un archivo en PVCS, habrá diez versiones del archivo en VSS. Sin embargo, los sistemas de numeración utilizados por dichos programas son diferentes. PVCS empieza por 1.0, seguido de 1.1, 1.2, 1.3 y así sucesivamente. VSS utiliza números enteros: 1, 2, 3, etc. Por tanto, lo que era 1.3 en PVCS se convierte en la versión 4 en VSS.

  • Durante su ejecución, el programa PVCS_SS.exe muestra todos los archivos que está convirtiendo y las bifurcaciones que pasa por alto. Todo esto queda registrado en un archivo llamado PVCS_SS.log en la carpeta donde está instalado VSS.

  • En PVCS una revisión nula es la revisión de un archivo que no aporta cambios. PVCS_SS.exe determina cómo tratar estas revisiones basándose en la variable de inicialización Update_No_Change del archivo SS.INI del usuario Admin. Si la variable Update_No_Change no está establecida, PVCS_SS.exe asume el valor predeterminado, Update (actualizar), y convierte todas las revisiones nulas.

  • Tanto PVCS como VSS aceptan bifurcaciones, pero PVCS_SS.exe no convierte bifurcaciones de PVCS en bifurcaciones de VSS. Tendrá que convertir manualmente las bifurcaciones que desee mantener. PVCS_SS.exe le ayuda durante dicho proceso informando y registrando en PVCS_SS.log todas las bifurcaciones que pasa por alto.


Programa SS

Vea también

Puede utilizar el programa SS.exe para integrar otras aplicaciones con VSS mediante la creación de archivos por lotes o mediante la llamada a comandos de SS.exe desde la aplicación. SS.exe utiliza la sintaxis siguiente.

Sintaxis

SS nombre de comando <elemento(s) sobre los que operar> [modificadores]

Ejemplo

Ejecuta un comando Obtener la última versión de VSS en el archivo Archivo.txt:

ss Get Archivo.txt

En la Ayuda de VSS se describen todos los comandos del conjunto de comandos.


Programa SSARC

Vea también

SSARC.exe y SSrestor.exe constituyen juntos el programa Archive de VSS. Esta combinación:

  • Permite al usuario guardar archivos, proyectos o versiones antiguas de una base de datos de VSS y restaurarlos posteriormente si necesario.

  • Permite a instalaciones de área extensa de VSS mover archivos y proyectos entre las bases de datos.

  • La capacidad de mover información de una base de datos a otra es muy importante, especialmente en los usuarios más avanzados de VSS, que son los que necesitan usar más de una base de datos.

Sintaxis

SSARC [-d] [-v] [-s] [-c] [-o] [-i-] [-y] <archivo para crear> <archivos y proyectos para archivar>

La tabla siguiente describe las opciones de línea de comandos disponibles con este comando.

Opción | Descripción
[-d] | Elimina los elementos archivados de la base de datos.
[-d-] | -d- controla si VSS elimina realmente algo de una base de datos. Si no se utiliza este parámetro, se preguntará de forma predeterminada.
[-v] | Especifica un número de versión para los archivos (parámetro estándar de VSS).
[-s] | Especifica una ruta para SRCSAFE.INI y la carpeta de datos.
[-c] | Comentario (parámetro estándar de VSS).
[-o] | Redirige el resultado (parámetro estándar de VSS).
[-i-] | Sin entrada (parámetro estándar de VSS).
[-y] | Nombre usuario, contraseña (parámetro estándar de SVSS).
[-x] | Archive sólo eliminó elementos en los archivos y proyectos especificados en el parámetro archivos y proyectos para archivar. (Los elementos eliminados todavía se almacenan en la base de datos de VSS a no ser que se haya seleccionado la opción Destruir definitivamente al realizar la operación de eliminación.) Tenga en cuenta que este parámetro no es necesario al restaurar más adelante.

Nota VSS pregunta sólo una vez antes de eliminar los archivos, cada vez que ejecute SSARC.EXE.

La opción -v especifica una versión, en el formato estándar de VSS (número, fecha o etiqueta). Es el parámetro más importante. Si no lo utiliza, archivará archivos y proyectos enteros. Cuando haga esto, estará archivando "esta versión y todas las versiones por encima de ésta". Observe que este programa es normalmente inclusivo. Es decir, si escribe -v9 creará un archivo que contendrá la versión 9 y todo lo anterior. El paso de eliminar también es inclusivo; es decir, la versión 9 realmente se elimina a menos que sea una etiqueta. Si esta versión es una etiqueta, ésta se almacena en el archivo, pero no se elimina. Si se especifica -v, nunca se elimina la versión actual, incluso si se especifica -vd9/9/99. Si está usando una etiqueta y ésta tiene un espacio en blanco, debe escribir entre comillas toda la opción (por ejemplo: "-vEsta").

La opción -s permite al usuario especificar la ruta de SRCSAFE.INI o la ruta de datos. La sintaxis completa es la siguiente:

-sc: \VSS, OldDB

El elemento que aparece delante de la coma es la ruta completa de SRCSAFE.INI y el que figura después de la coma, si existe, es la cadena entre paréntesis de un valor Data_Path. Si no hay ninguna coma, el usuario está especificando una ruta de SRCSAFE.INI pero no una cadena de datos. Si el primer carácter que hay después de -s es una coma, el usuario está especificando una cadena de datos y no una ruta de SRCSAFE.INI.

Nota La mayoría de los usuarios no necesitan esta opción. El archivo SRCSAFE.INI y el programa Ssarc.exe se sitúan correctamente durante la instalación de VSS.

La opción –c es la opción de comentario estándar de VSS. El comentario se inserta en el historial de VSS, si se eliminan los elementos de la base de datos como parte del registro "archivado". El comentario, si existe, también se inserta en el propio archivo.

Las opciones –o e -i- son opciones estándar de VSS.

Al igual que en SSRestor.exe, la opción –y le permite especificar la contraseña del administrador. Por ejemplo:

-yAdmin, Bunny


Programa SSLogin

Vea también

SSLogin.exe lo utilizan principalmente macros y secuencias de comandos de integración para encontrar el nombre del usuario conectado y, opcionalmente, para obtener el archivo .INI e información del proyecto actual para dicho usuario. Si está ejecutando el programa SS.exe, puede utilizar también SSLogin.exe para establecer el nombre de inicio de sesión almacenado por SS.exe.

Sintaxis

SSLOGIN [-códigoSalida] [-E] [-OnombreArchivo] [nombreUsuario] [contraseña]

La tabla siguiente describe las opciones de línea de comandos disponibles con este comando.

Opción | Descripción
-códigoSalida | Muestra una línea del formato "Código de salida: 0" de forma que los programas que llaman puedan determinar si SSLogin.exe se ha ejecutado correctamente. Un cero indica que SSLogin.exe se ha ejecutado correctamente; cualquier otra cosa indica que no ha sido así.
-E | Muestra el proyecto actual del usuario y la ruta del archivo .ini, además del nombre de usuario.
-O nombreArchivo | Envía la información al archivo especificado en vez de enviarlo a la pantalla.
nombreUsuario | Nombre del usuario sobre el que desea información. Si el usuario no existe, devuelve un código de salida distinto de cero. Si no se especifica ningún nombre, se utiliza el usuario actual de VSS. Si se está ejecutando SS.exe, el nombre de usuario especificado se pasa a SS.exe, que se conecta en la práctica como un usuario nuevo.
contraseña | Utilizado para validar el usuario.


Programa SSRestor

Vea también

SSRestor.exe restaura información a partir de un archivo creado previamente.

Sintaxis

SSRESTOR [-pProyecto] [-l] [-t] [-s] [-o] [-i-] [-y] <archivo para restaurar> [archivos/proyectos]

La tabla siguiente describe las opciones de línea de comandos disponibles con este comando.

Opción | Descripción
[-p] | Especifica un proyecto para restaurar.
[-l] | Lista.
[-la] | Lista de todos.
[-t] | Comprueba si hay daños en el archivo pero no hace nada.
[-s] | Especifica una ruta para SRCSAFE.INI y la carpeta de datos.
[-o] | Redirige el resultado (parámetro estándar de VSS).
[-i-] | Sin entrada (parámetro estándar de VSS).
[-y] | Nombre de usuario, contraseña (parámetro estándar de VSS).
[-x] | Identifica qué elemento se va a restaurar cuando se haya eliminado el elemento del proyecto. -x significa que se va a restaurar el elemento eliminado. Por ejemplo, suponga que tiene un proyecto $/a/b, tanto eliminado como sin eliminar. Si guarda y elimina $/a, se obtienen realmente tres proyectos ($/a, $/a/b y $/a/b) eliminados. Por tanto, ¿qué significa ssrestor $/a/b realmente? Si no se especifica -x, ssrestor $/a/b significa que va a usar el proyecto $/a/b no eliminado. Si se especifica -x, se restaura el proyecto $/a/b eliminado. Aunque tengan el mismo nombre, son dos proyectos diferentes.
[-c] | Especifica el comentario que se aplica a la entrada de historial para los elementos restaurados.

La opción -p especifica un proyecto para restaurar. Por ejemplo, si archiva $/A/BAR.C y luego lo restaura, debe restaurarse como $/A/BAR.C. Utilice el parámetro -p sólo si desea restaurar el archivo en otro proyecto diferente.

Nota Observe que si al restaurar intenta crear un nombre de archivo o de proyecto duplicado, la restauración falla.

La opción -l especifica "no restaurar nada, sólo enumerar lo que hay en este archivo". Suponga que ha archivado $/A en este archivo. Si usa –l simplemente le dirá que $/A está ahí. Si utiliza –la mostrará realmente todos los archivos y subproyectos de $/A. En general, -l sólo muestra los elementos que ha puesto explícitamente en el archivo; -la muestra todos los proyectos y archivos secundarios.

La opción -t es análoga a pkunzip -t. Dice: "no restaurar ahora este archivo, sólo decir si está dañado".

La opción -s se describe con detalle en Programa SSARC.EXE.

Las opciones –o e -i- son opciones estándar de VSS.

Como en SSARC, la opción -y le permite especificar la contraseña del administrador. Por ejemplo:

-yAdmin,Moggy


Programa Testlock

Vea también

Testlock.exe determina si su red acepta bloqueo nativo. Testlock.exe se instala de forma predeterminada en la subcarpeta específica de la plataforma (por ejemplo, WIN32).

El sistema de bloqueo se establece en el archivo SRCSAFE.INI. La variable primaria es Lock_Mode, que se puede establecer como Native o como Lockfile. El valor predeterminado es Native.

Para averiguar el sistema de bloqueo utilizado en su red:

  1. Instale VSS en una unidad que sea accesible desde dos o más equipos.

  2. Desde uno de los equipos, ejecute lo siguiente desde la carpeta WIN32:

    Testlock.exe <nombre de archivo>

    Testlock.exe bloquea un archivo y muestra el mensaje "Presione cualquier tecla para continuar". No presione aún una tecla; deje el programa en ejecución y vaya al paso 3.

    Si Testlock.exe falla y no muestra el mensaje, vaya a la carpeta especificada y elimine los archivos Testlock.* y vuelva a intentarlo. Asegúrese de no eliminar nada más.

  3. Desde otra máquina, ejecute Testlock.exe de nuevo, asignándole la misma ruta de carpeta que antes.

    Testlock.exe intenta bloquear los mismos registros que ha bloqueado el primer equipo e informa de los resultados. Si el bloqueo falla, el sistema de archivos de la red acepta el bloqueo nativo. Si el bloqueo se realiza correctamente, deberá utilizar el valor de la variable Lockfile.

  4. Presione una tecla en ambos equipos para terminar la ejecución del programa.

    Si se acepta el bloqueo nativo, repita los pasos 2 al 4 en varios equipos de la red, probando cada combinación de plataformas para asegurarse de que se aceptan las características necesarias en toda la red.

    Para ahorrar tiempo, puede dejar ejecutándose Testlock.exe en un equipo y repetir el paso 3 en el resto de los equipos. Después, cambie a un "primer" equipo diferente y repita el modelo, y así sucesivamente.


Programa Unlock

Vea también

Unlock.exe limpia los bloqueos huérfanos si especifica el bloqueo (del mensaje de error) en la línea de comandos.

VSS utiliza diversos mecanismos para implementar la mutua exclusión en la base de datos. (Esto no tiene nada que ver con la desprotección de archivos.) Si VSS se detiene inesperadamente (por ejemplo, debido a un fallo de la alimentación eléctrica), puede que deje activados algunos bloqueos de exclusión mutua. La próxima vez que VSS intente tener acceso a los registros protegidos, informará de un error.

Sintaxis

UNLOCK bloqueo

Bloqueo es el nombre del bloqueo mostrado en el mensaje de error "Superado el tiempo máximo de bloqueo".


Programa Updini

Vea también

Updini.exe convierte archivos .ini de VSS a la versión actual desde una versión anterior.

La configuración de VSS se almacena en una serie de archivos .ini. Lo utilizan principalmente las secuencias de comandos de instalación de forma que todos los archivos .ini tengan el formato apropiado después de una actualización de versión.

También puede resultar necesario este programa si movió los archivos .ini de la versión anterior de su ubicación predeterminada. Si instala VSS 3.1 o posterior, el programa de instalación ejecutará el programa Updini.exe para convertir los archivos .ini al nuevo formato. Si los archivos .ini están en sus ubicaciones predeterminadas, el programa de instalación los convertirá automáticamente. Sin embargo, si movió el archivo SS.INI, puede que el programa de instalación no encuentre el archivo. Será entonces responsabilidad suya ejecutar Updini.exe manualmente para actualizar el archivo SS.INI al terminar la instalación de VSS.

Sintaxis

UPDINI [-MSSruta]|[archivo.INI]

La tabla siguiente describe las opciones de línea de comandos disponibles con este comando.

Opciones | Descripción
-MSSruta | Si se especifica este parámetro en vez de un archivo .ini, Updini.exe buscará el archivo System.ini (el nombre antiguo de SRCSAFE.INI). Si encuentra System.ini, lo abre, busca todos los archivos .ini de usuario, actualiza el contenido de todos los archivos .ini y cambia el nombre del archivo System.ini por SRCSAFE.INI.
archivo.INI | Proporciona a Updini.exe el nombre de un archivo .ini para actualizar.


No se encuentra el tema

No se halló el tema correspondiente. A continuación enumeramos algunas posibles razones y sus soluciones:

  • El archivo (.chm) que contiene el tema de destino no se encuentra en la ubicación esperada.

    Solución: vuelva a ejecutar la instalación de la Biblioteca MSDN.

  • El archivo (.chm) que contiene el tema actual o el de destino no está actualizado y el vínculo ya no es válido.

    Solución: instale la última versión de la Biblioteca MSDN.

  • El CD de la Biblioteca MSDN no está en la unidad de CD-ROM.

    Solución: inserte el CD en la unidad.


Introducir comentarios en la línea de comandos

Vea también

Para introducir comentarios en la línea de comandos:

  1. En el símbolo del sistema, escriba ss comment "el nombreelemento.*"

  2. Cuando la línea de comandos le solicite un comentario, escriba el comentario y presiones INTRO.

    Nota Los comentarios no están limitados a una única línea, si llega al final de la línea y sigue escribiendo, VSS ajustará el comentario a la siguiente línea.

  3. Si quiere forzar un retorno de carro sin dar por terminado el comentario, escriba una barra invertida (\) y presione INTRO. La barra invertida no forma parte del comentario, pero el retorno de carro se incluirá en él y podrá seguir escribiendo.

    Nota Después de introducir un retorno de carro forzado, no podrá volver a las líneas anteriores utilizando la tecla borrar carácter.

Puede utilizar la opción de línea de comandos -C para muchos elementos o para uno solo. Esto le permitirá escribir un único comentario y aplicarlo a todos los archivos.


Utilizar comandos alternativos de la línea de comandos

Vea también

VSS proporciona dos métodos para personalizar VSS de forma que acepte una sintaxis alternativa en la línea de comandos en lugar de la sintaxis incluida en el comando VSS.

Puede definir comandos alternativos y colocarlos en los archivos de inicialización, en el apartado [Commands]. La sintaxis utiliza la forma Comando Alternativo= Comando de Visual SourceSafe. por ejemplo, un usuario de Microsoft Windows NT podría colocar las siguientes líneas en SS.INI.

[Commands]
Grep = Find
Ls = Dir

Puede escribir el comando alternativo en lugar del comando de VSS, con los mismos parámetros y resultados, VSS seguirá funcionando.

VSS también proporciona comandos alternativos incluidos en el código. La siguiente tabla muestra los comandos alternativos y sus equivalentes en VSS.

Alternativo | VSS
CD | CP
ChPro | CP
Copiar | Compartir y bifurcar
Quitar | Eliminar
Grep | Encontrar
LS | Directory
MD | Crear
MkPro | Crear
MP | Crear
Type | Ver
Undelete | Recover
++WhereIs | Locate
Scan | FindInFiles
Separate | Bifurcar
Uncheckout | UndoCheckout
Update | CheckIn


Utilizar códigos de salida de la línea de comandos

Vea también

Siempre que ejecute la línea de comandos VSS, configurar el código de salida para indicar su estado de ejecución. Puede utilizar esta variable del sistema operativo en los archivos de proceso por lotes, secuencias de comandos macros para reaccionar dependiendo de lo que haya sucedido al ejecutar VSS.

El código de salida se establece así:

Código | Descripción
100 | Algo ha ido mal. Por ejemplo, VSS no ha podido encontrar sus archivos de datos, o un archivo que quería desproteger ya está desprotegido.
1 | Indica un tipo de fallo más leve y se produce en tres circunstancias: Cuando se ejecuta ssDir y no se encuentra ningún elemento. Cuando se ejecuta ss Status y se desprotege al menos un elemento. Cuando ejecuta ss Diff y al menos uno de los elementos es diferente. Todas estas circunstancias indican que el siguiente comando VSS podría fallar, incluso aunque este comando se halla ejecutado correctamente.
0 | VSS se ha ejecutado correctamente.


¿Desea agregar este proyecto a <proyecto>?

Este mensaje tiene la siguiente causa y solución:

  • No agregó este proyecto al control de código fuente.

Haga clic en Sí para agregar este proyecto al control de código fuente. Haga clic en No para dejar este proyecto fuera del control de código fuente (por ejemplo, para depurar el código primero).


Otro usuario (<usuario>) ha situado esta base de datos bajo control de código fuente y es la única persona que debería trabajar con él

Este mensaje tiene la siguiente causa y solución:

  • Está intentando abrir una base de datos propiedad de otro usuario.

Usted no fue el último usuario en utilizar este archivo. Si continúa, sobrescribirá sus cambios y el estado de desprotección. Termine la sesión de VSS y obtenga su propia copia del archivo mediante el comando Crear <objeto> desde SourceSafe.


No ha agregado el archivo .acb al control de código fuente para tener una base de datos completa

Este mensaje tiene la siguiente causa y solución:

  • Agregó un proyecto Access pero no eligió agregar un archivo .ACB.

Vuelva a agregar el proyecto al control de código fuente e incluya el archivo .ACB.


Ya existe una base de datos con este nombre en el proyecto <proyecto> de control de código fuente. ¿Desea volver a conectarse a esta base de datos?

Este mensaje tiene la siguiente causa y solución:

  • Intentó agregar un proyecto, pero ya existe otro proyecto con ese nombre en el control de código fuente.

Haga clic en Sí para volver a conectarse al proyecto existente o haga clic en No si el proyecto del control de código fuente es un proyecto distinto pero con el mismo nombre. Después, elija otro nombre para el nuevo proyecto.


No se pudo crear un nombre válido de archivo para <archivo>

Este mensaje tiene la siguiente causa y solución:

  • Sólo puede agregar módulos a VSS si el nombre del módulo es un nombre de archivo válido. El nombre de archivo que ha elegido no es válido.

Cambie el nombre de su objeto a un nombre de archivo válido.

Si escribe mal el nombre de archivo, inténtelo de nuevo con un nombre de archivo válido. Si cree que el nombre de archivo es válido y está trabajando en un entorno de sistemas operativos mixtos, el problema puede estar en que el nombre de archivo que ha elegido no se traduce correctamente a uno de los demás entornos de sistemas operativos conectados a su base de datos de VSS. En este caso, pruebe con otro nombre de archivo.


Fallo al agregar el archivo<archivo> al control de código fuente

Este mensaje tiene la siguiente causa y solución:

  • Ya existe un archivo con el nombre seleccionado en el proyecto de control de código fuente.

Puede guardar su archivo nuevo con otro nombre o aceptar el archivo que ya existe en el control de código fuente (sobreescribiendo cualquier cambio).


No se pudieron agregar archivos a <proyecto>

Este mensaje tiene la siguiente causa y solución:

  • VSS no pudo guardar los archivos que desea agregar y contienen cambios sin guardar.

La operación de VSS puede haber fallado, puede no tener derechos para este proyecto o puede que no haya memoria disponible. Guarde los archivos manualmente e inténtelo de nuevo. Si esto falla, compruebe su conexión con VSS e inténtelo de nuevo.


¿Desea agregar este proyecto a <proyecto>?

Este mensaje tiene la siguiente causa y solución:

  • Creó un nuevo proyecto o abrió un proyecto que no estaba bajo el control de código fuente.

Elija Sí para agregar el proyecto o elija No para cancelar la operación.


No se pueden agregar los archivos de soporte necesarios al control de código fuente; la operación de protección ha fallado

Este mensaje tiene la siguiente causa y solución:

  • Intentó una operación Agregar pero falló cuando VSS intentó agregar archivos de proyecto de soporte (por ejemplo, el archivo de formulario .frx).

Agregue cada archivo por separado al control de código fuente.


No se pudo crear un nuevo proyecto basado en el proyecto <proveedor de control de código fuente>

Este mensaje tiene la siguiente causa y solución:

  • Se encontró con un error interno mientras intentaba crear una carpeta nueva.

Salga y vuelva a iniciar Microsoft Access y VSS, si se está ejecutando.


No se han podido establecer todas las opciones correctamente

Este mensaje tiene la siguiente causa y solución:

  • Se encontró con un error al escribir en el Registro del sistema.

Asegúrese de que tiene suficiente espacio en su unidad para poder guardar los cambios en el Registro del sistema.


No se puede tener acceso al archivo <archivo>

Este mensaje tiene la siguiente causa y solución:

  • El proveedor de control de código fuente no pudo crear un archivo temporal en el que se pueda escribir.

Compruebe los permisos de escritura y lectura de sus archivos y directorios, compruebe el espacio de su disco y asegúrese de que la base de datos está en una unidad en la que tiene permiso de escritura.


No se puede usar el proyecto de control de código fuente seleccionado

Este mensaje tiene la siguiente causa y solución:

  • Al agregar un proyecto principal al control de código fuente, debe seleccionar un proyecto de control de código fuente en el que colocará los archivos. El proveedor de control de código fuente comprueba el proyecto de control de código fuente para asegurarse de que se puede llevar a cabo la operación. Si se encuentra un problema, se produce este error.

Siga las reglas impuestas por el proveedor de control de código fuente acerca de proyectos compatibles con el comando Agregar.


No se pudo crear una carpeta de trabajo para este proyecto

Este mensaje tiene la siguiente causa y solución:

  • La carpeta de trabajo que ha especificado no se pudo crear.

Debe tener permisos para crear una carpeta en el equipo que especifique, la unidad de disco puede estar llena o el nombre que he elegido puede estar ya en uso. Inténtelo de nuevo especificando otro nombre.


No se puede inicializar la aplicación principal de control de código fuente

Este mensaje tiene la siguiente causa y solución:

  • El proveedor de control de código fuente no puede conectarse correctamente con el host del entorno de desarrollo.

Ejecute de nuevo el programa de instalación para elegir su host de entorno de desarrollo y el proveedor de control de código fuente.


No se ha podido inicializar el proveedor de control de código fuente

Este mensaje tiene la siguiente causa y solución:

  • El proveedor de control de código fuente no puede conectarse correctamente con el host del entorno de desarrollo.

Ejecute de nuevo el programa de instalación para elegir su proveedor de código fuente.


El proveedor de control de código fuente no se inicializó correctamente

Este mensaje tiene la siguiente causa y solución:

  • El proveedor de control de código fuente se cargó pero no se pudo iniciar.

Ejecute de nuevo el programa de instalación de su proveedor de control de código fuente.


<objeto> ya está desprotegido en algún lugar; no puede cambiar el nombre ahora

Este mensaje tiene la siguiente causa y solución:

  • Está intentando cambiar el nombre de un archivo que actualmente está desprotegido.

Puede esperar a que el otro usuario proteja el archivo o ponerse en contacto con su administrador de VSS para deshacer la desprotección del usuario (lo que sobreescribirá los cambios del otro usuario).


No se pudo actualizar la información de ubicación del proyecto en la aplicación principal

Este mensaje tiene la siguiente causa y solución:

  • Otra aplicación está usando el archivo .mdb.

Asegúrese de que ninguna otra aplicación está usando la base de datos (asegúrese de comprobar el uso a través de programación mediante DAO).


La operación proteger ha fallado

Este mensaje tiene la siguiente causa y solución:

  • No guardó los objetos que se podrían perder si realiza esta operación.

Guarde todos los objetos de su proyecto en un archivo e inténtelo otra vez.


La operación desproteger ha fallado

Este mensaje tiene la siguiente causa y solución:

  • No guardó los objetos que se podrían perder si realiza esta operación.

Guarde todos los objetos de su proyecto en un archivo e inténtelo otra vez.


No se pueden mostrar las diferencias

Este mensaje tiene la siguiente causa y solución:

  • Se encontró con un error interno mientras intentaba comprobar diferencias entre objetos.

Salga y vuelva a iniciar Microsoft Access y VSS, si se está ejecutando.


Otro usuario (<usuario>) ha situado este proyecto bajo control de código fuente y es la única persona que debería trabajar con él

Este mensaje tiene la siguiente causa y solución:

  • Otro usuario tiene esta base de datos bajo control de código fuente y usted la abrió. Sobreescribirá todos los cambios del otro usuario a menos que salga inmediatamente. Si el otro usuario tenía algo desprotegido, sus cambios se perderán la próxima vez que use el comando Obtener.

Salga de inmediato o sacrifique los cambios del otro usuario.


<proveedor de control de código fuente> no se desconectó correctamente

Este mensaje tiene la siguiente causa y solución:

  • El proveedor de control de código fuente no se desconectó de su proyecto.

Salga y vuelva a iniciar Microsoft Access para eliminar este error.


Error al abrir el archivo <archivo> para comprobar los cambios

Este mensaje tiene la siguiente causa y solución:

  • Se encontró con un error interno de control de código fuente.

Salga y vuelva a iniciar VSS. Si esto no resuelve el problema, vuelva a instalar VSS y reinicie su equipo. Si esto no resuelve el problema, compruebe que tiene memoria y espacio en disco suficientes, compruebe el espacio en disco del servidor y compruebe la conexión de red con su equipo.


Error al leer el archivo <archivo> para comprobar los cambios

Este mensaje tiene la siguiente causa y solución:

  • Se encontró con un error interno de control de código fuente.

Salga y vuelva a iniciar VSS. Si esto no resuelve el problema, vuelva a instalar VSS y reinicie su equipo. Si esto no resuelve el problema, compruebe que tiene memoria y espacio en disco suficientes, compruebe el espacio en disco del servidor y compruebe la conexión de red con su equipo.


El archivo <archivo> ya existe en el proyecto de control de código fuente, pero su copia local es diferente

Este mensaje tiene la siguiente causa y solución:

  • Intentó agregar un archivo a su proyecto cuando ya existe un archivo con ese nombre en su proyecto. El archivo no se agregó y su copia local no se cambió.

Elija otro nombre diferente para el archivo que desea agregar.


La operación obtener ha fallado

Este mensaje tiene la siguiente causa y solución:

  • No guardó los objetos que se podrían perder si realiza esta operación.

Guarde todos los objetos de su proyecto en un archivo e inténtelo otra vez.


La operación de historial ha fallado

Este mensaje tiene la siguiente causa y solución:

  • No guardó los objetos que se podrían perder si realiza esta operación.

Guarde todos los objetos de su proyecto en un archivo e inténtelo otra vez.


No se puede volver a cargar el archivo en el IDE principal

Este mensaje tiene la siguiente causa y solución:

  • Normalmente está provocado por un error interno de SourceSafe.

Cierre el proyecto y vuelva a abrirlo.


No ha agregado suficientes archivos al control de código fuente para tener un proyecto completo

Este mensaje tiene la siguiente causa y solución:

  • Intentó agregar algunos archivos al control de código fuente, pero no hay suficientes para definir completamente un proyecto. Este proyecto no se ha conectado con el control de código fuente.

VSS necesita mantener todos los archivos del proyecto. Agregue el grupo completo al proyecto de VSS.


No se pudo inicializar el proyecto actual. Salga y vuelva a cargar este proyecto

Este mensaje tiene la siguiente causa y solución:

  • Normalmente está provocado por un error interno de VSS.

Salga y vuelva a cargar el proyecto. Si esto no resuelve el problema, salga y vuelva a cargar su entorno de aplicación. Si el problema persiste, reinicie su equipo.


No se puede usar el nuevo nombre ya que no es un nombre de archivo válido

Este mensaje tiene la siguiente causa y solución:

  • Está intentando cambiar el nombre de un archivo o un objeto y el nuevo nombre no es un nombre de archivo válido (normalmente porque contiene caracteres no válidos).

Elija otro nombre diferente para el archivo o el objeto.


Error al intentar la conexión con el proyecto <proyecto>

Este mensaje tiene la siguiente causa y solución:

  • El proveedor de control de código fuente no pudo inicializar el proyecto de control de código fuente.

Salga del entorno de desarrollo y vuelva a iniciarlo. Si esto no elimina el error, vuelva a ejecutar el programa de instalación del proveedor de control de código fuente. Compruebe los recursos del sistema, especialmente la memoria y el espacio en disco.


Memoria insuficiente; no se puede terminar la operación

Este mensaje tiene la siguiente causa y solución:

  • Su equipo no tiene suficiente memoria.

Cierre las aplicaciones que no esté utilizando. Si el problema persiste, reinicie su equipo.


No se puede usar el nuevo nombre porque ya existe un objeto con ese nombre en <proveedor>

Este mensaje tiene la siguiente causa y solución:

  • Está intentando cambiar el nombre de un archivo o un objeto y el nuevo nombre es el nombre de un objeto o un archivo que ya existe en el control de código fuente.

Elija otro nombre diferente para el archivo o el objeto, o cambie el nombre o elimine el objeto existente que tiene el nombre deseado.


Ya se han agregado todos los archivos disponibles al control de código fuente

Este error tiene la siguiente causa y solución:

  • Todos los archivos del proyecto de desarrollo actual ya se han agregado al control de código fuente.

    Si desea proteger un archivo que no está todavía en el proyecto de desarrollo, agregue primero el archivo al proyecto de desarrollo. VSS le pedirá que lo agregue al control de código fuente.


No hay archivos disponibles para desproteger desde el control de código fuente

Este error tiene la siguiente causa y solución:

  • No hay ningún archivo desprotegido en el proyecto actual de VSS.

    Para desproteger un archivo que todavía no se ha agregado al control de código fuente, utilice el comando Agregar archivo para agregar archivos. Si el archivo ya está en el proyecto, asegúrese de que no esté desprotegido.

    Este error se produce a veces si alguien elimina el archivo con el que desea trabajar (o elimina todo el proyecto); asegúrese de que el proyecto sigue existiendo.


No hay archivos disponibles para obtener desde el control de código fuente

Este mensaje tiene la siguiente causa y solución:

  • Eligió el comando Obtener, pero después de una cuidadosa comprobación, no había ningún archivo para la operación.

Este error se produce a veces si alguien elimina el archivo con el que desea trabajar (o elimina todo el proyecto); asegúrese de que el proyecto sigue existiendo. A continuación, asegúrese de que tiene algún archivo desprotegido.


Como no ha iniciado sesión en <proveedor de control de código fuente>, las características de control de código fuente no están habilitadas para este proyecto

Este mensaje tiene la siguiente causa y solución:

  • No inició la sesión en el proveedor de control de código fuente.

Vuelva a abrir su proyecto e inicie su sesión en el proveedor de control de código fuente para usar las características de control de código fuente.


No se pudo desproteger el archivo <archivo> porque ya está desprotegido

Este mensaje tiene la siguiente causa y solución:

  • El archivo que eligió ya está desprotegido.

Los archivos almacenados en formato binario no los puede desproteger más de una persona a la vez, porque VSS no podría combinar los cambios realizados por múltiples usuarios.


No tiene archivos desprotegidos desde el control de código fuente

Este mensaje tiene la siguiente causa y solución:

  • Eligió el comando Agregar, Desproteger, Proteger o Deshacer desprotección, pero después de una cuidadosa comprobación, no había ningún archivo disponible para la operación.

Este error se produce a veces si alguien elimina el archivo con el que desea trabajar (o elimina todo el proyecto); asegúrese de que el proyecto sigue existiendo. A continuación, asegúrese de que tiene algún archivo desprotegido.


No tiene un programa de control de código fuente (como Microsoft Visual SourceSafe) instalado en su equipo

Este mensaje tiene la siguiente causa y solución:

  • No agregó ningún programa de control de código fuente a su equipo.

Por tanto, los comandos de control de código fuente no están disponibles. Haga clic en Sí para mostrar esta advertencia la próxima vez que intente utilizar comandos de control de código fuente o haga clic en No para desactivar este mensaje de advertencia.

Para los usuarios de VSS, ejecute NETSETUP.EXE desde la carpeta de SourceSafe para obtener capacidades de control de código fuente. Para otros proveedores de control de código fuente, vuelva a ejecutar el programa de instalación de su proveedor.


<proveedor de control de código fuente> no es compatible con esta operación

Este mensaje tiene la siguiente causa y solución:

  • Su proveedor de control de código fuente no es compatible con el elemento de menú que eligió.

Póngase en contacto con su proveedor de control de código fuente o compre Microsoft Visual SourceSafe.


No se puede cargar el proveedor de control de código fuente; necesita una versión más reciente

Este mensaje tiene la siguiente causa y solución:

  • Está usando una versión del proveedor de control de código fuente anterior a la versión admitida.

Vuelva la última versión del proveedor de control de código fuente.


El archivo <archivo> ya no está bajo control de código fuente; falló la operación

Este mensaje tiene la siguiente causa y solución:

  • Algún usuario eliminó un archivo de la base de datos de VSS durante la sesión y usted intentó utilizar un menú contextual para obtenerlo.

Vuelva a agregar el archivo al control de código fuente, compruebe quién lo eliminó y por qué, etc.


Error al volver a cargar el proyecto

Este mensaje tiene la siguiente causa y solución:

  • Se produjo un error interno en la aplicación.

Cierre este proyecto desde el menú Archivo y vuelva a abrirlo para obtener la versión correcta de todos los archivos cargados en memoria.


En el proyecto de control de código de fuente <proyecto> ya existe un proyecto con este nombre

Este mensaje tiene la siguiente causa y solución:

  • Intentó agregar una base de datos al control de código fuente en un proyecto existente.

Elija Sí para volverse a conectar al proyecto existente o elija No para cancelar esta operación.


El proyecto <proyecto> ya no está bajo control de código fuente. Debe recuperar o volver a crear el proyecto antes de que pueda usar este proyecto con control de código fuente

Este mensaje tiene la siguiente causa y solución:

  • Otro usuario eliminó (o movió) su proyecto.

Haga clic Aceptar si desea intentar encontrar el proyecto. Si el proyecto se eliminó, haga clic en Cancelar. Al hacer clic en Cancelar, la base de datos se dará de baja del control de código fuente y podrá volver a agregar el proyecto al control de código fuente (pero perderá cualquier información histórica acerca de este proyecto).

Si puede averiguar quién eliminó o movió su proyecto, es posible que pueda recuperar el proyecto y su historial (por ejemplo, si su administrador de control de código fuente ha archivado su proyecto en una copia de seguridad en cinta).


El proyecto se llamó <nombre> pero se ha movido, copiado o cambiado de nombre

Este mensaje tiene la siguiente causa y solución:

  • Una vez que ha situado una base de datos de Access bajo el control de código fuente, no está permitido cambiar su nombre, moverla a otra carpeta o trabajar con copias de ellas. Cuando abra una base de datos que esté bajo el control de código fuente y se haya movido, cambiado de nombre o copiado, se presentará este mensaje y se deshabilitarán todas las funciones del control de código fuente para esta base de datos.

No trabaje con una copia de la base de datos de Access que esté bajo el control de código fuente. Utilice el comando Crear base de datos del SCC para crear una nueva base de datos en la ubicación que desee.

Si la base de datos se ha movido, devuélvala a su ubicación original y vuelva a abrirla. Las funciones de control de código fuente volverán a funcionar. De la misma forma, si la base de datos se cambió de nombre, restaure su nombre original.


No se pueden mostrar las propiedades

Este mensaje tiene la siguiente causa y solución:

  • Se encontró con un error interno mientras intentaba ver las propiedades.

Salga y vuelva a iniciar Microsoft Access y VSS, si se está ejecutando.


No se ha quitado el elemento del proyecto <proveedor>

Este mensaje tiene la siguiente causa y solución:

  • Normalmente está provocado por un error interno de VSS.

Quite cada archivo por separado del control de código fuente.


Ha creado un nuevo proyecto con un nombre diferente. El nuevo proyecto ya no está asociado al control de código fuente

Este mensaje tiene la siguiente causa y solución:

  • Cambió el nombre de un proyecto y éste ya no está disponible en el control de código fuente.

Agregue el nuevo proyecto al control de código fuente, si lo desea.


No se ha cambiado el nombre al elemento en el proyecto <proveedor>

Este mensaje tiene la siguiente causa y solución:

  • Normalmente está provocado por un error interno de VSS.

Cambie el nombre de cada archivo por separado del control de código fuente.


Un archivo de etiqueta que se cambió de nombre no puede cambiarse de nombre automáticamente en el control de código fuente

Este mensaje tiene la siguiente causa y solución:

  • Normalmente está provocado por un error interno de VSS.

Cambie manualmente el nombre del archivo de etiqueta.


<archivo> no tiene un nombre de archivo válido. Debe tener un nombre de archivo válido para poder agregarlo al control de código fuente

Este mensaje tiene la siguiente causa y solución:

  • Aunque el nombre de este objeto es válido para la aplicación principal, no es un nombre válido para el sistema de archivos (contiene caracteres no permitidos).

Cambie el nombre del objeto y agréguelo al control de código fuente.


No se pudo guardar algunos archivos. El proyecto no se agregó a <proveedor>

Este mensaje tiene la siguiente causa y solución:

  • Está agregando un proyecto al control de código fuente sin guardar los cambios.

SourceSafe no pudo guardar alguno de sus cambios. Quizá no tenga permiso de escritura en algunos archivos o puede que haya un error de red.


La operación falló porque algunos archivos no se guardaron. Guarde su proyecto y vuelva a intentarlo

Este mensaje tiene la siguiente causa y solución:

  • No se pudo guardar en disco algunos archivos.

Asegúrese de que tiene permiso y espacio para guardar los archivos en el disco de destino Intente guardar los archivos manualmente y vuelva a intentar la operación.


No se pudo cerrar correctamente el proyecto en <proveedor de control de código fuente>

Este mensaje tiene la siguiente causa y solución:

  • El proveedor de control de código fuente no pudo cerrar el proyecto de control de código fuente.

Normalmente, si sale y vuelve a iniciar Microsoft Access eliminará este error.


La operación de uso compartido ha fallado

Este mensaje tiene la siguiente causa y solución:

  • Intentó compartir un archivo que tiene la misma propiedad de nombre que otro del proyecto de destino.

Existen varias causas posibles que producen este mensaje. Una causa es que si no ha asignado la propiedad de nombre en uno de sus archivo podrían producirse conflictos con un archivo del proyecto de destino (donde la propiedad de nombre tampoco está asignada o es la misma). En este caso, asigne la propiedad de nombre del archivo a su proyecto actual y después inténtelo de nuevo.

Otras posibilidades son que el archivo de proyecto está desprotegido por alguien o que no es capaz de desproteger el archivo de proyecto. Compruebe el estado de desprotección del archivo para determinar si es éste el caso. Si no, podría haber ocurrido un error interno de VSS.


La operación de uso compartido ha finalizado, pero no se pueden agregar los archivos al proyecto actual

Este mensaje tiene la siguiente causa y solución:

  • La operación de compartir se ha realizado con éxito, pero ha fallado al intentar agregar el archivo al proyecto.

Compruebe que la propiedad de nombre del archivo no causa conflicto con la propiedad de nombre de un formulario, módulo, módulo de clase u otro archivo de Visual Basic existente.


Sólo puede haber un proyecto bajo el control de código fuente a la vez con este proveedor de control de código fuente

Este mensaje tiene la siguiente causa y solución:

  • Algunos proveedores de control de código fuente sólo pueden tratar un proyecto a la vez.

Póngase en contacto con el fabricante para obtener una versión actualizada del proveedor de control de código fuente. Seleccione un proveedor de código fuente más avanzado o no utilice múltiples proyectos.


La operación deshacer desprotección ha fallado

Este mensaje tiene la siguiente causa y solución:

  • No guardó los objetos que se podrían perder si realiza esta operación.

Guarde todos los objetos de su proyecto en un archivo e inténtelo otra vez.


Puede que <archivo> haya cambiado. ¿Desea deshacer la desprotección y perder los cambios?

Este mensaje tiene la siguiente causa y solución:

  • El mensaje de confirmación le pregunta si desea continuar con el comando Deshacer desprotección aunque pueda perder los cambios que haya realizado en su archivo local.

Haga clic en Sí para deshacer las desprotección o en No para cancelar la operación.


No se pudo conectar Visual Basic con el control de código fuente. Compruebe la instalación del complemento del control de código fuente

Este mensaje tiene la siguiente causa y solución:

  • VSS no pudo conectarse correctamente con su host de desarrollo.

Vuelva a ejecutar el programa de instalación de VSS.


Esta operación requiere desproteger primero el archivo de proyecto de Visual Basic. ¿Desea desproteger el archivo de proyecto de Visual Basic?

Este mensaje tiene la siguiente causa y solución:

  • Necesita desproteger el archivo de proyecto de Visual Basic antes de que pueda realizar cambios en él.

Debe desproteger el archivo de proyecto y después realizar sus cambios.


El proveedor de control de código fuente no se pudo conectar

Falló un método de automatización OLE de Visual Basic. Este error tiene la siguiente causa y solución:

  • Se ha producido un error interno de OLE, Visual Basic o del proveedor de control de código fuente.

    Vuelva a instalar el proveedor de control de código fuente.


El complemento de control de código fuente no se desconectó de Visual Basic

Este error tiene la solución siguiente:

  • Cierre Visual Basic y vuélvalo a abrir; lo más probable es que sea un error interno temporal.


Puede compartir otro archivo de proyecto en este proyecto de control de código fuente, pero el archivo de proyecto no se ha agregado al proyecto de VB

Este error tiene la siguiente causa y solución:

  • Intentó compartir un archivo de proyecto de otro proyecto en el actual, pero no agregó el archivo de proyecto en VSS.

Agregue primero el archivo de proyecto al propio proyecto.


El archivo <archivo> ya existe en el proyecto de control de código fuente, pero su copia local es diferente

Usted (u otro usuario) agregó el proyecto al proveedor de control de código fuente. Sin embargo, cuando intentó agregar archivos al proyecto, había en el proyecto un archivo diferente con el mismo nombre. Debe utilizar el comando de diferencias del proveedor de control de código fuente para averiguar las diferencias y proteger la versión adecuada.

En vez de utilizar el comando Agregar proyecto, debe obtener el proyecto entero en su unidad local y desproteger los archivos que necesite. Con este método podría volver a tener sincronizado el proyecto, pero perdería las modificaciones locales que hubiera realizado en los archivos del proyecto.


No ha agregado el archivo de proyecto al control de código fuente. Este proyecto no se ha conectado con el control de código fuente

Este error tiene la siguiente causa y solución:

  • Agregó un nuevo proyecto al control de código fuente, pero no incluyó el archivo de proyecto.

Vuelva a agregar el proyecto e incluya el archivo de proyecto.


La copia del archivo de proyecto de Visual Basic que está en la base de datos de control de versiones ha cambiado; ya no podrá guardar sus cambios actuales. Debe desproteger el archivo de proyecto y volver a realizar los cambios

Este mensaje tiene la siguiente causa y solución:

  • Es una advertencia que le avisa que otro usuario ha cambiado el archivo de proyecto mientras usted estaba trabajando.

Desproteja la nueva versión del archivo de proyecto y vuelva a realizar sus cambios.


Ha elegido no desproteger el archivo de proyecto de Visual Basic; se perderán todos los cambios realizados durante esta sesión

Este mensaje tiene la siguiente causa y solución:

  • Es una advertencia que le avisa que si no desprotege el archivo de proyecto, cualquier cambio realizado durante esta sesión no se guardará en el control de código fuente.

Desproteja el archivo de proyecto si quiere que se guarden sus cambios.


Ha intentado cambiar el archivo de proyecto de Visual Basic sin desprotegerlo primero

Este mensaje tiene la siguiente causa y solución:

  • Necesita desproteger el archivo de proyecto de Visual Basic antes de que pueda realizar cambios en él.

Debe desproteger el archivo de proyecto y después realizar sus cambios.


No hay un archivo de proyecto asociado con este proyecto; no se puede crear un proyecto de Visual Basic desde el proyecto <proyecto>

Este mensaje tiene la siguiente causa y solución:

  • Intentó crear un proyecto de Visual Basic desde el control de código pero especificó un proyecto no válido.

Compruebe el nombre del proyecto e inténtelo de nuevo.


Algunos archivos no tienen nombres todavía

Este error tiene la siguiente causa y solución:

  • No ha asignado nombre a todos sus archivos.

Asigne nombre a sus archivos mediante el comando Guardar archivo de Visual Basic antes de continuar con la operación.


Ya existe un proyecto de VB con este nombre en el proyecto <proyecto> de control de código fuente. ¿Desea volver a conectar este proyecto de VB con el proyecto de control de código fuente existente?

Este error tiene la siguiente causa y solución:

  • Intentó agregar un proyecto, pero ya existe otro proyecto con ese nombre en el control de código fuente.

Haga clic en Sí para volver a conectarse al proyecto existente o haga clic en No si el proyecto del control de código fuente es un proyecto distinto pero con el mismo nombre. Después, elija otro nombre para el nuevo proyecto.


¿Desea desproteger el archivo <archivo>?

Este error tiene la siguiente causa y solución:

  • Intentó modificar al archivo de Visual Basic <archivo>, sin haberlo desprotegido.

Haga clic en Sí para desproteger el archivo o en No para cancelar esta operación.


El proyecto <proyecto> que ha seleccionado no contiene este proyecto de Visual Basic

Este mensaje tiene la siguiente causa y solución:

  • Esta advertencia le informa de que mientras intentaba explorar un proyecto eliminado eligió el proyecto erróneo.

Vuelva a intentar la operación de exploración.


¿Desea agregar los nuevos archivos al proyecto actual de control de código fuente?

Este mensaje tiene la siguiente causa y solución:

  • Está agregando, directa o indirectamente mediante un asistente u otra herramienta, varios archivos al control de código fuente.

Haga clic en Sí para agregar los archivos o en No para cancelar la operación.


¿Desea proteger todos los archivos que ha desprotegido en el proyecto <proyecto>?

Este mensaje tiene la siguiente causa y solución:

  • Está cerrando el entorno de programación dejando archivos desprotegidos.

Al cerrar su entorno de programación, VSS le recuerda que tiene archivos del proyecto desprotegidos y le pregunta si desea protegerlos. No es necesario protegerlos, pero si los deja desprotegidos otros usuarios no podrán desprotegerlos.


¿Desea obtener la última versión de todos los archivos del proyecto <proyecto>?

Este mensaje tiene la siguiente causa y solución:

  • Esta consulta le pregunta si desea obtener las últimas versiones de todos los archivos que están en la carpeta de trabajo de su proyecto.

Elija Sí para obtener las últimas versiones de todos los archivos del proyecto. Elija No para cancelar. Puede utilizar el comando Opciones para desactivar este mensaje de consulta.


¿Desea quitar el archivo <archivo> del control de código fuente?

Este mensaje tiene la siguiente causa y solución:

  • Quitó un objeto del proyecto de desarrollo.

Haga clic en Sí para quitar también el objeto del control de código fuente o haga clic en No para dejar el objeto en el proyecto de control de código fuente.


El proyecto <proyecto> que ha seleccionado no contiene este proyecto IDE

Este mensaje tiene la siguiente causa y solución:

  • Esta advertencia le informa de que mientras intentaba explorar un proyecto eliminado eligió el proyecto erróneo.

Vuelva a intentar la operación de exploración.


No hay ninguna aplicación asociada con este tipo de archivo

Este mensaje tiene la siguiente causa y solución:

  • Intentó ver un archivo para el que no existe ninguna asociación de archivo. Sin esta asociación, VSS no sabe qué editor debe utilizar para mostrar dicho archivo.

    Use el Administrador de archivos para asignar una asociación a este archivo e intente ejecutar el comando otra vez.

    Si desea invalidar la asociación del Administrador de archivos para un determinado tipo de archivos, puede especificar determinadas asociaciones en el archivo SS.INI; por ejemplo:

    .C = C:\VC\VC.EXE
.FRM = C:\WINDOWS\NOTEPAD.EXE


Hay demasiados controladores de archivo abiertos

Este mensaje tiene la siguiente causa y solución:

  • Hay demasiados archivos abiertos en el sistema.

    Cerrar algunos archivos abiertos.


Este comando actúa sobre un único elemento

En muchas listas de los cuadros de diálogo de VSS, puede seleccionar más de un elemento a la vez, y después actuar sobre todos los elementos de una sola vez. Sin embargo, algunas acciones no pueden actuar sobre más de un elemento a la vez.

Esta advertencia tiene la siguiente causa y solución:

  • Seleccionó más de un elemento y aplicó un comando que sólo actúa sobre un elemento a la vez. Por ejemplo, puede que intentara utilizar el comando Ver, que sólo funciona con un archivo a la vez.

    Presione la barra espaciadora sobre un elemento para convertirlo en el único elemento seleccionado de la lista.


<cadena> contiene un carácter no válido

Este error tiene la siguiente causa y solución:

  • El valor de la ruta de datos en el cuadro de diálogo Conectarse a VSS contiene un carácter no válido.

Los nombres de ruta de datos no deben contener los caracteres ( )[ ] ni caracteres en blanco.


El archivo srcsafe.ini no está en la carpeta <carpeta>

Este error tiene la siguiente causa y solución:

  • Eligió una ruta de acceso en el cuadro de diálogo Conectarse a VSS que no contiene un archivo SRCSAFE.INI.

Necesita elegir la carpeta en la que exista la información de su base de datos. Normalmente suele estar en el servidor donde está instalado SourceSafe.


Ya existe un vínculo eliminado a <archivo>

Vea también

Un archivo eliminado permanece como parte de un proyecto, pero no aparece en la lista de archivos. Este mensaje tiene la siguiente causa y solución:

  • Está intentando compartir un archivo desde otro proyecto con el proyecto actual. Sin embargo, el archivo ya existe en el proyecto actual. No aparece en la lista de archivos porque se ha eliminado.

    Para que el archivo aparezca en la lista de archivos, no lo comparta desde otro proyecto; mejor recupérelo en este proyecto mediante el botón Recuperar de la ficha Elementos eliminados del cuadro de diálogo Propiedades del menú Archivo.


Hay una versión más reciente desprotegida

Actualmente existe una versión más reciente del archivo que está desprotegida.


El archivo <archivo> ya está desprotegido por <usuario>. ¿Desea continuar?

Vea también

Esta advertencia tiene la siguiente causa y solución:

  • Ha intentado realizar una operación en un archivo VSS que está desprotegido pro otro usuario.

    VSS le ofrece la posibilidad de continuar, lo que implica que cualquier diferencia entre los cambios que realice y los cambios que realicen otros usuarios necesitarán combinarse en el futuro. Haga clic en Sí para seguir adelante y crear una situación de desprotecciones múltiples, haga clic en No para cancelar la acción de desprotección.


El usuario <usuario> ya existe

Este mensaje tiene la siguiente causa y solución:

  • Intentó agregar un usuario con un nombre de usuario que ya existe. Puede seleccionar otro nombre; por ejemplo, si ya existe Juan, agregue JuanG.

    Observe que los nombres no distinguen entre mayúsculas y minúsculas, por lo que si ya existe Juan, agregar JUAN genera este error.


Error interno: salga y vuelva a iniciar Visual Basic

Este error tiene la siguiente causa y solución:

  • Ha ocurrido un error interno en Visual Basic o en VSS.

Guarde su trabajo, salga de Visual Basic y de VSS, y reinicie ambos programas si todavía necesita usarlos.


Error al agregar. Los archivos no se agregaron al control de código fuente

Este error tiene la solución siguiente:

  • Abra la aplicación del proveedor de control de código fuente y agregue los archivos al proyecto manualmente.


No se puede agregar el proyecto nuevo al control de código fuente

Este error tiene la siguiente causa y solución:

  • No tiene suficientes derechos de acceso al proveedor de control de código fuente.

    Pida al administrador del control de código fuente que incremente sus derechos de acceso y vuélvalo a intentar o intente agregar el proyecto en otra parte del árbol de proyectos.

    Conéctese de nuevo a VSS con la contraseña apropiada.

    (Si ha obtenido otros errores procedentes de éste, revise sus causas para obtener más causas posibles.)


No se pudo agregar al proyecto de control de versiones todos los archivos solicitados

Este error tiene la causa siguiente:

  • Mientras se agregaba archivos al proveedor de control de código fuente, no se reemplazaron correctamente todos los archivos.

    Compruebe la ventana Resultados para obtener otras condiciones de error. Si las encuentra, corríjalas y vuelva a intentar la operación.


¿Desea agregar este proyecto al control de código fuente?

En la mayoría de los casos, haga clic en Sí para mantener sincronizados los proyectos de Visual Basic y del control de código fuente. Puede hacer clic en No si está probando un archivo que desea agregar más tarde o un archivo que no desea agregar.

Haga clic en Sí para agregar el archivo al control de código fuente.

Haga clic en No para agregar el archivo al proyecto de Visual Basic sin agregarlo al proyecto de control de código fuente.


El proyecto no está bajo el control de código fuente

Este error tiene la siguiente causa y solución:

  • VSS determinó que el proyecto actual no está almacenado en la base de datos de VSS.

    Si desea agregar ahora este proyecto al control de código fuente, guarde el proyecto y haga clic en Agregar proyecto en el menú del proveedor de control de código fuente.


El archivo <archivo> ya no está conectado a este proyecto de control de código fuente

Este error tiene la siguiente causa y solución:

  • Ha seleccionado un archivo que ya no está incluido en el control de código fuente de este proyecto.

Posiblemente el archivo se ha eliminado del proveedor de control de código fuente o se ha movido a otro proyecto. Use el comando Agregar archivos para agregarlo al control de código fuente de su proyecto o busque en la base de datos del control de código fuente para ver si el archivo forma parte de otro proyecto.


Falló el comando Abrir proyecto del proveedor del control de código fuente

Este error tiene la solución siguiente:

  • Abra la aplicación del proveedor de control de código fuente y obtenga el proyecto manualmente. Abra después el proyecto en Visual Basic.


No hay ningún archivo de proyecto de Visual Basic que corresponda a este proyecto de control de código fuente

Este error tiene la siguiente causa y solución:

  • El proveedor de control de código fuente no puede encontrar el archivo de proyecto de Visual Basic (archivo .VBP o .MAK). Se requiere un archivo de proyecto porque guarda la lista de archivos incluidos en el proyecto y el proveedor de control de código fuente utiliza la lista para hacer un seguimiento del estado del archivo.


No se pudo agregar el archivo <archivo> al proyecto de Visual Basic

Este error tiene la siguiente causa y solución:

  • No se pudo agregar el archivo a Visual Basic.

    Inténtelo con otro archivo.


No se puede agregar el archivo .FRX al control de código fuente

Este error tiene la siguiente causa y solución:

  • Se generó automáticamente un archivo .FRX para contener los recursos del archivo .FRM, pero no se pudo agregar el archivo .FRX al control de código fuente.

    Agregue manualmente el archivo.


El proveedor de control de código fuente no pudo conectarse con Visual Basic

Este error tiene las siguientes causas y soluciones:

  • Se produjo un error interno con OLE y Visual Basic.

  • Está utilizando una versión incorrecta de Visual Basic.

    Vuelva a instalar Visual Basic y el proveedor de control de código fuente.


El proveedor de control de código fuente no se inicializó correctamente

Este error tiene la solución siguiente:

  • Su sistema tiene poca memoria o recursos del sistema.

    Cierre algunas aplicaciones y vuélvalo a intentar.

    Si esto no es suficiente, vuelva a instalar el proveedor de código fuente.


El proveedor de control de código fuente no pudo instalar correctamente los menús

Este error tiene la siguiente causa y solución:

  • Se ha producido un error interno de OLE.

    Primero vuelva a instalar Visual Basic y luego el proveedor de control de código fuente (si es necesario); después, vuelva a instalar OLE (si es necesario).


No se pudo volver a cargar el archivo <archivo> en el proyecto de Visual Basic

Este error tiene la siguiente causa y solución:

  • No se pudo volver a cargar el archivo en el proyecto de Visual Basic.

    Asegúrese de que el proyecto de Visual Basic está desprotegido. Compruebe el nombre de archivo y, si es correcto, puede volver a cargar el archivo en el proyecto de Visual Basic. Puede que tenga que obtener una nueva copia del archivo del proveedor de control de código fuente y colocarla en la carpeta de trabajo, o puede que tenga que reiniciar Visual Basic.


No se han podido establecer todas las opciones correctamente

Este error tiene la solución siguiente:

  • En la mayoría de los casos, no se puede establecer correctamente las opciones debido a falta de memoria o de espacio en disco. Libere memoria o espacio en disco y vuélvalo a intentar.


Error del comando Proteger. Los archivos no se han protegido

Este error tiene la solución siguiente:

  • Abra la aplicación de control de código fuente y proteja los archivos manualmente.

    Compruebe la ventana Resultados para obtener otras condiciones de error. Si las encuentra, corríjalas y vuelva a intentar la operación.


Algunos archivos no se han podido proteger

Este error tiene la siguiente causa y solución:

  • Se produjo un error durante el comando Proteger.

    Compruebe el espacio libre del disco o reinicie Windows.

    Compruebe la ventana Resultados para obtener otras condiciones de error. Si las encuentra, corríjalas y vuelva a intentar la operación.


Fallo del comando Desproteger. Los archivos no se han desprotegido

Este error tiene la solución siguiente:

  • Abra la aplicación de control de código fuente y desproteja los archivos manualmente.

    Compruebe la ventana Resultados para obtener otras condiciones de error. Si las encuentra, corríjalas y vuelva a intentar la operación.


Algunos archivos no se han podido desproteger

Este error tiene la siguiente causa y solución:

  • Se produjo un error durante el comando Desproteger.

    Compruebe el espacio libre del disco o reinicie Windows.

    Compruebe la ventana Resultados para obtener otras condiciones de error. Si las encuentra, corríjalas y vuelva a intentar la operación.


No se pudo cerrar correctamente el proyecto cargado anteriormente

Este error tiene la siguiente causa y solución:

  • Mientras intentaba abrir un proyecto nuevo, el proveedor de control de código fuente no pudo cerrar correctamente el anterior.

    Salga de Visual Basic y reinícielo.


La operación de diferencia visual ha fallado

Este error tiene la solución siguiente:

  • Abra la aplicación del proveedor de control de código fuente y utilice el comando Diferencias manualmente.


Error al cargar el archivo <archivo>

Este error tiene la siguiente causa y solución:

  • Se han encontrado errores al cargar el archivo.

Es posible que Visual Basic no haya cargado el archivo correctamente. Intente abrir el archivo de nuevo o asegúrese de que no está dañado.


Fallo del comando Obtener. Los archivos no se han descargado del control de código fuente

Este error tiene la solución siguiente:

  • Abra la aplicación del proveedor de control de código fuente y obtenga los archivos manualmente.

    Compruebe la ventana Resultados para obtener otras condiciones de error. Si las encuentra, corríjalas y vuelva a intentar la operación.


El control de código fuente no pudo actualizar algunos archivos

Este error tiene la siguiente causa y solución:

  • Se produjo un error durante el comando Obtener la última versión.

    Compruebe el espacio libre del disco o reinicie Windows.

    Compruebe la ventana Resultados para obtener otras condiciones de error. Si las encuentra, corríjalas y vuelva a intentar la operación.


No se puede obtener el historial para este elemento

Este error tiene la siguiente causa y solución:

  • Visual Basic no pudo obtener el historial de este archivo o proyecto del proveedor del control de código fuente.

    Ejecute el proveedor de código fuente y obtenga allí el historial.


No se puede iniciar el proveedor de control de código fuente

Este error tiene la siguiente causa y solución:

  • Visual Basic no pudo iniciar un componente del proveedor de control de código fuente.

    Ejecute el proveedor de control de código fuente desde su icono, el Explorador de Windows 95 o el Administrador de archivos.


Error al intentar conectar el proyecto del control de código fuente con el proyecto actual de Visual Basic

Este error tiene la siguiente causa y solución:

  • El proveedor de control de código fuente no pudo asociar el proyecto actual de Visual Basic con un proyecto del proveedor de control de código fuente.

    Ejecute VSS y obtenga el proyecto (si está todavía en VSS).

    Intente realizar la misma operación con otro proyecto. Si funciona, cambie el nombre del proyecto original y vuelva a realizar la operación. Si no funciona, llame al Servicio de soporte técnico de Microsoft.


El proyecto de control de código fuente ya tiene un archivo de proyecto con el mismo nombre que el que está agregando. ¿Es el mismo archivo?

Este mensaje tiene la siguiente causa y solución:

  • Está intentando agregar un archivo de proyecto con el mismo nombre que un archivo del proyecto del proveedor de control de código fuente.

    Compruebe el nombre del archivo y cambie su nombre si es necesario.

    Haga clic en Sí para agregar el archivo seleccionado actualmente, sobrescribiendo el antiguo con el mismo nombre.

    Haga clic en No para cancelar la operación.


Debe desproteger el proyecto antes de poder realizar este comando

Este error tiene la siguiente causa y solución:

  • Intentó realizar un comando que requiere que se desproteja el archivo de proyecto de Visual Basic antes de desproteger el archivo de proyecto.

    Desproteja el archivo de proyecto de Visual Basic antes de continuar y vuelva a intentar realizar el comando.


Memoria insuficiente; no se puede terminar la operación

No tiene memoria suficiente en el equipo para realizar la operación deseada. Este error tiene las siguientes causas y soluciones:

  • Tiene abiertas demasiadas aplicaciones, documentos o archivos de origen.

    Cierre las aplicaciones, documentos o archivos de origen abiertos que no necesite.

  • Está ejecutando Microsoft Windows en modo estándar.

    Vuelva a iniciar Microsoft Windows en modo extendido.

  • Está ejecutando Microsoft Windows en modo extendido, pero se ha agotado la memoria virtual.

    Incremente la memoria virtual liberando espacio en disco o asegúrese de que tiene espacio disponible.

  • Hay programas residentes en ejecución.

    Elimine los programas residentes.

  • Tiene cargados muchos controladores de dispositivos.

    Elimine los controladores de dispositivos innecesarios.


No se pueden configurar correctamente los menús del control de código fuente para este proyecto

Este error tiene la siguiente causa y solución:

  • Se ha producido un error interno mientras se configuraba el sistema de menús de control de código fuente.

    Salga de Visual Basic y reinícielo o salga de Windows y reinícielo.


Todos los archivos disponibles se han agregado al proyecto de control de código fuente

Se ha agregado todos los archivos del proyecto de Visual Basic al proveedor de control de código fuente.


No tiene ningún archivo para proteger

Este error tiene la siguiente causa y solución:

  • Intentó proteger archivos, pero no hay ninguno desprotegido.

Si ha realizado cambios en un archivo que desea proteger, ejecute el Explorador de VSS, seleccione el archivo y, en el menú SourceSafe, haga clic en Desproteger. Asegúrese de hacer clic en la opción No obtener copia local del cuadro de diálogo Desproteger o, de lo contrario, perderá los cambios.


Ya se han desprotegido todos los archivos disponibles

Intentó desproteger un archivo, pero todos los archivos ya se habían desprotegido.


En este proyecto no hay archivos disponibles para obtener

Este error tiene la siguiente causa y solución:

  • No hay archivos en el proyecto actual de VSS.

    Para agregar archivos, utilice el comando Agregar archivos.


Como no ha iniciado sesión en <proveedor>, las características de control de código fuente no están habilitadas para este proyecto

Este error tiene la siguiente causa y solución:

  • Canceló su conexión al proveedor de control de código fuente; no están disponibles las características del proveedor de código fuente.

    Abra un proyecto diferente y vuelva a este proyecto e inicie una sesión.


No se puede cargar el proveedor de control de código fuente

Este error tiene las siguientes causas y soluciones:

  • Las cadenas de registro utilizadas para encontrar la biblioteca de vínculos dinámicos del proveedor de control de código fuente (por ejemplo, SSSCC.DLL) no son correctas, tiene la versión errónea de Visual Basic o falta el archivo SSSCC.DLL.

  • Cambió de lugar la carpeta del control de código fuente después de instalar sin actualizar el registro.

  • Falló el programa de instalación.

    Compruebe las instrucciones de instalación de su proveedor de código fuente.

    Vuelva a ejecutar el programa de instalación de VSS.


No se puede asignar el archivo <archivo> al proyecto <proyecto> de Visual SourceSafe

Este error tiene la causa siguiente:

  • El entorno de desarrollo de código prohibe copiar archivos directamente a VSS.


El archivo <archivo> no está bajo control de código fuente

Este error tiene la siguiente causa y solución:

  • Ha seleccionado un archivo que no está incluido en el control de código fuente.

Use al comando Agregar archivos para agregar el archivo al proveedor del control de código fuente antes de intentar desprotegerlo o utilizar las funciones que ofrece el control de código fuente.


El proveedor de control de código fuente no admite esta operación

Algunos proveedores de código fuente no admiten todos los comandos de control de código fuente. Este error tiene la siguiente causa y solución:

  • Intentó ejecutar una operación no admitida.

    Salga de Windows y reinícielo e informe del error al Servicio de soporte técnico de Microsoft.


El archivo <archivo> ya está desprotegido

Este error tiene la siguiente causa y solución:

  • Los archivos .FRM sólo los puede desproteger un usuario a la vez.

    Si es necesario, ejecute su proveedor de control de código fuente para saber quién ha desprotegido el archivo.


No se puede agregar el proyecto al control de código fuente porque la ruta es demasiado larga

Este error tiene la siguiente causa y solución:

  • La ruta de acceso para este proyecto es demasiado larga.

Utilice otra ruta de acceso más corta y pruebe otra vez.


Guarde y proteja su archivo de proyecto de Visual Basic

Este error tiene la siguiente causa y solución:

  • Ha realizado cambios que modifican su archivo de proyecto de Visual Basic.

Necesita guardar y proteger su archivo de proyecto. De lo contrario, el proyecto contendrá referencias a copias de archivos con sus anteriores ubicaciones en lugar de las ubicaciones actuales.


Esta operación necesita desproteger primero el archivo de proyecto de Visual Basic

Muchas operaciones, como agregar un archivo nuevo, quitar un archivo, cambiar el nombre de un archivo, etc. requieren que se desproteja primero el archivo de proyecto de Visual Basic.

  • Realizó una operación sin desproteger primero el archivo de proyecto de Visual Basic.

    Desproteja el archivo de proyecto de Visual Basic antes de continuar y vuelva a intentar realizar el comando.


El proyecto <proyecto> ya no existe bajo <proveedor>

Este error tiene la siguiente causa y solución:

  • Se eliminó (o cambió de lugar) el proyecto especificado. Debe recuperar (o seleccionar)el proyecto especificado antes de que se le puedan aplicar comandos de control de código fuente.

    Si se cambió de lugar el proyecto, obtendrá un cuadro de diálogo para ayudarle a buscar el nuevo proyecto. Si se eliminó el proyecto, deberá ejecutar el proveedor de control de código fuente para volver a instalar el proyecto.


No se encontró el proyecto <proyecto>

Este error tiene la siguiente causa y solución:

  • Se cambió el nombre del proyecto, o se movió o eliminó.

    Haga clic en Examinar si desea buscar el proyecto en la base de datos del proveedor de control de código fuente.


No se pueden determinar las propiedades de este elemento

Este error tiene la siguiente causa y solución:

  • Visual Basic no pudo encontrar las propiedades de este elemento.

    Ejecute el proveedor de control de código fuente y obtenga desde allí las propiedades.


No se pudo eliminar automáticamente el archivo del proveedor de control de código fuente

Este error tiene la solución siguiente:

  • Abra la aplicación de control de código fuente y elimine manualmente el archivo.


No se pudo cambiar automáticamente el nombre del archivo en el proveedor de control de código fuente

Este error tiene la solución siguiente:

  • Abra la aplicación del proveedor de control de código fuente y cambie el nombre del archivo manualmente.


Ha creado un nuevo proyecto

Este error tiene la siguiente causa y solución:

  • Ha elegido guardar el proyecto en otra carpeta diferente, pero el proveedor de control de código fuente no puede asignar directamente el nombre de la nueva carpeta.

El proyecto antiguo está aún bajo el control de código fuente, pero el nuevo no. Utilice el comando Agregar proyecto para agregar manualmente el nuevo nombre del proyecto al control de código fuente.


La ventana Resultados está llena; se eliminarán las entradas anteriores de la ventana Resultados

Cuando se realiza una operación con varios archivos, la ventana Resultados puede llenarse rápidamente con mensajes de estado. Este mensaje de advertencia tiene la causa siguiente:

  • La ventana Resultados está llena. No podrá ver algunas de las entradas anteriores.


Algunos resultados antiguos se han eliminado para hacer espacio para los resultados más recientes

Este mensaje le informa de que se han eliminado los resultados antiguos; no es necesaria ninguna acción.


La operación cambiar el nombre del archivo se ha detenido, no se han guardado todos los archivos

Este error tiene la siguiente causa y solución:

  • Eligió no permitir al proveedor de control de código fuente desproteger el archivo de proyecto al que está cambiando el nombre.

Si elige no permitir al proveedor de control de código fuente desproteger el archivo de proyecto mientras cambia el nombre de un archivo, la operación no podrá continuar hasta que no se cambie el nombre del archivo en el proveedor de control de código fuente.


No se ha guardado el archivo de proyecto. Guarde el archivo de proyecto antes de realizar operaciones de control de código fuente

Este error tiene la siguiente causa y solución:

  • El control de código fuente requiere que guarde el archivo de proyecto de forma que sólo tenga que trabajar con un archivo.


No se ha guardado el proyecto. Guarde el proyecto antes de agregarlo al control de código fuente

Este error tiene la siguiente causa y solución:

  • El control de código fuente requiere que guarde el proyecto para que no se pierdan los cambios.


No se pudo asignar el archivo <archivo> al proyecto <proyecto> del proveedor de control de código fuente

Este error tiene la siguiente causa y solución:

  • El proveedor de control de código fuente no sabe en qué proyecto del proveedor de control de código fuente debe colocar el archivo o del que debe obtener el archivo.

    El proveedor de control de código fuente determina esto basándose en la carpeta en la que está el archivo. Aunque el proveedor de control de código fuente puede asignar proyectos a carpetas dentro de una subcarpeta de un proyecto o carpeta, los archivos en subcarpetas o en otras unidades crean problemas, a menos que haya una asociación entre la carpeta de la que procede el archivo y el proyecto del proveedor de control de código fuente.

    Agregue el archivo especificado a una carpeta que esté al mismo nivel o por debajo del proyecto especificado. Si el archivo ya está en el proveedor de control de código fuente, comparta el archivo con el proyecto actual.


No se puede asignar el archivo <archivo> al proyecto <proyecto> de Visual SourceSafe

Este error tiene la siguiente causa y solución:

  • Debe tener el archivo en VSS antes de continuar con la operación.

    Haga clic en Sí para copiar el archivo al proyecto especificado y continuar.

    Haga clic en No para cancelar la operación.


No se puede compartir un archivo desde el proveedor de control de código fuente

Este error tiene la solución siguiente:

  • Ejecute el proveedor de control de código fuente y comparta desde allí los archivos.


No se ha guardado el proyecto

Este error tiene la siguiente causa y solución:

  • Debe guardar el proyecto antes de utilizarlo con control de código fuente.

    Guarde el proyecto y vuelva a intentar el comando.


Sólo se puede ejecutar una copia del proveedor de control de código fuente a la vez

Este error tiene la causa siguiente:

  • Aunque se pueden ejecutar varias sesiones de Visual Basic a la vez, sólo se puede ejecutar a la vez un proveedor de control de código fuente; esta sesión de Visual Basic tiene desactivado el control de código fuente.


Error del comando Deshacer desprotección. Revise los archivos para comprobar el estado de sus versiones

Este error tiene la solución siguiente:

  • Abra la aplicación de control de código fuente y deshaga la protección de los archivos manualmente.

    Compruebe la ventana Resultados para obtener otras condiciones de error. Si las encuentra, corríjalas y vuelva a intentar la operación.


No se pudo deshacer el estado de desprotección de algunos archivos

Este error tiene la siguiente causa y solución:

  • Se produjo un error durante el comando Deshacer desprotección.

    Compruebe el espacio libre del disco o reinicie Windows.

    Compruebe la ventana Resultados para obtener otras condiciones de error. Si las encuentra, corríjalas y vuelva a intentar la operación.


¿Desea agregar el archivo <archivo> al proyecto actual de control de código fuente?

En la mayoría de los casos, haga clic en Sí para mantener sincronizados los proyectos de Visual Basic y del control de código fuente. Puede hacer clic en No si está probando un archivo que desea agregar más tarde o un archivo que no desea agregar.

Haga clic en Sí para agregar el archivo al control de código fuente.

Haga clic en No para agregar el archivo al proyecto de Visual Basic sin agregarlo al proyecto de control de código fuente.


¿Desea proteger todos los archivos que han cambiado?

Haga clic en Sí para proteger todos los archivos.

Haga clic en No para dejar la protección para otro momento.


El cambio que ha hecho ha cambiado el archivo de proyecto de Visual Basic, pero todavía no ha desprotegido el archivo de proyecto de Visual Basic

Este error tiene la siguiente causa y solución:

  • Modificó el archivo de proyecto de Visual Basic, pero no desprotegió el archivo antes en el proveedor de control de código fuente.

    Haga clic en Sí para desproteger el archivo de proyecto y poder guardar las modificaciones.

    Haga clic en No para mantener protegido el archivo de proyecto. No podrá guardar los cambios en el proveedor de control de código fuente.


¿Desea obtener la última copia protegida de los archivos en este proyecto?

Haga clic en Sí para obtener la última versión de los archivos.

Haga clic en No para conservar las versiones que tiene de los archivos.


El archivo <archivo> no es un tipo de archivo normal para agregarlo a un proyecto de Visual Basic

Este error tiene la siguiente causa y solución:

  • El archivo que está agregando al proveedor de control de código fuente es de un tipo que no reconoce Visual Basic.

    Haga clic en Sí para continuar agregando el archivo al proveedor de control de código fuente.

    Haga clic en No para cancelar la operación de agregar.


Se ha quitado el archivo del proyecto de Visual Basic. ¿Desea quitar también el archivo del control de código fuente?

Haga clic en Sí para quitar el archivo del proyecto de control de código fuente. (Se pueden recuperar después los archivos eliminados si es necesario.)

Haga clic en No para quitar el archivo de su proyecto de Visual Basic, pero manteniéndolo en el proyecto de control de código fuente.


¿Desea guardar sus archivos antes de continuar con esta operación <proveedor>?

Este error tiene la siguiente causa y solución:

  • No guardó los archivos antes de realizar una operación del proveedor de control de código fuente.

    Haga clic en Sí para guardar los archivos.

    Haga clic en No para permitir a VSS sobreescribir los cambios hechos en la última operación de guardar.


Ese proyecto de control de código fuente no contiene el archivo de proyecto de Visual Basic cargado. ¿Desea intentarlo de nuevo?

Este error tiene la siguiente causa y solución:

  • Seleccionó un proyecto de control de código fuente que no contenía el archivo de proyecto de Visual Basic apropiado.

    Haga clic en Sí para seguir examinando la base de datos del control de código fuente en busca del proyecto actual.

    Haga clic en No para cancelar la operación.


Comandos del menú Ayuda

Los comandos del menú Ayuda proporcionan Ayuda acerca de la utilización de VSS y de comandos específicos de VSS. Además, puede presionar F1 en cualquier momento para obtener Ayuda acerca del elemento de menú o cuadro de diálogo seleccionado.

Comando de Ayuda | Acción
Contenido | Ejecuta la Ayuda y muestra la Tabla de contenido de VSS.
Buscar Ayuda acerca de | Muestra el cuadro de diálogo Buscar Ayuda de forma que pueda encontrar rápidamente la información que necesita.
Soporte técnico | Muestra información acerca de los servicios de soporte técnico de Microsoft.
Acerca de VSS/Administrador | Muestra un cuadro de diálogo con información sobre de su copia de Microsoft VSS, incluyendo el número de versión y los avisos sobre derechos de autor, consideraciones legales y licencia.

Comentarios

Una forma rápida de encontrar información consiste en utilizar Buscar y un índice automático con cientos de entradas de índices y referencias cruzadas.

También puede buscar temas de ayuda en la Tabla de contenido de VSS.

A medida que lee un tema en la Ayuda de VSS, puede desplazarse por el tema con la barra de desplazamiento, las teclas de dirección o las teclas RE PÁG y AV PÁG.

En la ventana Ayuda, haga clic en Buscar para abrir el índice de VSS. Haga clic en Atrás para ir al último tema de Ayuda visto.


Obtener ayuda del Soporte Técnico de Microsoft

Si no puede encontrar las respuestas que necesita en el archivo de Ayuda o el manual del producto, puede resolver los problemas rápidamente mediante una de entre muchas opciones.

Nota Los servicios y precios que se enumeran aquí están disponibles sólo en EE.UU. y Canadá, y está sujeto a cambios sin previo aviso. El soporte fuera de EE.UU y Canadá puede variar. Póngase en contacto con el distribuidor de Microsoft más cercano mediante la lista mundial de distribuidores del archivo de Ayuda de este producto.

Soporte Online

Soporte estándar sin cargo

Soporte con pago por incidente

Respuesta Web

Soporte adicional

Soporte fuera de los EE.UU y Canadá


Agregar proyecto al control de código fuente (Comando, entorno de desarrollo)

Vea también

Agrega el proyecto actual del entorno de desarrollo a la base de datos de control de código fuente.

Para utilizar el comando Agregar proyecto al control de código fuente

  • En el menú Herramientas de SourceSafe, haga clic en Agregar proyecto al control de código fuente.

Nota Si especifica el nombre del proveedor de control de código fuente, aparecerá en lugar de "control de código fuente".

Comentario

El comando Agregar proyecto al control de código fuente toma los archivos seleccionados en la ventana del proyecto del entorno de desarrollo y crea con ellos un nuevo proyecto de control de código fuente. Este comando sólo está disponible al seleccionar un proyecto que no se encuentre ya bajo el control de código fuente. En este caso cada archivo seleccionado se agrega automáticamente.


Crear proyecto de SourceSafe (Comando, entorno de desarrollo)

Copia un proyecto al disco duro cuando se encuentra en el control de código fuente, pero no en el disco.

Para utilizar el comando Descargar proyecto de SourceSafe

  • En el menú Herramientas de SourceSafe, haga clic en Descargar proyecto de SourceSafe.

Nota Cuando haya ubicado el proyecto que desee, este comando lo abrirá en el entorno de desarrollo y obtendrá automáticamente todos sus archivos de la base de datos de VSS.


Ejecutar (Comando, entorno de desarrollo)

Inicia el proveedor de control de código fuente.

Para utilizar el comando Ejecutar

  • En el menú Herramientas de SourceSafe, haga clic en Ejecutar. En algunos casos, puede que necesite escribir su nombre de usuario y (si es necesario) su contraseña y, después, hacer clic en Aceptar.

Comentario

Nota Al utilizar el comando Ejecutar VSS tendrá acceso, a través del Explorador de VSS, a todas las características y comandos de VSS. Los comandos de VSS disponibles en el menú Herramientas son un subconjunto del conjunto completo de comandos de VSS.


Actualizar estado del archivo (Entorno de desarrollo)

Actualiza la presentación del estado de los archivos en la ventana de proyecto de Visual Basic.

Para utilizar el comando Actualizar estado del archivo

  • En el menú Herramientas de SourceSafe en Visual Basic, haga clic en Actualizar estado del archivo.

Comentario

Utilice este comando cuando haya protegido o desprotegido un archivo o cuando desee comprobar el estado del proyecto en un entorno con múltiples programadores, donde otros usuarios del control de código fuente hayan podido modificarlo.


Visual SourceSafe

Visual SourceSafe (VSS) es la principal herramienta de control de código para código y programadores de Web. Puede almacenar cualquier tipo de archivo. Si desea más información, abra el archivo de Ayuda en su sistema (si ha instalado VSS).


Diferencias de archivo (Cuadro de diálogo, Visual SourceSafe)

De forma predeterminada, VSS utiliza la opción de presentación Visual, ajustando el ancho de la línea al ancho de la pantalla y sin líneas de contexto. Si especifica una presentación UNIX, VSS aplicará las opciones Pasar por alto MAY/min e Ignorar espacios en blanco. En la presentación Visual se muestran todas las líneas (contexto infinito).

Visual

Muestra todo el archivo, con anotaciones de los cambios.

SourceSafe

Muestra una lista con las líneas agregadas, eliminadas y modificadas optimizada para su legibilidad.

Unix

Muestra las diferencias con el formato del programa Diff de UNIX.

Pasar por alto MAY/min

Muestra las diferencias sin tener en cuenta la distinción entre mayúsculas y minúsculas.

Ignorar espacios en blanco

Muestra las diferencias sin tener en cuenta los caracteres espaciadores, como los tabuladores.

Informe

Envía un informe al, a un archivo de texto o a una impresora.

Proyecto

Muestra el cuadro de diálogo Diferencias de proyecto.

Opciones avanzadas

Ignorar diferencias del SO

Indica a VSS que debe pasar por alto las diferencias en los caracteres de terminación de línea del sistema operativo. Esta opción es útil al comparar archivos en una red en la que, por ejemplo, un equipo funciona en una plataforma UNIX y otro funciona con Microsoft Windows NT.

Mostrar contexto

Incluye el número de líneas especificado en la presentación de las diferencias. Las líneas de contexto son las que rodean a las que VSS identifica como diferentes. Por ejemplo, si especifica 3 en Mostrar contexto, aparecerán tres líneas por encima y otras tres por debajo de la que contiene la diferencia.

Guardar configuración

Guarda la configuración seleccionada para su uso en el futuro.


Buscar archivo de proyecto (Cuadro de diálogo, entorno de desarrollo)

Identifica el archivo de proyecto del entorno de desarrollo para que el proveedor de control de código fuente pueda realizar sus operaciones correctamente. Sólo aparece al realizar operaciones con proyectos que contienen más de un archivo de proyecto en la misma carpeta.

Opciones del cuadro de diálogo

Seleccionar el archivo de proyecto de Visual Basic

Seleccione el archivo del proyecto del entorno de desarrollo con el que desee trabajar.

Aceptar

Abre el archivo de proyecto seleccionado.

Cancelar

Cancela el comando.


Propiedades (Comando, menú Archivo)

Muestra el cuadro de diálogo Propiedades, que contiene información básica acerca de un archivo o un proyecto de VSS, incluyendo el tamaño, nombre y tipo.

Derechos de acceso

Debe disponer del derecho de acceso Leer para ver el cuadro de diálogo Propiedades.

Debe disponer del derecho de acceso Agregar para cambiar el tipo de un archivo.

Debe disponer del derecho de acceso Destruir para cambiar el estado de Almacenar sólo la última versión de un archivo.

Comentario

Haga clic en la ficha que contiene la información que desea. El contenido de la ficha varía dependiendo si un archivo o un proyecto está seleccionado actualmente en el Explorador de VSS.

Nota Haga clic en el botón Informe de cualquiera de las fichas para crear un informe para enviarlo al Portapapeles, a un archivo de texto o a una impresora.

Fichas del cuadro de diálogo Propiedades de archivo

General

Muestra el nombre de archivo, su tipo, tamaño, el número de la versión más reciente, la fecha de la última modificación, el comentario, además de indicar si todo el historial del archivo (o sólo la última versión) está almacenado en la base de datos de SourceSafe. Puede cambiar el comentario y establecer que se almacene sólo la última versión del archivo para ahorrar espacio de disco. Aquí también puede modificar el tipo de archivo.

Estado de desprotección

Muestra el nombre del archivo, quién lo ha desprotegido (si está desprotegido), si se ha desprotegido de forma exclusiva, cuándo se desprotegió, la versión actual, la ruta de acceso de desprotección (con el nombre del equipo), el proyecto al que pertenece el archivo y el comentario de desprotección. Puede modificar el comentario de desprotección.

Vínculos

Muestra los vínculos compartidos actuales que tiene un archivo con otros proyectos.

Rutas de acceso

Muestra los proyectos que han bifurcado versiones de este archivo anteriormente.


Elementos eliminados (Ficha, cuadro de diálogo Propiedades)

Vea también

Muestra una lista de los archivos y subproyectos que se han quitado del proyecto.

Para ver la ficha Elementos eliminados

  1. Seleccione un proyecto del panel de proyectos del Explorador de VSS.

  2. En el menú Archivo, haga clic en Propiedades y después haga clic en la ficha Elementos eliminados.

Derechos de acceso

Debe disponer del derecho de acceso de Leer para poder utilizar este cuadro de diálogo.

Comentarios

Cuando utilice el comando Eliminar para eliminar un archivo o un proyecto de VSS, el elemento eliminado se quita del Explorador de VSS. Sin embargo, VSS continúa almacenando el elemento, de forma que puede recuperarlo si desea generar una versión anterior del proyecto.

No obstante, después de recuperar o purgar un elemento, deja de aparecer en la lista de la ficha Elementos eliminados. Si no se eliminó ningún archivo o proyecto secundario del proyecto, este diálogo indica simplemente que "No hay elementos eliminados para este proyecto".

Opciones de la ficha

Elementos

Lista de todos los archivos y subproyectos eliminados del proyecto actual.

Recuperar

Recupera (deshace la eliminación) un elemento y lo coloca en la lista de archivos o lista de proyectos.

Purgar

Elimina de forma permanente un elemento, de forma que no puede recuperarse.

Cerrar

Cierra la ficha Elementos eliminados y vuelve al Explorador de VSS.

Informe

Envía un informe al Portapapeles, a un archivo de texto, o a una impresora.


Agregar proyecto a SourceSafe (Cuadro de diálogo, Visual SourceSafe)

Proyecto

Escriba el nombre del proyecto de VSS que desee o bien haga clic en la lista de proyectos para elegir uno de ellos. Puede especificar una ruta de acceso completa (como $/CODIGO/RECURSOS) o simplemente un nombre de proyecto para crear uno nuevo bajo el proyecto actual.

Aceptar

Agrega a VSS el proyecto actual del entorno de desarrollo.

Cancelar

Cancela el comando Agregar proyecto a SourceSafe.

Crear

Crea un nuevo proyecto de VSS. Escriba un nombre bajo Proyecto y haga clic en Crear.


Mostrar diferencias (Comando, entorno de desarrollo)

Compara un archivo seleccionado del proyecto del entorno de desarrollo con la versión actual almacenada en la base de datos del proveedor de control de código fuente y muestra las diferencias, si existen.

Para utilizar el comando Mostrar diferencias

  • Una vez agregado un proyecto al proveedor de control de código fuente, en el menú Herramientas de SourceSafe, haga clic en Mostrar diferencias.

Comentario

Normalmente, el comando Mostrar diferencias se utiliza inmediatamente antes de proteger un archivo con el fin de comparar la copia modificada con la copia maestra. De este modo se obtiene una lista con los cambios realizados, lo que puede resultar útil para crear un comentario.

Al utilizar el comando Mostrar diferencias con un archivo de texto ASCII, el proveedor de control de código fuente muestra una lista con códigos de colores que indica las diferencias entre la versión del archivo almacenada en la base de datos y la copia local.

En el caso de archivos binarios, el proveedor de control de código fuente indica si la copia local del archivo es distinta de la copia maestra, pero no puede mostrar las diferencias.


Buscar archivo de proyecto (Cuadro de diálogo)

Le permite encontrar un archivo de proyecto de forma que pueda abrirlo bajo control de código fuente.

Una vez encontrado el archivo de proyecto (make file), haga clic en Aceptar para abrirlo bajo control de código fuente o haga clic en Cancelar para cancelar la operación.


Opciones de historial de archivo (Cuadro de diálogo, Visual SourceSafe)

Sólo etiquetas

Sólo incluye las etiquetas en el historial del archivo o el proyecto.

Desde

Indique una hora, una fecha, una versión o una etiqueta. Utilice el prefijo D para indicar una fecha o una hora y el prefijo L para indicar una etiqueta. Por ejemplo, "D29/02/95;12:15" o "LBeta1".

Hasta

Indique una hora, una fecha, una versión o una etiqueta. Utilice el prefijo D para indicar una fecha o una hora y el prefijo L para indicar una etiqueta. Por ejemplo, "D29/02/95;12:15" o "LBeta1".

Usuario

Indique un nombre de usuario para mostrar un historial de los archivos con los que ha trabajado el usuario especificado.

Aceptar

Muestra el cuadro de diálogo Historial de archivo.

Cancelar

Cancela el comando Mostrar historial.

Proyecto

Muestra el cuadro de diálogo Opciones de historial de proyecto. Este cuadro de diálogo contiene las mismas opciones que Opciones de historial de archivo, junto con otras dos: Incluir archivos, que incluye la información de los archivos en la presentación del historial del proyecto, y Recursivo, que incluye los subproyectos con todos sus archivos. Haga clic en Aceptar para mostrar el cuadro de diálogo Historial del proyecto.


Mostrar historial (Comando, entorno de desarrollo)

Vea también

Muestra el historial de un archivo o un proyecto bajo el control de código fuente.

Para utilizar el comando Mostrar historial

  • Una vez agregado un proyecto de entorno de desarrollo al proveedor de control de código fuente, haga clic en Mostrar historial del menú Herramientas de SourceSafe.

Comentario

Cada vez que protege en el proveedor de control de código fuente un archivo o un proyecto, éste recibirá un nuevo número de versión. Puede utilizar el comando Mostrar historial para obtener una lista de las versiones anteriores del archivo o el proyecto.

Nota De forma predeterminada, el comando Mostrar historial muestra el cuadro de diálogo Opciones de historial de archivo. Haga clic en Proyectos para mostrar el cuadro de diálogo Opciones de historial de proyecto.

Las versiones que aparecen comienzan por la más reciente y llegan hasta la creación del archivo o el proyecto. VSS proporciona información acerca del número de versión, que puede utilizarse con otros comandos (como Obtener la última versión) para indicar una versión determinada.

De forma predeterminada, el historial de un proyecto incluye los historiales de todos sus archivos, pero no es recursivo y no incluye los subproyectos.


Resultados del control del código fuente (Ventana, entorno de desarrollo)

Muestra el resultado del último comando de control de código fuente.

Opciones del cuadro de diálogo

Cerrar

Cierra la ventana Resultados del control del código fuente.


Compartir archivos (Comando, entorno de desarrollo)

Convierte el archivo seleccionado en un miembro del proyecto actual o crea un nuevo proyecto bifurcado.

Para utilizar el comando Compartir archivos

Una vez agregado un proyecto del entorno de desarrollo al proveedor de control de código fuente, haga clic en Compartir archivos en el menú Herramientas de SourceSafe.

Comentario

Nota Para compartir un archivo, cree un vínculo compartido entre proyectos. El archivo existe simultáneamente en dos (o más) proyectos. Al protegerlo en uno de ellos, los cambios se protegen automáticamente en todos los demás.

Si crea una bifurcación, los cambios realizados en el archivo bifurcado no se propagarán al proyecto original y viceversa.

Al compartir un proyecto crea bajo un nuevo proyecto bajo el proyecto actual que es un duplicado exacto del proyecto especificado. Todos los archivos del nuevo proyecto se comparten con los correspondientes archivos del proyecto original y los cambios en ellos se reflejan en el proyecto original al protegerlos.

Nota Cuando comparta un proyecto con archivos de formulario de Visual Basic (.FRM), asegúrese de compartir el archivo .FRX asociado por Visual Basic. Si no lo hace, el proyecto compartido no tendrá todos los archivos necesarios y no funcionará correctamente.


Agregar archivos a control de código fuente (Comando, entorno de desarrollo)

Vea también

Copia un archivo o un grupo de archivos de un proyecto del entorno de desarrollo a un proyecto de VSS.

Para utilizar el comando Agregar archivos a control de código fuente

  • Una vez agregado un proyecto del entorno de desarrollo a un control de código fuente, en el menú Herramientas de SourceSafe, haga clic en el comando Agregar archivos a control de código fuente.

Comentario

Puede utilizar el cuadro de diálogo Agregar al control de código fuente para llevar un archivo del entorno de desarrollo a la base de datos del control de código fuente. Sólo puede utilizar este comando con los archivos que ya formen parte del proyecto del entorno de desarrollo. Si desea agregar un archivo que no forma parte de ningún proyecto, primero deberá agregarlo al proyecto del entorno de desarrollo.

Nota Los archivos del entorno de desarrollo ya agregados al proyecto de control de código fuente actual no aparecen bajo Archivos para agregar.

Opciones del cuadro de diálogo

Archivos para agregar

Archivos disponibles para agregarlos a la base de datos de control de código fuente. Haga clic en la casilla de verificación correspondiente a los archivos que desee agregar.

Comentario

Escriba un comentario opcional para todos los archivos seleccionados.

Aceptar

Agrega los archivos al control de código fuente.

Cancelar

Cancela el comando Agregar archivos al control de código fuente.

Seleccionar todo

Selecciona todos los archivos de la lista.


Proteger (Comando, entorno de desarrollo)

Protege las modificaciones realizadas en la carpeta de trabajo del entorno de desarrollo en la base de datos de control de código fuente.

Para usar el comando Proteger

  • En el menú Herramientas de SourceSafe en Visual Basic, haga clic en Proteger.

Opciones del cuadro de diálogo

Archivos para proteger

Presenta una lista con los archivos que pueden ser protegidos. Haga clic en los archivos que quiere proteger o en Seleccionar todo para seleccionar todos los archivos que aparecen en la lista

Comentario

Escriba un comentario opcional.

Mantener desprotegido

Actualiza con los cambios la base de datos de control de código fuente, pero mantiene el archivo desprotegido.

Aceptar

Protege los archivos seleccionados.

Cancelar

Cancela el comando Proteger.


Desproteger (Comando, entorno de desarrollo)

Vea también

Desprotege una copia del archivo o los archivos seleccionados del proveedor de control de código fuente y la coloca como editable en la carpeta de trabajo correspondiente del entorno de desarrollo.

Para utilizar el comando Desproteger

  • En el menú Herramientas de SourceSafe en Visual Basic, haga clic en Desproteger.

Opciones del cuadro de diálogo

Archivos para desproteger

Muestra los archivos disponibles para su desprotección. Haga clic en los que desee desproteger o en Seleccionar todo para seleccionar todos ellos.

Comentario

Escriba una breve descripción del motivo de la desprotección.

Aceptar

Confirma la desprotección.

Cancelar

Cancela el comando Desproteger.

Seleccionar todo

Selecciona todos los archivos de la lista.


Obtener la última versión (Comando, entorno de desarrollo)

Vea también

Obtiene los archivos seleccionados del proveedor de control de código fuente y coloca un archivo de sólo lectura en el proyecto del entorno de desarrollo.

Para utilizar el comando Obtener la última versión

  • En el menú Herramientas de SourceSafe en Visual Basic, haga clic en Obtener la última versión.

Opciones del cuadro de diálogo

Archivos para obtener/proteger

Selecciona el archivo o los archivos que se desea obtener o proteger.

Aceptar

Confirma las selecciones.

Cancelar

Cancela las selecciones.

Seleccionar todo

Selecciona todos los archivos de la lista.


Opciones (Comando, entorno de desarrollo)

Personaliza el entorno del proveedor de control de código fuente.

Para utilizar el comando Opciones

  • Una vez agregado un proyecto del entorno de desarrollo al proveedor de control de código fuente, haga clic en Opciones en el menú Herramientas de SourceSafe.

Comentario

El comando Opciones muestra el cuadro de diálogo Opciones de control de código fuente.

Opciones del cuadro de diálogo

Para cada opción puede especificar Sí, No o Preguntar.

  • ¿Desea obtener la versión protegida de los archivos al abrir un proyecto? (El valor predeterminado es No).

  • ¿Desea proteger los archivos al cerrar el proyecto? (El valor predeterminado es Preguntar).

  • ¿Desea agregar los archivos al control fuente cuando se agreguen a Visual Basic? (El valor predeterminado es Sí).

  • ¿Desea quitar los archivos del control fuente cuando se eliminen de Visual Basic? (El valor predeterminado es Preguntar).

Avanzadas

Muestra las opciones avanzadas.

Aceptar

Confirma las selecciones.

Cancelar

Cancela las selecciones.


Deshacer desprotección (Comando, entorno de desarrollo)

Sobrescribe las modificaciones realizadas en un archivo y copia la última versión protegida del mismo a la carpeta de trabajo del entorno de desarrollo.

Para utilizar el comando Deshacer desprotección

  • En el menú Herramientas de SourceSafe en Visual Basic, haga clic en Deshacer desprotección.

Opciones del cuadro de diálogo

Deshacer protección de archivos

Muestra los archivos desprotegidos. Haga clic en aquéllos cuya desprotección desee deshacer o en Seleccionar todo para seleccionar todos los archivos de la lista.

Aceptar

Confirma la selección.

Cancelar

Cancela la selección.

Seleccionar todo

Selecciona todos los archivos de la lista.


Si tienen otras necesidades de soporte

Si no tienen acceso a Internet

Las FastTip son un servicio de respuesta por fax gratuito y automatizado que proporciona artículos de la popular Knowledge Base y respuestas rápidas a las cuestiones técnicas más comunes. Para obtener acceso, marque el (800) 936-4300.

Si necesita servicios de soporte para un negocio pequeño, mediano o grande

Las opciones Priority Annual Support, Priority Plus y Premier Support proporcionan una selección de paquetes de soporte anual que se ajustan a las empresas. Para determinar qué cuenta se adapta mejor a sus necesidades de negocio, vaya a http://www.microsoft.com/spanish/soporte. O llame al (800) 936-3500 si desea información sobre las opciones de soporte para negocios pequeños y medios, o al (800) 936-3200 para grandes empresas.

Si necesita soporte técnico a domicilio, de varios proveedores o de productos propietarios

Los Microsoft Certified Solution Providers y los Authorized Support Centers se especializan en proporcionar paquetes de soporte para productos hardware, software y de red tanto de Microsoft como de otros fabricantes. Si desea más información o una referencia a un Microsoft Certified Solution Provider, llame al (800) 765-7768 entre las 6:30 A.M. y las 5:30 P.M., de lunes a viernes, excepto festivos, o visite http://www.microsoft.com/spain/mcsp. Si desea más información sobre los Authorized Support Centers, póngase en contacto con su proveedor de Microsoft, o visite http://www.microsoft.com/enterprise/asc.htm.

Si necesita servicios de teléfono-texto (TTY/TDD)

En EE.UU, llame al (425) 635-4948, o en Canadá, llame al (905) 568-9641.

Los servicios de soporte de Microsoft están sujetos a los precios, términos y condiciones de Microsoft en el lugar y hora en que se utiliza el servicio y están sujetos a cambios sin previo aviso.


Si tiene una pregunta sencilla y necesita una rápida respuesta

Encontrar sus respuestas en línea rápidamente

Use el Soporte en línea para buscar en la Microsoft Knowledge Base y otros recursos de información técnica las respuestas rápidas y certeras. También puede personalizar el sitio para controlar su búsqueda. Para comenzar su búsqueda, vaya a http://www.microsoft.com/spanish/soporte.

Si desea recursos e información técnica adicional sobre el desarrollo con productos y tecnologías de Microsoft, visite MSDN en línea en http://www.microsoft.com/spain/msdn.


Si necesita soporte fuera de Estados Unidos y Canadá

Soporte técnico de Microsoft en el mundo

Si está fuera de los EE.UU. y tiene una pregunta sobre un producto Microsoft, primero:

  • Compruebe la información de su archivo de Ayuda o el manual del producto.

  • Compruebe los archivos Léame que vienen con los discos o disquetes del producto. Esos archivos proporcionan información general de la que se dispone justo antes que se libere el producto.

  • Vaya al Soporte en línea del Soporte técnico de Microsoft en http://www.microsoft.com/spanish/soporte.

Si no puede encontrar una solución, puede recibir información sobre cómo obtener soporte técnico contactando con el distribuidor de Microsoft de su área.

Importante Los números de teléfono de los distribuidores de Microsoft están sujetos a cambios. Para obtener la lista más reciente, consulte la sección de opciones y números de teléfono en el sitio Web de Soporte en línea en http://www.microsoft.com/spanish/soporte. Si no hay distribuidor de Microsoft en su país/región, póngase en contacto con el establecimiento en el que ha obtenido su producto Microsoft.

  • Acerbaiyán

    Consulte Rusia

  • Alemania

    Microsoft GmbH
    Teléfono: 089/3176-0
    Fax: 089/3176-1000
    Telex: (17) 89/83 28 MS GMBH D
    Información: 089/3176-1199
    Precios, actualizaciones, etc.: 8105-25-1199
    Internet: www.microsoft.com/germany
    Soporte estándar:
    Instalación y control: 01805/67 22 55
    Información general sobre soporte Microsoft en Europa central: Fax: 1805-25-1191

  • América central

    Consulte Latinoamérica

  • Arabia Saudí

    Microsoft Saudi Arabia
    Teléfono: +966-1-488-1165
    Fax: +966-1-488-1576
    Soporte técnico:
    (Sólo para Sistema operativo personal y aplicaciones de escritorio):
    Teléfono: 800 124 0500
    (gratuito dentro de Arabia Saudí)
    Fax: 966-1-4740576

  • Argentina

    Microsoft de Argentina S.A.
    Servicio al cliente: (54) (1) 316-4600
    Fax: (54) (1) 316-4698
    Soporte técnico: (54) (1) 316-4664

  • Armenia

    Consulte Rusia

  • Australia

    Microsoft Pty. Ltd.
    Fax: (61) (02) 9805 1108
    Centro de información de ventas: (61) (02) 9870 -2100
    Internet: //www.microsoft.com.au/
    Soporte técnico: (61) (02) 9870 -2131
    Fax: (61) (02) 9805 0519

  • Austria

    Microsoft Ges.m.b.H.
    Teléfono: (+43) 1 610 64 -0
    Fax: (+43) 1 610 64 -200
    Información: 0660-6520
    Precios, actualizaciones, etc.: 0660-6520
    Soporte estándar:
    Instalación y control: 01 50222-2255
    Información general sobre Support Network en Europa central:
    Fax: 01805-251191

  • Bélgica

    Microsoft NV
    Teléfono: +32-2-730 39 11
    Fax: +32-2-726 96 09
    Centro de Información de Microsoft: +32-2-481 52 52
    Boletín electrónico: +32-2-726 85 45 (14400/1200/2400/9600 bd, 8N1, ANSI)
    Soporte técnico:+32-2-513 32 74 (en holandés)
    +32-2-502 34 32 (en inglés)
    +32-2-513 22 68 (en francés)

  • Bielorrusia

    Consulte Rusia

  • Bolivia

    Consulte Argentina

  • Brasil

    Microsoft Informatica Ltda.
    Teléfono: (55) (11) 5514 -7100
    Fax: (55) (11) 5514 - 7106/5514-7107
    Soporte técnico: (55) (11) 5506 -8087
    Fax: (55) (11) 5506 -7621
    Fax automático: (55) (11) 5506 -8506
    Boletín electrónico de soporte técnico: (55) (11) 5506 -1234
    Soporte al cliente: (55) (11) 822-5764

  • Canadá

    Microsoft Canada Inc.
    Teléfono de la oficina principal: 1 (905) 568-0434
    Centro de información al cliente: 1 (800) 563-9048
    Soporte técnico: Sistemas de escritorio incluyendo Microsoft Windows 95: (905) 568-4494
    Microsoft Office y componentes de Office: (905) 568-2294
    Resto de soporte técnico estándar: (905) 568-3503
    Información de soporte prioritaria: (800) 668-7975
    Teléfono-texto (TTY/TDD) (905) 568-9641
    Boletín electrónico de soporte técnico: (905) 507-3022

  • Caribe

    Microsoft Caribbean, Inc.
    Teléfono: (809) 273-3600
    Fax: (809) 273-3636
    Soporte técnico: (214) 714-9100

  • Chile

    Microsoft Chile S.A.
    Teléfono: 56-2-330-6000
    Fax: 56-2-330-6190
    Servicio al cliente: 56-2-800-213121
    Sistema Operativo personal y aplicaciones de escritorio:
    Teléfono: 56-2-330-6222
    Fax: 56-2-341-1439

  • China

    Microsoft (China) Co. Ltd
    4/F Kai Yuen Commercial Building
    No.28 Zhichunli, Hai Dian District
    Beijing 100086, PRC
    Teléfono: 011-86-10-6261-7711
    Fax: 011-86-10-6253-6630

  • Colombia

    Microsoft Colombia
    Teléfono: (571) 618 2245
    Fax: (571) 618 2269
    Soporte técnico:
    Línea de Respuesta Microsoft
    Teléfono: (571) 5230022
    Fax: (571) 5231220
    Teléfono de voz: (571) 5034216

  • Corea

    Microsoft CH
    Teléfono: (82) (2) 531-4500
    Fax: (82) (2) 531-1724
    Servicio al cliente: 080-022-7337 (gratuito, sólo para particulares)
    Soporte técnico: Soporte técnico para Office: (82) (2) 508-0040
    Soporte técnico de Windows: (82) (2) 563-54
    Soporte técnico al programador: (82) (2) 566-71
    Microsoft FastTips: (82) (2) 3453-7555
    Soporte de ventas: (82) (2) 531-4544

  • Croatia

    Microsoft Hrvatska d.o.o.
    Teléfono: (+385) (1) 304 555
    Fax: (+385) (1) 335 051
    Soporte técnico: (Póngase en contacto con el distribuidor.)

  • Dinamarca

    Microsoft Denmark
    Teléfono: (45) 44 89 01 00
    Fax: (45) 44 68 55 10
    Soporte técnico:Teléfono: (45) 44 89 01 11
    Soporte de ventas de Microsoft (45) 44 89 01 90
    Microsoft FastTips: (45) 44 89 01 44
    (El documento 769.696,20 cm de las FasTips contiene instrucciones detalladas) Microsoft MSDL (BBS): (45) 44 66 90 46

  • Dubai

    Microsoft Middle East
    Teléfono: (971) 4 513 888
    Fax: (971) 4 527 444
    Soporte técnico:SÓLO para sistemas personales y aplicaciones de escritorio:
    Teléfono: (971) (4) 524 488
    Fax: (971) 4 -524 495
    correo electrónico: mts@emirates.net.ae
    Información de soporte prioritaria: (971) (4) 555 752
    Centro de servicio al cliente:
    (Version upgrade / TechNet and MSDN subscription)
    Teléfono: (971) (4) 655 082
    Fax: (971) (4) 655 097

  • Ecuador

    Corporation Microsoft del Ecuador S.A.
    Teléfono: (593) 2 460-447, (593) (2) 460-451
    Servicio al cliente: (593) (2) 460-453, (593) (2) 460-458
    Soporte técnico: (593) (2) 463-094

  • Egipto

    Microsoft Egypt
    Teléfono: +202-418-6101
    Fax: +-4174766
    Soporte técnico:SÓLO para sistemas personales y aplicaciones de escritorio:
    Teléfono: (202) 261 3991 / 6
    Fax: (971) 403 2718

  • Escocia

    Consulte Reino Unido

  • Eslovenia/Slovenija

    Microsoft d.o.o.
    Teléfono: (+386) (61) 1800 8-00
    Fax: (+386) (61) 1800 822
    Soporte técnico: (+386) (61) 185 3449

  • España

    Microsoft Iberica SRL
    Teléfono: (34) 1-807-9999
    Fax: (34) 1-803-8310
    Soporte técnico: (34) 1 -3754004
    Servicio al cliente: (34) 1 -3754004
    Teléfono de fax según demanda: (34) 1-3754004

  • Estonia

    Consulte Alemania
    Soporte técnico: (+372) 650 49 99

  • Filipinas (SP)

    Microsoft Philippines
    Teléfono: 632 811 0062
    Soporte técnico: Teléfono: 632 892 2295/2495
    Fax: 632 813 2493

  • Finlandia

    Microsoft OY
    Teléfono: +358-(0) 9-525 501
    Fax: +358-(0) 9-878 8770
    Soporte técnico:
    Teléfono: +358-(0) 9-525 502 500
    Soporte de ventas: +358-(0) 9-525 5026
    Microsoft MSDL: +358-(0) 9-878 77 99
    (Información en sueco e inglés)
    Microsoft FastTips: +358-(0) 9-525 550 500
    (Información en sueco e inglés)

  • Francia

    Microsoft France
    Teléfono: (33) 01 69-86-46-46
    Fax: (33) 01 64-46-6-60
    Telex: MSPARIS 604322
    Soporte técnico:
    Teléfono: (33) 01 -69-86-10-20
    Fax: (33) (01) 69-28-00-28

  • Gales

    Consulte Reino Unido

  • Georgia

    Consulte Rusia

  • Grecia

    Microsoft Hellas, S.A.
    Teléfono: (30)(1) 6806-775 hasta (30)(1) 6806-779
    Fax: (30)(1) 6806-780
    Soporte técnico: Teléfono: (30) (1) 9247-030
    Fax: (30) (1) 9215-363

  • Holanda

    Microsoft BV
    Teléfono: 023-5689189
    Servicio al cliente: 023-5677700
    Boletín electrónico: 023-5634221
    (1200/2400/9600/14400 bd, 8N1, ANSI)
    Soporte técnico:023-5677877 (en holandés)
    023-5677853 (en inglés)

  • Hong Kong SAR, RPC

    Microsoft Hong Kong Limited
    Fax: (852) 2560-2217
    Servicio de Fax bajo demanda de soporte al producto: (852) 2535-9293
    Microsoft Club Hotline: (852) 28044277
    Soporte técnico: (852) 2804-4222

  • Hungría

    Microsoft Hungary
    Teléfono: +36 (1) 327-2800
    Fax: +36 (1) 327-2899
    Soporte técnico: +36 (1) 267-4636 (2MSINFO)

  • India

    Microsoft India
    Teléfono: (011) (91) (80) 5092678, (011) (91) (11) 646 0767, 646 0813
    Fax: (011) (91) (80) 509-2601, (011) (91) (11) 647- 4714

  • Indonesia (SP)

    Microsoft Indonesia - Jakarta
    Soporte técnico: Teléfono: 62 21 5721060
    Fax: 62 21 5732077

  • Inglaterra

    Consulte Reino Unido

  • Irlanda

    Consulte Reino Unido

  • Irlanda del Norte

    Consulte Reino Unido

  • Islandia

    Consulte Dinamarca

  • Israel

    Microsoft Israel Ltd.
    Teléfono: 972-3-613-833
    Fax: 972-3-613-0834

  • Italia

    Microsoft SpA
    Teléfono: (39) (2) 7039-21
    Fax: (39) (2) 7039-2020
    Oficina de Microsoft en Roma: (39) (6) 5095-01 - Fax: (39) (6) 5095-0600
    Microsoft por fax (Servicio de fax bajo demanda): (39) (2) 70-398-888
    Servicio al cliente (Información sobre productos nuevos, bibliografía sobre productos): (39) (2) 70-398-398
    Soporte al comerciante (Servicio al cliente sólo para distribuidores): (39) (2) 70-398-388
    Soporte técnico: (39) (2) 70-398-398
    Servicio de consulta de Microsoft: (39) (2) 7039-21

  • Japón

    Microsoft Company Ltd.
    Soporte técnico (Soporte estándar): (81) (424) 41-8700
    (Opciones de soporte técnico/Contratos de soporte):
    Teléfono: 120-37-196 (gratuito, sólo para particulares)
    Centro de Información de Marketing del Canal:
    (Soporte al producto previo a ventas)
    Teléfono de Tokio: (81) (3) 5454-2300
    Teléfono de Osaka: (81) (6) 245-6995
    Teléfono de servicio al cliente:
    (Versión actualización/Registro)
    Teléfono: (81) (48) 226-5500
    Fax: (81) (48) 226-5511

  • Kazajistán

    Consulte Rusia

  • Kirgizia

    Consulte Rusia

  • Latinoamérica

    Microsoft
    Latin American Headquarters (U.S.A.)
    Teléfono: (305) 489-4800
    Fax: (305) 491-1616
    Servicio al cliente: (425) 936-8661
    Soporte técnico: (214) 714-9100
    http://www.microsoft.com/latam/soporte

  • Liechtenstein

    Consulte Suiza (en alemán)

  • Luxemburgo

    Microsoft NV
    Teléfono: +32-2-730 39 11
    Centro de Información de Microsoft: +32-2-481 52 52
    Boletín electrónico: +32-2-726 85 45
    (1200/2400/9600/14400 bd, 8N1, ANSI)
    Soporte técnico:+32-2-513 32 74 (en holandés)
    +32-2-502 34 32 (en inglés)
    +32-2-513 22 68 (en francés)

  • Malasia (SP)

    Microsoft (Malaysia) Sdn Bhd:
    Teléfono: (60-3) 793-9595
    Fax: (60-3) 791-6080

  • Marruecos

    Microsoft Afrique Du Nord
    Teléfono: (212) 2 47 10 72
    Fax: (212) 2 47 10 86

  • México

    Microsoft México, S.A. de C.V.
    267-2110 Atención a Distribuidores
    265-3380 Atención a Clientes
    265-3399 Soporte Sistemas Operativos y Applicaciones de Escritorio
    267-2190 Soporte de Servidores y Herramientas de Desarrollo
    Fast Tips: (52)(5) 2612199
    Microsoft BBS 628-6200/02 MSMEXICO sin password

  • Noruega

    Microsoft Norway AS
    Teléfono: +(47) 22 02 25 00
    Fax: +(47) 22 95 06 64
    Soporte técnico: +(47) 22 02 25 50
    Soporte de ventas de Microsoft +(47) 22 02 25 80
    Microsoft MSDL: +(47) 22 18 22 09
    Microsoft FastTips: +(47) 22 02 25 70
    (El documento 404040 de las FasTips contiene instrucciones detalladas)

  • Nueva Zelanda

    Microsoft New Zealand Ltd
    Teléfono: 64 (9) 357-5800
    Fax: 64 (9) 358-3726
    Soporte técnico:Teléfono: 64 (9) 357-5575
    Fax: 64 (9) 307-0516 y 357-5577

  • Papúa Nueva Guinea

    Consulte Australia

  • Paraguay

    Consulte Argentina

  • Perú

    Consulte Latinoamérica

  • Polinesia francesa

    Consulte Francia

  • Polonia

    Microsoft Sp. z o.o.
    Teléfono: +(48-22) 661-54-00
    Fax: +(48-22) 661-54-34
    Servicio de información: +(48-22) 865-99-33
    Soporte técnico: +(48-22) 865-99-66

  • Portugal

    Microsoft Portugal MSFT, Lda.
    Teléfono: (351) 1 4409200
    Fax: (351) 1 4412101
    Soporte técnico:Soporte estándar: (351) 1 4409280/1/2/3
    Fax: (351) 1 4411655
    República de Irlanda
    Consulte Reino Unido

  • Región de Taiwán

    Microsoft Taiwan Corp.
    Teléfono: (886) (2) 504-3122
    Fax: (886) (2) 504-3121
    Soporte técnico: (886) (2) 508-9501

  • República Checa

    Microsoft s.r.o.
    Teléfono (+42) (2) 611 97 111
    Fax: (+42) (2) 611 97 100
    Soporte técnico: (+420) (2) 2150 3222

  • República de Eslovaquia

    Microsoft Slovakia s.r.o.
    Teléfono (+421) (7) 37 63 02
    Fax: (+421) (7) 37 66 71
    Soporte técnico: (+421) (7) 531 20 83

  • República Dominicana

    Consulte América Central

  • Rumanía

    Microsoft s.r.l.
    Teléfono: (+40) (1) 222 90 16
    Fax: (+40) (1) 222 90 12
    Soporte técnico: (+40) (1) 312 09 48

  • Rusia

    Microsoft A/O
    Centro de Información de Microsoft: (095)-913-99-88

  • Singapur

    Microsoft Singapore Pte Ltd
    Teléfono: (65) 337-6088
    Fax: (65) 337-6788
    Servicio al cliente:
    Teléfono: (65) 433-5488
    Fax: (65) 339-9958
    Servicios de soporte al producto:
    Teléfono: (65) 337-9946
    Fax: (65) 337-6700

  • Sudáfrica

    Microsoft South Africa
    Teléfono: (27) 11 445 0000
    Fax: (27) 11 445 0046
    Soporte técnico:(Gratuito): 0 802 11 11 04
    (Gratuito): (27) 11 445 0000
    Fax: (+27) 11 445-0343

  • Sudeste de África e Islas del Océano Índico

    Consulte Sudáfrica

  • Suecia

    Microsoft AB
    Teléfono: +46-(0)8-752 56 00
    Fax: +46-(0)8-750 51 58
    Soporte técnico: +46-(0)8-752 09 29
    Soporte de ventas: +46-(0)8-752 56 30
    Microsoft MSDL: +46-(0)8-750 47 42
    Microsoft FastTips: +46-(0)8-752 29 00
    (El documento 202020 de las FasTips contiene instrucciones detalladas)

  • Suiza

    Microsoft AG
    Teléfono: 01-839 61 11
    Fax: 01-831 08 69
    Precios, actualizaciones, etc.: 01/839 61 11
    Mapa de la documentación
    Teléfono: 155 59 00
    Fax: 064-224294, Microsoft Info-Service, Postfach, 8099 Zürich
    Soporte técnico estándar: Instalación y control:
    0848 80 - 2255
    Soporte técnico (en francés): 022-738 96 88
    Información general sobre soporte Microsoft en Europa central:
    FAX: 0049/2622/167006

  • Tadzhikistán

    Consulte Rusia

  • Tailandia

    Microsoft (Thailand) Limited
    Teléfono: (662) 266-3300
    Fax: (662) 266-3310
    Soporte al producto:
    Teléfono: (662) 613-7208 hasta 11
    Fax: (662) 613-7198

  • Turkmenistán

    Consulte Rusia
    Reino Unido
    Microsoft Limited
    Fax: (0870) 60 20 100
    Teléfono: (0870) 60 10 100
    Microsoft KeyData:
    (Boletín electrónico)
    (0870) 50 30 200 (hasta 28,8Kbaud, n, 8, 1)
    Microsoft KeyFax:
    (Servicio de información por fax según demanda)
    (0870) 50 30 100
    Soporte técnico: Aplicaciones de escritorio, Productos para el hogar, Sistemas de escritorio y hardware:
    0870 50 10 100
    Productos de programación:
    0870 50 10 200
    Sistemas de empresa: 0870 50 10 300
    Los clientes que llaman desde Irlanda deben marcar el 706 5353 para soporte técnico.
    Minicom Line 0870 50 30 400
    Información previa a ventas: Microsoft Connection (0345) 00 2000

  • Turquía

    Microsoft Turkey
    Teléfono: 90 (212) 258 59 98
    Fax: 90 (212) 258 59 54
    Soporte Hotline:
    Teléfono: 90 (212) 258 96 66
    Fax: 90 (212) 258 95 99
    Boletín electrónico: 90 (212) 227 93 90

  • Uruguay

    Soporte técnico: (598) (2) 77-4934

  • Uzbekistán

    Consulte Rusia

  • Venezuela

    Corporation MS 90 de Venezuela S.A.
    Otra información: (582) 265-9922
    Fax: (582) 265-0863
    Soporte técnico: (582) 993-6755


Si su pregunta no es urgente

Enviar un mensaje de correo electrónico a un ingeniero del soporte técnico de Microsoft

Con la Respuesta Web, puede enviar cuestiones convenientemente a través de correo electrónico. Esta opción es ideal para cuestiones detalladas o cuestiones con archivos adjuntos. Puede enviar cuestiones las 24 horas del día y recibirá una respuesta de un ingeniero dentro del primer día laborable. Para enviar su pregunta, vaya a http://www.microsoft.com/spanish/soporte, busque la opción Respuesta de Web y elija una de las siguientes opciones.

Respuesta estándar sin cargo en el Web

La cantidad de soporte sin cargo a la que tiene derecho se describe en el apartado anterior titulado Soporte estándar sin cargo.

Respuesta en el Web de pago por incidente

Si ha gastado su Soporte estándar sin cargo que se describe anteriormente, puede enviar su pregunta por una cuota de $95 USA.


Si su pregunta es urgente y más complicada

Llamar a un ingeniero del Soporte Técnico de Microsoft

El Soporte técnico de Microsoft proporciona un soporte telefónico sin cargo y por cuota. La cantidad de soporte sin cargo variará dependiendo de la edición del producto que haya adquirido, tal como se describe más adelante.

Soporte estándar sin cargo durante las horas de trabajo normales

Nota El soporte sin cargo está disponible sólo para versiones actuales.

  • Si ha adquirido Visual Studio Edición profesional, Visual Basic Edición empresarial o Visual C++ Edición empresarial

    Recibirá soporte sin cargo para un total de dos incidencias. Puede aplicar esas dos incidencias sin cargo a cualquiera de los productos que se incluyen en la edición que ha adquirido. Si desea información adicional, consulte la nota más abajo.

  • Si ha adquirido Visual Studio Edición empresarial

    Recibirá soporte sin cargo para un total de cuatro incidencias. Puede aplicar esas cuatro incidencias sin cargo a cualquiera de los productos que se incluyen en Visual Studio Edición empresarial. Si desea información adicional, consulte la nota más abajo.

  • Si ha adquirido Visual Basic Edición profesional, Visual C++ Edición profesional, Visual J++, Visual InterDev, Visual FoxPro o Visual Source Safe

    Recibirá soporte sin cargo para un total de dos incidencias para el producto que ha adquirido.

Para recibir soporte estándar sin cargo para los productos descritos anteriormente

Puede recibir Soporte estándar sin cargo a través de correo electrónico o por teléfono llamando al (425) 635-7012 entre las 6:00 A.M. y las 6:00 P.M., hora del Pacífico, de lunes a viernes, excepto festivos.

Nota Microsoft Internet Explorer, Windows NT Option Pack y FrontPage puede que se hayan incluido con uno de los productos que ha adquirido, sin embargo las opciones de soporte disponibles están separadas de las que se mencionaron anteriormente. Si tiene alguna pregunta con respecto a alguno de estos productos, consulte la sección de soporte técnico del archivo de Ayuda del producto individual.

  • Si ha adquirido Visual Basic Edición de aprendizaje, Visual C++ Edición estándar, Visual J++ Edición estándar o MSDN Library Edition

    Sólo recibirá soporte sin cargo para incidencias relacionadas con la configuración y la instalación. Para todas las demás cuestiones necesitará adquirir Soporte de pago por incidente tal y como se describe más adelante. Puede recibir Soporte estándar sin cargo por teléfono llamando al (425) 635-7033 entre las 6:00 A.M. y las 6:00 P.M., hora del Pacífico, de lunes a viernes, excepto festivos.

Soporte con cargo, para ayudar fuera del horario normal o como suplemento al soporte estándar

Si necesita ayuda fuera de tiempo, o si ha utilizado sus incidencias del Soporte estándar sin cargo que se describieron anteriormente, puede adquirir el Soporte de pago por incidencia por una cuota de $95 USA por incidencia llamando al (800) 936-5800. Las cuotas de soporte se facturarán con cargo a su tarjeta VISA, MasterCard o American Express. En EE.UU, puede llamar también al (900) 555-2300 para hacer que se apliquen las cuotas a su factura de teléfono.


Mantener siempre los archivos desprotegidos

Vea también

Cuando selecciona esta opción, el archivo se desprotege en su carpeta de trabajo. El archivo se copia en la base de datos de VSS, pero se deja desprotegido para el usuario, por lo que la base de datos se actualiza con cambios. Puede continuar trabajando con el archivo.

Nota Esta opción no se recomienda para entornos de equipos de programación.

Para mantener siempre los archivos desprotegidos:

  1. En el menú Herramientas de VSS, haga clic en Opciones para mostrar el cuadro de diálogo Opciones de SourceSafe.

  2. Haga clic en la ficha General, si no está ya seleccionada.

  3. Seleccione la casilla de verificación Mantener los archivos desprotegidos siempre.

  4. Haga clic en Aceptar.


Accesibilidad para personas con discapacidades

Microsoft se compromete a hacer sus productos y servicios más fáciles de usar para todos. Este archivo de Ayuda proporciona información sobre las siguientes características, productos y servicios, que hacen que Microsoft Windows, Microsoft Windows NT y Microsoft Visual Studio sean más accesibles para personas con discapacidades:

Servicios de Microsoft para personas sordas o con problemas de audición

Documentación de Microsoft en otros formatos

Utilidades de otras compañías para mejorar la accesibilidad

Personalizar Windows o Windows NT

Más información sobre accesibilidad

Nota La información de esta sección se aplica sólo a los usuarios que hayan adquirido Windows o Windows NT en EE.UU. Si ha adquirido Windows o Windows NT fuera de los EE.UU, su paquete de Windows contiene una tarjeta información de distribuidores que muestra los números de teléfono y direcciones de los Servicios de soporte de productos de Microsoft. Puede ponerse en contacto con su distribuidor para averiguar si el tipo de productos y servicios que se describen en este archivo de Ayuda están disponibles en su área.


Agregar archivos y carpetas utilizando arrastrar y colocar

Vea también

Para agregar un archivo o carpeta utilizando arrastrar y colocar:

  1. Abrir el Explorador de VSS y cambie su tamaño de forma que tenga espacio suficiente para ver el Explorador de Windows.

  2. Abrir el Explorador de Windows y cambie su tamaño de forma que tenga suficiente espacio para ver el Explorador de VSS.

  3. Seleccione uno o más archivos o carpetas en la vista Listas (en el panel de la derecha) del Explorador de Windows.

  4. Arrastre los archivos o carpetas seleccionados en el Explorador de VSS. Los archivos se agregarán al proyecto VSS. Las carpetas se agregarán como subproyectos del proyecto.


Agregar carpetas

Vea también

Puede agregar carpetas siguiendo los pasos que aparecen debajo o utilizando arrastrar y colocar. Vea Agregar archivos y carpetas utilizando arrastrar y colocar.

Para agregar una carpeta completa a VSS:

  1. Seleccione el proyecto al que desee agregar una carpeta.

  2. En el menú Archivo, haga clic en Agregar archivos para mostrar el cuadro de diálogo Agregar archivo.

  3. Seleccione una carpeta en la lista Carpetas.

  4. Haga clic en Agregar para mostrar el cuadro de diálogo Agregar carpeta.

  5. Escriba un comentario en el cuadro Comentario para describir el archivo o carpeta que está agregando.

  6. Si quiere incluir las subcarpetas, haga clic en Recursivo.

  7. Haga clic en Aceptar para agregar la carpeta con un comentario.

    — O bien —

    Haga clic en Cancelar para cancelar la operación y volver al cuadro de diálogo Agregar archivo. Haga clic en Cerrar.


Agregar múltiples archivos

Vea también

Puede agregar múltiples archivos a VSS siguiendo los pasos que aparecen debajo o utilizando arrastrar y colocar. Vea Agregar archivos y carpetas utilizando arrastrar y colocar.

Para agregar múltiples archivos a VSS:

  1. Seleccione el proyecto al que desee agregar los archivos.

  2. En el menú Archivo, haga clic en Agregar archivos para mostrar el cuadro de diálogo Agregar archivo.

  3. En la lista Unidades, seleccione la unidad en la que se encuentra el archivo.

  4. En la lista Carpetas, seleccione la carpeta en la que se encuentra el archivo.

  5. En la lista Mostrar archivos de tipo, seleccione un tipo de archivo. Es un paso opcional que se utiliza para filtrar la lista y mostrar una lista de tamaño más manejable.

  6. En la lista Nombre de archivo, haga clic en los archivos que quiere agregar mientras mantiene pulsada la tecla CTRL.

    Nota Para seleccionar todos los archivos mostrados, presione la tecla INICIO para ir al principio de la lista y, después, Mayús-Fin para ir al final. Este cuadro de diálogo sólo aceptará 256 caracteres.

    Los archivos que ya formen parte del proyecto actual no aparecerán en la lista Nombre de archivo.

  7. Haga clic en Agregar.

  8. VSS muestra un cuadro de diálogo en el que puede especificar un comentario. Active la casilla de verificación Aplicar el mismo comentario para todo para aplicar este comentario a todos los archivos que se están agregando; de lo contrario, el cuadro de diálogo se repetirá para cada archivo que haya seleccionado.

  9. Haga clic en Aceptar para agregar los archivos con un comentario o haga clic en Cancelar para cancelar la operación de Agregar archivos. VSS vuelve al cuadro de diálogo Agregar archivo.

  10. Haga clic en Cerrar.


Agregar un solo archivo

Vea también

Puede agregar un único archivo, múltiples archivos o carpetas a VSS. También puede agregar un archivo utilizando arrastrar y soltar. Vea Agregar archivos y carpetas utilizando arrastrar y colocar.

Para agregar un archivo o una carpeta:

  1. Seleccione el proyecto al que desee agregar los archivos.

  2. En el menú Archivo, haga clic en Agregar archivos para mostrar el cuadro de diálogo Agregar archivo.

  3. En la lista Unidades, seleccione la unidad en la que se encuentra el archivo.

  4. En la lista Carpetas, seleccione la carpeta en la que se encuentra el archivo.

  5. En la lista Mostrar archivos de tipo, seleccione un tipo de archivo. Es un paso opcional que se utiliza para filtrar la lista y mostrar una lista de tamaño más manejable.

  6. En la lista Nombre de archivo, seleccione un archivo y haga clic en Agregar para agregarlo a VSS.

    Nota Los archivos que ya formen parte del proyecto actual no aparecerán en la lista Nombre de archivo.

  7. VSS muestra un cuadro de diálogo en el que puede especificar un comentario. Introduzca un comentario aplicable, si existe, y haga clic en Aceptar.

  8. Haga clic en Cerrar para cerrar el cuadro de diálogo Agregar archivo.


Incluir subproyectos siempre

Vea también

Para incluir siempre subproyectos:

  1. En el menú Herramientas, haga clic en Opciones y después en la ficha General si aun no hay ninguna seleccionada.

  2. Seleccione la casilla de verificación Actuar recursivamente en los proyectos.

  3. Haga clic en Aceptar.


Agregar fin de línea a todos los archivos de texto

Vea también

Utilice esta opción para agregar un carácter de fin de línea siempre que VSS recupere un archivo de texto que no lo incluya. Algunos compiladores requieren que todos los archivos que compilan terminen con un carácter de fin de línea.

Para agregar fin de línea a todos los archivos de texto

  1. En el menú Herramientas de VSS, haga clic en Opciones para mostrar el cuadro de diálogo Opciones de SourceSafe.

  2. Haga clic en la ficha Archivos locales:

  3. Seleccione la casilla de verificación Agregar fin de línea a todos los archivos de texto.

  4. Haga clic en Aceptar.

VSS lee los caracteres de fin de línea del siguiente modo

  • RC — Macintosh

  • RC/AL — Macintosh/UNIX

  • AL — UNIX


Evitar la pregunta de inicio de sesión

Vea también

Cada vez que introduzca un comando desde la línea de comandos, VSS le preguntará su nombre de usuario y, si está configurada, por su contraseña. Si quiere evitar este paso puede realizar ciertas acciones basadas en su entorno.

Establecer la variable de entorno SSUSER con su nombre de usuario

En Windows NT y Windows 95, la interfaz de la línea de comandos pregunta al sistema operativo el nombre del usuario que ha iniciado la sesión. Si este nombre coincide con el nombre de un usuario presente en la base de datos de VSS, el usuario iniciará la sesión automáticamente en la bases de datos VSS. Si el nombre del usuario no coincide, la interfaz de línea de comandos utiliza otros métodos para determinar el nombre de usuario VSS, como preguntar el nombre de usuario cada vez que se ejecuta un comando.

Puede establecer la variable de entorno SSUSER en su ordenador para que su valor sea su nombre de usuario y evitar la pregunta de inicio de sesión cada vez que introduzca un comando desde la línea de comandos. Por ejemplo, el usuario Kim introduciría la siguiente instrucción desde la línea de comandos:

set ssuser=kim

Establecer SSUSER en el archivo Autoexec.bat

También puede incluir una línea similar a la del ejemplo anterior en el archivo Autoexec.bat de Windows 95, o configurarla en el panel de control Sistema de Windows NT. Si incluye esta línea en cualquier momento podrá cambiar a otro usuario escribiendo el comando SET SSUSER en el símbolo del sistema.

Nota Asegúrese de que no incluye ningún espacio en cualquiera de los lados del signo igual cuando introduzca el nombre del usuario.


Bifurcar archivos compartidos

Vea también

Al bifurcar un archivo se rompe el vínculo compartido, haciendo que el archivo de ese proyecto sea independiente de todos los demás proyectos.

Nota Para ver la historia de bifurcación de un archivo, haga clic en la ficha Rutas del comando Propiedades del menú Archivo.

Para bifurcar un archivo:

  1. Seleccione los archivos que quiera utilizar en el Explorador de VSS.

  2. En el menú SourceSafe, haga clic en Bifurcar para mostrar el cuadro de diálogo Bifurcar.

  3. Escriba un comentario que describa la bifurcación, si lo desea, en el cuadro Comentario.

  4. Haga clic en Aceptar.


Cancelar búsqueda

Vea también

Para cancelar una búsqueda:

  • En el menú Ver, haga clic en Cancelar búsqueda.


Comprobar hipervínculos en un proyecto Web

Vea también

Puede utilizar este comparando para comprobar los vínculos Web en sus archivos HTML, bien en los archivos de su carpeta de trabajo o bien en los del proyecto VSS. VSS comprueba los vínculos que saltan a otros archivos de su proyecto y los vínculos a páginas externas.

Los vínculos comprobados son etiquetas HTML, incluyendo la etiqueta <A HREF>. No se comprueban los vínculos con otras direcciones del Web creados mediante código como VBScript o Java.

Para comprobar los hipervínculos de un proyecto Web:

  1. Seleccione un proyecto de sitio Web. Los proyectos de sitio Web utilizan este icono: ( [image])

  2. En el menú Web, haga clic en Comprobar hipervínculos.

  3. Si desea comprobar los vínculos con páginas externas, haga clic en el cuadro Comprobar hipervínculos externos en World Wide Web.

  4. Haga clic en Aceptar.

    Cuando termina la comprobación, VSS muestra un cuadro de diálogo con tres cuadros de lista:

    • El cuadro superior muestra todos los archivos en los que se han encontrado errores.

    • El cuadro intermedio muestra los vínculos (saltos a otros archivos del proyecto Web) que parecen no ser válidos en el archivo seleccionado en el cuadro superior.

    • El cuadro inferior muestra los vínculos que se han encontrado y no se han comprobado.


Proteger archivos o proyectos

Vea también

Para proteger un archivo o proyecto, guardando los cambios

  1. Seleccione en el Explorador de VSS el elemento o los elementos que quiere proteger.

  2. En el menú SourceSafe, haga clic en Proteger para mostrar el cuadro de diálogo Proteger.

  3. Si lo desea, introduzca un comentario en el cuadro de diálogo Comentario que describa los cambios que ha realizado en el elemento.

  4. Haga clic en Aceptar.


Desproteger archivos o proyectos

Vea también

Nota Configure su carpeta de trabajo antes de utilizar este comando. Vea Cómo establecer una carpeta de trabajo para obtener más información.

Para desproteger un archivo o proyecto:

  1. Seleccione el elemento o los elementos que desee en el Explorador de VSS.

  2. En el menú SourceSafe, haga clic en Desproteger.

  3. Si aún no ha configurado una carpeta de trabajo, VSS le preguntará si desea hacerlo en este momento. Haga clic en Aceptar y configure su carpeta de trabajo.

  4. Si ha configurado las opciones para mostrar un cuadro de diálogo para el comando desproteger (utilizando la ficha Diálogos de comandos en el comando Opciones del menú Herramientas), VSS muestra el cuadro de diálogo Desproteger. Haga clic en Aceptar para desproteger el elemento o los elementos.

  5. VSS ubica el elemento o elementos en su carpeta de trabajo. Ahora puede modificar el elemento o los elementos.

Para obtener información acerca de cómo deshacer una desprotección en un archivo, vea:

  • Cómo proteger archivos o proyectos

  • Cómo deshacer una desprotección


Desproteger múltiples archivos

Vea también

Nota La desprotección múltiple no es posible ha menos que haya sido habilitada por el administrador de VSS.

De forma predeterminada, VSS impide que más de un usuario pueda desproteger el mismo archivo a la vez. Sin embargo, su Administrador VSS puede permitir que múltiples usuarios desprotejan un archivo simultáneamente.

Cuando se permiten varias desprotecciones, VSS mantiene un seguimiento de los usuarios que tienen el archivo desprotegido en un momento dado y compara los cambios realizados en el archivo cuando el usuario protege dichos cambios. En la mayoría de los casos, los usuarios pueden haber cambiado líneas diferentes de código en un archivo, de forma que VSS simplemente combina los cambios en la copia maestra del archivo. Sin embargo, si VSS detecta que dos usuarios han modificado la misma línea del archivo, VSS muestra un mensaje para alertar al usuario que protege los cambios de que resuelva los conflictos antes de continuar. Cuando esto sucede no se realiza la protección. El usuario que recibe el mensaje debería editar la copia local del archivo en la carpeta de trabajo del usuario para resolver los conflictos.


Cerrar una base de datos

Puesto que sólo se puede trabajar con una base de datos cada vez, para cerrar una base de datos puede abrir otra. Consulte Cómo abrir una base de datos de VSS existente. También puede salir de VSS para cerrar una base de datos.


Copyright

Sistema de desarrollo Microsoft® Visual Studio™ 6.0

La información contenida en este documento está sujeta a modificaciones sin previo aviso. Los nombre de las compañías, productos, personas, caracteres y datos que se mencionan aquí son ficticios y no representan a ningún individuo, compañía, producto o evento real, a menos que se indique lo contrario. El cumplimiento de todas las leyes aplicables al mouse es responsabilidad del usuario. Ninguna parte de este documento puede ser reproducida o transmitida de ninguna forma, ni por ningún medio, ya sea electrónico o mecánico, con ningún propósito, sin la previa autorización por escrito de Microsoft Corporation. Sin embargo, si su único medio de acceso es electrónico, se le garantiza el permiso para imprimir una copia.

Microsoft puede tener patentes, aplicaciones patentadas, marcas, mouse u otros derechos de propiedad intelectual que cubran el asunto que se trata en este documento. El suministro de este documento no le da ninguna licencia sobre esas patentes, marcas, mouse u otra propiedad intelectual, excepto lo que Microsoft proporcione en un acuerdo de licencia escrito.

© 1991-1998 Microsoft Corporation. Reservados todos los derechos.

MSDN, la Red de desarrollo de Microsoft.

Microsoft, MS, MS-DOS, MSN, ActiveX, DataTips, FoxPro, el diseño de la cabeza de Fox, IntelliSense, Developer Studio, J/Direct, Microsoft Press, Microsoft QuickBasic, PivotTable, Rushmore, Visual Basic, Visual C++, Visual FoxPro, Visual InterDev, Visual J++, Visual SourceSafe, Windows, Windows NT, Win32 y Win32s son marcas registradas o marcas de Microsoft Corporation en EE.UU. y otros países.

Java es una marca de Sun Microsystems, Inc.

MMX es una marca registrada de Intel Corporation.

TrueType es una marca registrada de Apple Computer, Inc.

Otros productos y nombres de compañías que se mencionan pueden ser marcas de sus respectivos propietarios.


Crear un mapa del sitio

Vea también

Los mapas de sitios cada vez son más populares como métodos de exploración a través de un sitio Web. Este comando le permite generar una lista de los archivos HTML de su proyecto Web. La lista se crea como un archivo HTML con vínculos a cada uno de los archivos que pertenecen al proyecto. Luego puede agregar el archivo resultante a su sitio Web y proporcionar así a los usuarios un método de navegación clásico.

Cada vez que ejecute este comando se creará un archivo totalmente nuevo. Es decir, este comando no compara el material nuevo con el antiguo y únicamente realiza cambios. Por tanto, si ha agregado alguna característica personal al archivo resultante, debería estar preparado para agregarla de nuevo cada vez que ejecute este comando, o utilizar tecnología como Archivos incluidos en el servidor para almacenarlo en un lugar independiente. Además, el HTML generado por este comando utiliza etiquetas HTML 2.0 bastante rudimentarias. Si quiere una página más personalizada, puede copiar los datos de la página generada por este comando o agregar directamente en ella etiquetas HTML más avanzadas.

Para crear un mapa de sitio de los archivos HTML:

  1. Seleccione un proyecto de sitio Web. Los proyectos de sitio Web utilizan este icono: ( [image])

  2. En el menú Web, haga clic en Crear mapa de sitios para mostrar el cuadro de diálogo Crear mapa de sitios.

  3. Haga clic en Aceptar.


Crear vínculos a archivos y rutas

Vea también

Al compartir un archivo se crean vínculos desde ese archivo a múltiples proyectos. Para obtener más información acerca de cómo compartir archivos, vea Compartir archivos. Al bifurcar un archivo se crean rutas diferentes en cada proyecto. Para obtener más información acerca de la bifurcación, consulte Bifurcar y compartir archivos y proyectos.

  • Para crear un vínculo de archivo, vea Cómo compartir archivos.

  • Para crear una ruta de archivo, vea Cómo bifurcar archivos compartidos.

Nota Para ver los proyectos que comparten un archivo, haga clic en la ficha Vínculos del comando Propiedades en el menú Archivo. Para ver la historia de bifurcación de un archivo, haga clic en la ficha Rutas del comando Propiedades del menú Archivo.


Personalizar los archivos SS.INI y SRCSAFE.INI

Vea también

Puede personalizar los archivos SS.INI y SRCSAFE.INI de dos formas diferentes, utilizando los cuadros de diálogo de opciones o un editor de textos.

Utilizando los cuadros de diálogo de opciones

Puede configurar la mayoría de las variables de inicialización de SS.INI directamente desde VSS, en el cuadro de diálogo Opciones del menú Herramientas. Sólo los administradores deberían configurar las variables de SRCSAFE.INI, utilizando para ello el cuadro de diálogo Opciones del Administrador de VSS. Cuando utilice el cuadro de diálogo Opciones, tenga en cuenta que VSS guarda los cambios en la memoria, pero no los escribe en el archivo hasta que abandona VSS o abre una base de datos diferente. Por tanto, si inicia una segunda sesión de VSS antes de abandonar la primera, los cambios aún no tendrán efecto.

Utilizando un editor de textos

Puede leer y modificar los archivos de inicialización con cualquier editor de texto. Hay un límite de 511 caracteres en cada línea del archivo de inicialización, aunque se puede limitar este máximo debido a requisitos de variables específicas (como las limitaciones de la ruta de proyecto).

Ubicación del archivo SS.INI

Normalmente, el archivo SS.INI se encuentra en la subcarpeta Users de la carpeta en la que se instaló VSS, por ejemplo, VSS\Users\NombreUsuario. Puede cambiar de lugar su archivo SS.INIm suponiendo que indique el cambio a VSS modificando adecuadamente el archivo Users.txt (consulte a su administrador de VSS).

El archivo SRCSAFE.INI suele encontrarse en la carpeta principal de VSS de la instalación del servidor.

Nota Las variables de inicialización configuradas en Ss.ini prevalecen sobre la configuración de Srcsafe.ini.

El formato

Hay tres clases de línea en Ss.ini y Srcsafe.ini.

  • Las variables de inicialización, que son las líneas funcionales, tienen el siguiente formato:
    Variable de inicialización = valor

    Las variables booleanas se pueden configurar con "Yes", "No", "True", or "False."

  • Los comentarios comienzan con un punto y coma:
    ; Aquí estoy, JP.

    VSS ignora todos los comentarios.

  • Los encabezados se muestran entre corchetes:
     [$/Word]

    La mayoría de los encabezados especifican las rutas de un determinado proyecto. Otros encabezados, como [Keyword Comments], se utilizan para propósitos específicos.

El orden de las variables contenidas en un archivo de inicialización no importa en absoluto; sin embargo, el encabezado bajo el cual se coloca una variable sí es importante. Si una variable se coloca bajo un encabezado incorrecto, por ejemplo, si una variable de propósito general se coloca bajo [Keyword Comments], será ignorada.

Ss.ini en múltiples plataformas

Si está ejecutando una instalación multiplataforma, puede que desee que ciertas variables tengan diferentes valores en las distintas plataformas o en distintos ordenadores. Por tanto, puede colocar una plataforma o un nombre de equipo entre paréntesis tras la variable para indicar que la variable se aplica sólo a esa plataforma. Por ejemplo:

Use_ReadOnly (WIN) = Yes
Comment_Editor (JOSE1)= c:\MSOFFICE\WINWORD\WINWORD.EXE

La configuración del primer ejemplo se aplica sólo bajo Microsoft Windows. La configuración del segundo ejemplo se aplica sólo a un ordenador llamado JOE1. Otras posibles configuraciones son Win, UNIX, UI, CL, NT, MAC y PC la última es una forma de hacer referencia a los sistemas operativos basados en Intel.

Cada variable de SRCSAFE.INI puede estar acompañada por un especificador de plataforma, es decir, un nombre de un ordenador, que aparecerá a continuación y entre paréntesis. Dicho especificador activa una variable para que tenga distintas configuraciones en plataformas diferentes. No todas las variables reconocen distintos nombres de ordenadores, pero muchas lo hacen. Sólo se permiten 10 especificadores de plataforma por usuario, o 10 por cada archivo SS.INI.

Las distintas versiones de VSS buscan diferentes especificadores. Por ejemplo, la interfaz VSS en un ordenador Windows NT busca los especificadores de plataforma en el siguiente orden:

JOSE1, NT, Win, PC, UI

Busca una variable establecida para el equipo de Jose llamado JOSE1; si no la encuentra, buscará Windows NT; después Win, luego PC, después UI y, por último, una variable sin ningún especificador de plataforma.

Sin embargo, puede anular esta configuración mediante la variable de entorno SSiniENV. Por ejemplo:

Set SSiniENV = Ragiv, MS-DOS, PC, CL

Hará que VSS busque las variables especificadas para Ragiv antes de buscar las de MS-DOS, PC, CL o las que no tienen especificador. Si las dos próximas líneas estuvieran en el archivo SRCSAFE.INI:

Data_Path (Ragiv) = R:\SS\DATA
Data_Path (Kim) = R:\SS2\DATA

VSS utilizaría la primera configuración e ignoraría la segunda. Si el valor de SSiniEnv fuera Kim, VSS utilizaría la segunda cadena e ignoraría la primera. Así, asignando un valor adecuado a la variable SSiniENV, puede controlar qué variable Data_Path leerá VSS y que carpeta DATA se utilizará.


Personalizar Windows o Windows NT

Hay muchas maneras de personalizar Windows o Windows NT para hacer que su equipo sea más accesible.

  • Comenzando con Windows 95, las características de accesibilidad están incorporadas en Windows. Esas características son útiles para individuos que tengan dificultad al escribir o usar un mouse, tengan una disfunción visual moderada o que sean sordas o con deficiencias de audición. Las características se pueden instalar durante la instalación, o se pueden agregar después desde los discos de instalación de Windows 95. Busque "accesibilidad" en el Índice de Ayuda de Windows si desea información sobre la instalación y utilización de esas características.

  • Muchas de las características que hacen que Windows 95 sea más accesible se pueden agregar a Windows NT, versiones anteriores de Microsoft Windows y MS-DOS mediante los Access Packs. Puede descargar esos archivos mediante módem, puede solicitarlos en discos a Microsoft.

  • También puede usar el Panel de control y otras características incorporadas para ajustar la apariencia y comportamiento de Windows o Windows NT para adaptar las variaciones de visión y las capacidades motoras. Entre ellas se incluyen los ajustes de colores y tamaños, el volumen de sonido y el comportamiento del mouse y el teclado.

  • Las distribuciones de teclado Dvrak hacen que los caracteres que se escriben más frecuentemente en un teclado sean más accesibles si tiene dificultades para usa la distribución "QWERTY" estándar. Hay tres distribuciones Dvorak: una para usuarios con dos manos, una para personas que escriben sólo con la mano izquierda y otra para personas que escriben sólo con la mano derecha. No necesita adquirir ningún equipo especial para usar estas características.

Las características específicas disponibles, ya estén incorporadas o deban obtenerse de manera separada, dependen del sistema operativo que esté usando.

Para obtener documentación completa sobre las características de accesibilidad disponibles en el sistema operativo que está usando, obtenga las notas de la aplicación apropiada que se enumeran más adelante. Las características de accesibilidad también están documentadas en el Microsoft Windows 95 Resource Kit y el Microsoft Windows NT Resource Kit.

Archivos que debe descargar o pedir

Puede obtener esos archivos descargándolos con su módem, o puede solicitarlos en discos por teléfono. A esta lista de archivos le sigue inmediatamente información específica sobre la descarga y solicitud de esos archivos.

Estos archivos incluyen:

  • Notas de aplicación que proporciona una documentación más completa sobre las maneras de personalizar Windows y Windows NT

  • Los Access Packs y las distribuciones de teclado Dvorak proporcionan características adicionales para versiones de Windows o Windows NT en la que todavía no se incluyen.
Para | Necesita
Notas de aplicación para Microsoft Windows 95 | Ww1062.exe
Notas de aplicación para Microsoft Windows NT 3.1 y 3.5 (incluye Access Pack para Microsof Windows NT) | Wn0789.exe
Notas de aplicación para Microsoft Windows para Trabajo en Grupo 3.1 | Wg0788.txt
Notas de aplicación para Microsoft Windows 3,1 | Ww0787.txt
Notas de aplicación para Microsoft Windows 3.0 | Ww0786.txt
Access Pack para Microsoft Windows 3.0 y 3.1 | Accp.exe
Distribuciones de teclado Dvorak para personas con una mano (ya incluidas en Windows NT 3.5 y superiores) | Ga0650.exe (La mayoría de los servicios de red), Ga0650.zip (Microsoft Download Service)

Para descargar por módem los paquetes de acceso, las notas de la aplicación y formatos de teclado alternativos

Si tiene un módem, puede descargar esos archivos desde los siguientes servicios de red:

  • Sitio Web de Microsoft en Internet. En la página de inicio www.microsoft.com/spain, haga clic en Soporte. Haga clic en Knowledge Base y seleccione MS-DOS como producto. Escriba KBFILE GA0650.EXE y haga clic en Buscar. Abra el artículo y haga clic en el botón para descargar el archivo.

  • Servidores Internet de Microsoft, ftp.microsoft.com y gopher.microsoft.com, en /softlib/mslfiles

  • MSN™, el servicio en línea Microsoft Network

  • CompuServe®, escriba GO MSL.

  • Genie™

  • MSDL (Microsoft Download Service), al que se puede acceder llamando al (206) 936-6735 a cualquier hora excepto entre la 1:00 A.M. y la 2:30 A.M., hora del Pacífico.

  • MSDL admite velocidades de transmisión de 1200, 2400, 9600, 14400 o 28800 (V.32 y V.42), con 8 bits de datos, sin paridad y 1 bit de parada.

  • Varios boletines electrónicos (como los servicios de boletín electrónico de la red de la Asociación de Grupos de usuarios de PC)

Para pedir por teléfono los paquetes de acceso, las notas de la aplicación y formatos de teclado alternativos en disquetes

Si no tiene módem, dentro de EE.UU puede solicitar los Access Packs, las Notas de aplicación y las Distribuciones alternativas en discos llamando al Microsoft Sales Information Center, al (800) 426-9400 (voz) o al (800) 892-5234 (teléfono-texto).

En Canadá, puede llamar al (905) 568-3503 o al (905) 568-9641 (teléfono-texto).


Eliminar un archivo o proyecto

Vea también

Después de eliminar un archivo o subproyecto de VSS, se puede recuperar hasta el momento en que se purga o se destruye.

Para eliminar un archivo o proyecto de VSS:

  1. Seleccione el archivo o un proyecto en el Explorador de VSS.

  2. En el menú Archivo, haga clic en Eliminar para mostrar el cuadro de diálogo Eliminar.

  3. Haga clic en Aceptar.


Distribuir archivos Web a un servidor

Vea también

Cuando haya terminado el desarrollo y las pruebas de sus páginas Web, puede utilizar el comando Distribuir para copiar los archivos del proyecto n un servidor Web. La ubicación de dicho servidor es una carpeta o un sitio FTP especificado por el administrador de VSS. Cuando elija el comando Distribuir, se copiará el contenido del proyecto actual a dicha ubicación.

Para distribuir los archivos Web en un servidor:

  1. Seleccione un proyecto de sitio Web. Los proyectos de sitio Web utilizan este icono: ( [image])

  2. En el menú Archivo, haga clic en Distribuir para mostrar el cuadro de diálogo Distribuir.

  3. Haga clic en Aceptar.


Diseñar y organizar proyectos

VSS no impone el criterio de diseño de proyectos. Sin embargo, para asegurar que su proyecto está organizado cuidadosamente y se ejecuta eficientemente, considere las siguientes instrucciones de diseño:

  • Puede que quiera hacer que cada carpeta existente en su sistema operativo sea un proyecto de VSS. Cada subcarpeta puede ser un subproyecto. Por ejemplo, si almacena código en una carpeta con tres subcarpetas de su sistema operativo, cree un proyecto con tres subproyectos dentro de VSS.

  • Divida los archivos de manera lógica entre los proyectos y e subproyectos. VSS controla hasta 8.000 archivos en un proyecto, pero la división de grandes proyectos en subproyectos hace que los archivos sean más fáciles de administrar.

  • No agregue el mismo archivo de manera separada a varios proyectos si desea que se apliquen los mismos cambios en proyectos separados. En lugar de eso, comparta el archivo entre los proyectos.

  • No cree un nuevo proyecto si sólo está moviendo desde una nueva versión de un proyecto. Puede etiquetar el proyecto para marcar la versión.

  • Coloque todos los archivos necesarios para generar un programa en un proyecto de VSS. Esos archivos suelen ser de código, pero también pueden incluirse archivos de generación, bibliotecas, mapas de bits, bibliotecas de vínculos dinámicos y programas subsidiarios.

  • No mantenga archivos ejecutable en proyectos de VSS a menos que se tarde mucho tiempo en generarlos. No gaste espacio en VSS cuando pueda compilar y vincular un archivo ejecutable a petición.

  • Asegúrese que el proyecto sólo contiene el código comprobado más reciente que se compila y se ejecuta. Cuando esto no sea posible algunas veces, especialmente en los comienzos de un proyecto, una buena regla de trabajo puede ser que nadie debería proteger código en VSS a menos que se compile y se ejecute. Si se sigue esta regla, cualquiera puede obtener un proyecto, compilarlo y ver el estado del proyecto en cualquier momento.

  • Almacene sus archivos de documentación, iconos, archivos gráficos y otros archivos en proyectos de VSS.

  • En cualquier proyecto multiusuario, no se debería desproteger ningún archivo durante más tiempo del que lleva hacerlo y probar los cambios en el archivo. Si un archivo se desprotege durante muchos días, puede que otras personas no puedan usar los cambios que se han realizado en el archivo.

  • Cuando anide subproyectos, tenga en cuenta el límite que se admite de 15 niveles de anidamiento. También se puede restringir debido a la longitud de la cadena de la ruta de acceso del proyecto, que no puede sobrepasar los 259 caracteres.


Destruir un archivo o proyecto

Vea también

Advertencia Cuando destruye un archivo permanentemente no se puede recuperar desde VSS. Se perderá toda la información anterior del historial de ese archivo.

Para destruir un archivo o proyecto:

  1. Seleccione el archivo o un proyecto en el Explorador de VSS.

  2. En el menú Archivo, haga clic en Eliminar para mostrar el cuadro de diálogo Eliminar.

  3. Seleccione la casilla de verificación Destruir definitivamente.

  4. Haga clic en Aceptar.


Deshabilitar la entrada de datos

Vea también

Si está creando un archivo de proceso por lotes que contiene una serie de comandos VSS (para que se ejecute por la noche, por ejemplo) no querrá que el programa se detenga para preguntarle algo. Hay tres parámetros de la línea de comandos que puede utilizar juntos para asegurarse de que VSS no pide datos a un usuario.

Por defecto, VSS solicita un comentario en muchos comandos, como Agregar o Proteger. Sin embargo, puede utilizar la opción -c de las tres formas siguientes para evitar estas preguntas.

Comando | Acción
-c- | No se agregan comentarios.
"-cHola" | Utiliza la cadena Hola como comentario.
-c@COMMENT.TXT | Utiliza el contenido del archivo Comment.txt como comentario.

Además de solicitar comentarios, VSS hace a menudo preguntas que hay que responder con sí o no. Puede utilizar la opción -i para evitar estas preguntas, como en los siguientes ejemplos.

Comando | Acción
-i-y | Responde Yes automáticamente a todas las preguntas Yes/No
-i-n | Responde No automáticamente a todas las preguntas Yes/No
-I- | Utiliza el valor predeterminado.

VSS también puede solicitar un nombre de inicio de sesión. Si recibe esta pregunta, puede utilizar la opción -y para proporcionar la información necesaria.


Arrastrar y colocar

Vea también

Hay muchas operaciones de arrastrar y colocar disponibles en VSS. Por ejemplo, puede arrastrar un archivo desde el panel Archivos hasta el panel Proyectos para compartirlo rápidamente con otro proyecto. Si mantiene presionada la tecla CTRL mientras arrastra un archivo en un proyecto, puede compartir e inmediatamente bifurcar el archivo.

También puede arrastrar un archivo desde el Explorador de Windows hasta el Explorador de VSS para agregarlo a un proyecto, o arrastrar una carpeta desde el Explorador de Windows hasta el Explorador de VSS para crear un nuevo proyecto bajo el proyecto en el que coloque la carpeta. También puede seleccionar varios archivos o varias carpetas y hacer lo mismo con varios elementos a la vez.

Si arrastra un archivo desprotegido desde el Explorador de Windows hasta el proyecto de VSS que contiene ese archivo, protegerá el archivo. Si el archivo no está desprotegido, VSS mostrará un error. También puede arrastrar la carpeta de trabajo de un proyecto desde el Explorador de Windows hasta el proyecto VSS adecuado para proteger todos los archivos de esa carpeta que estén desprotegidos.

Por último, si arrastra un acceso directo de Windows en VSS, VSS le permitirá guardar el acceso directo en VSS o el archivo al que apunta el acceso directo.


Editar archivos

Vea también

Utilice el comando Modificar archivo para desproteger y modificar un archivo en una sola operación. VSS muestra automáticamente el archivo en el editor asociado a ese tipo de archivo. Por ejemplo, un archivo cuyo tipo de archivo sea .doc estará asociado con Microsoft Word, por lo que se abrirá en Word. Para seleccionar un editor diferente, haga clic en el botón Avanzado del cuadro de diálogo Archivo.

Para modificar un archivo:

  1. Seleccione el archivo que quiera utilizar en el Explorador de VSS.

  2. En el menú Editar, haga clic en Editar archivo para mostrar el cuadro de diálogo Archivo.

  3. Haga clic en la casilla Desproteger este archivo y editarlo en su carpeta de trabajo, si aún no está seleccionada.

  4. Si desea especificar un editor, haga clic en el botón Avanzado para poder hacerlo en el último cuadro de texto.

  5. Haga clic en Aceptar para mostrar el cuadro de diálogo Desproteger para los proyectos y los archivos.

  6. Especifique su carpeta de trabajo en el cuadro A.

    — O bien—

    Haga clic en Examinar para buscar y seleccionar una carpeta de trabajo.

  7. Haga clic en Aceptar.


Editar propiedades

Vea también

Para editar las propiedades de un archivo:

  1. En el Explorador de VSS, seleccione el elemento cuyas propiedades desea cambiar.

  2. En el menú Archivo, haga clic en Propiedades y luego en la ficha General si aun no hay ninguna seleccionada.

  3. Realice sus cambios.

  4. Haga clic en Cerrar cuando haya terminado de realizar sus cambios.


Expandir palabras clave

Vea también

Nota La expansión de palabras clave está desactivada por defecto para todos los archivos. Consulte a su administrador de VSS para habilitar la expansión de palabras clave.

La expansión de palabras clave hace referencia a la capacidad de VSS para colocar determinada información directamente en su archivo para crear un encabezado de archivo por usted.

Para ello, coloque ciertas palabras clave en el texto de su archivo, en forma de comentarios para que no tengan efecto sobre el código. Cuando agregue o proteja el archivo, VSS buscará dichas palabras clave y colocará la información relevante después de ellas. Palabras clave de SourceSafe

En este tema se describe la forma tradicional que tiene VSS de expandir las palabras clave. Con VSS, también puede expandir palabras clave de otra forma que hace que utilizar palabras clave con archivos HTML sea mucho más útil. Consulte Usar la expansión de palabras clave en archivos HTML para más información.

Palabras clave de VSS

La siguiente tabla es una lista de todas las palabras clave de VSS. Algunas de las palabras clave son redundantes, ya sea por comodidad o por compatibilidad con otros sistemas de control de versiones, como RCS.

Nota Las palabras clave distinguen entre mayúsculas y minúsculas, así que tenga cuidado y coloque las mayúsculas correctamente.

Para expandir las palabras clave:

Escriba esta palabra clave | Para agregar lo siguiente
$Archive: $ | ubicación del archivo de VSS
$Author: $ | Último usuario que ha modificado el archivo
$Date: $ | Fecha y hora de la última protección
$Header: $ | Archivo de registro de operaciones, revisión, fecha, autor
$History: $ | Historial del archivo, formato VSS
$JustDate: $ | Fecha, sin la hora.
$Log: $ | Historial del archivo, formato RCS
$Logfile: $ | Igual que Archive
$Modtime: $ | Fecha y hora de la última modificación
$Revision: $ | Número de la versión de VSS
$Workfile: $ | Nombre de archivo
$NoKeywords: $ | No expandir las palabras clave que aparecen a continuación

Por ejemplo, podría colocar lo siguiente en un archivo:

$Revision: $

Sobre la protección, VSS podría reemplazarlo con:

$Revision: 23 $

La próxima vez que proteja el archivo, el 23 se reemplazará con un 24 y así sucesivamente. Sin ejecutar VSS, siempre puede examinar la parte superior del archivo para ver qué versión es su copia del archivo.


Obtener más rápido

Gracias a las capacidades mejoradas de VSS, puede realizar una operación Obtener dos veces más rápido que en versiones anteriores de VSS.

Para aprovecharse de la característica de Obtener más rápido de VSS, primero debe hacer que el administrador de VSS ejecute la utilidad DDUPD. Consulte Usar DDUPD para aprovechar las mejoras de rendimiento para obtener más información.

Cuando hace un Obtener, Desproteger, Distribuir o cualquier otra operación que coloca una copia de un archivo en su unidad local, se crea un archivo vssver.scc (o se actualiza sí ya existe uno) en su carpeta de trabajo. Hay un vssver.scc para todos los archivos de esa carpeta. Vssver.scc contiene información necesaria para identificar el archivo local, de forma que VSS determine qué archivos han cambiado y cuáles no.

Nota Si elimina el archivo vssver.scc, no ocurrirá nada excepto que sus nuevos comandos Obtener serán un poco más lentes y se creará otro archivo vssver.scc. El comando Diferencias del proyecto ignora al archivo vssver.scc, por lo que no se mostrará como un archivo a Agregar a un proyecto de VSS.


Símbolos de la lista de archivos

Vea también

Los símbolos que aparecen en la siguiente tabla se utilizan en la lista de archivos del Explorador de VSS.

Símbolos de la lista de archivos del Explorador de VSS

Símbolo | Descripción
 | Archivo
 | archivo desprotegido
 | Archivo desprotegido para múltiples usuarios
 | Archivo compartido
 | Archivo desprotegido en modo exclusivo
 | Archivo fijado a una determinada versión
 | Archivo compartido, desprotegido
 | Archivo compartido, desprotegido en modo exclusivo


Formatear palabras clave

Vea también

De manera predeterminada, VSS reemplaza el espacio entre una palabra clave y el signo de moneda ($) siguiente con el valor que ha especificado. Así se dificulta, sin embargo, la creación de una presentación en columnas atractiva.

Para fijar archivos, puede colocar dos puntos en lugar de uno tras la palabra clave y después agregar la cantidad de espacio que desee que se muestre. Esto indica a VSS que el signo de moneda que sigue a la palabra clave esté exactamente donde lo desea: VSS agrega espacios en blanco o trunca el valor para asegurarse de que las columnas permanecen intactas.

Archivos binarios

Además de crear columnas atractivas, esta característica es muy útil cuando desea incrustar información de palabra clave en archivos binarios (como archivos ejecutables), donde la longitud exacta de los datos es importante.

Por ejemplo:

$Revision::     $

VSS expande la palabra clave con el número de versión del archivo y conserva el espacio adicional que agregó dentro del carácter símbolo de moneda de forma que la columna del número de revisión mantenga su ancho.

Dar formato a las palabras clave History Log

Las palabras clave History y Log indican a VSS que coloque información del historial tras la palabra clave. VSS coloca el nombre del archivo entre el signo de dos puntos y el signo de moneda; en las líneas siguientes a la palabra clave, coloca la última entrada del historial del archivo.

Para asegurarse de que el historial se lee como un comentario (y que el código siga siendo compilable), el administrador de VSS puede definir caracteres de comentario que VSS coloca antes y después de las líneas de historial y de registro.

Cada extensión de archivo se asocia con una cadena que se coloca delante de cada línea, seguida opcionalmente de una cadena que se coloca tras cada línea. Ambas cadenas están entre comillas, separadas por comas.

Importante Si no se especifica ningún comentario de palabras clave, se asumen los siguientes comentarios:

*.asm = "; "

*.bas = "rem "

*.bat = "rem "

*.s = "; "

<Todos los demás> = "* "

Suponga que el administrador no tiene una configuración para *.c en el archivo SRCSAFE.INI. VSS utiliza su configuración predeterminada, que es un asterisco. Podría después colocar lo siguiente dentro del encabezado del archivo Ss.ini:

/*
 * $History: $
 */

Expandiendo esto, VSS colocaría un asterisco delante de cada línea y nada después. El archivo resultante, tras agregarlo a VSS, podría aparecer como el siguiente.

/*
 * $History: IDRANGE.TXT $
 *
 * ***** Versión 1 *****
 * Usuario:mariaj Fecha:8/01/92 Hora:11:02
 * Creado
 * Comentario: Intervalos definidos para Id.
 */


Obtener versión anterior

Vea también

Nota Cuando se realiza un Obtener archivo, el archivo se coloca en su carpeta de trabajo con el tipo de sólo lectura: cualquier modificación que realice en el archivo en este punto no se guarda en el proyecto.

Para obtener una versión anterior de un archivo o proyecto:

  1. Seleccione el elemento del cual desea ver una copia anterior.

  2. En el menú Herramientas, haga clic en Mostrar historial para mostrar el cuadro de diálogo Opciones de historial.

  3. Haga clic en Aceptar para mostrar el cuadro de diálogo Historial.

  4. Seleccione la versión del elemento del cual desea una copia.

  5. Haga clic en Obtener para mostrar el cuadro de diálogo Obtener.

  6. Si aún no ha configurado una carpeta de trabajo, VSS le preguntará si desea hacerlo en este momento. Haga clic en Aceptar y configure su carpeta de trabajo.

  7. Haga clic en Aceptar del cuadro de diálogo Obtener. El elemento seleccionado se copia entonces el proyecto actual a su carpeta de trabajo.


Obtener la última versión

Vea también

Nota Cuando se realiza un Obtener archivo, el archivo se coloca en su carpeta de trabajo con el tipo de sólo lectura: cualquier modificación que realice en el archivo en este punto no se guarda en el proyecto.

Para obtener la versión más reciente de un archivo o proyecto:

  1. Seleccione el elemento o los elementos que desee. Puede seleccionar un archivo, varios archivo o un proyecto completo.

  2. En el menú SourceSafe, haga clic en Obtener la última versión.

  3. Si aún no ha configurado una carpeta de trabajo, VSS le preguntará si desea hacerlo en este momento. Haga clic en Aceptar y configure su carpeta de trabajo.

  4. Si ha especificado en las opciones que se muestre el cuadro de diálogo Obtener la última versión, VSS muestra el cuadro de diálogo. Haga clic en Aceptar para obtener el elemento seleccionado. El elemento seleccionado se copia del proyecto actual a su carpeta de trabajo.


Cómo trabajar con el Explorador

Para aprender más cosas sobre cómo trabajar con los archivos y proyectos en el Explorador de VSS, vea los siguientes temas:

  • Arrastrar y colocar

  • Símbolos de la lista de Archivos

  • Símbolos de la lista de Proyectos

  • Actualizar la vista Lista

  • Cambiar el tamaño de la vista Listas

  • Botón secundario del mouse

  • Ordenar la vista Listas

  • Botones de comando de la barra de herramientas


Combinar archivos bifurcados

Vea también

Para combinar archivos:

  1. Seleccione el archivo o proyecto que desee en el Explorador de VSS.

  2. En el menú SourceSafe, haga clic en Combinar bifurcaciones para mostrar el cuadro de diálogo Combinar con.

  3. En el cuadro Proyectos, seleccione el proyecto que tiene la versión del archivo desde la que desea combinar cambios.

  4. Haga clic en Combinar para mostrar el cuadro de diálogo Comentario.

  5. Si lo desea, escriba un comentario.

  6. Haga clic en Aceptar.

Nota Si utiliza la función Buscar durante una combinación visual, sólo se buscará en uno de los tres paneles de la combinación visual, en el panel donde está el cursor.


Documentación de Microsoft en otros formatos

Además de los formularios estándar de la documentación, muchos productos Microsoft están también disponibles en otros formatos para hacerlos más accesibles.

Muchos documentos de Visual Studio 6.0 están disponibles también en formato de visor en pantalla, o en papel. Si tiene dificultades para leer o manipular documentación impresa, puede obtener muchas publicaciones de Microsoft de Recording for the Blind & Dyslexic, Inc. Recording for the Blind & Dyslexic distribuye esos documentos a miembros registrados que reúnan las condiciones de su servicio de distribución, bien sobre casetes de audio o sobre discos flexibles. La colección de Recording for the Blind & Dyslexic contiene más de 80.000 títulos, incluyendo la documentación de productos y libros de Microsoft Press.

Puede ponerse en contacto con Recording for the Blind & Dyslexis en las siguientes direcciones o números de teléfono si desea información sobre la reunión de condiciones y disponibilidad de documentación y libros de productos Microsoft de Microsoft Press:

Recording for the Blind & Dyslexic, Inc.

20 Roszel Road, Princeton

NJ 08540

Teléfono:(609) 452-0606

Fax:(609) 987-8116

Sitio Web:http://www.rfbd.org


Servicios de Microsoft para personas sordas o con problemas de oído

Si usted es sordo o tiene problemas de oído, hay disponible un acceso completo a los servicios de productos Microsoft y al cliente a través del servicio de teléfono-texto (TT/TDD).

Información de ventas

Puede ponerse en contacto con el Centro de información de ventas de Microsoft mediante un teléfono-texto llamando al (800) 892-5234 entre las 6:30 A.M. y las 5:30 P.M, hora del Pacífico.

Asistencia técnica

Para asistencia técnica en EE.UU, puede ponerse en contacto con la Red de soporte Microsoft mediante un teléfono-texto llamando al (206) 635-4948 entre las 6:00 A.M y las 6:00 P.M, hora del Pacífico, de lunes a viernes, excepto festivos. En Canadá, marque el (905) 568-9641 entre las 8:00 A.M. y las 8:00 P.M, hora de la costa Este, de lunes a viernes, excepto festivos. Los servicios de soporte de Microsoft están sujetos a los precios, términos y condiciones de Microsoft en el lugar y hora en que se utiliza el servicio.


Más información sobre accesibilidad

Otros productos, servicios y recursos están disponibles a través de Microsoft y otras organizaciones.

Servicios y productos alternativos de Microsoft para personas con discapacidades

Si desea más información, póngase en contacto con:

Microsoft Sales Information Center
One Microsoft Way
Redmond, WA 98052-6393 		Sitio Web:
Teléfono de voz:Teléfono-texto: 		http://www.microsoft.com
(800) 426-9400
(800) 892-5234

Directorios de productos para PC que ayudan a personas con discapacidades

El Trace R&D Center de la Universidad de Wisconsin-Madison produce un libro y un disco compacto que describe productos que ayudan a las personas con discapacidades a usar computadoras. El libro, titulado Trace ResourceBook, proporciona descripciones y fotografías sobre unos 2000 productos. El disco compacto, titulado CO-NET CD, proporciona una base de datos de más de 18.000 productos y otra información para personas con discapacidades. Se publica dos veces por año.

Para obtener esos directorios, póngase en contacto con:

Trace R&D Center
University of Wisconsin
S-151 Waisman Center
1500 Highland Avenue
Madison, WI 53705-2280 		Sitio Web:
Fax:
 http://trace.wisc.edu
(608) 262-8848

Referencias a programas de tecnología de ayuda y evaluadores entrenados

Si desea información general y recomendaciones sobre cómo pueden ayudar las computadoras a necesidades específicas, debería consultar con un evaluador capacitado. Un programa de asistencia tecnológica de su área proporcionará referencias a los programas y servicios que están disponibles para usted.

Para localizar el programa de asistencia tecnológica más cercano, póngase en contacto con:

Sistema de Información Nacional
Universidad de Carolina del Sur
Centro para las Discapacidades de desarrollo
Columbia, SC 29208 		Teléfono Voz/texto:
Fax: 		(803) 935-5231
(803) 935-5059


Mover archivos

Vea también

La única manera de mover un archivo es compartirlo con el nuevo proyecto primario, y eliminar o destruir después el archivo en el proyecto original. Se mantendrá el historial del archivo. No puede mover archivos individuales con el comando Mover.

Para mover un archivo:

  1. Seleccione el archivo que quiera utilizar en el Explorador de VSS.

  2. En el menú Archivo, haga clic en Mover para mostrar el cuadro de diálogo Mover.

  3. Haga clic en la nueva ubicación del archivo.

  4. Haga clic en Aceptar.


Mover proyectos

Vea también

Para mover un subproyecto a un proyecto primario diferente:

  1. En la vista del proyecto del Explorador de VSS, haga clic en el subproyecto que desee mover.

  2. En el menú Archivo, haga clic en Mover para mostrar el cuadro de diálogo Mover.

  3. Haga clic en la nueva ubicación del subproyecto.

  4. Haga clic en Aceptar.


Abrir una base de datos existente

Vea también

Cuando ejecuta VSS, debe conectase a una base de datos de VSS donde se almacenan sus archivos. Debería ocurrir automáticamente, pero si no ocurre o si necesita conectarse a una base de datos diferente, siga los pasos que se describen a continuación. Si no ha establecido una base de datos, póngase en contacto con el administrador de VSS.

Nota Sin nunca anteriormente ha abierto una base de datos, desde el cuadro de diálogo Inicio de sesión en VSS, haga clic en Examinar para buscar una base de datos existente y después haga clic en Aceptar.

Para abrir una base de datos existente desde dentro de VSS:

  1. En el menú Archivo, haga clic en Abrir base de datos de SourceSafe para mostrar el cuadro de diálogo Abrir base de datos de SourceSafe.

  2. Seleccione una base de datos en la lista Bases de datos disponibles.

    — O bien —

    Para buscar una base de datos existente, haga clic en Examinar. Tras localizar la base de datos, seleccione su archivo SRCSAFE.INI, y haga clic en Abrir.

    Nota Si la base de datos que desea no está en la lista Bases de datos disponibles, o no puede buscarla mediante Examinar, consulte con el administrador de VSS.

  3. Haga clic en Abrir del cuadro de diálogo Abrir base de datos de SourceSafe.


Optimizar el rendimiento

Vea también

La instalación predeterminada de VSS, si bien es fácil de crear y utilizar, no está necesariamente optimizada en cuanto a rendimiento. Por tanto, VSS proporciona dos formas de personalizar su sistema para aumentar el rendimiento:

  • Copie tanto como sea posible de la red a su unidad de disco. Este cambio es extremadamente útil para todos los usuarios de la red, pero para los usuarios de Macintosh en redes de PC es esencial. Puede usar el programa Netsetup.exe de VSS (en el servidor de VSS) para copiar los archivos ejecutables necesarios en su equipo local.

  • Ajuste los archivos de inicialización para conseguir un mejor rendimiento. La mayor parte de las mejoras, descritas más adelante en Optimizaciones generales, implican compromisos de varios órdenes, como desactivar ciertas clases de funcionalidad. Ninguna de estas optimizaciones proporciona tanto beneficio como las medidas que se describen en la lista siguiente.

Para optimizar el rendimiento en VSS

Establezca las siguientes variables del archivo Ss.ini o Srcsafe.ini:

  • Diff_Ignore (PC) = c-e-s-w-

    Indica a VSS que no pase por alto las diferencias de fin de línea, lo que acelera la comparación. De manera predeterminada, VSS pasa por alto las diferencias de fin de línea, lo que hace mucho más lento el algoritmo.

  • CP_OnSelection = No

    Desactiva la selección de un proyecto a medida que utiliza el mouse (ratón) o las teclas de dirección para moverse por la lista de proyectos. Si establece esta variable de inicialización a No, debe utilizar la tecla ENTRAR o hacer doble clic para establecer su proyecto actual.

Optimizaciones generales

Puede configurar estas opciones en la ficha Archivos locales y la ficha General del cuadro de diálogo Opciones, en el menú Herramientas.

  • Copiar los archivos de claves expandidas a la carpeta de trabajo

    Útil si emplea expansión de palabras clave. Si no selecciona esta casilla de verificación, puede que la velocidad de VSS sea mayor, ya que VSS no obtendrá un archivo después de protegerlo.

  • Comparar archivos por

    Controla cómo determina VSS si ya tiene la última copia de un archivo en su carpeta de trabajo. La opción Hora a veces no se comporta según lo previsto cuando intenta obtener versiones anteriores. A veces la solución consiste en eliminar su copia local para forzar una operación Obtener.

  • Carpeta para archivos temporales

    Especifica el lugar donde va almacenar los archivos temporales. La configuración predeterminada es almacenar los archivos temporales en el servidor, pero su administrador también establece la variable Temp_Patch en su archivo SS.INI a una carpeta local que acelera operaciones como la visualización de archivos. Por ejemplo:

    Temp_Path = c:\windows\temp

Pida al administrador de VSS que compruebe la siguiente variable en el archivo SRCSAFE.INI:

  • Lock_Mode = Native

    Es el valor predeterminado para esta variable de SRCSAFE.INI. Configurar esta variable de inicialización como Native acelera toda operación de VSS.

    Importante: Sólo el administrado de VSS puede establecer esta variable.

Características que puede desactivar para aumentar el rendimiento

Su administrador de VSS puede deshabilitar cualquiera de estas características para optimizar la velocidad de muchos comandos de VSS:

  • Carpetas centrales

  • Archivos de diario

  • Sistema de seguridad del proyecto

  • Expansión de palabras clave


Realizar una desprotección exclusiva

Vea también

También puede desproteger elementos de forma exclusiva; es decir, desprotegerlos de forma que nadie más pueda desprotegerlos mientras usted tenga el archivo o el proyecto desprotegido.

Hay dos formas de hacerlo. Su administrador de VSS puede establecer una opción administrativa para desactivar desprotecciones múltiples para un proyecto todo el tiempo, o puede usted hacer lo siguiente.

Para realizar una desprotección exclusiva:

  1. Seleccione el archivo o proyecto que desee desproteger.

  2. En el menú SourceSafe, haga clic en Desproteger para mostrar el cuadro de diálogo Desproteger.

    Nota Si no aparece este cuadro de diálogo, necesita mostrarlo mediante la ficha Cuadros de diálogo de comandos del comando Opciones del menú Herramientas.

  3. Haga clic en Avanzadas.

  4. Desactive la casilla de verificación Permitir varias desprotecciones.

  5. Haga clic en Aceptar.

Nota Así se desprotege de manera exclusiva el archivo o proyecto pero sólo sesión a sesión.

Cómo se indica si un archivo está desprotegido de manera exclusiva:

Hay tres formas para indicar si un archivo está desprotegido de manera exclusiva, que incluyen:

  • Un marco rojo alrededor del icono del archivo.

  • La ficha Estado de desprotección del cuadro de diálogo Propiedades de archivo cambia. Se agrega una línea bajo el nombre de archivo que indica "Desprotección exclusiva."

  • En la línea de comandos, el comando SS Status indica el estado:
    Ssus.rc    Charry v572    4/08/98 2:37 (Desprotección exclusiva)


Fijar archivos

Vea también

Puede fijar cualquier archivo.

Para fijar una determinada versión de un archivo:

  1. En el Explorador de VSS, seleccione el archivo que desea fijar.

  2. En el menú Herramientas, haga clic en Mostrar historial para mostrar el cuadro de diálogo Opciones de historial.

  3. Haga clic en Aceptar para mostrar el cuadro de diálogo Historial de archivo.

  4. Seleccione la versión del archivo que desee utilizar y haga clic en Fijar. Junto al archivo fijado aparece un nuevo icono indicando que está fijado.

  5. Haga clic en Cerrar.

Cuando necesite utilizar la versión más reciente del archivo sólo tendrá que liberarlo.


Símbolos de la lista de proyectos

Vea también

Los símbolos que aparecen en la siguiente tabla se utilizan en la lista de proyectos del Explorador de VSS.

Símbolos de la lista de proyectos del Explorador de VSS

Símbolo | Descripción
 | Proyecto
 | Proyecto abierto actualmente
 | Indica que en este proyecto existen subproyectos. Haga clic en el icono para expandir la lista de proyectos.
 | Haga clic para contraer la lista de proyectos.
 | Proyecto escondido
 | Proyecto de sitio Web.


Purgar archivos eliminados

Vea también

La purga quita de forma permanente los archivos y proyectos eliminados de la base de VSS.

Nota Los archivos purgados no pueden recuperarse.

Para purgar un archivo que previamente se ha eliminado:

  1. Seleccione un proyecto del panel de proyectos del Explorador de VSS.

  2. En el menú Archivo, haga clic en Propiedades y después haga clic en la ficha Elementos eliminados.

  3. Seleccione el archivo que desea purgar.

  4. Haga clic en Purgar.

  5. Haga clic en Sí cuando VSS le pregunte si desea continuar.


Recuperar archivos eliminados

Vea también

Para recuperar un archivo

  1. Seleccione del proyecto el archivo que ha eliminado del panel de proyectos del Explorador de VSS.

  2. En el menú Archivo, haga clic en Propiedades y después haga clic en la ficha Elementos eliminados.

  3. Seleccione el archivo que desea recuperar.

  4. Haga clic en Recuperar.


Redireccionar el resultado

Vea también

Por defecto, VSS dirige todos sus resultados a la pantalla. Los usuarios de la línea de comandos pueden utilizar la opción -o para paginar el resultado, que es exactamente lo contrario de lo que se desea en un archivo de proceso por lotes. Sin embargo, también puede utilizar -o para redireccionar el resultado.

Para redireccionar o no mostrar el resultado:

Escriba este comando | Acción resultante
-o- | Sin resultado
-oRESULTS.TXT | Redirecciona todo el resultado al archivo Results.txt. Si el archivo ya existe, el resultado se agrega a él.


Actualizar la vista Listas

Vea también

Mientras esté usando VSS, otras personas pueden cambiar el contenido del proyecto actual. Por ejemplo, pueden desproteger y proteger archivos. Para permanecer actualizado, VSS refresca automáticamente la vista Lista de forma periódica. Puede cambiar la frecuencia de refresco utilizando la sección Lista de Archivos en la ficha Ver del comando Opciones del menú Herramientas.

También puede refrescar la lista manualmente.

Para refrescar la vista Listas manualmente:

  • Desde el menú Ver, haga clic en Actualizar lista de archivos o presione la tecla F5.


Cambiar el nombre a archivos o proyectos

Vea también

VSS le permite modificar el nombre de un archivo y aún así seguirá manteniendo su historial. Si un archivo está compartido por múltiples proyectos y se le cambia el nombre, el nombre cambiará en todos los proyectos que comparten el archivo. Sin embargo, si alguno de los vínculos ha sido destruido por el comando bifurcar, los archivos bifurcados no cambiarán su nombre.

Para cambiar el nombre a un archivo:

  1. En el Explorador de VSS, seleccione el elemento cuyo nombre desea cambiar.

  2. En el menú Archivo, haga clic en Cambiar nombre.

  3. Escriba el nuevo nombre del elemento.

  4. Presiones INTRO cuando haya terminado.


Redimensionar la vista de listas

Vea también

También puede cambiar la cantidad de espacio asignado a la vista Proyecto y a la vista Lista de VSS.

Para cambiar el tamaño de la vista Lista:

  1. Coloque el mouse sobre la barra horizontal situada entre la vista de proyectos y la vista Listas, mantenga quieto el mouse hasta que el cursor se convierta en una flecha con dos puntas.

  2. Mientras mantiene pulsado un botón, arrastre la barra hacia la izquierda o hacia la derecha para cambiar el tamaño de la vista Proyectos/Listas.

También puede cambiar el tamaño del panel Resultados, si aparece.


Resolver conflictos de combinación con combinación visual

Vea también

Cuando hay un conflicto, VSS utiliza su formato de combinación visual, mostrándolo abajo de manera predeterminada. Así ocurre independientemente de si inicia usted la combinación o la inicia VSS.

El cuadro de diálogo Combinación visual

  • Los dos paneles superiores representan las dos versiones que se están combinando. En el cuadro de diálogo de ejemplo que se muestra más arriba, la combinación se está realizando automáticamente, como resultado de desprotecciones múltiples; por tanto, el archivo de la izquierda está en VSS, y el de la derecha está en su disco duro. En el caso de "Combinación de bifurcaciones", las dos versiones son de proyectos diferentes.

  • El panel inferior representa el resultado de la combinación. Comienza con todos los cambios sin conflicto ya hechos, y cambia dinámicamente conforme trabaja. Si está combinando bifurcaciones, el panel inferior contiene el archivo original desde el que se creó antes la bifurcación.

  • Los tres paneles se desplazan verticalmente juntos, para extenderse tanto como sea posible. (Bajo algunas circunstancias, VSS puede perder temporalmente la sincronización.) Los paneles superiores también se desplazan juntos horizontalmente; la posición horizontal del panel inferior es independiente.

  • Los colores y fuentes se controlan mediante las mismas opciones que se utilizan para la comprobación de diferencias. El estilo de fuente (negrita, cursiva, etc.) no se puede cambiar.

  • El panel inferior es modificable directamente, pero los paneles superiores no.

  • También puede copiar/copias desde los dos paneles superiores y pegar en el panel inferior.

  • Use el menú contextual para resolver conflictos.


Resolver conflictos de combinación sin combinación visual

Vea también

Si elige no usar la combinación visual, y desea personalizar la manera en que VSS presenta los conflictos de combinación en la combinación manual, una forma es configurar la variable de inicialización Mark_Merges de su archivo SS.INI. Por ejemplo, en el archivo escriba:

Mark_Merges = yes

Usar la combinación visual significa que no tendrá que preocuparse de los marcadores de conflictos. pero, si usa Mark_Merges, VSS:

  • Marca todos los cambios, incluso si no son conflictos. Esto le da la oportunidad de ver y aprobar todos los cambios. Por supuesto, debe quitar todos los marcadores de cambio antes de proteger el archivo o compilar el código.

  • Le muestra las líneas originales y también las líneas modificadas.

Lo siguiente es un ejemplo del aspecto que podrían tener los marcadores de conflictos de VSS.

<<<<<< Versión de SourceSafe
if (a <= 5)
|||||| Versión original
if (a < 5)
======
if (a < 6)
>>>>>> Versión local

El formato es similar al marcador de conflicto de combinación manual, excepto en que VSS muestra el original (versión sin desproteger) entre las versiones maestra y local, que pueden serle útiles para determinar la mejor manera de limpiar el archivo.

Establecer las opciones de combinación en los archivos de inicialización

Puede establecer las dos variables de inicialización siguientes para cambiar las extensiones de los archivos utilizados por el proceso de combinación.

Backup_Ext = .ORG
Merge_Ext = .MRG

Backup_Ext controla qué ocurre con su archivo original (previo a la combinación) después de que la combinación tenga lugar. De manera predeterminada, VSS elimina el archivo si no hay conflictos; cambia el nombre del archivo .org si hay algún conflicto. Sin embargo, cuando se establece esta variable, VSS cambia el nombre del archivo, por lo que siempre tendrá una copia de su archivo original. Puede configurarlo con la extensión predeterminada .org, o con una extensión diferente si .org ya se utiliza en su sistema.

Merge_Ext controla la extensión que VSS utiliza para su archivo de combinación temporal. Este archivo siempre se elimina tras completarse el proceso de combinación, la única razón para cambiarlo es cuando la extensión .mrg ya está siendo usada en su sistema.


Botón secundario del mouse (ratón)

Vea también

El Explorador de VSS proporciona otra forma de trabajar con la lista de archivos y la lista de proyectos. Si hace clic en un archivo con el botón secundario del ratón, VSS mostrará un menú de accesos directos a comandos de archivos comunes. Si hace clic en un proyecto con el botón secundario del ratón, VSS mostrará un menú que contiene los comandos que actúan sobre proyectos.

Al hacer clic con el botón secundario del ratón y arrastrar elementos desde el explorador de Windows hasta VSS aparece una lista de opciones, que incluye Agregar archivo(s), Proteger, Deshacer desprotección, y Cancelar.

Nota No puede arrastrar elementos desde una copia a otra de VSS a menos que tenga la misma base de datos VSS abierta en ambas copias.


Volver a la versión anterior de un archivo

Vea también

Cuidado Cuando deshace un archivo se pierden todos los cambios que se han realizado en él después de la versión a la que se vuelve. Por ejemplo, si hace clic en la versión 5 y después elige Deshacer, se perderán todos los cambios realizados a partir de la versión 5.

Para deshacer un archivo:

  1. Seleccione el archivo en el Explorador de VSS.

  2. En el menú Herramientas, haga clic en Mostrar historial para mostrar el cuadro de diálogo Opciones de historial.

  3. Haga clic en Aceptar para mostrar el cuadro de diálogo Historial de archivo.

  4. Seleccione una versión anterior del archivo y haga clic en Deshacer.


Búsqueda por cadena

Vea también

Las cadenas de búsqueda pueden tener hasta 63 caracteres.

Para buscar por una cadena de texto:

  1. En el menú Herramientas, haga clic en Buscar en archivos para mostrar el cuadro de diálogo Buscar.

  2. Escriba la cadena de texto que esta buscando.

    Nota Si utiliza un asterisco en su cadena de texto como parte de una búsqueda con caracteres comodín, seleccione la casilla de verificación, Usar expresiones normales. Si utiliza un asterisco como un carácter normal, desactive la casilla Usar expresiones normales.

  3. Si quiere que la búsqueda distinga entre mayúsculas y minúsculas, seleccione la casilla de verificación Coincidir mayúsculas y minúsculas.

  4. Haga clic en Aceptar. VSS comenzará la búsqueda.


Búsqueda por archivos desprotegidos

Vea también

Nota Permanecerá en modo de búsqueda hasta que la cancele de forma explícita.

Para realizar una búsqueda por archivos desprotegidos:

  1. En el menú Ver, haga clic en Buscar por estado para mostrar el cuadro de diálogo Buscar por estado.

  2. Para mostrar los archivos desprotegidos para un determinado usuario, haga clic en Mostrar archivos desprotegidos por y seleccione luego uno de los usuarios de la lista desplegable.

  3. Para realizar una búsqueda global, haga clic en Buscar en todos los proyectos.

  4. Haga clic en Aceptar para iniciar la búsqueda.


Buscar con un carácter comodín

Vea también

Las cadenas de búsqueda pueden tener hasta 63 caracteres.

Nota Permanecerá en modo de búsqueda hasta que la cancele de forma explícita.

Para buscar con un nombre con comodines:

  1. En el menú Ver, haga clic en Búsqueda por comodín para mostrar el cuadro de diálogo Buscar por comodín.

  2. En el cuadro Comodín, escriba la parte del nombre de archivo que conoce, utilizando un asterisco (*) para las partes que desconoce.

    Por ejemplo, si busca un archivo que cree que se llama ProyectoDeHoy, pero no recuerda el nombre completo, escriba *Hoy.*, como búsqueda con comodines. VSS identificará todos los archivos que contengan la palabra Hoy, ayudándole a restringir la búsqueda.

    También puede ejecutar búsquedas utilizando máscaras múltiples, separando cada una con un punto y como, como *.exe; ?.dll; !ga*.

  3. Seleccione un área de búsqueda.

  4. Haga clic en Aceptar para iniciar la búsqueda.


Configurar una carpeta de trabajo en el archivo SS.INI

Vea también

Cuando se guarda una carpeta de trabajo como carpeta predeterminada utilizando la casilla de verificación Guardar como predeterminada del cuadro de diálogo Establecer carpeta de trabajo, VSS guarda esa información en su archivo SS.INI. A continuación hay un ejemplo del que podría ser su aspecto.

 [$/Spelling/American]
Dir (PC) = C:\DEV\SPELL\ENGLISH

La primera línea es un encabezado de proyecto, que indica que las variables por debajo del encabezado se aplican al proyecto especificado. La segunda línea utiliza la variable de inicialización Dir para especificar su carpeta de trabajo. El identificador de plataforma entre paréntesis indica que el valor es específico de la máquina; si estuviera trabajando en el mismo proyecto en un equipo Macintosh, querría especificar otra carpeta de trabajo distinta o la sintaxis de la ruta de acceso a su carpeta.

Puede configurar usted mismo estas variables en su archivo SS.INI, aunque suele ser más sencillo permitir que VSS lo haga por usted.


Compartir y bifurcar un archivo en una sola operación

Vea también

Compartir un archivo significa que existe por igual en todos los proyectos para los que está compartido. Al bifurcar un archivo se rompe el vínculo compartido, haciendo que el archivo de ese proyecto sea independiente de todos los demás proyectos.

Nota Para ver los proyectos que comparten un archivo, haga clic en la ficha Vínculos del comando Propiedades en el menú Archivo. Para ver la historia de bifurcación de un archivo, haga clic en la ficha Rutas del comando Propiedades del menú Archivo.

Para bifurcar y compartir un archivo en una sola operación:

  1. En el Explorador de VSS, seleccione el proyecto en el que quiere bifurcar/compartir un archivo.

  2. En el menú SourceSafe, haga clic en Compartir para mostrar el cuadro de diálogo Compartir.

  3. En la lista Archivo a compartir, seleccione e l archivo que desea compartir. Si el archivo que desea compartir no aparece en la lista, seleccione el proyecto que contiene el archivo en la lista Proyectos.

  4. Seleccione la casilla de verificación Bifurcar después de compartir.

  5. Haga clic en Compartir para mostrar el cuadro de diálogo Compartir archivo.

  6. En el cuadro Comentario, escriba un comentario que describa la bifurcación/comparición, si lo desea.

  7. Haga clic en Aceptar para cerrar el cuadro de diálogo Compartir archivo.

  8. Haga clic en Cerrar para cerrar el cuadro de diálogo Compartir.


Compartir, bifurcar y fijar para crear proyectos de Service Pack (Corrección de errores)

Si es necesario reparar un error una fez que un proyecto ha sido etiquetado y se ha continuado con su desarrollo, utilice el siguiente escenario de archivos fijados, compartidos y bifurcados. Así utilizará my poco espacio en el disco duro.

Para compartir, fijar y bifurcar un proyecto:

  1. En la unidad dirigida a la versión 2.0, desarrolle y compruebe su proyecto (por ejemplo, $/Application).

  2. Etiquete el proyecto como "Versión 2.0."

  3. Comience a modificar los archivos del proyecto en la unidad dirigida a la versión 3.0 del proyecto, en la que se introducirán nuevas características.

  4. Si se da cuenta de que es necesaria una versión intermedia 2.1 para corregir errores, seleccione el proyecto.

  5. en el menú Herramientas, haga clic en Mostrar historial para mostrar el cuadro de diálogo Opciones de historial de proyecto.

  6. Seleccione el cuadro Incluir etiquetas.

  7. Haga clic en Aceptar para mostrar el cuadro de diálogo Historial del proyecto.

  8. Seleccione la etiqueta de versión "Versión 2.0."

  9. Haga clic en Compartir para mostrar el cuadro de diálogo Compartir desde.

  10. Seleccione el proyecto que quiere que sea el primario respecto al proyecto recién creado. Suele ser el proyecto $/. Asegúrese también de que no está activada la casilla de verificación Bifurcar después de compartir.

  11. Haga clic Aceptar para mostrar el cuadro de diálogo Compartir.

  12. Asigne un Nuevo nombre al proyecto (por ejemplo, $/Application V 2.1).

  13. Si el proyecto tiene subproyectos, seleccione Recursivo.

  14. Si es necesario, agrega comentarios en el cuadro Comentarios y luego haga clic en Aceptar.

  15. Haga clic en Cerrar para salir del cuadro de diálogo Historial del proyecto.

  16. Seleccione el proyecto que acaba de crear (por ejemplo, $/Application V 2.1). Todos los archivos de este proyecto deberían estar fijados.

  17. Seleccione sólo aquellos archivos que haya que modificar para solucionar los errores, luego, bifurque los archivos. Vea Bifurcar archivos compartidos para obtener más información. Deje fijado cualquier archivo que no haya que modificar.

Más adelante podrá combinar con el proyecto de la versión 3.0 los cambios realizados para reparar los errores.


Compartir archivos

Vea también

Los proyectos de VSS son análogos en muchos sentidos a las carpetas del sistema operativo. Sin embargo, mientras que en un sistema operativo cada archivo existe únicamente en una carpeta, un archivo de VSS puede existir simultáneamente en varios proyectos diferentes.

En VSS, puede compartir archivos. Dentro de la base de datos de VSS sólo hay una copia, la copia maestra, del archivo; cada proyecto al que pertenece el archivo tiene simplemente un puntero a ella. Cuando cambia el archivo en algún proyecto, VSS lo actualiza inmediatamente en todos los proyectos que lo comparten.

Ejemplo

Cuando agrega un archivo llamado test al proyecto A y al proyecto B, ha agregado dos archivos desconectados con el mismo nombre. Cuando agrega el archivo a uno de los proyectos y lo comparte con el otro proyecto, los dos proyectos están vinculados al mismo archivo.

El archivo compartido existe en todos los proyectos en los cuales se comparte; es decir, cada proyecto en el que está compartido el archivo tiene un puntero igual a la copia maestra del archivo.

Nota Es importante entender qué ocurre cuando se ejecutan los comandos Destruir y Purgar sobre archivos compartidos.

Si un archivo está compartido por múltiples proyectos, destruirlo o purgarlo en un proyecto no lo elimina de la base de datos de VSS y, por tanto, no libera espacio en disco.

Para obtener más información acerca de cómo compartir archivos, consulte:

  • Cómo compartir archivos


Ordenar la vista de listas

Vea también

Para ordenar la vista Listas del Explorador de VSS:

  • Haga clic en cualquier encabezado de la lista. Por ejemplo, haga clic en Nombre para ordenar la lista por el nombre o haga clic en Usuario para ordenar la lista por el usuario.

  • Vuelva a hacer clic en el mismo encabezado para invertir la ordenación.


Utilidades de otras compañías para mejorar la accesibilidad

Hay disponibles una gran variedad de productos hardware y software de otras compañías para hacer más fácil el uso de computadoras personales. Entre los diferentes tipos de productos disponibles para los sistemas operativos MS-DOS, Windows y Windows NT están:

  • Programas que amplían o alteran el color de la información de la pantalla para personas con deficiencias visuales.

  • Programas que describen la información de la pantalla en Braille o con voz sintetizada para personas invidentes o que tengan dificultades para leer.

  • Utilidades hardware y software que modifican el comportamiento del mouse y el teclado.

  • Programas que permiten a las personas "escribir" usando un mouse o su voz.

  • Software de predicción de palabras o frases que permite a la gente escribir más rápidamente con menos presiones de teclas.

  • Dispositivos de entrada alternativos, como conmutadores sencillos o dispositivos de soplado y aspirado para personas que no puedan usar un mouse o un teclado.

Para aprender más sobre esos productos, consulte el tema "Obtener más información".


Botones de comando de la barra de herramientas

Vea también

Los botones de comando que aparecen en la siguiente tabla se utilizan en la barra de herramientas del Explorador de VSS. Puede agregar o quitar cualquiera de estos botones de comando utilizando el comando Personalizar barra de herramientas del menú Herramientas.

Botones de comando de la barra de herramientas del Explorador de VSS

Botón | Descripción
 | Separa los botones de comando
 | Buscar
 | Combinar archivos bifurcados
 | Ver vínculos
 | Ver rutas
 | Cambiar nombre de archivo o proyecto
 | Mover
 | Cambiar fuente
 | Crear un nuevo proyecto
 | Agregar archivos
 | Etiquetar una versión
 | Eliminar
 | Obtener la última versión
 | Desproteger
 | Proteger
 | Deshacer desprotección
 | Compartir
 | Bifurcar
 | Ver
 | Editar
 | Ver diferencias
 | Propiedades
 | Historial
 | Encontrar
 | Establecer carpeta de trabajo
 | Refrescar
 | Ayudar


Deshacer Desproteger

Vea también

Para deshacer una desprotección:

  1. En el Explorador de VSS, haga clic en el elemento o los elementos que desee utilizar.

  2. En el menú SourceSafe, haga clic en Deshacer desprotección para mostrar el cuadro de diálogo Deshacer desprotección.

  3. Haga clic en Aceptar.

Advertencia Si elige el comando Deshacer desprotección, perderá todos los cambios que haya realizado en la copia local de su archivo o proyecto.


Liberar archivos

Vea también

Para liberar un archivo:

  1. En el Explorador de VSS, seleccione el archivo que desea liberar.

    Nota VSS muestra un icono junto a los archivos que están fijados.

  2. En el menú Herramientas, haga clic en Mostrar historial para mostrar el cuadro de diálogo Historial de archivo.

  3. Seleccione la versión fijada y haga clic en Liberar.

  4. Haga clic en Cerrar.

VSS libera el archivo de forma que la versión más reciente sea la versión que se utilice en el proyecto en ese momento.


Utilizar opciones y comandos de la línea de comandos

Vea también

A continuación hay una lista y una descripción general de todos los comandos de la línea de comandos.

Para obtener más información acerca de la utilización de los comandos, vea Cómo utilizar la sintaxis de la línea de comandos.

Importante No incluya espacios entre una opción y el valor sobre el cual se aplica. Por ejemplo, el siguiente comando produce un mensaje de error:

ss view readme.txt -v 2

Comando | Acción
Add | Agrega un archivo a la base de datos VSS.
Branch | Permite el desarrollo paralelo de dos versiones de un archivo.
Checkin | Protege un archivo en la base de datos VSS.
Checkout | Desprotege un archivo en su carpeta de trabajo.
Cloak | Esconde un proyecto de VSS.
Comment | Introduce un comentario en la base de datos VSS.
CP | Establece la ruta de proyecto actual.
Create | Crea un nuevo subproyecto.
Decloak | Muestra un proyecto de VSS.
Deploy | Distribuye a un servidor un proyecto Web o un archivo.
Destroy | Destruye permanentemente un archivo o un proyecto.
Diff | Muestra las diferencias entre la copia maestra y la copia local de un archivo.
Dir | Muestra una lista con el contenido del proyecto actual o de un proyecto especificado.
FileType | Muestra el tipo (de texto o binario) de un archivo.
Find | Muestra todas las instancias de una cadena especificada en uno o más archivos.
Get | Obtiene una copia de sólo lectura del archivo o archivos especificados.
Help | Muestra ayuda acerca de la utilización de VSS o de un comando específico.
History | Muestra el historial de un archivo o un proyecto de VSS.
Label | Asigna una etiqueta a la versión especificada o a la versión actual de un archivo o un proyecto.
Links | Muestra los proyectos que comparten un archivo especificado.
Locate | Busca en los proyectos de VSS nombres de archivo o de proyecto.
Merge | Copia todos los cambios realizados en una bifurcación a otra bifurcación.
Move | Cambia la ubicación de un subproyecto desde un proyecto primario a otro.
Password | Establece la contraseña para el usuario actual.
Paths | Muestra todos los vínculos compartidos que se han bifurcado.
Pin | Hace que una versión anterior de un archivo se comporte en el proyecto actual como si fuera la versión más reciente.
Project | Muestra la ruta del proyecto actual.
Properties | Muestra información básica acerca de un archivo o un proyecto de VSS.
Purge | Quita de forma permanente los archivos y proyectos previamente eliminados de la base de VSS.
Recover | Recupera los archivos y proyectos que se han eliminado.
Remove | Nombre de comando alternativo para Delete.
Rename | Cambia el nombre de un archivo o un proyecto.
Rollback | Deshace todos los cambios realizados desde una versión anterior de un archivo.
Share | Convierte el archivo o proyecto especificado en un miembro del proyecto actual.
Status | Muestra información de desprotección sobre archivos.
UndoCheckout | Deshace la desprotección de un archivo.
Unpin | Deshace una operación Pin.
View | Muestra el texto de un archivo.
Whoami | Muestra un nombre de usuario. Actual de VSS.
Workfold | Establece la carpeta de trabajo.

La siguiente lista contiene un conjunto general de opciones que son aplicables a muchos comandos. Las opciones aparecen en mayúsculas, pero también pueden utilizarse en minúsculas.

Opción | Descripción | Comando(s)
-?, -H | Proporciona ayuda sobre un comando en lugar de ejecutarlo. | Todos
-C[-] | Utiliza un comentario para todos los elementos especificados. Para no utilizar comentarios, escriba un punto detrás de la C. | Add, Branch, Checkin, Checkout, Comment, Create, Label, Merge, Rollback, y Share
-G | Establece las opciones para la copia local. | Check Out, Deploy, Get, Recover, Rollback, Share, y Undo Check Out
-I- | no pide entradas bajo ninguna circunstancia. | Todos
-N | Utilizar el modo de nombres de archivos largos o cortos ( sólo Windows NT y Windows 95). | Todos
-O[-] | Redirige o pagina el resultado del comando. Para eliminar el resultado, escriba un guión después de la O. | Todos excepto CP, Move, Password, Pin, Unpin y Whoami
-R | Ejecuta un comando de forma recursiva. | Add, Checkin, Checkout, Deploy, Diff, Dir, Filetype, Find, Get, History, Properties, Share, Status y Undo Check Out
-S | Activa la característica Smartmode, ejecutando diferentes acciones dependiendo de cada comando. | Create, Delete, Destroy, Recover y Rename
-V | Opera sobre una versión específica de un elemento. | Checkout, Comment, Deploy, Dir, Diff, Find, Get, History, Label, Pin, Rollback, Share y View
-W[-] | Hace que los archivos locales sean de sólo lectura o de lectura y escritura. Para anular la variable y hacer que un archivo sea de sólo lectura para una instancia del comando, escriba un guión después de la W. | Add, Checkin project, Deploy Get, Pin, Recover, Rollback, Share, Undocheckout y Unpin
-Y | Especificar el nombre y la contraseña de usuario. Se utiliza con todos los comandos. | Todos


Utilizar sintaxis de la línea de comandos

Vea también

Todos los comandos de VSS que se introducen desde la línea de comandos deben comenzar por ss.

La sintaxis de los comandos VSS es la siguiente:

ss Comando [elemento(s)] [opcione(s)]

Elementos

Un elemento puede ser un proyecto o un archivo. La naturaleza de un elemento dependerá del comando. Para el comando Get, cada elemento debe ser un proyecto o archivo de VSS. Para el comando Add, cada elemento debe ser un archivo o una carpeta del sistema operativo.

Opciones

Las opciones son parámetros que se utilizan para modificar la acción de comando y están formados por un guión ( - ), una letra y un valor. El valor debe ir directamente detrás de la letra de opción, sin dejar espacios entre ambos. Por ejemplo:

ss Get hello.c -v22

En casi todos los casos en los que se puede especificar un elemento sobre el que actuar, también se pueden especificar múltiples elementos. Por ejemplo, cualquiera de las siguientes formas de ejecutar el comando Get es válida:

ss Get "mi archivo.doc"
ss Get hello.c hello.h test.h proyecto
ss Get *.c *.h proyecto vínculo
ss Get *.*

La línea de comandos no distingue entre mayúsculas y minúsculas. Cualquier cosa que esté en la línea de comandos puede aparecer en mayúsculas o en minúsculas. Por ejemplo, el segundo de los comandos anteriores se podría haber introducido como:

SS get HELLO.C Hello.H test.h Proyecto

Puede obtener ayuda acerca de cualquier comando de la línea de comandos si introduce:

SS [comando] -?

La siguiente tabla muestra otros comandos que se pueden utilizar desde la línea de comandos:

Comando | Acción
ss dir | Muestra el contenido del proyecto actual.
ss add sort.bas | Agrega el archivo Sort.bas al proyecto actual.
ss checkout reference.doc | Desprotege el archivo Reference.doc.
ss create $/newproj | Crea un nuevo proyecto, $/newproj, directamente bajo el proyecto raíz.
ss cp .. | Cambia el proyecto actual por el proyecto situado un nivel por encima del actual.
ss locate Léame.txt | Ejecuta una búsqueda global para el proyecto que contiene el archivo Léame.txt. Si el archivo está compartido, el resultado muestra todos los proyectos que comparten el archivo.
ss find database Léame.txt | Busca apariciones de la cadena "database" en el archivo Léame.txt.
ss workfold $/Myprj C:\Mystf\Myfld | Establece C:\Mystf\Myfld como directorio de trabajo para el proyecto $/Myprj.

Si desea una lista completa de comandos, consulte Claves y opciones de los comandos de la línea de comandos.


Utilizar la expansión de palabras clave en archivos HTML

Vea también

Nota No utilice palabras clave HTML en archivos que no sean de HTML.

La expansión de palabras clave se refiere a la capacidad de VSS para colocar determinada información en el archivo directamente desde la base de datos VSS. Esto puede ser muy práctico, por ejemplo, si desea colocar la cadena "Modificado por última vez en: date" en sus páginas Web. Para obtener más información, consulte Cómo expandir palabras clave.

Palabras clave HTML de VSS

Las palabras clave HTML sin idénticas a las palabras clave tradicionales de VSS, con la única excepción de que incluyen un signo de dólar delante de ellas. Por ejemplo, $$JustDate $ en lugar de $JustDate $.

Nota Las palabras clave distinguen entre mayúsculas y minúsculas, así que tenga cuidado y coloque las mayúsculas correctamente.

Por ejemplo, podría colocar lo siguiente en un archivo:

Modificado por última vez el <!--$$JustDate:--!> <!--$-->

Sobre la protección, VSS podría reemplazarlo con:

Modificado por última vez el <!--$$JustDate:-->5/16/96<!--$-->

La próxima vez que proteja el archivo, se sustituirá 16/05/96 por la fecha actual y así sucesivamente. Así se automatiza la actualización de las páginas HTML cada vez que son modificadas.


Utilizar encabezados de proyecto en el archivo SS.INI

Vea también

Los encabezados de proyecto le permiten especificar variables proyecto a proyecto. Como casi todas las variables se pueden colocar bajo un encabezado de proyecto, puede personalizar VSS de forma que los diferentes proyectos actúen de forma muy distinta.

Si una variable aparece en el archivo Ss.ini delante de algún encabezado, se aplica a todos los proyectos. Si una variable se coloca bajo un encabezado de proyecto, se aplica sólo a ese proyecto. Considere el ejemplo siguiente, en el cual la variable Diff_Format se configura tres veces:

;la siguiente variable se aplica a todos los proyectos
Diff_Format = Visual
;las siguientes variables se aplican a $/Reports
 [$/Reports]
Diff_Format = SS
Dir = C:\DEV
;la siguiente variable se aplica a $/Reports/JournalLogs
 [$/Reports/JournalLogs]
Diff_Format = UNIX

El primer valor de Diff_Format aparece delante de todos los encabezados; por tanto, establece el valor predeterminado para todos los proyectos. El segundo valor de Diff_Format anula esta configuración para el proyecto $/Reports. Además, este valor, por defecto es heredado por todos los subproyectos de $/Reports Sin embargo, bajo $/Reports/JournalLogs, la variable está configurada como UNIX de forma explícita; este valor bloquea otras herencias y se aplica tan sólo a JournalLogs y su subproyecto.


Utilizar la línea de comandos después de ejecutar la instalación de un cliente

Mientras trabaja en la línea de comandos, si aparece un mensaje que indica "No se puede encontrar la base de datos VSS (SRCSAFE.INI). Utilice la variable de entorno SSDIR o ejecute netsetup.", configure la variable SSDIR. Así indicará a VSS dónde puede encontrar el archivo SRCSAFE.INI correspondiente a la instalación del servidor VSS con el que se quiere conectar. Puede hacerlo escribiendo el siguiente comando en el símbolo de sistema de MS-DOS:

set ssdir=\\server\share\vss

Donde \\server\share\vss es la carpeta donde se encuentra el archivo srcsafe.ini.

Nota No ponga espacios entre el signo igual y la ubicación de la instalación de servidor de VSS. La cadena siguiente no funciona: set ssdir= \\server\share\vss.


Utilizar la carpeta de trabajo desde la línea de comandos

Vea también

Cuando está trabajando con la interfaz de VSS de línea de comandos, comandos como Obtener y Proteger colocan los archivos en la carpeta en la que se encuentra en ese momento, no en la carpeta de trabajo del proyecto, como lo harían en la interfaz para Windows.

Por defecto, VSS no cambia la carpeta actual cuando ejecuta el comando ss CP (cambiar el proyecto actual); ni tampoco cambia el proyecto si pasa de una carpeta a otra. Es decir, la carpeta de trabajo no tiene, por defecto, ningún efecto sobre la línea de comandos y viceversa.

Para cambiar la carpeta de trabajo de un proyecto:

  • En el símbolo del sistema, escriba ss workfold $/el nombre del proyecto C:\el nombre de la carpeta de trabajo

    Por ejemplo, para cambiar la carpeta de trabajo de un proyecto $/myprj de C:\default a C:\Mystf\Myfld, escriba lo siguiente:

    ss workfold $/Myprj C:\Mystf\Myfld


Ver comentarios de protección

Vea también

Para ver los comentarios de un archivo desprotegido:

  1. En el Explorador de VSS, seleccione el archivo del cual desea ver los comentarios.

  2. En el menú Herramientas, haga clic en Mostrar historial para mostrar el cuadro de diálogo Opciones de historial.

  3. Haga clic en Aceptar para mostrar el cuadro de diálogo Historial de archivo.

  4. Haga clic en Detalles para mostrar el cuadro de diálogo Detalles de historial.

  5. Vea los comentarios en el cuadro Comentario.


Ver información de protección

Vea también

Así se muestra la información acerca de la fecha de protección del archivo.

Para ver la información de protección de un archivo:

  1. En el Explorador de VSS, seleccione el archivo del cual quiere ver la información de protección.

  2. En el menú Herramientas, haga clic en Mostrar historial para mostrar el cuadro de diálogo Opciones de historial.

  3. Haga clic en Aceptar para mostrar el cuadro de diálogo Historial de archivo. VSS muestra la información de protección, como la versión del archivo, el usuario, la fecha de la desprotección y la acción realizada sobre el archivo.


Ver la lista de archivos eliminados

Vea también

Para ver la lista de archivos eliminados de un proyecto:

  1. En el Explorador de VSS, seleccione el proyecto en el que quiere ver la lista de archivos eliminados.

  2. En el menú Archivo, haga clic en Propiedades.

  3. Haga clic en la ficha Elementos eliminados.

  4. Haga clic en Cerrar cuando haya terminado de ver la lista.


Ver los detalles del historial del archivo

Vea también

Para ver los detalles del historial de un archivo:

  1. En el Explorador de VSS, seleccione el archivo del cual desea ver los detalles.

  2. En el menú Herramientas, haga clic en Mostrar historial para mostrar el cuadro de diálogo Opciones de historial.

  3. Haga clic en Aceptar para mostrar el cuadro de diálogo Historial de archivo.

  4. Haga clic en Detalles para mostrar el cuadro de diálogo Detalles de historial.


Ver los vínculos del archivo

Vea también

Los vínculos de archivo son los lugares en los que está compartido un archivo.

Para ver los vínculos de un archivo:

  1. En el Explorador de VSS, seleccione el elemento cuyas propiedades desea ver.

  2. En el menú Archivo, haga clic en Propiedades y después en la ficha Vínculos.

  3. Haga clic en Cerrar cuando haya terminado de ver los vínculos.


Ver las rutas del archivo

Vea también

Una ruta de archivo es el historial de bifurcación de un archivo.

Para ver las rutas de archivo:

  1. En el Explorador de VSS, seleccione el elemento cuyas propiedades desea ver.

  2. En el menú Archivo, haga clic en Propiedades y después en la ficha Ruta de acceso.

  3. Haga clic en Cerrar cuando haya terminado de ver las rutas.


Ver las propiedades del archivo

Vea también

Para ver las propiedades de un archivo:

  1. En el Explorador de VSS, seleccione el elemento cuyas propiedades desea ver.

  2. En el menú Archivo, haga clic en Propiedades y luego en la ficha General si aun no hay ninguna seleccionada.

  3. Haga clic en Cerrar cuando haya terminado de ver las propiedades.


Ver archivos sin una carpeta de trabajo

Vea también

Puede ver la copia maestra de un archivo sin colocar una copia local del archivo en su carpeta de trabajo.

Para ver un archivo:

  1. Haga clic en el elemento que desee en el Explorador de VSS.

  2. En el menú Edición, haga clic en Ver archivo para mostrar el cuadro de diálogo Archivo.

  3. Haga clic en el cuadro Ver la copia de este archivo de SourceSafe, si no está ya seleccionada.

  4. Si desea especificar un editor, haga clic en el botón Avanzadas para poder hacerlo en el último cuadro de texto.

  5. Haga clic en Aceptar.


Ver archivos sin obtenerlos o desprotegerlos

Vea también

Puede ver la copia maestra de un archivo sin colocar una copia local del archivo en su carpeta de trabajo.

Para ver un archivo:

  1. Haga clic en el archivo que desee en el Explorador de VSS.

  2. En el menú Edición, haga clic en Ver archivo.

  3. Si desea especificar un editor, haga clic en el botón Avanzadas.

  4. Haga clic en Aceptar.


Ver el tamaño del archivo seleccionado

Vea también

Para ver el tamaño de un archivo seleccionado:

  1. En el Explorador de VSS, seleccione el elemento cuyo tamaño desea ver.

  2. En el menú Archivo, haga clic en Propiedades y luego en la ficha General si aun no hay ninguna seleccionada.

  3. Haga clic en Cerrar cuando haya terminado de ver el tamaño del archivo.


Deshacer virtual para volver a la versión anterior de un archivo

Vea también

Para ejecutar Deshacer virtual en un archivo:

  1. Seleccione el archivo en el Explorador de VSS.

  2. Desproteja el archivo utilizando el comando Desproteger del menú SourceSafe.

  3. En el menú Herramientas, haga clic en Mostrar historial para mostrar el cuadro de diálogo Opciones de historial.

  4. Haga clic en Aceptar para mostrar el cuadro de diálogo Historial de archivo.

  5. Seleccione una versión anterior del archivo y haga clic en Obtener.

  6. Haga clic en Cerrar para salir del cuadro de diálogo Historial de archivo.

  7. Vuelva a proteger el archivo en el Explorador de VSS utilizando el comando Proteger del menú SourceSafe.